Altium NEXUS Documentation

CloseObject

Modified by Tiffany Cullen on Mar 12, 2019

Parent page: WorkspaceManager Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: ObjectKind=Document

Summary

This command is used to close the active document.

Access

This command can be accessed from the active document's editor by:

  • Choosing the File » Close command, from the main menus.
  • Using the Ctrl+F4 keyboard shortcut.

Use

After launching the command, the active document will be closed. If any changes have been made to the document since the last save, you will be prompted to save these changes first.

Tips

  1. If the document is a free document, its entry will be removed from the Projects panel upon closure.
  2. The active document can also be closed using the corresponding command from its document tab - right-click on the tab to access a context menu of commands.


Applied Parameters: ObjectKind=ProjectAndDocuments

Summary

This command is used to close the active project. A project is currently active when one of its associated design documents is active in the main design window.

Access

This command is accessed from the active document's editor by choosing the Project » Close Project command, from the main menus.

Use

First, ensure that one of the documents associated with the project you wish to close, is the active document in the main design window.

After launching the command, the active project will be closed. If changes have been made to only one of the project's associated open design documents, a dialog will appear and you will be prompted to save these changes first. If two or more associated open documents have been changed since the last save, the Confirm Save for Modified Documents dialog will appear, from where you can control which of the documents (if any) you want to save before the project is closed.


Applied Parameters: ObjectKind=ProjectDocuments

Summary

This command is used to close all currently open documents associated with the active project. A project is currently active when one of its associated design documents is active in the main design window.

Access

This command is accessed from the active document's editor by choosing the Project » Close Project Documents command, from the main menus.

Use

First, ensure that one of the documents associated with the project whose documents you wish to close, is the active document in the main design window.

After launching the command, all open design documents associated with the active project will be closed. If changes have been made to only one design document, a dialog will appear and you will be prompted to save these changes first. If two or more documents have been changed since the last save, the Confirm Save for Modified Documents dialog will appear, from where you can control which of the documents (if any) you want to save before they are closed.


Applied Parameters: ObjectKind=FocusedDocument

Summary

This command is used to close the focused document in the Projects panel.

Access

This command is accessed from the Projects panel by right-clicking on the entry for the required document and choosing the Close command, from the context menu.

The command will only be available provided the focused document is actually open.

Use

First, ensure that the document you wish to close is the focused document in the Projects panel.

After launching the command, the focused document will be closed. If any changes have been made to the document since the last save, you will be prompted to save these changes first.

Tips

  1. If the document is a free document, its entry will be removed from the Projects panel upon closure.
  2. The focused document can also be closed using the corresponding command from its document tab - right-click on the tab to access a context menu of commands.


Applied Parameters: ObjectKind=FocusedProjectAndDocuments

Summary

This command is used to close the currently focused project in the Projects panel.

Access

This command is accessed from the Projects panel by right-clicking on the entry for the required project and choosing the Close Project command, from the context menu.

Use

First, ensure that the project you wish to close is focused in the Projects panel.

After launching the command, the focused project will be closed. If changes have been made to only one of the project's associated open design documents, a dialog will appear and you will be prompted to save these changes first. If two or more associated open documents have been changed since the last save, the Confirm Save for Modified Documents dialog will appear, from where you can control which of the documents (if any) you want to save before the project is closed.


Applied Parameters: ObjectKind=FocusedCategory

Summary

This command is used to close all open documents within the focused sub-folder in the Projects panel.

Access

This command is accessed from the Projects panel by right-clicking on the entry for the required category (sub-folder) and choosing the Close All command, from the context menu.

The command will only be available provided the focused category contains at least one document that is actually open.

Use

First, ensure that the sub-folder whose documents you wish to close is focused in the Projects panel. Focus is given simply by clicking once on the folder's entry.

After launching the command, all currently open documents residing within the focused sub-folder, or descendant folders therein, will be closed. If changes have been made to only one design document, a dialog will appear and you will be prompted to save these changes first. If two or more documents have been changed since the last save, the Confirm Save for Modified Documents dialog will appear, from where you can control which of the documents (if any) you want to save before they are closed.


Applied Parameters: ObjectKind=FocusedProjectDocuments

Summary

This command is used to close all currently open documents associated with the focused project in the Projects panel.

Access

This command is accessed from the Projects panel by right-clicking on the entry for the required project and choosing the Close Project Documents command, from the context menu.

The command will only be available provided the focused project has at least one document that is actually open.

Use

First, ensure that the project you wish to close all documents for, is focused in the Projects panel.

After launching the command, all open design documents associated with the focused project will be closed. If changes have been made to only one design document, a dialog will appear and you will be prompted to save these changes first. If two or more documents have been changed since the last save, the Confirm Save for Modified Documents dialog will appear, from where you can control which of the documents (if any) you want to save before they are closed.


Applied Parameters: ObjectKind=WorkspaceDocuments

Summary

This command is used to close all currently open documents in the current Design Project Group. All projects that have been opened, will remain opened.

Access

This command is accessed from any editor by choosing the Window » Close Documents command, from the main menus.

Use

After launching the command, all open design documents in the current Design Project Group will be closed - both project-associated and free document types.

If changes have been made to only one design document, a dialog will appear and you will be prompted to save these changes first. If two or more documents have been changed since the last save, the Confirm Save for Modified Documents dialog will appear, from where you can control which of the documents (if any) you want to save before they are closed.

Tips

  1. The current Design Project Group is identified in the Projects panel. Unless a specific Design Project Group is opened, there will always be a default Design Project Group - Project Group 1.DsnWrk - which contains all currently open projects and/or free documents. Although this group exists in terms of carrying out certain Design Project Group-related commands (e.g. opening, closing and compiling), it is initially unsaved and therefore does not exist as an entity on the hard disk.
  2. All document can also be closed using the corresponding command from the right-click context menu of the document tabs area of the main design window.


Applied Parameters: ObjectKind=All

Summary

This command is used to close all currently open documents and projects in the current Design Project Group.

Access

This command can be accessed from any editor by:

  • Choosing the Window » Close All command, from the main menus.
  • Choosing the File » New » Design Project Group command, from the main menus.

Use

After launching the command, all open design documents and projects will be closed.

If changes have been made to only one design document, a dialog will appear and you will be prompted to save these changes first. If two or more documents have been changed since the last save, the Confirm Save for Modified Documents dialog will appear, from where you can control which of the documents (if any) you want to save before they are closed.

Tips

  1. The Projects panel will contain an empty Design Project Group, with the default name Workspace1.DsnWrk. This is ready to accept new or existing projects, added as required. The Design Project Group document itself is initially not saved. In addition, any Items from a managed content server that were previously opened under a direct editing session, but subsequently closed (without discarding or comitting) will appear listed under the <SourceServerName> folder, ready to continue editing should you desire.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。