Altium NEXUS Documentation

ConvertToManagedObject

Modified by Tiffany Cullen on May 14, 2019

Parent page: UnifiedComponent Commands

The following pre-packaged resource, derived from this base command, is available:


Applied Parameters: None

Summary

This command is used to create a Managed Project from an existing non-managed one. Managed Projects target the development stage of the project lifecycle, simplifying the creation and ongoing workflow for version controlled projects. Centralized storage under the control of the server also enables this feature to be a foundation for other collaborative services. Some key benefits to using Managed Projects are:

  • Simplified storage. No need to make decisions about storage locations. Backup and other basic services are taken care of.
  • Foundation for collaborative features.
  • Enforced version control.
  • Beneficiary of a dedicated commenting system.
  • Notifications and status. Document status including local modifications is visible to entire design teams.
  • Concurrent PCB design works without any complex setup.
The beauty of Managed Projects is that they are version controlled by default, and can be collaboratively worked upon without having to worry about shared drives, servers, agreements etc.

Access

This command is accessed by right-clicking over the entry for a non-managed project in the Projects panel, and choosing the Make Project Available on Server command from the context menu.

If the Make Project Available on Server option is not available from the menu, it means that the project is currently under Version Control (in a local or network VCS Design Repository), or has been so in the past.

This can be resolved by creating a 'clean' copy of the project (one not associated with VCS) in another local folder and converting that version to a Managed Project.

  1. Open the project in Altium NEXUS:
    • For a project currently under Version Control, use File » Checkout to open (check out) the project from its VCS repository to a local working folder.
    • For a project that is no longer under Version Control, use File » Open Project to locate and open the project from its local folder.
  2. Use the Project Packager (Project » Project Packager) to create a single zip file of the project, which by default, will be stored in the project's local source directory - typically, a path such as C:\Users\Public\Documents\Altium\Projects\MyProject.
  3. In the operating system, create a local working folder specifically for Managed Projects, for example: C:\Users\Public\Documents\Altium\ManagedProjects.
  4. Move the project's packaged zip file to the new folder (...\ManagedProjects) and extract its contents: right-click - Extract All and rename to suit. The resulting path to the duplicated project folder would therefore be C:\Users\Public\Documents\Altium\ManagedProjects\MyProject.
  5. If the project was previously a Managed Project, open its Project file (*.PrjPcb) in a text editor such as Windows Notepad and delete the ManagedProjectGUID= entry, which can be found under the first [Design] section. Save the edited Project file.
  6. Back in Altium NEXUS, navigate to and open (File » Open Project) the newly duplicated project from its folder – that is, from where the project was unzipped.
  7. Right click on the project file and select the Make Project Available on Server command, which should now be available.

Use

Prior to converting an existing non-managed project, ensure that a Design Repository exists in which to store that project, and all future projects. Design Repositories are centrally managed as part of the server. Such repositories can be created through the local SVN Service - part of the server installation. Alternatively, you can connect to an external repository.

After launching the command, the Make Available on Server dialog will appear. This dialog operates in the following two modes:

  • Simple Mode - determine the project's name, and a description. By default, the name will be that of the original project.
  • Advanced Mode - provides access to the managed Design Repository. Choose from all managed repositories shared with the current user signed in to the server, as defined on the VCS page of the server's browser interface. The repository path and directory therein are shown, the latter of which can be modified as required (by default a folder of the same name as the project will be created within the repository). The path to the local working copy of the project is also reflected.

Once you have defined the properties for the Managed Project as required, click OK. The Add to Version Control dialog will open, with all pertinent files selected for addition. Check all is as required and click OK. Once added, the Projects panel will reflect the fully synchronized state that exists between the files in the repository and the local working copy.

The newly-converted Managed Project will subsequently be available from the PROJECTS page of the server's browser interface.

Tips

  1. The project will initially be shared with the designer who converted it, all Administrators for the server, and publically - all users of the server can view (but not edit unless the owner/admin). To make it accessible to others simply share it, by configuring its permissions. Sharing can be performed directly from within Altium NEXUS, or by navigating to the project and setting Share permissions from the Projects page of the server's browser interface.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

You are reporting an issue with the following selected text
and/or image within the active document:
Altium Designer 無償評価版
Altium Designer 無償評価版
Altium Designerを使用していますか?

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

評価版ライセンスが必要な理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、評価版ライセンスは不要です。

ボタンをクリックして、最新のAltium Designerインストーラをダウンロードしてください。

Altium Designerインストーラをダウンロードする

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

Altium Designerの新規ライセンスのお見積もりをご希望の場合、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerサブスクリプションをご利用中の場合、評価版ライセンスは不要です。

お客様がAltium Designerサブスクリプションの有効なメンバーではない場合、下記のフォームに入力して無償評価版をダウンロードしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Altium Designerを評価する理由を下記から選択してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

無償評価版を使用するには、下記のフォームに入力してください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。

素晴らしいですね。アルティウムではモノづくりに最適なプログラムを提供しています。

Upverterは、コミュニティ主導型の無償プラットフォームで、お客様のような作り手の要求に合わせて設計されています。

試してみる場合、こちらをクリック してください。

弊社の営業担当より詳細情報をご案内しますので、アルティウムジャパン までお問い合わせください。.
Copyright © 2019 Altium Limited

その場合、Altium Designerビューワーの無償ライセンス(有効期間6か月)をダウンロードできます。

下記のフォームに入力してライセンスをリクエストしてください。

プライバシーポリシーに同意の上、[ダウンロード]をクリックしてください。ご登録いただきましたメールアドレスにメールマガジンが送信されます。メール配信の停止は、メール内の​通知設定​​でお手続きいただけます。