Altium NEXUS Documentation

Управление проектами из Altium NEXUS

Последнее изменение: Pavel Demidov; 18.06.2020

Главная страница: Управляемые проекты

В этом документе рассмотрена работа с управляемыми проектами в Altium NEXUS, в том числе:

  • Создание проекта – непосредственное создание или преобразование существующего неуправляемого проекта для доступа к нему онлайн.
  • Публикация проекта – изменение прав доступа к проекту, чтобы нужные пользователи могли видеть проект и работать над ним.
  • Открытие проекта – для возможности работать над ним.
  • Клонирование проекта – для быстрого получения идентичной копии проекта без необходимости создания проекта с нуля, если следующий проект должен быть очень похожим на предыдущий.

Создание нового проекта

Существует два способа создания управляемого проекта из Altium NEXUS:

  • Создание нового управляемого проекта через диалоговое окно Create Project.
  • Преобразование существующего неуправляемого проекта (обычного проекта или проекта, находящегося под управлением системы контроля версий) для доступа к нему в Workspace – по сути, "регистрация" проекта в Workspace и создание его зеркальной копии.

В следующих разделах эти два способа создания проекта рассмотрены подробнее.

Через диалоговое окно Create Project

Новый управляемый проект может быть создан в Altium NEXUS с помощью диалогового окна Create Project (File » New » Project).

Задание настроек в диалоговом окне Create Project для создания нового управляемого проекта из Altium NEXUS. Обратите внимание, что опции Advanced будут заданы соответствующим образом по умолчанию.

  1. В списке Locations выберите запись вашего Workspace (будет отображено его название). Вы должны быть подключены к Workspace, чтобы увидеть его в списке. Это будет целевой сервер, в котором будет хранится новый управляемый проект.
  2. В списке Project Type выберите тип проекта, который вы хотите создать, и выберите нужный шаблон из доступных. Если есть шаблоны проектов, созданные и выпущенные в Workspace, только они будут отображены как доступные для выбора шаблоны.
  3. Введите название проекта (Project Name) и опциональное описание (Description).

    Название проекта должно начинаться с A-Z, a-z или 0-9, и оно может содержать эти символы. Допустимы подчеркивания, дефисы и пробелы, но пробелы могут быть только в середине имени (пробелы в начале и в конце будут игнорироваться). Вы не можете использовать следующие слова: AUX, COM1-COM9, LPT1-LPT9, CON, NUL и PRN. Кроме того, имя не может содержать следующие символы: \ . / ? % * : | " < >.

Помимо этого, диалоговое окно Create Project включает в себя следующие опции:

  • Включите опцию Enable Formal Version Control (включена по умолчанию) для применения к проекту всех возможностей контроля версий, таких как ведение ревизий и расширенные возможности публикации. Когда эта опция отключена, проект будет просто сохранен в Workspace для базового общего доступа к нему. Подробнее.
  • Нажмите Advanced, чтобы указать пути к папкам.

    • Используйте поле Folder, чтобы указать, в какой папке в структуре Workspace должен быть создан проект. Путь по умолчанию для новых проектов указан на странице Admin - Settings - Projects веб-интерфейса Workspace (по умолчанию это путь Projects\<НазваниеПроекта>). Нажмите кнопку для выбора другой серверной папки, если это необходимо.
    • Используйте поле Local Storage, чтобы указать где на жестком диске будет создан проект перед его фиксацией в центральном проектном репозитории. Путь по умолчанию задан на странице System - Default Locations диалогового окна Preferences. Нажмите кнопку для выбора другой папки, если это необходимо. Это "рабочая" папка проекта и локальный Git-репозиторий, в который проект будет фиксироваться. В конечном итоге (или во время фиксации) проект передается в центральный проектный репозиторий в Workspace (Versioned Storage), который является удаленным Git-репозиторием.
  • Используйте область списка Parameters для добавления или удаления пар Name/Value (Имя/Значение) пользовательских параметров, связанных с проектом, которые будут хранится в Workspace. Используйте кнопку для добавления в список пары Имя-Значение нового параметра. Эти параметры управляемого проекта хранятся в Workspace с новым проектом, и их можно изменить в Workspace. В свою очередь, проектные параметры хранятся в файле проекта (*.PrjPcb), и их можно изменить в Altium NEXUS. Параметры обоих типов могут использоваться в Altium NEXUS в качестве специальных строк в Altium NEXUS – откройте панель Properties, когда размещенный объект Text String выделен в рабочей области. Все заданные для проекта параметры также можно просмотреть на вкладках Parameters и Server Parameters диалогового окна Project Options (Project » Project Options).

Когда настройки проекта заданы нужным образом, нажмите кнопку . Структура нового проекта будет создана в указанных локальной и серверной (в Workspace) папках. Проект будет открыт в панели Projects, где будет показано, что проект и входящие в него документы запланированы на добавление (Scheduled for addition) – это обозначено иконкой синего перекрестия ().

Проект будет открыт в панели Projects под записью целевого Workspace, отражающей название этого Workspace.

Щелкните ПКМ по проекту в панели Projects и выберите команду Commit Project или Version Control » Commit Whole Project. Будет открыто диалоговое окно Commit to Version Control. Выберите файлы, которые вы хотите зафиксировать в проектном репозитории Versioned Storage в Workspace и нажмите кнопку . После добавления файлов, в панели Projects будет отражено состояние полной синхронизации между файлами в удаленном репозитории (в Workspace) и файлами в локальном репозитории (рабочей копией), что обозначено соответствующими иконками .

Фиксация и передача нового проекта в проектный репозиторий Versioned Storage в Workspace.

При фиксации проекта Altium NEXUS обнаружит наличие несохраненных файлов и предложит сохранить их.

Кроме того, запись проекта появится на странице Projects веб-интерфейса Workspace.

Изначально проект будет опубликован с правами на редактирование проектировщику, который создал его (владельцу), и всем администраторам Workspace. Для получения более подробной информации о настройке прав доступа к проекту перейдите в раздел Публикация проекта.

Фиксация проекта без передачи

Для тех, кто не знаком с Git-репозиториями, или для тех, кто просто хочет выполнить передачу (Push) локальных проектных изменений в Workspace, использование кнопки в диалоговом окне Commit to Version Control является самым прозрачным и оптимальным подходом.

Однако вы также можете зафиксировать (Commit) изменения в локальном Git-репозитории перед их передачей в удаленный Git-репозиторий (Versioned Storage) в Workspace. Для этого выберите команду Commit, как указано выше, и в диалоговом окне Commit to Version Control выберите Commit из выпадающего меню кнопки . Изменения будут сохранены в локальный Git-репозиторий этого проекта, и в панели Projects будет отражено состояние файлов Ahead of server ().

Пример фиксации нового проекта в локальном Git-репозитории.

Позже эти локально сохраненные файлы могут быть отправлены в удаленный Git-репозиторий в Workspace путем выполнения команды Push. Это можно сделать следующими способами:

  • Щелкните ПКМ по записи проекта в панели Projects и выберите команду Commit Project из контекстного меню либо выберите команду File » Commit Project из главного меню. В диалоговом окне Commit to Version Control нажмите кнопку . Будут выполнена передача файлов в состоянии Ahead of server и фиксация и передача остальных файлов.

  • Щелкните ПКМ по записи проекта в панели Projects (или по определенному файлу) и выберите команду Version Control » Push(n) из контекстного меню. Здесь n отражает количество локальных фиксаций, которые были выполнены (перед сервером).

После передачи, в панели Projects будет отражено состояние полной синхронизации () между файлами в удаленном репозитории (в Workspace) и файлами в локальном репозитории (рабочей копией).

Преобразование существующего проекта для онлайн-доступа

Вы также можете преобразовать существующий неуправляемый проект (обычный проект или проект, находящийся под управлением системы контроля версий) для доступа к нему в Workspace – по сути, "зарегистрировать" проект в Workspace и создать его зеркальную копию. Это позволит вам воспользоваться преимуществами совместной работы, возможности которой доступны в платформе Altium 365, и при этом оставить изначальный проект там, где он есть. Для этого откройте существующий неуправляемый проект как обычно в Altium NEXUS, щелкните ПКМ по его записи в панели Projects и выберите команду Make Project Available Online из контекстного меню. Будет открыто диалоговое окно Make Available Online.

Преобразование существующего проекта для его доступа в Workspace – по сути, "регистрация" проекта в Workspace и создание его зеркальной копии

Используйте диалоговое окно Make Available Online, чтобы изменить название (Name) проекта и добавить его описание (Description). По умолчанию будет задано то же название, что и у изначального проекта.

Включите опцию Enable Formal Version Control, чтобы добавить проект под управление встроенной в Workspace системы контроля версий (Git). Эта опция отключена по умолчанию – в этом случае проект будет просто сохранен в Workspace для базового общего доступа к нему, с возможностью публикации другим пользователям только для просмотра и комментирования, т.е. как бы менее формальная, простая синхронизация (Simple Sync). Рекомендуется включать формальный контроль версий, поскольку в этом случае у вас будет доступ ко всем функциональным возможностям, предлагаемым Workspace и платформой Altium 365.

Если неуправляемый проект уже находится под управлением контроля версий (внешнего проектного репозитория), эта опция будет включена и неактивна, и будет приведен текст, что проект уже находится под управлением системы контроля версий. Это значит, что проект останется под управлением проектного репозитория внешней системы контроля версий и он не будет добавлен во встроенный в Workspace проектный репозиторий системы контроля версий (Git). Будет применена простая синхронизация, но множество сотрудников cмогут продолжить работу над проектом, поскольку он находится под управлением системы контроля версий.
Обратите внимание, что если опция Enable Formal Version Control отключена, т.е. будет использоваться неформальная простая синхронизация (Simple Sync) для неуправляемого проекта (который не находится под управлением внешней системы контроля версий), проект сможет редактировать только один пользователь – владелец проекта (пользователь, который сделал проект доступным онлайн в Workspace). Преимущество простой синхронизации проявляется, когда вы не хотите, чтобы кто-либо другой мог редактировать ваш проект, но при этом вы хотите использовать возможности Altium 365 для публикации проекта другим пользователям для просмотра и комментирования. Когда опция Enable Formal Version Control включена, то благодаря проектному репозиторию Versioned Storage на основе Git проект может быть опубликован множеству пользователей для редактирования (если они входят в команду Workspace), и при этом доступно использование возможностей глобальной публикации Altium 365 для общего просмотра и комментирования.

Нажмите по ссылке Advanced, чтобы отобразить поле Folder. Это поле используется для определения того, в какой папке в структуре Workspace должна быть создана зеркальная копия проекта. Путь по умолчанию для новых проектов указан на странице Admin - Settings - Projects веб-интерфейса Workspace (по умолчанию это путь Projects\<НазваниеПроекта>). Нажмите кнопку для выбора другой серверной папки, если это необходимо.

Когда свойства зеркального проекта определены в диалоговом окне Make Available Online нужным образом, нажмите OK. Проекты, которые стали доступны онлайн в Workspace, будут отображены в панели Projects в Altium NEXUS следующим образом:

  • Если проект не находится под управлением внешней системы контроля версий и при настройке доступа проекта онлайн опция Enable Formal Version Control была отключена, то этот проект будет отображен только с иконкой . Это означает, что проект зарегистрирован в Workspace, что существует его зеркальная копия и что эти два проекта синхронизированы с использованием методологии простой синхронизации. Файлы, сохраненные локально, автоматически синхронизируются со своими зеркальными копиями в Workspace.

    Для получения информации о различных состояниях, используемых простой синхронизацией, перейдите в раздел Состояния простой синхронизации.
  • Если проект находится под управлением внешней системы контроля версий, то он будет отображен с иконкой , что означает, что проект зарегистрирован в Workspace, что существует его зеркальная копия и что эти два проекта синхронизированы с использованием методологии простой синхронизации. Соответствующие иконки отражают состояние полной синхронизации между внешним проектным репозиторием и локальной рабочей копией. После сохранения и фиксации изменений локальных файлов во внешнем проектном репозитории эти изменения автоматически синхронизируются с зеркальной копией проекта в Workspace.

    Для получения информации о различных состояниях, используемых простой синхронизацией, перейдите в раздел Состояния простой синхронизации.
  • Если проект не находится под управлением внешней системы контроля версий и при настройке доступа проекта онлайн опция Enable Formal Version Control была включена, то проект и его файлы будут зафиксированы и переданы в проектный репозиторий Versioned Storage в Workspace, и в панели Projects с помощью соответствующих иконок будет отражено состояние полной синхронизации между этим внешним проектным репозиторием и локальным (рабочим) репозиторием. Проект будет работать как по-настоящему управляемый проект – не просто "зарегистрированный" в Workspace, а зафиксированный в нем и находящийся под его контролем версий. Изменения, выполненные в проекте, должны быть зафиксированы в репозитории в Workspace.

Зеркальный проект станет доступен на странице Projects веб-интерфейса Workspace.

Зеркальный проект будет изначально опубликован на чтение/запись проектировщику, который создал его (владельцу), и всем администраторам Workspace. Для получения более подробной информации о настройке прав доступа к проекту перейдите в раздел Публикация управляемого проекта.

Состояния простой синхронизации

Когда неуправляемый проект преобразован для доступа к нему онлайн в Workspace с использованием подхода простой синхронизации, а не формального контроля версий Workspace, текущее состояние синхронизации между локальным серверным проектом отображается в панели Projects различными иконками. Далее приведены эти иконки и их значения.

Синхронизирован Локальный проект и зеркальный проект в Workspace синхронизрованы.
Выполнение синхронизации Изменения локального проекта синхронизируются с зеркальным проектом в Workspace. Для локального проекта, который не находится под управлением внешней системы контроля версий, это происходит при сохранении локального файла. Для локального проекта, который находится под управлением внешней системы контроля версий, это происходит при сохранении и фиксации изменений локального файла во внешнем проектном репозитории.
Проект доступен только для чтения Проект был опубликован вам, но у вас есть доступ к нему только на чтение. При использовании методологии простой синхронизации, проект может быть изменен только одним человеком – его владельцем (пользователем, который сделал проект доступным онлайн в Workspace).
Не синхронизирован Изменения были выполнены локально, но они еще не были синхронизированы с зеркальным проектом в Workspace. Это может произойти, например, когда проект открыт на редактирование его владельцем/автором на двух компьютерах (ПК1 и ПК2). На ПК1 Workspace отключен. На ПК2 подключение к Workspace остается и выполняются изменения. При сохранении локальных файлов проект остается несинхронизированным. Если вы попытаетесь закрыть проект на ПК2, будет открыто диалоговое окно Closing unsynchronized projects, предупреждающее вас об этом. Если вы выберите закрытие этого проекта, изменения не будут доступны на ПК1. Чтобы исправить эту ситуацию, отключитесь от Workspace на ПК2 и подключитесь снова. Проект будет синхронизирован с Workspace. Синхронизированные данные будут отражены на ПК1 после его подключения к Workspace.
Конфликт

Существует конфликт между данными локального проекта и данными зеркального проекта в Workspace. Это может произойти, например, если один и тот же проект был открыт его владельцем/автором на редактирование на двух компьютерах (ПК1 и ПК2). На ПК1 проект был открыт, после чего ПК1 был отключен от Workspace. Затем были выполнены изменения и сохранены локальные файлы. Далее на ПК2 был открыт тот же проект, и при подключенном Workspace были выполнены и сохранены изменения. Затем ПК1 был вновь подключен к Workspace. Происходит конфликт, поскольку есть изменения, сохраненные локально на ПК1, но Workspace содержит обновленные данные, появившиеся после внесения изменений на ПК2 и их синхронизации.

Чтобы исправить эту ситуацию, на ПК1 щелкните ПКМ по проекту и выберите команду Resolve Conflicts. Будет открыто диалоговое окно Resolve Conflicts. Вы можете выбрать использование серверных файлов (Use Server files – будут использованы данные из зеркального проекта в Workspace, и локальные изменения будут потеряны) либо использование локальных файлов (Use Local files – будут использованы данные из локального проекта, и они будут синхронизированы с перезаписью текущих данных зеркального проекта в Workspace).

Ограничения при использовании существующего репозитория внешней системы контроля версий

Как упоминалось ранее, неуправляемые проекты могут уже находиться под управлением существующей внешней системы контроля версий (Git, SVN, EPDM и т.д.). Вы можете продолжить использовать это как прежде и сделать проекты доступными в Workspace путем их регистрации в этом Workspace с помощью функции Make Project Available Online.

В этом режиме при каждом внесении изменений в проект и их фиксации в существующем репозитории системы контроля версий, в Workspace будет создаваться зеркальная копия этих проектных данных, и все необходимые процессы будут выполнены как обычно: предварительный просмотр, отслеживание применяемости и т.д. Однако существуют некоторые ограничения, которые следует иметь в виду:

  • Создание нового проекта всё ещё должно происходить по прежнему рабочему процессу, т.е. проект создается вручную во внешней системе контроля версий. Затем проект регистрируется в Workspace, где создается его зеркальная копия (с помощью функции Make Project Available Online).
  • Если были выполнены проектные изменения, но фиксация/передача была выполнена внешним средством, а не через Altium NEXUS, то эти изменения не появится в зеркальной копии проекта в Workspace. Это будет исправлено при следующем повторном открытии проекта в Altium NEXUS, который автоматически синхронизирует локальный проект с его зеркальной версией в Workspace. Если другим пользователем были выполнены какие-либо изменения, то повторно открытые проектные файлы будут отображены как неактуальные (Out Of Date), что можно исправить с помощью команды Update контроля версий.
  • Открытие проекта вторым человеком потребует его доступа к этому репозиторию внешней системы контроля версий.
  • Права доступа потребуют настройки и сопровождения в двух местах: в Workspace и в главном источнике (репозитории Git, SVN и т.п. внешней системы контроля версий).

Работа с GitHub

Использование платформы GitHub в качестве внешней системы контроля версий (VCS) – это распространенный способ хранения и публикации проектов, и его легко интегрировать с Altium 365 Workspace через Altium NEXUS. Как описано выше, существующая внешняя система контроля версий синхронизируется с Altium 365 Workspace, что позволяет использовать преимущества его эффективных возможностей управления данными и совместной работы.

То, как вы сами обычно работаете с GitHub, зависит от практик компании или от средств Git, которые у вас есть под рукой. Как правило, проект создается в локальном репозитории Git, после чего он передается в репозиторий GitHub (удаленный), либо существующий проект клонируется в локальный репозиторий из GitHub. Когда проект находится в локальном репозитории Git, можно открыть проект в Altium NEXUS и сделать его зеркальную копию в Altium 365 Workspace (Make Project Available Online), как описано выше.

Протоколы GitHub

Хотя существует ряд протоколов передачи данных, предлагаемых системой контроля версий Git, на текущий момент Altium NEXUS поддерживает только протокол HTTP/HTTPS для подключений между локальным репозиторием Git и его удаленным главным репозиторием. На практике, применяемый протокол задается URL-префиксом, указанным для подключения к удаленному репозиторию – https://<удаленный репозиторий>, ssh://<удаленный репозиторий>, git://<удаленный репозиторий> и т.п.

GitHub поддерживает как протокол SSH, так и HTTPS, и для подключений рекомендуется использовать URL-адреса HTTPS.

► Для получения более подробной информации перейдите на страницу Which remote URL should I use? (Какой удаленный URL мне следует использовать?) на GitHub.

Протокол HTTPS имеет преимущество безопасного подключения, которое просто в использовании и реализации, в то время как SSH является более сложным для работы (поскольку требует общий ключ, настройки файервола/портов прокси) и, возможно, менее безопасным, и он не обеспечивает удобство аутентификации единого входа (SSO).

Аналогично, протокол подключения GIT не рекомендуется использовать (и он не поддерживается) из-за отсутствия аутентификации и сложности настройки.

Если ваша внешняя система контроля версий подключена с помощью протокола, отличным от HTTPS, таким как SSH-соединение GitHub, это будет задано в репозитории, клонированном из удаленного репозитория. Поскольку этот протокол несовместим с Altium NEXUS, то при попытке интегрировать проект с Altium 365 Workspace будет выдано сообщение об ошибке. Если вы не уверены в протоколе удаленного URL, который используется для локального репозитория Git, это можно проверить с помощью команды git remote - v.

Используйте интерфейс командной строки Git Bash для проверки настройки удаленного URL репозитория.

Репозиторий можно перенастроить для использования другого URL, например, использующего протокол HTTPS, для совместимости с Altium NEXUS с помощью команды git remote set-url <название> <URL>, где префикс URL указывает тип протокола.

Изменение протокола URL подключения к удаленному репозиторию и последующее подтверждение с помощью удаленной команды.

Управление синхронизацией проекта

После того, как неуправляемый проект был преобразован для доступа к нему онлайн, на вкладке General диалогового окна Project Options станут доступны элементы управления его онлайн-доступом и синхронизацией.

Опции и элементы управления, относящиеся к онлайн-доступу к проекту, представлены на вкладке General диалогового окна Project Options.

Используйте опции, доступные в области General этой вкладки, чтобы внести изменения в название и/или описание проекта. Это повлияет только на зеркальную копию проекта в Workspace – название локального проекта не изменится.

В области Online Availability and Synchronization этой вкладки опция Enable Formal Version Control отражает текущий метод онлайн-доступа:

  • Опция включена – проект (и его исходные файлы) хранятся под управлением собственной системы контроля версий Workspace (Git). Этот подход является рекомендуемым, поскольку таким образом у вас будет доступ во всем функциональным возможностям, предлагаемым Workspace и платформой Altium 365.
  • Опция отключена – проектные файлы хранятся в Workspace для базового доступа к ним и для их публикации другим пользователям только для просмотра и комментирования – как бы менее формальная простая синхронизация (Simple Sync).

Используйте эту опцию для переключения между двумя состояниями.

Обратите внимание, что если локальный неуправляемый проект находится под управлением репозитория внешней системы контроля версий, эта опция будет постоянно включена и недоступна для изменения.

Если вы хотите остановить синхронизация между локальным проектом и его управляемой инкарнацией, доступной в Workspace, нажмите кнопку . Будет открыто окно Turn off project synchronization. Нажмите Unlink, затем OK в диалоговом окне Project Options. Локальный проект больше не будет связан с проектом в Workspace.

Это будет отражено в панели Projects после сохранения локального проекта – проект будет отображен под записью активной группы проектов (*.DsnWrk), а не активного Workspace. Сохранение необходимо, поскольку ссылки на проект в Workspace удаляются из файла проекта.

Проект в Workspace останется нетронутым – он не будет удален при этой операции.

Вы можете разорвать связь между локальным проектом и его инкарнацией, доступной в Workspace.

Вы всегда можете сделать неуправляемый проект снова доступным онлайн. На вкладке General диалогового окна Project Options будет представлена кнопка , с помощью которой открывается диалоговое окно Make Available Online. Вернитесь в раздел Преобразование существующего проекта для онлайн-доступа для получения более подробной информации.

Обратите внимание, что если вы сделали локальный проект доступным онлайн после отключения синхронизации, вам может понадобиться изменить название проекта. Поскольку отключение синхронизации не удаляет проект в Workspace, проект с тем же названием и серверной папкой всё ещё может существовать. Если необходимо, чтобы у проекта было то же название, то вы всегда можете удалить предыдущий экземпляр проекта в Workspace.

Локальный неуправляемый проект также может быть преобразован для доступа онлайн к нему в Workspace с вкладки General диалогового окна Project Options.

Публикация управляемого проекта

Связанная страница: Публикация проекта из Altium NEXUS

Если проект является управляемым (доступен в Workspace), вы можете определить, у каких пользователей есть доступ к этому проекту. Это выполняется путем публикации проекта, или точнее, настройкой прав доступа к нему. Помните, что управляемый проект, новый или преобразованный для доступа в Workspace, по умолчанию опубликован следующим пользователям:

  • Владельцу проекта, который, как правило, является проектировщиком, который создал его (или сделал его доступным в Workspace): полные права доступа (на чтение/запись).
  • Роли Administrators: полные права доступа (на чтение/запись).

Элементы управления для публикации проекта из Altium NEXUS находятся в диалоговом окне Share, которое открывается нажатием кнопки в верхней правой части окна приложения.

Убедитесь, что проект, который вы хотите опубликовать, выбран в панели Projects.

Открытие диалогового окна Share – центра управления публикацией проекта из Altium NEXUS.

Поддерживаются следующие уровни публикации из Altium NEXUS:

  • Публикация текущего проекта – динамический проект, находящийся в процессе разработки, который может быть опубликован:

    • Другим членам вашей команды Workspace – для редактирования и/или просмотра. Для публикации на этом уровне необходима как регистрация на AltiumLive, так и активная подписка на лицензии Altium NEXUS. Также необходимо подключение к своему Altium 365 Workspace. Приглашенный член команды может просматривать проект через Altium NEXUS либо через интерфейс платформы Altium 365. Редактирование осуществляется только через Altium NEXUS.
    • Людям вне команды вашего Workspace – только для просмотра и комментирования, по email-приглашению. Для публикации на этом уровне необходима как регистрация на AltiumLive, так и активная подписка на лицензии Altium NEXUS. Также необходимо подключение к своему Altium 365 Workspace. Это позволяет приглашенным заинтересованным лицам просматривать динамический, находящийся в процессе разработки проект из любого веб-браузера, из любой точки мира, без получения доступа ко всем вашим проектным данным на сервере. Когда соответствующие участники вашей команды Workspace вносят изменения в проект, люди извне смогут увидеть эти изменения. Эта функциональность доступна через платформу, но за пределами Altium 365 Workspace, поэтому всё, что необходимо для получения доступа – это регистрация на AltiumLive.
  • Публикация слепка проекта – статичный слепок проекта в определенный момент времени. Может быть опубликован:

    • По ссылке – доступ кого угодно через веб-браузер. Для публикации на этом уровне не нужна ни регистрация на AltiumLive, ни активная подписка на лицензии Altium NEXUS. Получатели общей ссылки используют Altium 365 Viewer для просмотра проекта (но не его комментирования). Для просмотра не нужна регистрация на AltiumLive, ссылка доступна в течение 48 часов.
    • Определенным людям – доступ определенных людей по email-приглашению. Для публикации на этом уровне необходима регистрация на AltiumLive, но не активная подписка на лицензии Altium NEXUS. Получатели открывают слепок проекта в интерфейсе платформы Altium 365 через email-приглашение. Для просмотра нужна регистрация на AltiumLive, но слепок доступен постоянно. Также доступно комментирование проекта.
Для получения более подробной информации о выгрузке слепков проектов через интерфейс платформы Altium 365 Platform и его публикации другим перейдите на страницу Публикация слепков проектов. Для получения более подробной информации о публикации динамических проектов людям вне команды при просмотре проекта в веб-браузере перейдите на страницу Публикация динамических проектов за пределы Workspace.

Открытие управляемого проекта в Altium NEXUS

Для работы над управляемым проектом вы, по сути, извлекаете его в качестве локальной рабочей копии. Это выполняется непосредственно из Altium NEXUS с помощью команды File » Open Project. Будет открыто диалоговое окно Open Project, где вы можете выбрать, какой управляемый проект следует открыть из Workspace (когда Workspace подключен, этот Workspace будет отображен в области Locations с иконкой и названием этого Workspace). Будут отображены только опубликованные для вас проекты (те, к которым у вас есть права доступа).

Открытый проект будет отображен под записью Workspace в панели Projects.

Выберите, какой управляемый проект следует открыть в Altium NEXUS из тех, которые доступны вам.

Вы можете открыть проект по пути извлечения по умолчанию либо использовать выпадающее меню для указания пользовательского пути. Путь извлечения по умолчанию берется из поля Document Path на странице System - Default Locations диалогового окна Preferences.
При просмотре проекта через панель Explorer в Altium NEXUS, которая по умолчанию отображается в режиме Project View, а не Classic View, нажмите кнопку в верхней правой части панели, чтобы открыть проект в Altium NEXUS (добавить его в панель Projects).

Клонирование управляемого проекта

Чтобы клонировать управляемый проекта из Altium NEXUS, щелкните ПКМ по записи проекта в панели Projects и выберите команду Clone из контекстного меню. Используйте диалоговое окно Clone Project, чтобы задать название проекта (Project Name), описание (Description, не будет заполнено автоматически), путь к папке в Workspace (Folder) и путь локального хранения рабочей копии (Local Storage).

Клонирование управляемого проекта из Altium NEXUS.

При просмотре проекта через панель Explorer в Altium NEXUS, которая по умолчанию отображается в режиме Project View, а не Classic View, проект может быть клонирован нажатием кнопки в верхней правой части панели.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.