Storage Manager

Последнее изменение: Pavel Demidov; 09.07.2019

Главная страница: Панели системы и окружения


Панель Storage Manager

Обзор

Панель Storage Manager предоставляет элементы управления для навигации по активному проекту с точки зрения хранения его файлов в Windows. Панель также предоставляет доступ к локальной истории документов, а также контролю версий.

Панель Projects отображает логическую структуру проекта, в то время как панель Storage Manager предоставляет интерфейс для управления файлами.

Доступ к панели

Доступ к панели осуществляется следующими способами:

  • Нажмите кнопку Panels в правой нижней части приложения и выберите Storage Manager.
  • Выберите команду View » Panels » Storage Manager из главного меню.
  • Щелкните ПКМ по файлу схемы или платы в панели Projects и выберите команду Local History » Storage Manager из контекстного меню.

Содержимое и использование

Панель Storage Manager представляет вид папок/файлов документов активного проекта. Вы можете сразу увидеть, какие документы входят в проект и где они сохранены, а также прочие файлы, которые сохранены, но не добавлены явно в проект. В панели приведены документы и пути в активном проекте. Щелкните ПКМ по документу для выполнения задач управления файлом, таких как переименование или удаление, как описано в разделах ниже.

Если активным документом является библиотека на основе базы данных в системе контроля версий (*.SVNDBLib), в панели будет представлена локальная рабочая копия библиотек символов и посадочных мест, извлеченных из подключенного репозитория Subversion. Панель выступает в роли центрального интерфейса для фиксации изменений в репозитории и обновления из него.

Панель Storage Manager может использоваться для следующих задач:

  • Общие функции управления файлами в проекте или в структуре папок активного проекта.
  • Управление библиотеками символов и посадочных мест, которые хранятся в репозитории SVN и связаны и библиотекой SVN Database Library. Панель предоставляет доступ к локальной рабочей директории, в которую извлечена копия библиотек, сохраненных в репозитории. Фиксация изменений в репозитории и получение обновлений из репозитория может быть выполнена только через эту панель.
  • Управление резервными копиями с помощью функции Local History (см. Data Management - Local History).
  • Использование в качестве SVN-совместимого интерфейса для проектов.
  • Выполнение физического или электрического сравнения любых двух версий в локальной истории.

Разделы панели

Панель Storage Manager состоит из трех разделов:

  • Project Folders (Папка проекта)
  • Project Files (Файлы проекта)
  • Time line (Временная шкала)

  • Щелкните ПКМ в разделе Time line и выберите Switch to Classic View, чтобы отобразить разделенный режим для ревизий VCS (VCS Revisions) и локальной истории (Local History).

Чтобы вернуться в режим Time line, щелкните ПКМ и выберите Switch to Combined View.

Раздел Project Folders

В этом разделе представлен вид структуры папок активного проекта. Если активный документ входит в состав проекта или библиотеки SVN Database Library, название этого проекта или библиотеки будет отображено в заголовке этого раздела. Файл проекта приведен в верхней части структуры. Структура соответствует корневой директории со всеми остальными папками и подпапками в ней, которые отображаются ниже иерархии хранения.

Если активный документ в рабочей области входит в состав проекта, эта структура хранения папок проекта останется видимой. Если активный документ является свободным (т.е. не входит в состав проекта), в этом разделе будет отображена только запись этого документа, с корневой директорией, в котором этот документ находится. Прочие подпапки не будут отображаться, даже если они существуют на жестком диске.

Если активным документом является файл библиотеки SVN Database Library, будет отображена структура папок для символов и посадочных мест, извлеченных в локальную рабочую директорию. Эта директория является локальным рабочим пространством, из которого осуществляется фиксация изменений библиотек в подключенном репозитории SVN.

При щелчке мышью по записи, документы, которые содержатся в корневой директории или подпапке, приводятся в разделе Files.

Щелкните ПКМ в разделе Folders, чтобы получить доступ к следующим командам:

  • Refresh (Обновить вид) – обновить содержимое раздела после использования команды Delete или изменений папок через Проводник Windows.
  • Copy (Копировать) – копировать выделенный объект. Это позволяет легко копировать папки между проектами. Если при выборе команды выделена запись самого проекта, будет скопирована полная структура папок.
  • Paste (Вставить) – вставить скопированную ранее папку или директорию проекта в структуру папок активного проекта. Содержимое будет вставлено в папку, которая в данный момент находится в фокусе.
  • Delete (Удалить) – удалить выделенную папку(-и) из структуры папок. Появится диалоговое окно с запросом на подтверждение удаления. Папки будут безвозвратно удалены с жесткого диска. Примечание: запись самого проекта удалить нельзя.
  • Rename (Переименовать) – переименовать выделенную папку или папку в фокусе в группе выделенных папок. Запись папки станет доступна для редактирования. Введите необходимое новое имя. Примечание: запись самого проекта переименовать нельзя.
  • New (Новая) – создать новую папку.

Раздел Files

В этом разделе приведены все документы, которые сохранены в корневой папке или подпапке активного проекта. Для свободного документа, будут отображены все документы, сохраненные в том же месте, что и свободный документ.

Для документа SVN Database Library, в этом разделе приведены все библиотеки символов и посадочных мест в папке, которая в данный момент выделена в разделе Folders. Это не те библиотеки, которые находятся в репозитории, а те, которые были извлечены из репозитория в локальную рабочую папку.

При щелчке мышью по записи в разделе Folders, будет отображено ее содержимое, как показано ниже.

Для каждого документа отображается следующая информация:

  • File (Файл) – имя файла с его расширением.
  • Size (Размер) – размер файла на диске, в байтах.
  • Kind (Тип) – тип файла.
  • Date Modified (Дата изменения) – дата и время последнего сохранения файла.
  • Status (Статус) – текущее состояние документа с точки зрения контроля версий.

Дополнительная информация о документах предоставляется следующим образом (большинство из них относится только к документам, которые входят в состав проекта):

  • Жирный текст – используется для отображения активного в рабочей области документа.
  • Красный текст – используется для отображения документа, который был изменен и еще не сохранен. Примечание: если документ является активным и измененным, он будет отображен как выделенная жирным красная запись.
  • Серый текст – используется для отображения документа, который существует в папке, но который не добавлен в состав проекта. Запись в столбце Kind будет заключена в фигурные скобки (например, {TEXT}). Чтобы скрыть эти документы в списке и отображать только документы, добавленные в проект, поставьте флажок Only Show Files in Current Project в правой верхней части раздела.
  • Курсив – используется для отображения документа, который добавлен в проект, но не находится в иерархии хранения этого проекта (например, файл ограничений, который является частью установки).

При щелчке мышью по записи документа, в верхней части панели будет отображен путь к локальной папке, в которой этот документ находится (полный путь также отображается в качестве всплывающей подсказки). Также будет показан статус ссылки на папку в репозитории SVN. Чтобы скрыть документы, которые существуют в папке, но которые не добавлены в проект, поставьте флажок Only Show Files in Current Project.

Щелкните ПКМ в разделе Files, чтобы получить доступ к следующим командам:

  • Open (Открыть) – открыть выделенный документ в качестве активного документа в рабочей области. Если выделена группа документов, все документы будут открыты в качестве вкладок рабочей области; запись в фокусе станет активным документом. Двойной щелчок мышью по записи документа также откроет его в качестве активного документа в рабочей области.
  • Refresh (Обновить вид) – обновить содержимое раздела, например, после использования команды Delete или после изменений документа через Проводник Windows.
  • Copy (Копировать) – скопировать выделенный документ(-ы). Это позволяет легко копировать документы между папками одного проекта или в папку другого проекта.
  • Paste (Вставить) – вставить скопированный ранее документ(-ы) в папку в фокусе активного проекта.
  • Add Project Folder to Version Control (Добавить папку проекта в контроль версий) – для проектов, которые еще не зафиксированы в системе контроля версий, эта команда откроет диалоговое окно Add to Version Control, в котором вы можете добавить всю папку проекта в систему контроля версий.
  • Delete (Удалить) – удалить выделенный документ(-ы). Появится диалоговое окно с запросом на подтверждение удаления. Документы будут безвозвратно удалены с жесткого диска. Примечание: документ проекта удалить нельзя.
  • Rename (Переименовать) – переименовать выделенный документ (или документ в фокусе в группе выделенных документов). Запись имени файла документа станет доступна для редактирования. Введите необходимое новое имя.
  • Add to Version Control (Добавить в контроль версий) – эта команда доступна только если активный проект находится в системе контроля версий. Будет открыто диалоговое окно Add to Version Control, где выделенная папка в списке Folders будет добавлена в систему контроля версий в родительскую папку проекта.

Контекстные команды контроля версий

Если на вашем компьютере установлено программное обеспечение для контроля версий, в контекстном меню будут доступны дополнительные команды, которые относятся к контролю версий. Точный перечень доступных команд зависит от того, добавлены ли активный проект и его документы в репозиторий системы контроля версий, и от типа используемой системы контроля версий. Ниже приведен перечень всех возможных команд. Если команда относится к определенному типу систем контроля версий, то это оговорено.

  • Add Project Folder to Version Control (Добавить папку проекта в контроль версий) – используйте эту команду, чтобы добавить выделенный проект в репозиторий/базу данных контроля версий. Эта команда доступна только если проект еще не добавлен в систему контроля версий. После запуска команды будет открыто диалоговое окно Add to Version Control (зависит от используемого программного обеспечения для контроля версий), в котором необходимо выбрать целевой проектный репозиторий или создать новую запись папки для текущего проекта. После того, как область хранения проекта была определена (и, соответственно, проект связан с базой данных), в диалоговом окне будут отображены проект и входящие в его состав документы, где файл проекта уже выделен для добавления в базу данных контроля версий. Выберите другие файлы, которые вы также хотите добавить в контроль версий, если необходимо.

    Выберите проектный репозиторий в диалоговом окне Add to Version Control, чтобы отобразить в диалоговом окне предполагаемые для добавления в контроль версий файлы.

    После нажатия OK, файлы будут добавлены в базу данных контроля версий, и в соответствующем поле Status документа(-ов) в разделе Files будет отображено Scheduled for addition (Запланировано для добавления).

  • Commit Whole Project (Зафиксировать весь проект) – используйте эту команду, чтобы зафиксировать в системе контроля версий проект, который уже был добавлен, что обозначено статусом файлов Scheduled for addition (см. выше).

    После нажатия OK, файлы будут добавлены в базу данных контроля версий, и в соответствующем поле Status документа(-ов) в разделе Files будет отображено No modification (Нет изменений).

    Обратите внимание, что будут зафиксированы только файлы, которые входят в состав проекта и которые находятся в той же папке, что и документ проекта.

  • Remove From Version Control (Удалить из контроля версий) – используйте эту команду для удаления выделенного проекта из репозитория/базы данных контроля версий. Эта команда доступна только если проект добавлен в систему контроля версий. После запуска команды будет открыто диалоговое окно Remove from Version Control, где запись проекта уже выделена.

    В списке будут также приведены связанные с проектом документы, и вы можете выделить любой из них или их все для удаления из системы контроля версий. После нажатия OK, проект и прочие указанные документы будут переведены в статус Scheduled for deletion (Запланировано для удаления).

    Последующая команда фиксации (Commit Whole project или просто Commit для отдельный файлов) удалит проектные файлы из базы данных системы контроля версий, и эти документы будут отображены в статусе Not in version control (Не в контроле версий).

    Обратите внимание, что при удалении из базы данных контроля версий вы запрашиваете не связывать проект с контролем версий, и связь между Altium NEXUS и программного обеспечения контроля версий будет удалена. Удаление одного проекта не удалит все связанные проектные документы из базы данных контроля версий. Они все еще будут там, но поскольку связи Altium NEXUS с контролем версий больше нет, Altium NEXUS будет работать как если бы они не были в базе данных контроля версий. Они будут зафиксированы снова, только если проект добавлен обратно в систему контроля версий и выполнено обновление для повторной синхронизации системы.

  • Add To Version Control (Добавить в контроль версий) – используйте эту команду для добавления выделенного файла(-ов) в репозиторий контроля версий. После запуска команды, статус файла(-ов) будет изменен на Scheduled for addition (Запланирован на добавление). В случае добавления всего проекта, на финальном шаге фиксации будет открыто диалоговое окно Edit Comment.

    Используйте это диалоговое окно для прикрепления комментария (или журнального сообщения) к файлу(-ам), где, например, сказано, почему файлы добавляются в контроль версий. Введите новый комментарий или используйте текст предыдущего комментария.

    Обратите внимание, что для корректной фиксации выделенные файлы должны входить в состав родительского проекта. Если добавляемый файл в данный момент открыт, он должен быть сохранен перед добавлением в систему контроля версий, поскольку в VCS будет отправлена последняя сохраненная версия файла, а не текущая копия в оперативной памяти.

  • Commit (Зафиксировать) – используйте эту команду, чтобы зафиксировать изменения рабочей копии выделенного файла (отображается со статусом Modified) в репозиторий SVN. Будет зафиксирована самая новая копия файла в рабочей папке, и будет увеличен соответствующий номер ревизии – см. раздел Commit Whole Project выше.

    Обратите внимание, что вы не сможете зафиксировать файл, если кто-либо другой зафиксировал обновление, поскольку вы извлекли свою копию файла. В этом случае, необходимо выполнить обновление (Update) перед фиксацией файла.

  • Refresh (Обновить статус) – используйте эту команду, чтобы опросить ссылку между выделенным проектом в панели Storage Manager и соответствующим проектом, который находится в базе данных системы контроля версий, и обновить статус локального проекта и его документов. После запуска команды, будет произведено сравнение проекта в фокусе и его документов и записей в базе данных системы контроля версий, и их статус будет обновлен. Эту команду можно использовать в любой момент, но она особенно полезна, когда вы выполнили какое-либо действие, например фиксацию, извлечение или удаление непосредственно в программном обеспечении контроля версий. Вы также можете использовать в панели Storage Manager клавишу F5 для обновления статуса документов.

  • Update (Обновить) и Update Whole Project (Обновить весь проект) – используйте эти команды для обновления рабочей копии выделенного файла(-ов) в соответствии с изменениями, которые существуют в самой новой ревизии этого файла в репозитории SVN.

  • Revert Local Modifications (Откатить локальные изменения) – используйте эту команду, чтобы откатить локальные изменения файлов. Перед завершением этого действия у вас будет запрошено подтверждение изменений.

  • VCS Properties (Свойства VCS) – используйте эту команду для отображения информации о свойствах записи выделенного документа в репозитории SVN. После запуска команды будет открыто диалоговое окно с информацией о свойствах документа в фокусе. Интерфейс диалогового окна и отображаемая информация будут зависеть от используемого программного обеспечения контроля версий, но здесь не будет приведена такая информация, как тип файла, размер, версия и состояние извлечения файла.

Раздел Time line

В разделе Time line показана динамика исторических событий и событий контроля версий для выделенной папки или файла.

Этот раздел можно переключать между комбинированным видом по умолчанию и "классическим" видом VCS/истории через контекстное меню.

Команды и функции являются общими для обоих видов. Ниже приведены команды для классического разделенного режима.

Область VCS Revisions (Ревизии VCS)

Если активный проект в разделе Folders находится под управлением контроля версий и если вы используете системы контроля версий SVN, то при выборе документа, который принадлежит проекту (в разделе Project Files панели) область VCS Revisions будет заполнена списком истории ревизий этого документа.

Будет также показана история выделенного документа библиотеки, если эта библиотека является библиотекой символов или посадочных мест, которая относится к базе данных, которая, в свою очередь, связана с файлом библиотеки SVN Database Library.

Список истории ревизий может включать в себя записи следующих типов:

  • Document (Документ) – версия документа, открытого в данный момент в рабочей области. В этом документе могли быть изменения, которые необходимо сохранить.
  • Last Saved Contents (Последнее сохраненное содержимое) – последняя сохраненная версия документа (в локальной рабочей папке).
  • НомерРевизии – ревизия документа в репозитории VCS. При изменении документа, его сохранении и последующей фиксации в репозитории VCS, будет сохранена копия документа, и его номер ревизии будет увеличен. Самая новая ревизия в VCS отображается в списке первой.

Для каждой записи в списке приводится следующая информация:

  • Date Modified (Дата изменения) – для записей Document и Last Saved Contents, это время последнего сохранения рабочей копии документа. Для записей ревизий VCS, это время фиксации файла.
  • Author (Автор) – имя пользователя, вошедшего в данный момент в программное обеспечение VCS.
  • Comment (Комментарий) – комментарий для ревизии VCS, указанный при фиксации файла в репозитории VCS.

При щелчке ПКМ внутри области VCS Revisions будет открыто контекстное меню для доступа к следующим командам:

  • Compare (Сравнить) – эта команда становится доступной, когда в области выбраны две версии. Используйте ее для проведения сравнения документов (см. раздел Сравнение документов).
  • Open (Открыть) – используйте эту команду, чтобы открыть выделенную версию документа в рабочей области. Названию открытого документа будет предшествовать номер ревизии, например [Revision 1.2] Buzzer.SchDoc. Обратите внимание, что эта команда не доступна при выделении в этой области множества записей версий.
  • Switch to Combined View (Переключиться в комбинированный вид) – переключить раздел в единый вид Time line, как сказано выше.

Область Local History (Локальная история)

В этой области панели представлена локальная история документа, который в данный момент находится в фокусе в разделе Files панели.

Список в этой области может включать в себя следующие записи:

  • Document (Документ) – версия документа, открытого в данный момент в рабочей области. В этом документе могли быть изменения, которые необходимо сохранить.
  • Last Saved Contents (Последнее сохраненное содержимое) – последняя сохраненная версия документа.
  • Version n (Версия n) – локальная (сохраненная вручную) резервная версия документа. При сохранении документа, версия, которая была приведена как Last Saved Contents, будет сохранена как запись Version 1. Повторное сохранение создаст копию Last Saved Contents как Version 2 и т.д., тем самым будет формироваться история документа.
  • Version n [label] (Версия n [метка]) – локальная (сохраненная вручную) резервная версия документа, для которой использовалась метка.
  • Version n [AutoSave Date Time] (Версия n [AutoSave Дата Время]) – автоматически сформированная резервная версия документа, которая отличается отметкой о дате/времени автосохранения.

Список истории приводится с самой новой версией наверху, например:

  • Document
  • Last Saved Contents
  • Version 3
  • Version 2 [AutoSave 2015-01-28 14~14~17-935]
  • Version 1 [Original Draft]

При щелчке ПКМ внутри области Local History будет открыто контекстное меню для доступа к следующим командам:

  • Compare (Сравнить) – эта команда становится доступной, когда в области выбраны две версии. Используйте ее для проведения сравнения документов (см. раздел Сравнение документов).
  • Open (Открыть) – используйте эту команду, чтобы открыть выделенную версию документа в рабочей области. Эта команда не доступна при выделении в этой области множества записей версий.
  • Apply Label (Применить метку) – используйте эту команду, чтобы добавить осмысленную метку для выбранной версии (например, чтобы можно было легко понять назначение этой версии). Будет открыто диалоговое окно Apply Label, где вы можете ввести необходимое название метки, до 64 символов. Запись будет отображаться как Version n [метка]. При использовании метки, сохраненная резервная копия будет доступна только для чтения.
  • Revert to (Откатить до) – используйте эту команду, чтобы откатиться до выделенной версии файла. Будет создана резервная копия последней сохраненной версии, и будет применена метка для обозначения, до какой версии был восстановлен файл. Выбранная историческая версия станет текущей версией, которая будет отображена в рабочей области.
  • Delete (Удалить) – используйте эту команду, чтобы удалить выделенную версию(-и) файла. Файл(-ы) будут безвозвратно удалены с жесткого диска. Примечание: записи Document и Last Saved Content удалить нельзя.
  • Purge History (Очистить историю) – удалить файлы локальной истории для выделенного документа(-ов). Будет открыто диалоговое окно Confirm purge document history, откуда вы можете определить, какие именно файлы локальной истории необходимо очистить.

    После нажатия OK, все записи Version n (где n – это номер версии) выделенных документов в области Local History будут удалены в соответствии с заданными параметрами. Если вы включили параметр для удаления версий файлов с метками, соответствующие записи Version n [метка] будут также удалены.

  • Show Autobackups (Показать автоматические резервные копии) – используйте эту команду, чтобы включить в списке локальной истории отображение автоматически сохраненных версий файлов, которые были созданы с помощью функции автосохранения Altium NEXUS.
  • Switch to Combined View (Переключиться в комбинированный вид) – переключить раздел обратно в режим Time line, где события VCS и истории отображаются в единой области.

Сравнение документов

Выделите две записи (в области VCS Revisions или Local History), затем щелкните ПКМ и выберите команду Compare из контекстного меню. Будет проведено сравнение двух документов, результат которого зависит от типа документов:

  • Для схем и плат (документов или библиотек) – будет проведено графическое сравнение, и найденные различия будут приведены в панели Differences. Две версии документа будут открыты рядом друг с другом в рабочей области, где вы можете просмотреть изменения графически. Щелкните по папке верхнего уровня, чтобы подсветить найденные различия одновременно в обоих документах.

  • Для текстовых документов ASCII – будет открыто диалоговое окно CompareForm с графическим отображением различий двух версий документа. Выбранные документы будут отображены рядом друг с другом. Диалог служит только для сравнения – провести изменения загруженных документов нельзя. Диалоговое окно подсвечивает различия между двумя версиями документа с помощью цветовой кодировки: добавленные строки выделяются розовым, измененные строки – зеленым, удаленные строки – синим. Сводка по изменениям и легенда цветовой кодировки приведены в левой нижней части диалогового окна.

Настройки

  • Включение/отключение функциональных возможностей контроля версий и выбор типа системы осуществляется на странице Data Management - Version Control диалогового окна Preferences.
  • Для просмотра библиотек символов и посадочных мест активного файла SVN Database Library копия этих библиотек должна быть извлечена в указанную локальную рабочую папку. Эта директория указывается на странице Data Management - SVN Libraries диалогового окна Preferences. Также необходимо убедиться, что на странице Data Management - Version Control диалогового окна Preferences в качестве системы контроля версия задано SVN - Subversion.
  • Версия Last Saved Contents файла является актуальной мастер-копией файла, сохраненного в папке проекта. Ручные резервные версии (Version 1, Version 2 и т.д.) хранятся в подпапке проекта. Вы можете хранить все локальные резервные версии файлов в выбранном едином расположении. Включите параметр Use global repository на странице Data Management - Local History диалогового окна Preferences и укажите нужную папку хранения.
  • Можно создать любое количество локальных (созданных вручную) резервных копий, в зависимости от собственных предпочтений и доступного для хранения пространства. Резервные копии будут храниться на жестком диске в течение времени (в днях), указанного на странице Data Management - Local History диалогового окна Preferences. Вы можете указать от 1 до 10 дней для хранения сформированных резервных документов в локальной истории, по истечении которых они будут удалены (в соответствии с отметкой о времени) и будут созданы новые резервные копии.
  • Резервные копии открытых документов могут быть созданы автоматически с помощью функции Auto Save, которая настраивается на странице Data Management - Backup диалогового окна Preferences.

Советы

  • Поддерживаются стандартные сочетания выделения множества записей: Ctrl+ЛКМ и Shift+ЛКМ. Кроме того, выделение множества документов в разделах Files, VCS Revisions и Local History можно осуществить с помощью перетаскивания мыши с зажатой ЛКМ.
  • Доступ к локальной истории активного в рабочей области документа можно получить с помощью команды Project » Local History » Show Local History из главного меню. Будет открыто диалогового окно Local History, где показана текущая версия открытого документа, а также сохраненные ранее резервные версии.

  • Выделите две версии документа, которые вы хотите сравнить, затем нажмите кнопку Compare.
  • Для схем и плат (документов и библиотек), две версии одного документа также можно графически сравнить с помощью команды Project » Show Physical Differences. Обратите внимание, что перед открытием предыдущая версия (как правило, резервная копия) сохраняется под другим именем. Резервную версию документа не нужно добавлять в проект, она будет открыта как свободный документ. Запустите команду, чтобы открыть диалоговое окно Choose Documents To Compare, в котором, при использовании в режиме Advanced, можно выбрать две версии документа для сравнения.

    Нажмите OK, чтобы начать сравнение. Найденные различия можно отобразить в панели Differences.

  • Для навигации в панели можно использовать следующие клавиши:
    • Стрелка вверх – переход к предыдущей записи в разделе.
    • Стрелка вниз – переход к следующей записи в разделе.
    • Стрелка вправо – развернуть запись верхнего уровня или подпапку.
    • Стрелка влево – свернуть запись верхнего уровня или подпапку.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.