Altium NEXUS Documentation

Работа между схемой и платой

Последнее изменение: Pavel Demidov; 30.06.2019
Эта страница документации относится к Altium Vault – продукту, который больше не поддерживается. Altium Vault и его функциональные возможности по управлению компонентами теперь доступны в Altium Concord Pro.
Clicking in the Navigator panel while holding the Alt key, to select a component on the schematic and the PCB simultaneously

Одним из главных преимуществ Altium NEXUS является то, что вы можете легко переходить между различными элементами своего проекта. Например, одно нажатие мыши в панели Projects открывает лист схемы, другое – печатную плату, третье – файл OutputJob со всеми выходными документами, которые необходимо сформировать.

Тем не менее, проект – это не только простой доступ к файлам. Вам необходимы ориентированные на проектирование средства, которые помогают решить все конструкторские задачи. Ключевым элементом эффективной работы является возможность беспрепятственно переходить между схемой и платой при выполнении различных задач проектирования.

Например, вы готовитесь к размещению компонентов и изучаете различные варианты компоновки, группируя связанные между собой компоненты на периферии платы. Или, возможно, вы проверяете связность, находите критические цепи и исследуете, как они были разведены.

Для решения подобных задач вам необходимо найти объекты в целевом документе на основе объектов, которые вы видите в исходных документах.

Перекрестный переход, перекрестное выделение и панель Navigator – вот некоторые способы, которые позволяют вам работать между документами схем и плат.

Перекрестный переход, перекрестное выделение и панель Navigator могут приближать вид, выделять объекты и затенять прочие объекты. Настройка этих действий осуществляется на странице System - Navigation диалогового окна Preferences.


Унифицированная среда проектирования

Altium NEXUS использует термин унифицированный по отношению к проекту – единой сущности, которая является центральным элементом процесса проектирования. Именно этот унифицированный, ориентированный на проектирование подход делает работу между схемой и платой эффективной. Среда также является унифицированной, поскольку все редакторы и технологии проектирования работают в едином программном приложении.

Так как Altium NEXUS является унифицированной средой проектирования, схему и плату можно открыть одновременно рядом друг с другом. После компиляции проекта вы можете:

  • Щелкнуть мышью в панели Navigator, чтобы найти компонент, вывод, цепь или шину на схеме, или, если зажата клавиша Alt, то и на плате.
  • Произвести перекрестный переход к компоненту, выводу, цепи или шине между схемой и платой.
  • Произвести перекрестное выделение из одного редактора в другом.
  • Легко передавать проектные изменения из одного редактора в другой, в любом направлении.

Зачем необходима компиляция, и что такое унифицированная модель данных?

Итак, что же такое компиляция и зачем необходимо компилировать проект?

При компиляции проекта система создает связность, которую вы определили размещением связей между выводами в схеме. Последовательность следующая:

Concept image showing how the different editors all access the single Unified Data Model
  • Создается связность между выводами внутри каждого листа.
  • Затем создается связность между листами, на основе выбранной области действия идентификаторов цепей.
  • Запускаются включенные проверки ошибок.

Унифицированная модель данных

В основе системы лежит унифицированная модель данных (Unified Data Model, UDM). При компиляции проекта происходит создание единой связанной модели, которая занимает центральное место в процессе проектирования. Данные этой модели затем можно открывать и изменять с помощью различных редакторов и служб системы. Вместо того, чтобы хранить данные каждого аспекта проектирования по отдельности, модель UDM структурирована для хранения всей информации о проекте, в том числе о компонентах и связи между ними.


Перекрестный переход

Перекрестным переходом называется возможность щелкнуть (или щелкнуть дважды) мышью по объекту в одном проектном интерфейсе и отобразить этот объект в другом проектном интерфейсе. В Altium NEXUS существует множество мест, где можно осуществить перекрестный переход.

Например, после запуска команды Tools » Cross Probe в редакторе плат вы можете щелкнуть по компоненту в плате и отобразить тот же самый компонент на схеме. Эта команда поддерживает перекрестный переход между компонентами, шинами, цепями и выводами/контактными площадками. По умолчанию вы остаетесь в исходном редакторе; используйте это поведение, когда видимы исходный и целевой документы. Зажмите Ctrl при щелчке мышью, чтобы перейти в целевой документ.

Кроме того, после компиляции проекта вы можете щелкнуть ПКМ по сообщению об ошибке в панели Messages и выбрать команду Cross Probe либо дважды щелкнуть по сообщению мышью, чтобы перейти к месту ошибки в схеме.

Animation demonstrating how to cross probe from the schematic to the PCB
Вы можете осуществлять перекрестный переход между компонентами, выводами, цепями или шинами. Зажмите Ctrl для перехода в целевой редактор.

Существует ряд различных способов, с помощью которых вы можете осуществлять перекрестный переход в Altium NEXUS.

► Узнайте больше о Перекрестном переходе и выделении.


Перекрестное выделение

Перекрестное выделение схоже с перекрестным переходом. Используйте его для выделения компонента, который вы в данный момент можете видеть в другом проектном интерфейсе. Перекрестное выделение также предлагает выделение множества компонентов. Оно работает в обоих направлениях между схемой и платой, и это идеальное средство для создания набора выделенных объектов, которые готовы к какой-либо проектной операции. Например, вы можете видеть ряд компонентов на схеме и хотели бы найти их в рабочей области редактора плат для размещения их на плате.

После включения режима Cross Select Mode (меню Tools) при выделении компонента в одном редакторе он будет автоматически выделен в другом редакторе.

Animation demonstrating how to use cross selection from the schematic to the PCB
Используйте перекрестное выделение для быстрого выделения компонентов на плате непосредственно из схемы. Включите этот режим через меню Tools любого из редакторов.

► Узнайте больше о Перекрестном переходе и выделении.


Применение цвета к цепям

При создании проекта он быстро становится визуально перегруженным – схема занята связями, плата становится лабиринтом из линий соединения и разведенных цепей. Для внесения визуальной ясности, проектировщик может применить цвет к связям на схеме, а также к линиям соединения и трассировке на плате.

Функция выборочного переопределения цвета определенных цепей называется Net Color Override. Можно цвет применить к цепям на схеме и затем передать эти настройки цвета в плату, либо настройки цвета можно применить непосредственно в редакторе плат.

Image showing a schematic and PCB side by side, showing how color can be applied to nets in both editors

► Узнайте больше о Применении цвета к цепям.


Синхронизация проекта

Самой распространенной задачей при работе между схемой и платой является поддержание соответствия схемы и платы, т.е. их синхронизация. Независимо от того, передаете ли вы данные из схемы в новую плату первый раз или вносите изменения в существующий проект на стороне схемы или платы, используется один и тот же процесс.

Concept image showing how the schematic and PCB are synchronized, using the Comparator engineПроцесс синхронизации ищет и устраняет различия схемы и платы.

Синхронизация проекта осуществляется непосредственно между редакторами схем и плат, каких-либо промежуточных файлов списка цепей не используется. Система использует модуль сравнения (компаратор), чтобы сравнивать все аспекты проекта и формировать список запросов на инженерные изменения (Engineering Change Order, ECO). После применения этих запросов, две стороны проекта становятся синхронизированными.

► Узнайте больше о Синхронизации проекта.


Панель Navigator

Если проект большой и разбит на множество листов, может быть сложно отследить цепь и проверить связность проекта, просто взглянув на схему. Чтобы упростить этот процесс, используется панель Navigator. Панель отображает весь скомпилированный проект, поэтому она будет пустой, пока вы не скомпилируете проект (Project » Compile PCB Project). Панель Navigator можно открыть, нажав кнопку Panels button в нижней правой части приложения и выбрав Navigator.

Using the Navigator panel to locate a bus simultaneously on the schematic and PCB, by holding the Alt key as you click
Используйте панель Navigator для просмотра всего скомпилированного проекта. Зажмите клавишу Alt при щелчке мышью в панели, чтобы найти этот же объект на плате.

► Узнайте больше о Панели Navigator.


Что дальше?

Подобно всем технологиям проектирования Altium NEXUS, редактор схем и редактор плат разработаны для быстрого изучения и простой работы в них. Широко используются контекстные меню, и везде доступна контекстно-зависимая справка (F1) и списки сочетаний клавиш для интерактивных команд (Shift+F1).

Если вы не знакомы с Altium NEXUS, вы можете начать с базового урока. Создайте простой проект из девяти компонентов, начав с пустого листа схемы и закончив платой, а также набором файлов, необходимых для ее изготовления.

Также могут оказаться полезными следующие страницы:

Синхронизация проекта

Панель Navigator

Перекрестный переход и выделение

Применение цвета к цепям

Эквивалентная замена выводов и секций

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.