Ansys CoDesigner

Do độ phức tạp của các sản phẩm điện tử hiện đại có tích hợp mạch tốc độ cao và RF, cần có sự trao đổi chặt chẽ giữa kỹ sư PCB và kỹ sư mô phỏng trong suốt quá trình thiết kế PCB, và việc trao đổi này cần rõ ràng, đơn giản nhất có thể cho cả hai bên. Chỉ xuất một thiết kế đã được kỹ sư PCB thay đổi hoặc được kỹ sư mô phỏng tối ưu hóa rồi chuyển cho phía còn lại là chưa đủ – còn cần truyền đạt rõ những gì đã được thay đổi, việc này thường được thực hiện qua email hoặc trao đổi trực tiếp. Cách tiếp cận này chưa tối ưu vì cần theo dõi tất cả các yêu cầu và so sánh dữ liệu thủ công để quyết định thay đổi thiết kế hoặc bắt đầu một phân tích mới. Những thách thức này và các vấn đề liên quan khác có thể được giải quyết bằng Ansys CoDesigner, một giao diện dùng để chuyển thiết kế bo mạch in giữa miền thiết kế PCB và miền mô phỏng.

Tính năng này khả dụng khi đã cài đặt tiện ích mở rộng Ansys CoDesigner (dành cho Altium Designer) và Altium Link (dành cho Ansys Electronics Desktop).

Phần mềm được hỗ trợ

Nền tảng mô phỏng sau đây và các phiên bản của nó hiện đang được hỗ trợ:

Ansys Electronics Desktop (AEDT) – phiên bản 2023 R1, 2023 R2, 2024 R1, 2024 R2, 2025 R1, 2025 R2, 2026 R1

Cài đặt và cấu hình

Để truy cập Ansys CoDesigner trong Altium Designer, cần cài đặt tiện ích mở rộng phần mềm Ansys CoDesigner. Tiện ích này có thể được cài đặt hoặc gỡ bỏ thủ công.

Để biết thêm thông tin về cách quản lý tiện ích mở rộng, hãy tham khảo trang Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Để truy cập Ansys CoDesigner trong Ansys Electronics Desktop, cần cài đặt tiện ích mở rộng Altium Link. Quy trình như sau:

  1. Tải xuống và giải nén gói tiện ích mở rộng Altium Link. Bạn có thể nhận gói này bằng cách liên hệ ansyscollaboration@altium.com (cung cấp phiên bản AEDT đang sử dụng).

  2. Đảm bảo ứng dụng AEDT đã được đóng.

  3. Trong thư mục đã giải nén, tìm tệp install_altiumlink.bat, nhấp chuột phải vào tệp đó và chọn Run as administrator.

  4. Mở AEDT và chọn lệnh Tools » Layout Links từ các menu chính.

  5. Trên tab Config của hộp thoại Layout Links mở ra, nhấp nút Add Link, duyệt đến thư mục \AnsysEM\<version>\Win64 của các tệp chương trình AEDT, rồi mở tệp altiumlink.dll.

  6. Trên tab Layout Links của hộp thoại Layout Links, hãy đảm bảo liên kết Altium đã được liệt kê và đóng hộp thoại.

Cách thức hoạt động

Sau khi chức năng Ansys CoDesigner được thêm vào phần mềm thiết kế PCB và phần mềm mô phỏng, nó có thể chuyển các thay đổi thiết kế qua lại giữa hai bên. Các thay đổi thiết kế được chuyển qua một Altium 365 Workspace, đóng vai trò như cầu nối giữa hai miền. Ưu điểm của việc chuyển thay đổi thiết kế thông qua Workspace là quy trình cập nhật trở nên stateless. Điều đó có nghĩa là mỗi bên có thể tiếp tục làm việc độc lập; không cần lo lắng về việc nhóm còn lại đang ở giai đoạn nào trong quy trình thiết kế/mô phỏng.

Ansys CoDesigner hỗ trợ cơ chế đẩy/kéo hai chiều các thay đổi thiết kế giữa hai miền. Từ Altium Designer, các thay đổi đối với chồng lớp và vật liệu, linh kiện và primitive sẽ được phát hiện và có thể áp dụng trong AEDT. Từ AEDT, các thay đổi đề xuất đối với chồng lớp và vật liệu có thể được đẩy qua tệp EDB và được phát hiện/áp dụng trong Altium Designer. Kỹ sư ECAD và kỹ sư mô phỏng có thể trao đổi bằng hệ thống bình luận, với mỗi chuỗi bình luận được gắn với một linh kiện cụ thể trong thiết kế. Kết quả mô phỏng có thể được đẩy từ AEDT lên Altium 365 Workspace và gắn với một phiên bản sửa đổi của thiết kế, đồng thời có thể xem qua giao diện trình duyệt của Workspace và xem trước ngay trong Altium Designer.

Giao diện cộng tác

  • Trong Altium Designer, Ansys CoDesigner panel được dùng để Push và Pull các thay đổi thiết kế qua lại và hiển thị thông báo.

    Có thể truy cập Ansys CoDesigner panel từ trình chỉnh sửa PCB trong Altium Designer bằng cách nhấp nút Panels ở góc dưới bên phải của vùng thiết kế và chọn tùy chọn Ansys CoDesigner  từ menu xuất hiện. Lưu ý rằng bạn phải kết nối với một Workspace để truy cập panel này, và tài liệu PCB phải là một phần của dự án PCB được lưu trong Workspace đó thì mới có thể sử dụng chức năng này.

  • Trong AEDT, các hộp thoại được truy cập từ hộp thoại Layout Links (Tools » Layout Links) hoặc từ tab Desktop trên ribbon khi một dự án đang mở được dùng để:
    • Kết nối với Altium 365 Workspace của bạn và nhập một thiết kế PCB từ đó.
    • Đẩy thiết kế lên và kéo thiết kế xuống từ Workspace.
    • Khám phá lịch sử trao đổi dữ liệu giữa Altium Designer và AEDT.
    • Thêm bình luận vào các linh kiện trong thiết kế.

Đẩy thay đổi từ Altium Designer

Để đẩy thiết kế từ Altium Designer, nhấp nút Push trong Ansys CoDesigner panel. Một cửa sổ chỉnh sửa sẽ xuất hiện ở phía trên panel. Nhập thông điệp về thay đổi thiết kế, sau đó nhấp Send. Vùng Latest from Altium Designer của Ansys CoDesigner panel sẽ được cập nhật với thông tin chi tiết về lần đẩy này.

Sau đó, thiết kế có thể được nhập vào AEDT. Với một thiết kế đã được nhập trước đó, các thay đổi có thể được kéo vào AEDT.

Lưu ý rằng khi sử dụng chức năng Ansys CoDesign, thông tin về các mô hình mô phỏng (SPICE, IBIS, v.v.) được chuyển từ schematic sang PCB khi áp dụng Engineering Change Order. Sử dụng kiểu so sánh Changed Simulation Model trên tab Comparator của hộp thoại Project Options và kiểu sửa đổi Change Component Simulation Model trên tab ECO Generation của hộp thoại Project Options để lần lượt cấu hình việc phát hiện khác biệt trong các mô hình mô phỏng giữa schematic và PCB, cũng như tạo ECO cho các khác biệt này.

Tìm hiểu thêm về Keeping the Schematics & PCB Synchronized.

Push và Share để mời kỹ sư mô phỏng

Khi bạn nhấp Push trong Ansys CoDesigner panel, bạn cũng có thể bật tùy chọn Share bên dưới trường Comment để gửi email lời mời cho kỹ sư mô phỏng bằng hộp thoại Share with a Simulation Engineer mở ra sau khi nhấp nút Send.

Nhập địa chỉ email của kỹ sư mô phỏng và ghi chú tùy chọn (nếu cần), sau đó nhấp nút Share . Bạn có thể chia sẻ với một người đã là thành viên trong nhóm Workspace của bạn, một người dùng Altium đã đăng ký khác trong hoặc ngoài tổ chức của bạn, hoặc một người dùng chưa có tài khoản Altium. Một hộp thoại thông báo có thể xuất hiện để cảnh báo rằng người dùng có email bạn vừa nhập có thể ở ngoài tổ chức của bạn – hãy nhấp OK để vẫn mời họ.

Sau một khoảng trễ ngắn, một hộp thoại khác sẽ xuất hiện để cho biết lời mời đã được gửi thành công.

Trong quy trình mời:

  • Một người dùng đã là thành viên trong nhóm Workspace của bạn sẽ được chia sẻ dự án với quyền View, và họ sẽ nhận được email mời để truy cập dự án trong Workspace.
  • Một người dùng chưa là thành viên trong nhóm Workspace của bạn nhưng đã có tài khoản Altium (bất kể họ ở trong hay ngoài tổ chức của bạn) sẽ được thêm làm thành viên của nhóm Workspace, và dự án sẽ được chia sẻ với họ với quyền View. Họ sẽ nhận được email mời để có thể truy cập dự án trong Workspace.
  • Một người dùng chưa có tài khoản Altium sẽ nhận được email dẫn họ đến một biểu mẫu trung gian để đăng ký tài khoản Altium. Họ sẽ được thêm làm thành viên của nhóm Workspace sau khi đăng ký, và dự án sẽ được chia sẻ với họ với quyền View.
  • Việc gửi lời mời chỉ có thể được thực hiện bởi Administrator của Workspace.
  • Kỹ sư mô phỏng sẽ không thể nhập thiết kế bo mạch vào AEDT nếu dự án không được chia sẻ với họ.
  • Bạn nên đăng nhập vào Workspace của mình trên trình duyệt và xác nhận rằng kỹ sư mô phỏng được mời đã được gán Edit permissions trong hộp thoại dự án Share. Mặc dù kỹ sư mô phỏng sẽ có thể Pull thiết kế chỉ với quyền View, họ sẽ không thể Push các thay đổi vào thiết kế nếu the project không được chia sẻ với họ với quyền Edit.
  • Lưu ý rằng người dùng chưa có tài khoản Altium sẽ được xem như thuộc tổ chức cá nhân của riêng họ sau khi đăng ký. Họ sẽ không được thêm vào tổ chức của bạn.

Kéo thay đổi vào Altium Designer

Khi có thay đổi mới được đẩy từ AEDT, banner New changes have been detected sẽ tự động xuất hiện trong Ansys CoDesigner panel. Panel sẽ hiển thị chi tiết tên của kỹ sư mô phỏng đã thực hiện Push và bình luận tùy chọn mà họ đã nhập khi Push.

Khi nhấp nút Pull và nếu tệp EDB đã được bao gồm trong lần Push từ AEDT, mỗi thay đổi cần thực hiện đối với tệp làm việc để đồng bộ với snapshot trên Workspace của bạn sẽ được liệt kê. Mỗi khác biệt được phát hiện sẽ được liệt kê trong danh sách Changes trong panel. Bỏ chọn hộp kiểm cho từng thay đổi mà bạn không muốn áp dụng. Khi đã sẵn sàng, nhấp nút Apply để áp dụng tất cả các thay đổi đang được bật cho thiết kế.

Nếu kết quả mô phỏng đã được bao gồm trong lần Push từ AEDT, điều khiển Design Summary sẽ được hiển thị trong panel. Nhấp điều khiển đó để hiển thị kết quả mô phỏng trong hộp thoại Design Summary.

Các kết quả mô phỏng cũng có thể được truy cập trong chế độ xem dự án trên giao diện trình duyệt Altium 365, trong thư mục Ansys của khu vực Simulation .

Nhập thiết kế vào AEDT

Để bắt đầu làm việc với một thiết kế PCB trong AEDT, trước tiên phải nhập thiết kế đó vào AEDT. Cách thực hiện như sau:

  1. Trong hộp thoại Layout Links (Tools » Layout Links), nhấp ô [Action] cho liên kết Altium trên tab Layout Links và chọn Projects. Ngoài ra, nhấp nút Projects trên tab Desktop của ribbon khi một dự án đang mở. Hộp thoại Altium sẽ mở ra.
  2. Đăng nhập vào tài khoản Altium của bạn. Đảm bảo rằng mục Altium Account được chọn trong danh sách thả xuống ở phía trên hộp thoại và nhấp nút Sign In. Một trang sẽ mở trong trình duyệt mặc định của bạn, nơi bạn có thể nhập thông tin đăng nhập tài khoản Altium hoặc sử dụng SSO để đăng nhập vào tài khoản Altium – xem ví dụ.

    • Phương thức xác thực SSO được hỗ trợ trong AEDT 2024 R1.
    • Khi đã kết nối, hãy dùng nút Sign Out ở phía trên hộp thoại Altium để đăng xuất khỏi tài khoản Altium hiện đang kết nối. 
  3. Chọn Workspace chứa dự án cần thiết từ danh sách thả xuống Workspace.
  4. Chọn dự án trong danh sách Projects và nhấp nút Import.

    Lưu ý rằng dự án phải được đẩy từ Altium Designer thì mới có thể nhập được.
  5. Lưu tệp dự án AEDT bằng hộp thoại Save As mở ra, sau đó đóng hộp thoại Altium.

  • Sử dụng nút Refresh trong hộp thoại Altium để cập nhật hộp thoại với dữ liệu mới nhất từ Workspace đang kết nối.
  • Về sau, bạn có thể tiếp tục làm việc trên một thiết kế đã nhập bằng cách mở lại bản sao làm việc của dự án AEDT (File » Open).

Đẩy thay đổi từ AEDT

Để đẩy thiết kế từ AEDT:

  1. Trong hộp thoại Layout Links (Tools » Layout Links), nhấp ô [Action] cho liên kết Altium trên tab Layout Links và chọn Push/Pull. Ngoài ra, nhấp nút Push/Pull trên tab Desktop của ribbon khi dự án đang mở.
  2. Sử dụng trường Comment ở phía trên hộp thoại mở ra để thêm bình luận mô tả những gì được bao gồm trong lần Push.
  3. Bật tùy chọn Include EDB file (để đẩy các thay đổi thiết kế) và/hoặc Include the Simulation Result (để đẩy kết quả mô phỏng).
  4. Nhấp nút Push to Altium 365. Vùng Latest from Ansys của hộp thoại sẽ được cập nhật với thông tin chi tiết về lần đẩy này.

Lần đẩy này sẽ được phát hiện trong Altium Designer, và có thể được kéo vào Altium Designer như mô tả ở trên.

Kéo thay đổi vào AEDT

Khi các thay đổi thiết kế đã được đẩy từ Altium Designer, chúng có thể được kéo vào AEDT.

  1. Trong hộp thoại Layout Links (Tools » Layout Links), nhấp ô [Action] cho liên kết Altium trên tab Layout Links và chọn Push/Pull. Ngoài ra, nhấp nút Push/Pull trên tab Desktop của ribbon khi dự án đang mở.
  2. Kiểm tra vùng Latest From Altium của hộp thoại mở ra để xem thông tin về lần đẩy mới nhất từ Altium Designer và nhấp nút Show Changes để mở hộp thoại mô tả sự khác biệt giữa thiết kế trong Workspace và thiết kế hiện tại trong AEDT. Sử dụng các hộp kiểm trên các tab của hộp thoại để chọn những thay đổi mà bạn muốn áp dụng cho thiết kế trong AEDT.

    Sử dụng nút Refresh để làm mới vùng Latest From Altium với dữ liệu mới nhất.
  3. Sau khi đã xem xét các thay đổi, nhấp nút Apply changes để áp dụng các thay đổi cho thiết kế trong AEDT.

Trong tất cả các phiên bản AEDT được hỗ trợ, bạn sẽ cần nhấp nút Apply changes trên mọi tab của hộp thoại EDB Diff để kéo các thay đổi all vào AEDT.

Khám phá lịch sử trao đổi

Lịch sử các lần đẩy và kéo của thiết kế được lưu giữ lại.

Để xem lịch sử trong Altium Designer, nhấp điều khiển History ở bên phải tiêu đề vùng Latest from the Ansys trong Ansys Codesigner panel. Danh sách các lần đẩy và kéo từ cả Altium Designer và Ansys sẽ mở ra. Sử dụng nút  ở phía trên panel để quay lại các thay đổi mới nhất.

Để xem lịch sử trong AEDT, nhấp ô [Action] cho liên kết Altium trên tab Layout Links của hộp thoại Layout Links (Tools » Layout Links) và chọn Push/Pull hoặc Comment hoặc nhấp nút Push/Pull hoặc Comment  trên tab Desktop của ribbon. Chọn tab History của hộp thoại mở ra. Mở rộng một mục push/pull để xem chi tiết của nó. Sử dụng nút Refresh để làm mới tab với dữ liệu mới nhất.

Thêm bình luận trong Altium Designer và AEDT

Cả kỹ sư điện và kỹ sư mô phỏng cũng có thể hưởng lợi từ khả năng hỗ trợ bình luận của Workspace bằng cách tạo các chuỗi bình luận gắn với các linh kiện cụ thể.

Trong Altium Designer, các bình luận hiện có khả dụng thông qua panel Comments and Tasks.

  • Để thêm một bình luận mới vào một linh kiện trên PCB, nhấp nút Comments ở phía trên panel, di con trỏ lên một linh kiện trong vùng thiết kế để linh kiện đó được tô sáng bằng viền xanh lam, rồi nhấp chuột. Trong hộp thoại nhập bình luận mở ra, gõ bình luận và nhấp Post.

  • Để trả lời một bình luận, chọn mục bình luận trong panel Comments and Tasks, nhập nội dung trả lời vào trường văn bản được cung cấp trong hộp thoại nhập bình luận, rồi nhấp Reply. Phần trả lời sẽ được thêm vào chuỗi bình luận.

Tham khảo trang Document Commenting để tìm hiểu thêm.

Trong AEDT, các chuỗi bình luận được quản lý thông qua tab Comments của hộp thoại Altium, được truy cập bằng cách nhấp ô [Action] cho liên kết Altium trên tab Layout Links của hộp thoại Layout Links (Tools » Layout Links) và chọn Comment. Danh sách ở phần trên của hộp thoại hiển thị các chuỗi bình luận hiện có cho dự án.

Để thêm bình luận vào một linh kiện trong AEDT:

  1. Chọn một linh kiện cụ thể trong panel Components (View » Components) hoặc trong vùng thiết kế.
  2. Trong hộp thoại Layout Links (Tools » Layout Links), nhấp ô [Action] cho liên kết Altium trên tab Layout Links và chọn Comment.
  3. Nhập bình luận vào trường Comment ở phần dưới của hộp thoại mở ra.
  4. Nhấp nút Create Thread . Một chuỗi mới sẽ được thêm vào danh sách.

Để trả lời một chuỗi hiện có từ AEDT:

  1. Chọn một mục bình luận được đánh số trong danh sách trên tab Comments của hộp thoại Altium.
  2. Nhập nội dung trả lời vào trường Comment ở phần dưới của hộp thoại.
  3. Nhấp nút Reply Thread . Một phản hồi mới sẽ được thêm bên dưới mục của chuỗi bình luận liên quan trong danh sách.

  • Sau khi được thêm, các chuỗi mới và phản hồi được thêm từ AEDT sẽ khả dụng trong panel Comments and Tasks của Altium Designer.
  • Để làm mới tab Comments của hộp thoại Altium với các bình luận và phản hồi mới được thêm từ Altium Designer, nhấp nút Refresh.
  • Bật tùy chọn Unresolved Only trong hộp thoại Altium để ẩn khỏi danh sách các chuỗi bình luận đã được đánh dấu là đã giải quyết (trong Altium Designer).
  • Sử dụng menu nhấp chuột phải của một mục được chọn cho một bình luận và chuỗi bình luận trong hộp thoại Altium để xóa mục này, chọn linh kiện liên quan, hoặc phóng to vào linh kiện trong vùng thiết kế.
AI-LocalizedBản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.
Tính khả dụng của tính năng

Các tính năng bạn có thể sử dụng phụ thuộc vào giải pháp Altium mà bạn đang có – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, hoặc Altium Designer (đang trong thời hạn hiệu lực).

Nếu bạn không thấy một tính năng được nêu trong tài liệu có trong phần mềm thực tế của mình, liên hệ Bộ phận Kinh doanh của Altium để tìm hiểu thêm.

Tài liệu cũ

Tài liệu Altium Designer không còn được phân phiên bản. Nếu bạn cần truy cập tài liệu cho các phiên bản cũ hơn của Altium Designer, hãy truy cập mục Tài liệu cũ trên trang Trình cài đặt khác.

Nội dung