Giữ cho sơ đồ nguyên lý và PCB luôn đồng bộ
Altium Essentials: Transfer to PCB
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Sơ lược
- Tìm hiểu sự khác biệt giữa quy trình so sánh hai chiều và cập nhật trực tiếp, cùng các trường hợp sử dụng từng phương pháp.
- Hiểu những dữ liệu Altium Designer có thể đồng bộ giữa sơ đồ nguyên lý và PCB, bao gồm linh kiện, kết nối, các lớp và một số quy tắc thiết kế.
- Tìm hiểu cách các tùy chọn dự án như cài đặt Comparator (Bộ so sánh) và ECO Generation (Tạo ECO) ảnh hưởng đến quá trình đồng bộ và những thay đổi có thể áp dụng.
Tác vụ phổ biến nhất khi thiết kế từ sơ đồ nguyên lý sang PCB là giữ cho sơ đồ nguyên lý và PCB khớp nhau hoặc được đồng bộ. Dù bạn đang chuyển thiết kế đã vẽ sang một PCB mới lần đầu tiên hay chỉnh sửa thiết kế hiện có ở phía sơ đồ nguyên lý hoặc PCB, bạn đều cần một cách để giữ hai phía đồng bộ. Altium Designer cung cấp các khả năng đồng bộ thiết kế mạnh mẽ, giúp đơn giản hóa tác vụ này để người thiết kế có thể tập trung vào các khía cạnh sáng tạo của quá trình thiết kế.
Quá trình đồng bộ phát hiện và giải quyết các khác biệt giữa sơ đồ nguyên lý và PCB.
Việc đồng bộ thiết kế được thực hiện trực tiếp giữa các trình biên tập sơ đồ nguyên lý và PCB; không sử dụng tài liệu trung gian dạng netlist. Phần mềm sử dụng bộ máy so sánh để đối chiếu mọi khía cạnh của thiết kế và trình bày kết quả dưới dạng danh sách các khác biệt. Người thiết kế quyết định phía nào cần thay đổi để giải quyết các khác biệt, từ đó một tập hợp các lệnh thay đổi kỹ thuật (ECO) được tạo ra. Khi áp dụng các lệnh này, hai phía của thiết kế sẽ được đồng bộ trở lại.
Những gì có thể được đồng bộ?
Quá trình đồng bộ bảo đảm dữ liệu linh kiện và kết nối trên sơ đồ nguyên lý khớp với dữ liệu linh kiện và kết nối trên PCB. Ngoài dữ liệu linh kiện và kết nối, quá trình này còn bảo đảm các ràng buộc thiết kế khác, chẳng hạn như các lớp net, lớp linh kiện và quy tắc thiết kế, cũng được đồng bộ.
Cấu hình các tùy chọn so sánh
Dialog page: Tùy chọn cho dự án PCB, thẻ So sánh
Việc xác định chính xác dữ liệu sơ đồ nguyên lý và PCB what được so sánh được cấu hình trong thẻ So sánh của hộp thoại Options for PCB Project. Chọn Project » Project Options để mở hộp thoại.

Bộ máy so sánh tuân theo các thiết lập được xác định trong thẻ Comparator của hộp thoại Options for Project.
Vùng chính của hộp thoại chứa một danh sách lớn các loại so sánh, chẳng hạn như Different Designators và Changed Net Name, được chia thành 5 nhóm. Cột Mode ở bên phải có danh sách thả xuống cho từng loại, nơi bạn chọn chế độ so sánh, chẳng hạn như Find Differences hoặc Ignore Differences. Các phép so sánh dạng văn bản có thêm tùy chọn thứ ba cho phép so sánh không phân biệt chữ hoa và chữ thường.
Mặc định đối với dự án mới là tìm khác biệt cho mọi loại so sánh; hãy thiết lập các tùy chọn theo yêu cầu của dự án.
Ở cuối hộp thoại có các tùy chọn để thiết lập Object Matching Criteria. Việc đối sánh là một quá trình tinh vi, gồm nhiều lượt và không chỉ dựa vào việc so khớp chuỗi chính xác đơn giản. Để tìm hiểu thêm, hãy tham khảo phần Đối sánh các net và lớp .
Lưu ý tùy chọn Ignore Rules Defined in the PCB Only ở cuối hộp thoại; bật tùy chọn này để loại các quy tắc bạn đã xác định trong PCB khỏi quá trình so sánh.
Đồng bộ các lớp net và linh kiện
Dialog page: Tùy chọn cho dự án PCB, thẻ Tạo lớp
Ngoài dữ liệu linh kiện và kết nối, bạn cũng có thể tạo và đồng bộ các lớp cùng quy tắc thiết kế khi thực hiện Design » Update PCB.
Đồng bộ quy tắc thiết kế
Có thể xác định các quy tắc thiết kế trong sơ đồ nguyên lý bằng đối tượng tập tham số. Khi chọn đối tượng tập tham số, bảng điều khiển hoặc hộp thoại dạng modal Properties sẽ có vùng Rules. Nhấp vào danh sách thả xuống Add để thêm quy tắc thiết kế. Quy tắc sẽ được áp dụng cho net / bus / bó dây / các đối tượng nằm dưới vùng bao mà đối tượng tập tham số tiếp xúc.
Trong hình bên dưới, một quy tắc thiết kế ràng buộc độ rộng đang được áp dụng cho lớp net USB_data (lớp net này cũng được xác định trong tập tham số này, tại vùng Classes của danh sách thả xuống Parameters ).

Tập tham số được dùng để xác định một lớp net và một quy tắc thiết kế cho các net nằm dưới đối tượng vùng bao trên sơ đồ nguyên lý. Lưu ý rằng các đơn vị đo cần dùng được cấu hình ở cuối hộp thoại Chỉnh sửa quy tắc PCB.
Thêm quy tắc thiết kế trong sơ đồ nguyên lý
- Gắn một tập tham số vào net / bus / bó dây / vùng bao (thêm định nghĩa lớp net trong tập tham số nếu cần).
- Add một định nghĩa quy tắc trong tập tham số. Thao tác này sẽ mở hộp thoại Choose Design Rule Type, như minh họa ở trên.
- Chọn Rule Type cần dùng.
- Nhấp vào nút OK để mở hộp thoại Edit PCB Rule.
- Cấu hình các yêu cầu của quy tắc PCB theo nhu cầu. Lưu ý rằng các đơn vị đo cần dùng cho quy tắc PCB này được chọn ở cuối hộp thoại.
Trong cả hình bên trên và hình bên dưới, quy tắc thiết kế được xác định trong một đối tượng tập tham số gắn với vùng bao. Khi đưa định nghĩa lớp vào đối tượng tập tham số, một lớp net PCB cũng sẽ được tạo; và do có định nghĩa lớp, phạm vi áp dụng của quy tắc PCB sẽ là InNetClass('<PCB_NetClassName >').
Trong hình bên dưới, bạn sẽ thấy đối tượng tập tham số được hiển thị dưới dạng chỉ thị cặp vi sai. Đây là một loại đối tượng tập tham số đặc biệt, được đặt bằng lệnh Place » Directives » Differential Pair.

Chỉ thị cặp vi sai được dùng để xác định một lớp net và một quy tắc thiết kế, sau đó áp dụng cho các cặp vi sai được chỉ định.
Cấu hình các tùy chọn tạo ECO
Hộp thoại Options for Project cũng có tab Tạo ECO. Tab này xác định những thay đổi thiết kế nào có thể được tạo ECO. Thông thường, tất cả các tùy chọn này đều được bật, còn các tùy chọn trong tab Bộ so sánh của hộp thoại được dùng để cấu hình những thay đổi thiết kế nào sẽ được đồng bộ giữa sơ đồ nguyên lý và PCB.

Tab Tạo ECO xác định những loại thay đổi nào có thể được tạo ECO.
Tìm sự khác biệt
Tính năng đồng bộ thiết kế có thể phát hiện và xử lý các khác biệt theo cả hai chiều: từ sơ đồ nguyên lý sang PCB hoặc từ PCB trở lại sơ đồ nguyên lý.
Phần mềm có thể xử lý các khác biệt này bằng cách áp dụng thay đổi cho cả hai phía cùng lúc. Ví dụ, giả sử người thiết kế điện tử đã thay đổi giá trị của một tụ điện, trong khi người thiết kế PCB đã thay đổi footprint của chính tụ điện đó. Hai khác biệt này có thể được xử lý trong một quy trình cập nhật duy nhất, bằng cách áp dụng thay đổi trường Comment theo chiều từ sơ đồ nguyên lý sang PCB và thay đổi footprint theo chiều từ PCB sang sơ đồ nguyên lý.
Khi bộ so sánh đối chiếu dự án sơ đồ nguyên lý với PCB, một danh sách đầy đủ các khác biệt sẽ được tạo ra - ở giai đoạn này, chưa có giả định nào về việc phải thay đổi phía nào để đồng bộ lại chúng.
Có thể xem danh sách các khác biệt trong hộp thoại Differences between.
Các tùy chọn và điều khiển của hộp thoại Differences between
Về cơ bản, hộp thoại được chia thành ba vùng chính - Differences, Update và Change Order.
Các khác biệt
Vùng này của hộp thoại liệt kê tất cả các khác biệt mà Bộ so sánh đã tìm thấy giữa các tài liệu được chọn. Mỗi khác biệt được liệt kê trong cột tương ứng với tài liệu chứa nó. Các khác biệt được nhóm theo loại so sánh được liệt kê và bật trên tab Bộ so sánh của hộp thoại Project Options . Mục ở cấp nhóm này thể hiện số lượng khác biệt thuộc loại đó.
Nhấp đúp vào một mục để truy xuất chéo đến đối tượng trên tài liệu nguồn tương ứng.
Cập nhật
Sử dụng vùng này của hộp thoại để chỉ định tài liệu cần được cập nhật nhằm khắc phục khác biệt. Theo mặc định, tất cả các mục Decision ban đầu đều được áp dụng quyết định No Change .
Có thể xác định riêng quyết định cập nhật cho từng khác biệt bằng cách nhấp vào mục tương ứng trong cột Decision , sau đó chọn hành động cập nhật cần thiết trong hộp thoại Quyết định ECO xuất hiện tiếp theo. Chỉ cần chọn chiều cập nhật (tài liệu nào trong số các tài liệu được so sánh sẽ được cập nhật) hoặc hoàn toàn No Updates.
Lệnh thay đổi
Vùng này của hộp thoại liệt kê (đối với mỗi khác biệt mà bạn quyết định xử lý) hành động cần thực hiện, đối tượng chịu tác động của hành động và tài liệu sẽ được thực hiện hành động đó. Thông tin này được dùng để lập ECO tiếp theo nhằm thực hiện các cập nhật. Những hành động thường được liệt kê trong vùng này gồm:
- Remove - khi cập nhật theo chiều hướng đến tài liệu chứa đối tượng gây ra khác biệt; đối tượng sẽ bị xóa.
- Add - khi cập nhật theo chiều hướng đến tài liệu không chứa đối tượng gây ra khác biệt; đối tượng sẽ được thêm vào.
- Update - khi cả hai tài liệu đều chứa cùng một đối tượng nhưng đối tượng đó khác nhau ở một khía cạnh nào đó; đối tượng được thay đổi phụ thuộc vào chiều đã chọn.
Menu chuột phải
- Create Change Order - dùng để tạo Lệnh thay đổi kỹ thuật (ECO).
- Generate Report - dùng để tạo báo cáo về các khác biệt do Bộ so sánh tìm thấy. Các quyết định cập nhật và hành động mà bạn đã chọn sẽ được đưa vào ECO được tạo. Báo cáo sẽ được tải vào hộp thoại Report Preview. Sử dụng hộp thoại này để xem báo cáo trước khi xuất báo cáo sang một trong các định dạng được hỗ trợ hoặc in trực tiếp.
- << Update All in - dùng để đặt chiều cập nhật cho tất cả các khác biệt về phía tài liệu bên trái (nếu áp dụng được).
- Update All in >> - dùng để đặt chiều cập nhật cho tất cả các khác biệt về phía tài liệu bên phải (nếu áp dụng được).
- Reverse Direction For All - dùng để nhanh chóng đảo chiều cập nhật cho tất cả các khác biệt (nếu áp dụng được). Nếu việc đổi chiều cho một khác biệt không hợp lệ, mục đó sẽ được đặt thành No Change.
- Set No Action For All - dùng để nhanh chóng đặt quyết định cập nhật cho tất cả các khác biệt thành No Change.
- << Update Same Kind in - dùng để đặt chiều cập nhật cho tất cả các khác biệt có cùng loại so sánh với khác biệt đang được chọn về phía tài liệu bên trái (nếu áp dụng được).
- Update Same Kind in >> - dùng để đặt hướng cập nhật cho tất cả các khác biệt có cùng loại so sánh với khác biệt đang được chọn sang tài liệu bên phải (nếu áp dụng được).
- Reverse Direction For Same Kind - dùng để nhanh chóng đảo ngược hướng cập nhật cho tất cả các khác biệt có cùng loại so sánh với khác biệt đang được chọn, nếu áp dụng được. Nếu không thể thay đổi hướng cho một khác biệt, mục đó sẽ được đặt thành No Change.
- Set No Action For Same Kind - dùng để nhanh chóng đặt hướng cập nhật cho tất cả các khác biệt có cùng loại so sánh với khác biệt đang được chọn thành No Change.
- << Update Selected in - dùng để đặt hướng cập nhật cho tất cả các khác biệt đã chọn sang tài liệu bên trái (nếu áp dụng được).
- Update Selected in >> - dùng để đặt hướng cập nhật cho tất cả các khác biệt đã chọn sang tài liệu bên phải (nếu áp dụng được).
- Reverse Direction For Selected - dùng để nhanh chóng đảo ngược hướng cập nhật cho tất cả các khác biệt đã chọn (nếu áp dụng được). Nếu không thể thay đổi hướng cho một khác biệt, mục đó sẽ được đặt thành No Change.
- Set No Action For Selected - dùng để nhanh chóng đặt quyết định cập nhật cho tất cả các khác biệt đã chọn thành No Change.
- Invert Selection - dùng để chọn tất cả các khác biệt hiện chưa được chọn trong danh sách hoặc bỏ chọn các khác biệt đã được chọn.
Các điều khiển bổ sung
Các nút sau có ở cuối hộp thoại:
- Create Engineering Change Order - nhấp vào nút này để tạo ECO. Hộp thoại Engineering Change Order sẽ xuất hiện để bạn kiểm tra tính hợp lệ và thực thi các cập nhật nhằm đồng bộ hóa các tài liệu.
- Report Differences - nhấp vào nút này để tạo báo cáo về các khác biệt do bộ so sánh phát hiện. Các quyết định cập nhật bạn đã đưa ra và các hành động sẽ được đưa vào ECO được tạo. Báo cáo sẽ được tải vào hộp thoại Report Preview. Sử dụng hộp thoại này để xem báo cáo trước khi xuất báo cáo sang một trong các định dạng được hỗ trợ hoặc in trực tiếp.
- Explore Differences - nhấp vào nút này để tìm hiểu thêm về các khác biệt do bộ so sánh phát hiện trước khi tạo ECO. Hộp thoại Differences between sẽ đóng và bạn sẽ trở lại không gian làm việc chính với bảng Khác biệt đang mở. Bảng này sẽ chứa tất cả các khác biệt do bộ so sánh liệt kê, được phân loại giống như trong bộ so sánh. Sử dụng bảng này để truy chiếu đến đối tượng gây ra khác biệt trên tài liệu chứa đối tượng đó.
Để mở hộp thoại Difference between và xem danh sách các khác biệt:
-
Để mở hộp thoại Choose Documents to Compare như trong hình bên dưới, hãy chạy lệnh Project » Show Differences hoặc nhấp chuột phải vào mục của dự án cần dùng (hoặc một trong các tài liệu nguồn của dự án) trong bảng Projects và chọn lệnh Show Differences từ menu ngữ cảnh. Hộp thoại Choose Documents to Compare được dùng để chọn hai tài liệu/bộ tài liệu sẽ được so sánh, thông thường là so sánh dự án sơ đồ nguyên lý với PCB. Bạn cũng có thể dùng hộp thoại này để so sánh hai tài liệu bất kỳ bằng cách đánh dấu tùy chọn Advanced Mode. Ví dụ, bạn có thể so sánh một netlist với một PCB, hoặc một PCB với một PCB khác.
Nhìn chung, thiết lập mặc định của hộp thoại — ở chế độ cơ bản hoặc nâng cao — phù hợp với hầu hết nhu cầu so sánh thiết kế, khi cần so sánh các tài liệu nguồn và thiết kế PCB đích nhằm đồng bộ hóa chúng. Tuy nhiên, hộp thoại cũng cho phép so sánh các tài liệu khác; điều này có thể hữu ích nếu bạn cần tải các phiên bản của một dự án và so sánh các khác biệt giữa các tài liệu nguồn tương ứng.

Chọn PCB để so sánh với dự án sơ đồ nguyên lý. - Chọn PCB trong phần chính của hộp thoại, rồi nhấp vào OK để mở hộp thoại Difference between như minh họa bên dưới. Nếu tài liệu PCB hiện đã được đồng bộ với các tài liệu nguồn, một hộp thoại sẽ xuất hiện thông báo rằng không phát hiện khác biệt nào.
Hộp thoại Differences between sẽ mở. Bộ đồng bộ hóa hoạt động theo hai chiều. Điều này có nghĩa là bạn có thể chỉ định các cập nhật cho cả hai tài liệu trong cùng một ECO. Để đồng bộ hóa các tài liệu được so sánh, cần xác định với từng khác biệt liệu có thực hiện hành động hay không và thay đổi được thực hiện theo hướng nào — tức là chỉ định tài liệu cần được cập nhật để khắc phục khác biệt. Vì vậy, bước tiếp theo là gán hướng cập nhật cho từng khác biệt:
- Đối với một khác biệt riêng lẻ, nhấp vào cột Update để hiển thị bộ chọn hướng, như trong hình bên dưới.
- Đối với nhiều khác biệt cùng loại, nhấp chuột phải vào một tiêu đề, chẳng hạn như Footprint khác nhau, rồi chọn lệnh Update Same Kind cần dùng.
- Đối với tất cả các khác biệt, nhấp chuột phải vào vị trí bất kỳ trong hộp thoại rồi chọn lệnh Update All cần dùng.

Với mỗi khác biệt, phải đặt hướng cập nhật thì mới có thể tạo ECO để giải quyết khác biệt đó.
Nhấp vào nút Explore Differences để truy cập bảng Differences và xem xét các khác biệt như mô tả trong phần Khám phá các thay đổi thiết kế bằng bảng Khác biệt bên dưới.
Nhấp vào Report Differences để thiết lập và in/xuất báo cáo về các khác biệt do bộ so sánh phát hiện, các quyết định cập nhật đã chỉ định và các hành động sẽ được đưa vào ECO được tạo.
Sau khi đã gán hướng cập nhật, nhấp vào nút Create Engineering Change Order để mở hộp thoại Engineering Change Order, được mô tả trong phần Giải quyết các khác biệt - Áp dụng ECO bên dưới.
Khám phá các thay đổi thiết kế bằng bảng Khác biệt

Bảng Differences hiển thị các khác biệt giữa tài liệu theo cấu trúc phân cấp.
Tóm tắt
Bảng Differences được dùng để hiển thị các khác biệt về logic hoặc vật lý do bộ so sánh khác biệt tích hợp của phần mềm phát hiện khi so sánh các tài liệu thiết kế (ví dụ: khi so sánh hệ thống phân cấp tài liệu nguồn (sơ đồ nguyên lý) của một dự án với tài liệu thiết kế PCB). Bảng này cho phép bạn khám phá các khác biệt một cách tương tác trước khi quyết định tạo Lệnh thay đổi kỹ thuật (ECO) để đồng bộ hóa các tài liệu của dự án.
Truy cập bảng
Để mở bảng Differences :
- Chọn View » Panels » Differences từ các menu chính.
- Nhấp vào nút Panels ở góc dưới bên phải của không gian làm việc thiết kế, sau đó nhấp vào Differences.
Hiển thị các khác biệt
Cách sử dụng bảng Differences phụ thuộc vào mục tiêu của bạn:
- Phân tích tính toàn vẹn của toàn bộ dự án về nội dung và cấu trúc bằng cách phát hiện các khác biệt về logic trong hệ thống phân cấp của dự án.
- So sánh hai phiên bản của cùng một tài liệu sơ đồ nguyên lý hoặc PCB bằng cách phát hiện các khác biệt về đồ họa (vật lý) giữa chúng.
Hiển thị các khác biệt về logic
Việc so sánh các tài liệu dự án để tìm khác biệt về logic được thực hiện trong hộp thoại Choose Documents To Compare, được mở bằng cách nhấp chuột phải vào một dự án (hoặc tài liệu dự án) trong bảng Projects rồi chọn Show Differences từ menu ngữ cảnh tương ứng.

Nhấp chuột phải vào tên dự án rồi chọn Show Differences để mở hộp thoại Choose Documents To Compare.
Thông thường, tài liệu PCB sẽ được so sánh với hệ thống phân cấp tài liệu nguồn của dự án chứa nó để phát hiện các khác biệt về logic giữa nội dung thiết kế sơ đồ nguyên lý và nội dung thiết kế PCB.
Sau khi nhấp vào OK, nếu có bất kỳ khác biệt nào giữa các tài liệu đã chỉ định, hộp thoại Khác biệt giữa sẽ mở ra. Thông tin trong bảng Differences chỉ xuất hiện sau khi nhấp vào nút Explore Differences trong hộp thoại Differences between.
Bảng Differences sẽ chỉ hiển thị các khác biệt được liệt kê trong hộp thoại Differences between. Các khác biệt này được xác định bởi những lựa chọn trên thẻ Bộ so sánh của hộp thoại Project Options (Project » Options). Thẻ này liệt kê tất cả các loại so sánh, chẳng hạn như các khác biệt liên quan đến linh kiện, net và tham số. Việc đặt Mode cho từng loại so sánh thành Find Differences hoặc Ignore Differences sẽ quyết định liệu bộ so sánh khác biệt có chuyển kết quả vào hộp thoại Differences between hay không.

Thiết lập cách phát hiện và báo cáo các khác biệt trong hộp thoại Project Options .
Bảng Differences hiển thị các khác biệt tìm thấy giữa các tài liệu nguồn theo cấu trúc dạng cây, trong đó thư mục cấp cao nhất hiển thị tổng số khác biệt được phát hiện. Các thư mục con được tạo cho từng loại so sánh cụ thể xuất hiện trong hộp thoại Khác biệt giữa. Mỗi thư mục con liệt kê các khác biệt cụ thể đã tìm thấy; các khác biệt này tiếp tục được phân tách thành các đối tượng trên tài liệu gây ra chúng.
Nếu tài liệu liên quan đang mở (hoặc đang mở nhưng bị ẩn), việc nhấp vào một mục đối tượng trong bảng sẽ thực hiện truy tìm chéo đến đối tượng đó trên tài liệu.
Đối tượng được hiển thị bằng hiệu ứng thu phóng và làm mờ, trong đó đối tượng được làm nổi bật bằng cách làm mờ tất cả các đối tượng khác. Có thể điều chỉnh độ tương phản của hiệu ứng làm mờ bằng thanh trượt Dimming trong vùng Highlight Methods của trang Hệ thống - Điều hướng thuộc hộp thoại Preferences .
Hiển thị các khác biệt về vật lý
Việc so sánh đồ họa (vật lý) giữa hai phiên bản của cùng một tài liệu sơ đồ nguyên lý hoặc PCB về cơ bản được thực hiện giống như cách so sánh logic nêu trên, nhưng còn sử dụng Advanced Mode trong hộp thoại Choose Documents To Compare.
Thực hiện so sánh vật lý giữa các tài liệu bằng lệnh Show Differences (trong menu chuột phải của bảng Projects) để mở hộp thoại Choose Documents To Compare rồi đánh dấu ô Advanced Mode. Khi tất cả các tệp dự án đã hiển thị trong hộp thoại, hãy chọn hai phiên bản của một tài liệu để so sánh.

Chọn các tài liệu để so sánh vật lý từ hộp thoại Choose Documents To Compare trong Advanced Mode.
Nhấp vào OK sẽ tiến hành so sánh đồ họa và mở hộp thoại Khác biệt giữa như đã mô tả trước đó. Nhấp vào Explore Differences để mở danh sách khác biệt tương tác trong bảng Differences.
Bảng hiển thị các khác biệt tìm thấy giữa các tài liệu theo cấu trúc dạng cây. Thư mục cấp cao nhất hiển thị tổng số khác biệt được phát hiện. Các mục được tạo cho từng loại khác biệt, trong đó mỗi mục chứa các tham chiếu cụ thể và đối tượng liên quan (cổng, linh kiện, v.v.).
Chọn mục đối tượng của một khác biệt được phát hiện sẽ làm nổi bật và phóng to đối tượng đó trong không gian thiết kế của trình biên tập.
Lưu ý
- Nếu một đối tượng trong bảng nằm trên tài liệu hiện đang bị ẩn, tài liệu đó sẽ tự động được mở và trở thành tài liệu đang hoạt động trong cửa sổ trình biên tập thiết kế khi bạn nhấp vào mục tương ứng.
- Bộ lọc được áp dụng khi truy tìm chéo từ bảng Differences chỉ có hiệu lực tạm thời. Vì vậy, bạn vẫn có thể chọn hoặc chỉnh sửa các đối tượng thiết kế nằm ngoài phạm vi của bộ lọc.
- Thông tin trong bảng Differences sẽ bị xóa khi thực hiện một lần so sánh tài liệu mới hoặc biên dịch dự án chứa tài liệu.
- Sử dụng lệnh Project » Show Physical Differences từ các menu chính để phát hiện các khác biệt về vật lý giữa hai phiên bản của một tài liệu sơ đồ nguyên lý hoặc PCB, đồng thời hiển thị các khác biệt này bằng đồ họa khi xem hai tài liệu cạnh nhau trong không gian thiết kế. Tính năng Hiển thị khác biệt vật lý này chỉ cung cấp khả năng so sánh trực quan – không tài liệu nào trong hai tài liệu được so sánh có thể được cập nhật bằng cách tạo ECO. Tính năng này được dùng để so sánh hai phiên bản của cùng một tài liệu, nhưng nếu dùng để so sánh các tài liệu khác nhau, chẳng hạn như hệ thống phân cấp tài liệu nguồn của dự án với PCB, bảng Differences sẽ xuất hiện và liệt kê các khác biệt về logic được phát hiện.
Thực hiện cập nhật trực tiếp
Vì người thiết kế thường biết muốn áp dụng các cập nhật theo chiều nào và tất cả các cập nhật đó đều theo cùng một chiều, bạn có thể chọn bỏ qua quy trình phát hiện khác biệt và chỉ định chiều cập nhật vừa được mô tả.
Thay vì chọn lệnh Show Differences từ menu Project, bạn chọn lệnh Update từ menu Design trong trình biên tập sơ đồ nguyên lý hoặc trình biên tập PCB. Việc chọn trình biên tập để chạy lệnh sẽ xác định hướng áp dụng các thay đổi — từ trình biên tập this sang trình biên tập that. Ví dụ, bạn chọn Design » Update trong trình biên tập sơ đồ nguyên lý để chuyển tất cả thay đổi từ sơ đồ nguyên lý sang PCB.
Hộp thoại Differences between sẽ được bỏ qua và bạn sẽ chuyển thẳng đến hộp thoại Engineering Change Order.
Nếu tất cả các cập nhật đều được áp dụng theo cùng một hướng, hãy sử dụng lệnh Design » Update.
Giải quyết khác biệt — Áp dụng các ECO
Mỗi khác biệt được giải quyết bằng cách áp dụng một lệnh thay đổi kỹ thuật (Engineering Change Order — ECO). Các ECO được liệt kê trong hộp thoại Engineering Change Order, mỗi ECO nằm trên một dòng và có hộp kiểm Enable riêng.
Khi sử dụng hộp thoại Engineering Change Order:
- Khi hộp thoại mở ra, tất cả các thay đổi đều được bật; hãy tắt những thay đổi mà bạn muốn tạm hoãn. Hộp thoại hỗ trợ chọn nhiều mục — sử dụng menu ngữ cảnh khi nhấp chuột phải để chuyển đổi trạng thái bật/tắt của các ECO đã chọn.
- Sử dụng lệnh Cross Probe trong menu chuột phải để kiểm tra các đối tượng chịu ảnh hưởng của ECO đó.
- Sử dụng nút Validate Changes để kiểm tra xem có thể thực hiện các thay đổi hay không. ECO thường thất bại do không tìm thấy đối tượng — ví dụ, footprint PCB được chỉ định không tồn tại trong Các thư viện dựa trên tệp khả dụng, hoặc pad được chỉ định không tồn tại trên footprint.
- ECO cũng có thể thất bại vì một đối tượng cần thiết cho ECO đó chưa tồn tại, nhưng lại được thêm vào trong quá trình xử lý các ECO hiện tại. Trong trường hợp này, hãy chạy lại lệnh Update để hoàn tất ECO đó.

Mỗi thay đổi thiết kế được biểu diễn dưới dạng một ECO; hãy bật những ECO cần thiết.
Các tùy chọn và điều khiển của hộp thoại Engineering Change Order
Hộp thoại được chia thành hai vùng chính: Modifications và Status.
Các thay đổi
Vùng này của hộp thoại liệt kê tất cả các thay đổi cần thiết để đồng bộ hóa. Các thay đổi được nhóm theo loại như được liệt kê và bật trong hộp thoại Project Options - ECO Generation. Mục ở cấp nhóm này thể hiện số lượng thay đổi thuộc loại đó. Mỗi thay đổi cụ thể trong vùng này được liệt kê theo các thông tin sau:
- Enable - tùy chọn này xác định liệu thay đổi có được đưa vào khi thực thi ECO hay không. Nhấp trực tiếp vào hộp kiểm để chuyển đổi trạng thái giữa bật/đưa vào (được chọn) và tắt/loại trừ (không được chọn). Bạn có thể bật hoặc tắt hộp kiểm Enable bằng phím cách.
- Action - hành động cụ thể cần thực hiện. Các loại hành động phụ thuộc vào loại ECO cần thực hiện.
- Affected Object - đối tượng chịu ảnh hưởng của hành động.
- Affected Document - tài liệu mà hành động sẽ được thực hiện trên đó.
Menu chuột phải
Theo mặc định, tất cả các thay đổi đều được bật để đưa vào khi thực thi ECO. Hãy bật/tắt từng mục thay đổi theo nhu cầu, hoặc sử dụng các lệnh sau trong menu chuột phải để thay đổi trạng thái bật/tắt của nhiều thay đổi:
- Validate Changes - nhấp để kiểm tra tính hợp lệ của các thay đổi được bật để đưa vào ECO. Kết quả kiểm tra sẽ xuất hiện trong cột Check thuộc vùng Status của hộp thoại.
- Execute Changes - nhấp để thực thi ECO. Kết quả thực thi sẽ xuất hiện trong cột Done thuộc vùng Status của hộp thoại. Lưu ý rằng chỉ những thay đổi vượt qua bước kiểm tra tính hợp lệ mới được thực thi.
- Create Report - nhấp để tạo báo cáo về các thay đổi có trong ECO. Báo cáo sẽ được tải vào hộp thoại Report Preview.
- Cross Probe - nhấp để định vị chéo các đối tượng đích và đối tượng tham chiếu liên quan đến một hành động thay đổi trên các tài liệu sơ đồ nguyên lý và PCB tương ứng.
- Expand All - nhấp để mở rộng chế độ xem của tất cả các thay đổi trong danh sách.
- Contract All - nhấp để thu gọn chế độ xem của tất cả các thay đổi trong danh sách.
- Enable All - dùng để bật tất cả các thay đổi.
- Disable All - dùng để tắt tất cả các thay đổi.
- Enable Selected - dùng để bật tất cả các thay đổi đã chọn.
- Disable Selected - dùng để tắt tất cả các thay đổi đã chọn.
- Enable all of same Kind - dùng để bật tất cả các thay đổi cùng loại với thay đổi đang được đặt tiêu điểm.
- Disable all of same Kind - dùng để tắt tất cả các thay đổi cùng loại với thay đổi đang được đặt tiêu điểm.
- Invert Selection - dùng để nhanh chóng chọn tất cả các thay đổi hiện chưa được chọn trong danh sách và bỏ chọn những thay đổi đang được chọn.
Trạng thái
Vùng này của hộp thoại hiển thị thông tin trạng thái sau cho mỗi thay đổi được bật:
- Check - trường này hiển thị kết quả kiểm tra tính hợp lệ của thay đổi. Dấu tích màu xanh lá cho biết thay đổi được đề xuất được hỗ trợ và sẽ được thực hiện khi thực thi ECO. Dấu chéo màu đỏ cho biết thay đổi được đề xuất không hợp lệ và sẽ không được thực hiện khi thực thi ECO.
- Done - trường này hiển thị kết quả thực thi thay đổi. Dấu tích màu xanh lá cho biết thay đổi hợp lệ đã được thực thi thành công.
- Message - nếu thay đổi không vượt qua bước kiểm tra tính hợp lệ, một mục sẽ xuất hiện trong trường này (và cả trong bảng Messages), cho biết nguyên nhân không đạt.
Các điều khiển bổ sung
Các điều khiển sau có ở phía dưới hộp thoại và trong menu nhấp chuột phải:
- Validate Changes - nhấp để kiểm tra tính hợp lệ của các thay đổi được bật để đưa vào ECO. Kết quả kiểm tra sẽ xuất hiện trong cột Check ở vùng Status của hộp thoại.
- Execute Changes - nhấp để thực thi ECO và áp dụng các thay đổi hợp lệ trong đó. Kết quả thực thi sẽ xuất hiện trong cột Done ở vùng Status của hộp thoại. Hãy nhớ rằng chỉ những thay đổi vượt qua bước kiểm tra tính hợp lệ mới được thực thi.
- Report Changes - nhấp để tạo báo cáo về các thay đổi có trong ECO. Báo cáo sẽ được tải vào hộp thoại Report Preview.
- Only Show Errors - chọn tùy chọn này để chỉ hiển thị các lỗi của Lệnh thay đổi kỹ thuật (ECO). Các thay đổi đã được xác nhận hợp lệ sẽ không hiển thị. Việc chỉ hiển thị danh sách lỗi giúp bạn nhanh chóng xem xét và thực hiện các điều chỉnh cần thiết cho thiết kế để ECO tạo ra vượt qua hoàn toàn bước kiểm tra tính hợp lệ.
Tìm hiểu liên kết giữa sơ đồ nguyên lý và PCB
Ghép cặp linh kiện bằng mã định danh duy nhất
Mỗi linh kiện trên sơ đồ nguyên lý liên kết với linh kiện tương ứng trên PCB thông qua một mã định danh duy nhất (UID). UID được gán khi linh kiện được đặt trên trang sơ đồ nguyên lý, và giá trị này được chuyển sang linh kiện PCB khi thiết kế được chuyển sang trình biên tập PCB. Khi thông tin linh kiện được chuyển lần đầu từ các tài liệu sơ đồ nguyên lý nguồn sang tài liệu thiết kế PCB trống bằng Synchronizer, tất cả linh kiện sẽ tự động được liên kết bằng mã định danh duy nhất – thông tin ID của mỗi linh kiện trên sơ đồ nguyên lý được gán cho footprint linh kiện tương ứng.
Cơ chế này phù hợp với thiết kế đơn giản, nhưng không đủ để hỗ trợ thiết kế đa kênh. Trong thiết kế đa kênh, cùng một linh kiện trên sơ đồ nguyên lý được lặp lại ở mỗi kênh vật lý, đồng nghĩa với việc các linh kiện PCB lặp lại sẽ có cùng UID. Để xử lý trường hợp này, UID của linh kiện PCB được tạo bằng cách kết hợp UID của ký hiệu trang sơ đồ nguyên lý cấp cha với UID của linh kiện trên sơ đồ nguyên lý. Cú pháp UID trên PCB thay đổi đôi chút tùy theo cách tạo thiết kế đa kênh.
Với thiết kế đa kênh được tạo bằng cách đặt nhiều ký hiệu trang sơ đồ nguyên lý cùng tham chiếu đến một trang sơ đồ nguyên lý, mỗi ký hiệu trang có thể cung cấp một ID duy nhất, do đó UID trên PCB có định dạng:
\SheetSymbolUID\SchComponentUID
Với thiết kế đa kênh được tạo bằng từ khóa Repeat, chỉ có một UID của ký hiệu trang sơ đồ nguyên lý, nên UID trên PCB còn bao gồm giá trị ChannelIndex, theo định dạng:
\ChannelIndex+SheetSymbolUID\SchComponentUID
Khi các linh kiện chưa được liên kết
Ưu điểm của việc sử dụng UID để ghép cặp linh kiện giữa sơ đồ nguyên lý và PCB là cho phép các ký hiệu định danh không còn đồng bộ (chẳng hạn do đánh số lại linh kiện trên PCB nhiều lần), mà không có nguy cơ khiến sơ đồ nguyên lý và PCB không thể đồng bộ lại.
Nếu có một linh kiện trên sơ đồ nguyên lý hoặc PCB không có linh kiện tương ứng (cùng UID) trong trình biên tập còn lại, các tình huống sau sẽ xảy ra:
- Nếu linh kiện dư chỉ có trong trình biên tập nguồn, một ECO sẽ được tạo để thêm linh kiện đó vào trình biên tập đích.
- Nếu linh kiện dư chỉ có trong trình biên tập đích, một ECO sẽ được tạo để xóa linh kiện dư đó.
- Khi có các linh kiện chưa được ghép cặp trong cả hai trình biên tập, phần mềm cần được hướng dẫn cách xử lý, vì vậy hộp thoại Failed to Match Unique Identifiers sẽ mở ra.
Hộp thoại e Failed to Match Unique Identifiers
Các nút trong hộp thoại cung cấp những tùy chọn sau:
- Automatically Create Component Links - nhấp nút này nếu bạn biết rằng các linh kiện chưa được ghép cặp đã có ký hiệu định danh trùng khớp. Dựa trên ký hiệu định danh linh kiện, phần mềm sẽ gán các UID trùng khớp cho những linh kiện dư này. Với các linh kiện có thể ghép cặp theo ký hiệu định danh, mọi khác biệt về thuộc tính khác (chẳng hạn các tham số không khớp) sẽ khiến các ECO được tạo ra. Nếu có linh kiện không thể ghép cặp theo ký hiệu định danh, các ECO sẽ được tạo để thêm/xóa chúng (thêm linh kiện dư có trong trình biên tập nguồn, xóa linh kiện dư có trong trình biên tập đích).
-
Manual Component Links - nhấp nút này nếu bạn biết có các linh kiện tương ứng nhưng không biết trạng thái ký hiệu định danh của chúng. Hộp thoại Edit Component Links sẽ mở ra (được mô tả bên dưới), nơi bạn có thể chọn thủ công từng linh kiện nguồn và đích rồi chuyển chúng sang danh sách linh kiện đã ghép cặp, đồng thời gán cho chúng các UID trùng khớp. Sau đó, các ECO sẽ được tạo để đồng bộ ký hiệu định danh (và mọi thuộc tính linh kiện khác chưa khớp).
- Cancel - nhấp nút này để tạo các ECO nhằm thêm các linh kiện dư có trong trình biên tập nguồn và xóa các linh kiện dư khỏi trình biên tập đích.
Liên kết linh kiện thủ công
Bạn có thể kiểm tra và quản lý trạng thái liên kết giữa linh kiện trên sơ đồ nguyên lý và footprint linh kiện tương ứng trên PCB bất kỳ lúc nào trong hộp thoại Edit Component Links (trình biên tập PCB, lệnh Projects » Component Links).

Hộp thoại Chỉnh sửa liên kết linh kiện được dùng để phát hiện và giải quyết các UID không khớp, và được mở từ trình biên tập PCB.
Tóm tắt các tính năng của hộp thoại:
- Các linh kiện chưa được ghép cặp được hiển thị trong hai cột Un-Matched Components bên trái; các linh kiện có UID trùng khớp được hiển thị trong vùng Matched Components bên phải hộp thoại.
- Các nút mũi tên ở giữa hộp thoại được dùng để ghép cặp (hoặc hủy ghép cặp) thủ công các linh kiện đã chọn, hoặc hủy ghép cặp tất cả linh kiện hiện đang được ghép cặp.
- Nút Add Pairs Matched By và các tùy chọn ở phía dưới hộp thoại được dùng để quét danh sách linh kiện hiện chưa được ghép cặp và thử ghép cặp chúng theo các thuộc tính được bật (Ký hiệu định danh, Chú thích, Footprint).
- Khi nhấp nút Perform Update, mỗi linh kiện PCB mới được ghép cặp sẽ được gán UID của linh kiện tương ứng trên sơ đồ nguyên lý. Nếu bạn đã di chuyển bất kỳ mục nào trong Matched của hộp thoại trở lại các phần Unmatched , một hộp thoại xác nhận sẽ xuất hiện, thông báo rằng các liên kết linh kiện hiện có sẽ bị hủy nếu tiếp tục. Nhấp vào Yes để tiếp tục cập nhật; một hộp thoại thông tin sẽ xuất hiện, tóm tắt các liên kết linh kiện đã được sửa đổi trong tài liệu PCB. Một mục mới trong phần Matched được tóm tắt là Link Modified, còn một mục đã được liên kết trước đó nhưng nay đã bỏ ghép sẽ được tóm tắt là Link Removed.
- Sau khi dùng hộp thoại này để liên kết linh kiện thủ công, bạn nên kiểm tra trạng thái đồng bộ hóa (chạy lệnh Design » Update).
Ghép các net và lớp
Cả net và lớp đều có đối tượng cha (net hoặc lớp) và các đối tượng con (các thành viên của net hoặc lớp đó). Việc ghép các đối tượng này đòi hỏi cách tiếp cận khác với cơ chế UID dùng để liên kết linh kiện, nhằm hỗ trợ thay đổi đối tượng cha, các đối tượng con, hoặc cả đối tượng cha lẫn các đối tượng con của nó. Ví dụ, một thao tác đơn giản như đổi tên một net trên sơ đồ nguyên lý không nên đòi hỏi phải xóa net đó cùng toàn bộ các chân thuộc net khỏi PCB, rồi thêm net với tên mới, và cuối cùng thêm toàn bộ các chân vào net mới đó.
Để hỗ trợ điều này, phần mềm có các thuật toán ghép riêng để ghép net và lớp theo thành viên cũng như theo tên. Quá trình ghép được cấu hình trong phần Object Matching Criteria trên thẻ Comparator của hộp thoại Options for Project.

Thiết lập mặc định là ghép theo thành viên trước, sau đó theo tên loại đối tượng.
Việc ghép các loại đối tượng này được xử lý như sau:
- Trong quá trình đồng bộ hóa thiết kế, hành vi mặc định là trước tiên thử ghép theo thành viên, theo các thiết lập Min Match % và Min Match Member.
- Nếu ghép theo thành viên không thành công, phần mềm sẽ thử ghép theo tên (nếu tùy chọn Use Name Matching được bật).
- Nếu một trong hai quá trình ghép này thành công, bạn sẽ chuyển đến hộp thoại Engineering Change Order.
-
Nếu cả hai phương pháp ghép đều không thành công (hoặc tùy chọn Use Name Matching được đặt thành
Never), hộp thoại Match Manually sẽ mở.
- Nhấp vào No trong hộp thoại Match Manually sẽ bỏ qua quá trình ghép do người dùng thực hiện và chuyển thẳng đến hộp thoại Engineering Change Order. Vì bạn chưa thử ghép bất kỳ đối tượng nào chưa được ghép, phần mềm sẽ coi các đối tượng tham chiếu và đối tượng đích là không liên quan, do đó sẽ tạo các ECO để xóa Unmatched Reference Objects khỏi bo mạch và thêm Unmatched Target Objects dưới dạng các đối tượng mới.
- Nếu bạn nhấp vào Yes trong hộp thoại để ghép thủ công, hộp thoại Match sẽ mở như minh họa bên dưới (tiêu đề hộp thoại sẽ thay đổi cho phù hợp với loại đối tượng chưa được ghép).
Hộp thoại Match được dùng để ghép thủ công các đối tượng mà bạn biết là tương ứng với nhau. Để trống phía bên phải và nhấp vào Continue nếu bạn không chắc chắn.
Các tùy chọn và điều khiển của hộp thoại ghép
-
Unmatched <Object>
- Unmatched Reference Objects - liệt kê các đối tượng chưa được ghép. Sử dụng các điều khiển mở rộng/thu gọn để mở/đóng danh sách.
- Unmatched Target Objects - liệt kê các đối tượng đích. Sử dụng các điều khiển mở rộng/thu gọn để mở/đóng danh sách.
-
- nhấp để ghép các đối tượng tham chiếu và đối tượng đích đã chọn, đồng thời chuyển các đối tượng đã chọn từ vùng Unmatched sang vùng Matched Pairs.
-
- nhấp để chuyển các đối tượng đã chọn từ vùng Matched Pairs sang vùng Unmatched. Thao tác này sẽ bỏ ghép các đối tượng được chuyển.
-
- nhấp để chuyển tất cả các đối tượng từ vùng Matched Pairs sang vùng Unmatched. Thao tác này sẽ bỏ ghép các đối tượng được chuyển.
- Matched Pairs - liệt kê Reference Object và Target Object hiện đã được ghép.
- Continue - nhấp để chấp nhận các cập nhật ghép và mở hộp thoại Engineering Change Order.
- Trong hộp thoại này, chọn các đối tượng bạn muốn ghép trong Unmatched Reference Objects và Unmatched Target Objects, rồi chuyển chúng sang phần Matched Pairs của hộp thoại. Với các đối tượng này, phần mềm sẽ tạo một ECO để cập nhật tên cho khớp nhau và các ECO để xóa/thêm thành viên, sao cho các thành viên cũng khớp nhau.
- Nếu không chắc chắn, bạn không cần ghép các đối tượng thủ công. Với mọi đối tượng chưa được ghép, phần mềm sẽ coi các đối tượng tham chiếu và đối tượng đích là không liên quan, do đó sẽ tạo các ECO để xóa Unmatched Reference Objects khỏi bo mạch và thêm Unmatched Target Objects dưới dạng các đối tượng mới.
- Sau khi đã ghép các đối tượng mà bạn biết là tương ứng với nhau, nhấp vào Continue để mở hộp thoại Engineering Change Order.
- Nếu bạn nhấp vào Cancel, quá trình cập nhật sẽ kết thúc.
Ghép các quy tắc thiết kế
Các quy tắc thiết kế được định nghĩa trên sơ đồ nguyên lý cũng phải được liên kết với quy tắc tương ứng trên PCB. Nếu không có cơ chế liên kết, bạn sẽ không thể cập nhật quy tắc trên sơ đồ nguyên lý rồi chuyển những thay đổi đó sang PCB. UID được dùng để liên kết quy tắc thiết kế trên sơ đồ nguyên lý với quy tắc thiết kế trên PCB.
UID được tự động gán trong bộ tham số chứa định nghĩa quy tắc trên sơ đồ nguyên lý và được chuyển sang PCB trong quá trình đồng bộ hóa thiết kế.
Các quy tắc thiết kế sử dụng UID để ghép định nghĩa quy tắc thiết kế trên sơ đồ nguyên lý với quy tắc thiết kế trên PCB.
Thông thường, bạn không cần quản lý thủ công việc đối chiếu các quy tắc, trừ khi bạn đã chỉnh sửa thủ công UID trong hộp thoại PCB Rules and Constraints của trình biên tập PCB. Nếu các UID không khớp, phần mềm sẽ thêm một quy tắc mới vào PCB cho mỗi quy tắc trên sơ đồ nguyên lý không có quy tắc PCB tương ứng, đồng thời xóa mọi quy tắc thiết kế PCB không có quy tắc thiết kế tương ứng trên sơ đồ nguyên lý.
