工作区项目

Altium Designer 与 Altium 365 工作区相结合,支持一种面向项目生命周期开发阶段的高级项目架构,简化了版本受控项目的创建和持续工作流程。由工作区管理的集中式存储也使此功能成为其他协作服务的基础。

使用基于工作区的项目有以下主要优势:

  • 简化存储。无需决定存储位置。备份和其他基础服务均由系统负责。

  • 为协作功能奠定基础。

  • 强制实施版本控制。

  • 享受专用评论系统的优势。

  • 通知和状态。整个设计团队都能查看文档状态,包括本地修改。

  • 无需复杂设置即可开展并行 PCB 设计。

  • 能够与多人共享项目,允许他们编辑,或仅查看和评论。

  • 使用项目历史记录功能时可获得完整功能,包括与 VCS 相关的提交事件。

从技术上讲,项目由存储在工作区中的元信息组成,并与工作区内置的基于 Git 的版本控制紧密集成。典型工作流程如下:

  1. 用户创建新项目(通过 Altium Designer 中的创建项目对话框、工作区浏览器界面,或在 Altium Designer 中将现有本地项目上传至工作区)。创建时,用户需定义项目的名称和描述。

  2. 在工作区浏览器界面中或直接在 Altium Designer 中定义和管理项目的访问权限。

  3. 所有协作者均可在 Altium Designer 中选择并打开项目,随后项目会自动签出。

基于工作区的项目的优势在于,默认情况下它们就受版本控制,并且可以协同处理,无需操心共享驱动器、服务器、协作约定等事宜。版本控制由工作区内置的 Git 版本控制服务负责。所有项目均存储在工作区内名为 Versioned Storage 的单一设计存储库(Git 存储库)中。如果项目使用外部版本控制,您可以将其迁移为工作区中的项目,使设计文件托管在服务器自身的 Git 存储库中(实际上就是切换到工作区原生 VCS)。有关具体操作的详细信息,请参阅从外部 VCS 迁移到工作区原生 VCS。

您也可以将项目保留在本地(常规项目或基于 VCS 的项目),同时将其同步副本发布到线上,即发送到工作区。此方式称为 Simple Sync,可让您充分利用 Altium 365 提供的协作优势。

本文介绍如何通过工作区浏览器界面处理项目。有关在设计软件中处理项目的信息,请参阅熟悉 Altium 设计环境。

创建新项目

可以直接从工作区浏览器界面的 Projects 页面创建项目。该页面列出了工作区中所有已与当前登录用户共享的项目。要创建新项目,请单击项目列表上方的 按钮,然后选择菜单中 Create 组内的 Project 条目,打开 Create Project 窗口。

通过工作区浏览器界面创建新项目。通过工作区浏览器界面创建新项目。

Create Project 窗口最初以简化视图显示,其中包含以下字段:

  • Project Name – 输入所需的项目名称。

项目名称应以 A-Z、a-z 或 0-9 开头,且可以包含这些字符。允许使用下划线、连字符和空格,但空格只能用于名称中间(开头和结尾的空格将被忽略)。不能使用以下词语:AUX、COM1-COM9、LPT1-LPT9、CON、NUL 和 PRN。此外,名称不能包含以下字符:\ . / ? % * : | " < >。
  • Template – 选择可用的项目模板。关联的下拉字段会列出工作区中所有现有的项目模板(格式为 <Comment> (<ItemID>))。选择模板即会确定项目类型。如果您不想基于现有项目模板创建新项目,只需指定要创建的项目类型(使用列表中的 PCB Project 或 Multiboard 条目)。
  • Description – 输入项目描述(可选)。

要访问更多控件,请单击 按钮。将显示以下字段:

  • Parent Folder – 使用此字段指定在工作区文件夹结构中的哪个位置创建项目。该位置为当前打开的文件夹,否则默认为 Projects。请注意,新项目的默认文件夹路径在工作区浏览器界面的 Admin – Settings – Projects 页面上指定。在 Create Project 窗口中,单击字段右侧的 Change 链接,访问工作区的服务器文件夹结构,从中选择其他文件夹来存储项目。

    请注意,如果执行此过程时未在 Parent Folder 字段中选择可写文件夹,系统将自动创建 Personal Folder 结构以存储项目。这是一个以您的电子邮件地址命名的私有顶层文件夹,其中包含一个 My Projects 子文件夹。以下是其创建和使用示例:

    • 您无法访问新项目的默认文件夹(通常为 Projects),或该文件夹为只读(不可写)。在这种情况下,创建或上传的项目将存储在个人 My Projects 文件夹中。

    • Parent Folder 目标设置并非默认位置,但您对该文件夹只有查看权限(不可写)。在这种情况下,项目创建将被阻止,也不会向 My Projects 文件夹中添加内容。

有关更多信息,请参阅在没有文件夹写入权限的情况下创建项目。

  • 用户对工作区文件夹(包括 Projects 文件夹)的访问权限,由文件夹共享权限决定。这些权限可通过 Projects 页面的 Share 选项 ,或通过资源管理器页面(Admin – Explorer)进行配置。有关更多信息,请参阅管理项目创建权限。

  • 您可以根据需要,将项目组织为子文件夹层级结构。有关更多信息,请参阅创建项目文件夹层级结构一节。

按需定义新项目后,单击 。您将返回项目汇总列表,并在其中看到新创建的项目条目。

返回工作区浏览器界面的 Projects 页面后,即可看到新创建的项目。返回工作区浏览器界面的 Projects 页面后,即可看到新创建的项目。

项目最初将与创建该项目的设计人员(作者/所有者)及工作区管理员共享,并授予他们编辑权限。其他访问权限将取决于 管理–设置–项目 页面视图中的 Default permissions for new projects 设置:

  • 如果未启用此选项(默认状态),新项目将继承其所在“父”文件夹的共享权限,同时向该文件夹的所有者授予写入(Edit)权限。

  • 如果启用此选项,项目将采用该选项指定的共享权限,而不是继承父文件夹的权限。

有关更多信息,请参阅管理项目创建权限。

有关配置项目访问权限的更多信息,请参阅下文的共享项目。

上传现有本地项目

您也可以将现有设计项目上传到工作区。操作步骤如下:

  1. 单击项目列表上方的 按钮,然后在菜单的 Upload 组中选择 Project 条目。浏览并选择项目 ZIP 压缩包,然后单击 Open 开始上传。

  2. 弹出窗口将提示此次上传涉及的潜在文件数量(包含在所选文件夹中),并要求确认是否继续——单击 。

  3. 随后将显示 Upload Project 窗口。默认情况下,Project Name 将与现有项目一致——可根据需要修改,并添加适当的描述。Parent Folder 将设置为开始上传过程时处于活动状态的文件夹。单击该字段右侧的 Change 链接,访问工作区的服务器文件夹结构,从中选择其他文件夹来存储项目。如有需要,您可以将项目组织成多层子文件夹结构。有关更多信息,请参阅创建项目文件夹层次结构一节。按需完成设置后,单击 按钮。

  4. 上传将开始进行,完成后,项目汇总列表中将新增该项目的条目。

本地项目中任何现有的版本控制关联都将被忽略,上传的项目将成为一个完全托管、受版本控制且基于工作区的项目。本地源项目不会发生任何更改。

与新建项目一样,上传的项目将与所有者(上传者)及管理员共享,并授予他们编辑权限。其他共享访问权限由其父文件夹的权限集决定;如果启用了新项目的默认权限设置,则由该设置决定。

上传 Gerber 或 ODB++ 文件集

工作区也支持以压缩包格式上传生成的 Gerber/ODB++ 制造文件集,可通过 按钮菜单中的 Manufacturing Files 选项进行上传。上传过程与上述项目上传过程基本相同。

选择 New – Manufacturing Files – Gerber 选项,在 Windows 文件浏览器中浏览并选择 Gerber 文件集压缩包。

在 Upload Gerber 窗口中,根据需要修改建议的项目 Name(取自 Gerber 压缩包名称),并添加 Description。您可以使用 Change 选项指定不同于默认项目存储文件夹的项目存储位置。

上传的文件集将经过处理并添加到工作区项目集合中,最初显示 Gerber 图标,刷新或查看后将显示生成的预览图像。

选择 New – Upload ODB++ 选项,在 Windows 文件浏览器中浏览并选择 ODB++ 压缩包。

在 Upload ODB++ 窗口中,根据需要修改建议的项目 Name(取自 ODB++ 压缩包名称),并添加 Description。您可以使用 Change 选项指定不同于默认项目存储文件夹的项目存储位置。

上传的文件集将经过处理并添加到工作区项目集合中,最初显示 ODB++ 图标,刷新或查看后将显示生成的预览图像。

 

单击 Gerber/ODB++ 项目名称,或使用其关联菜单中的 Open 选项,在工作区专用的制造查看器中加载文件集。该查看器提供所有所含文件/层的合成视图,支持隐藏层或仅查看指定层,提供点到点测量功能,并允许添加评论。

有关这些选项的更多信息,请参阅 Web 查看器文档中的制造一节。

上传 OrCAD 设计

工作区的 OrCAD® 上传功能进一步扩展了 Altium 365 工作区可上传和解析的设计文件类型。包含适用原理图(*.dsn)和 PCB(*.brd)文件的压缩文件(*.zip)可通过 Projects 页面上 按钮中的 Design Files » OrCAD 选项上传,如下所示。OrCAD 设计将存储在 Altium 365 中,并纳入版本控制。

  • 目前,上传的压缩包需要包含适当的 *.opj 项目文件,其中记录原理图/PCB 文件的相对路径。

  • 支持 17.2 或更高版本的 OrCAD PCB 文件。

  • 有关更多信息,请参阅支持哪些 ECAD 文件?

选择 New – Design Files – OrCAD 选项,在 Windows 文件浏览器中找到并选择已压缩的 OrCAD 设计文件集。

在 Upload OrCAD 窗口中,根据需要编辑建议的项目 Name(取自 OrCAD 压缩包名称),并添加 Description。您可以使用 Change 选项指定不同于默认存储文件夹的项目存储位置。

上传的文件集将经过处理并添加到工作区项目集合中,最初显示为初始图标,刷新或查看后则显示生成的预览图像。

 

与其他工作区项目一样,双击项目磁贴,或从磁贴的 菜单或页面主 菜单中选择 Open 选项,即可打开上传的 OrCAD 设计。处理完成后,OrCAD 设计文件将被解析为原理图、PCB、3D PCB 和 BOM 列表项目视图。

请注意,查看器的设计导航树可在平面 File 视图和 Hierarchical 结构视图之间切换。

 

借助 Web 查看器提供的高级工作区功能,统一后的设计允许您在不同设计域视图之间快速交叉探查对象、搜索对象、跟踪/高亮显示网络、添加评论、与其他用户共享设计、查看历史记录、处理任务活动等。您还可以基于上传的 OrCAD 项目创建高级 Managed BOM 文档,以便审查、配置和共享可直接用于采购的 BOM 文件,其中的数据来自 Altium 丰富的供应链数据资源。有关详细信息,请参阅 BOM Portal 页面。

有关查看器功能与特性的信息,请参阅 Web 查看器页面。

上传设计的新版本

当 OrCAD 设计已上传到工作区,并且该设计有了新版本(例如外部承包商进一步修改后的版本)时,可以使用项目的 Upload New Version 选项更新现有工作区项目。由于现有项目存储在 Git 版本控制之下,此选项允许将新的设计更新作为该项目的新 VCS 修订版提交。所有此类提交(以及项目发布)事件都会被记录,并可在项目的历史记录视图中查看。

通过 OrCAD 项目磁贴的 菜单或主 菜单中的 Upload New Version 选项,上传现有 OrCAD 项目设计的新版本。

随后显示的 Upload Project 窗口会将 Project Name 和 Parent Folder 字段锁定为现有项目的对应值。添加有意义的 Description,然后确认上传新版本。

更新过程会提交项目的新 VCS 修订版。打开项目即可访问新版 OrCAD 设计及其包含的更改。

在项目视图中,您可以打开 History 视图,查看带有注释的项目提交事件时间线。此处,新版 OrCAD 设计所创建的提交已被手动标记为 Version 2。

您可以使用提交事件磁贴上的选项访问设计的早期版本,分别查看、复制(克隆)、与其他提交进行比较,以及将源文件下载为 ZIP 压缩包。

 

OrCAD 与 Altium 365 集成

除了支持将 OrCAD® 设计上传到工作区之外,Altium 365 还支持通过专用插件实现 OrCAD 与工作区之间的直接集成。

有关 Altium 365 ECAD 功能的信息,请参阅多 CAD 文件支持页面。

Altium 365 Plugin for OrCAD 是安装在运行 OrCAD 的计算机上的小型应用程序,可在两个环境之间提供双向设计数据交换。这种集成提供了一种便捷方式,让现有 OrCAD 安装也能利用 Altium 365 的数据管理优势。转移到工作区的 OrCAD 设计将存储在可跟踪历史记录的版本控制系统中,可用于协作、查看、共享、评论等。相关人员可通过 Web 浏览器访问,访问权限受权限设置控制。

如果尚未向您共享 Altium 365 Plugin for OrCAD 安装程序,可从此处下载:https://altium-install.s3.amazonaws.com/A365/A365OrCADPlug-in.exe

在运行 OrCAD 的计算机上下载并运行 Altium OrCAD 插件可执行文件,按照安装向导的提示操作;安装程序应会自动检测 OrCAD 的安装位置。

安装完成后,可通过 OrCAD 主菜单中的 Altium 365 条目访问该插件。您可以使用其中的菜单选项登录并将当前 OrCAD 项目保存到 Altium 365 工作区,或从工作区加载之前保存的项目。

通过 OrCAD 插件添加的 Altium 365 菜单,从 OrCAD 登录您的 Altium 365 工作区。

输入工作区 URL 及其登录凭据以登录。

连接后,您可以将当前设计保存到工作区(Save to Server)、从工作区导入之前保存的 OrCAD 设计(Open from Server),或在服务器的浏览器界面中查看当前已保存的设计(View in Server)。

将当前设计保存到工作区时,接受或编辑 Project Name,并添加可选的 Description。

上传成功通知中包含相应选项,可立即在工作区浏览器界面中查看已保存的设计。

导入设计的工作区视图提供了共享、评论、任务管理和 VCS 历史跟踪等附加功能。

 
  • 将 OrCAD 设计保存到 Altium 365 工作区,实际上会将这两个项目关联起来,以便在插件连接到工作区时实现数据同步。

  • 之后在 OrCAD 环境中进行的设计修改可随时保存到工作区,刷新或重新打开工作区项目后,即可显示更新后的设计数据。有关更多信息,请参阅使用新数据更新。

  • 如果已连接的工作区提供 Altium 365 设计评审功能,OrCAD Altium 365 菜单中的 Request for Review 选项将直接打开当前项目的工作区 Design Reviews 页面,您可以在此创建、访问和管理同行评审。

注意:OrCAD® 是 Cadence Design Systems, Inc. 拥有的美国联邦注册商标。所有对此商标的引用仅用于识别目的。使用此商标并不表示与 Cadence Design Systems, Inc. 存在任何关联,也不表示获得其批准或认可。

评论和任务支持

Altium 365 Plugin for OrCAD 通过 Comments and Tasks 面板,将 Altium 365 的增强协作功能引入 OrCAD。该面板通过实时同步评论和任务数据,与 Altium 365 直接通信。OrCAD 用户可以立即使用 Altium 365 的协作功能,例如创建和参与评论讨论串、向自己或其他用户分配工作请求(任务)、粘贴和查看相关图像,以及查看活动任务的优先级和进度状态。

有关使用 Altium 365 评论和任务的信息,请参阅网页查看器评论。

从 Altium 365 菜单中选择 Comments and Tasks 选项,打开插件的 Comments and Tasks 叠加面板。该面板将显示从已连接的 Altium 365 工作区项目中获取的所有现有文档评论和任务引用。

请注意,您必须登录 Altium 365 平台,才能启用 Altium 365 工作区与 OrCAD 之间的双向数据交换。

插件的 Comments and Tasks 面板本质上是已连接工作区中 Comments and Tasks 窗格的同步版本。因此,该面板提供了工作区窗格的大部分功能,但无法访问文档中放置的评论,因为 OrCAD 本身不支持文档评论。有关这些工作区功能的更多信息,请参阅使用评论窗格。

您可以在插件 Comments and Tasks 面板的上部添加新评论,评论将关联到当前活动的 OrCAD 文档。随时按下 F5 即可刷新面板数据。

在 Comments and Tasks 面板上部的评论输入框中输入适当文本,即可在 OrCAD 中添加评论。

如需提及其他用户,可输入 @ 字符,后跟其工作区成员名称,和/或从下拉用户列表中选择名称。

您可以将新的工作区任务分配给被提及的用户,或从 Assign a task to 下拉列表中选择的其他用户。

完成所有选项设置后,单击 按钮创建评论及可选的任务。

新评论将作为与当前文档关联的条目添加到 Comments and Tasks 面板中。该条目包含指向工作区任务的链接,以及表示其当前优先级和状态的图标。

工作区端的其他用户,或已登录 Altium 365 OrCAD Plugin 的其他 OrCAD 用户,可以继续在此讨论串中添加评论。

 

与 Altium 365 工作区的 Comments and Tasks 窗格一样,OrCAD 插件的 Comments and Tasks 面板包含以下选项和功能:

  • Comments and Tasks Filtering – 控制窗格中显示哪些用户的评论(或仅显示任务)。

  • Threads and Notifications – 将条目限制为当前文档中的条目和/或尚未解决的条目(默认设置)。如果启用了工作区电子邮件通知,可使用 Notification Settings 选项指定触发电子邮件提醒的评论范围。

  • Comment entry options – 使用评论的 菜单管理该条目,或根据该评论创建相应任务。

  • Comment image – Original Snapshot 控件可打开在文档中放置评论时自动捕获的屏幕截图。仅当评论通过 Altium 365 工作区放置时可用。

  • Task assignment – 从 Assign a task to 菜单中选择用户名,创建与评论关联的任务。仅在尚未分配任务时可用。

  • Link to associated Task – 选择评论中的任务标识条目,在工作区项目任务视图中打开该任务。任务优先级和状态的更改将反映在 OrCAD 的 Comments and Tasks 面板中。

上传 KiCad 设计

工作区的 KiCad® 上传功能提供了另一种可由 Altium 365 工作区上传和解析的 ECAD 设计数据来源。如下面所示,可通过 Projects 页面上 按钮提供的 Design Files » KiCad 选项,上传包含适用的 KiCad 原理图和 PCB 文件的压缩文件(*.zip)。处理后的 KiCad 设计将存储在 Altium 365 中,并纳入版本控制。

有关 Altium 365 ECAD 功能的信息,请参阅多 CAD 文件支持页面。

与其他工作区项目一样,您可以双击已上传 KiCad 设计的磁贴来打开它,也可以从磁贴的 菜单或页面的主 菜单中选择 Open 选项。处理完成后,KiCad 设计文件将被解析为原理图、PCB、3D PCB 和 BOM 列表项目视图。

选择 New – Upload KiCad 选项,在 Windows 文件浏览器中找到并选择已压缩的 KiCad 设计文件集。

在 Upload KiCad 窗口中,根据需要编辑建议的项目 Name(取自 KiCad 压缩文件名),并添加 Description。您可以使用 Change 选项,指定不同于默认存储文件夹的项目存储位置。

上传的文件集将经过处理并添加到工作区项目集合中,最初显示为初始图标,刷新或查看后则显示生成的预览图像。

双击已上传 KiCad 设计的磁贴,或从磁贴的 菜单或页面的主 菜单中选择 Open 选项,即可打开该设计。

使用顶部选项卡查看设计的原理图、PCB 和 BOM 文档。选择其他菜单和按钮选项,可访问设计查看器的各种功能。

 

该设计及其文档将提供 Altium 365 的高级功能,包括对象/层可见性控制、双向交叉探查、通过受控设计共享进行协作、文档评论、历史记录访问等。如果您有权访问 BOM Portal 应用程序,则可以根据该设计创建面向采购的 Managed BOM 文档,以管理其制造和供应商零件数据。

有关设计查看器功能和特性的信息,请参阅网页查看器页面。

当该 KiCad 设计有新版本可用时(例如外部承包商进一步完成设计工作后),可使用项目的 Upload New Version 选项()更新现有工作区项目。新的设计更新将作为新的 VCS 项目修订版本提交,并作为事件记录在项目的历史记录视图中。

上传 EAGLE 设计

Workspace 的 Autodesk® EAGLE™ 上传功能提供了另一种 ECAD 设计数据源,可将其上传至 Altium 365 Workspace 并进行解析。如下所示,在 Projects 页面上,通过 按钮中的 Design Files » EAGLE 选项,可上传包含适用的 EAGLE 原理图(*.sch)和 PCB 文件(*.brd)的归档文件(*.zip)。处理后的 EAGLE 设计将存储在 Altium 365 中,并纳入版本控制。

有关 Altium 365 ECAD 功能的信息,请参阅 多 CAD 文件支持页面。

与其他 Workspace 项目一样,您可以双击已上传 EAGLE 设计的磁贴,或从磁贴的 菜单或页面主 菜单中选择 Open 选项来打开设计。处理完成后,EAGLE 设计文件将被解析为原理图、PCB、3D PCB 和 BOM 列表等项目视图。

选择 New – Upload EAGLE 选项,在 Windows 文件浏览器中找到并选择已归档的 EAGLE 设计文件集。

在 Upload EAGLE 窗口中,根据需要修改建议的项目 Name(取自 EAGLE 归档文件名),并添加 Description。您可以使用 Change 选项指定不同于默认存储文件夹的项目存储位置。

上传的文件集将经过处理并添加到 Workspace 项目集合中,最初显示为图标,刷新或查看后将显示生成的预览图。

双击已上传 EAGLE 设计的磁贴,或从磁贴的 菜单或页面主 菜单中选择 Open 选项,即可打开设计。初始视图为原理图文档。

使用顶部的选项卡切换到其他设计视图,例如 2D 和 3D PCB 视图。选择其他菜单和按钮选项可访问设计查看器的各项功能。

BOM 视图的数据仅限于可从 EAGLE 设计文件中提取的信息,但您可以通过设计项目的 Create Managed BOM 选项()创建高级托管 BOM 文档。注意:此功能仅在启用 BOM Portal 时可用。

 

该设计及其文档支持 Altium 365 提供的高级功能,包括控制对象/层的可见性、双向交叉探查、通过受控设计共享进行协作、文档评论、历史记录访问等。如果您有权访问 BOM Portal 应用程序,则可以基于设计创建面向采购的 Managed BOM 文档,以管理其制造商和供应商零件数据。

有关设计查看器的功能和特性,请参阅 Web 查看器页面。

当该 EAGLE 设计有新版本可用时(例如外部承包商完成进一步设计工作后),可以使用项目的 Upload New Version 选项()更新现有 Workspace 项目。新的设计更新将作为新的 VCS 项目修订版提交,并以事件形式记录在项目的 历史记录视图中。

上传或创建托管 BOM

如果您的 Workspace 已启用 Altium 365 BOM Portal 应用程序,则可以上传 CSV/XLS 格式的 BOM 文件来创建 Managed BOM 项目条目,也可以直接从现有设计项目创建。托管 BOM 文件由 BOM Portal 解析和处理,最终生成可用于采购的 BOM 文档。这些文档会填充通过 Altium 数据资源获取的最新制造商/供应商信息,并且可以完全根据您公司的需求进行配置。

您还可以创建 Consolidated BOM,这是一种由多个现有托管 BOM 组成的复合 BOM。对于包含多块电路板或多个部分的项目,您可以利用此功能创建整个项目的采购 BOM,归并等效零件并优化订购数量。有关更多信息,请参阅 BOM Portal 页面上的合并 BOM 部分。

有关详细信息,请参阅 BOM Portal 页面。

要上传 BOM 文件,请从 按钮菜单的 Upload 组中选择 BOM 选项,浏览并选择适用的 CSV/XML BOM 文件,在 Upload BOM 窗口中输入其详细信息,然后确认上传。托管 BOM 文件默认保存在当前打开的文件夹或 Projects 文件夹中,其访问和管理方式与设计项目类似。

 

要从现有设计项目创建托管 BOM,请从项目磁贴的 菜单中选择 Create Managed BOM 选项,选择项目变体,在 Create Managed BOM 窗口中输入 BOM 详细信息,然后确认创建 BOM。

 

双击托管 BOM 的磁贴、单击其名称,或从相应的省略号菜单中选择 Open,即可打开托管 BOM。BOM Portal 应用程序将尝试自动识别并映射 BOM 参数(Description、Designator、Manufacturer Part Number 等);如果无法自动完成,则会引导您根据自己的选择逐步完成列映射。

参数数据成功映射后,系统将自动获取最合适的元器件制造商和零件供应商数据,标记任何兼容性或风险问题,并以图形方式展示 BOM 的“健康状况”概览。

 

创建项目文件夹层次结构

Related information: 管理内容结构与访问权限

Workspace 还支持在服务器结构中创建和管理项目文件夹。随后,您可以在所形成的文件夹层次结构中的任意文件夹内创建项目,或将项目移至其中。

要在(默认的)顶级 Project 文件夹下创建新文件夹,请单击项目列表上方的 按钮,然后选择菜单中 Create 组下的 Folder 条目。在出现的 Create Folder 窗口中,指定新文件夹的名称、父文件夹以及可选的描述。新文件夹始终创建在当前选定的文件夹下,后者将成为其父文件夹。新文件夹的权限继承自其父文件夹;如果该父文件夹的“所有者”不是当前用户,继承的权限也将包括该所有者的写入权限。

如果您已定义项目文件夹层次结构,请单击 Parent Folder 字段右侧的 Change 链接,访问 Workspace 的服务器文件夹结构,从中选择另一个父文件夹来创建新文件夹。

按需定义属性后,单击 。系统将创建新文件夹(子文件夹),并自动进入该文件夹。

创建用于存储项目的新文件夹(子文件夹)的示例。

创建用于存储项目的新文件夹(子文件夹)的示例。

创建用于存储项目的新文件夹(子文件夹)的示例。

 

根据需要继续创建更多文件夹,逐步构建用于存储和分类设计项目的文件夹层次结构。之后创建文件夹时,就可以选择这些文件夹作为父文件夹,如下图所示。

已定义的项目文件夹层次结构示例。已定义的项目文件夹层次结构示例。

浏览文件夹层次结构

Projects 页面的默认视图(图形视图)会显示 Projects 文件夹下的所有子文件夹。选中文件夹的详细信息会显示在右侧信息窗格中。

单击文件夹条目的名称可打开其内容,选择面包屑导航中的条目可返回文件夹层次结构的上一级,或选择主导航树中的 Projects 条目以返回项目的顶层。访问列表视图()时,也可以采用相同的方式进行导航。

共享文件夹

要修改现有项目文件夹的共享权限,请在 Projects 页面上选择该文件夹条目,然后从其关联的 控件中选择 Share 条目,或单击上方的 按钮。在 Share Item 窗口中,您可以为指定用户或组(Share Item With 条目)添加文件夹访问权限,并查看和修改文件夹现有的共享权限(位于 Share With 下)——所有者和管理员的固有权限无法更改。

只有管理员和文件夹所有者才能访问文件夹共享权限。

根文件夹 Projects 的共享权限只能由管理员通过 Explorer 页面进行修改。

在 Share Item 窗口中,可以添加和修改应用于所选文件夹的共享权限。在 Share Item 窗口中,可以添加和修改应用于所选文件夹的共享权限。

请注意,某些用户访问级别(查看、编辑或无访问权限)可能无法在 Shared With 条目中选择。这是因为更改访问级别会与从父文件夹继承的权限集冲突(导致权限降级)——默认情况下,所有用户都具有 Edit 权限。您可以在 Share Item 窗口的 Advanced Settings 下禁用 Inherit parent folder permissions 选项,将文件夹的权限与其父文件夹的权限分离,从而禁用权限继承并启用所有访问级别选项。

有关更多详细信息,请参阅管理内容结构和访问权限页面。

编辑文件夹

要编辑现有项目文件夹的属性,请在 Projects 页面上选择该文件夹条目,单击项目/文件夹列表上方的 控件,然后在关联菜单中选择 Edit 条目。

您也可以在 Projects 页面中选择所需文件夹的磁贴,然后从 图标的上下文菜单中选择 Edit 命令来进行编辑。当 Projects 页面处于列表视图时,请单击所需文件夹条目最右侧的 控件,然后从关联菜单中选择 Edit 命令。

根文件夹 Projects 无法修改。

在随后显示的 Edit Folder 窗口中,您可以更改文件夹的名称和描述。单击 按钮以确认所做的更改。

您可以随时编辑项目文件夹的 Name 和 Description 。您可以随时编辑项目文件夹的 Name 和 Description 。

在层次结构中移动文件夹

要将文件夹移动(重新定位)到层次结构中的其他父文件夹下,请在 Projects 页面上选择该文件夹条目,单击项目/文件夹列表上方的 控件,然后在关联菜单中选择 Move 条目。

您也可以在 Projects 页面中选择所需文件夹的磁贴,然后从 图标的上下文菜单中选择 Move 命令来进行移动。当 Projects 页面处于列表视图时,请单击所需文件夹条目最右侧的 控件,然后从关联菜单中选择 Move 命令。

根文件夹 Projects 无法移动。

随后将显示 Move folder 窗口,供您选择新的父文件夹。单击 按钮以执行移动。该文件夹及其包含的项目将一起移动,成为所选新父文件夹的子文件夹。

请注意,将文件夹(或项目/条目)移动到其他父文件夹的操作将遵循工作区的高级权限继承机制。

有关完整信息,请参阅管理内容结构和访问权限页面中的移动文件夹部分。

您可以随时在文件夹层次结构中移动文件夹。您可以随时在文件夹层次结构中移动文件夹。

移除文件夹

要从工作区中移除现有项目文件夹,请在 Projects 页面上选择该文件夹条目,单击项目文件夹列表上方的 控件,然后在关联菜单中选择 Remove 条目。

您也可以在 Projects 页面中选择所需文件夹的磁贴,然后从 图标的上下文菜单中选择 Remove 命令来进行移除。当 Projects 页面处于列表视图时,请单击所需文件夹条目最右侧的 控件,然后从关联菜单中选择 Remove 命令。

根文件夹 Projects 无法移除或删除。

随后将显示 Remove 窗口,供您确认移除操作。要继续删除,请单击 按钮。

该文件夹及其包含的项目将从文件夹层次结构中移除,页面将转到被移除文件夹的父文件夹。项目文件夹可以从回收站页面恢复或永久删除。随文件夹一起移除的项目可以从 Trash 页面恢复或永久删除,但只有该项目的所有者或工作区管理员才能执行此操作。

删除项目文件夹——将其发送到工作区的独立 Trash  区域。删除项目文件夹——将其发送到工作区的独立 Trash 区域。

浏览项目

工作区浏览器界面的 Projects 页面上的项目列表包含您有权访问的所有项目,并提供全面的项目管理功能和控件。使用 按钮可将页面切换为列表视图(),使用 按钮可将页面切换为图形视图(默认视图)。

工作区浏览器界面的 Projects 页面——处理项目的控制中心。此处显示的是该页面的图形视图。 工作区浏览器界面的 Projects 页面——处理项目的控制中心。此处显示的是该页面的图形视图。

项目列表会自动按上次修改日期排序,最近修改的项目显示在列表左上角(图形视图)或列表顶部(列表视图)。在图形视图()中,可以使用 按钮按名称、作者、所有者或上次修改日期对项目文档进行快速排序。

在列表视图()中,可以使用相应的列标题,按 Name、Author、Owner 或 Last Modified 对项目列表进行排序。单击一次按升序排序,再次单击则按降序排序。列名右侧的箭头指示当前的排序方向。在任一视图中选择的排序方式都会应用于两种视图。

项目筛选器

使用筛选器()下拉菜单中的选项,可将列表限定为特定所有者和/或文档类型,或两者的组合。

Filters 窗口提供项目文档 Type 或项目 Owner 的筛选选项。单击 选项可查看更多条目。

选择一种或多种项目类型,即可立即筛选项目网格视图,使其仅包含相应文档。使用该区域中的 Clear 或 Clear All 可恢复原来的显示。

选择一位或多位工作区用户,可筛选项目列表,使其仅显示这些用户拥有的项目。所有者通常是项目的作者/创建者。

如果您的工作区通过 Altium Agile 订阅启用,则还会提供一个 Has Access 筛选器。选择一位用户,即可查看其有权访问的项目文档。

Has Access 筛选选项还可让您快速查看一位或所有外部共享访客用户可访问的项目文档。

 

 

信息、选项和搜索

在默认的图形视图()中,项目或托管 BOM 的磁贴包含项目名称和上次修改日期。如果项目包含 PCB,项目磁贴会自动显示该 PCB 的俯视 3D 视图,而托管 BOM 磁贴则会显示从 BOM 本身提取的关键采购数据。

页面图形视图中选中的项目和托管 BOM 磁贴。页面图形视图中选中的项目和托管 BOM 磁贴。

在列表视图()中,每个项目条目包含以下信息:

  • Name – 项目名称。

  • Description – 为项目输入或生成的描述。

  • Author – 创建项目的用户。

  • Owner – 通常为作者,除非项目已转移给新的所有者。► 有关信息,请参阅转移项目所有权。

  • Last Modified – 项目上次修改的日期和时间。

两种项目视图(图形视图和列表视图)的列表右上角均提供以下控件(后续链接章节中有详细介绍)。这些控件作用于列表中当前选中的项目:

(共享)– 单击可打开共享窗口,其中包含与其他用户共享项目所需的所有控件。

(More)– 单击可访问更多选项:

  • Open – 单击可打开项目的详细管理页面。该页面将在浏览器的单独选项卡中打开。

  • Share(位于项目磁贴的 菜单中)– 单击可打开共享窗口,其中包含与其他用户共享项目所需的所有控件。

  • Move – 单击可打开移动项目窗口。在此,您可以从文件夹层次结构中的所有可用文件夹中,选择另一个父文件夹,将项目移至其中。

  • Edit – 单击可打开编辑项目窗口。在此,您可以更改项目的 Name、Description 和服务器 Parameters。Parent Folder 字段不可编辑,仅用于显示信息。要更改父文件夹,需使用移动命令。

  • Upload New Version – 选择此命令可浏览并上传项目的新版本/修订版。此选项通常用于已导入(上传)到工作区的设计项目,例如使用 OrCAD、KiCad、Eagle 等创建的设计。

  • Clone – 选择此命令可打开克隆项目窗口,其中提供了用于创建项目完全相同副本的控件。

  • Watch – 选择此命令可关注项目。您将通过工作区发送的电子邮件接收与项目相关的通知(例如更新、发布、参数和权限更改),前提是管理员已为工作区启用电子邮件通知。项目的创建者/所有者会自动设为关注该项目。

  • UnWatch – 选择此命令可取消关注项目,并停止接收与该项目相关的事件通知。

  • Create Managed BOM – 选择此命令可根据当前项目的源数据生成托管 BOM 文档。可通过 BOM Portal 访问托管 BOM。

  • Remove – 选择此命令可移除项目。随后会显示 Remove 窗口,供您确认删除。此操作为“软删除”,项目(包括其修订版和发布版本)将被移至工作区的 Trash 区域。

在图形视图中,所有命令均可直接从项目磁贴访问——单击 控件即可打开相应菜单。此外,在此视图中双击项目磁贴(或单击其名称)可进入项目的详细管理页面。在列表视图()中,所有命令均可通过项目条目最右侧 控件的菜单访问。

项目搜索

此外,还提供了项目 Search 功能,可用于搜索所有项目文件夹中的项目。您可以按工作区参数名称和值进行搜索,从而通过自定义项目参数(例如客户名称、项目编号)来优化搜索。在浏览器界面顶部的字段中输入搜索字符串的任意部分。列表将随之更新,仅显示属性中包含该搜索字符串的项目条目。

按项目参数搜索时,您可以搜索参数名称,也可以搜索某个现有参数的特定值。对于参数名称,如果名称中没有空格,请在搜索字段中输入字符串 <ParameterName> =。如果名称中包含空格,请按 "<ParameterName>" = 的形式输入字面字符串。通常会使用参数值进行搜索,例如客户名称(位于 Customer、Customer Name 等参数中)。在下面的示例中,完整(而非部分)搜索字符串为 "Customer Name"= CompanyXYZ。参数也可以用作简单的“标签”,通过定义特定项目类型、应用、状态等的参数来筛选项目列表。

搜索功能使用示例。此处使用部分搜索字符串,根据项目参数(Customer Name)的值查找项目。搜索功能使用示例。此处使用部分搜索字符串,根据项目参数(Customer Name)的值查找项目。

  • 搜索不区分大小写,但用引号括起的参数名称(本质上为字面值)区分大小写。

  • 要快速显示所有项目文件夹中的完整项目列表,请在搜索字段中输入 *。

  • 要清除搜索筛选,请单击左侧导航窗格中的主 Projects 页面条目,或清空搜索字段(x)。

属性窗格

如果尚未显示,请单击右侧窗格顶部的 Properties ,以访问 Properties 窗格。此窗格显示当前所选项目的详细属性信息。

在 Properties  窗格中访问当前所选项目的更多详细信息。在 Properties 窗格中访问当前所选项目的更多详细信息。

Properties 窗格中的属性数据由工作区从当前所选项目中提取或生成。窗格顶部区域显示电路板的 3D 视图(如果项目中包含 PCB),以及总体概况信息,包括项目名称、描述、所有者、创建时间、上次修改时间,以及指向项目父文件夹的链接。

其他属性按以下可展开的标题分组显示(附有示例图片说明):

  • Child Projects(仅限多板项目)– 列出多板项目中包含并链接的子项目 PCB。单击子项目链接,即可按常规方式在 Web 查看器中打开该 PCB 项目。

  • Child BOMs – 列出从项目生成并与其关联的受管 BOM 文档。

  • Who Has Access – 汇总有权访问该项目的工作区组、成员和外部共享访客。将鼠标悬停在图标上,即可查看相应共享访问权限的详细信息,下方文字中也提供了摘要。请注意,外部共享用户的访问图标带有黄色圆点。
    使用 Manage Access 命令可直接打开项目的 Share 对话框。请参阅下文的共享项目。

  • Issues(选择受管 BOM 时可用)– 按类别汇总受管 BOM 报告的所有 BOM 检查问题。有关相关信息,请参阅 BOM 错误检测与纠正。

  • Reports – 为当前所选项目生成的电气规则检查和设计规则检查(ERC 和 DRC),包括每份报告中的错误/违规数量。选择 ERC 或 DRC 条目,即可在项目中访问并查看报告详情。请参阅 Web 查看器中的 DRC 和 ERC 报告。

  • Parameters – 从项目设计本身提取或计算得出的完整详细数据集。单击 Show 控件可展开完整列表,单击 Hide 可再次收起。

  • Where Used – 列出将该项目用作子实体的关联项目,例如多板项目。单击列出的 Where Used 项目链接,即可打开相应的父项目。

  • Releases – 列出项目的发布版本。多个发布版本按顺序显示,最新版本位于顶部。单击某个条目可打开该发布版本,并通过 Manufacturing Portal 在单独的选项卡中显示。在此门户中,您可以查看和浏览已发布的文件数据、检查 BOM,以及查看设计本身的快照并添加评论;该设计是这些发布数据的来源。您还可以使用相关控件,以不同粒度下载制造数据(从完整数据集到单个生成的输出文件)。所选发布版本还可以作为 Manufacturing Package 直接发送给制造商。

活动窗格

如果尚未显示,请单击右侧窗格顶部的 Activity ,以访问 Activity 窗格。此窗格显示当前所选项目的活动信息。每条消息都突出显示与该项目相关的一项事件(属性更改、新提交、发布等)。最新事件显示在列表顶部。

在 Activity 窗格中访问当前所选项目的事件历史记录。在 Activity 窗格中访问当前所选项目的事件历史记录。

单击任意事件消息中的项目条目,即可访问该项目的详细管理页面。

共享项目

项目在工作区中可用后,您需要确定哪些用户能够实际访问该项目。这是通过共享项目来实现的,而非直接配置其访问权限。

默认共享设置

对于新建或已在工作区中可用的项目,默认会与以下用户或组共享:

  • 项目所有者,通常是创建项目(或将其放入工作区)的设计人员:拥有完整编辑权限。

  • Administrators 组:拥有完整编辑权限。

  • 其他用户或组,具体取决于从项目父文件夹继承的权限(通常共享给所有 Workspace Members),或由工作区管理员指定的一组固定默认权限。

新建项目的默认位置可在工作区界面的 Admin – Settings – Projects 页面上定义或更改。选择并编辑 Default path for new projects 字段,即可指定其他默认位置。新项目将存储在此位置,或用户当前打开的其他文件夹中,前提是用户拥有该文件夹的 Write 访问权限。

如果用户对 Projects 文件夹(或其他默认文件夹)没有写入权限(仅有 View 权限),则其在此位置创建的项目将存储在以用户电子邮件地址命名的顶层文件夹下的 My Projects 文件夹中,即其 Personal Folder 结构中。对于默认位置以外的文件夹,仅拥有 View 访问权限的用户将无法创建项目。

有关更多信息,请参阅无文件夹写入权限时创建项目。

在工作区浏览器界面的管理区域中管理新项目的默认位置。在工作区浏览器界面的管理区域中管理新项目的默认位置。

要指定新建项目的默认访问权限,可在 Admin –Settings – Projects 页面上启用 Default permissions for new projects 选项,这将覆盖新项目继承父文件夹权限的默认行为。启用后,此选项允许定义一组明确的访问权限,并将其应用于所有新建项目。如果所有新项目都在同一位置(例如 Projects 文件夹)创建,这种方式可能更合适。有关更多信息,请参阅管理项目创建权限。

在工作区浏览器界面的管理区域中,为新项目指定一组默认访问权限。在工作区浏览器界面的管理区域中,为新项目指定一组默认访问权限。

要配置项目文件夹的共享设置,可在 Admin – Explorer 页面上从文件夹条目的右键菜单中选择 Share Folder 选项;管理员或文件夹所有者也可以在 Projects 页面视图中进行配置,参见上文的共享文件夹。对于新激活的工作区,所有工作区成员均拥有根 Projects 文件夹的写入权限,用共享设置的术语来说,即向 Workspace Members 授予 Write 权限(所有用户都可以向该文件夹添加内容或编辑该文件夹)。

可以将共享对象更改为特定用户或组。不过,建议在此顶层文件夹下创建文件夹层次结构,通过对特定文件夹及其包含的项目应用自定义共享设置,精确控制共享范围(进而控制访问权限)。

  • 需要注意的是,工作区采用权限继承结构,因此对文件夹权限的添加或编辑会沿文件夹层次结构向下传播。有关更多信息,请参阅共享文件夹和条目。

  • 您可能无法更改(尤其是降低)文件夹从其父文件夹 继承的权限,除非在 Share 窗口的 Advanced Settings 下禁用 Inherit permissions from parent folder 选项,以“断开”该父子关系。请参阅相关信息。

Projects 文件夹是工作区的顶层文件夹,仅管理员可以访问。在此层级下创建受权限控制的文件夹层次结构,以管理工作区成员的访问权限。Projects 文件夹是工作区的顶层文件夹,仅管理员可以访问。在此层级下创建受权限控制的文件夹层次结构,以管理工作区成员的访问权限。

共享概述

要从工作区浏览器界面配置项目访问权限,请在界面的 Projects 页面上选择项目磁贴,然后从其 上下文菜单中选择 Share 命令,或单击上方的 按钮。当 Projects 页面以列表视图显示时,单击项目条目最右侧对应的 控件,然后从相关菜单中选择 Share 命令。

如果您是项目所有者、工作区管理员,或拥有项目的 Edit 权限和再次共享权限,则可以与其他用户共享项目。

以下 Share 窗口包含与其他用户共享项目所需的所有控件。

在工作区中集中管理设计项目后,与他人共享只需管理各个项目的权限即可。在工作区中集中管理设计项目后,与他人共享只需管理各个项目的权限即可。

共享用户会看到什么?

设计可以与工作区的其他成员、组织内的非工作区成员或组织外部的用户共享。采用后两种方式共享时(例如与承包商或合作伙伴共享),共享用户通常通过其 Altium 365 个人空间中的与我共享页面访问设计。作为外部共享访客,他们只能看到该项目,无法查看您的任何其他工作区数据,包括成员列表或库元件。

有关相关信息,请参阅此工作区访问知识库页面。

Note:如果您在共享过程中 Invite a User to your Workspace(见下文),随后将其接纳为新的工作区成员,该用户将能够查看工作区成员列表,以及与所有工作区成员和其所属组共享的所有项目。

注意事项:

  • 在权限方面,选中 Can Edit 选项时,用户或组便拥有项目的完整编辑权限。否则,他们只有查看权限。

  • Owner 和 Administrators 组始终拥有完整编辑权限(Can Edit)。

  • 除 Owner 和 Administrators 组外,可以将所有已包含用户或组的权限单独设置为 Can View 或 Can Edit,也可以完全移除其访问权限。

  • 对于从 Altium Designer 以镜像形式(Simple Sync)提供给工作区、而非纳入工作区版本控制(Git VCS)的项目,无法以编辑权限(Can Edit)进行共享,只有项目所有者可以编辑。
    ► 请参阅有关使 Altium Designer 项目可在线访问的信息。

  • 可以将项目明确共享给特定用户和/或组,也可以直接共享给工作区的任意成员(或所有成员)。

  • 如果您拥有足够的项目共享权限,则可以将项目共享给不属于您工作区的用户。此类用户将成为工作区的 External Share 用户,并可以按您指定的权限级别访问共享项目,但无法访问任何其他工作区数据。有关更多信息,请参阅与外部用户共享。

与特定用户或组共享

在工作区中与指定用户和/或组共享项目的步骤如下:

  1. 在 Share 窗口的 Share Project With 字段中添加所需的用户/组名称。要添加条目,请在该字段中开始输入所需的姓名、电子邮件地址或组名,然后从动态列表中选择匹配的用户/组。该列表仅包含经过筛选的工作区成员或组织内的用户,以及为工作区定义的现有组。您可以选择多个用户/组。要移除已输入的用户/组,请点击该条目对应的 控件。

要与组织外部的用户共享,无论其是否拥有 Altium 账户,都必须输入其完整的电子邮件地址并按下 Enter。

  1. 从相应的下拉菜单中选择 Can View 或 Can Edit,为添加的用户/组设置共享访问权限,其中后一个选项本身包含查看权限。该设置最初会应用于 Share Project With 字段中的所有条目(用户/组)。

  1. 如果您希望添加与此项目的共享安排相关的信息,请点击 控件以打开文本输入区域。

  1. 点击 Shared With 控件,可显示当前明确获准共享此项目的用户/组,默认包括 Owner 和 Administrators 组。

除 Owner 和 Administrators 组外,可以将所列所有用户/组的权限分别设置为 Can View、Can Edit、Owner,或完全移除其访问权限。点击当前权限状态即可显示相关控件。► 有关 Make Owner 选项的更多信息,请参阅 转移项目所有权。

  1. 要向工作区中的所有成员开放访问权限,请从 Workspace Members 条目的下拉菜单中选择适当的权限级别:Can View(只读访问权限)或 Can Edit(完整的读/写访问权限)。设置为 No access 时,仅所有者、管理员以及明确添加的共享用户可以访问。

    请注意,工作区的权限继承机制可能会禁用某些权限级别选项。 这是为了防止降低从父文件夹继承的权限,从而避免违反现有的父子继承关系。如果确实需要解除父子继承关系,请在 Share 窗口的 高级设置 中禁用 Inherit parent folder permissions 选项。

  1. 共享窗口的 Advanced Settings 包含一些选项,可用于控制哪些用户能够再次共享或下载与其共享的项目。这些设置分为工作区 Member 和访客级别的访问权限,可用于指定具有编辑权限(Can Edit)的用户能否共享项目,以及具有只读权限(Can View)的用户能否下载项目。

    例如,在实际应用中,您可以借此限制外部承包商进一步共享项目。 对于仅具有查看权限的用户,您还可以控制其能否下载原生数据(项目本身)和派生数据(例如生成的 Gerber 文件或 PDF 文件)。 他们仍然可以在 Web 界面中查看数据并发表评论。在上述各种情况下,均可分别为工作区内部人员(成员)和外部人员(外部共享用户)设置权限。

  • 如果仅具有查看权限的人员未获准下载,则只能通过 Web 界面查看项目。他们无法通过 Altium Designer 查看项目,因为这需要先下载项目。

  • 请注意,编辑者始终可以下载项目,而查看者始终无法共享项目。但是,项目查看者可以请求将项目共享给指定用户(),提交的请求随后可由任何具有该项目编辑权限的用户处理,详情如下。

从设计软件内共享项目时,需要使用 Altium Designer 21.3 或更高版本才能访问高级设置。

  1. 点击 按钮,确认更新后的项目共享权限。后续操作取决于受邀用户的类型:

  • 如果用户已是工作区成员,则会直接添加到项目的访问列表中。他们会收到电子邮件通知,告知项目已与其共享,以及其拥有的访问权限。他们可以在 Altium Designer 中打开项目(如果权限允许),也可以通过 Altium 365 平台界面访问项目(从 Projects 页面)。

  • 添加现有工作区组进行共享时,该组会直接添加到项目的访问列表中。组内所有成员都会收到电子邮件通知,告知项目已与其共享,以及其拥有的访问权限。他们可以在 Altium Designer 中打开项目(如果权限允许),也可以通过 Altium 365 平台界面访问项目(从 Projects 页面)。

  • 对于工作区外部的人员,项目将与其共享,并向其发送通知邮件,请参阅下文的 与外部用户共享。作为工作区的 External Share 用户(见下文),他们可以在 Altium Designer 中打开项目(如果权限允许),并通过其 Altium 365 个人空间中的 Shared with Me 页面访问项目。该电子邮件提供了通过 Altium 365 直接访问设计的方式。点击邮件中的 按钮后,他们将转到 Altium 365 Sign In 页面(除非已登录平台或其 Altium 账户)。登录后,他们将直接进入 Web 查看器,其中已加载共享的设计。

如果该人员没有 Altium 账户,则需要先注册一个账户,Altium 365 Sign In 页面上提供了注册链接。

在 Altium Designer 中,使用 File » Open Project 命令及相应的 打开项目对话框来访问项目。如果您是工作区成员,可以从已连接的工作区中选择要打开的项目。连接到工作区后,该工作区会显示在对话框的 Locations 区域中,以 图标标识,并显示为该工作区所使用的名称。列表中仅显示已与您共享(您有权访问)的项目。

与外部用户共享

与“外部”用户(非工作区成员)共享工作区项目的流程,取决于期望的结果以及当前用户自身对该项目的访问权限。用户可以通过为外部用户提供范围受限的 外部共享访问权限、提交 共享请求,或请求将其添加为 工作区成员,来与其共享项目。最后一种方式会创建用户 邀请请求,由工作区管理员接受或拒绝。

这些共享机制可用于您所在组织内的其他 Altium 账户用户、其他组织的 Altium 账户用户,以及没有 Altium 账户的用户(这些用户随后需要注册账户)。共享用户可获得的项目访问权限级别取决于项目的编辑和共享配置。

应用外部共享

拥有项目编辑权限和共享权限的用户(包括管理员)可以向外部用户提供受限的 External Share 访问权限来共享项目,而不会暴露任何其他工作区数据。

在 Share 窗口中,通过输入外部用户的 Share Project With 电子邮件地址与其共享项目时,确认 Share 窗口后,还会显示一个确认窗口,说明共享的方式及对象。保持 Request to have these people invited to your Workspace as Members 选项未勾选,并确认此窗口(),即可为外部用户启用 External Share 访问权限。如果勾选(启用)上述选项,请参阅提交邀请请求。

可在 Properties 窗格的 Who Has Access 列表中查看项目的外部共享状态,外部用户的图标上带有黄色圆点标记(将鼠标悬停在图标上可查看详细信息)。在项目 Share 窗口的 Share With 列表中,该用户条目会带有外部共享标签()。另请注意,管理员可以在 Team 页面下的外部共享选项卡中访问和管理外部共享条目。

外部用户可通过其个人空间或其有权访问的其他工作区中的 Shared With Me 页面,访问与其共享的项目。其访问权限级别(编辑/查看及共享权限)由共享过程中选择的选项决定。

在 Altium Designer 中,用户可以从 Open Project 对话框中的 Shared WIth Me 位置访问项目——更多信息请参阅工作区团队之外受邀的利益相关者。请注意,如果源工作区中已启用 Can Edit 共享权限,则可以在 Altium Designer(20.2 或更高版本)中编辑共享项目。在这种情况下,项目共享实际上是双向的,因此外部用户所做的更改也会反映在工作区中。

与工作区外部用户进行外部共享以供编辑,是一种适用于承包商的严格受控解决方案——您希望他们积极参与设计工作,但不希望将其纳入工作区成员。

更多信息,请参阅此工作区访问知识库页面。

提交共享邀请请求

拥有项目编辑权限的用户可以通过提交邀请请求,与外部用户共享项目(请求将其添加为工作区成员)。管理员接受请求后,这些用户将能够访问该项目以及工作区的所有数据和功能。

在这种情况下,共享确认窗口中的 Request to have these people invited to your Workspace as Members 选项处于勾选(启用)状态,随后显示的 Request Invitation 窗口允许在请求中添加备注和更多用户。点击 按钮进行确认后,系统会将该用户添加为 External Share (暂时),向工作区管理员发送访问请求电子邮件,并在 Team 页面的邀请请求选项卡下创建一条请求条目。

管理员通过批准或拒绝请求来处理此条目。请求获批后,该用户将从外部共享用户升级为新的工作区成员。与其他成员一样,其对项目的访问权限级别由共享过程中选择的选项决定。如果管理员拒绝请求,则该用户仍然仅具有 External Share 访问权限。

如果上述用户在被接纳为工作区成员后又被移除,其访问权限级别将降为 External Share。这意味着该用户仍可访问共享项目,但只能通过 Shared with Me 位置(例如其个人空间)进行访问。

提交共享访问请求

没有项目共享权限的用户,可以通过提交该项目的共享访问请求,申请与外部用户共享项目。任何对该项目拥有完整共享权限(Edit和共享)的工作区成员都可以处理该请求;如果获批,指定用户将获得该项目的外部共享访问权限。

在这种情况下,Share 窗口将提供为指定用户提交项目共享访问请求的功能()。拥有该项目编辑权限的用户会收到一封访问请求电子邮件,其中包含指向项目 Share 窗口的 Open sharing settings 链接。 

收到访问请求电子邮件的工作区用户,可以在项目 Share 窗口中处理对应的 Pending Approval 条目,为该用户指定适当的 Edit/View 权限,然后确认设置()。随后显示的确认窗口将发出警告,指出该用户位于工作区之外(并非工作区成员)。确认同意()后,该用户将获得项目的外部共享访问权限。 

如果请求中指定且已获准访问的用户是工作区的现有成员,而非外部用户,则将获得该项目的工作区级别访问权限。请参阅下文的 处理访问请求 。

通过添加新工作区成员进行共享

工作区管理员可以通过将外部用户添加为正式的工作区成员,立即与其共享项目,使其能够访问该项目以及工作区的所有数据和功能。

共享确认窗口中的 Request to have these people invited to your Workspace as Members 选项处于勾选(启用)状态,随后显示的 Invite Team Members 窗口允许在请求中添加备注和更多用户。点击 按钮进行确认后,将打开最后一个窗口,提示您外部用户将被添加为新成员。

点击该窗口中的 按钮以完成此过程。此前的外部用户现在已成为新的工作区成员。与其他成员一样,其编辑/共享访问权限级别由共享过程中选择的选项决定。

与您的组织共享

除了上述与特定用户或组共享项目的方式外,您还可以通过选择 Share 窗口中的 Anyone in <company> can access 选项,为组织的所有成员提供基本的只读访问权限。此处所指的组织成员以组织仪表板的用户页面中的定义为准。

仅应用此级别的共享时,组织内的所有注册用户都可以通过 Altium Designer 和各自的 Altium 365 个人空间中的 Shared with Me 选项访问项目。所有用户均只有只读访问权限,而项目所有者和工作区管理员仍可通过工作区本身保有完整访问权限。

请注意,应用于项目的任何特定共享设置(例如为某个工作区成员授予的 View/Edit 权限)都是在基本的组织范围共享之外额外生效的。例如,如果之后将项目与某个特定工作区用户共享,该用户便可以在工作区中访问该项目(具有所授予的权限),同时仍保有其个人空间中现有的组织级只读访问权限。

通过直接链接共享

您还可以共享项目的直接链接。单击 Sharing 窗口底部的 控件即可获取链接。该链接根据项目当前的共享权限提供访问:

  • For members of the Workspace – 其访问权限由 Workspace Members 条目的权限设置(No access、Can View、Can Edit)决定,或由针对其姓名(或其所属的组)明确设置的 Share With 条目所授予的权限决定。

  • For users outside of the Workspace – 其访问权限由针对其姓名明确设置的 Share With 条目及授予该姓名的权限决定。用户必须注册并登录 Altium Account 才能访问。他们将被归类为 外部共享 用户。

获取项目的直接链接,该链接的使用受 Sharing 窗口中现有共享权限的约束。获取项目的直接链接,该链接的使用受 Sharing 窗口中现有共享权限的约束。

链接会复制到剪贴板。使用此链接时,相应用户可在获得许可的情况下直接访问项目的详细管理页面。有关更多信息,请参阅下方章节。

此外,如果打开所提供链接的用户没有项目访问权限(即项目未与其共享),系统将提供提交访问请求的方式。

当用户无法访问链接指向的项目时,可以发送访问请求,再由相应的工作区用户处理,详见下文。

当用户无法访问链接指向的项目时,可以发送访问请求,再由相应的工作区用户处理,详见下文。

 

处理访问请求

用户提交访问请求后,哪些用户有权共享该项目(授予访问权限),由 Share 对话框中该项目的 Advanced Settings 决定,如上文所述。在此语境中,“编辑者”指具有项目编辑权限(Can Edit)的用户。请注意,工作区管理员和项目所有者始终可以共享项目。

如果在工作区的管理-设置页面中启用了电子邮件通知选项,系统也会向这些用户发送相应的访问请求电子邮件。收件人由项目 Sh 窗口中的高级设置决定,具体如下:

  • 当允许工作区成员中的编辑者进行共享时,管理员、项目所有者以及对该项目具有编辑权限的成员将收到访问请求电子邮件。

  • 当允许外部共享编辑者(工作区外部的编辑者)进行共享时,管理员以及对该项目具有编辑权限的访客级用户将收到访问请求电子邮件。

  • 当此项目的两个编辑者选项均未勾选时,只有管理员会收到访问请求电子邮件。

Note: 如果您已将项目设置为向所有工作区成员授予编辑权限,并将 Advanced Settings 设置为允许编辑者共享,则 all 工作区成员将收到共享请求电子邮件。

收到访问请求电子邮件的任何用户均可通过邮件中的 Open sharing settings 按钮处理请求。这将打开该项目的 Share 窗口,您可以在其中批准待处理的请求(授予 View 或 Edit 权限),也可以拒绝请求。 请注意,能否访问共享窗口中的 Pending approval 条目并不取决于是否收到 Access Request 电子邮件,您随时可以直接通过 Share 对话框处理请求。 指定共享权限后,请求访问的用户将获得相应级别的项目访问权限, 同时会收到一封电子邮件,确认共享审批流程的结果。

如果请求访问并已获批准的用户不是工作区的现有成员(即外部用户),则会获得该项目的外部共享访问权限。请参阅 上文的“提交共享访问请求”。

发送给项目所有者的访问请求电子邮件中包含一个直接链接,可转到该项目的共享属性。发送给项目所有者的访问请求电子邮件中包含一个直接链接,可转到该项目的共享属性。

共享多板项目

多板项目是一种特殊的项目类型,它包含多个 PCB 设计项目,用于构建完整的功能系统。各子项目链接到父级多板项目,以便从中获取数据,建立整个系统的电气连接和物理连接关系。

有关使用多板项目的更多信息,请参阅多板设计。

多板项目与其关联子项目之间的链接以相对路径形式保存在多板项目本身(*.PrjMbd)中,因此,当从设计客户端(Project » Make available Online)将这些项目保存到工作区 VCS 时,必须确保这些路径仍然有效。在实际操作中,这意味着要确保all这些项目已保存到工作区,并位于正确的文件夹结构中。不过,在大多数情况下,多板系统涉及的所有项目通常都位于同一个文件夹中。

共享多板项目时也需要考虑同样的问题。父级多板项目及其关联子项目应以相同的查看/编辑权限共享给相同的工作区成员。用户首次在设计客户端中打开多板项目时,还必须打开关联的子项目,并再次确保本地的相对文件夹结构正确。

多板项目及其子项目都需要作为独立项目在线保存、共享和打开。多板项目及其子项目都需要作为独立项目在线保存、共享和打开。

转移项目所有权

与工作区管理员一样,项目所有者(默认情况下为创建/添加该项目的用户)拥有完整的项目编辑权限,而拥有项目共享访问权限的其他成员则具有项目Share窗口中指定的Edit/View权限。

Share窗口显示当前的项目所有者,并提供将所有权转移给其他工作区成员的选项。Share窗口显示当前的项目所有者,并提供将所有权转移给其他工作区成员的选项。

项目的Owner状态及其固有的编辑权限可以通过项目Share窗口从一位工作区成员转移给另一位成员,让新所有者能够完全掌控该项目。管理员和当前项目所有者可使用此选项,且只能转移给其他工作区成员(不能转移给成员组,例如Engineers或Administrators)。

工作区成员必须已经拥有项目的共享访问权限,才能接收其所有者状态和权限集。随后,可通过Share窗口(Make Owner)中的权限下拉菜单,将该成员当前对项目的View/Edit权限设置更改为Owner。使用窗口中的按钮,然后在随后出现的警告窗口()中确认所有权转移。

使用权限下拉菜单中的Make Owner选项,将项目所有权转移给另一位工作区成员。使用权限下拉菜单中的Make Owner选项,将项目所有权转移给另一位工作区成员。

  • 所有权转移后,原所有者将被分配该项目的 Editing权限;如果项目未纳入版本控制(SimpleSync),则仅获得View权限。如有必要,新所有者或管理员随后可以更改原所有者的访问权限。

  • 如果所有者被从工作区成员中移除,则会自动启动所有权转移。当管理员通过工作区成员页面移除某位成员时,移除流程会要求为该成员拥有的所有项目和条目指定新的所有者。确认并完成转移后,新所有者将收到相应的所有权转移通知电子邮件(如果已启用)。

    有关更多信息,请参阅移除用户。

如果已启用工作区电子邮件通知,新项目所有者将收到一封所有权转移通知电子邮件。

访问项目的详细管理页面

Main page: 管理特定项目

工作区提供以 CAD 为核心、面向制造的高级项目视图。要打开此视图,请选择所需项目,点击项目列表上方的控件,然后在相关菜单中选择Open 条目。也可以直接双击列表中所需的项目条目。

在Projects页面的图形视图中也可执行此操作:选择所需项目的磁贴,然后点击控件,并从上下文菜单中选择Open命令。也可以点击磁贴中的项目名称。当Projects 页面以列表视图显示时,点击所需项目条目最右侧的控件,然后从相关菜单中选择Open 命令。

该项目的详细管理页面将在新的浏览器选项卡中打开,其中包含以 CAD 为核心的界面,提供设计、仿真、发布、历史记录和装配视图选项:

  • Design – 显示和浏览源项目设计文档、查看设计对象属性以及添加审阅评论。此视图使用网页查看器界面,通过四个不同的数据子视图呈现您的设计,分别显示源原理图、2D 电路板、3D 电路板和物料清单。此视图显示的是源项目数据的最新版本,而不是该项目的某个指定发布版本,因此可以视为进行中(WIP)视图。您可以审阅基础设计及其任何已定义的变体。
您可以在整个设计中以及各个适用的子视图之间搜索、选择、交叉探查和检查元件及网络。在以 2D 方式查看电路板时,您甚至可以进行测量。

  • Simulation – 允许您上传(拖放)电路仿真结果文件,并将其关联到当前项目或项目发布版本。这些文件实际上作为附件附加到项目中,使工作区成员能够查看和/或下载与当前打开的项目相关的仿真结果文档。有关更多信息,请参阅特定项目的管理 – 仿真。

  • Tasks – 允许您访问和管理适用于当前打开的设计项目的工作任务请求(Tasks)。任务以看板流程形式呈现,其进度状态(ToDo、InProgress 和 Resolved)按任务行排列。其中一行专用于 General Tasks,其余各行分别对应特定项目文档的任务。这些行中显示的任务与打开的项目相关联,在将项目评论分配给特定用户(工作区成员)时创建。从这个意义上说,工作区任务系统实际上是评论系统的扩展。您还可以通过 New 按钮创建常规任务,这些任务适用于当前项目,但不与项目评论或文档关联。

另请注意,根据您购买的软件访问权限级别,工作区还提供基于流程工作流的高级任务系统。

  • Releases – 查看项目的发布版本。您可以打开完整的发布数据或特定的装配数据包,这些内容将通过 Manufacturing Portal 显示在单独的选项卡上。在此门户中,您可以查看和浏览已发布的文件数据、检查 BOM,以及查看设计本身的快照并发表评论;该设计是这些发布数据的来源。无论是在 Releases 视图中,还是通过特定发布版本的 Manufacturing Portal,您都可以使用相关控件,以不同的粒度下载制造数据(从完整数据集到单个生成的输出文件)。您还可以将选定的发布版本以 Manufacturing Package 的形式直接发送给制造商。此外,您还可以直接比较 Gerber、原理图或 BOM 数据。有关更多信息,请参阅项目发布版本。

Altium 365 平台提供了专用的 Manufacturing Package Viewer,它是平台 Global Sharing 支持功能的一部分,可让世界各地的其他人员通过任意 Web 浏览器在您的工作区外部查看制造数据包,从而确保他们无法访问您的设计本身和其他宝贵的知识产权。有关更多信息,请参阅全局共享和制造数据包查看器。

  • Activities – 提供适用于当前项目的开放(当前活动)或已关闭(已完成/已终止)流程工作流的详细信息。这些通常包括 Ad-hoc、Milestone 和 Handoff 同行评审工作流等活动。是否可用取决于您的 Altium 软件访问权限级别。

    有关更多信息,请参阅活动。

  • Design Reviews – 创建和管理结构化的项目评审实例,并可将其分配给其他用户(评审人员)进行评估。评审由任务驱动,可以接受或拒绝,并提供设计快照、可自定义的检查清单、评论、文档附件和设计源文件比较等附加功能。是否可用取决于您的 Altium 软件访问权限级别。

    有关更多信息,请参阅设计评审页面。

  • History – 按时间顺序浏览与项目相关的重要事件,包括创建、提交、发布、克隆和 MCAD 交换。每当项目发生受支持的事件时,该事件都会以专用卡片的形式添加到时间线中,并在适用时提供各种操作。对于发布/提交事件,您还可以直接比较 Gerber(仅限发布事件)、原理图或 BOM 数据。有关更多信息,请参阅项目历史记录。

  • Assembly Assistant – 使用交互式装配助手工具,检查并逐步完成电路板装配过程。该工具将项目的详细 BOM 数据与其 2D/3D 装配视图整合在同一界面中,提供逐步完成装配过程所需的图形和元器件信息。有关更多信息,请参阅装配助手页面。

 

您也可以从 Altium Designer 内部访问项目的详细管理页面。对于活动项目,请使用主菜单中的 Project » Show in Web Browser 命令。或者,在 Projects 面板中右键单击项目条目,然后从上下文菜单中选择 Show in Web Browser 命令。通过 Altium Designer 的 Explorer 面板浏览项目时,如果该面板配置为默认的 Project View 而不是 Classic View,则可单击 按钮访问详细管理页面。

移动项目

要将项目移动(重新定位)到文件夹层次结构中的其他父文件夹下,请在 Projects 页面上选中该项目的条目,单击项目/文件夹列表上方的 控件,然后在相应菜单中选择 Move 条目。

您也可以在 Projects 页面的图形视图中执行此操作:选中所需项目的卡片,然后单击 控件,并从上下文菜单中选择 Move 命令。当 Projects 页面以列表视图显示时,单击所需项目条目最右侧的 控件,然后从相应菜单中选择 Move 命令。

此时将显示 Move project 窗口,您可以在其中选择新的父文件夹。单击 按钮执行移动操作。项目将被移动到选定的文件夹,页面也将跳转到该文件夹。

请注意,将项目移动到其他父文件夹的操作将遵循工作区的高级权限继承机制。

有关完整信息,请参阅管理内容结构与访问权限页面中的移动文件夹部分。

您可以随时将项目移动到项目文件夹层次结构中的任意文件夹。

您可以随时将项目移动到项目文件夹层次结构中的任意文件夹。

 

编辑项目

要编辑工作区中现有项目的属性,请在 Projects 页面上选中其条目,单击项目列表上方的 控件,然后从相应菜单中选择 Edit 条目。在随后打开的 Edit Project 窗口(以简化视图打开)中,您可以更改项目的 Name 和 Description。

也可以在 Projects 页面的图形视图中,选择所需项目的磁贴,然后点击 控件,并从上下文菜单中选择 Edit 命令。当 Projects 页面以列表视图显示时,点击所需项目条目最右侧的 控件,并从相应菜单中选择 Edit 命令。

您可以在任何阶段编辑项目的 Name 和 Description 。您可以在任何阶段编辑项目的 Name 和 Description 。

点击 按钮可访问 Edit Project 窗口中的其他字段。

点击 Advanced  按钮可访问其他字段。点击 Advanced 按钮可访问其他字段。

  • Requirements – 此字段适用于设计项目,可用于将相关的 需求门户模块关联到当前项目。建立关联后,即可在设计项目中实时访问需求;除非解锁,否则只能以只读方式访问。有关信息,请参阅使用需求。

  • Jira – 为工作区启用 Jira 集成后,即可使用此高级字段。它用于将设计项目关联到 Atlassian Jira® 项目,从而通过 Altium 365 的评论和任务功能,在两者之间实现任务双向同步。点击 Jira 输入字段,可从可用的 Jira 项目列表中进行选择。请注意,除非通过 Jira 应用程序配置向所有用户开放,否则此映射选项仅供管理员使用。有关更多信息,请参阅使用 Jira 任务页面。

  • Project – 此字段仅在编辑受管 BOM 项目时可用,用于指定 BOM 文档与 PCB 设计项目之间的关联。通过此关联,可以将源项目中的元器件数据同步到关联的 BOM。对于从项目创建的 BOM 文档,系统会自动定义此关联。请注意,如果重新定义或移除此关联,项目到 BOM 的同步将会中断。使用该字段的 选项可浏览并选择项目关联。

  • Parameters – 点击此控件可展开一个区域,在其中管理项目的服务器端参数。您可以添加 ()、编辑(行内编辑)或移除 () 参数名称/值对。

    编辑项目的服务器端参数。编辑项目的服务器端参数。

编辑项目的服务器端参数。

服务器端项目参数随项目一起保存在工作区中,并且只能在工作区内编辑。相比之下,设计端项目参数保存在项目文件 (*.PrjPcb) 中,可在 Altium Designer 中编辑。这两类参数均可在 Altium Designer 中用作特殊字符串:在设计工作区中选中已放置的文本字符串后,即可通过 Properties 面板访问。为项目定义的所有参数(包括设计端和服务器端参数)均可在 Project Options 对话框 (Project » Project Options) 的参数选项卡中查看。

点击 按钮以确认所做的更改。

克隆项目

要克隆现有项目,请在 Projects 页面上选择其条目,点击项目列表上方的 控件,然后在相应菜单中选择 Clone 条目。随后将显示 Clone Project 窗口。

也可以在 Projects 页面的图形视图中,选择所需项目的磁贴,然后点击 控件,并从上下文菜单中选择 Clone 命令。当 Projects 页面以列表视图显示时,点击所需项目条目最右侧的 控件,并从相应菜单中选择 Clone 命令。

您可以克隆项目,创建包含其工作文件的完全相同的副本。您可以克隆项目,创建包含其工作文件的完全相同的副本。

在 Clone Project 窗口中指定项目名称和可选的描述。默认情况下,将使用原项目名称并添加后缀“ – Copy”,同时预填默认描述。

请注意,克隆项目的名称必须以 A-Z、a-z 或 0-9 开头,并且可以包含这些字符。允许使用下划线、短划线和空格,但空格只能用于名称中间(开头和结尾的空格将被忽略)。不能使用以下词语:AUX、COM1-COM9、LPT1-LPT9、CON、NUL 和 PRN。此外,名称不能包含以下字符:\ . / ? % * : | " < >。不能使用与源项目相同的名称。

点击 按钮可访问 Parent Folder 字段。默认情况下,此字段将设置为源项目所在的文件夹。点击字段右侧的 Change 链接可访问工作区的服务器文件夹结构,从中选择另一个用于存储克隆项目的文件夹。您可以根据需要,将项目组织为子文件夹层次结构。有关更多信息,请参阅创建项目文件夹层次结构部分。

按需设置各字段后,点击 按钮。原项目及其组成文件和数据将被克隆(复制),并作为新项目条目添加到 Projects 页面的列表中(位于所选父文件夹下)。由于创建的克隆实际上是一个新项目,其权限的设置方式与创建(或上传)新项目时相同,即默认从父文件夹继承权限,执行克隆的用户为所有者。另请参阅管理项目创建权限,了解相关信息。

移除项目

Related page: 回收站

要从工作区中移除(删除)现有项目,请在 Projects 页面上选择其条目,点击项目列表上方的 控件或项目磁贴内的 控件,然后在相应菜单中选择 Remove 条目。当 Projects 页面以列表视图显示时,点击所需项目条目最右侧的 控件,并从相应菜单中选择 Remove 命令。

只有项目所有者或工作区管理员才能执行移除操作。

随后显示的 Remove <project> 窗口将列出与项目相关且也将被移除的所有条目,例如关联的发布版本。选择 Show details 选项可打开项目的发布视图,查看其关联的发布版本和制造数据包。 如果项目没有关联的发布版本,则会显示简化的 Remove 窗口。

移除工作区项目的操作实际上是“软删除”,即将项目及其所有关联条目移至工作区的 Trash 区域。点击 Remove <project> 窗口中的 按钮,确认移除操作。

如果您只想软删除与某个特定项目关联的某个制造数据包,可以直接在该项目的 Releases 视图中执行此操作。

移除完成后,该项目条目将从项目主列表中移除。在 Altium Designer 中,您的本地工作副本不受此操作影响,但您将无法再向服务器提交更改。由于本地项目现在引用的 VCS 存储库已不存在,您可以关闭并重新打开本地工作副本,以查看一系列建议操作。

所有以这种方式移除的项目都可以在界面的 Trash 页面上找到。请注意,您只能查看由您本人软删除的项目(其他任何条目也是如此)。管理员可以查看 Trash 页面的全部内容,即所有已软删除的条目。

关于已软删除的项目,需要注意以下事项:

  • 您将无法从设计软件或 Web 界面中打开和浏览该项目。

  • 如果该项目曾与工作区外部的人员共享,则所有相关外部人员在 Altium 365 平台界面的 Shared with Me 页面上都将不再看到该项目的磁贴。

  • 随项目一起移除的任何已共享制造数据包,也将从所有相关人员的 Altium 365 平台界面的 Shared with Me 页面中移除。

  • 浏览项目中使用过的任何条目时,该项目的“使用位置”条目将显示该项目已被移除。

  • 只有项目所有者或工作区管理员才能从 Trash 页面恢复或永久删除项目。

请注意,如果您已软删除某个项目(将其移至 Trash),则可以再次创建同名的新项目。如果您随后恢复原项目,而其原名称已被占用,系统将添加整数后缀,以确保其名称在工作区内唯一。

AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

Contents