打开项目和文档

父页面: 熟悉Altium设计环境

要在Altium Designer中处理项目,首先应该打开它。这是通过在Altium Designer内部使用打开项目对话框来执行的,可以通过选择主菜单中的文件»打开项目命令来访问。 打开项目对话框提供了一个单一位置来打开、搜索和浏览项目。

使用打开项目对话框打开项目

打开工作区项目

要处理工作区项目,您实际上是将其作为本地工作副本签出。选择文件»打开项目命令后会发生什么取决于您是否是工作区团队的成员或者是否已经与工作区团队外的人共享了项目。

工作区团队成员

打开项目对话框将打开,在其中您可以从您连接的工作区中选择要打开的工作区项目(连接到工作区时,该工作区将出现在对话框的位置区域中,由图标区分,并以给定的工作区名称显示)。只有与您共享的工作区项目(您有权限访问它们)才会被列出。

当选择工作区位置时的打开项目对话框
当选择工作区位置时的打开项目对话框

列表中的每个项目都会显示以下信息:

  • 名称 – 项目的名称;项目的位置路径显示在名称下方。
  • 最后修改 – 项目最后修改的日期和时间。日期和时间会根据您个人电脑的设置显示。如果您想以特定格式配置每个项目的修改日期和时间,您可以在电脑的系统区域设置中进行配置。

    可以通过点击(并切换)每列标题,对名称最后修改列进行升序或降序排序。

要查看和导航项目文件夹层次结构,请选择文件夹视图按钮()以在对话框的搜索栏中访问项目文件夹和面包屑路径。

对话框中的项目列表视图。将光标悬停在图片上以查看文件夹结构视图。
对话框中的项目列表视图。将光标悬停在图片上以查看文件夹结构视图。

当对话框中启用文件夹视图,并且如果您的项目位于文件夹中,将出现一个文件夹条目(),您可以双击它以查看位于其中的现有项目。

当点击时,对话框的右侧将显示有关所选项目的额外详细信息,包括基本项目信息(详细信息窗格的常规标签)和所有项目参数(详细信息窗格的参数标签)。

通过点击打开按钮打开项目后,项目将出现在工作区的一个条目下,在项目面板中。

从您连接的工作区内,选择要在Altium Designer中打开的工作区项目,从那些当前与您共享的项目中选择。
从您连接的工作区内,选择要在Altium Designer中打开的工作区项目,从那些当前与您共享的项目中选择。

  • 您可以选择将项目打开到默认的签出路径,或使用 下拉菜单指定自定义路径。默认的签出路径是作为项目所在的设计仓库的属性定义的。对于Git仓库(例如,原生于工作区的版本存储仓库),这是在Git仓库对话框中找到的本地路径字段。对于SVN仓库,这是在SVN设计仓库对话框中找到的默认签出路径字段。通过在首选项对话框的数据管理 - 设计仓库页面上选择仓库的条目,然后点击 按钮来访问属性对话框。
  • 选择作为副本打开项目选项,以不同的名称创建项目的克隆版本。了解更多关于克隆项目

 

在登录您的Altium账户、连接到工作区或激活工作区之前,访问Altium 365位置的打开项目对话框时,对话框的右侧将显示相关文本和控件。

工作区团队外的受邀利益相关者

打开项目对话框将打开,在其中您可以访问已与您共享的共享给我的位置的任何工作区项目。

当选择共享给我的位置时的打开项目对话框
当选择共享给我的位置时的打开项目对话框

列表中的每个项目都会显示以下信息:

  • 名称 – 项目的名称。
  • 创建者 – 创建项目的人的名字。
  • 最后修改 – 项目最后修改的日期和时间。日期和时间会根据您个人电脑的设置显示。要以特定格式配置每个项目的修改日期和时间,您可以在电脑的系统区域设置中进行配置。

    可以通过点击(并切换)每列的标题,对名称最后修改列进行升序或降序排序。

通过点击打开按钮打开后,所选项目将出现在条目共享给我的下,在项目面板中。您能对项目做什么取决于您被赋予的访问权限。如果被分配了编辑权限,您将能够正常编辑设计,这通常是外部承包商的情况。如果您只有查看权限,您将能够评论正在进行中的设计。

共享给我的下可用的项目是那些已经从Altium 365工作区共享给您的登录名(您的Altium账户)的项目。请注意,无需连接到工作区即可访问共享项目。

从Altium Designer内部选择要打开的工作区项目,从那些当前作为外部利益相关者与您共享的项目中选择。请注意,访问这些项目无需访问工作区。
从Altium Designer内部选择要打开的工作区项目,从那些当前作为外部利益相关者与您共享的项目中选择。请注意,访问这些项目无需访问工作区。

您可以选择将项目打开到默认的签出路径,或使用 下拉菜单指定自定义路径。默认的签出路径取自首选项对话框中的系统 - 默认位置页面文档路径字段。

当更新的项目文件名已同步到工作区时,工作区会自动更改工作区项目的名称参数以匹配。相反,当工作区中的工作区项目名称在工作区更新(通过工作区项目页面上的编辑模式或设计客户端的资源管理器面板),更改在下次打开项目时传播到客户端。当打开更新的项目(文件 » 打开项目)时,将打开项目名称和项目文件名不同对话框,提供将项目文件名与新项目名称对齐、强制项目名称与现有项目文件名匹配或允许两个名称不同的选项。

打开本地项目

选择本地项目位置,查看当前默认位置中存储的项目列表,该位置在首选项对话框的系统 - 默认位置页面中指定。

当选择本地项目位置时的打开项目对话框
当选择本地项目位置时的打开项目对话框

列表中的每个项目都显示以下信息:

  • 名称 – 项目的名称;项目的位置路径显示在名称下方。您可以双击文件夹图标()查看其中的现有内容。
  • 最后修改 – 项目最后修改的日期和时间。日期和时间根据您个人电脑的设置显示。要以特定格式配置每个项目的修改日期和时间,您可以在电脑的系统区域设置中进行配置。

    可以通过点击(并切换)每列的标题,按升序或降序对名称最后修改列进行排序。

当点击时,对话框的右侧会显示列表中当前选中的项目的名称、最后修改日期/时间和位置。

通过点击打开按钮后,所选项目将出现在项目面板中。

打开项目对话框的左下角点击浏览按钮,通过Windows 打开对话框浏览并打开一个项目。

打开最近的项目

选择最近位置,可以看到最近从本地或工作区源打开的项目列表。

当选择本地项目位置时的打开项目对话框
当选择本地项目位置时的打开项目对话框

列表中的每个项目都会显示以下信息:

  • 名称 – 项目的名称;项目的位置路径显示在名称下方。
  • 最后修改 – 项目最后修改的日期和时间。日期和时间会根据您个人电脑的设置显示。如果您想以特定格式配置每个项目的修改日期和时间,可以在电脑的系统区域设置中进行配置。

    可以通过点击(并切换)每列的标题,对名称最后修改列进行升序或降序排序。

当点击时,对话框的右侧会显示当前在列表中选中的项目的名称、最后修改日期/时间和位置。

最近的项目、文档和项目组也可以通过文件主菜单打开:了解更多

搜索项目

打开项目对话框顶部使用搜索字段,通过输入字母/数字字符来过滤项目列表。在打开工作区项目时,搜索过滤器也会响应来自工作区项目的参数/值对。这些包括项目和工作区参数,以及由工作区生成的分析参数。

 
 
 
 
 

点击搜索栏右侧的图标来移除当前定义的搜索字符串。

 

在查看工作区项目列表(在文件夹结构视图中)或本地项目列表时,当前选中文件夹的路径将显示在搜索栏中。点击文件夹名称以在对话框中显示该文件夹的内容。点击栏右侧的按钮或使用Alt + 上箭头快捷键来显示上一级文件夹的内容。

项目组

在Altium Designer中,您可以打开和编辑多个项目,并且如果需要,可以将一组项目保存为项目组(*.DsnWrk)。在项目面板中,当前项目组的条目——无论是默认的(Project Group 1.DsnWrk),还是您创建或打开的项目组——都会显示 图标。

当一组项目是相关联或链接的时候,这特别有优势,比如由多个PCB组成的产品设计。创建一个包含所有相关项目的项目组,可以让您作为单一实体打开、操作和保存多个项目。

当以下情况发生时,一个默认的设计项目组(ProjectGroup1.DsnWrk)会被分配到项目面板:

  • 没有特定的设计项目组被打开。
  • 指定创建一个新的设计项目组。
  • 当所有打开的项目和文档——无论是否属于特定的设计项目组——都被关闭。

这个默认的设计项目组最初是未保存的。它的名字被用作另存为对话框中的默认条目,当您继续保存设计项目组时。

打开文档

要打开文档,在项目面板中双击它,或右键点击其条目并从上下文菜单中选择打开命令。可以同时打开多个文档,每个打开的文档在设计窗口顶部的文档栏上都有自己的标签。

如果您在首选项对话框的系统 - 项目面板页面单击区域中启用了打开并显示文档/对象选项,那么在面板中单击文档条目将会在主设计窗口中打开它。

您也可以按以下方式打开文档:

  • 通过从编辑器的主菜单中选择文件»打开命令(按钮位于快速访问栏;快捷键:Ctrl+O)。以这种方式打开的任何文档都将作为自由文档打开(出现在项目面板中的自由文档文件夹的相关子文件夹中)并在主设计窗口中成为活动文档。打开的任何项目文件都将被添加到项目面板中并成为焦点项目。
  • 项目面板中聚焦的类别(子文件夹)内的所有文档都可以通过右键单击所需类别的条目,然后从上下文菜单中选择打开全部命令来打开。
  • 可以通过右键单击包含原理图文档的源文档文件夹,然后从上下文菜单中选择打开所有原理图文档命令来打开聚焦项目的所有原理图文档。
  • 可以通过选择主菜单中的项目»项目文档命令(快捷键:Alt+Ctrl+O)来打开一个或多个文档,无论是在当前聚焦的项目中还是在活动设计项目组中的所有打开项目中。

    启动命令后,将打开打开项目文档对话框。使用此对话框选择您想要打开的文档。您可以限制视图,仅列出项目面板中当前聚焦的项目中的文档或活动设计项目组中打开的所有项目的文档。使用标准的Windows快捷键(Ctrl+点击Shift+点击)从列表中选择多个项目。选定所需的文档后,点击确定将导致这些文档被打开。

    打开项目文档对话框
    打开项目文档对话框

    • 您也可以双击对话框中的文档名称来打开它。
    • 所有选定的文档将以标签页文档视图的形式在主设计窗口中打开。最后选择的文档将是最后打开的文档,其父项目将成为项目面板中的活动项目(也是焦点项目)。
    • 要显示项目面板中文档的当前状态,请点击面板顶部的按钮,然后在弹出控件的排序分组中启用打开/修改状态选项。或者,在首选项对话框的系统 - 项目面板页面上启用此选项。

可以通过任何编辑器使用文件 » 最近的文档文件 » 最近的项目文件 » 最近的项目组子菜单中的索引命令分别打开最近关闭的文档、项目和项目组。列表显示最近关闭的实体(最多九个实体)。位置1(顶部)反映了最后关闭的实体。

  • 如果打开的最近文档当前不在项目面板中打开的项目中,它将作为自由文档打开。
  • 打开最近的项目组时,之前活动项目组的任何打开项目(及其文档)都将被关闭。您将被提示保存任何更改。

您还可以从这些菜单中选择所有最近的文档和项目命令,以打开最近的文档、项目和项目组对话框。该对话框在一个位置方便地列出了所有最近关闭的文档、项目和设计项目组。列出的信息包括:

  • 文档名称 - 打开文档的名称。
  • 文档类型 - 打开文档的类型(PCB、原理图等)。
  • 位置 - 打开文档的位置路径。
  • 修改 - 文档最后修改的日期和时间。

选择您想要打开的内容,然后点击确定关闭对话框并打开您的选择,或点击打开选定的文档打开您的选择 - 保持对话框打开以进行进一步选择。使用标准的Windows快捷键(Ctrl+点击Shift+点击)从列表中选择多个项目。

对话框最近的文档、项目和项目组
对话框最近的文档、项目和项目组

  • 在对话框中双击一个条目也将打开关联的文档、项目或项目组。
  • 如果您的选择包括文档和/或项目以及项目组,只有项目组将被打开(及其构成的项目/文档)。
或者,您可以直接拖放文档、项目文件或项目组文件到Altium Designer中打开。

关闭项目和文档

要关闭项目面板中当前聚焦的项目,请在其条目上右键点击并从上下文菜单中选择关闭项目命令。可以通过从主菜单中选择项目 » 关闭项目命令来关闭活动项目。

右键点击任何文档标签页可以访问一个下拉菜单,该菜单提供关闭您右键点击的文档、关闭与您右键点击的文档相同编辑器的所有文档(例如,所有PcbDoc、所有SchLib或所有PcbLib文档),或关闭所有打开的文档的命令。

打开的文档也可以从以下位置关闭:

  • 可以通过在项目面板中右键点击打开的文档条目并从上下文菜单中选择关闭命令来关闭。
  • 可以通过从主菜单中选择文件 » 关闭命令来关闭活动文档(快捷键:Ctrl+F4)。
  • 可以通过从主菜单中选择项目 » 关闭项目文档命令来关闭与活动项目关联的所有当前打开的文档。
  • 可以通过在项目面板中右键点击所需项目的条目并从上下文菜单中选择关闭项目文档命令来关闭与聚焦项目关联的所有当前打开的文档。
  • 可以通过在项目面板中右键点击所需类别(子文件夹)的条目并从上下文菜单中选择全部关闭命令来关闭聚焦子文件夹内的所有打开文档。
  • 可以通过从主菜单中选择窗口 » 关闭文档命令来关闭所有当前打开的文档。
  • 可以通过从主菜单中选择窗口 » 全部关闭文件 » 新建 » 设计项目组命令来关闭当前设计项目组中的所有当前打开的文档和项目。

关闭后,自由文档的条目将从项目面板中移除。

可用的功能取决于您的 Altium Designer 软件订阅级别

Content