Erstellen & Verwalten von Prozessen

Altium Designer bietet eine leistungsstarke kollaborative Designumgebung. Dazu gehört auch die Unterstützung von Workflows, die die Designer eines Unternehmens durch typische, alltägliche Designprozesse führen, wie zum Beispiel:

  • Anfordern neuer Workspace-Bibliotheksbauteile
  • Durchführen von Design-Reviews
  • Erstellen neuer Workspace-Projekte.

Jeder Workflow, der zur Umsetzung eines bestimmten Designprozesses verwendet wird, wird als Teil einer Process Definition erstellt. Er kann daher als zugrunde liegender Workflow dieses Prozesses oder einfach als Process Workflow bezeichnet werden.

Prozesse und ihre Workflows werden über die Browser-Oberfläche des Enterprise Server Workspace erstellt und verwaltet – durch einen Administrator dieses Workspace.

Für die drei zuvor genannten Designbereiche sind vordefinierte Prozess-Workflows in Ihrer Server-Installation enthalten. Einige davon sind direkt einsatzbereit aktiviert. Verwenden Sie diese, passen Sie sie an oder erstellen Sie bei Bedarf eigene, damit sie den Anforderungen Ihres Unternehmens entsprechen. Andere sind Beispiele – diese können nicht unverändert aktiviert und verwendet werden. Jede davon ist daher eher wie eine „Vorlage“ – passen Sie sie an die Anforderungen und Bezeichnung Ihres Unternehmens an und speichern Sie sie als neue Prozessdefinition, die Sie can anschließend zusammen mit allen anderen Definitionen aktivieren und verwenden.

Ein leistungsstarker Process Workflow Editor bietet Ihnen die Flexibilität, Prozesse mit Workflows zu erstellen, die so einfach oder so komplex sein können wie erforderlich und mit den Anforderungen Ihres Unternehmens übereinstimmen.

Zugriff auf Prozesse

Die gesamte Prozessverwaltung erfolgt im Bereich Processes (Admin – Processes) der Browser-Oberfläche des Enterprise Server Workspace.

Sie müssen als Administrator Ihres Enterprise Server Workspace angemeldet sein, um den Bereich Processes der Oberfläche sehen zu können.

Zugriff auf den Bereich Processes der Browser-Oberfläche des Enterprise Server Workspace – die zentrale Schaltstelle für die Arbeit mit Prozessen und den zugehörigen Workflows.Zugriff auf den Bereich Processes der Browser-Oberfläche des Enterprise Server Workspace – die zentrale Schaltstelle für die Arbeit mit Prozessen und den zugehörigen Workflows.

Die Oberfläche Processes wird über die folgenden vier Registerkarten bereitgestellt:

  • Browser – bietet eine zusammenfassende Liste aller Prozesse (aktiv oder geschlossen). Wenn Sie so wollen, ein zentrales „Prozess-Dashboard“.
  • Part Requests – bietet einen dedizierten Bereich zum Verwalten der Prozesse zum Thema Teileanforderung.
  • Project Activities – bietet einen dedizierten Bereich zum Verwalten der Prozesse zum Thema Arbeit mit Workspace-Projekten, wie Design-Reviews und Veröffentlichung in ein PLM-System.
  • Project Creations – bietet einen dedizierten Bereich zum Verwalten der Prozesse zum Thema Erstellen neuer Workspace-Designprojekte.
Die letzten drei Registerkarten können als Process Themes bezeichnet werden. Prozessthemen ermöglichen es, die verschiedenen Prozesse intuitiv nach Designbereich zu gruppieren. Außerdem ermöglichen sie es der Software, die Erstellung neuer Prozesse zu unterstützen, indem nur die Workflow-Elemente bereitgestellt werden, die für einen bestimmten Bereich benötigt werden, und dadurch der Aufbau eines erforderlichen Workflows optimiert wird. Mit Blick auf die Zukunft bietet dieser Ansatz Altium eine Grundlage, die Oberfläche bei Bedarf durch das Hinzufügen weiterer Themen zu erweitern.

In den folgenden Abschnitten werden diese verschiedenen Registerkarten näher betrachtet.

Registerkarte „Browser“

Verwenden Sie diese Registerkarte, um zentral alle aktiven oder geschlossenen Prozesse über alle Prozessthemen hinweg zu durchsuchen. Standardmäßig zeigt die Registerkarte alle Active (laufenden) Prozesse an. Wechseln Sie über das Dropdown-Feld oberhalb der Liste zur Anzeige aller Closed Prozesse (z. B. abgeschlossen, abgelehnt oder beendet).

Durchsuchen Sie alle aktiven Prozesse an einem komfortablen Ort. Bewegen Sie den Mauszeiger über das Bild, um ein Beispiel für das Durchsuchen aller geschlossenen Prozesse zu sehen.
Durchsuchen Sie alle aktiven Prozesse an einem komfortablen Ort. Bewegen Sie den Mauszeiger über das Bild, um ein Beispiel für das Durchsuchen aller geschlossenen Prozesse zu sehen.

Für jeden Eintrag werden die folgenden Informationen angezeigt (sofern zutreffend):

  • Status – der Status des Prozesses. Dies kann einer der folgenden sein:
    • Active – der Prozess ist derzeit aktiv und sein zugehöriger Workflow wird fortgesetzt.
    • On hold – der Prozess ist derzeit aktiv, wartet jedoch auf eine anfängliche Eingabe, wie z. B. die Zuweisung eines Bearbeiters, bevor sein Workflow fortgesetzt werden kann.
    • Closed – der Prozess ist nun geschlossen, wurde zum Beispiel entweder erfolgreich abgeschlossen oder abgelehnt.
    • Terminated – der Prozess ist nun geschlossen und wurde direkt von einem Workspace-Administrator beendet.
  • Process Name – der Name der Prozessdefinition.
  • Title – dieses Feld dient zur Unterscheidung zwischen mehreren Instanzen desselben Prozesses. Der Titel ist der Prozessname mit einem Instanzsuffix (#1, #2 usw.).
  • State – dies ist der aktuell im zugehörigen Workflow des Prozesses erreichte Status.
  • Assignee (nur aktiver Prozess) – dies ist der Benutzer, der nun eine Aufgabe ausführen muss, um den Prozess von seinem aktuellen Workflow-Status aus weiterzubringen.
  • Started By – der Benutzer, der den Prozess initiiert hat.
  • Started At – Datum und Uhrzeit, zu denen der Prozess gestartet wurde.
  • Ended At (nur geschlossener Prozess) – Datum und Uhrzeit, zu denen der Prozess geschlossen wurde.

Für einen aktiven Prozess gibt es außerdem ein Steuerelement Terminate (). Klicken Sie darauf, um einen Prozess zwangsweise zu beenden. Der Prozess wird in die Liste Closed der Prozesse verschoben.

Prozesse können nach jeder Spalte sortiert werden, die das Steuerelement besitzt – klicken Sie auf das Steuerelement oder auf den Spaltennamen. Es kann auch gesucht werden, und zwar über das Feld Search oben in der Liste. Daten in allen Feldern außer Status, Started At, Ended At und Terminate können für die Suche verwendet werden.
  • Sie können auch eine zuvor exportierte Prozessdefinition direkt über die Registerkarte Browser aus einer Datei importieren. Klicken Sie dazu auf die Schaltfläche . Navigieren Sie im daraufhin angezeigten Dialogfeld Open zur gewünschten Workflow-Datei (*.aaw) und öffnen Sie sie. Das richtige Prozessthema wird erkannt, und der Inhalt der Datei wird in den Process Workflow Editor geladen. Weitere Informationen finden Sie unter Importieren/Exportieren einer Prozessdefinition.
  • Verwenden Sie die Schaltfläche , um einen Bericht der aktuell aufgelisteten Aktivitäten (Prozess-Workflows) als detaillierte kommagetrennte *.csv-Datei zu exportieren – Beispiel anzeigen. Active oder Closed Aktivitäten können exportiert werden, und die einzuschließenden Einträge können über das Prozessnamen-Feld Search gefiltert werden. Auf der Designseite enthält das Explorer panel in Altium Designer eine entsprechende Schaltfläche – unter der Registerkarte Activites beim Durchsuchen eines Projekts (unter Verwendung der Standardansicht Project ) – zum Herunterladen der aktuell aufgelisteten Aktivitätsdaten, die sich auf dieses Projekt beziehen.

Klicken Sie auf einen Prozesseintrag, um ein Diagramm seines zugrunde liegenden Workflows anzuzeigen (auf der Registerkarte Diagram unterhalb der Liste). Dieses zeigt, was geschehen muss, damit der Prozess abgeschlossen werden kann, und an welcher Stelle im Ablauf sich der Prozess aktuell befindet, also wer nun eine Aufgabe ausführen muss, um den Prozess weiterzuführen.

Klicken Sie unten rechts auf das Steuerelement , um den aktuell im Workflow erreichten Punkt hervorzuheben – der Eintrag des/der Benutzer(s) blinkt kurz auf.

Anzeigen des zugrunde liegenden Workflows für einen ausgewählten Prozess auf seiner Registerkarte Diagram. Jeder Workflow wird diagrammbasiert aufgebaut, sodass Sie auf einen Blick sehen können, an welcher Stelle im Workflow sich ein Prozess aktuell befindet und wer als Nächstes eine Aufgabe hat, um den Fortschritt dieses Prozesses fortzusetzen.Anzeigen des zugrunde liegenden Workflows für einen ausgewählten Prozess auf seiner Registerkarte Diagram. Jeder Workflow wird diagrammbasiert aufgebaut, sodass Sie auf einen Blick sehen können, an welcher Stelle im Workflow sich ein Prozess aktuell befindet und wer als Nächstes eine Aufgabe hat, um den Fortschritt dieses Prozesses fortzusetzen.

Die folgenden zusätzlichen Registerkarten sind ebenfalls verfügbar:

  • Data – zeigt alle relevanten Daten für den Prozess an. Bei einem Design-Review-Prozess kann dies beispielsweise das Projekt und seinen Datensatz, den Review-Typ, die am Review beteiligten Personen und zusätzliche Anhänge umfassen. Bei einem Teileanforderungsprozess kann dies angehängte Datenblätter, parametrische Daten und erste Komponenten umfassen.

    Anwendbare Entitäten wie Anhänge, Datenblätter, Projekt und Projektdatensatz (Item-Revision) werden als Hyperlinks angezeigt, um schnell dorthin zu navigieren oder sie zu öffnen. Sie haben außerdem die Möglichkeit, die parametrischen Daten zu konfigurieren, die dem Standardbenutzer auf dieser Registerkarte angezeigt werden. Wenn Sie den Workflow für einen Prozess bearbeiten und kein Element ausgewählt ist, werden die Daten, die auf der Registerkarte Data dargestellt werden können, im rechten Bereich aufgelistet. Klicken Sie auf das Steuerelement Edit , um auf das zugehörige Formular (<ProcessName> Data) zuzugreifen.
  • History – zeigt einen Verlauf der entlang des Prozess-Workflows durchgeführten Aktionen.

    Verwenden Sie die Registerkarten Data und History, um jeweils weitere Details zum Prozess und eine Spur seiner Workflow-Aktivität anzuzeigen.Verwenden Sie die Registerkarten Data und History, um jeweils weitere Details zum Prozess und eine Spur seiner Workflow-Aktivität anzuzeigen.

Registerkarten „Teileanfragen/Projektaktivitäten/Projekterstellungen“

Verwenden Sie diese Registerkarten – die Prozesse in bestimmten Themen zusammenfassen –, um Prozess-Workflows anzuzeigen, zu erstellen und zu verwalten, die jeweils beim Anfordern eines neuen Workspace-Bibliotheksbauteils, beim Durchführen von Design-Reviews oder beim Veröffentlichen in ein PLM-System oder beim Erstellen neuer Designprojekte verwendet werden.

Standardmäßig zeigt der obere Bereich einer Registerkarte alle Latest-Versionen definierter Prozesse innerhalb des Themas an. Wechseln Sie über das Dropdown-Feld oberhalb der Liste zur Anzeige All definierter Prozesse (d. h. aller Versionen).

Beispiel für das Durchsuchen der neuesten Versionen definierter Prozesse für ein bestimmtes Thema (in diesem Fall das Thema Project Activities).Beispiel für das Durchsuchen der neuesten Versionen definierter Prozesse für ein bestimmtes Thema (in diesem Fall das Thema Project Activities).

Für jeden Eintrag werden die folgenden Informationen angezeigt:

  • Process Name : version – der Name der Prozessdefinition und ihre Version. Um sicherzustellen, dass Sie immer die neueste Version anzeigen bzw. damit arbeiten, stellen Sie sicher, dass das Versions-Dropdown-Feld oberhalb der Liste auf Latest gesetzt ist.
  • Instances (active / all) – die Anzahl der aktuell aktiven Instanzen dieser Version der Prozessdefinition sowie die Gesamtzahl der gestarteten Instanzen.
  • Created By – der Benutzer, der diese Version der Prozessdefinition erstellt hat.
  • Created At – Datum und Uhrzeit, zu denen diese Version der Prozessdefinition erstellt wurde (gespeichert und bereitgestellt).
  • Active – zeigt an, ob diese Version der Prozessdefinition aktiv ist () und daher verwendet werden kann, oder ausgesetzt wurde () oder eine Beispieldefinition (Vorlage) ist () und daher nicht verwendet werden kann. Nur aktive Prozessdefinitionen erscheinen im relevanten Bereich der Altium Designer GUI zur Nutzung durch Designer. Klicken Sie gegebenenfalls auf das Symbol, um den aktiven Status umzuschalten.

    Nur die neueste Version einer Prozessdefinition kann verwendet werden (aktiviert und gestartet werden). Frühere Versionen können nicht verwendet werden, aber sie können geändert werden, um eine spätere Version zu erzeugen. Außerdem können Beispiel-Prozessdefinitionen (deren Status Active durch gekennzeichnet ist) nicht direkt verwendet werden. Jede davon ist eher wie eine „Vorlage“ – bearbeiten Sie sie entsprechend den Anforderungen und der Bezeichnung Ihres Unternehmens und speichern Sie sie als neue Prozessdefinition, die Sie can anschließend zusammen mit allen anderen Definitionen aktivieren und verwenden.
  • Actions – klicken Sie auf das  Steuerelement, um ein Aktionsmenü für die Prozessdefinition aufzurufen:
    • Startals Administrator können Sie durch Auswahl dieses Befehls eine neue Instanz dieser Version der Prozessdefinition starten. Dies ist nur verfügbar, wenn die Prozessdefinition aktiviert wurde. Wenn der Prozess ausgesetzt wurde oder es sich um eine Beispieldefinition (Vorlage) handelt, ist der Befehl ausgegraut und eine Instanz kann nicht gestartet werden.
    • Edit – wählen Sie aus, um den zugrunde liegenden Workflow der Prozessdefinition zu ändern. Das Workflow-Diagramm für diese Version der Prozessdefinition wird im Process Workflow Editor als Ausgangspunkt für die weitere Bearbeitung angezeigt. Jeder Administrator kann jede benutzerdefinierte Prozessdefinition ändern, unabhängig davon, wer diese Definition ursprünglich erstellt hat, und sie als nächste Version speichern und bereitstellen. Für von Altium bereitgestellte Standard-Prozessdefinitionen können Sie eine neue Prozessdefinition erstellen, die auf der Bearbeitung einer dieser Definitionen basiert (im Wesentlichen ein Fork), Sie können jedoch den Standard selbst nicht ändern. Weitere Informationen zum Bearbeiten einer Prozessdefinition finden Sie unter Bearbeiten einer vorhandenen Prozessdefinition.
    • Assign – wählen Sie dies aus, um das Fenster Assign Access to This Workflow zu öffnen, in dem Sie festlegen können, welche Benutzer und/oder Gruppen auf den zugrunde liegenden Workflow zugreifen können. Weitere Informationen zur Verwaltung des Zugriffs auf einen Workflow finden Sie unter Verwalten des Zugriffs auf Prozess-Workflows.
    • Remove – wählen Sie dies aus, um diese Version der Prozessdefinition zu entfernen (zu löschen). Beachten Sie, dass einige der von Altium bereitgestellten Standard-Prozessdefinitionen nicht entfernt werden können (und daher kein solches Steuerelement besitzen). Wenn mindestens eine Instanz der Prozessdefinition gestartet wurde, unabhängig davon, ob sie noch aktiv ist oder nicht, kann die Definition nicht entfernt werden (der Befehl wird nicht im Menü aufgeführt).
Prozessdefinitionen können nach jeder Spalte sortiert werden, die das Steuerelement besitzt – klicken Sie auf das Steuerelement oder auf den Spaltennamen. Es kann auch gesucht werden, und zwar über das Feld Search oben in der Liste. Daten in den Spalten Process Name : version und Created By können für die Suche verwendet werden.

Klicken Sie auf einen Eintrag für eine Prozessdefinition, um den diagrammbasierten Workflow auf der Registerkarte Diagram unterhalb der Liste anzuzeigen. Wenn es eine aktuell aktive Instanz eines Prozesses gibt, zeigt die Ansicht, an welcher Stelle im Ablauf sich dieser Prozess befindet, also wer nun eine Aufgabe ausführen muss, um den Prozess weiterzuführen.

Wenn mehrere Instanzen eines Prozesses aktiv sind, zeigt die Ansicht Diagram einen kombinierten Status. Klicken Sie unten rechts auf das Steuerelement , um den aktuell im Workflow erreichten Punkt hervorzuheben – der Eintrag des/der Benutzer(s) blinkt kurz auf.

Anzeigen des zugrunde liegenden Workflows für einen ausgewählten Prozess auf seiner Registerkarte Diagram.Anzeigen des zugrunde liegenden Workflows für einen ausgewählten Prozess auf seiner Registerkarte Diagram.

Standard-Prozessdefinitionen

Eine Reihe von Prozessdefinitionen wird von Altium – über die drei Prozessthemen hinweg – als Teil der Installation des Enterprise Server bereitgestellt. Einige davon sind direkt einsatzbereit aktiviert und können unverändert verwendet werden, während andere Beispiele sind – sie können nicht direkt aktiviert und verwendet werden. Alle können als Ausgangspunkt zur Erstellung eigener Prozessdefinitionen nach Bedarf verwendet werden. Verwenden Sie die folgenden aufklappbaren Abschnitte, um auf Informationen zu den bereitgestellten Prozessdefinitionen zuzugreifen.

Die Enterprise Server-Installation enthält außerdem den Prozess LibSync, der Komponentendaten zwischen dem Enterprise Server und einer Ziel-PLM-Instanz synchronisiert. Dies ist ein integrierter schreibgeschützter Prozess-Workflow und daher weder bearbeitbar noch in der Prozessliste auf der Seite Processes des Workspace enthalten (Admin » Processes). Weitere Informationen finden Sie unter PLM-Komponentensynchronisierung.

Hinzufügen einer neuen Prozessdefinition

Related page: Definieren eines Prozess-Workflows

Neue Prozesse können mit dem dedizierten Process Workflow Editor erstellt werden. Um auf den Editor zuzugreifen, aktivieren Sie die Registerkarte des Themas, in dem Sie Ihren neuen Prozess erstellen möchten, und klicken Sie dann oben rechts auf der Seite auf die Schaltfläche .

Es ist wichtig, zuerst das Thema zu aktivieren, damit der Prozess mit dem richtigen Type erstellt wird.

Zugriff auf den Process Workflow Editor. Wenn Sie zuvor das gewünschte Prozessthema aktivieren, wird sichergestellt, dass die neue Prozessdefinition dem richtigen Thementyp zugeordnet wird.Zugriff auf den Process Workflow Editor. Wenn Sie zuvor das gewünschte Prozessthema aktivieren, wird sichergestellt, dass die neue Prozessdefinition dem richtigen Thementyp zugeordnet wird.

Geben Sie Ihrer neuen Prozessdefinition einen aussagekräftigen Namen, erstellen Sie dann den Workflow grafisch und definieren Sie die erforderlichen Aspekte jedes Elements in diesem Ablauf. Für Benutzeraufgaben wird ein User Form Editor verwendet, um das erforderliche Formular zu erstellen, das dem Benutzer angezeigt wird, damit er seine Eingaben machen kann, wenn ihm an der entsprechenden Stelle im Workflow eine Aufgabe zugewiesen wird.

Der leistungsstarke Process Workflow Editor bietet Ihnen die Flexibilität, Prozesse mit Workflows zu erstellen, die so einfach oder so komplex sein können wie erforderlich und mit den Anforderungen Ihres Unternehmens übereinstimmen.Der leistungsstarke Process Workflow Editor bietet Ihnen die Flexibilität, Prozesse mit Workflows zu erstellen, die so einfach oder so komplex sein können wie erforderlich und mit den Anforderungen Ihres Unternehmens übereinstimmen.

Sobald ein Prozess wie gewünscht definiert wurde, klicken Sie auf die Schaltfläche , um ihn der Liste der verfügbaren Prozesse für dieses Prozessthema hinzuzufügen. Die neue Prozessdefinition wird aktiviert und ist sofort einsatzbereit.

Der Editor kennzeichnet alle Probleme in Ihrem Workflow-Diagramm, die das Speichern und Bereitstellen verhindern – ein Diagramm muss zum Beispiel ein Ereignis Start und mindestens ein Ereignis End enthalten. Und eine Benutzeraufgabe muss mindestens ein Formularfeld und einen Bearbeiter haben.

Bearbeiten einer vorhandenen Prozessdefinition

Jeder Administrator kann jede benutzerdefinierte Prozessdefinition ändern, unabhängig davon, wer diese Definition ursprünglich erstellt hat, und sie als nächste Version speichern und bereitstellen. Klicken Sie dazu auf das  Steuerung in der Spalte Actions für die Prozessdefinition, die Sie ändern möchten, und wählen Sie Edit aus dem daraufhin angezeigten Menü. Das Workflow-Diagramm für diese Version der Prozessdefinition wird im Process Workflow Editor angezeigt und dient als Ausgangspunkt für die weitere Bearbeitung.

Für von Altium bereitgestellte Prozessdefinitionen können Sie eine neue Prozessdefinition erstellen, die auf der Bearbeitung einer dieser Definitionen basiert (im Wesentlichen ein Fork), Sie können jedoch die Standarddefinition selbst nicht ändern.

Beispiel für die Bearbeitung einer vorhandenen Prozessdefinition – Zugriff auf den Process Workflow Editor, in dem die erforderlichen Änderungen vorgenommen werden können.Beispiel für die Bearbeitung einer vorhandenen Prozessdefinition – Zugriff auf den Process Workflow Editor, in dem die erforderlichen Änderungen vorgenommen werden können.

Nehmen Sie die erforderlichen Änderungen am grafischen Workflow des Prozesses vor, einschließlich aller Änderungen an den Formularen, die Benutzertasks zugeordnet sind, und klicken Sie dann auf die Schaltfläche , um die Definition effektiv als nächste Version zu speichern. Im hier gezeigten Beispiel wird die ursprüngliche Prozessdefinition Company Pre-release Review : 1 (Version 1) geändert und als Company Pre-release Review : 2 (Version 2) gespeichert.

Nach den Änderungen speichern Sie die Definition und stellen sie als nächste Version dieser Prozessdefinition bereit.Nach den Änderungen speichern Sie die Definition und stellen sie als nächste Version dieser Prozessdefinition bereit.

Durch Verwendung des Dropdown-Felds oben links und Einstellen des Eintrags auf All können Sie alle Versionen vorhandener Prozessdefinitionen anzeigen. Im folgenden Bild sehen Sie beide Versionen der Prozessdefinition Company Pre-release Review.

Anzeige aller Versionen der Beispiel-Prozessdefinition Company Pre-release Review. Beachten Sie, dass nur die neueste Version (Version 2) aktiviert und verwendet werden kann.Anzeige aller Versionen der Beispiel-Prozessdefinition Company Pre-release Review. Beachten Sie, dass nur die neueste Version (Version 2) aktiviert und verwendet werden kann.

Nur die neueste Version einer Prozessdefinition kann verwendet werden (aktiviert und gestartet werden). Frühere Versionen können jedoch als Ausgangspunkt für die Erstellung einer späteren Version dienen. Wenn Sie die neueste Version einer Prozessdefinition löschen, wird die unmittelbar vorherige Version effektiv zur neuesten und kann erneut aktiviert und verwendet werden (Instanzen können gestartet werden).

Importieren/Exportieren einer Prozessdefinition

Prozessdefinitionen können exportiert und importiert werden, sodass Sie sie schnell über Enterprise-Server-Instanzen hinweg wiederverwenden können – eine echte Zeitersparnis, wenn der zugrunde liegende Workflow eines Prozesses besonders komplex ist und man andernfalls sozusagen das Rad neu erfinden müsste.

So importieren Sie:

  1. Rufen Sie die Themenregisterkarte (Part Requests, Project Activities, Project Creations) auf, die der Prozessdefinition entspricht, die Sie importieren möchten.

    Wenn Sie versuchen, eine Prozessdefinition in das falsche Thema zu importieren, weist Sie die Software darauf hin und der Import wird verhindert.
  2. Klicken Sie auf die Schaltfläche , um eine neue Prozessdefinition zu erstellen und den Process Workflow Editor zu öffnen.
  3. Klicken Sie auf die Schaltfläche . Navigieren Sie im daraufhin angezeigten Dialog Open zur gewünschten Workflow-Datei (*.aaw) und öffnen Sie sie. Der Inhalt der Datei überschreibt vollständig alles, was derzeit für die Prozessdefinition definiert ist (Name, Diagramm usw.).
Sie können eine zuvor exportierte Prozessdefinition auch direkt aus der Registerkarte Browser der Oberfläche aus einer Datei importieren. Klicken Sie dazu auf die Schaltfläche . Navigieren Sie im daraufhin angezeigten Dialog Open zur gewünschten Workflow-Datei (*.aaw) und öffnen Sie sie. Das korrekte Prozessthema wird erkannt, und der Inhalt der Datei wird in den Process Workflow Editor geladen.

So exportieren Sie:

  1. Klicken Sie auf die  Steuerung in der Spalte Actions für die erforderliche Version der Prozessdefinition, die Sie exportieren möchten, und wählen Sie Edit aus dem daraufhin angezeigten Menü, um den Bearbeitungsmodus zu öffnen.
  2. Klicken Sie im Process Workflow Editor auf die Schaltfläche . Die Prozessdefinition wird als Workflow-Datei (<ProcessDefinitionName>.aaw) in den für Ihren Browser festgelegten Standard-Downloadordner exportiert.
  3. Klicken Sie im linken Navigationsbaum der Browseroberfläche des Workspace auf den Eintrag Processes, um den Process Workflow Editor zu verlassen, ohne Änderungen an der Prozessdefinition vorzunehmen.

Verwalten des Zugriffs auf Prozess-Workflows

Als Administrator können Sie festlegen, welche Benutzer und/oder Gruppen auf einen Prozess-Workflow zugreifen können. Klicken Sie dazu auf die  Steuerung in der Spalte Actions für die Prozessdefinition, für deren zugrunde liegenden Workflow Sie den Zugriff konfigurieren möchten, und wählen Sie Assign aus dem daraufhin angezeigten Menü. Das Fenster Assign Access to This Workflow wird geöffnet.

Beginnen Sie im Textfeld mit der Eingabe des vollständigen Namens oder des Benutzernamens eines Benutzers oder des Namens einer Gruppe, damit eine Popup-Liste mit passenden Benutzern/Gruppen angezeigt wird. Es können mehrere Benutzer/Gruppen hinzugefügt werden. Um einem hinzugefügten Benutzer/einer hinzugefügten Gruppe den Zugriff auf den Workflow zu entziehen, klicken Sie ganz rechts neben dem Namen auf das Löschkreuz.

Wenn die Benutzer/Gruppen wie erforderlich definiert sind, klicken Sie auf , um die Workflow-Zuweisung zu übernehmen. Der Workflow ist nun nur noch für die hinzugefügten Benutzer/Gruppen (und Mitglieder der Gruppe Administrators) verfügbar, wenn er wie im Abschnitt Designer Access to Process Workflows unten beschrieben aufgerufen wird.

Wie im Fenster Assign Access to This Workflow angegeben, ist der Workflow für alle Benutzer verfügbar, wenn kein Benutzer/keine Gruppe hinzugefügt wird.

Zugriff von Designern auf Prozess-Workflows

Related pages: Durchführen von Design-Reviews, Veröffentlichen in einem PLM, Prozessbasierte Teileanforderungen

Sobald der erforderliche Satz an Prozessdefinitionen für jedes verfügbare Prozessthema entsprechend den Anforderungen Ihres Unternehmens erstellt wurde, stehen die aktivierten Definitionen zugewiesenen Benutzern zur Verfügung, sobald diese mit dem Enterprise Server Workspace verbunden sind. In den folgenden Abschnitten wird erläutert, wo ein Designer auf diese aktiven Prozesse zugreifen und sie starten kann – sowohl über Altium Designer als auch über die Browseroberfläche des Workspace.

Administratoren des Workspace können, wie bereits erwähnt, eine neue Instanz jeder aktivierten Prozessdefinition direkt über die entsprechende Registerkarte des Prozessthemas im Bereich Processes der Browseroberfläche des Workspace starten, indem sie auf die  Steuerung in der Spalte Actions klicken und Start aus dem daraufhin angezeigten Menü auswählen.

Teileanforderungen

Related page: Prozessbasierte Teileanforderungen

Innerhalb von Altium Designer kann auf aktivierte Prozessdefinitionen, die Teil des Themas „Part Requests“ sind, an den folgenden Stellen zugegriffen werden:

  • Im Components panel. Klicken Sie mit der rechten Maustaste in den Hauptbereich des Panels – die aktiven Prozessdefinitionen für Teileanforderungen sind über das Untermenü Operations » Submit Request verfügbar. Alternativ klicken Sie auf den Link Submit request im Abschnitt Need more components?.

Wenn keine aktiven Prozessdefinitionen für das Prozessthema „Part Requests“ verfügbar sind, wird das Untermenü Submit Request nicht angezeigt. Möglicherweise müssen Sie sich vom Workspace abmelden und erneut anmelden oder Altium Designer neu starten, um die Anzeige zu aktualisieren.
  • Im Manufacturer Part Search panel. Wenn das aktuell ausgewählte Suchergebnis das Symbol aufweist, zeigt der Bereich Information (aufgerufen durch Klicken auf ) die Schaltfläche an. Klicken Sie auf den Dropdown-Teil der Schaltfläche, um ein Menü der aktiven Prozessdefinitionen für Teileanforderungen aufzurufen. Wenn Sie direkt auf den Hauptteil der Schaltfläche klicken, wird die erste Prozessdefinition in der Liste gestartet.
Die Anforderung eines Teils über das Panel Manufacturer Part Search bietet den zusätzlichen Vorteil, dass wichtige Informationen automatisch für Sie ausgefüllt werden, einschließlich aller Datenblätter und parametrischen Informationen.

Wenn keine aktiven Prozessdefinitionen für das Prozessthema „Part Requests“ verfügbar sind, wird die Schaltfläche nicht angezeigt. Möglicherweise müssen Sie sich vom Workspace abmelden und erneut anmelden oder Altium Designer neu starten, um die Anzeige zu aktualisieren.

Wenn das aktuell ausgewählte Suchergebnis ein Symbol aufweist, sind die aktiven Prozessdefinitionen für Teileanforderungen über das Menü verfügbar, das der Schaltfläche zugeordnet ist (klicken Sie auf den Dropdown-Teil der Schaltfläche).

Die aktiven Prozessdefinitionen für Teileanforderungen können auch über das Rechtsklickmenü im Hauptbereich des Panels, über das Untermenü Submit Request, aufgerufen werden.

Wenn keine aktiven Prozessdefinitionen für das Prozessthema „Part Requests“ verfügbar sind, wird das Untermenü Submit Request nicht angezeigt. Möglicherweise müssen Sie sich vom Workspace abmelden und erneut anmelden oder Altium Designer neu starten, um die Anzeige zu aktualisieren.
  • Im Explorer panel, im Ordner Part requests oder nach Durchführung einer Suche. Die Schaltfläche ist verfügbar und zeigt beim Klicken die aktiven Prozessdefinitionen für Teileanforderungen an, aus denen Sie wählen können.

Beachten Sie, dass die Schaltfläche als erscheint, wenn die Funktion Legacy Part Requests feature aktiviert wurde. Ein zusätzlicher Eintrag in Bezug auf neue Teileanforderungen, die diese Legacy-Funktionalität verwenden, erscheint ebenfalls im Menü. Dieser hat das Suffix (Legacy). Wenn keine aktiven Prozessdefinitionen für das Prozessthema „Part Requests“ verfügbar sind und die Funktion „Legacy Part Requests“ nicht aktiviert ist, wird die Schaltfläche Submit Request nicht angezeigt. Möglicherweise müssen Sie sich vom Workspace abmelden und erneut anmelden oder Altium Designer neu starten, um die Anzeige zu aktualisieren.

Über die Browseroberfläche des Workspace kann auf aktivierte Prozessdefinitionen, die Teil des Themas „Part Requests“ sind, über die Seite Part Requests zugegriffen werden, indem Sie oben rechts auf der Seite auf die Schaltfläche klicken.

Zugriff auf aktivierte Definitionen für Part Requests über die Seite Part Requests der Browseroberfläche des Workspace.Zugriff auf aktivierte Definitionen für Part Requests über die Seite Part Requests der Browseroberfläche des Workspace.

Wenn keine aktiven Prozessdefinitionen für das Prozessthema „Part Requests“ verfügbar sind, ist die Schaltfläche nicht verfügbar. Wenn nur eine Prozessdefinition vorhanden ist, wird die Schaltfläche nicht mit Dropdown-Funktion angezeigt und startet diesen Prozess sofort beim Anklicken.

Projektaktivitäten

Related pages: Durchführen von Design-Reviews, Veröffentlichen in einem PLM, PLM-Integration.

Aktivierte Prozessdefinitionen, die Teil des Themas „Project Activities“ sind, können an verschiedenen Stellen aufgerufen werden.

Design-Review und standardmäßiges PLM-Publishing

Innerhalb von Altium Designer kann auf aktivierte Prozessdefinitionen für Design-Reviews und Publishing – die Teil des Themas „Project Activities“ sind – über das Kontext-Untermenü Project Activities zugegriffen werden, das durch Rechtsklick auf den Eintrag des Designprojekts im Projects panel aufgerufen wird, oder über das Hauptmenü Project » Project Activities.

Wenn keine aktiven Prozessdefinitionen für Design-Reviews und standardmäßiges PLM-Publishing für das Prozessthema „Project Activities“ verfügbar sind, werden die Menüs nicht angezeigt.

Über die Browseroberfläche des Workspace kann auf aktivierte Prozessdefinitionen für Design-Reviews und Publishing – die Teil des Themas „Project Activities“ sind – über die Seite Projects der Oberfläche zugegriffen werden. Wählen Sie das gewünschte Projekt aus und klicken Sie dann auf die Schaltfläche .

Zugriff auf aktivierte Definitionen für Project Activities (Design-Review und standardmäßiges PLM-Publishing) für ein Workspace-Projekt im Bereich Projects der Browseroberfläche des Workspace.Zugriff auf aktivierte Definitionen für Project Activities (Design-Review und standardmäßiges PLM-Publishing) für ein Workspace-Projekt im Bereich Projects der Browseroberfläche des Workspace.

Wenn keine aktiven Prozessdefinitionen für Design-Reviews und standardmäßiges PLM-Publishing für das Prozessthema „Project Activities“ verfügbar sind, wird die Schaltfläche nicht angezeigt.

PLM-Publishing über den Project Releaser

Innerhalb von Altium Designer kann auf den Prozess zum Veröffentlichen in eine PLM-Instanz als Teil des Project Releaser über das Untermenü Project » Project Releaser für das aktive Projekt zugegriffen werden, oder durch Rechtsklick auf den Eintrag des Designprojekts im Projects panel und Auswahl des Prozesses über den Kontextmenüeintrag Project Releaser.

Projekterstellungen

Innerhalb von Altium Designer kann auf aktivierte Prozessdefinitionen, die Teil des Themas „Project Creations“ sind, an drei Stellen zugegriffen werden:

  • Vom Untermenü File » New » Project in <WorkspaceName> im Hauptmenü.

  • Vom Kontext-Untermenü Convert to Managed Project, das durch Rechtsklick auf den Eintrag für ein lokales Projekt im Panel Projects aufgerufen wird.

  • Vom Kontext-Untermenü Clone, das durch Rechtsklick auf den Projekteintrag im Dialog Open Project dialog aufgerufen wird, wenn der Workspace-Speicherort ausgewählt ist.

Beachten Sie, dass die Möglichkeit, über den Dialog Create Project dialog (File » New » Project) ein neues Workspace-Projekt zu erstellen, deaktiviert ist, wenn mindestens eine Prozessdefinition für das Prozessthema „Project Creations“ aktiv ist – der verbundene Workspace ist nicht als Zielort verfügbar. Regular (lokale) und Projekte vom Typ VCS können über diesen Dialog wie gewohnt erstellt werden.

Wenn keine aktiven Prozessdefinitionen für das Prozessthema „Project Creations“ verfügbar sind – was bei einer Neuinstallation des Enterprise Server der Standardfall ist –, sind die Prozessmenüs nicht sichtbar, und Sie können wie gewohnt über den Dialog Create Project ein Workspace-Projekt erstellen.

Beachten Sie außerdem, dass sich in dieser Standardkonfiguration der Befehl Convert to Managed Project in Make Project Available on Server ändert.

Über die Browseroberfläche des Workspace kann auf aktivierte Prozessdefinitionen, die Teil des Themas „Project Creations“ sind, an den folgenden Stellen zugegriffen werden:

  • Von der Hauptseite Projects der Oberfläche aus, durch Klicken auf die Schaltfläche .

Zugriff auf aktivierte Definitionen für Project Creations über den Hauptbereich Projects der Browseroberfläche des Workspace.Zugriff auf aktivierte Definitionen für Project Creations über den Hauptbereich Projects der Browseroberfläche des Workspace.

  • Von der Seite Projects der Oberfläche aus, wenn ein bestimmtes Projekt geklont werden soll. Wählen Sie das gewünschte Projekt aus und klicken Sie dann auf die Schaltfläche , um auf die Prozesse im Menü zuzugreifen.

Zugriff auf aktivierte Definitionen für Project Creations beim Klonen eines Workspace-Projekts im Bereich Projects der Browseroberfläche des Workspace.Zugriff auf aktivierte Definitionen für Project Creations beim Klonen eines Workspace-Projekts im Bereich Projects der Browseroberfläche des Workspace.

  • Wenn keine aktiven Prozessdefinitionen für das Prozessthema „Project Creations“ verfügbar sind – was bei einer Neuinstallation des Enterprise Server der Standardfall ist –, bietet das Menü die grundlegende Funktion zum Klonen von Projekten (Clone). Diese steht nicht im Zusammenhang mit der Prozess-Workflow-Funktionalität.
  • Um den Constraint Manager zur Verwaltung der Design-Constraints für Ihr prozessbasiertes Workspace-PCB-Projekt zu verwenden, stellen Sie sicher, dass Sie beim Erstellen dieses Projekts eine geeignete Projektvorlage zuweisen. Dabei sollte es sich um eine Vorlage handeln, die aus einem PCB-Projekt gespeichert wurde, das mit aktivierter Option Constraint Management im Dialog Create Project dialog erstellt wurde.
AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Inhalt