Document Commenting in Altium Designer

Created: December 7, 2022 | Updated: February 2, 2023

Parent page: Working with Documents

Altium Designer projects, when integrated with a connected Workspace, enable a dispersed design team to collaboratively work on projects that are centrally stored and managed through that Workspace. To enhance the design collaboration process, the design interface supports the commenting of design documents. Comments – user-added notes – can be applied to a point, object, or area on a schematic or PCB document and may be replied to by other users.

The Comments and Tasks panel
The Comments and Tasks panel

Placed comments are available in real-time to collaborating users – those that have shared access to the document – and are saved to the server independently of the project, without altering its constituent documents in any way. The commenting feature is managed through the Comments and Tasks panel.

The Comments and Tasks panel
The Comments and Tasks panel

The Comments and Tasks panel allows you to add comments to a defined area or point in the active document of a Workspace project and assign these comments to Workspace members, essentially creating tasks for them. The panel allows all users who are working on the document to add comments and view all comments without actually modifying the document itself. This feature allows for the facilitation of strong collaboration processes and is invaluable when issues within the document need to be pointed out without physically merging and receiving conflicts. The Comments and Tasks panel can essentially be used to create a 'to do' list, and as the design matures, the comments can be resolved and closed. Placed comments are available in real-time to collaborating users – those that have shared access to the document – and are saved to the Workspace independently of the project, without altering its constituent documents in any way.

Note that the functionality for creating and managing tasks is not supported with the Altium Designer Standard Subscription. As such, with this level of access to Altium 365, this functionality will not be available and the panel will be named Comments.

This functionality is also not available when connecting to an Enterprise Server Workspace.

For information on Projects from a Workspace perspective, see Workspace Projects (Altium 365 Workspace, Enterprise Server Workspace).

Note that comments and tasks can be added and managed in both Altium Designer and in the related Workspace, via its browser interface design view. The functionality of the two commenting systems is essentially the same, and since both the project and commenting data are stored in the Workspace, the systems work together in real time.

► See Commenting in the Web Viewer (Altium 365 Workspace, Enterprise Server Workspace) for detailed information on the commenting system in a Workspace's browser interface.

Comments and Tasks Panel Access

The panel is accessed from a Workspace project in the following ways:

  • Click the Panels button on the bottom-right of the design space then select Comments and Tasks.

    The Workspace icon next to a panel's name in the menu at the bottom-right of the design space indicates that a connection to a Workspace is required to view the associated panel's data. A blue icon () signifies that there is currently a connection to a Workspace. A gray icon () indicates that there is currently not a connection to a Workspace and you will be directed to connect to a Workspace before the panel's data can be accessed.
  • Select the View » Panels » Comments and Tasks command from the main menus.
  • Double-click on the marker pin of a comment placed in the design space.
In order to access the Comments and Tasks panel, the active document must be a schematic, PCB, ActiveBOM, Multi-board schematic, or Draftsman document of an opened Workspace project. Only those projects currently shared with you will be available for selection.
For more information on support for projects from the Workspace perspective, see Design Management with a Connected Workspace.

Adding a Comment When Not Connected to a Workspace

Before using the commenting feature, ensure that you are connected to your Workspace and have opened a project and one of its schematic or PCB documents. Use the File » Open Project command to choose a Workspace project from those that have been shared with you. The Comments and Tasks panel will provide hints for these prerequisites.

If you enjoy the benefits of your Altium Subscription but have not created an Altium 365 Workspace for your company yet, you can test commenting features in demo mode. When signed in to your Altium account from Altium Designer and working with a local project, you can place up to 3 comments. For using the commenting feature in full functionality mode and for saving the placed comments, the project must be made available to the Workspace – an appropriate control will be provided for doing this in the message box under the pop-up comment dialog in the design space.

Try the commenting feature in its demo mode when not having an activated Altium 365 Workspace yet.
Try the commenting feature in its demo mode when not having an activated Altium 365 Workspace yet.

Comments and Tasks Panel Options

Use the buttons at the top of the Comments and Tasks panel to set the availability of comments in the panel and editor space, and to specify if mentioned users are notified.

The panel's  button toggles the visibility of comment marker pins on the document. Comment entries may still be selected as usual in the Comments and Tasks panel listing.

Use the filter drop-down menu in the Comments and Tasks panel () to configure comment filtering, and the associated  button to toggle between the filtered and unfiltered view.

  • Tasks only - enable this option to show only comments that are assigned to a user (this filter is not available with the Standard subscription).
  • ASSIGNED TO - all options are disabled by default. Consequently, all tasks/comments are shown and sorted by name (the first entry in the list is the current user). When checkboxes are enabled for a user(s), the entries of those enabled will be displayed. 

Use the options of the  button menu to configure comment visibility and notifications:

  • Unresolved Only – comments that have been resolved are not included in the listing.
  • Current document only – show only comments that have been placed on the currently active document.
  • Notification settings – click to open the Notification Settings dialog and configure email alerts receiving for all comment activity in this design (All), for only those comments where you are mentioned or assigned (My), or not receiving email alerts at all (None). ► Email content example.
  • Export Comments – click to open the Comment Export Configuration dialog, with which to configure the export of comments into a PDF file.

You can choose to export all comments associated with the design, irrespective of when those comments were made, or only comments made between specific releases of the design. There are also a couple of options to define what screenshots to include in the generated PDF document. Together, both give information on where a comment is, and what it applies to (point, component, area). If you leave both unchecked, you'll get just the comments themselves. Once configured, click Export to generate the PDF, using the subsequent dialog to determine where and with what name (by default, that of the project). 

  • Entire designs snapshots - include a snapshot of each source document that includes a comment within the nominate time Period. This provides a visual confirmation of where on the document the comment resides, by numbered comment marker.
  • Original design screenshots - include the Original Snapshot that was taken at the time a comment was created (and is the snapshot available from the Contextual Commenting window when a comment marker is clicked in the main design space). This shows the point, area or component to which the comment applies.
Exporting comments to a PDF can also be configured and generated through an Output Job file, as part of releasing the project. Add an Export Comments outputter as part of the Report Outputs category.

Placement

To place a comment in the design space, run the command for it first. This can be done by performing one of the following:

  • Click the  button available in the Comments and Tasks panel.
  • Click  near the top right-hand corner of the design space.
  • Click Place » Comment from the main menus.
  • Using the Ctrl+Alt+C keyboard shortcut.
  • Right-click then select Comment from the design space.

Comments can be assigned to an object, a specific point, or an area on the active document. The command invokes the comment placement mode and the cursor changes to a crosshair with a blue circle that detects and highlights objects for selection:

  • Click a highlighted object to attach (pin) a comment to that object (in schematic and PCB editors).
  • Click in an un-highlighted area to attach a comment to that specific point on the document.
  • Click away from an object and drag the cursor to create a rectangular highlighted area, and then click again to confirm its final shape to attach a comment to the specified area. ► See example.

The placement action then opens a comment entry dialog that offers a field for entering the comment text, and also an additional option for adding a freehand drawing to the comment (). Select the Assign a task to option to assign a task to yourself or to one of the users mentioned in the comment (see details below). Click  to confirm the comment creation, which will associate the comment with a numbered pin marker on the document and also add a comment summary entry to the Comments and Tasks panel.

Placing a comment on an object, mentioning another registered user in the comment, moving the comment's pin indicator, and adding a freehand drawing to the comment.

A placed comment is immediately available to all users that have access to the project, and also will be available in the browser-based project view of the connected Workspace.

Mentions and Task Assignments

Along with text in the comment entry dialog, a 'mention' reference can be added for any other user or role registered with the connected Workspace by entering the @ character. Select a name/email from the dropdown list to add the user (Workspace member) reference to the comment, and also as an Assign a task to entry – essentially, a task will be assigned to the user. Uncheck the latter option if you do not wish the comment to be regarded as specifically assigned to that user. A Role group (say, 'Engineers'), and therefore its constituent users, may also be added as a mention.

If a mentioned user does not have access to the current project, you will be invited to share it with that user. This option is available if you are the project owner or a Workspace administrator. User Access Rights are granted through the Share dialog; the user will receive an email notifying them of the shared access. The project will not be shared if you cancel the Share dialog, but the comment will be placed as usual.

See more information about sharing a design.

When a task is assigned to a user, the image/photo of this user will be shown at the top-left of the comment dialog and the comment tile in the Comments and Tasks panel. Also, the task will be named with the project name and the sequence number (e.g., Kame_FMU-1) instead of a simple number as for normal comments. This name is also shown in the comment dialog and the comment tile – click it to open the Tasks page of the project in the Workspace's browser interface, with the selected task focused in the task list.

A task can be referenced to a project commit when saving the project to the connected Workspace. As the hint in the Save to Server dialog states, add the task ID to the Comment field (as it appears in the Comments and Tasks panel); the task will be linked to the project commit that will be created after clicking OK in the dialog.

The link to the commit will be shown in the task detail pane when the task tile is selected on the Tasks page of the Altium 365 Workspace browser interface or the Tasks view of the project's detailed management page. Click the link to open the project's History view with the related commit highlighted on the timeline.

The link to the connected commit will be shown in the task detail pane. Hover the cursor over the image to see the History page that opens after clicking the link and the related commit highlighted on the timeline.
The link to the connected commit will be shown in the task detail pane. Hover the cursor over the image to see the History page that opens after clicking the link and the related commit highlighted on the timeline.

Positioning

A comment's location in the editor space is moved by dragging its associated 'pin' to a new position – during or after its placement. When selected, the comment pin includes a connecting line to its associated object or area.

While you can move (drag) a comment pin around in the document editor, the initial defined point or area cannot be modified.

Note that a comment also may be positioned during its initial placement by clicking and dragging when in placement mode. ► See example.

Pasting Images

You can add an image to a comment by first copying the image from an Explorer window or a web browser page by right-clicking on the image, which copies the image to the clipboard. To attach the image, use right-click Paste (or the Ctrl+V shortcut) in the comment itself (in the field that states "Add others with @ or paste images"). 

Each image can be a maximum of 2MB. After it is pasted into the comment, click the image to display the full image, as shown in the image on the right.

Drawing

When placing or editing a comment, select the  option button to add freehand drawing with the resulting pen cursor. Click and drag to create lines, and then right-click to finish and associate the drawing with the currently selected comment.

To access the Freehand Drawing mode of the Properties panel, press the Tab key when freehand drawing mode is active (this is indicated by the  icon in the design space). These options allow you to undo and redo comments under the Commands drop-down and change the width size and color under the Properties drop-down.

General Tasks

General tasks (tasks applied to the current project but are not associated with a project comment or document) are listed in the panel in a separate group, under the entry of the project. For general tasks, the same content and attributes are shown in the panel as for regular tasks (assignee, priority, etc.).

General tasks are listed in the Comments and Tasks panel.
General tasks are listed in the Comments and Tasks panel.

A general task for a project can be created from the Tasks page of the Altium 365 Workspace browser-based interface when accessing the detailed management page for the project. To learn more, see Management of a Specific Project – Tasks.

Detached Comments

When a project document is removed or its UniqueID has changed, the comments for the document can become "detached". Those comments can still be accessed from the panel's Detached Comments collapsible region. Click on a detached comment's tile in the Comments and Tasks panel to show its dialog in the design space of the currently opened document.

Detached comments can be accessed from the dedicated region of the Comments and Tasks panel
Detached comments can be accessed from the dedicated region of the Comments and Tasks panel

PCB and Draftsman Comments

Comments also can be placed on a board layout in the PCB editor design space and on a Draftsman document using the same placement approach as that in the schematic editor. When a comment entry is selected in the Comments and Tasks panel, the system will open (and load if necessary) the associated design document.

An example comment in a PCB document
An example comment in a PCB document

An example comment in a Draftsman document.
An example comment in a Draftsman document.

BOM Comments

Comments can also be placed for an item in an ActiveBOM document. This can be done in the following ways:

  • Click the  button available in the Comments and Tasks panel.
  • Click  near the top right-hand corner of the design space.
  • Use the Tools » Comment command from the main menus.

After selecting a command, click on a row in the document to add a comment. Alternatively, right-click on a row then select the Comment command to add a comment to this row.

Working with Comments

Comments placed in a design document are registered in both the Comments and Tasks panel (as a sequence of numbered entries) and in the corresponding document editor (as numbered pin graphics). Each panel entry represents a comment thread and provides summary information that includes who placed the comment and when, the initial comment text, any applied mentions/assignments, and the number of thread replies.

A comment thread is opened by selecting its entry in the Comments and Tasks panel, or by clicking on its associated pin in the design space. This highlights the comment in the document editor and opens the comment entry dialog, which includes the initiating comment and any user replies. If a selected comment is associated with another design document, the system will open (and load if necessary) that document.

Navigating comments by selecting pin markers in the design space, and by selecting entries in the Comments and Tasks panel.

Comments Dialog

Interaction with a placed comment is through the pop-up comment dialog, which shows all entries in the selected comment thread and includes options to preview, reply, edit, resolve and delete an entry. The dialog is opened when initially placing a comment, or when a placed comment is selected in the Comments and Tasks panel or in the design space. Press Esc or click in the design space to close the comment dialog.

You can sequentially step through all available comments using the previous/next buttons () in the dialog's header.

Preview

Select the Original Snapshot option in the initial comment to see a graphical capture of the editor area when the comment was placed. Click the icon at the top-right of the screenshot or the screenshot itself to open a full-size preview (click the  icon at the top-right of this preview or the image itself to close it).

Reply

Enter text, and optionally a user mention ('@'), in the Reply field to add a new entry to the comment thread. Select the Assign a task to option to create a task assigned to a user specified in the drop-down. Click  to confirm the entry.

Edit and Delete

An existing comment may be edited by the author of that comment using the Edit option available from the comment's  menu. Click the  button to confirm the comment edit.

Use the Delete option to remove the currently selected comment. Note that the entire thread will be removed if the initial comment (as opposed to a Reply) is deleted.

Use the Convert to Task option to convert the comment to a task assigned to yourself.

Use the Copy Link option to copy the URL to the comment thread. This link can be used to open this project in the Web Viewer of the Workspace's browser interface, with an object, point, or area of the comment zoomed and centered.

Resolve

Click the dialog's / button to toggle the comment state between Resolved and Unresolved (the default). A resolved comment (closed as complete) is inactive and non-editable, and both its entry in the Comments and Tasks panel and its pin marker on the document are grayed out.

Setting Task Priorities and Statuses

If a task comment has been assigned to a user, its priority and status can be set. A task is initially immediately set to Medium priority and to To Do status but they can be changed by clicking an associated control at the top of the comment dialog.

To-Do Panel

While your connected Workspace provides a comprehensive set of features for commenting and task assignment described above, you can also access the To-Do panel to keep track of your tasks. The To-Do panel lists all To-Do items that are currently defined for the active project. A To-Do item is used as a reminder for a task that needs to be carried out at a later stage in relation to a document.

The To-Do panel
The To-Do panel

To access the panel, the Value field for the UI.PanelToDoList Preference Name on the Advanced Settings dialog must be enabled (it is disabled by default). The Advanced Settings dialog is accessed by clicking the Advanced button on the System - General page of the Preferences dialog. If any changes are made in the Advanced Settings dialog, the software must be restarted in order for the changes to take effect.

The To-Do panel can list two varieties of "to do" items for the active project:

  • A project-level To-Do item.
  • A document-level To-Do item - added to a text-based document within the project.

For each To-Do item, the following information is displayed:

  • Done - this check box enables you to check the item when its defined task has been completed.
  • Action Item - the actual task that needs to be performed.
  • Priority - the importance of the task to be performed (Lowest, Low, Normal (default), High, Highest).
  • Document - a reference to the source document to which a document-level To-Do item has been added.
  • Owner - this could be the name of the person entering the task or who is to actually perform the task.
  • Category - this could be the particular area within the project that the task to be performed falls under (e.g., schematics, design rules, routing, constraints, etc.).

Adding Project-level To-Do Items

Project-level To-Do items are added from within the panel itself. Before adding any items, ensure that the active document in the design editor window is one of the design documents for the project for which you want to define To-Do items.

To add a new To-Do item, right-click within the panel and choose the Add Project To-Do Item entry from the subsequent context menu that appears. The Edit To-Do Item dialog will open.

Use this dialog to enter suitable text pertaining to the task that needs to be carried out for the project. Use the available fields in the dialog to define a PriorityOwner, and Category for the task. After defining the item as required, click OK to add the new item to the panel.

Adding Document-level To-Do Items

Document-level To-Do items are added to a text-based source document (e.g., VHDL file, Constraint file, Embedded Source code document, etc.,). Before adding any items, ensure that the required document is active in the design editor window and that this document belongs to the project whose overall To-Do items you are currently defining.

To add a new To-Do item, place the text cursor at the required position within the document at which you wish to place a To-Do item, right-click and choose the Add To-Do Item entry from the subsequent pop-up menu that appears. The Edit To-Do Item dialog appears. Use this dialog to enter suitable text pertaining to the task that needs to be carried out at that point in the document. Use the available fields in the dialog to define a PriorityOwner and Category for the task (e.g., Formatting pass, Code Review pass, etc.,). After defining the To-Do item as required, click OK to close the dialog and return focus to the current document. An entry for the To-Do item will appear in the To-Do panel and also at the point marked by the current text cursor position. The entry will appear as a comment (between the comment delimiter(s) defined for that document type), including the actual text for the item and a unique identifier as shown in the image below.

Right-click Menu

The right-click menu provides the following commands:

  • Goto Source - this command becomes available when the selected item in the panel is a document-level To-Do item. Use this command to open (if not already) the associated source document referenced in the Document field of the item and make it the active document in the design editor window. The text cursor will be placed at the beginning of the To-Do item text.
  • Add Project To-Do Item - add a project-level To-Do item to the panel for the active project.
  • Edit - edit the selected To-Do item. The Edit To-Do Item dialog will appear in which you can make the required changes.
  • Delete - delete the selected To-Do item from the panel.
  • Show Completed Items - with this option enabled, only To-Do items that have been marked as complete (Done option enabled) will remain displayed in the panel.
  • Report - generate a report containing all To-Do items currently displayed in the panel. After launching the command, the Report Preview dialog will open in which you can configure, print and export the report in various file formats.

Notes

  • If a document-level To-Do item has been defined in the panel and the corresponding source document is the active document in the design editor window, the text for the entire To-Do entry in the panel will become bold.
  • Double-clicking on a To-Do item entry in the panel will open the Edit To-Do Item dialog, enabling you to make any required modifications to the task's definition.
  • The entries in the panel may be sorted by any column by clicking on the header for that column. Click once to sort in ascending order; click again to sort in descending order.
  • Direct filtering is available, allowing you to quickly jump to a To-Do item entry by directly typing within the panel. You can filter based on any data column in the panel. Use the Right Arrow and Left Arrow keys to switch between columns for filtering, or click directly on a field within a column. To use this filter feature, click within a data column and type the first letter of the entry to which you want to jump. The first entry in that column starting with the letter you type will become selected and the letter will be highlighted to show that filtering of the column content is based upon the letter typed.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: