SI Analyzer de Keysight
De un vistazo
- Descubre qué hace la extensión SI Analyzer by Keysight en Altium Designer y qué tipos de comprobaciones de integridad de señal permite realizar.
- Aprende a instalar la extensión, abrir un documento de SI Analyzer, añadir redes o clases y asignar especificaciones predefinidas o personalizadas.
- Comprende el flujo de trabajo básico para preparar las restricciones y los datos de análisis, de modo que puedas avanzar hacia la ejecución de comprobaciones de integridad de señal en tu diseño.
Cada vez más dispositivos electrónicos modernos incorporan diseños de PCB de alta velocidad, y las velocidades de las señales aumentan a medida que las tecnologías evolucionan (17 GHz en DDR6, 400 Gbps en QSFP++, etc.). Garantizar la integridad de la señal (SI) es un paso crucial en el diseño de alta velocidad. El incumplimiento de los requisitos del desarrollador de la interfaz puede provocar problemas en las etapas posteriores del diseño, la fabricación y el funcionamiento.
Para realizar un análisis de integridad de la señal directamente en el entorno de Altium Designer, está disponible la solución SI Analyzer by Keysight. SI Analyzer by Keysight, que se ofrece como una extensión de software, se integra directamente con Altium Designer y permite realizar una serie de comprobaciones de SI posteriores al trazado para evaluar los parámetros más importantes del diseño de alta velocidad:
-
Impedancia
-
Retardo
-
Pérdidas de inserción (IL)
-
Pérdidas de retorno (RL)
Acceso a las funciones de SI Analyzer by Keysight
Para acceder a las funciones de SI Analyzer by Keysight en Altium Designer, debe estar instalada la extensión de software SI Analyzer by Keysight . Esta extensión se puede instalar o eliminar manualmente.
Para obtener más información sobre la gestión de extensiones, consulte la página Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).
Una vez instalada la extensión de software SI Analyzer by Keysight, podrá:
-
Crear un documento de SI Analyzer by Keysight nuevo o abrir uno existente.
-
Añadir y configurar redes para un análisis de SI.
-
Revisar los resultados de análisis de SI existentes.
-
Generar un informe de análisis de SI.
Sin embargo, para realizar un nuevo análisis de SI, debe tener una suscripción válida a SI Analyzer by Keysight. De lo contrario, al intentar iniciar un análisis de SI se abrirá el cuadro de diálogo Analyze Your Nets, donde podrá solicitar una prueba gratuita
Inicio de SI Analyzer by Keysight
Para iniciar el análisis de integridad de la señal, abra el documento de PCB del proyecto y seleccione Tools » SI Analyzer by Keysight en los menús principales.
Se abrirá el documento de SI Analyzer by Keysight (<ProjectName> [SIK]) y se añadirá al área Source Documents del proyecto (en el panel Projects). Inicialmente, el documento no está guardado. Utilice el comando File » Save As de los menús principales para guardar el documento en la ubicación deseada.
Preparación para el análisis
Adición de redes para analizar
Tras iniciar SI Analyzer by Keysight, los datos de la PCB se importan (en formato ODB++) al motor de cálculo. En esta etapa, puede definir la lista de redes que se analizarán y asignarles especificaciones. Para ello, haga clic en el botón Manage Nets situado en la parte superior del documento de SI Analyzer by Keysight o utilice el comando Edit » Manage Nets de los menús principales (como alternativa, si no hay redes en el documento, también estará disponible el botón Manage Nets en el centro del documento). Se abrirá el cuadro de diálogo Manage Nets, que muestra la lista de clases de redes, pares diferenciales y xSignals de la PCB.
Marque la casilla de cada clase necesaria (o utilice la casilla del encabezado de la tabla para seleccionar todas las clases). Si lo desea, haga clic en la celda de la columna Specifications para mostrar una ventana emergente y seleccionar las especificaciones que definirán las restricciones de la clase seleccionada (que podrá redefinir más adelante si es necesario: más información). Puede elegir entre especificaciones integradas o definidas por el usuario (en la pestaña Specifications de la ventana emergente) o definir manualmente los valores de restricción necesarios para una clase (en la pestaña Custom Constraints de la ventana emergente).
Consulte la sección Gestión de especificaciones para obtener más información sobre cómo gestionar las especificaciones integradas o definidas por el usuario.
También puede expandir la lista All Nets situada en la parte inferior del cuadro de diálogo para seleccionar y asignar especificaciones a redes individuales del diseño.
Tras hacer clic en OK en el cuadro de diálogo, las clases seleccionadas se mostrarán en el documento de SI Analyzer by Keysight. Si se seleccionó una red en la región All Nets del cuadro de diálogo Manage Nets, se mostrará en la entrada de la clase All Nets. Expanda la entrada de una clase para ver sus redes/xSignals.
Expanda la entrada de una red, xSignal o par diferencial para ver los objetos que la componen (pads, pistas, arcos y vías) en la región Transmission Line. Sitúe el cursor sobre el recuadro de un objeto y haga clic en el icono
para localizar ese objeto en la PCB mediante sondeo cruzado.
Para eliminar del documento una clase o una red añadida individualmente, haga clic en el botón
situado a la derecha de su entrada.
Gestión de especificaciones
El cuadro de diálogo Manage Specifications, al que se accede haciendo clic en el botón Manage Specifications situado en la parte superior del documento de SI Analyzer by Keysight, permite gestionar tanto las especificaciones integradas como las definidas por el usuario. Después, las especificaciones se pueden asignar a una clase o red para definir rápidamente sus restricciones, tal como se describe en la sección anterior.
-
En el lado izquierdo del cuadro de diálogo se muestra la lista de especificaciones definidas actualmente. Para cada especificación se indican su nombre y uno o varios tipos de restricciones que define.
- Seleccione una especificación de la lista para mostrar sus detalles (nombre, si es una especificación Built-In o User-Defined, y restricciones) en el lado derecho del cuadro de diálogo.
-
Para crear una nueva especificación, haga clic en el botón Add New situado en la parte inferior izquierda de la lista de especificaciones. En el lado derecho del cuadro de diálogo se mostrarán los controles para definir la especificación:
-
Defina el nombre de la nueva restricción mediante el campo Specification Name.
-
Seleccione los tipos de restricciones que desee que defina esta especificación mediante las casillas de verificación: Impedance, Delay, Insertion Losses (IL) y/o Return Losses (RL).
-
Para los tipos de restricciones habilitados, defina sus valores. Para las restricciones de los tipos Impedance y Delay, utilice los campos de texto disponibles. Para las restricciones de los tipos Insertion Losses (IL) y Return Losses (RL), puede añadir, editar y eliminar límites para delimitar una zona de valores de pérdidas restringidos y permitidos en el intervalo de frecuencias requerido.
-
Una vez definida la especificación según sus necesidades, haga clic en el botón Save situado en la parte superior derecha del cuadro de diálogo para crearla, o haga clic en Cancel para salir sin crearla.
-
-
También se puede crear una nueva especificación duplicando una existente (ya sea definida por el usuario o integrada). Seleccione en la lista la especificación que desee duplicar y, a continuación, haga clic en el botón Duplicate situado en la parte inferior izquierda de la lista de especificaciones. Se creará una nueva especificación con el nombre inicial
<OriginalSpecificationName>(Copy)y las mismas restricciones que la original, lista para editarse en el lado derecho del cuadro de diálogo. Realice los cambios necesarios y haga clic en el botón Save de la parte superior para crear la especificación, o haga clic en Cancel para salir sin crearla. -
Para editar una especificación definida por el usuario, selecciónela en la lista y haga clic en el botón
del lado derecho del cuadro de diálogo. Realice los cambios necesarios y haga clic en el botón Save de la parte superior para guardar los cambios, o haga clic en Cancel para salir sin aplicar ningún cambio.
-
Para eliminar una especificación (ya sea definida por el usuario o integrada), selecciónela en la lista y haga clic en el botón
del lado derecho del cuadro de diálogo.
- Las especificaciones integradas que se hayan eliminado se pueden restaurar haciendo clic con el botón derecho en la lista de especificaciones y seleccionando el comando Restore Built-In Spec. Este comando no afectará a las especificaciones definidas por el usuario.
Definición de restricciones
Cada red se analizará para determinar si cumple las restricciones especificadas. Si se ha seleccionado una especificación para la clase a la que pertenece, las restricciones estarán definidas por esa especificación.
Para consultar las restricciones actuales de una red, xSignal o par diferencial, seleccione la pestaña Constraints cuando su entrada esté expandida.
Haga clic en el valor de una restricción para editarla en la ventana emergente que aparece.
Tenga en cuenta que, si el valor de una restricción se ha cambiado manualmente, se mostrará el mensaje de advertencia Custom constraints are used en la entrada correspondiente.
Ejecución de un análisis
Una vez completada la configuración, puede ejecutar un análisis de todas las redes añadidas, de una clase específica o de una red específica. Haga clic en el botón Analyze All situado en la parte superior derecha del documento de SI Analyzer by Keysight para analizar todas las redes, o en el botón Analyze de la entrada de una clase o red específica para analizar únicamente esa clase o red.
Exploración de los resultados
Una vez finalizado el análisis, los resultados se muestran en el documento de SI Analyzer by Keysight. El mensaje Analyzed se mostrará en la parte superior derecha del documento. Si todas las redes analizadas cumplen las restricciones, se mostrará el texto All Passed junto al mensaje. De lo contrario, se mostrará el texto Failed, con el número de redes que no cumplen las restricciones.
Si todas las redes de una clase superan el análisis, se mostrará el texto Success en su entrada. De lo contrario, se mostrará el texto Failed.
Expanda la entrada de una clase para ver los valores calculados (impedancia, retardo, pérdidas de inserción y pérdidas de retorno) de cada red analizada de esa clase. Los valores que cumplen las restricciones se muestran en verde; los que no las cumplen se muestran en rojo.
Expanda la entrada de una red para ver los valores calculados para esa red en la pestaña Results. Además, los recuadros de los objetos de la red que no cumplen las restricciones tienen un borde rojo en la región Transmission Line, y el valor que incumple la restricción se muestra en rojo.
Para ver los resultados del análisis de una clase o de una red/xSignal/par diferencial en la PCB, haga clic en el botón Show on PCB correspondiente.
El panel SI Analyzer by Keysight
En el editor de PCB, el proceso de análisis y sus resultados se controlan mediante el panel SI Analyzer by Keysight. Tenga en cuenta que el panel se añade a la lista de paneles disponibles (a través del botón Panels) después de realizar un análisis de integridad de señal y hacer clic en el botón Show on PCB.
Señal simulada
- Simulated Signal – utilice esta opción para seleccionar la clase o la red/xSignal/par diferencial que desea visualizar como mapa de calor en el espacio de diseño.
- Only nets with violations – cuando esta opción está activada, en la lista desplegable solo están disponibles las entidades que presentan actualmente alguna infracción. Desactive esta opción para mostrar todas las entidades analizadas.
- Show Heatmap – cuando esta opción está activada, se muestra un mapa de calor en el espacio de diseño para la entidad seleccionada actualmente en la lista desplegable Simulated Signal.
Debajo de estos controles, el panel tiene dos pestañas, General y Heatmap. Las opciones de estas pestañas se aplican a la entidad seleccionada actualmente en la lista desplegable Simulated Signal.
Mapa de calor
La pestaña Heatmap del panel SI Analyzer by Keysight se utiliza para controlar qué datos se representan como mapa de calor, ya sea la impedancia o el retardo, y cómo se aplica el color a la impedancia o al retardo. Tenga en cuenta que estos controles de configuración del mapa de calor solo están disponibles cuando la opción Show Heatmap está activada.
Utilice los botones Impedance y Delay para alternar entre los dos modos. Toda la red se colorea para reflejar la impedancia o el retardo en cada punto de su recorrido, de la siguiente manera:
- Para la impedancia, cuanto más se acerque al valor objetivo Z0, más verde será el color, y cuanto más se aleje de dicho valor, más rojo será. Los valores calculados inferiores al mínimo y superiores al máximo se muestran en rojo.
- Para el retardo, cuanto mayor sea, más cálido (más rojo) será el color, y cuanto menor sea, más frío será el color. Los valores calculados inferiores al mínimo se muestran en azul y los superiores al máximo se muestran en rojo.
La escala de colores refleja cómo se aplica el color. Los valores mínimo y máximo se pueden ajustar haciendo clic y arrastrando el control deslizante, o introduciendo un nuevo valor en los campos inferiores. La escala también se muestra como una barra de colores en el espacio de diseño, debajo de la PCB.
Active la opción Color focus on results para resaltar la entidad seleccionada actualmente en la lista desplegable Simulated Signal y ocultar los demás objetos de la PCB.

Ejemplo de un mapa de calor para los cálculos de impedancia.

Ejemplo de un mapa de calor para los cálculos de retardo.
Detección de infracciones
Si el análisis detecta infracciones de las restricciones para la entidad seleccionada actualmente en la lista desplegable Simulated Signal, estas se enumeran en la región Violations de la pestaña General del panel SI Analyzer by Keysight.
- Utilice los botones de la parte superior de la región para definir qué tipos de infracciones deben mostrarse en la lista.
- Utilice el botón Analyze de la parte inferior de la región para volver a ejecutar el análisis de integridad de señal. Esto permite comprobar rápidamente si la entidad cumple la restricción después de aplicar cambios en el editor de PCB, sin tener que volver al documento de SI Analyzer by Keysight.
Sondas
La región Probes del panel SI Analyzer by Keysight se utiliza para colocar sondas de medición directamente en la PCB. Las sondas pueden medir la impedancia o el retardo; el tipo de medición viene determinado por el modo actual del mapa de calor de la placa.
Las sondas pueden ser individuales, para medir un valor absoluto en la ubicación de la sonda, o diferenciales, para medir la diferencia entre las dos ubicaciones de la sonda. Ambos tipos se colocan haciendo clic en el botón Add de la región Probes del panel. Para colocar una sonda individual, haga clic en la ubicación deseada y, a continuación, haga clic con el botón derecho del ratón (o pulse Esc). Para colocar una sonda diferencial, haga clic una vez para definir la primera ubicación y, después, haga clic de nuevo para definir la segunda. Una vez definida la sonda, los resultados de la medición se mostrarán en el panel.

Ejemplo de una sonda individual

Ejemplo de una sonda diferencial
Haga clic en una entrada de sonda del panel para mostrar su ubicación o ubicaciones en la PCB. Seleccione una entrada de sonda en el panel y haga clic en el botón
de la parte inferior de la región para eliminarla.
Haga clic en el botón Add to Report para crear una imagen de la PCB en la ubicación de la sonda seleccionada. La imagen se mostrará en la región Image Captures del panel, identificada con un distintivo Probe. Sitúe el cursor sobre la captura de pantalla para mostrar los detalles de la sonda.
Capturas de imágenes
La función de captura de imágenes del panel SI Analyzer by Keysight permite realizar capturas de pantalla específicas del diseño, que luego se pueden incluir en un informe.
Para capturar una zona específica de la placa, primero ajuste la vista de la placa en el espacio de diseño de modo que los elementos que desee incluir en la captura sean visibles. Cuando esté listo, haga clic en el botón Add de la región Image Captures del panel para realizar la captura de pantalla. Puede seguir cambiando la vista de la placa y añadir más imágenes.
Para eliminar una imagen, sitúe el cursor sobre ella para que aparezca el botón
y, a continuación, haga clic en él.
Generación de informes de resultados
Para generar un informe completo del análisis, haga clic en el botón Full Report de la parte superior del documento de SI Analyzer by Keysight. El informe completo incluye una sección para cada clase (y la entrada All Nets para las redes añadidas individualmente que no pertenecen a ninguna clase de redes).
En el informe completo, haga clic en el nombre de una clase de redes (o en el nombre de la red en la lista All Nets) para ver un informe detallado que incluye:
- Nombre de la clase de redes o de la red.
- Especificaciones asignadas.
- Resumen de la comprobación de restricciones. Haga clic en una comprobación fallida para ver recomendaciones para solucionar los problemas relacionados.
- Apilado de capas de la placa.
- Comprobaciones de restricciones para cada red. Expanda la entrada de una red para ver las comprobaciones de restricciones de cada objeto de esa red.
- Gráfico de pérdidas de inserción.
- Gráfico de pérdidas de retorno.
Al explorar un informe detallado, haga clic en el botón Show on PCB para abrir la PCB y el panel SI Analyzer by Keysight para explorar la clase o la red.
Trabajo con gráficos
Los gráficos de pérdidas de inserción y de pérdidas de retorno muestran las formas de onda correspondientes a cada red de la clase que se está explorando. El área roja del gráfico indica la zona restringida definida por las restricciones.
-
Utilice el menú desplegable situado en la parte superior derecha del gráfico de pérdidas de inserción o de pérdidas de retorno para gestionar las redes que se muestran en él. Se pueden mostrar todas las redes, las redes con comprobaciones fallidas o redes específicas.
-
Haga clic en el nombre de una forma de onda a la derecha del gráfico para resaltarla atenuando las demás formas de onda. Vuelva a hacer clic en el nombre de una forma de onda para quitar el resaltado.
-
Gire la rueda del ratón para acercar o alejar la vista tomando como referencia la posición del puntero en el gráfico. Cuando el puntero esté sobre un eje del gráfico, gire la rueda del ratón para acercar o alejar la vista tomando como referencia la posición del puntero únicamente en ese eje (la escala del otro eje no cambiará).
-
Se pueden realizar mediciones de datos mediante cursores de medición. Hay dos cursores disponibles, que pueden añadirse a la misma forma de onda o a formas de onda diferentes de un gráfico. Haga clic con el botón derecho en el nombre de una forma de onda a la derecha del gráfico y utilice los comandos Cursor A y Cursor B del menú contextual para activar o desactivar los cursores. Para mover un cursor, haga clic en su pestaña y arrástrela. Los datos medidos con un cursor activado se muestran en la parte inferior del gráfico.

Ejemplo de los cursores A y B añadidos a la misma forma de onda.
Exportación del informe
Haga clic en el botón Save Report para guardar el informe en formato HTML. Utilice el cuadro de diálogo Report Settings que aparece a continuación para configurar qué redes (cuando se accede al cuadro de diálogo desde el informe completo) y qué datos específicos se incluirán en el informe.
Después de hacer clic en el botón Generate Report, el informe se guarda en una subcarpeta de la carpeta del proyecto denominada \SiAnalyzerByKeysight_Output\HTMLReport\<ProjectName>.sik_<CurrentDate>_<CurrentTime>. Todas las imágenes del informe se guardan en una subcarpeta \Images.
).
).

).
. Si una red forma parte de un par diferencial, se añadirá al documento de SI Analyzer by Keysight como un par diferencial, junto con la otra red del par, y su entrada tendrá el icono
.












