Navegar por un documento

Altium Training

Altium Essentials: Navigating Schematics

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Al trabajar con un documento gráfico, como una hoja de esquemático, un documento PCB o un documento de Draftsman, puede ampliar, reducir y desplazar la vista para centrarse en un área específica del documento. Los atajos básicos que puede utilizar para ello son:

  • Ctrl+Mouse Wheel para ampliar y reducir la vista
  • Right-Click, Hold&Drag para desplazar el documento

El menú principal View incluye varios comandos que permiten controlar la vista del documento actual.

Utilice los comandos del menú principal View para controlar la vista del documento. En la imagen superior se muestra el menú View del editor de esquemáticos. En la imagen inferior se muestra el menú View del editor de PCB.

Utilice los comandos del menú principal View para controlar la vista del documento. En la imagen superior se muestra el menú View del editor de esquemáticos. En la imagen inferior se muestra el menú View del editor de PCB.

Estos comandos incluyen:

  • Fit Document - mostrar toda el área del documento actual.

  • Fit All Objects - mostrar todos los objetos de diseño del documento actual.

  • Area - ampliar un área del documento actual definida por el usuario.

  • Around Point - redefinir el área de visualización en torno a un punto especificado del documento actual.

  • Selected Objects - cambiar la vista del espacio de diseño para que todos los objetos seleccionados queden visibles.

  • Zoom In - acercar el diseño, tomando como referencia la posición del cursor en el documento actual.

  • Zoom Out - alejar el diseño, tomando como referencia la posición del cursor en el documento actual.

  • Zoom Last - volver a la vista anterior de la pantalla en el documento actual.

También puede utilizar el atajo Z para acceder al menú emergente con los comandos de zoom.

En los editores de PCB y de huellas de PCB, este menú permite acceder al comando Select, que abre el cuadro de diálogo Zoom Value (0.001x..4x), desde donde puede cambiar el nivel de ampliación del documento actual mediante un valor específico. Los valores superiores a 1 permiten acercar más la vista (aumentar la ampliación). Los valores inferiores a 1 permiten alejar más la vista (reducir la ampliación).

El cuadro de diálogo Zoom Value
El cuadro de diálogo Zoom Value

Al visualizar un documento PCB o de huella de PCB en 3D, dispone de comandos, atajos y controles adicionales para navegar por la vista con fluidez. Consulte la página Control de la vista 3D para obtener más información.

Saltar a un punto específico de un documento

Con los comandos del submenú Edit » Jump de los menús principales del editor de esquemáticos, de símbolos de esquemático, de PCB o de huellas de PCB, puede saltar a un punto específico del documento activo. También puede acceder al menú emergente de salto pulsando la tecla J en el espacio de diseño. Por ejemplo, puede saltar a:

  • la coordenada de origen del documento:
    • el punto de origen de una hoja de esquemático (que corresponde a la esquina inferior izquierda) - Origin;

    • el origen absoluto del documento PCB - Absolute Origin;

    • el origen relativo del documento PCB actual - Current Origin;

    • la ubicación del punto de referencia del componente en el documento de huella de PCB - Reference;

  • cualquier ubicación del documento actual, a partir de las coordenadas XY especificadas por el usuario: seleccione el comando New Location para introducir, en el cuadro de diálogo Jump To Location que aparece, los valores de las coordenadas X e Y del espacio de diseño correspondientes a la ubicación a la que desea que salte el cursor. En el editor de PCB, también puede utilizar los campos Delta X y Delta Y para especificar los incrementos de las coordenadas X e Y de la ubicación a la que desea saltar.

    El cuadro de diálogo Jump To Location en el editor de esquemáticos (primera imagen) y en el editor de PCB (segunda imagen)
    El cuadro de diálogo Jump To Location en el editor de esquemáticos (primera imagen) y en el editor de PCB (segunda imagen)

  • un objeto del documento. Utilice los siguientes comandos para saltar al objeto que le interese:
    • un componente de la hoja de esquemático - Jump Component. Tras ejecutar el comando, aparecerá el cuadro de diálogo Component Designator. Introduzca el designador del componente al que desea saltar. Si el designador es válido y el componente existe en un documento esquemático de origen del proyecto activo, el documento esquemático correspondiente pasará a ser el documento activo y la vista se ampliará y centrará en el componente de destino (siempre que sea posible) dentro del espacio de diseño. El componente encontrado (o todas sus partes, si se trata de un componente de varias partes) también se muestra en el panel Messages . Haga doble clic en una entrada de mensaje para saltar a ese componente (o a una de sus partes) en el espacio de diseño.

      El cuadro de diálogo Component Designator
      El cuadro de diálogo Component Designator

      Si busca un componente de varias partes, introduzca únicamente el designador raíz. No incluya el sufijo de la parte. Por ejemplo, para saltar a un circuito integrado de dos partes cuyos designadores son IC1_CPA y IC1_CPB, introduzca IC1_CP en el cuadro de diálogo Component Designator. En el caso de un componente de varias partes, se resaltará la primera y se abrirá el cuadro de diálogo Find Text - Jump. Utilice este cuadro de diálogo para saltar entre las distintas partes del componente.
      Active la opción Physical en el cuadro de diálogo Component Designator para limitar la función de salto a los designadores físicos de los componentes, es decir, los que aparecen en las vistas de las pestañas Compiled Document de los documentos esquemáticos de origen. Con esta opción desactivada, la función de salto solo tendrá en cuenta los designadores lógicos, es decir, los que aparecen en las vistas de las pestañas Editor de los documentos esquemáticos de origen.
    • un componente específico del documento PCB - Component. Tras ejecutar el comando, aparecerá el cuadro de diálogo Component Designator. Introduzca el designador del componente para saltar a él. Si no conoce con certeza el designador, escriba ? y haga clic en OK para abrir el cuadro de diálogo Components Placed, que muestra todos los componentes del diseño. Introduzca texto en el campo Mask para buscar el componente deseado. A medida que escribe, la lista se filtra para mostrar únicamente las cadenas que coinciden con el patrón de búsqueda. Puede utilizar los comodines ? (cualquier carácter individual) y * (cualquier secuencia de caracteres) en la cadena. El cursor saltará al punto de referencia del componente que seleccione.

      Escriba ? en el cuadro de diálogo Component Designator para acceder al cuadro de diálogo Components Placed, que muestra todos los componentes de la PCB.
      Escriba ? en el cuadro de diálogo Component Designator para acceder al cuadro de diálogo Components Placed, que muestra todos los componentes de la PCB.

    • una red específica del documento PCB - Net. Tras ejecutar el comando, aparecerá el cuadro de diálogo Net Name. Introduzca el nombre de la red a la que desea saltar, o escriba ? y pulse OK para abrir el cuadro de diálogo Nets Loaded, que contiene una lista de todas las redes cargadas en el diseño. Introduzca texto en el campo Mask para buscar la red deseada. A medida que escribe, la lista se filtra para mostrar únicamente las cadenas que coinciden con el patrón de búsqueda. Puede utilizar los comodines ? (cualquier carácter individual) y * (cualquier secuencia de caracteres) en la cadena de búsqueda. Si la red de destino ya se muestra en la ventana principal de diseño, el cursor saltará al objeto de diseño más cercano que pertenezca a esa red. Si la red está fuera de la vista, el cursor se situará en el objeto de diseño más cercano que pertenezca a esa red, y la vista se centrará en él dentro del espacio de diseño (siempre que sea posible).

      Escriba ? en el cuadro de diálogo Net Name para acceder al cuadro de diálogo Nets Loaded, que muestra todas las redes de la PCB.Escriba ? en el cuadro de diálogo Net Name para acceder al cuadro de diálogo Nets Loaded, que muestra todas las redes de la PCB.

    • un pad específico de un componente en el documento de PCB - Pad. Tras ejecutar el comando, aparecerá el cuadro de diálogo Jump To Pad Number. Introduzca el pad requerido del componente deseado con el formato ComponentDesignator-PadDesignator (p. ej., U1-6) y haga clic en OK. Si el pad de destino ya se muestra en el espacio de diseño, el cursor simplemente saltará al centro de ese pad. Si el pad está fuera de la vista, el cursor se situará en el centro del pad y este quedará centrado en el espacio de diseño (siempre que sea posible).

      El cuadro de diálogo Jump To Pad Number
      El cuadro de diálogo Jump To Pad Number

    • una cadena de texto específica en el documento de PCB - String. Tras ejecutar el comando, aparecerá el cuadro de diálogo Jump To String. Escriba la cadena de texto a la que desea saltar, o escriba ? y haga clic en OK para abrir el cuadro de diálogo Strings, que contiene una lista de todas las cadenas de texto presentes en el documento de placa activo (tanto las independientes como las que forman parte de otros objetos de grupo). Utilice este cuadro de diálogo para localizar rápidamente la cadena de texto a la que desea saltar. Si la cadena de texto de destino ya se muestra en el espacio de diseño, el cursor simplemente saltará a su punto de anclaje: el punto por el que se sujeta durante una operación de desplazamiento o alrededor del cual gira. Si la cadena de texto está fuera de la vista, el cursor se situará en su punto de anclaje y este quedará centrado en el espacio de diseño (siempre que sea posible).

      Escriba ? en el cuadro de diálogo Jump To String para acceder al cuadro de diálogo Strings, que muestra una lista de todas las redes de la PCB.
      Escriba ? en el cuadro de diálogo Jump To String para acceder al cuadro de diálogo Strings, que muestra una lista de todas las redes de la PCB.

      El sistema realizará tres búsquedas: primero buscará una cadena de texto que coincida con la especificada en mayúsculas y minúsculas, caracteres y longitud; después, una cadena con los mismos caracteres, pero que quizá contenga caracteres adicionales; y, por último, una cadena con los mismos caracteres, sin distinguir entre mayúsculas y minúsculas.

    • saltar a todos los marcadores de error del documento de diseño actual y recorrerlos - Error Marker. Tras ejecutar el comando, el cursor saltará al primer marcador de error de comprobación de reglas de diseño (DRC), que quedará centrado en la ventana principal de diseño. Al utilizar el comando repetidamente, se saltará al segundo marcador de error y así sucesivamente. Este comando saltará a un marcador de error independientemente de si la infracción está eximida o no.

      Consulte las infracciones asociadas al objeto situado bajo el cursor haciendo clic con el botón derecho y eligiendo el comando correspondiente del submenú Violations .

  • saltar a todos los objetos de diseño seleccionados en el documento actual y recorrerlos - Selection. Tras ejecutar el comando, el cursor saltará al primer objeto seleccionado, que se mostrará ampliado y centrado en la ventana principal de diseño. Al utilizar el comando repetidamente, se saltará al segundo objeto seleccionado y así sucesivamente, recorriendo todos los objetos seleccionados en el documento actual. El comando recorre los objetos seleccionados en el orden en que se añadieron originalmente a la selección.

  • una posición en el documento de esquemático o de PCB actual, cuyas coordenadas se hayan guardado previamente en el marcador de ubicación indicado: seleccione el comando Location Marks » n para saltar a la posición que se haya guardado en el marcador de ubicación indicado mediante el comando Set Location Marks » n.

    En un documento de esquemático, una ubicación guardada solo está disponible mientras el documento permanezca abierto (esté activo o no). Si el documento se cierra y se vuelve a abrir, el marcador de ubicación estará vacío. En un documento de PCB, los marcadores de ubicación se guardan con el diseño, por lo que se puede seguir accediendo a las posiciones definidas por el usuario entre sesiones de diseño.
AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.