Controlar la vista 3D
Altium Essentials: PCB Introduction
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
De un vistazo
- Aprende los atajos de teclado y los controles del ratón para ampliar y reducir la vista, desplazarla, girar tu PCB y cambiar su orientación en el modo de diseño 3D.
- Comprende cómo Altium Designer gestiona los estados de la vista al alternar entre 2D y 3D, y cómo modificar el comportamiento predeterminado.
- Descubre las opciones de visualización específicas de 3D disponibles en el panel View Configuration, como la proyección, los colores, la escala del grosor de la placa y la visibilidad de los cuerpos 3D.
El editor de PCB es un verdadero espacio de diseño tridimensional y permite alternar fácilmente entre los modos de visualización 2D y 3D. Esta página describe las funciones del editor de PCB para controlar la presentación de la placa en el modo de diseño 3D.
Para cambiar al modo de visualización tridimensional: seleccione el comando View » 3D Layout Mode en los menús principales; utilice el atajo 3; o cambie la opción 3D en la sección General Settings de la pestaña View Options del panel View Configuration al estado On. Pulse el atajo 2 para volver al modo de visualización bidimensional.
Navegación por una PCB en 3D
En el modo de diseño 3D del editor de PCB, puede ampliar y reducir la vista con fluidez, girarla e incluso desplazarse por el interior de la placa mediante diversas combinaciones de teclado y ratón. El siguiente vídeo muestra estas técnicas de control de la vista.
Utilice las teclas del teclado en combinación con el botón derecho del ratón para orientar la vista 3D.
Utilice las siguientes combinaciones de teclado y ratón para:
Desplazamiento
| Any direction | Right-drag mouse |
| Up/Down | Roll mouse-wheel |
| Left/Right | Shift+Roll mouse-wheel |
| Numeric keypad | Teclado numérico, en combinación con la tecla Ctrl:
|
Rotación
| Mostrar la esfera de orientación | Hold Shift key down Al mantener pulsada la tecla Shift, aparece una esfera de orientación en la posición actual del cursor (como se muestra en la animación anterior). El movimiento de rotación del modelo se realiza alrededor del centro de la esfera; coloque el cursor para definir el punto de pivote antes de pulsar Shift. A continuación, utilice los siguientes controles para girar la placa: |
| Shift + Right-drag mouse | Mantenga pulsado Shift para mostrar la esfera, mueva el ratón para resaltar y seleccionar el control deseado en la esfera y, a continuación, haga clic con el botón derecho y realice la acción Shift + Right-drag mouse:
|
| Numeric keypad | Pulse la tecla correspondiente del teclado numérico para:
|
Reorientar la vista
| Main keyboard |
|
| Numeric keypad |
|
Control de la vista al alternar entre los modos de visualización 2D y 3D
Al pulsar los atajos 2 y 3 para alternar entre los modos de visualización 2D y 3D, el comportamiento predeterminado es que cada vista conserve su último estado. Esto significa que, si tenía la placa completa visible en el modo 2D y luego cambió al modo 3D y amplió la vista, al volver al modo 2D se mostrará de nuevo la placa completa. Si lo necesita, puede anular este comportamiento manteniendo pulsados los atajos Ctrl+Alt mientras pulsa 2 o 3.
|
La placa completa se muestra en 2D Si cambia a 3D y luego amplía la vista, al pulsar 2 para volver a 2D, se muestra el último estado de la vista 2D (la placa completa). En su lugar, mantenga pulsado Ctrl+Alt mientras pulsa 2 para mostrar la placa en 2D utilizando el último estado de la vista 3D. |
Ajustes de configuración de la vista 3D
Los modos de visualización 2D y 3D se configuran en el panel View Configuration. Para mostrar el panel: pulse el atajo L; utilice el botón Panels situado en la esquina inferior derecha del software; o seleccione la opción de menú View » Panels » View Configuration.
Al cambiar al modo de diseño 3D, aparecen opciones adicionales para controlar la presentación de la placa en 3D en la pestaña View Options del panel View Configuration.
La pestaña Opciones de vista del panel Configuración de vista incluye controles específicos para 3D.
Ajustes generales
Configuración 3D
| Board thickness (Scale) | Controla la escala vertical de la vista 3D para facilitar la diferenciación de las capas, por ejemplo, al revisar las conexiones entre capas de una vía ciega interna. La transparencia de cada capa 3D se establece a continuación; puede deslizar el control para see through los objetos de una capa específica. Arrastre el control deslizante de grosor para establecer la escala vertical entre 1 y 100 veces el grosor real de la placa. |
| Colors – Realistic / By Layer |
La presentación predeterminada representa la placa 3D utilizando colores Realistic basados en el Configuration seleccionado actualmente en la sección General Settings de este panel. Haga clic en el botón By Layer para mostrar la vista 3D utilizando las asignaciones de colores de las capas 2D actuales. |
| Grid |
|
| Component transparency | La transparencia de los componentes 3D se configura en el modo 3D Models del panel PCB. Seleccione uno o varios componentes para ajustar su transparencia |
Vista en sección de la placa 3D
Una vista en sección permite cortar virtualmente la placa en una ubicación seleccionada, mostrando una vista en corte de la placa y los componentes. Utilícela para examinar componentes pequeños colocados debajo de un componente más grande o de una pieza mecánica, o para examinar el recorrido estructural de las vías ciegas y enterradas a través de las capas de la placa. Una vista en sección se obtiene definiendo planos en los que una sección de la PCB se sliced o cut away, a lo largo de uno, dos o tres de los ejes de la placa.
La función de vista en sección está disponible en el modo de diseño 3D del editor de PCB. Para habilitar la vista en sección: seleccione el comando View » Toggle Section View; haga clic en el botón
de la barra activa; o utilice los botones de la opción Section View en la pestaña Section View del panel View Configuration para alternar la visualización entre Edit, On y Off.
|
Edit modo de la vista en sección aplicado a una PCB. On modo de la vista en sección aplicado a una PCB. Off modo de la vista en sección aplicado a una PCB. |
Controles de la vista en sección
| Section View Origin | Cuando la vista en sección está habilitada, el origen actual se indica mediante el manipulador de tres flechas Los objetos de la PCB situados más allá del origen (en el espacio positivo de la vista en sección) se muestran cuando la vista en sección está configurada en Edit o On. |
| Edit | En el modo Edit, los planos de sección se muestran en el espacio de diseño; cada plano se indica mediante una superficie semitransparente de color que se extiende desde el origen de la vista en sección. La ubicación de cada plano de sección se puede cambiar haciendo clic y arrastrando la flecha del color correspondiente del manipulador de la vista en sección. También puede habilitar o deshabilitar planos de sección individuales y configurar su dirección y color mediante los controles de la parte inferior del panel. |
| On | Se aplica el corte y se ocultan los planos de sección. |
| Off | En este modo no se aplica el corte. |
| Invert Cutout | De forma predeterminada, se oculta todo lo que se encuentra en el espacio negativo de la vista en sección actual, es decir, solo se muestran los objetos que aparecen en el espacio positivo de la vista en sección. Este comportamiento se invierte si se habilita la opción Invert Cutout, de modo que se muestran los objetos del espacio negativo y se ocultan los del espacio positivo. |
| Plane controls | Hay controles de los planos en la sección inferior del panel: 1) utilice las casillas para activar/desactivar un plano de sección específico, 2) haga clic en la muestra de color para configurar el color de ese plano y 3) haga clic en la flecha de dirección para controlar la dirección en la que se aplica el plano |
Generación de salidas de tipo 3D
Se pueden generar diversos tipos de salidas 3D a partir de la PCB. La siguiente tabla resume las salidas disponibles y cómo se configura y genera cada una.

Una captura de pantalla 3D de 300 ppp tomada desde el editor de PCB y reducida posteriormente en un editor de imágenes al tamaño máximo admitido por este editor de documentación web.
Salidas 3D disponibles
Tipo de salida |
Desde |
Notas |
| Screen capture | Editor de PCB | Cuando el editor esté en el modo de diseño 3D, pulse Ctrl+C para tomar una captura de pantalla de la vista actual. Aparecerá el cuadro de diálogo 3D Snapshot Resolution; seleccione el Render Resolution deseado y haga clic en OK para copiar la imagen al portapapeles de Windows. Desde allí, péguela en su editor de mapas de bits preferido. |
| Export as an image | Editor de PCB | Seleccione el comando File » Export » PCB 3D Print. Tras seleccionar la ubicación donde guardar el archivo de imagen, se abrirá el cuadro de diálogo PCB 3D Print Settings, donde podrá establecer la resolución de renderizado, cómo desea visualizar la placa y el formato de imagen. |
| PCB 3D Print | OutputJob | Se configura en el cuadro de diálogo de configuración de impresión 3D de PCB. En OutputJob, asigne la salida a un contenedor New PDF o directamente a una impresora. Coloque la placa según sea necesario antes de generar la salida y, a continuación, haga clic en los botones Take Current Camera Position y Take Current View Configuration para generar una impresión de lo que ve en pantalla. También puede crear un archivo de imagen asignando el Output Job a un contenedor de salida de estructura de carpetas. |
| PCB 3D Video | OutputJob | Se configura en el cuadro de diálogo PCB 3D Video. En OutputJob, asigne la salida a un contenedor New Video. La salida puede generarse en diversos formatos de vídeo. Para generar esta salida, primero debe definir una película 3D de la PCB en el panel PCB 3D Movie Editor. Consulte la página Preparación de un vídeo 3D de PCB para obtener más información. |
| PDF 3D | Notas/Editor de PCB | Se configura en el cuadro de diálogo PDF3D. En OutputJob, asigne la salida a un New Folder Structure. Se requiere Adobe Acrobat v9 o posterior para admitir el movimiento 3D. La salida también puede incluir fotogramas clave de una película 3D de la PCB, si se ha definido alguna. Consulte la página Preparación de un archivo PDF3D para obtener más información. |
| Mechanical data | Editor de PCB | La placa terminada también se puede exportar en varios formatos de datos mecánicos (en su estado plegado, en el caso de una placa rígido-flexible, si es necesario), lista para cargarla en su herramienta de diseño MCAD. Obtenga más información sobre la importación/exportación de formatos mecánicos. |
).
).
).


).


).
).