Creazione e gestione dei processi

Altium Designer offre un potente ambiente di progettazione collaborativa. Parte di questo supporta i Workflows, che guidano i progettisti di un'azienda attraverso i tipici processi di progettazione quotidiani, quali:

  • Richiesta di nuovi componenti di libreria del Workspace
  • Esecuzione di revisioni di progetto
  • Creazione di nuovi progetti del Workspace.

Ogni Workflow utilizzato per implementare uno specifico processo di progettazione viene creato come parte di un Process Definition. Può quindi essere considerato il Workflow sottostante di quel processo, o semplicemente un Process Workflow.

I processi e i relativi Workflow vengono creati e gestiti tramite l'interfaccia browser del Workspace di Enterprise Server, da un amministratore di quel Workspace.

Per le tre aree di progettazione menzionate in precedenza, con l'installazione del server sono inclusi workflow di processo predefiniti. Alcuni di questi sono attivati e pronti all'uso. Puoi usarli, modificarli oppure crearne di tuoi secondo necessità, in base alle esigenze della tua azienda. Altri sono invece esempi: non possono essere attivati e usati così come sono. Ognuno di questi è quindi più simile a un "modello": modificalo in base ai requisiti della tua azienda, assegnagli un nome e salvalo come nuova definizione di processo, che can potrai poi attivare e utilizzare insieme a tutte le altre definizioni.

Un potente Process Workflow Editor offre la flessibilità necessaria per costruire processi con workflow semplici o complessi quanto serve, in linea con i requisiti della tua azienda.

Accesso ai processi

Tutta la gestione dei processi viene eseguita dall'area Processes (Admin – Processes) dell'interfaccia browser del Workspace di Enterprise Server.

Per visualizzare l'area Processes dell'interfaccia, devi aver effettuato l'accesso come amministratore del tuo Workspace di Enterprise Server.

Accesso all'area Processes dell'interfaccia browser del Workspace di Enterprise Server: il centro di comando per lavorare con i processi e i workflow associati.Accesso all'area Processes dell'interfaccia browser del Workspace di Enterprise Server: il centro di comando per lavorare con i processi e i workflow associati.

L'interfaccia Processes è organizzata nelle seguenti quattro schede:

  • Browser – fornisce un elenco riepilogativo di tutti i processi (attivi o chiusi). Se vuoi, è una dashboard centralizzata dei processi.
  • Part Requests – fornisce un'area dedicata per gestire i processi legati al tema delle richieste di componenti.
  • Project Activities – fornisce un'area dedicata per gestire i processi legati al tema del lavoro con i progetti del Workspace, come le revisioni di progetto e la pubblicazione in un sistema PLM.
  • Project Creations – fornisce un'area dedicata per gestire i processi legati al tema della creazione di nuovi progetti di progettazione nel Workspace.
Le ultime tre schede possono essere considerate Process Themes. I temi di processo consentono di raggruppare in modo intuitivo i vari processi per area di progettazione. Consentono inoltre al software di agevolare la creazione di nuovi processi, supportando solo gli elementi di workflow necessari per una particolare area e semplificando così la costruzione del workflow richiesto. In prospettiva, questo approccio fornisce ad Altium una base per estendere l'interfaccia aggiungendo ulteriori temi, quando necessario.

Le sezioni seguenti esaminano queste varie schede in modo più dettagliato.

Scheda Browser

Usa questa scheda per consultare centralmente tutti i processi attivi o chiusi, in tutti i temi di processo. Per impostazione predefinita, la scheda mostra tutti i processi Active (in esecuzione). Passa alla visualizzazione di tutti i processi Closed (ad esempio completati, rifiutati o terminati) utilizzando il campo a discesa sopra l'elenco.

Consulta tutti i processi attivi da un'unica comoda posizione. Passa il mouse sull'immagine per vedere un esempio di consultazione di tutti i processi chiusi.
Consulta tutti i processi attivi da un'unica comoda posizione. Passa il mouse sull'immagine per vedere un esempio di consultazione di tutti i processi chiusi.

Per ogni voce vengono presentate le seguenti informazioni, ove applicabile:

  • Status – lo stato del processo. Può essere uno dei seguenti:
    • Active – il processo è attualmente attivo e il workflow associato sta procedendo.
    • On hold – il processo è attualmente attivo, ma è in attesa di un input iniziale, come l'assegnazione del responsabile, prima che il workflow possa procedere.
    • Closed – il processo è ora chiuso, ad esempio perché è stato completato con successo oppure rifiutato.
    • Terminated – il processo è ora chiuso ed è stato terminato direttamente da un amministratore del Workspace.
  • Process Name – il nome della definizione di processo.
  • Title – questo campo viene utilizzato per distinguere tra più istanze dello stesso processo. Il titolo è il nome del processo, con un suffisso di istanza (#1, #2 e così via).
  • State – questo è lo stato attualmente raggiunto nel workflow associato al processo.
  • Assignee (solo processo attivo) – è l'utente che ora ha un'attività da eseguire per far avanzare il processo dal suo stato corrente nel workflow.
  • Started By – l'utente che ha avviato il processo.
  • Started At – la data e l'ora in cui il processo è stato avviato.
  • Ended At (solo processo chiuso) – la data e l'ora in cui il processo è stato chiuso.

Per un processo attivo è disponibile anche un controllo Terminate (). Fai clic su di esso per forzare la chiusura di un processo. Il processo verrà spostato nell'elenco dei processi Closed.

I processi possono essere ordinati in base a qualsiasi colonna dotata del controllo : fai clic sul controllo o sul nome della colonna. È inoltre possibile effettuare ricerche utilizzando il campo Search nella parte superiore dell'elenco. I dati in tutti i campi, eccetto Status, Started At, Ended At e Terminate, possono essere usati per la ricerca.
  • Puoi anche importare una definizione di processo precedentemente esportata da file, direttamente dalla scheda Browser . Per farlo, fai clic sul pulsante . Nella finestra di dialogo Open che compare, individua e apri il file Workflow richiesto (*.aaw). Verrà rilevato il tema di processo corretto e il contenuto del file verrà caricato nel Process Workflow Editor. Per maggiori informazioni, vedi Importazione/Esportazione di una definizione di processo.
  • Usa il pulsante per esportare un report delle attività attualmente elencate (Process Workflows) come file *.csv dettagliato delimitato da virgole – vedi esempio. È possibile esportare attività Active o Closed, e le voci da includere possono essere filtrate usando il campo Search del nome del processo. Dal lato progettazione, il pannello Explorer panel di Altium Designer include un pulsante equivalente – nella scheda Activites durante la consultazione di un progetto (usando la vista predefinita Project ) – per scaricare i dati delle attività attualmente elencate relative a quel progetto.

Fai clic su una voce di processo per visualizzare un diagramma del workflow sottostante (nella scheda Diagram sotto l'elenco), che mostra cosa deve accadere perché il processo venga completato e a che punto si trova il processo lungo il suo flusso, in termini di chi ha ora un'attività da svolgere per farlo avanzare.

Fai clic sul controllo in basso a destra per evidenziare il punto corrente raggiunto nel workflow: la voce dell'utente o degli utenti lampeggerà brevemente.

Visualizzazione del workflow sottostante per un processo selezionato nella relativa scheda Diagram. Ogni workflow è costruito in forma diagrammatica per consentirti di vedere a colpo d'occhio in quale punto del workflow si trova attualmente un processo e chi ha il prossimo compito da svolgere per consentirne l'avanzamento.Visualizzazione del workflow sottostante per un processo selezionato nella relativa scheda Diagram. Ogni workflow è costruito in forma diagrammatica per consentirti di vedere a colpo d'occhio in quale punto del workflow si trova attualmente un processo e chi ha il prossimo compito da svolgere per consentirne l'avanzamento.

Sono disponibili anche le seguenti schede aggiuntive:

  • Data – mostra tutti i dati pertinenti al processo. Per esempio, per un processo di revisione di progetto questo può includere il progetto e il relativo set di dati, il tipo di revisione, le persone coinvolte nella revisione ed eventuali allegati aggiuntivi. Per un processo di richiesta componente, questo può includere datasheet allegati, dati parametrici ed eventuali componenti preliminari.

    Le entità applicabili, come allegati, datasheet, progetto e set di dati del progetto (Item-Revision), appariranno come collegamenti ipertestuali per una rapida navigazione o apertura. Hai inoltre la possibilità di configurare i dati parametrici visibili all'utente standard in questa scheda. Durante la modifica del workflow di un processo, e senza alcun elemento selezionato, i dati che possono essere presentati nella scheda Data sono elencati nel riquadro a destra. Fai clic sul controllo Edit per accedere al relativo modulo (<ProcessName> Data).
  • History – mostra una cronologia delle azioni eseguite lungo il workflow del processo.

    Usa le schede Data e History per consultare rispettivamente ulteriori dettagli del processo e la traccia delle attività del suo workflow.Usa le schede Data e History per consultare rispettivamente ulteriori dettagli del processo e la traccia delle attività del suo workflow.

Schede Richieste componenti/Attività progetto/Creazioni progetto

Usa queste schede, che raggruppano i processi in temi specifici, per visualizzare, creare e gestire i workflow di processo da utilizzare rispettivamente per richiedere un nuovo componente di libreria del Workspace, eseguire revisioni di progetto o pubblicare in un sistema PLM, oppure creare nuovi progetti di progettazione.

Per impostazione predefinita, la regione superiore di una scheda presenta tutte le versioni Latest dei processi definiti all'interno del tema. Passa alla visualizzazione dei processi definiti All (cioè tutte le versioni) utilizzando il campo a discesa sopra l'elenco.

Esempio di consultazione delle versioni più recenti dei processi definiti per un tema specifico (in questo caso, il tema Project Activities).Esempio di consultazione delle versioni più recenti dei processi definiti per un tema specifico (in questo caso, il tema Project Activities).

Per ogni voce vengono presentate le seguenti informazioni:

  • Process Name : version – il nome della definizione di processo e la sua versione. Per essere sicuro di visualizzare/lavorare sempre con la versione più recente, verifica che il campo a discesa della versione sopra l'elenco sia impostato su Latest.
  • Instances (active / all) – il numero di istanze di questa versione della definizione di processo attualmente attive, insieme al numero totale di istanze avviate.
  • Created By – l'utente che ha creato questa versione della definizione di processo.
  • Created At – la data e l'ora in cui questa versione della definizione di processo è stata creata (salvata e distribuita).
  • Active – mostra se questa versione della definizione di processo è attiva () e quindi può essere utilizzata, oppure è sospesa (), oppure è una definizione di esempio (modello) () e quindi non può essere utilizzata. Solo le definizioni di processo attive appariranno nell'area pertinente della GUI di Altium Designer, per l'utilizzo da parte dei progettisti. Fai clic sull'icona per commutare lo stato attivo, se applicabile.

    Solo la versione più recente di una definizione di processo può essere utilizzata (resa attiva e avviata). Le versioni precedenti non possono essere usate, ma possono essere modificate per produrre una versione successiva. Inoltre, le definizioni di processo di esempio (il cui stato Active è contraddistinto da ) non possono essere usate immediatamente così come sono. Ognuna di queste è più simile a un "modello": modificala in base ai requisiti della tua azienda, assegnale un nome e salvala come nuova definizione di processo, che can potrai poi attivare e utilizzare insieme a tutte le altre definizioni.
  • Actions – fai clic sul controllo  per accedere a un menu di azioni per la definizione di processo:
    • Startcome amministratore, puoi avviare una nuova istanza di questa versione della definizione di processo selezionando questo comando. È disponibile solo se la definizione di processo è stata attivata. Se il processo è stato sospeso, oppure è una definizione di esempio (modello), il comando è disattivato e non è possibile avviare un'istanza.
    • Edit – seleziona per modificare il workflow sottostante della definizione di processo. Il diagramma del workflow di questa versione della definizione di processo verrà presentato nel Process Workflow Editor, come punto di partenza da cui lavorare. Qualsiasi amministratore può modificare qualsiasi definizione di processo definita dall'utente, indipendentemente da chi abbia originariamente creato quella definizione, e salvarla e distribuirla come versione successiva. Per le definizioni di processo predefinite fornite da Altium, puoi creare una nuova definizione di processo basata sulla modifica di una di queste (in sostanza effettuando un fork), ma non puoi modificare l'originale predefinito stesso. Per maggiori informazioni sulla modifica di una definizione di processo, vedi Modifica di una definizione di processo esistente.
    • Assign – seleziona per aprire la finestra Assign Access to This Workflow, dalla quale puoi definire quali utenti e/o gruppi possono accedere al workflow sottostante. Per maggiori informazioni sulla gestione dell'accesso a un workflow, vedi Gestione dell'accesso al workflow di processo.
    • Remove – seleziona per rimuovere (eliminare) questa versione della definizione di processo. Nota che alcune delle definizioni di processo predefinite fornite da Altium non possono essere rimosse (e quindi non dispongono di tale controllo). Se è stata avviata almeno un'istanza della definizione di processo, indipendentemente dal fatto che sia ancora attiva o meno, la definizione non può essere rimossa (il comando non verrà elencato nel menu).
Le definizioni di processo possono essere ordinate in base a qualsiasi colonna dotata del controllo : fai clic sul controllo o sul nome della colonna. È inoltre possibile effettuare ricerche utilizzando il campo Search nella parte superiore dell'elenco. I dati nelle colonne Process Name : version e Created By possono essere usati per la ricerca.

Fai clic su una voce di definizione di processo per visualizzarne il workflow diagrammatico nella scheda Diagram sotto l'elenco. Se esiste un'istanza attualmente attiva di un processo, la vista mostrerà a che punto si trova quel processo lungo il suo flusso, in termini di chi ha ora un'attività da eseguire per farlo avanzare.

Se sono attive più istanze di un processo, la vista Diagram mostrerà uno stato combinato. Fai clic sul controllo in basso a destra per evidenziare il punto corrente raggiunto nel workflow: la voce dell'utente o degli utenti lampeggerà brevemente.

Visualizzazione del workflow sottostante per un processo selezionato nella relativa scheda Diagram.Visualizzazione del workflow sottostante per un processo selezionato nella relativa scheda Diagram.

Definizioni di processo predefinite

Con l'installazione di Enterprise Server, Altium fornisce un certo numero di definizioni di processo, distribuite nei tre temi di processo. Alcune di queste sono attivate e pronte all'uso e possono essere usate così come sono, mentre altre sono esempi e non possono essere attivate e usate direttamente. Tutte possono essere utilizzate come punto di partenza per creare le tue definizioni di processo secondo necessità. Usa le seguenti sezioni comprimibili per accedere alle informazioni sulle definizioni di processo fornite.

L'installazione di Enterprise Server include anche il processo LibSync che sincronizza i dati dei componenti tra Enterprise Server e un'istanza PLM di destinazione. Si tratta di un workflow di processo "integrato" in sola lettura e pertanto non è modificabile né incluso nell'elenco dei processi nella pagina Processes del Workspace (Admin » Processes). Per maggiori informazioni, vedi Sincronizzazione dei componenti PLM.

Aggiunta di una nuova definizione di processo

Related page: Definizione di un workflow di processo

I nuovi processi possono essere creati utilizzando l'apposito Process Workflow Editor. Per accedere all'editor, attiva la scheda del tema in cui vuoi creare il nuovo processo, quindi fai clic sul pulsante in alto a destra della pagina.

È importante attivare prima il tema, in modo che il processo venga creato con il corretto Type.

Accesso al Process Workflow Editor. Assicurandoti di attivare prima il tema di processo desiderato, la nuova definizione di processo verrà impostata sul tipo di tema corretto.Accesso al Process Workflow Editor. Assicurandoti di attivare prima il tema di processo desiderato, la nuova definizione di processo verrà impostata sul tipo di tema corretto.

Assegna alla nuova definizione di processo un nome significativo, quindi costruisci graficamente il workflow e definisci gli aspetti richiesti di ciascun elemento in quel flusso. Per le attività utente, viene usato un User Form Editor per modellare il modulo richiesto che verrà presentato all'utente, in modo che possa inserire i propri dati quando gli viene assegnata un'attività nel punto pertinente del workflow.

Il potente Process Workflow Editor offre la flessibilità necessaria per costruire processi con workflow semplici o complessi quanto serve, in linea con i requisiti della tua azienda.Il potente Process Workflow Editor offre la flessibilità necessaria per costruire processi con workflow semplici o complessi quanto serve, in linea con i requisiti della tua azienda.

Una volta definito il processo secondo necessità, fai clic sul pulsante per aggiungerlo all'elenco dei processi disponibili per quel tema di processo. La nuova definizione di processo verrà attivata e sarà pronta all'uso.

L'Editor segnalerà eventuali problemi nel diagramma del workflow che ne impediscono il salvataggio e la distribuzione: ad esempio, un diagramma deve avere un evento Start e almeno un evento End definito. Inoltre, una User Task deve avere almeno un campo modulo e un assegnatario.

Modifica di una definizione di processo esistente

Qualsiasi amministratore può modificare qualsiasi definizione di processo definita dall'utente, indipendentemente da chi abbia originariamente creato quella definizione, e salvarla e distribuirla come versione successiva. Per farlo, fai clic sul  controllo nella colonna Actions per la definizione di processo che si desidera modificare e selezionare Edit dal menu visualizzato. Il diagramma del flusso di lavoro per questa versione della definizione di processo verrà presentato nel Process Workflow Editor, come punto di partenza da cui operare.

Per le definizioni di processo fornite da Altium, è possibile creare una nuova definizione di processo basata sulla modifica di una di queste (in sostanza effettuando un fork), ma non è possibile modificare il valore predefinito stesso.

Esempio di modifica di una definizione di processo esistente: accesso al Process Workflow Editor, con cui eseguire le modifiche richieste.Esempio di modifica di una definizione di processo esistente: accesso al Process Workflow Editor, con cui eseguire le modifiche richieste.

Apportare le modifiche richieste al flusso di lavoro diagrammatico del processo, incluse eventuali modifiche ai moduli associati alle attività utente, quindi fare clic sul pulsante per salvare di fatto la definizione come versione successiva. Nell'esempio qui, la definizione di processo originale Company Pre-release Review : 1 (versione 1) viene modificata e salvata per diventare Company Pre-release Review : 2 (versione 2).

Una volta effettuate le modifiche, salvare e distribuire come versione successiva di quella definizione di processo.Una volta effettuate le modifiche, salvare e distribuire come versione successiva di quella definizione di processo.

Utilizzando il campo a discesa in alto a sinistra e impostando la voce su All, è possibile vedere tutte le versioni delle definizioni di processo esistenti. Nell'immagine seguente, è possibile vedere entrambe le versioni della definizione di processo Company Pre-release Review.

Visualizzazione di tutte le versioni della definizione di processo di esempio Company Pre-release Review. Si noti che solo la versione più recente (versione 2) può essere attivata e utilizzata.Visualizzazione di tutte le versioni della definizione di processo di esempio Company Pre-release Review. Si noti che solo la versione più recente (versione 2) può essere attivata e utilizzata.

È possibile utilizzare (rendere attiva e avviare) solo la versione più recente di una definizione di processo. Le versioni precedenti possono tuttavia essere usate come punto di partenza per creare una versione successiva. Se si elimina la versione più recente di una definizione di processo, la versione precedente diventerà di fatto la più recente e potrà nuovamente essere resa attiva e utilizzata (avviando istanze).

Importazione/esportazione di una definizione di processo

Le definizioni di processo possono essere esportate e importate, consentendo di riutilizzarle rapidamente tra istanze di Enterprise Server: un vero risparmio di tempo quando il flusso di lavoro sottostante di un processo è particolarmente complesso e dover, per così dire, "reinventare la ruota" sarebbe altrimenti un compito scoraggiante.

Per importare:

  1. Accedere alla scheda del tema (Part Requests, Project Activities, Project Creations) corrispondente alla definizione di processo che si desidera importare.

    Se si tenta di importare una definizione di processo nel tema sbagliato, il software lo segnalerà e l'importazione verrà impedita.
  2. Fare clic sul pulsante per creare una nuova definizione di processo e accedere al Process Workflow Editor.
  3. Fare clic sul pulsante . Nella finestra di dialogo Open visualizzata, individuare e aprire il file Workflow richiesto (*.aaw). Il contenuto del file sovrascriverà completamente qualsiasi elemento attualmente definito per la definizione di processo (nome, diagramma, ecc.).
È inoltre possibile importare da file una definizione di processo precedentemente esportata, direttamente dalla scheda Browser dell'interfaccia. Per farlo, fare clic sul pulsante . Nella finestra di dialogo Open visualizzata, individuare e aprire il file Workflow richiesto (*.aaw). Verrà rilevato il tema di processo corretto e il contenuto del file verrà caricato nel Process Workflow Editor.

Per esportare:

  1. Fare clic sul controllo  nella colonna Actions per la versione richiesta della definizione di processo che si desidera esportare e selezionare Edit dal menu visualizzato per accedere alla modalità di modifica.
  2. Nel Process Workflow Editor, fare clic sul pulsante . La definizione di processo verrà esportata come file Workflow (<ProcessDefinitionName>.aaw) nella cartella predefinita dei download definita per il browser.
  3. Fare clic sulla voce Processes nell'albero di navigazione a sinistra dell'interfaccia browser del Workspace per uscire dal Process Workflow Editor senza apportare modifiche alla definizione di processo.

Gestione dell'accesso al flusso di lavoro del processo

Come amministratore, è possibile definire quali utenti e/o gruppi possono accedere a un flusso di lavoro del processo. A tal fine, fare clic sul controllo  nella colonna Actions per la definizione di processo per cui si desidera configurare l'accesso al flusso di lavoro sottostante e selezionare Assign dal menu visualizzato. Si aprirà la finestra Assign Access to This Workflow.

Iniziare a digitare il nome completo o il nome utente di un utente, oppure il nome di un gruppo, nel campo di testo per visualizzare un elenco a comparsa di utenti/gruppi corrispondenti. È possibile aggiungere più utenti/gruppi. Per rimuovere l'accesso al flusso di lavoro a un utente/gruppo aggiunto, fare clic sulla croce di eliminazione all'estrema destra del relativo nome.

Una volta definiti utenti/gruppi come richiesto, fare clic su per applicare l'assegnazione del flusso di lavoro. Il flusso di lavoro sarà ora disponibile solo per gli utenti/gruppi aggiunti (e per i membri del gruppo Administrators) quando viene aperto come descritto nella sezione Designer Access to Process Workflows riportata di seguito.

Come indicato nella finestra Assign Access to This Workflow, se non viene aggiunto alcun utente/gruppo, il flusso di lavoro sarà disponibile per tutti gli utenti.

Accesso del designer ai flussi di lavoro di processo

Related pages: Esecuzione di revisioni del progetto, Pubblicazione su un PLM, Richieste di componenti basate su processo

Una volta create, secondo le esigenze dell'azienda, le necessarie definizioni di processo per ciascun tema di processo disponibile, quelle attivate saranno disponibili per l'uso da parte degli utenti assegnati una volta connessi al Workspace di Enterprise Server. Le sezioni seguenti illustrano dove un progettista può accedere e avviare questi processi attivi, sia tramite Altium Designer sia tramite l'interfaccia browser del Workspace.

Gli amministratori del Workspace possono anche, come già menzionato, avviare una nuova istanza di qualsiasi definizione di processo attivata direttamente dalla scheda del tema di processo corrispondente nell'area Processes dell'interfaccia browser del Workspace, facendo clic sul controllo  nella colonna Actions e selezionando Start dal menu visualizzato.

Richieste di componenti

Related page: Richieste di componenti basate su processo

Dall'interno di Altium Designer, le definizioni di processo attivate che fanno parte del tema Part Requests sono accessibili nei seguenti punti:

  • Dal pannello Components panel. Fare clic con il pulsante destro del mouse nell'area principale del pannello: le definizioni di processo attive per la richiesta di componenti sono disponibili dal sottomenu Operations » Submit Request. In alternativa, fare clic sul collegamento Submit request nella sezione Need more components?.

Se non sono disponibili definizioni di processo attive per il tema di processo Part Requests, il sottomenu Submit Request non verrà visualizzato. Potrebbe essere necessario disconnettersi dal Workspace e accedere di nuovo, oppure riavviare Altium Designer, per aggiornare.
  • Dall'interno del pannello Manufacturer Part Search panel. Se l'elemento di ricerca attualmente selezionato ha l'icona , il riquadro Information (accessibile facendo clic su ) presenterà il pulsante . Fare clic sulla parte a discesa del pulsante per accedere a un menu delle definizioni di processo attive per la richiesta di componenti. Facendo clic direttamente sulla parte principale del pulsante verrà avviata la prima definizione di processo nell'elenco.
La richiesta di un componente tramite il pannello Manufacturer Part Search offre l'ulteriore vantaggio di compilare automaticamente informazioni chiave, inclusi tutti i datasheet e le informazioni parametriche.

Se non sono disponibili definizioni di processo attive per il tema di processo Part Requests, il pulsante non verrà visualizzato. Potrebbe essere necessario disconnettersi dal Workspace e accedere di nuovo, oppure riavviare Altium Designer, per aggiornare.

Se l'elemento di ricerca attualmente selezionato ha un'icona , le definizioni di processo attive per la richiesta di componenti saranno disponibili dal menu associato al pulsante (fare clic sulla parte a discesa del pulsante).

Le definizioni di processo attive per la richiesta di componenti possono essere accessibili anche dal menu del tasto destro nell'area principale del pannello, dal sottomenu Submit Request.

Se non sono disponibili definizioni di processo attive per il tema di processo Part Requests, il sottomenu Submit Request non verrà visualizzato. Potrebbe essere necessario disconnettersi dal Workspace e accedere di nuovo, oppure riavviare Altium Designer, per aggiornare.
  • Dal pannello Explorer panel, nella cartella Part requests oppure dopo aver eseguito una ricerca. Sarà disponibile il pulsante che, se premuto, presenterà le definizioni di processo attive per la richiesta di componenti tra cui scegliere.

Si noti che se la funzionalità Legacy Part Requests feature è stata abilitata, il pulsante apparirà come . Nel menu comparirà anche una voce aggiuntiva relativa alle nuove richieste di componenti che utilizzano tale funzionalità legacy. Questa avrà il suffisso (Legacy). Se non sono disponibili definizioni di processo attive per il tema di processo Part Requests e la funzionalità Legacy Part Requests non è abilitata, il pulsante Submit Request non verrà visualizzato. Potrebbe essere necessario disconnettersi dal Workspace e accedere di nuovo, oppure riavviare Altium Designer, per aggiornare.

Dall'interfaccia browser del Workspace, le definizioni di processo attivate che fanno parte del tema Part Requests sono accessibili dalla pagina Part Requests, facendo clic sul pulsante in alto a destra della pagina.

Accesso alle definizioni attivate di Part Requests dalla pagina Part Requests dell'interfaccia browser del Workspace.Accesso alle definizioni attivate di Part Requests dalla pagina Part Requests dell'interfaccia browser del Workspace.

Se non sono disponibili definizioni di processo attive per il tema di processo Part Requests, il pulsante non sarà disponibile. Se esiste una sola definizione di processo, il pulsante non apparirà con funzionalità a discesa e avvierà immediatamente quel processo quando viene fatto clic.

Attività di progetto

Related pages: Esecuzione di revisioni del progetto, Pubblicazione su un PLM, Integrazione PLM.

Le definizioni di processo attivate che fanno parte del tema Project Activities possono essere accessibili in vari punti.

Revisione del progetto e pubblicazione PLM standard

Dall'interno di Altium Designer, le definizioni di processo attivate per revisione del progetto e pubblicazione, che fanno parte del tema Project Activities, sono accessibili dal sottomenu contestuale Project Activities, accessibile facendo clic con il pulsante destro del mouse sulla voce del progetto di progettazione nel Projects panel, oppure dal menu principale Project » Project Activities.

Se non sono disponibili definizioni di processo attive per la revisione del progetto e la pubblicazione PLM standard per il tema di processo Project Activities, i menu non saranno visibili.

Dall'interfaccia browser del Workspace, le definizioni di processo attivate per revisione del progetto e pubblicazione, che fanno parte del tema Project Activities, sono accessibili dalla pagina Projects dell'interfaccia. Selezionare il progetto richiesto, quindi fare clic sul pulsante .

Accesso alle definizioni attivate di Project Activities (revisione del progetto e pubblicazione PLM standard) per un progetto Workspace, nell'area Projects dell'interfaccia browser del Workspace.Accesso alle definizioni attivate di Project Activities (revisione del progetto e pubblicazione PLM standard) per un progetto Workspace, nell'area Projects dell'interfaccia browser del Workspace.

Se non sono disponibili definizioni di processo attive per la revisione del progetto e la pubblicazione PLM standard per il tema di processo Project Activities, il pulsante non verrà visualizzato.

Pubblicazione PLM tramite Project Releaser

Dall'interno di Altium Designer, il processo per la pubblicazione in un'istanza PLM come parte del Project Releaser è accessibile dal sottomenu Project » Project Releaser del progetto attivo, oppure facendo clic con il pulsante destro del mouse sulla voce del progetto di progettazione nel Projects panel e scegliendo il processo dalla voce di menu contestuale Project Releaser.

Creazioni di progetto

Dall'interno di Altium Designer, le definizioni di processo attivate che fanno parte del tema Project Creations possono essere accessibili in tre punti:

  • Dal sottomenu principale File » New » Project in <WorkspaceName>.

  • Dal sottomenu contestuale Convert to Managed Project, accessibile facendo clic con il pulsante destro del mouse sulla voce di un progetto locale nel pannello Projects.

  • Dal sottomenu contestuale Clone, accessibile facendo clic con il pulsante destro del mouse sulla voce di un progetto nella finestra di dialogo Open Project dialog quando è selezionata la posizione Workspace.

Si noti che quando è attiva almeno una definizione di processo per il tema di processo Project Creations, la possibilità di creare un nuovo progetto Workspace tramite la finestra di dialogo Create Project dialog (File » New » Project) viene disabilitata: il Workspace connesso non è disponibile come posizione di destinazione. Regular I progetti di tipo (Local) e VCS possono essere creati normalmente tramite questa finestra di dialogo.

Se non sono disponibili definizioni di processo attive per il tema di processo Project Creations, che è il caso predefinito per una nuova installazione di Enterprise Server, i menu di processo non saranno visibili e sarà possibile creare un progetto Workspace tramite la finestra di dialogo Create Project come di consueto.

Si noti inoltre che in questa configurazione predefinita il comando Convert to Managed Project cambia in Make Project Available on Server.

Dall'interfaccia browser del Workspace, le definizioni di processo attivate che fanno parte del tema Project Creations possono essere accessibili nei seguenti punti:

  • Dalla pagina principale Projects dell'interfaccia, facendo clic sul pulsante .

Accesso alle definizioni attivate di Project Creations dall'area principale Projects dell'interfaccia browser del Workspace.Accesso alle definizioni attivate di Project Creations dall'area principale Projects dell'interfaccia browser del Workspace.

  • Dalla pagina Projects dell'interfaccia, quando si desidera clonare un progetto specifico. Selezionare il progetto richiesto, quindi fare clic sul pulsante per accedere ai processi nel menu.

Accesso alle definizioni attivate di Project Creations quando si desidera clonare un progetto Workspace, nell'area Projects dell'interfaccia browser del Workspace.Accesso alle definizioni attivate di Project Creations quando si desidera clonare un progetto Workspace, nell'area Projects dell'interfaccia browser del Workspace.

  • Se non sono disponibili definizioni di processo attive per il tema di processo Project Creations, che è il caso predefinito per una nuova installazione di Enterprise Server, il menu offrirà la funzionalità di base di clonazione del progetto (Clone). Questa non è correlata alla funzionalità del flusso di lavoro di processo.
  • Per utilizzare il Constraint Manager per gestire i vincoli di progettazione del progetto PCB Workspace basato su processo, assicurarsi di assegnare un modello di progetto appropriato durante la creazione di tale progetto. Questo dovrebbe essere un modello salvato da un progetto PCB creato con l'opzione Constraint Management abilitata nella finestra di dialogo Create Project dialog.
AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Contenuto