Ricerca e posizionamento dei componenti

Altium Training

Altium Essentials: Schematic Capture

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

A colpo d'occhio

Questo articolo spiega come il pannello Components di Altium Designer ti aiuta a trovare, esaminare, gestire e posizionare i componenti del tuo Workspace, nonché quelli delle librerie basate su database e su file. Illustra le diverse opzioni di ricerca disponibili, tra cui la navigazione per categorie, la ricerca tramite query dirette e il filtraggio parametrico dei componenti del Workspace, mostrando anche come il pannello si integra con strumenti correlati quali il pannello Manufacturer Part Search, l'editor Component e il pannello Explorer. Scoprirai inoltre come aprire il pannello dai documenti schematici e PCB, come vengono determinate le categorie dei componenti e quali operazioni e controlli di visualizzazione sono disponibili per ottimizzare il tuo flusso di lavoro. Se cerchi un modo più semplice per trovare i componenti giusti e posizionarli in modo efficiente nei tuoi progetti, questo articolo ti aiuterà a farlo: continua a leggere.

- Scopri come cercare i componenti nel pannello Components utilizzando categorie, query di ricerca e filtri basati sui parametri.
- Comprendi da dove provengono i componenti, incluse le risorse del Workspace, le librerie basate su file, le librerie basate su database e i risultati del pannello Manufacturer Part Search.
- Scopri come posizionare i componenti e utilizzare le principali funzionalità del pannello per visualizzare i dettagli, modificare i componenti, gestire le librerie e organizzare l'elenco dei componenti.
Approfondisci con l'IA:

I componenti sono il cuore di qualsiasi progetto elettronico. Il componente che verrà infine saldato sulla scheda deve essere rappresentato, o modellato, in ogni ambito di progettazione: come simbolo nello schema elettrico, come modello SPICE nel simulatore, come footprint sulla scheda e come modello 3D STEP nel file consegnato al progettista meccanico.

Scopri di più su Creazione e manutenzione di componenti e librerie.

Il pannello Components di Altium Designer offre una potente interfaccia per interagire con tutti i tuoi componenti, sia quelli del Workspace sia quelli esterni al Workspace. Puoi cercare il componente desiderato specificando la categoria e utilizzando la modalità di ricerca semplice, inserendo una query (il nome completo o parziale del componente, il valore, ecc.) nel campo di ricerca. Inoltre, il pannello offre una funzione di ricerca parametrica (a faccette) basata su filtri per specificare i parametri desiderati dei componenti del Workspace. Il pannello offre anche opzioni per modificare un componente del Workspace tramite l'editor dei componenti in modalità di modifica di un singolo componente, visualizzare il componente nel Workspace di origine ed eseguire operazioni di gestione dei componenti, come la creazione e la clonazione oppure la modifica delle scelte dei componenti e del tipo del componente selezionato. Un componente può essere posizionato nello schema elettrico trascinandolo o utilizzando il comando Place dal menu contestuale del componente.

Sebbene tu possa naturalmente creare i tuoi componenti, Altium Designer offre un potente pannello di ricerca dei componenti dei produttori che consente di cercare componenti effettivamente in produzione. Se disponi di un Workspace, puoi salvarvi questi componenti e accedervi tramite il pannello Components. Questo processo prevede la creazione di un nuovo componente del Workspace, utilizzando l'editor dei componenti in modalità di modifica di un singolo componente, e il suo salvataggio nel Workspace.

Il pannello Components consente di accedere direttamente ai componenti del Workspace disponibili e ai componenti delle librerie basate su database e basate su file in Altium Designer.

Il pannello recupera i componenti da un Workspace connesso e da qualsiasi libreria aperta o installata. Offre tutti i dettagli del componente selezionato (parametri, modelli, scelte dei componenti, dati dei fornitori, ecc.), il confronto tra componenti e, per i componenti del Workspace, una funzione di ricerca parametrica basata su filtri per specificare i parametri desiderati.

Il pannello Components in modalità normale

Il pannello Components in modalità compatta

 

Il pannello Components utilizza le funzionalità di base del motore di ricerca e la vista impiegate nel pannello di ricerca dei componenti dei produttori. Mentre il pannello Manufacturer Part Search sfrutta il servizio Altium Parts Provider e si concentra sulla ricerca dei dati dei produttori e dei fornitori di componenti, il pannello Components contiene componenti pronti per il posizionamento, provenienti dal Workspace connesso e dalle librerie basate su database e su file.

Per i componenti del Workspace, il pannello mostra solo la revisione più recente di ciascun componente.
Sebbene molte delle funzionalità per lavorare con i componenti siano disponibili tramite il pannello Components, puoi utilizzare anche il pannello Explorer: in sostanza, il primo offre un sottoinsieme delle funzionalità disponibili nel secondo, concentrandosi sulla gestione dei componenti. Alcune operazioni relative ai componenti possono ancora essere eseguite solo tramite il pannello Explorer (aggiunta di schede tecniche senza apportare modifiche, modifica degli stati, eliminazione in blocco di componenti e modelli, ecc.), ma riguardano principalmente casi atipici o particolari, oppure attività di amministrazione e organizzazione del Workspace. Ricorda che il componente è solo uno dei tipi di contenuto: il pannello Explorer esprime appieno il proprio potenziale con l'intera gamma di tipi di contenuto supportati da un Workspace. Ad esempio, la creazione e la gestione dei template dei componenti, elementi particolarmente rilevanti per i componenti, possono essere eseguite solo dal pannello Explorer (a meno che i template non vengano creati durante l'importazione della libreria utilizzando l'importatore di librerie).

Accesso al pannello dei componenti

Per aprire il pannello Components, seleziona View » Panels » Components dai menu principali oppure l'opzione Components dal menu del pulsante in basso a destra nella schermata principale. Grazie a una configurazione responsive, il layout del pannello si adatta dinamicamente passando dalla modalità normale a schermo intero () alla modalità compatta (), nella quale le opzioni Categorie/Filtri vengono raggruppate in menu.

Da un documento schematico, utilizza la scorciatoia da tastiera P, P per aprire il pannello Components. Puoi anche utilizzare il comando Place » Part dai menu principali, il comando Place » Part dal menu contestuale dell'area di progettazione dell'editor schematico oppure il pulsante Part () sulla Active Bar.

Da un documento PCB, utilizza la scorciatoia da tastiera P, C per aprire il pannello Components. Puoi anche utilizzare il comando Place » Component dai menu principali, il comando Place » Component dal menu contestuale dell'area di progettazione dell'editor PCB oppure il comando Component () sulla Active Bar.

Alla prima apertura del pannello Components nella sessione corrente di Altium Designer, quando sei connesso a un Workspace sono disponibili i seguenti controlli:

  • Use Existing Components – fai clic per esplorare il tipo di componente attualmente selezionato nel menu a discesa nella parte superiore del pannello.

  • Delete Existing Components – fai clic per aprire la finestra di dialogo Delete Existing Components, seguita dalla pagina Data Cleanup del Settings del Workspace, dove puoi selezionare i tipi di contenuto da rimuovere.

  • Import Library – fai clic per aprire la finestra di dialogo standard di Windows Open, quindi seleziona una libreria basata su database o su file salvata in una cartella locale o di rete. Dopo l'apertura di un file di libreria, verrà avviato l'importatore di librerie in modalità semplice con la libreria selezionata già caricata.

  • Create Component – fai clic per aprire la finestra di dialogo per la creazione di un nuovo componente, seguita dall' editor dei componenti in modalità di modifica di un singolo componente, pronto per definire un nuovo componente.

Il riquadro Categories del pannello (o il menu a discesa in modalità compatta) elenca tutti i componenti del Workspace disponibili sotto la voce di categoria All e tutte le librerie disponibili. Quando il pannello è in modalità normale, fai clic sull'icona dell'elenco Categories o sull'icona « per comprimere o espandere la visualizzazione della colonna e utilizza il pulsante (in alto a destra) per mostrare o nascondere il riquadro Details del componente. Durante la consultazione del riquadro Categories, puoi utilizzare le scorciatoie da tastiera Up/Down e PgUp/PgDn per scorrere l'elenco. Le scorciatoie da tastiera Left/Right consentono di aprire e chiudere i singoli rami.

Il raggruppamento Categories dei componenti del Workspace deriva dai parametri Component Type associati a ciascun componente. Ad esempio, se il Component Type di un componente è stato impostato su Resistor, quel componente verrà elencato nella categoria Resistor del pannello Components (indipendentemente dalla cartella del Workspace in cui si trova).

Per specificare o modificare il tipo di un componente al volo, fai clic con il pulsante destro del mouse sulla relativa voce, quindi seleziona l'opzione Operations » Change Component Type dal menu contestuale per aprire la finestra di dialogo di selezione del tipo di componente.

Il parametro Type di un componente viene definito:

I tipi di componente vengono gestiti (creati/modificati/rimossi) nella pagina Gestione dati – Tipi di componente della finestra di dialogo Preferences. Il pulsante Templates della finestra di dialogo apre la finestra Edit Templates, in cui è possibile specificare o modificare il modello di componente associato a ciascun tipo di componente.

NOTE: La Category in cui è elencato un componente è definita dal relativo parametro Component Type e non è correlata alla cartella del Workspace in cui si trova. Pertanto, se sposti un componente in una cartella diversa tramite il pannello Explorer, tale modifica non verrà riflessa nel pannello Components.

Menu delle operazioni

Le opzioni del menu delle operazioni consentono di impostare le preferenze per le librerie basate su file, eseguire ricerche e specificare se visualizzare le raccolte di modelli dei componenti. Per accedere a queste opzioni, seleziona il pulsante del menu delle operazioni in alto a destra nel pannello.

  • Create Component – seleziona per aprire la finestra di dialogo Create new component, seguita dall'editor dei componenti in modalità di modifica di un singolo componente, pronto per definire un nuovo componente.
  • Import Library – seleziona per aprire la finestra di dialogo standard di Windows Open e selezionare una libreria basata su database o su file salvata in una cartella locale o di rete. Dopo l'apertura di un file di libreria, verrà avviato Library Importer in modalità semplice con la libreria selezionata già caricata.
  • Clean-up Library – seleziona per aprire la finestra di dialogo Delete Existing Components, seguita dalla pagina Data Cleanup di Settings del tuo Workspace, dove puoi selezionare i tipi di contenuto da rimuovere.
  • Models – seleziona per includere le voci delle raccolte di modelli di libreria nell'elenco Categories. Le voci aggiuntive in questa modalità di navigazione includono raccolte di simboli, footprint e modelli di simulazione provenienti dal Workspace connesso, nonché le librerie di footprint PCB installate (*.PcbLib).
  • File-based Libraries Preferences – seleziona per aprire la finestra di dialogo Available File-based Libraries, in cui sono disponibili i controlli per aggiungere librerie basate su database e su file al progetto corrente o rimuoverle, installare librerie e specificare i percorsi di ricerca delle librerie. Per ulteriori informazioni, consulta la sezione Gestione delle librerie disponibili basate su database e su file della pagina Ricerca di componenti nelle librerie basate su file e su database.
  • File-based Library Search – seleziona per aprire la finestra di dialogo File-based Libraries Search, in cui puoi cercare un componente quando non sai quale libreria basata su database o su file lo contenga o se sia effettivamente disponibile. Per ulteriori informazioni, consulta la sezione Ricerca di componenti nelle librerie basate su database e su file della pagina Ricerca di componenti nelle librerie basate su file e su database.
  • Refresh – fai clic per aggiornare rapidamente il pannello. La selezione corrente dei componenti verrà mantenuta.

Elenco dei componenti

All'interno della griglia dell'elenco dei componenti, i contenuti inclusi nell'elenco vengono gestiti mediante le seguenti operazioni:

  • Impostazione dell'ordinamento dell'elenco dei componenti – fai clic sull'intestazione di una colonna per ordinare l'elenco dei componenti in base ai dati di quella colonna. Fai nuovamente clic sull'intestazione per invertire l'ordinamento.

  • Impostazione dell'ordine delle colonne visualizzate – trascina l'intestazione di una colonna in una nuova posizione.

  • Scelta delle colonne dei parametri da visualizzare – fai clic con il pulsante destro del mouse sull'intestazione di una colonna e scegli Select Columns per aprire la finestra di dialogo Select Columns, che consente di controllare la visibilità di una colonna dei parametri e modificarne la posizione.

    La finestra di dialogo Select columns
    La finestra di dialogo Select columns

    • La finestra di dialogo elenca tutte le colonne che possono essere visualizzate nel pannello Components. Quando una voce mostra , la colonna corrispondente verrà visualizzata nel pannello Components . Quando una voce mostra , la colonna corrispondente not verrà visualizzata nel pannello Components. Fai clic sui simboli per alternare tra visualizzazione e occultamento.

    • Puoi anche controllare la visualizzazione di tutte le colonne facendo clic sull'icona / nella barra di intestazione delle colonne. Quando alcune colonne sono visibili e altre nascoste, viene mostrata l'icona .

    • Passa il cursore sulla barra di intestazione della seconda colonna e fai clic sull'icona  per aprire un menu a discesa da cui scegliere la colonna da visualizzare.

    • Usa i pulsanti  /  per spostare la voce selezionata verso l'alto o verso il basso nell'elenco. È possibile spostare solo le voci impostate come visibili (). Questo determina l'ordine in cui le colonne appariranno nel pannello Components.

  • Raggruppamento dell'elenco in base ai dati di una colonna – fai clic con il pulsante destro del mouse sull'intestazione di una colonna, seleziona l'opzione Enable Columns Grouping, quindi trascina l'intestazione di una colonna (ad esempio, Footprint) nell'area di raggruppamento in cima all'elenco. Le voci dell'elenco verranno raggruppate sotto ciascun valore univoco del parametro (ad esempio, il tipo di footprint) della colonna di raggruppamento specificata.

    Quando si utilizza Grouping per raggruppare i componenti nell'elenco, è previsto un limite di 10.000 voci.

  • Filtro dell'elenco in base a una voce specifica di una colonna – seleziona nell'intestazione di una colonna per visualizzare un elenco dei valori univoci del relativo parametro, quindi seleziona una voce per limitare l'elenco ai componenti che includono il parametro specificato (ad esempio, un codice del tipo di footprint). Seleziona l'opzione All per reimpostare il filtro. Seleziona (Custom) per aprire la finestra di dialogo Filter Editor e affinare ulteriormente il filtro nella colonna selezionata.

Visualizzazione delle colonne

Esistono vari modi per visualizzare i contenuti nel pannello Components. Facendo clic con il pulsante destro del mouse sui nomi delle singole colonne (Nome, Descrizione, Footprint), puoi selezionare le seguenti opzioni, a seconda di come desideri visualizzare i componenti:

  • Best Fit – avvicina i contenuti delle colonne Name e Descriptions, eliminando lo spazio in eccesso tra le colonne.

  • Best Fit All Columns – avvicina i contenuti di tutte le colonne, eliminando lo spazio in eccesso tra le colonne.

  • Clear Sorting – consente di annullare l'ordinamento delle colonne.

  • Enable Columns Grouping – consente di trascinare le intestazioni delle colonne in corrispondenza di una colonna specifica, permettendo di modificare l'ordine delle colonne Name, Description e Footprint.

  • Select Columns – apre la finestra di dialogo Select Columns, che consente di selezionare altre colonne da visualizzare in questa sezione.

  • Apply Column Visibility to Child Categories – quando la categoria selezionata ha una categoria figlia, utilizzare questo comando per consentire la propagazione delle impostazioni di visibilità delle colonne dalle categorie padre alle categorie figlie. Questo comando è disponibile solo se esiste una categoria figlia.

Ricerca e funzioni dei componenti

Ricerca dei componenti

Per cercare i componenti disponibili nel pannello Components, inserire una frase nel campo Search e/o utilizzare le selezioni Categories e Filters del pannello per restringere l'elenco dei componenti in base alle proprie esigenze. I filtri sono supportati solo per i componenti del Workspace e, come nel pannello Manufacturer Part Search, il pannello Components supporta filtri di ricerca che riconoscono le unità di misura (conversione da testo a numero). La funzione di ricerca assegna la priorità ai risultati in base ai criteri di ricerca inseriti.

La funzione Search consente di selezionare e quindi modificare o integrare una stringa Search attiva.

Fare clic sulla stringa di ricerca «attiva» per inserirla nel campo Search. È possibile riutilizzare o modificare tale ricerca dal campo Search.

Il campo Search supporta anche la ricerca con caratteri jolly, indicati da un asterisco (*) nella stringa.

La finestra di dialogo Find Similar Components, accessibile facendo clic con il pulsante destro del mouse su un componente dell'elenco e selezionando Find Similar Components, consente di definire le preferenze di ricerca in base al componente selezionato.

I risultati finali della ricerca dipendono dal tipo di componente selezionato, che si tratti di componenti del Workspace o esterni al Workspace, e dallo stato della connessione al Workspace. Ad esempio, i componenti del Workspace spesso mostrano più parametri rispetto ai componenti esterni al Workspace. Per cercare specificamente componenti e parametri uguali o diversi da quelli del componente selezionato, è possibile utilizzare i menu a discesa per selezionare le opzioni Same, Any o Different.

Posizionamento dei componenti

Un componente selezionato può essere posizionato su uno schema mediante trascinamento, selezionando Place dal relativo menu contestuale accessibile con il pulsante destro del mouse, utilizzando il pulsante nel riquadro Details, facendo doppio clic sulla voce del componente desiderato oppure utilizzando il tasto di scelta rapida Enter.

Per posizionare un componente dal pannello, è possibile:

  • Fare clic sul pulsante Place nel riquadro Component Details – il cursore si sposta automaticamente all'interno del foglio dello schema e il componente appare agganciato al cursore; portarlo nella posizione desiderata e fare clic per posizionarlo. Dopo aver posizionato un componente, un'altra istanza dello stesso componente apparirà sul cursore; fare clic con il pulsante destro del mouse per uscire dalla modalità di posizionamento.

    Components panel, placing from component details pane

  • Fare clic con il pulsante destro del mouse sul componente e selezionare Place dal menu contestuale. Il componente appare agganciato al cursore; portarlo nella posizione desiderata e fare clic per posizionarlo. Se il pannello è mobile e si sovrappone all'area di progettazione, diventerà trasparente per consentire di vedere lo schema e posizionare il componente. Dopo aver posizionato un componente, un'altra istanza dello stesso componente apparirà sul cursore; fare clic con il pulsante destro del mouse per uscire dalla modalità di posizionamento.

  • Click, Hold&Drag – fare clic sul componente e trascinarlo dall'area della griglia del pannello a un foglio dello schema. Questa modalità richiede di tenere premuto il pulsante del mouse; il componente viene posizionato quando si rilascia il pulsante. Dopo aver posizionato il componente, è possibile selezionare un altro componente o un altro comando.

    Il trascinamento posiziona una singola istanza del componente. Per posizionare più istanze, utilizzare il comando/pulsante Place oppure fare doppio clic sulla voce del componente.

Posizionare un componente è davvero semplicissimo. Prima di qualsiasi operazione, però, assicurarsi che il foglio dello schema (o il documento PCB) in cui si desidera inserire il componente sia aperto in Altium Designer e sia il documento attivo. Se i documenti sono aperti in più finestre, assicurarsi inoltre che la finestra contenente il documento schematico attivo abbia il focus.

Quando si lavora con Altium Designer in più finestre, se il pannello Components o il pannello Explorer è ancorato, in qualsiasi modalità, a una finestra che non contiene lo schema di destinazione, il comando Place rimarrà disabilitato. Questo perché un clic all'interno di un pannello ancorato sposta il focus sulla finestra a cui il pannello è collegato. Se invece il pannello è mobile, è possibile assegnare il focus alla finestra Altium desiderata (quella con lo schema di destinazione attivo), che manterrà il focus mentre si lavora all'interno del pannello.

Posizionamento di un componente multiparte

Se il componente da posizionare è composto da più parti, verrà inizialmente posizionata la parte selezionata sotto l'immagine di anteprima del simbolo nell'area Models del pannello.

Una volta posizionata una parte di un componente multiparte, è possibile sostituirla con un'altra parte dello stesso componente utilizzando il menu a discesa Part nel pannello Properties quando la parte è selezionata, oppure passare alla parte successiva disponibile utilizzando il comando Edit » Increment Part Number dai menu principali o il comando Part Actions » Increment Part Number dal menu accessibile facendo clic con il pulsante destro del mouse sulla parte.

Altium Designer consente di rappresentare un componente multiparte come un unico simbolo (tutte le sottoparti) o come più simboli (uno per ogni singola sottoparte), utilizzando un solo componente tramite le modalità di visualizzazione Normale e Alternativa definite (Mostra esempio).

  • Se un componente multiparte presenta sottoparti vuote nella propria modalità di visualizzazione (normale o alternativa), queste sottoparti vengono omesse durante il posizionamento (Mostra esempio).

  • Se un componente multiparte contiene primitive definite in una sola sottoparte, il suffisso del designatore viene nascosto quando tale sottoparte viene posizionata su un foglio schematico (Mostra esempio).

  • Quando una sottoparte non contiene primitive per la modalità di visualizzazione attualmente selezionata, oppure una modalità di visualizzazione non contiene primitive per la sottoparte attualmente selezionata, la voce corrispondente nel menu a discesa Part di Mode nel pannello Properties del componente viene disattivata (). Quando si seleziona tale voce nel menu a discesa, vengono visualizzate icone di avviso ().

  • Durante la convalida del progetto non viene segnalata una violazione Sottoparte inutilizzata nel componente se un componente presenta sottoparti prive di primitive e queste non sono posizionate sullo schematico.

Filtrare i componenti

Quando si visualizzano i componenti del Workspace, il riquadro Filters viene popolato con le opzioni di filtro selezionate in base alla ricerca corrente e ai parametri disponibili. Il filtraggio parametrico dei componenti elencati offre ulteriori opzioni per individuare un componente specifico o un tipo di componente. Aprire il riquadro Filters tramite il pulsante sopra il riquadro Categories. Nella modalità compatta del pannello, fare clic sul pulsante per aprire Filters come estensione del pannello.

Si noti che i filtri sono supportati solo per i componenti del Workspace. Utilizzare il campo Filter Search all'interno del riquadro per trovare un filtro parametrico specifico.

Javascript ID: Pnl_Components_Filter
  • La funzionalità di ricerca parametrica di Filters del pannello si basa sulla trasmissione di dati adeguati relativi ai parametri dei componenti da parte del Workspace che ospita i componenti. Di conseguenza, la funzionalità Filter potrebbe essere disabilitata quando il software è connesso a un prodotto server Altium meno recente. Per abilitare Filter per le versioni precedenti del server, abilitare l'opzione ComponentSearch.LegacyAFS.Filters nella finestra di dialogo Advanced Settings.

  • Si noti che, affinché un parametro compaia nel riquadro Filters, i componenti della categoria selezionata devono utilizzare almeno due valori diversi per quel parametro. Inoltre, nel riquadro Filters vengono mostrati al massimo i 100 parametri più utilizzati (quelli utilizzati dal maggior numero di componenti nel Workspace connesso, considerando tutti i tipi di componenti). I seguenti parametri (o quelli il cui nome inizia con uno dei seguenti nomi) vengono sempre mostrati nella parte superiore del riquadro: Power, Value, Resistance, Res, Capacitance, Case, Package, Tolerance, RoHS, Lead.

Le opzioni Filters del pannello possono essere adattate alle proprie esigenze selezionando determinati tipi di parametri come Favorites, che vengono quindi spostati in cima all'elenco per la categoria di componenti corrente. Passare il puntatore a destra del nome di un filtro parametrico e fare clic sull'icona per impostare il filtro come preferito. Le impostazioni dei filtri preferiti si applicano alle singole categorie di componenti e vengono salvate per ciascuna di esse.

Per i componenti del Workspace, il menu contestuale offre opzioni per modificare il componente tramite il Component Editor (Edit) ed eseguire funzioni di gestione dei componenti, come la creazione e la clonazione, oppure modificare le scelte dei componenti e il tipo del componente selezionato (Operations).

 
 
 
 
 

Le opzioni informative aggiuntive nel riquadro Details del componente includono: la visualizzazione di un'immagine del modello, la consultazione delle schede tecniche online (References), le informazioni aggiornate sui fornitori (Part Choices), la visualizzazione dei punti in cui il componente è stato utilizzato nei progetti del Workspace, nei fogli gestiti e nei blocchi di riutilizzo (Where Used) e, tramite il menu contestuale, la possibilità di copiare tutti i dati dei parametri del componente o solo quelli selezionati (dettagli tecnici) in un formato delimitato da tabulazioni e di ripristinare i parametri contrassegnati come preferiti ai cinque parametri predefiniti.

Durante la consultazione dei componenti in un Altium 365 Workspace connesso, se vengono rilevati problemi relativi allo stato del componente selezionato, questi vengono segnalati dall'icona (per gli errori) o (per gli errori fatali) nella riga Component issues sopra l'elenco dei parametri del componente. Il numero a destra dell'icona indica il numero di problemi rilevati. Fai clic sulla freccia verso il basso a destra del numero per visualizzare brevi descrizioni dei problemi.

Un esempio di problemi rilevati nello stato della libreria.
Un esempio di problemi rilevati nello stato della libreria.

Puoi esaminare più in dettaglio lo stato della libreria del Workspace tramite la pagina del dashboard Stato della libreria, accessibile dall'interfaccia browser di Altium 365 Workspace. Consulta Dashboard Stato della libreria per saperne di più.

Puoi utilizzare la funzione di filtro personalizzato per affinare ulteriormente il filtraggio nel pannello Components. ​​​​​​

La funzione è accessibile:

  1. facendo clic sull'icona del filtro () nell'intestazione per visualizzare il menu a discesa Filtro,

  2. che consente di filtrare selezionando un Filter Value (opzione predefinita) oppure configurando un Filter Rule definito dall'utente. Se selezioni un valore dall'elenco, questo viene automaticamente convertito in un'espressione (che può poi essere modificata).

  3. Se selezioni Filter Rules per definire il tuo filtro, scegli quindi un operatore dal primo menu a discesa,

  4. poi seleziona o inserisci un valore di filtro nel secondo menu a discesa.

  5. Il filtro corrente viene visualizzato sotto l'elenco dei risultati; fai clic sul pulsante per aprire la finestra di dialogo Filter Editor e modificare il filtro.

Dove viene utilizzato

Seleziona un componente del Workspace nel pannello Components per visualizzare, nell'area Where Used, informazioni su dove viene attualmente utilizzata la sua ultima revisione. L'area fornisce informazioni con filtri rapidi per:

  • Projects – i progetti del Workspace in cui è stato utilizzato il componente. Le informazioni vengono only visualizzate una volta che il progetto è stato salvato nel Workspace.

  • Managed Sheets – i fogli schematici gestiti in cui è stato utilizzato il componente. 

  • Reuse Blocks – i blocchi di riutilizzo memorizzati nella libreria di un Workspace connesso.

Nota che le schede vengono visualizzate solo se nel Workspace esiste un'entità che utilizza il componente selezionato.

Se un componente non viene utilizzato in tutte le varianti di progetto di un progetto del Workspace, la voce del progetto nell'area Where Used mostra il numero di varianti in cui il componente viene utilizzato e il numero totale di varianti del progetto, nonché l'elenco delle varianti in cui il componente viene utilizzato ().

Memorizzazione nella cache dei dati dei componenti

Quando utilizzi il pannello Components, i dati dei componenti del Workspace vengono memorizzati nella cache sul computer locale. Questo offre una modalità di accesso offline ai componenti del Workspace quando Altium Designer non è connesso al Workspace, consentendo quindi di consultare e posizionare normalmente i componenti e di eseguire altre operazioni.

Alla prima apertura del pannello Components nella sessione corrente di Altium Designer, in modalità offline viene visualizzato un avviso nel pannello, insieme ai controlli per continuare a utilizzare i dati dei componenti memorizzati nella cache oppure per svuotarla.

Fai clic su Use Cached Data per utilizzare i componenti memorizzati nella cache. Questa condizione viene indicata dal messaggio di avviso Offline mode – cached data is being used nella barra inferiore del riquadro dell'elenco dei componenti del pannello. Nota che Filters non sono abilitati in questa modalità.

La cache accumula i dati dei componenti nel tempo e può essere svuotata in qualsiasi momento (per tutti i Workspace) utilizzando l'opzione Clear Cache, disponibile sotto Known Servers nella pagina Gestione dati – Server della finestra di dialogo Preferences.

La cache mostra solo i componenti memorizzati provenienti dai Workspace attualmente connessi, come Altium 365 Workspace; pertanto, alcuni dati memorizzati nella cache potrebbero essere disabilitati. Questo comportamento può essere gestito dalla pagina Data Management – Servers della finestra di dialogo Preferences.

Elenco delle scelte dei componenti

Modifica l'elenco delle scelte dei componenti associato a un componente del Workspace selezionando l'opzione Operations » Create/Edit Part Choices dal menu contestuale della voce.

Utilizza il pulsante della successiva finestra di dialogo Edit Part Choices per aprire la finestra di dialogo Add Part Choices, che cercherà automaticamente i componenti dei produttori in base al parametro Name del componente selezionato. Deseleziona il termine di ricerca predefinito per cercare manualmente alternative. Dal punto di vista funzionale, la finestra di dialogo è una versione modale del pannello Ricerca componenti dei produttori.

Puoi assegnare una priorità alle voci dell'elenco delle scelte dei componenti selezionando il livello desiderato tramite l'icona a stella; l'elenco viene riordinato automaticamente, con la scelta del produttore con la priorità più alta in cima.

Le scelte dei componenti vengono mantenute insieme al componente ovunque vengano utilizzati i suoi dati, ad esempio in un progetto schematico, in un documento BOM, in un report di output e così via.

Quando un componente è selezionato nel pannello Components, il relativo elenco delle scelte dei componenti è visibile nell'area Part Choices del riquadro Details. Le informazioni di base (disponibilità a magazzino, prezzo unitario mediano e ciclo di vita del produttore) sulla scelta del componente correlata sono disponibili anche nella parte superiore del riquadro Details. La striscia colorata associata indica l'idoneità generale del componente all'uso in base allo stato del ciclo di vita dedotto: ad esempio, un componente contrassegnato come Obsolete (rosso) è meno consigliato rispetto a uno classificato come Volume Production (verde). Passa il puntatore su una striscia colorata per visualizzare lo stato del ciclo di vita del produttore.

Se utilizzi la funzionalità di integrazione con SiliconExpert o Z2Data, nella parte superiore del pannello Details potrebbero essere disponibili dati e controlli aggiuntivi. Consulta le pagine Recupero dei dati dei componenti da SiliconExpert e Recupero dei dati dei componenti da Z2Data per saperne di più.

Se nel tuo Workspace è abilitata la funzionalità Controllo delle revisioni delle scelte dei componenti, selezionando l'opzione Operations » Create/Edit Part Choices si aprirà l'Editor dei componenti (in modalità Modifica di un singolo componente o Modifica in batch dei componenti) anziché la finestra di dialogo Edit Part Choices. Apporta le modifiche necessarie alle scelte dei componenti e salva nuovamente i componenti nel Workspace, creando le revisioni successive.

Menu contestuale del pannello Componenti

Il menu contestuale del pannello, accessibile con il tasto destro del mouse, offre i seguenti comandi:

 
 
 
 
 
  • Place [ComponentName/FootprintName/SimulationModelName] – consente di posizionare il componente o il modello di simulazione attualmente selezionato nel documento schematico attivo, oppure il footprint attualmente selezionato nel documento PCB attivo.

  • Find Similar Components – consente di aprire la finestra di dialogo Trova componenti simili per impostare i criteri di ricerca e trovare componenti simili a quello selezionato.

  • Navigate to [ComponentName] – consente di aprire il componente del Workspace scelto nel pannello Explorer, dove puoi accedere a informazioni dettagliate sull'elemento e gestire le impostazioni delle revisioni e del ciclo di vita degli elementi, oltre a consultare i dettagli sui punti di utilizzo e sulla catena di approvvigionamento, tra le altre opzioni.

  • Edit – fai clic per modificare i componenti del Workspace selezionati tramite l'Editor dei componenti (in modalità Modifica di un singolo componente o Modifica in batch dei componenti) oppure il modello di dominio selezionato (simbolo, footprint o modello di simulazione) nel relativo editor. Se il tipo di componente corrente è diverso da quello del modello attualmente in uso, si aprirà la finestra di dialogo Change component type (). Utilizza questa finestra di dialogo per cambiare il tipo del componente selezionato.

  • Create – fai clic per aprire la finestra di dialogo Create new component e selezionare il tipo di componente quando aggiungi un nuovo componente.

  • Delete – fai clic per eliminare i componenti selezionati dal Workspace a cui sei connesso.

  • Operations – consente di accedere a un menu a discesa con funzioni aggiuntive per i componenti del Workspace, come descritto di seguito.

    • Submit Request – consente di accedere alle definizioni attive dei processi di richiesta dei componenti. Se non sono disponibili definizioni di processo attive per la categoria di processi Richieste di componenti, il pulsante Submit Request sarà disattivato (non disponibile). Per aggiornare, potrebbe essere necessario disconnettersi dal Workspace e accedere nuovamente oppure riavviare Altium Designer.

    • Download – consente di scaricare i componenti selezionati in una Libreria integrata compilata e compressa in formato ZIP (*.IntLib), con il relativo pacchetto delle librerie sorgente (*.LibPkg) e i file di libreria. Seleziona più voci di componenti per scaricarli in un'unica sessione.

    • Make a copy – fai clic per copiare il componente selezionato. L'Editor dei componenti si apre in modalità Single Component Editor.

    • Change Component Type – consente di aprire la finestra di dialogo Choose component type (), dalla quale puoi cambiare il tipo del componente corrente scegliendo uno degli altri tipi già definiti nell'elenco. La finestra di dialogo mostra informazioni su qualsiasi modello di componente associato a un tipo di componente e sulla cartella del Workspace connesso in cui è possibile trovare o salvare i componenti di quel tipo. Fai clic sul pulsante  per gestire l'elenco dei tipi di componente disponibili nella pagina Gestione dati – Tipi di componente della finestra di dialogo Preferences.

    • Change State – consente di cambiare lo stato della revisione dei componenti selezionati. Dopo aver utilizzato il comando, si apre la finestra di dialogo Modifica dello stato in batch, che consente di cambiare lo stato della revisione dei componenti.

    • Create/Edit Part Choices – consente di accedere alla finestra di dialogo Edit Part Choices, dove puoi creare o modificare l'elenco delle scelte dei componenti associato al componente del Workspace.

      Se nel tuo Workspace è abilitata la funzionalità Controllo delle revisioni delle scelte dei componenti, selezionando questo comando si aprirà l'Editor dei componenti in modalità Modifica di un singolo componente o Modifica in batch dei componenti.
    • Full Item History – consente di accedere a una vista dettagliata del componente attualmente selezionato, aperta come nuova scheda in Altium Designer. La Vista elemento fornisce una vista estremamente dettagliata della cronologia delle revisioni e del ciclo di vita di un elemento specifico, mostrando anche tutti gli elementi che lo compongono. La vista include inoltre una sequenza temporale. Utilizza la sequenza temporale per esaminare l'ora e la data esatte di qualsiasi modifica apportata al livello di revisione o allo stato del ciclo di vita di quell'elemento e sapere chi l'ha effettuata.

  • Refresh – fai clic per aggiornare rapidamente il pannello. La selezione corrente dei componenti verrà mantenuta.

Funzionalità di confronto dei componenti

La funzionalità Compare consente di confrontare i parametri di due componenti selezionati. Per accedere a questa funzionalità, selezionare due componenti nell'area della griglia con l'icona abilitata (blu). L'area Selected Component Details si apre a destra dell'area della griglia. L'area superiore (area 1 nell'immagine seguente) mostra affiancati un'immagine, il nome, la descrizione e il prezzo dei componenti selezionati. Fare clic sul pulsante Datasheet per aprire la scheda tecnica del produttore (se disponibile) del componente corrispondente. Fare clic sul pulsante Place per posizionare il componente nell'area di progettazione. Il componente apparirà sospeso nell'area di progettazione; fare clic per posizionarlo nel punto desiderato. È possibile continuare a posizionare altri componenti oppure fare clic con il pulsante destro del mouse o premere Esc per uscire dalla modalità di posizionamento e tornare al pannello Components.

L'area inferiore (area 2 nell'immagine seguente) mostra i parametri dei componenti affiancati, con le differenze evidenziate in rosso per facilitare il confronto.

La funzionalità Compare è disponibile anche quando il pannello Components è in modalità compatta, anche se il funzionamento è leggermente diverso. Per accedere a questa funzionalità, selezionare due componenti nell'area della griglia. L'area Selected Component Details si apre sotto l'area della griglia. L'area superiore mostra il nome, il prezzo e i parametri dei componenti, con le differenze evidenziate in rosso per facilitare il confronto. L'area inferiore mostra affiancati Symbols e Models dei componenti.

La funzionalità Compare e le relative funzioni sono disponibili anche nel pannello Ricerca componenti del produttore.

Modifica dei simboli e dei footprint dei componenti

Il simbolo e il footprint di un determinato componente possono essere nascosti nella sezione Models del riquadro Details, accessibile facendo clic su Info button in alto a destra. Una volta nascosti, il simbolo e il footprint vengono sostituiti da collegamenti cliccabili che ne ripristinano la visualizzazione originale. È inoltre possibile ridimensionare i modelli visualizzati. Sia per i simboli sia per i footprint, fare clic sul bordo inferiore dell'area del modello e trascinarlo per ridimensionare l'immagine.

Si noti che la possibilità di nascondere e ridimensionare le viste dei modelli è disponibile anche nel riquadro Details del pannello Ricerca componenti del produttore.

Per un file di libreria schematica (*.SchLib) consultato nel pannello Components, è possibile modificare il simbolo e il footprint del componente selezionato utilizzando il pulsante in basso a destra nell'anteprima del modello.

La possibilità di modificare un footprint è disponibile quando si accede a Components, purché siano già presenti footprint validi e collegati.

Finestre di dialogo per la selezione dei componenti

Il motore di ricerca e la vista utilizzati nel pannello Components sono impiegati anche in altre applicazioni di Altium Designer in cui è necessario scegliere un componente. La funzionalità di ricerca dei componenti è inclusa in queste finestre di dialogo (modali), insieme a un pulsante di conferma OK e a piccole variazioni nei comandi disponibili. La finestra di dialogo è generalmente denominata Component Search.

Accesso e posizionamento dei componenti generici

Questa funzionalità è in Open Beta ed è disponibile quando l'opzione ComponentSearch.GenericComponents è abilitata nella finestra di dialogo Impostazioni avanzate.

Per velocizzare il processo di definizione delle prime fasi di un progetto, è disponibile il concetto di Generic Components standard e di base. I componenti generici possono essere posizionati rapidamente in un progetto senza dover cercare e scegliere una parte di un produttore specifico tra le sorgenti di componenti disponibili. I componenti generici sono pensati come segnaposto da sostituire facilmente con un componente adatto in una fase successiva del processo di progettazione; possono anche essere considerati componenti virtuali o parametrici.

Per saperne di più sulla creazione di componenti generici, consultare la pagina Creazione di componenti generici.

Quando Altium Designer è connesso a un Workspace, è possibile accedere ai componenti generici disponibili dal pannello, dove vengono visualizzati quando si seleziona l'opzione All nel riquadro Categories, oppure dal menu a discesa superiore quando il pannello è in modalità compatta. Fare clic sul pulsante all'interno del riquadro di un componente generico per agganciare il componente al cursore e posizionarlo nel documento schematico attivo. Quando il componente viene posizionato in uno schema, le primitive dei pin, delle linee e dei bordi del simbolo, che ne costituiscono di fatto il contorno, sono colorate in rosso per indicare che si sta utilizzando un componente generico. Selezionando il riquadro stesso nel pannello Components, si apre nel pannello la categoria relativa a quel tipo di componente.

Posizionamento di un componente generico dal pannello Components
Posizionamento di un componente generico dal pannello Components

Poiché i componenti generici non devono essere utilizzati in un progetto definitivo, quando vengono posizionati in uno schema generano una violazione ERC: Componente generico. Il livello di questa violazione, per impostazione predefinita Fatal Error, è definito nella sezione Violazioni associate ai componenti delle impostazioni di segnalazione degli errori nella finestra di dialogo Project Options (Project » Project Options).

Selezionare un componente generico posizionato per accedere alle sue proprietà nel pannello Proprietà, che fornisce solo le impostazioni e i parametri pertinenti a questo tipo di componente. I parametri disponibili sono definiti dal relativo modello di componente (Resistors nell'esempio qui mostrato). I valori dei parametri possono essere inseriti manualmente oppure selezionati da un elenco a discesa che propone valori ricavati da tutti i componenti disponibili di quel tipo.

Definizione dei parametri di un componente generico: selezione dei valori dei parametri dagli elenchi a discesa.

Definizione dei parametri di un componente generico: il risultato.

 

Supporto per i componenti jumper

I jumper, detti anche ponticelli, consentono di sostituire il routing con un componente jumper, spesso essenziale per progettare correttamente una scheda a singola faccia. Altium Designer supporta l'uso dei componenti jumper tramite un tipo di componente speciale: Jumper.

Sebbene sia possibile iniziare posizionando i footprint dei jumper direttamente sul PCB, il flusso di lavoro consigliato parte dallo schema. Per saperne di più, consultare la pagina Utilizzo dei componenti jumper.

AI-LocalizedLocalizzato tramite A
Se trovi un problema, seleziona il testo/l’immagine e premi Ctrl + Enter per inviarci il tuo feedback.
Nav
Contents
Disponibilità delle funzionalità

Le funzionalità a tua disposizione dipendono dalla soluzione Altium di cui disponi: Altium Develop, Altium Agile Teams, Altium Agile Enterprise oppure Altium Designer (con abbonamento attivo).

Se non vedi una funzionalità documentata nel software che stai effettivamente utilizzando, contatta il reparto vendite di Altium per saperne di più.

Documentazione legacy

La documentazione di Altium Designer non è più suddivisa per versione. Se è necessario accedere alla documentazione delle versioni precedenti di Altium Designer, visitare la sezione Documentazione legacy della pagina Altri programmi di installazione.

Contents