Altium NEXUS Documentation

RemoveUnusedPads

Created: July 27, 2015 | Updated: June 21, 2017

Parent page: PCB Commands

The following pre-packaged resource, derived from this base command, is available:


Applied Parameters: None

Summary

Pads and vias are an essential ingredient of a modern PCB design. As well as providing mounting points for components, pads, along with vias, allow a net to traverse the different layers of a PCB as it travels from one component pin to another. Pads and vias come at a cost though; they consume valuable board space, they create impedance mismatches for high-speed signals, and they create holes in large copper areas defined by polygon pours.

This command is used to run the Unused Pad Shapes removal tool. The tool scans all pads or vias in the design, and removes the pad shape from each layer that the pad or via is not used on (meaning it has no other objects touching it on that layer). Polygon pours that surround that pad or via then only need to create the specified clearance to the pad or via hole, instead of to the edge of the unused pad shape. In some situations, such as under a BGA, this can recover a substantial amount of copper lost in polygons.

Access

This command is accessed from the PCB Editor, when configured in 2D Layout Mode, by choosing the Tools » Remove Unused Pad Shapes command, from the main menus.

The current viewing mode for the PCB document can be changed using the corresponding commands from the main View menu. To switch to 2D Layout Mode, use the command of the same name, or use the 2 keyboard shortcut.

Use

After launching the command, the Unused Pad Shapes dialog will appear. Use this dialog to configure the tool as required. While the tool is used primarily for removal of unused pad shapes, it can be configured to restore them as well, so make sure you set the correct operation of the tool according to your design requirements. Also, determine the scope of the removal/restoration - to work with only pads, or only vias, and either all, or just those currently selected in the design workspace.

With all options defined, clicking OK in the dialog will remove/restore unused pad shapes for the pads, or vias, targeted by the tool's scope.

Tips

  1. A pad or via might not use the pad shape on the outermost layers that its structure exists on, these outer-layer pad shapes can be preserved if required. Confirm that pad-less outer layer pads or vias are supported by your fabricator, before disabling the Preserve pads on start and end layers option.
  2. To ensure that existing polygons recover all available copper area that was lost to unused pad shapes in pads and vias, run the Tools » Polygon Pours » Repour All command after removing unused pad shapes.

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: