Altium Designer Documentation

Collaborate, Compare and Merge

Последнее изменение: Susan Riege; 14.11.2018
Полное содержание

Parent page: PCB Panel


The Collaborate, Compare and Merge panel

The Collaborate, Compare and Merge panel is command-central for performing a copper comparison between two versions of the same PCB design. It requires that the board is currently under version control and that the repository that it is stored in is configured in the Data Management - Design Repositories page of the Preferences dialog. The panel checks if the board is the latest revision (known as the Head revision). If it is not, it indicates what must be done to bring it up to date.

The board is divided into cells in the Difference Map. When you click on a cell the differences in that cell are detailed in the lower section of the panel, and also in the main workspace. The Difference Map also includes Layer tabs, use these to examine the differences on each layer.

Panel Access

  • To display the panel, click the Panels button at the bottom-right of the workspace when the PCB Editor is active and select the Collaborate, Compare and Merge entry from the pop-up menu.
  • You can also access the panel through the View » Panels » Collaborate, Compare and Merge command.

Panels can be configured to be floating in the editor space or docked to sides of the screen. If the Collaborate, Compare and Merge panel is currently in a group of panels, use the Collaborate, Compare and Merge tab located at the bottom of the panels to bring it to the front.

Terminology and Status Messages

Head

The latest revision committed to the version control system.

Base

The revision the local copy of the document was derived from, also known as the checked out revision.

Working Copy

Local copy of the version controlled document on which editing is performed.

Local changes

Changes made on the working copy that have not been committed to version control.

Status : Up to Date

The base revision is the head revision and no local changes have been made.

Status : Out of Date

The base revision is older than the Head revision and no changes have been made to the working copy.

Status : Modified

The base revision is the Head revision and changes have been made to the working copy.

Status : Merge required

The base revision is older than the Head revision and local changes have been made, i.e., the file is both modified and out of date.

Resolve

The act of updating the base revision number to the Head revision number. This will transform the status from merge required to modified.

Settings Region

  • Cell Size - displays the cell size when performing comparisons. Use the drop-down to select the desired size.
  • Include Polygon Pours in Comparison - enable to include polygon pours when performing comparisons.
  • Show Differences - enable to show differences.

Actions Region

When you click on a command in this region of the panel to initiate a Comparison, the software compares your file against the latest revision in the repository and displays the differences in the Difference Map region of the panel, as well as in the main editing workspace.

The Actions section of the panel is used for the following:

  • To display, define and clear Progress Regions in the main workspace.
  • To indicate if the board is up-to-date with the repository, define what must be done if it is not, and to initiate Compare and Merge actions.

Work in Progress Regions

Work in Progress regions are polygonal areas that each designer working on a board can place to show where they are currently working. These can then be displayed, hidden or removed.

The two Show work in progress commands display current regions in the Difference Map and main editor window. These can be hidden by clicking the red cross that appears when either command is run.

The Manually mark an area command presents you with an editing cursor in the main editing window. The placement behavior is the same as placing a solid polygonal region on your board: click to place each corner, press Shift+Spacebar to change the corner mode, Spacebar to change the corner start/end, and right-click to close the shape.

You can clear your own work in progress regions at any time using the Clear all My Work in Progress Regions command.

Version Control Status

When the panel is opened, the software automatically checks the revision number of your board and compares it to the revision number of the Head revision. If they are not the same, the Version control status will indicate what needs to be done to make them the same.

Difference Map Region

When a comparison is performed, the board is divided into cells (the cell size is defined at the top of the panel in the Settings region). The Difference Map presents these cells in a checkerboard fashion. As you hover the cursor over a cell, its cell reference is displayed, such as G4. Click on a cell to display that cell in the main editing window.

Cells that contain differences are shaded in color, the choice of color reflecting ownership of those changes as defined in the color key just below the map of the board. Clicking on a colored cell details all the differences in the Differences section at the bottom of the panel.

  • Layer tabs - select the desired layer to examine the differences on a specific layer.
  • Previous Unchecked / Next Unchecked - use to move backward or forward through the cells in a logical pattern, layer by layer.
  • Set Checked / Clear Checked - use to set or clear the checked differences.

Differences Details Region

The region at the bottom of the panel displays the Difference and Type of difference detected in the currently selected cell. 

Supported Objects

When working in Collaborative PCB Design, some objects/features are not supported by the merge process. Supported/not supported objects are detailed below.

Supported:

  • Tracks
  • Arcs
  • Fills
  • Solid Regions
  • Pads
  • Vias (also Blind & Buried)
  • Dimensions
  • Coordinates
  • Components

Not supported:

  • Polygon + cutout + board cutout
  • Embedded board array
  • Rooms
  • Origin
  • Grid
  • Free 3D Bodies
  • Guides
  • Rules
Multi-channel design is also not supported by the Collaborative PCB feature.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.