Altium NEXUS Documentation

Определение формы платы_AD

Created: 28.05.2021 | Updated: 28.05.2021
Если вы используете Altium NEXUS 4 или более новую версию, перейдите на страницу объекта Board Shape для получения актуальной информации о создании и изменении формы платы.

Форма платы Board Shape определяет границы платы, или ее участок, в редакторе плат. Board Shape – это объект редактора плат, также называемый Board Outline (Контур платы), который, по сути, является замкнутым полигоном. Когда вы создаете новый документ платы, это черная область с видимой на ней сеткой (в предположении, что сетка достаточно крупная для отображения с текущим уровнем приближения).


Плата по умолчанию размером 6х4 дюйма

Форма платы Board Shape используется в Altium NEXUS в следующих случаях:

  • Разделение платы на множество регионов платы.
  • Размещение линий сгиба на гибком регионе платы.
  • Определение участков экранных слоев для их отступов от края.
  • Разделение экранных слоев.
  • Расчет края платы при выводе проектных данных в другие инструменты.

При создании нового файла платы форме Board Shape по умолчанию задается размер 6000 x 4000 милов. Изменить размер формы, т.е. переопределить Board Shape, можно различными способами. Обратите внимание, что в документах платы, созданных с помощью шаблонов, форме платы уже задан размер. Независимо от итоговой конструкции платы (один жесткий регион или множество гибких и жестких регионов), общий внешний контур называется Board Shape.

Создание и изменение формы платы Board Shape

Форму платы Board Shape можно переопределить следующими способами:

  • Вручную – переопределением формы или перемещением вершин (углов) существующей платы. Переключитесь в режим Board Planning Mode (View » Board Planning Mode), затем используйте команды Redefine, Edit или Modify Board Shape меню Design.
  • Из выделенных объектов – выполняется, как правило, с помощью контура на механическом слое. Используйте этот вариант, если контур был импортирован из средства MCAD как файл DWG/DXF. Переключитесь в режим 2D Layout Mode (View » 2D Layout Mode), выделите примитивы на механическом слое (Edit » Select » All on Layer), затем используйте команду Design » Board Shape » Define from selected objects.
  • Из 3D-модели – используйте этот вариант, если в объект 3D Body (Place » 3D Body) была импортирована модель STEP из MCAD. Переключитесь в режим 3D Layout Mode (View » 3D Layout Mode), затем используйте команды подменю Design » Board Shape для выбора формы платы Board Shape.

Импорт контура для использования в качестве Board Shape


При импорте данных DXF/DWG убедитесь, что масштаб, ширина линий по умолчанию и отображения слоев настроены необходимым образом.

С помощью импорта данных DXF/DWG в механический слой и последующего определения формы платы из механического слоя, в редактор плат можно перенести форму, созданную в механической САПР.

Для импорта файла DXF/DWG в новый документ платы:

  1. Выберите команду File » New » PCB. Будет открыт новый документ платы, черная область представляет текущую формы платы Board Shape.
  2. Перед импортом новой формы задайте следующие параметры в соответствии с требованиями проекта и импортируемой формы:
    • Единицы измерения – задайте параметр Units в разделе Other панели Properties в режиме Board.

    • Сетка – задается в разделе Grid Manager панели Properties в режиме Board.

    • Точка отсчета – в новом документе платы положением пользовательской (относительной) точки отсчета является абсолютная точка отсчета. Выберите команду Edit » Origin » Set из главного меню, затем щелкните ЛКМ, чтобы определить положение пользовательской точки отсчета, например, в левом нижнем углу текущего контура платы. Это позволит задать подходящую точку отсчета в соответствии с точкой отсчета импортируемого контура.
  3. Следующим шагом является импорт контура платы из файла .DXF или .DWG. Обратите внимание, что импортируемый контур должен быть замкнут и что внутренние вырезы не будут созданы автоматически (но они могут быть определены из импортированных объектов позже). Выберите команду File » Import » DXF/DWG, чтобы открыть диалоговое окно Import File, убедитесь, что в качестве типа файла File Type в нижней правой части окна выбрано AutoCAD Files (*.DXF,*DWG), затем найдите нужный файл.
  4. После нажатия кнопки Open будет открыто диалоговое окно Import from AutoCAD (как показано на втором изображении на этой странице).
  5. Задайте масштаб (Scale), ширину линии по умолчанию (Default Line Width) и отображение слоев (Layer Mappings) необходимым образом, затем нажмите OK.
  6. Все объекты в файле DXF/DWG будут преобразованы в объекты редактора плат, которые будут отображены в рабочей области.

Если на механическом слое существует замкнутый контур, то его можно использовать для определения формы платы.

Определение формы платы из выделенных объектов

Как упоминалось ранее, если существует замкнутый контур, состоящий из линий и/или дуг, то эти объекты можно использовать для создания формы платы.

Для определения формы платы из этих объектов:

  1. Переключите режим отображения в 2D Layout Mode (меню View).
  2. Выделите объекты (команда Edit » Select » All on Layer отлично подходит для этого).
  3. Выберите команду Design » Board Shape » Define from selected objects – форма платы будет переопределена выделенными объектами, и будет отображен обновленный контур.
  4. Откройте панель View Configuration и дважды щелкните ЛКМ по механическому слою, который содержит контур платы, чтобы отредактировать его. Будет открыто диалоговое окно Edit Layer, где вы можете задать типу слоя Layer Type значение Board (Плата), как показано на анимации ниже.

Система попытается найти форму на основе средней линии выделенных объектов. Если координаты конца одного сегмента трассы/дуги не совпадают в точности с координатами конца следующего сегмента трассы/дуги, то алгоритм определения границ даст сбой, и будет отображено сообщение, показывающее место сбоя. Вместо этого будет предложено использовать алгоритм трассировки. Обратите внимание, что алгоритм трассировки следует внешнему краю трасс/дуг, и форма платы будет слегка отличаться от той, которая была создана из средних линий. Выбирайте этот вариант, только если это допустимо в конструкции вашей платы.

Определение формы платы из 3D-модели

Эта возможность позволяет переопределить форму платы на основе поверхности (грани) импортированной 3D-модели. Ее можно использовать для быстрого создания сложной формы платы, что позволяет объединить области электронного и механического проектирования. Это двухэтапный процесс: сначала импортируется STEP-модель, затем на STEP-модели выбирается нужна грань.

Для этого необходимо выполнить следующее:

  1. Переключитесь в режим View » 3D Layout Mode.
  2. Для импорта STEP-модели (.step или .stp) разместите 3D-модель (Place » 3D Body), затем в режиме 3D Body панели Properties выберите Generic в разделе 3D Model Type. В разделе Source выберите Embed Model (Встроить модель) или Link to Model (Добавить ссылку на модель) для импорта нужной модели STEP. Обратите внимание, что STEP-модель можно удалить после того, как форма платы была переопределена.
  3. Выберите команду Design » Board Shape » Define from 3D body.
  4. В строке состояния будет отображено Pick a 3D body (Выберите 3D-модель). Щелкните ЛКМ по 3D-модели, чтобы выбрать ее.
  5. Курсор изменит свой вид на перекрестие, и в строке состояния будет отображено Choose Face (Выберите грань). При наведении курсора мыши на грань она будет подсвечена. Щелкните ЛКМ по нужной грани, чтобы выбрать ее.
  6. Будет открыто диалоговое окно Board Outline Creation Successful, в которой доступны параметры размещения импортированной 3D-модели относительно новой созданной формы платы. Это диалоговое окно можно проигнорировать, если вы планируете удалить STEP-модель, в противном случае задайте параметры необходимым образом.

    Обратите внимание, что если вы встроили STEP-модель в файл платы или добавили в него ссылку на STEP-модель, то при изменении файла STEP вы получите уведомление. Вам также будет предложено обновить форму платы, что является полезным, если форма платы дорабатывается и ожидаются ее изменения.

Для создания формы платы можно использовать только поверхности, выровненные с плоскостью X-Y. Если вы выберите поверхность модели, которой требуется выравнивание с плоскостью X-Y, будет открыто диалоговое окно Confirmation, в котором у вас будет запрошено подтверждение на выравнивание поверхности, перед тем как вы сможете продолжить. Это диалоговое окно позволяет вам разместить модель, выровняв выбранную грань с верхней или нижней поверхностью платы. Это значит, что можно задать вертикальное положение модели. После выравнивания вам понадобится снова выбрать команду Design » Board Shape » Define from 3D Body. После того, как форма платы была переопределена, вы сможете скрыть 3D-модель.

Изменение или переопределение формы платы

В режиме просмотра Board Planning Mode вы можете изменить форму платы перетаскиванием вершин либо полностью перерисовать (переопределить) ее. Перейдите на страницу объекта Board Shape, чтобы узнать больше.

Переопределение формы платы с помощью перехода в определенную точку

Для точного определения формы на платы на основе размеров вы можете использовать сочетания клавиш для перехода в определенную точку вместо того, чтобы использовать мышь. Для этого необходимо выполнить следующее:

  1. Задайте точку отсчета в левом нижнем углу платы (Edit » Origin » Set).
  2. Переключите рабочую область в режим (View » Board Planning Mode).
  3. Выберите команду Design » Redefine Board Shape и отпустите мышь.
  4. Нажмите клавишу J, чтобы открыть подменю Jump.

    Нажмите клавишу O, чтобы перейти в заданную точку отсчета. Нажмите клавишу Enter, чтобы определить первый угол новой формы платы.

  5. Нажмите J, L, чтобы открыть диалоговое окно Jump to Location.

    Поле координаты X будет активным; введите координату X следующего угла платы (не перемещая мышь).

  6. Нажмите клавишу Tab, чтобы перейти к полю координаты Y в диалоговом окне Jump to Location, затем введите здесь подходящее значение координаты Y.
  7. Нажмите Enter, чтобы принять введенные значения и закрыть диалоговое окно. Курсор перейдет в нужное место. Не перемещая мышь, снова нажмите клавишу Enter, чтобы определить этот угол.
  8. Снова нажмите J, L, чтобы открыть диалоговое окно Jump to Location. Введите следующую координату X, нажмите Tab, введите координату Y, нажмите Enter, чтобы принять значения, затем нажмите Enter, чтобы определить угол.
  9. Повторяйте этот процесс до тех пор, пока все углы не будут определены и вы не вернетесь в точку отсчета 0, 0. Опять же, не перемещая мышь, нажмите Enter.

Интерактивное редактирование формы платы

Форма платы является полигональным объектом. Другим подходом является ее изменение путем задания относительно крупной сетки (Ctrl+G) и редактированием формы в интерактивном режиме, как показано на анимации ниже.


Если плата прямоугольная, может быть проще задать крупную сетку и изменить форму платы в интерактивном режиме.

► Узнайте больше об изменении полигональных объектов.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.