Altium NEXUS Documentation

Sch_Obj-ParameterParameter – Параметр_AD

Created: 02.07.2019 | Updated: 15.08.2019

Главная страница: Объекты редактора схем

Параметры используются для добавления подробной информации об объектах (на изображении выше показан компонент), документах и проектах.Параметры используются для добавления подробной информации об объектах (на изображении выше показан компонент), документах и проектах.

Обзор

Параметры – это текстовые строки общего назначения, которые являются дочерними по отношению к родительским объектам. Они определяют и добавляют дополнительную информацию к этому родительскому объекту, доступ к которой осуществляется непосредственно через панель Properties, когда объект выделен на листе схемы.

Широко используют параметры, например, схемные компоненты. Они используются для определения имени листа и комментария, а также для определения прочих строковых данных, которые необходимы для полного описания компонента. Параметры общего назначения (пользовательские параметры) компонентов могут использоваться по-разному, в том числе для определения информации о компонентах, рангов компонентов, информации о поставщиках, библиотечных ссылок и ссылок на даташиты.

Параметры также могут быть определены на уровне схемного листа (документа) и проекта. Параметры на уровне документа используются для определения таких полей, как номер и название документа, а параметры на уровне проекта подходят для определения таких полей, как разработчик и название проекта.

Доступ

Параметры добавляются или включаются автоматически в качестве свойств родительского объекта, они не размещаются независимо подобно объектам Text String. Типы доступных параметров можно разделить на системные и пользовательские, где пользовательские параметры добавляются вручную.

Системные параметры

При размещении объекта на схеме в него автоматически включается ряд ключевых системных параметров. Они определяют базовую информацию об объекте, которая используется системой для различия имени, типа и источника данных объекта.

Собственные системные параметра для объектов включают, но не ограничивают, свойства Comment (Комментарий), Description (Описание) и Design Item ID (Библиотечная ссылка).

Системные параметры объекта доступны в разделе Properties панели Properties (на вкладке General), когда родительский объект выделен. Когда отдельный параметр видим в рабочей области и выделен, он доступен через соответствующий режим панели Properties, как описано ниже.

Слева: системные параметры компонента в панели Properties. Справа: отдельный системный параметр в панели Properties.   Слева: системные параметры компонента в панели Properties. Справа: отдельный системный параметр в панели Properties.Слева: системные параметры компонента в панели Properties. Справа: отдельный системный параметр в панели Properties.

Некоторые системные параметры нельзя сделать видимыми (и выделить их) на листе схемы, следовательно, они не доступны в режиме Parameters панели Properties. Для компонентов такими параметрами являются Description (Описание), Design Item ID (Библиотечная ссылка), Footprint (Посадочное место), ссылки на модели и т.д. Другими системными параметрами, которые не доступны в схеме непосредственно, являются параметры документа (листа) и проекта.

Пользовательские параметры

Параметры добавляются в качестве свойств родительского объекта, и они не размещаются независимо, подобно объектам Text String. Параметры могут быть добавлены следующим объектам:

  • Component – добавьте пользовательские параметры на вкладке Parameters панели Properties, когда объект Component (Part) выделен, либо при определении компонента в редакторе схемных библиотек. Системные параметры, такие как Designator и Comment, всегда присутствуют в объекте Component, как обозначено выше. Чтобы открыть панель Properties, дважды щелкните по объекту либо щелкните ПКМ по объекту и выберите команду Properties из контекстного меню. Если панель Properties уже активна, выделите объект в рабочей области.
  • Part – на вкладке Parameters панели Properties, когда объект Part выделен.
  • Pin – на вкладке Parameters панели Properties, когда объект Pin выделен в файле .SchLib.
  • Port – на вкладке Parameters панели Properties, когда объект Port выделен.
  • Sheet Symbol – на вкладке Parameters панели Properties, когда объект Sheet Symbol выделен.
  • Document – на вкладке Parameters панели Properties в режиме Document Options (снимите выделение со всех объектов в схеме либо щелкните мышью по свободному месту документа). В новый лист схемы автоматически добавляется набор параметров по умолчанию, как определено шаблоном листа.
  • Project – в диалоговом окне Project Options (Project » Project Options). Параметры на уровне проекта перечисляются и добавляются на вкладке Parameters диалогового окна.
При размещении объекта (компонента, символа листа) нажмите клавишу Tab, чтобы приостановить размещение и открыть панель Properties в режиме родительского объекта, где параметры можно добавлять или изменять на лету. Нажмите значок "паузы" в рабочей области (), чтобы вернуться в режим размещения.

Пользовательские параметры доступны на вкладке Parameters панели Properties, когда родительский объект выделен. Здесь можно как добавлять, так и изменять параметры. Исключениями являются параметры проекта (доступ через диалоговое окно Project Options) и параметры вывода компонента (доступ через диалоговое окно Pin Properties). Когда отдельный параметр видим в рабочей области и выделен, он доступен через соответствующий режим панели Properties, как описано ниже.

Слева: пользовательские параметры компонента в панели Properties (вкладка Parameters). Справа: отдельный системный параметр в панели Properties.  Слева: пользовательские параметры компонента в панели Properties (вкладка Parameters). Справа: отдельный системный параметр в панели Properties.Слева: пользовательские параметры компонента в панели Properties (вкладка Parameters). Справа: отдельный системный параметр в панели Properties.

Параметры, добавленные родительскому объекту в процессе его размещения (см. выше) станут параметрами по умолчанию для следующих экземпляров размещаемого родительского объекта, если на странице Schematic - Default Primitives диалогового окна Preferences не включен параметр Permanent.

Когда этот параметр включен, параметры, добавленные размещаемому объекту, будут также добавлены следующим объектам, размещенным в этом же сеансе размещения, но не в последующих сеансах размещения этого объекта.

Графическое редактирование

Строки видимых параметров можно отредактировать графически непосредственно в рабочей области.

Перетащите параметр с зажатой ЛКМ, чтобы изменить его положение. Чтобы изменить строку параметра по месту:

  1. Щелкните мышью по параметру один раз, чтобы выделить его.
  2. Задержитесь на секунду, затем щелкните мышью еще раз, чтобы войти в режим редактирования по месту.
  3. Введите новые символы либо выделите всю строку, чтобы заменить все существующие символы.
  4. По завершении редактирования нажмите клавишу Enter или щелкните мышью все строки, чтобы выйти из режима редактирования по месту.

Строку параметра можно выделить и изменить непосредственно в рабочей области. Выделите всю строку, чтобы заменить ее.Строку параметра можно выделить и изменить непосредственно в рабочей области. Выделите всю строку, чтобы заменить ее.

Параметры, которые видимы в рабочей области и доступны для выделения, можно перетащить мышью в новое положение и повернуть в процессе перетаскивания. При перетаскивании мышью строки параметра используйте клавишу Пробел и сочетание клавиш Shift+Пробел, чтобы повернуть ее с шагом 90°, затем щелкните мышью, чтобы подтвердить новое положение/угол.

Перейдите в раздел Определение положения строки параметра ниже, чтобы получить информацию об автоматическом позиционировании параметра компонента и соответствующих настройках панели Properties.

Заблокированные параметры

Параметр, который является дочерним по отношению к объекту Component (Part), можно заблокировать и сделать его имя и значение недоступными для редактирования. Для этого необходимо выполнить одно из следующих действий:

  • переключите иконку () соответствующей записи на вкладке Parameters панели Properties родительского объекта;
  • поставьте флажок Lock Parameter в панели Properties, когда параметр непосредственно выделен в рабочей области.

Когда строка параметра заблокирована, ее нельзя изменить в панели Properties (на вкладке Parameters родительского объекта) либо в рабочей области с помощью редактирования по месту.

При попытке графически изменить объект со включенным свойством Locked (Заблокировано) появится диалоговое окно с запросом на подтверждение этого действия. Если на странице Schematic - Graphical Editing диалогового окна Preferences включен параметр Protect Locked Objects и свойство Locked объекта также включено, то этот объект нельзя выделить или графически изменить. Щелкните по заблокированному объекту мышью, чтобы выделить его, затем отключите свойство Locked в панели List или отключите параметр Protect Locked Objects для графического изменения объекта.

Редактирование вне графической области

Для видимого параметра, когда он выделен в рабочей области, существуют следующие методы редактирования вне графической области:

Через панель Properties

Страница свойств: Свойства Parameter

Этот метод редактирования использует соответствующий режим панели Properties для изменения свойств объекта Parameter.

Все атрибуты объекта Parameter доступны через режим Parameter панели Properties.Все атрибуты объекта Parameter доступны через режим Parameter панели Properties.

Когда строка параметра видима в рабочей области, открыть панель Properties в режиме Parameter можно одним из следующих способов:

  • Дважды щелкните ЛКМ по строке параметра.
  • Наведите курсор на строку параметра, щелкните ПКМ и выберите команду Properties из контекстного меню.
  • Если панель Properties уже активна, выделите объект Parameter.

Через панель List

Страницы панелей: SCH List, SCHLIB List , SCH Filter, SCHLIB Filter

Панель List позволяет отображать объекты одного или множества документов в табличном виде для быстрой проверки и изменения атрибутов объектов.

Использование панели с подходящим инструментом фильтрации (настройки Include панели) или в сочетании с диалоговым окном Find Similar Objects позволяет отображать в панели только те объекты, которые попадают в область действия фильтра. После этого свойства всех перечисленных объектов можно изменить непосредственно в панели List.

Параметры компонента

Параметры компонента, наиболее очевидные и часто используемые параметры в схеме, включают в себя дополнительные наборы специальных параметров и функциональных возможностей, которые расширяют возможности определения компонентов.

Определение параметров в схемной библиотеке

Перед размещением компонента в схеме, дочерние параметры родительского компонента можно определить в исходной библиотеке компонентов. Тем же образом, что и при работе в редакторе схем, вы можете использовать панель Properties для изменения и добавления параметров компонента в редакторе схемных библиотек.

Когда документ схемной библиотеки открыт, выберите компонент в панели SCH Library (View » Panels » SCH Library), чтобы открыть его параметры в панели Properties.

Открытие свойств библиотечного компонента при выборе этого компонента в панели SCH Library.Открытие свойств библиотечного компонента при выборе этого компонента в панели SCH Library.

По умолчанию свойства Designator и Comment библиотечного компонента не отображаются в рабочей области редактора схемных библиотек, но их можно отобразить, включив настройку Show Comment/Designator в панели Properties в режиме Library Options, который доступен, когда в рабочей области нет выделенных объектов.

Параметры, которыми владеет библиотечный компонент, определяются и редактируются так же, как и для размещенного на схеме компонента. Вы можете использовать клавишу Tab для создания и изменения параметров на лету при размещении объекта в рабочей области. Доступ к параметрам осуществляется через панель Properties, где базовые системные параметры доступны на вкладке General, а добавление/редактирование пользовательских параметров осуществляется на вкладке Parameters панели.

Чтобы добавить параметр, например, выводу компонента, выделите объект Pin в рабочей области, затем откройте вкладку Parameters в панели Properties. Нажмите кнопку Add, чтобы добавить в список пару Name/Value (Имя/Значение) нового параметра. Добавление параметров, связанных со всем компонентом, осуществляется обозначенным выше образом.

Параметр Designator

В редакторе схемных библиотек, параметр Designator компонента обычно определяется подходящим префиксом и знаком вопроса после него. Когда компонент размещен на схеме из библиотеки, средство Annotation редактора схем обнаруживает знак вопроса и заменяет его на подходящий числовой суффикс в ходе аннотирования проекта.

Редактор схем также включает в себя функциональную возможность простого автоматического увеличения позиционных обозначений, которую можно использовать в процессе размещения множества экземпляров одного компонента. Для ее использования нажмите клавишу Tab, когда к курсору прикреплен первый компонент, и в панели Properties введите подходящее позиционное обозначение, например R1. Следующие компоненты будут обозначены R2, R3 и т.д.

При размещении многосекционных компонентов, если начальное позиционное обозначение было назначено, как сказано выше, суффикс секции будет назначен автоматически, например U3A, U3B и т.д. Если начальное позиционное обозначение не было назначено, у всех секций будет один суффикс. Это можно разрешить с помощью команды Annotation редактора схем. Суффикс секции может быть буквенным или числовым, в соответствии с параметром Alpha Numeric Suffix на странице Schematic - General диалогового окна Preferences.

Определение положения строки параметра

Поведением по умолчанию строки параметра компонента является ее автоматическое позиционирование (сохранение углового положения) при повороте компонента в процессе или после размещения. Если такое поведение не требуется, отключите настройку Autoposition у этого параметра компонента на вкладке Parameters панели Properties – выберите параметр в списке на нажмите ссылку Other, чтобы получить доступ к этой настройке.

Обратите внимание, что для поворота компонента в процессе его размещения используются сочетания клавиш Пробел и Shift+Пробел. Вращение размещенного компонента осуществляется через меню Rotation в разделе Location панели Properties либо с помощью сочетаний клавиш Ctrl+Пробел и Ctrl+Shift+Пробел, когда компонент выделен.

Щелкните мышью по видимому параметру и перетащите его мышью, чтобы изменить его положение на схеме – используйте стандартные сочетания клавиш для изменения углового положения (Пробел и т.д.). Если настройка Autoposition этого параметра отключена и на странице Schematic - Graphical Editing диалогового окна Preferences включен параметр Mark Manual Parameters, перемещенные вручную параметры будут обозначены точкой в левом нижнем углу их прямоугольника выделения.

Особые параметры компонентов

Особые параметры компонентов доступны для ссылки на соответствующие URL или файловую документацию. Когда компонент выделен, эти ссылки добавляются в раздел Links панели Properties либо, для специальных ссылок справки, вызываемых по нажатию F1, на вкладке Parameters.

Параметры Link

Вы можете определять именованные ссылки на любое количество URL или документов.

Чтобы добавить ссылку в компонент, выделите его в рабочей области, нажмите кнопку в разделе Links панели Properties и введите имя ссылки и целевой URL или путь к файлу. Доступ к ссылке затем можно получить, щелкнув ПКМ по компоненту в рабочей области и выбрав имя ссылки в подменю References.

   

Ссылки компонентов, которые отображаются в панели и в рабочей области, внутренне основаны на паре имя/значение параметра в формате ComponentLinknDescription/ComponentLinknURL (где n – это номер ссылки в списке, в зависимости от порядка создания). Для получения более подробной информации перейдите к записи этого компонента в Parameter Table Editor.

Параметр HelpURL

Подобно параметру Link, параметр HelpURL позволяет определять ссылку из компонента на внешний документ, такой как PDF или URL веб-страницы. Когда такая ссылка добавлена в параметр компонента, активируйте ее с помощью клавиши F1, когда курсор наведен на компонент на листе схемы или когда компонент выделен в панели Libraries. Обратите внимание, что при этом будет переопределена стандартная функция клавиши F1, которая открывает соответствующую страницу онлайн-документации Altium.

Ссылка Help добавляется как пользовательский параметр на вкладке Parameters панели Properties, когда компонент выделен в рабочей области. Нажмите кнопку , чтобы добавить в список новый параметр, введите HelpURL в качестве имени параметра и целевой путь/URL в качестве значения параметра.

   

Значением параметра может быть URL, абсолютный путь к документу или просто имя документа. При нажатии F1, когда курсор наведен на компонент, или при использовании команды References » Help контекстного меню, поиск ссылки будет произведен следующим образом:

  • Если указан путь, сначала будет произведен поиск по нему.
  • Если документ не может быть найден в этом расположении либо если путь не указан, будет произведен поиск в папке \Help установки системы.
  • Если целью является URL, будет открыта веб-страница во внутреннем браузере системы либо во внешнем браузере, в зависимости от состояния параметра Open internet links in external Web browser на странице System - View диалогового окна Preferences.

Параметр в качестве значения строки

Большинство параметров компонента можно отобразить на листе схемы, переключив их видимость (если это применимо) в панели Properties (). Системные параметры доступны на вкладке General панели, пользовательские параметры – на вкладке Parameters панели.

Тем не менее, прочие параметры, такие как параметры документа и проекта, нельзя отобразить на листе схемы непосредственно, но их можно вставить в стандартный объект Text с помощью способа, известного как косвенная адресация строки. Для этого в качестве значения строкового объекта необходимо использовать имя доступного параметра (например, параметра документа или проекта) со знаком равенства перед ним – например =Title.

Система автоматически ищет такие строки и проверяет наличие имени параметра, которое соответствует значению размещенного объекта Text. Например, если параметр Title найден в параметрах документа, то текст строки будет преобразован в значение параметра Title, например MyDocument. Имя параметра можно перенаправить в значение выделенной текстовой строки путем редактирования по месту (введите =Title) или, что более информативно, с помощью выпадающего меню Text в панели Properties, где приведены доступные строки параметров.

Специальные строки

Параметры строк, доступные в качестве косвенных строк (см. выше), называются специальными строками. Значения, представленные этими строками, получены из шаблонов либо системных или исходных данных, например, специальная строка =Time найдет и отобразит текущее системное время, а строка =DocumentName отобразит имя файла текущего документа схемы (например, MySchematic.SchDoc).

Существует большое количество доступных предопределенных специальных строк, список которых приведен ниже. Пользовательские параметры документа или проекта тоже можно рассматривать как специальные строки, и их можно перенаправить в объект Text String на листе схемы.

Косвенные строки всегда преобразуются и отображаются в ходе формирования выходных документов, например, при печати листов схем. Многие из них также преобразуются и отображаются непосредственно на экране.

Специальные строки используются для определения полей основной надписи. Эта функциональная возможность обеспечит извлечение корректной информации об активном документе схемы из параметров документа и ее отображение соответствующим образом.

Предопределенные специальные строки

Приведенные ниже специальные строки доступны для использования в документе схемы. Большинство из них ссылаются на параметры по умолчанию, заданные в активном документе на вкладке Parameters панели Properties в режиме Document Options (нет выделенных объектов). Специальные строки, доступные на уровне проекта, можно просмотреть/добавить на вкладке Parameters диалогового окна Project Options.

  • =Address1 – отображает значение, заданное параметром по умолчанию Address1 на уровне документа.
  • =Address2 – отображает значение, заданное параметром по умолчанию Address2 на уровне документа.
  • =Address3 – отображает значение, заданное параметром по умолчанию Address3 на уровне документа.
  • =Address4 – отображает значение, заданное параметром по умолчанию Address4 на уровне документа.
  • =Application_BuildNumber – отображает версию и сборку текущей установки системы Altium.
  • =ApprovedBy – отображает значение, заданное параметром по умолчанию ApprovedBy на уровне документа.
  • =Author – отображает значение, заданное параметром по умолчанию Author на уровне документа.
  • =CheckedBy – отображает значение, заданное параметром по умолчанию CheckedBy на уровне документа.
  • =CompanyName – отображает значение, заданное параметром по умолчанию CompanyName на уровне документа.
  • =CurrentDate – текущая дата, вычисленная автоматически из настроек системы пользователя, в формате дд/мм/гггг. Обновляется при редактировании или при обновлении/перерисовке схемы. Пример: 10/12/2017.
  • =CurrentTime – текущее время, вычисленное автоматически из настроек системы пользователя, в формате чч:мм:сс AM/PM. Обновляется при редактировании или при обновлении/перерисовке схемы. Пример: 2:39:47 PM.
  • =Date – используется для отображения статической информации о дате. Отображает значение, указанное для параметра по умолчанию Date на уровне документа. В отличие от специальной строки =CurrentDate, которая автоматически вычисляется и представляется в заданном формате, пользователь может ввести статическую информацию о дате в любом предпочитаемом формате.
  • =DocumentFullPathAndName – используется для отображения полного пути и имени документа, в котором размещена строка. Пример: C:\MyTestDesign\PSU.SchDoc.
  • =DocumentName – используется для отображения только имени файла документа схемы (без пути файла). Пример: PSU.SchDoc.
  • =DocumentNumber – отображает значение, заданное параметром по умолчанию DocumentNumber на уровне документа. Исходный параметр также можно обновить с помощью диалогового окна Sheet Numbering for Project, которое открывается с помощью команды Tools » Annotation » Number Schematic Sheets.
  • =DrawnBy – отображает значение, заданное параметром по умолчанию DrawnBy на уровне документа.
  • =Engineer – отображает значение, заданное параметром по умолчанию Engineer на уровне документа.
  • =ImagePath – отображает значение, заданное параметром по умолчанию ImagePath на уровне документа.
  • =ModifiedDate – отметка времени изменения документа схемы, заполняется автоматически. Пример: 10/12/2015.
  • =Organization – отображает значение, заданное параметром по умолчанию Organization на уровне документа.
  • =ProjectName – отображает текущее имя проекта (включая расширение). Например, для проекта с именем файла MyPCB.PrjPcb эта специальная строка отобразит MyPCB.PrjPcb.
  • =Revision – отображает значение, заданное параметром по умолчанию Revision на уровне документа.
  • =Rule – отображает значение, заданное параметром по умолчанию Rule на уровне документа. Значением этого параметра изначально будет Undefined Rule (на схеме будет отображено *). Дважды щелкните по значению параметра, чтобы определить тип правила и изменить его ограничения.
  • =SheetNumber – номер листа текущего документа схемы. Это значение вычисляется с помощью команды Tools » Annotation » Number Schematic Sheets. Назначенный в диалоговом окне Sheet Numbering for Project номер листа будет присвоен параметру по умолчанию SheetNumber на уровне документа. При использовании специальной строки на вкладке Editor вида схемного листа, она будет брать эту информацию отсюда.
  • =SheetTotal – общее количество листов в проекте. Это значение вычисляется с помощью команды Tools » Number Schematic Sheets. Назначенное в диалоговом окне Sheet Numbering for Project общее количество листов будет присвоено параметру по умолчанию SheetTotal на уровне документа. При использовании специальной строки на вкладке Editor вида схемного листа, она будет брать эту информацию отсюда.
  • =Time – используется для отображения статической информации о времени. Отображает значение, указанное для параметра по умолчанию Time на уровне документа. В отличие от специальной строки =CurrentTime, которая автоматически вычисляется и представляется в заданном формате, пользователь может ввести статическую информацию о времени в любом предпочитаемом формате.
  • =Title – отображает значение, заданное параметром по умолчанию Title на уровне документа.
  • =VariantName – отображает вариант, из которого были сформированы выходные документы. Если для формирования выходных документов был использован базовый вариант, значением будет [No Variations].
  • =VersionControl_RevNumber – текущий номер ревизии документа. Чтобы эта строка содержала информацию, должен использоваться контроль версий.

Обратите внимание, что полный список специальных строк, доступный в выпадающем меню Text в панели Properties (когда текстовый объект выделен) будет также включать в себя все пользовательские параметры на уровне документа и проекта.

Специальные строки для использования с параметрами компонентов

При определении параметров компонента доступно несколько дополнительных специальных строк (или специальных преобразований существующих строк). В каждом случае, ввод специальной строки осуществляется в значение параметра.

  • =CurrentFootprint – отображает имя текущего посадочного места компонента, которое определено в разделе Models панели Properties (вкладка General).
  • =Comment – отображает значение, заданное в поле Comment компонента, как определено в разделе Properties панели Properties (вкладка General).
  • =Description – отображает значение, заданное в поле Description компонента, как определено в разделе Properties панели Properties (вкладка General).
  • =[ParameterName] – отображает значение, заданное для указанного параметра компонента. Введите имя параметра компонента в качестве имени специальной строки. Например, для параметра компонента с именем PowerRating введите =PowerRating. Этот подход можно использовать для отображения пользовательского параметра, например Description, путем создания пользовательского параметра (на вкладке Parameters панели Properties) со значением =Description и включения видимости этого параметра на схеме.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: