Altium NEXUS Documentation

Миграция существующих библиотек на сервер управляемых данных_AD

Created: 28.10.2020 | Updated: 28.10.2020

Главная страница: Работа с управляемыми компонентами

Altium NEXUS, в сочетании с сервером управляемых данных, предоставляет простой автоматизированный процесс для быстрой миграции существующих библиотек на этот сервер. Интерфейс для этого процесса – Library Migrator – представляет простое решение, которое автоматически анализирует выбранные библиотеки и мигрирует их на подключенный сервер управляемых данных.

Средство Library Migrator позволяет обрабатывать все типы библиотек, связанных со старыми методологиями управления компонентами (SCHLIB, PCBLIB, INTLIB, DBLIB, SVNDBLIB), для быстрого создания набора серверных управляемых компонентов предприятия и последующего использования всех преимуществ таких компонентов: высокая целостность данных, управление жизненными циклами, централизованное хранение и управление, изучение применяемости, простота повторного использования.

Средство Library Migrator предлагает минималистический простой режим интерфейса (Simple), где выбранные файловые библиотеки компонентов мигрируют в серверные управляемые компоненты в один этап. При этом средство миграции берет на себя классификацию по типам, назначение целевых папок, добавление параметров и типов значений, а также передачу всех связанных данных. Также доступен расширенный режим интерфейса (Advanced), где доступен полный предварительный просмотр планируемой миграции библиотек и все соответствующие данные и настройки. И хотя миграция по умолчанию осуществляется в один клик, средство миграции также предлагает расширенные настройки в панели Properties для лучшего контроля над тем, как будет осуществлена миграция.

Что доступно для миграции?

В серверные управляемые компоненты происходит миграция всей информации, которая присутствует в исходной библиотеке, со всеми доменными моделями (схемные символы, посадочные места, имитационные модели), параметрической информацией, назначенными вариантами выбора, файлами даташитов и т.д. При необходимости могут быть созданы шаблоны компонентов, которые можно изменить и использовать для последующих миграций библиотек.

Если у изначальных компонентов определено множество посадочных мест, вы можете быть уверены, что мигратор библиотек перенесет эти модели и также сохранит текущее посадочное место по умолчанию. И если вы работаете только с библиотеками посадочных мест (т.е. вам необходимо только конструирование плат), средство Library Migrator поддерживает миграцию только таких библиотек. Либо средство миграции можно переключить в режим миграции только моделей, при котором модели указанных типов будут мигрированы из интегрированных библиотек и библиотек на основе баз данных. Библиотеки, которые включают в себя компоненты множества типов (монолитные библиотеки), также автоматически обрабатываются.

Хотя процесс миграции библиотек требует работы с файловыми библиотеками, которые могут использовать различные стандарты оформления, автоматизированный анализ распознает типы компонентов в исходных библиотеках (резистор, конденсатор и т.д.), а также имена параметров и типы их значений (вольты, омы и т.д.). Система проводит ряд проверок, чтобы, например, убедиться, что отсутствуют дубликаты идентификаторов итоговых управляемых компонентов или что не будут созданы дубликаты моделей или шаблоны компонентов, для повторного использования этих сущностей. И если возникнут какие-либо проблемы, система укажет на них, с предложением их исправления, чтобы вернуться к миграции максимально быстрым и удобным способом.

Типы библиотек, которые могут быть мигрированы:

  • Библиотеки схемных символов (*.SchLib).
  • Библиотеки посадочных мест (*.PcbLib).
  • Интегрированные библиотеки (*.IntLib)
  • Библиотеки на основе баз данных (*.DBLib).
  • Библиотеки на основе баз данных под управлением SVN (*.SVNDBLib).
Миграция данных о сопоставлении выводов (для имитационных моделей) на данный момент не поддерживается.

Доступ к средству Library Migrator

Средство Library Migrator доступно при входе на сервер Altium. Чтобы открыть средство миграции в его простом режиме Simple:

  • Выберите файловую библиотеку в столбце Categories панели Components, затем выберите команду Migrate Library из меню кнопки .

    Вы можете просматривать установленные файловые библиотеки и управлять ими на странице Data Management – File-based Libraries диалогового окна Preferences.

    Если необходимо получить доступ к файловым неуправляемым библиотекам в панели Components, их можно включить в диалоговом окне Advanced Settings, которое открывается нажатием кнопки  на странице System – General диалогового окна Preferences. Включите опцию Legacy.UnManagedLibraries, чтобы включить доступ к файловым (неуправляемым) компонентам в панели, а также включить доступ к диалоговому окну Available File-based Libraries с помощью команды File-based Libraries Preferences меню кнопки  панели. Вам понадобится перезапустить Altium NEXUS, чтобы изменение этой настройки вступило в силу.

  • Щелкните ПКМ по файлу библиотеки в панели Projects и выберите команду Migrate Library из контекстного меню.
  • Выберите команду Tools » Migrate Library в редакторе схемных библиотек или в редакторе библиотек посадочных мест.
  • Перетащите с зажатой ЛКМ библиотеку из Проводника Windows в панель Explorer.

В простом режиме доступны опции для немедленной миграции выбранной библиотеки () и открытия средства миграции в режиме полного интерфейса пользователя ().

Средство Library Migrator в простом режиме (Simple).Средство Library Migrator в простом режиме (Simple).

Чтобы открыть средство Library Migrator непосредственно в режиме Advanced со связанной с ним панелью Properties, выберите команду File » Library Migrator из главного меню.

 Средство Library Migrator в полном режиме интерфейса (Advanced), который также поддерживает процесс миграции в один этап.

Simple Mode – Простой режим

Простой режим средства Library Migrator предварительно определяет все аспекты процесса миграции на основе анализа исходной библиотеки и подключенного сервера. Далее в диалоговом окне представляется сводка по структуре миграции, в том числе общее количество для объектов каждого типа. Процесс миграции осуществляется в один этап с помощью команды .

Этот простой режим интерфейса подойдет для наиболее распространенных форматов исходных библиотек, в которых содержатся компоненты общих типов (резисторы, конденсаторы, микросхемы и т.д.) и значения стандартизированных параметров. В процессе начального анализа, система определяет типы компонентов в библиотеке на основе позиционного обозначения и ключевых слов параметров (LD?, LED и т.д.), затем находит соответствующий шаблон компонентов на целевом сервере (LED). Этот шаблон применяется для миграции этих компонентов, и он определяет настройки миграции, такие как целевая папка (Components/LED), сопоставление параметров, единицы измерения параметров и т.д. Подходящие шаблоны доступны на сервере, если в процессе установки была включена опция Install sample data.

Результаты миграции библиотеки, т.е. новые управляемые компоненты, можно увидеть в панели Explorer и в панели Components. Мигрированные компоненты включают в себя все модели, параметры, интерпретированные соответствующими шаблонами компонентов, варианты выбора, полученные из ссылок на поставщиков в исходных данных, а также все ссылки и файлы.

К шаблонам компонентов, которые были созданы при миграции библиотек, можно получить доступ из папки Managed Content\Templates\Component Templates панели Explorer.

Если по каким-либо причинам вы хотите удалить набор компонентов (например, вас не устроил результат миграции), их следует выделить в панели Explorer, затем выбрать команду Delete Components and Models из контекстного меню. Помимо выбранных компонентов, могут быть также удалены связанные с ними модели (если они не используются другими компонентами). Эта возможность доступна только для пользователей с правами администратора сервера.

Замечания, касающиеся процесса миграции библиотек:

  • Монолитные библиотеки (те, которые содержат в себе компоненты множества типов) автоматически разделяются на подгруппы, где каждая группа представляет тип компонентов в этой библиотеке. Группы обрабатываются как отдельные библиотеки.
  • Исходная библиотека с компонентами нераспознаваемого (неопределяемого) типа будет мигрирована без интерпретации в виде компонентов неназначенного типа в серверной папке Components/Uncategorized. Перед началом миграции эти ситуации можно исправить, применив сопоставление позиционных обозначений или группирование параметров в расширенном режиме Advanced (полный интерфейс). Либо вы можете осуществить миграцию, затем изменить настройки и папки компонентов позже через панель Explorer.
  • Процесс миграции библиотек включает в себя этап автоматической валидации компонентов. Компоненты, которые вызывают нарушение валидации, будут пропущены.
  • Все ошибки, обнаруженные в процессе, могут быть отображены в отчете Migration Report, доступном с помощью кнопки по завершении миграции.

Advanced Mode – Расширенный режим

Полный интерфейс пользователя средства Library Migrator отображается в его расширенном (Advanced) режиме, который предоставляет полный контроль над библиотеками, типами компонентов и их параметрами. В сочетании с панелью Properties, миграция библиотек компонентов на сервер может быть настроена в соответствии с индивидуальными требованиями. Обратите внимание, что настройки миграции можно сохранять и восстанавливать путем экспорта/импорта файлов конфигурации.

Расширенный режим включается при открытии средства Library Migrator с помощью команды File » Library Migrator либо по нажатию кнопки в простом режиме. Библиотеки добавляются в раздел SOURCE LIBRARIES средства миграции (если он еще не заполнен) с помощью кнопки , путем перетаскивания файла библиотеки в эту область либо щелчком ПКМ по <All Libraries> и выбором команды Add Library. Используйте контекстное меню для исключения выбранной библиотеки или извлеченной подбиблиотеки из процесса миграции.

В разделе MIGRATION PREVIEW приводится список групп по типам компонентов, определенных из исходных библиотек – по типам компонентов (Component Types, ) или по предложенной структуре папок (Folder Structure, ) – и включает в себя табличный вид этих компонентов с их параметрами (Components). Значения параметров в таблице можно изменять на лету, что избавляет от необходимости открывать и редактировать исходную библиотеку. Область Details ниже включает в себя дополнительную информацию, взятую из выбранного в данный компонента: варианты выбора компонента, модели и даташиты.

Вы можете изменить тип компонента, щелкнув ПКМ по типу в списке Components Type.

Несмотря на наличие в интерфейсе более детальных опций и данных, расширенный режим средства миграции можно использовать тем же образом, что и простой режим – просто нажмите кнопку , чтобы запустить процесс миграции без какого-либо вмешательства. Как и в простом режиме, средство миграции проанализирует библиотеку, определит тип компонентов в ней и применит необходимый шаблон компонента. В свою очередь, шаблон определяет целевую серверную папку, применимые схемы именования и определения жизненных циклов, а также сопоставление/интерпретацию параметров.

  • Используйте кнопку (вверху слева) для обновления данных в средстве миграции. Данные исходных библиотек и сервера будут перезагружены для отражения всех изменений, которые произошли с момента открытия средства миграции.
  • Используйте поле Search (вверху справа) для фильтрации записей компонентов по совпадающему значению параметра.

Монолитные библиотеки

Исходные библиотеки, которые включают в себя компоненты множества типов, определяются процессами анализа средства миграции и разделяются на группы подбиблиотек, которые затем могут быть обработаны как отдельные библиотеки. Определение типов компонентов основано на позиционных обозначениях исходных компонентов (R?, C? и т.д.), а также на ключевых словах (Resistor, Res и т.д.), которые содержатся в основных параметрах компонентов (описание, ID и т.д.).

В примере, показанном ниже, исходная библиотека (ProjectABC.IntLib) была автоматически "разделена" в соответствии с обнаруженными типами компонентов (резисторы, конденсаторы и т.д.), которые можно выбрать в столбце Component Types для предварительного просмотра в таблице Components входящих в них записей компонентов.

Обратите внимание, что представление списка Components может быть изменено различными способами:

  • Щелкните ЛКМ по заголовку столбца, чтобы изменить порядок отображения списка по параметру этого столбца. Щелкните ЛКМ еще раз, чтобы обратить порядок.
  • В контекстном меню заголовка:
    • Выберите Clear Sorting, чтобы сбросить порядок отображения списка до настроек по умолчанию.
    • Выберите Best Fit, чтобы задать ширину этого столбца в соответствии с его содержимым.
    • Выберите Select Best Fit All Columns, чтобы задать ширину всех столбцов в соответствии с их содержимым.
    • Выберите Select Columns, чтобы открыть диалоговое окно Select Columns, где можно включать и отключать столбцы и изменять их порядок.
  • Щелкните ЛКМ по иконке фильтра () в заголовке, чтобы ограничить список одним из доступных в столбце параметров, пустыми/непустыми значениями или пользовательскими (Custom) настройками. Примененный фильтр отображается под списком, и здесь его можно включить/отключить (с помощью соответствующего флажка), изменить в Filter Editor или удалить. При выборе All через иконку фильтра в заголовке () примененный фильтр также будет удален.

Компоненты вне категорий

В показанной выше монолитной библиотеке, одна из библиотечных подгрупп названа Uncategorized (и она отображена как Uncategorized в списке Component Types), что означает, что средство миграции не может определить и назначить тип для данной группы компонентов – тип компонентов задан как None. В этом примере, неопределенные компоненты (логические микросхемы) используют неопознанный префикс позиционного обозначения (U?), и их параметры не содержат ключевые слова, такие как IC, logic и т.п.

При запуске процесса миграции, компоненты преобразуются как внекатегорийный тип без интерпретации. Тем не менее, если присутствуют ключевые/стандартные параметры (такие как Resistance, Capacitance, Tolerance и т.д.), средство миграции автоматически задаст им подходящий тип параметра (Ohm, Farad, Percent и т.д.).

Это можно исправить путем ручного сопоставления позиционных обозначений, используемых для этих компонентов, с нужным типом компонентов в диалоговом окне Library Splitting, которое открывается с помощью кнопки – доступна, когда исходная библиотека (ProjectABC.IntLib) выделена.

Когда в диалоговом окне включена опция Custom Designator Mapping , нажмите кнопку , чтобы создать новую запись для сопоставления, выберите нужный вариант строки позиционного обозначения для компонентов вне категорий из выпадающего списка Designator (в который включены все доступные позиционные обозначения), а затем выберите нужный тип компонентов из выпадающего меню Component Type. Подтвердите сопоставление типов компонентов и позиционных обозначений (позиционные обозначения U? в тип компонентов Logic) с помощью кнопки . Обратите внимание, что при необходимости вы можете вручную ввести множество типов позиционных обозначений, разделенных запятой.

Когда тип компонентов указан в применяемом сопоставлении, средство миграции будет использовать соответствующий шаблон компонентов (Logic) для конфигурации миграции библиотеки в соответствии с заданными в шаблоне настройками (папка, именование и т.д.).

  • Диалоговое окно Library Splitting также включает в себя опцию для группирования разделенных компонентов по указанному значению параметра (например, по параметру Category или Component_Type), если он был задан в исходной библиотеке. Для этого включите в диалоговом окне опцию Parameter Grouping и затем выберите подходящий параметр из выпадающего меню.
  • Также тип библиотечного компонента может быть выбран вручную в разделе General панели Properties.
  • Чтобы изменить тип компонента для отдельной записи в списке Components, нажмите по ее ячейке Component Type и выберите другой тип из выпадающего меню либо щелкните ПКМ по типу компонента и выберите Change Component Type из контекстного меню.

Благодаря гибкости настроек средства миграции, можно мигрировать новый (внекатегорийный) тип библиотеки компонентов с полной инфраструктурой, необходимой для последующих миграций этого типа библиотек. При задании подходящей конфигурации миграции (новый тип компонентов, шаблон компонентов, целевая папка, сопоставление параметров и единицы измерения значений параметров), единственным требованием к следующей миграции библиотеки этого типа является выбор определенного ранее типа компонентов. Выбранный тип компонентов затем определит все прочие аспекты миграции.

Исключение из миграции

Вы также можете исключить определенные типы компонентов из миграции. Чтобы исключить тип компонентов, щелкните ПКМ в списке Component Types по типу компонентов, который вы хотите исключить, и выберите Exclude from Migration из контекстного меню.

Исключенный тип компонентов будет затенен в списке Component Types. Чтобы отобразить исключенные компоненты в таблице, нажмите Show Excluded Component (n), где n означает количество исключенных компонентов.

Включение в миграцию

Если вы исключили тип компонентов из миграции с помощью описанной выше команды Exclude from Migration, но затем вам всё же понадобилось включить этот тип компонентов, щелкните ПКМ по затененному типу компонентов в списке Component Types и выберите Include to Migration из контекстного меню. Тип компонентов будет снова отображен в списке Component Types, что означает, что он больше не исключен.

Ошибки и предупреждения

Компоненты, которые не могут быть корректно мигрированы на сервер, помечаются ошибками или предупреждениями в расширенном интерфейсе пользователя, когда средство Library Migrator запущено () или при выполнении валидации миграции (). Критическая ошибка не позволит провести миграцию.

Обратите внимание, что раздел Migration Checks панели Properties показывает, какие проблемы необходимо искать (Violation Types) и как их следует помечать (Report Mode) – используйте выпадающее меню Report Mode для выбора другого уровня отчета для соответствующего типа нарушения.

При попытке провести миграцию, найденные нарушения отображаются в панели Messages, и диалоговое окно предложит прекратить или продолжить миграцию с текущей конфигурацией. В последнем случае, некорректные компоненты не будут мигрированы либо процесс миграции завершится неудачей.

В случае отмены миграции или при запуске валидации вручную, компоненты, не прошедшие проверки, будут отображаться с иконками ошибок/предупреждений, а в области Details ниже будет приведена дополнительная информация. Иконки в столбце Status указывают на записи определенных компонентов с нарушениями проверок правил миграции.

Устранение ошибок и предупреждений

Ошибки параметров, как в показанном здесь примере, где значение Forward Voltage компонента не может быть интерпретировано в корректное напряжение, можно устранить следующими способами:

  • Удаление компонента из процесса миграции – щелкните ПКМ по записи компонента и выберите команду Exclude from Migration.
  • Изменение вызывающего нарушение значения параметра – найдите и измените его ячейку до совместимого формата.
  • Изменение типа (Type) сопоставленного параметра, заданного примененным шаблоном компонента, с Voltage на неинтерпретируемый Text – выберите исходную библиотеку в интерфейсе мигратора, затем измените тип (Type) для Forward Voltage в списке Parameter Mapping панели Properties (на вкладке General).

Ошибка отсутствующего файла, например, ненайденный файл даташита, может быть устранена следующими способами:

  • Добавление отсутствующего файла в ожидаемое расположение.
  • Исключение компонента из процесса миграции библиотеки, как описано выше.
  • Отключение миграции файлов даташитов – измените опцию Migrate в разделе Datasheet панели Properties (на вкладке Advanced).

Используйте поле Search (вверху справа), если вы хотите найти записи определенных компонентов. Поиск отфильтрует список объектов по совпадающим значениям параметров для выбранного типа компонентов – выберите All в столбце Component Types, чтобы провести поиск по всем компонентам в доступных исходных библиотеках.

Миграция библиотеки схемных символов

Если при попытке мигрировать схемную библиотеку вы сталкиваетесь с ошибкой 'model not found' (модель не найдена), например, Footprint <НазваниеПосадочногоМеста> not found in available libraries), это значит, что средство миграции не может найти модели, которые связаны с компонентами в библиотеке SCHLIB.

В режиме Simple Mode такие ошибки будут отображены в HTML-отчете Migration Report, который открывается с помощью кнопки , доступной после запуска миграции. В режиме Advanced Mode ошибки обозначаются иконкой состояния в главном интерфейсе (), а также в качестве записей в панели Messages – это происходит при проведении валидационной проверки () либо при попытке мигрировать библиотеку ().

Самый простой способ исправить (или избежать) этой проблемы – это убедиться, что необходимые файлы библиотек моделей доступны в Altium NEXUS. Установка библиотек осуществляется на странице Data Management - File-based Libraries диалогового окна Preferences.

Либо, если вы не хотите устанавливать множество библиотек моделей, необходимо разместить их по пути библиотек по умолчанию (или изменить этот путь) и проверить, что исходные библиотеки моделей указаны в компонентах схемной библиотеки:

  • Добавьте библиотеку моделей по пути библиотек по умолчанию системы. Добавьте библиотеку моделей, например библиотеку посадочных мест, в это расположение. Чтобы определить этот путь, посмотрите запись Library Path на странице System - Default Locations диалогового окна Preferences. Если в это расположение был добавлен/скопирован файл библиотеки, может понадобиться перезапустить Altium NEXUS, чтобы изменение было принято.
  • Укажите название целевой библиотеки моделей в компонентах схемной библиотеки. Чтобы библиотека моделей, связанная с компонентом схемной библиотеки, стала известна средству миграции, укажите ее название в диалоговом окне PCB Model.

Обратите внимание, что нет необходимости в миграции библиотеки посадочных мест вместе со схемной библиотекой, поскольку миграция и связывание нужных моделей будет осуществлена самим средством миграции. Процесс миграции определяет, находит и переносит нужные модели каждого компонента для создания унифицированного управляемого компонента на целевом сервере.

Обнаружение дубликатов

Средство Library Migrator также включает в себя механизмы, которые позволяют избежать создания на целевом сервере дубликатов компонентов. Это достигается на этапе валидации путем сравнения идентифицирующих параметров и вариантов выбора компонента в исходной библиотеке и компонентов на целевом сервере.

С настройками средства миграции по умолчанию, этап валидации () отобразит предупреждение (Warning), если на целевом сервере будет обнаружен компонент с таким же именем (Name) или вариантами выбора (Part Choices), т.е. потенциальный дубликат компонента. Сообщение о предупреждении/ошибке включает в себя тип дублирования (параметр или вариант выбора компонента), название библиотечного компонента с нарушением и компонент на сервере (его ID), с которым возникает конфликт.

На стадии валидации обнаружено два потенциальных дубликата, где компоненты с теми же параметрами Name (изображение сверху) и Part Choice (изображение снизу) уже существуют на сервере.На стадии валидации обнаружено два потенциальных дубликата, где компоненты с теми же параметрами Name (изображение сверху) и Part Choice (изображение снизу) уже существуют на сервере.

Пара имя-значение параметра, используемая для обнаружения дубликатов, указывается в области Duplicates Detection панели Properties, на вкладке Advanced. Используйте выпадающее меню Unique Field (по умолчанию задано Name) для выбора из параметров, доступных в исходной библиотеке. Это особенно полезно для конфигураций библиотек, которые используют специальное идентифицирующее поле, связанное с корпоративной системой более высокого уровня.

Обнаружен дубликат, где значение определенного параметра (ERP-REF) совпадает у компонента в локальной библиотеке и компонента на сервере.Обнаружен дубликат, где значение определенного параметра (ERP-REF) совпадает у компонента в локальной библиотеке и компонента на сервере.

Другой тип пометки о статусе для таких нарушений можно задать, выбрав другой режим Report Mode в разделе Migration Checks на вкладке General панели Properties.

Библиотеки с единой моделью

Автоматизированное обнаружение дубликатов также применяется при обработке исходных библиотек, которые используют общие символы для всех компонентов. Такие библиотеки, как правило, состоят из компонентов одного типа с разными стилями и значениями, например, это могут быть резисторы определенного форм-фактора, для которых используется стандартное условно-графическое обозначение.

Такая ситуация с единой общей моделью обнаруживается средством Library Migrator, и он затем переносит только одну модель, которая применяется ко всем мигрируемым компонентам, вместо применения отдельного символа с собственным именем к каждому компоненту. Мигрируемый символ принимает общее название Symbol, все параметры компонента остаются неизменными.

Мигрированный библиотечный символ (с именем Symbol и пустым полем описания) можно изменить в соответствии с собственными требованиями. В панели Explorer используйте команду Edit контекстного меню для этого. Выберите команду Update items related to <ID_символа> в диалоговом окне Create Revisions for Item, чтобы обеспечить использование новой ревизии символа смигрированными компонентами.

Мигрированный библиотечный символ (с именем Symbol и пустым полем описания) можно изменить в соответствии с собственными требованиями. В панели Explorer используйте команду Edit контекстного меню для этого. Выберите команду Update items related to <ID_символа> в диалоговом окне Create Revisions for Item, чтобы обеспечить использование новой ревизии символа в компонентах, которые были мигрированы.

Объединение типов компонентов

Типы компонентов, зарегистрированные в системе, т.е. на подключенном сервере, доступны для просмотра и управления ими на странице Data Management – Component Types диалогового окна Preferences. Вместе с типами приводятся связанные с ними шаблоны компонентов (Template) и серверные папки (Folder), и этот список будет включать в себя все новые типы, созданные после миграции файлов библиотек на сервер с помощью средства Library Migrator.

Создание множества новых типов компонентов происходит, как правило, когда настройка средства Library Migrator использует группирование параметров (указанное значение параметра компонента) для определения типа мигрируемых компонентов. Например, параметром Categories может быть Resistor-0608 для одной группы мигрируемых компонентов, Resistor-0402 для другой, и т.д. Все эти компоненты лучше сгруппировать в один тип компонентов Resistors.

Вместо того, чтобы вручную изменять тип каждого компонента, страница Component Types диалогового окна Preferences позволяет объединить выделенные типы в одну указанную запись. Для этого выберите все записи типов, которые необходимо объединить, в том числе целевой тип, и затем щелкните ПКМ по выделенным записям и выберите команду Merge из контекстного меню. В открывшемся диалоговом окне Merging выберите целевой тип компонентов из выпадающего списка Merge to и нажмите кнопку для подтверждения. На изображении ниже это показано для набора мигрированных типов компонентов – резисторов.

Процесс изменит тип компонентов, участвующих в объединении (например, Resistor-0402, Resistor-0603 и т.д.) на целевой тип – Resistors в этом примере. Одним из полезных результатов является то, что все компоненты определенного типа теперь будут доступны при выборе этого типа в области Categories панели Components. Обратите внимание, что записи компонентов не изменяются каким-либо другим образом. Они остаются в своих существующих папках, которые связаны с шаблонами компонентов, созданными в процессе миграции, и сами шаблоны останутся доступными.

После объединения, на странице Data Management – Component Types будет показано, что тип компонентов Resistors является умолчательным для множества шаблонов, а именно – для шаблона Resistors и всех связанных с новым объединенным типом компонентов (шаблон Resistor_0402 и др.). Запись Folder для типа компонентов Resistors соответствует целевым папкам для этого множества шаблонов.

Результатом этого является то, что когда в средстве миграции в качестве типа мигрируемых компонентов выбран Resistors, он будет применен при выборе любого из объединенных шаблонов (Resistor_0402 и т.д.) в качестве альтернативы. При создании нового компонента (File » New » Component), эти шаблоны предлагаются в качестве подзаписей для типа компонентов Resistors в диалоговом окне Create new Component.

Результат объединения будет более оптимальным, если со всеми исходными типами компонентов изначально связан один шаблон – например, шаблон Resistors связан с типами компонентов Resistor-0402, Resistor-0603 и Resistor-0805. В этом случае, при объединении типов компонентов с типом Resistors, настройки его определенного шаблона и целевой папки останутся неизменными.

Назначения шаблонов

Диалоговое окно Edit Templates, которое открывается с помощью кнопки позволят изменить сопоставление шаблонов и типов компонентов, обозначенное на странице Data Management – Component Types. Это сопоставление, которое отображается в столбцах диалогового окна, показывает, какой тип компонента (Component Type) будет применен при использовании соответствующего шаблона (Template) – и наоборот, какой шаблон используется при выборе типа компонента (например, при создании нового компонента).

Для выбранной в диалоговом окне записи шаблона, изменение сопоставления осуществляется путем выбора альтернативного типа компонентов из выпадающего меню это записи. При последующем закрытии диалогового окна и страницы, значение параметра ComponentType шаблона и его настройка Default Folder будет изменена на соответствующие указанному типу. Это эквивалентно изменению шаблона вручную.

Используйте опцию Update existing components for changed templates для автоматического применения обновленного типа к компонентам, которые использовали предыдущий тип. Например, если настройка Component Type меняется с LED_SMT на LED, то компонентам, которым был задан тип LED_SMT, будет автоматически задан тип LED.

Результат обновленного сопоставления шаблонов и типов отображается на странице Data Management – Components Types, где показан список типов компонентов (столбец Name). Здесь обозначено, что с типом компонентов Resistor связано множество различных типов (Resistor_0402, Resistor_0603 и т.д.).

Миграция только моделей

Средство Library Migrator можно переключить в специальный режим миграции Models Only (Только модели), который обнаруживает и обрабатывает доступные модели компонентов в исходной библиотеке. Чтобы переключиться в этот режим миграции, включите опцию LibraryMigrator.ModelsOnlyMode в диалоговом окне Advanced Setting, доступного со страницы System – General диалогового окна Preferences.

В этом режиме, процесс анализа средства миграции будет определять все символы, посадочные места и имитационные модели, которые доступны в исходной библиотеке (IntLib, SchLib, PcbLib и т.д.), после чего будет осуществлена миграция этих моделей на сервер с использованием расположений, схем именования и определений жизненных циклов системы по умолчанию.

При переключении средства Library Migrator в расширенный режим () либо при его открытии в расширенном режиме (File » Library Migrator), становятся доступной вся подробная информация о планируемой миграции моделей. В области Migration Preview показана структура папок (Folder Structure), которая будет использоваться на целевом сервере. Ее настройку по умолчанию можно изменить в поле Folder панели Properties для каждого из типов моделей. Применяемые схемы именования и определение жизненного цикла для каждой модели можно выбрать из доступных системных типов (см. раздел Панель Properties ниже).

При необходимости вы можете ограничить типы моделей компонентов, которые будут мигрированы, путем отключения (или включения) определенных типов моделей в панели Properties с помощью соответствующих кнопок .

После того, как средство Library Migrator настроено, нажмите кнопку , чтобы завершить миграцию приведенных в списке моделей компонентов. Результаты можно просмотреть в лог-файле миграции, доступного из диалогового окна Library Migrator () или при просмотре мигрированных моделей в панели Explorer.

Панель Properties

Настройки в связанной со средством Library Migrator панели Properties обеспечивают расширенный контроль над миграцией выбранной библиотеки (или группы подбиблиотек). Настройки панели определяются системными настройками по умолчанию или теми настройками, которые указаны в применяемом шаблоне компонентов, который, в свою очередь, определяется типом компонентов – LED в примере показанном ниже. Эти настройки также доступны для изменения пользователем, что позволяет определять процесс миграции необходимым образом, и их можно восстановить до настроек по умолчанию с помощью ссылки Reset to Default (вверху справа).

На вкладке General панели представлены следующие разделы:

  • General (Общее):
    • Component Type (Тип компонентов) – тип компонентов, обнаруженный средством миграции для выбранной библиотеки и соответствующий применяемому шаблону (см. Component Template ниже). Переопределите эту настройку, введя значение в поле, что создаст новый тип компонентов, или выбрав альтернативный тип или шаблон с помощью выпадающего меню (или кнопки ). Это еще один способ устранить проблему внекатегорийных компонентов. Выберите опцию [НазваниеБиблиотеки], чтобы типу было задано название выбранной библиотеки.
    • Component Template (Шаблон компонентов) – серверный шаблон компонентов, который будет применен к мигрируемым компонентам, соответственнующий выбранному типу компонента. Переопределите эту настройку, выбрав альтернативный шаблон с помощью выпадающего меню (или кнопки ). Выберите опцию [Create new] для автоматического создания шаблона на основе параметров исходной библиотеки и текущих настроек средства миграции. Либо выберите [No Template], чтобы не применять и не создавать шаблон.
      Обратите внимание, что настройки Component Type и Component Template, по сути, связаны между собой при использовании доступного типа/шаблона. Например, если одну из этих настроек задать как Capacitors, то другой настройке будет автоматически задано Capacitors. Тем не менее, при изменении настройки Component Template на [Create New] будет создан другой шаблон Capacitors (с подходящей версией/суффиксом ревизии в названии) в соответствии с текущими настройками. Существующие шаблоны компонентов не будут изменены в процессе миграции.
  • Parameter Mapping (Сопоставление параметров) – сопоставление параметров между библиотечными параметрами и теми параметрами, которые находятся в шаблоне компонента (или которые заданы настройками по умолчанию, если шаблона нет), а также тип значения для каждого параметра (текстовый или с единицами измерения). Используйте выпадающие меню в столбце Source Library Parameter для внесения изменений в сопоставление и выпадающие меню в столбце Type для переопределения существующих настроек, заданных шаблоном или настройками по умолчанию. Выберите <Skip>, чтобы не включать параметры. Параметр, который не был автоматически сопоставлен с параметром в исходной библиотеке (т.е. был задан системой как <Skip>), может быть вручную сопоставлен с подходящим параметром в шаблоне. Например, исходный параметр ROHS может быть выбран для сопоставления с параметром RoHS Compliant, заданным в шаблоне на сервере. Вы можете изменять имена параметров, а также добавлять, изменять и удалять наборы параметров. Можно изменять сопоставление для основных параметров компонентов (ID, Name, Description), но в остальном они доступны только для чтения.
    Для серверного параметра ID, параметр из исходной библиотеки задан как <Auto>. Это значит, что идентификаторы компонентов будут автоматически созданы на основе шаблона именования (Naming Template), указанного в разделе Component панели, который находится на вкладке Advanced. Сопоставление идентификаторов можно изменить для использования любого параметра в исходной библиотеке (который уникален для каждого компонента) путем выбора другого параметра из выпадающего меню в столбце Source Library Parameter. Можно изменять сопоставление для основных параметров компонентов (ID, Name, Description), но в остальном они доступны только для чтения.
  • Part Choice Mapping (Сопоставление вариантов выбора компонентов) – список компонентов производителей (или ссылок на поставщиков), распознанных средством миграции, который будет использоваться для создания вариантов выбора для мигрированных компонентов. Используйте выпадающее меню для переопределения сопоставления, а также для добавления и удаления наборов сопоставлений. Обратите внимание, что по умолчанию эти параметры не включаются в процесс миграции (они будут пропущены). Если в библиотечный компонент добавлено множество ссылок на поставщиков, то для записей поля вариантов выбора компонента будет использоваться основная ссылка на поставщика (Supplier 1 / Supplier Part Number 1).
  • Migration Checks (Проверки миграции) – просматривайте и настраивайте отчеты средства миграции об ошибках/предупреждениях для нарушений правил миграции. Используйте выпадающее меню Report Mode для изменения отчета и иконки для записи Violation Type. Обратите внимание, что если выбран режим отчета Fatal Error, то при обнаружении этого нарушения процесс миграции будет приостановлен.

Вкладка Advanced панели предлагает настройки для всех объектов мигрируемых данных, заданных системными настройками по умолчанию или применяемым шаблоном компонента. Эти настройки включают в себя модели компонентов, файлы даташитов и все созданные шаблоны компонентов. Настройки для каждого объекта (кроме Datasheet, который представляет собой переключатель) включает в себя следующие разделы:

  • Folder (Папка) – целевая серверная папка для мигрируемого объекта, которую можно изменить вручную (например, создать новую целевую папку) или выбрать с помощью кнопки .
  • Naming Scheme (Схема именования) – серверное именование объекта, определенное шаблоном компонента. При отсутствии активного шаблона, схема определяется целевой папкой (или вводится вручную). Используйте выпадающее меню, чтобы выбрать доступную схему именования (Naming Schemes). Обратите внимание, что изменение пути к целевой папке (Folder) может привести к изменению примененной схемы именования, заданной самой папкой или связанным шаблоном компонентов.
  • Revision Naming Scheme (Схема именования ревизий) – схема именования, используемая для ревизий объекта на сервере, которая определена шаблоном или выбрана из выпадающего меню записи. Для выбора будут доступны только схемы, включенные системой.
  • Lifecycle Definition (Определение жизненного цикла) – система жизненных циклов, используемая для объекта, которая определена шаблоном или выбрана из выпадающего меню записи. Для выбора будут доступны только определения, включенные системой.
Раздел объекта Component включает в себя настройку для определения дубликатов (Duplicates Detection), как описано выше.

Экспорт и импорт конфигурации

Средство миграции библиотек включает в себя возможность экспорта подробного текстового файла с информацией о текущей конфигурации, который включает в себя все настройки миграции, такие как целевые пути, сопоставление параметров, схему именования, определения жизненных циклов, целевые типы компонентов и т.д.

Сохранение файла настройки миграции с расширением *.lmcfg осуществляется с помощью команды File » Export » Migration Config, и этот файл можно применить в любой момент с помощью команды File » Import » Migration.

Возможность восстановления конфигурации особенно полезна в случае, когда исходная файловая библиотека была изменена и эти изменения необходимо мигрировать на сервер. Если конфигурация была экспортирована при первой миграции библиотеки, то восстановленная (импортированная) конфигурация в точности восстановит настройки, которые использовались ранее, что обеспечит согласованность схемы передачи данных для этой библиотеки (или библиотек).

Обратите внимание, что экспортированный (сохраненный) файл конфигурации включает в себя ссылки на файлы библиотек, которые были открыты в качестве исходных библиотек на момент экспорта этой конфигурации. При последующем импорте (повторной загрузке) файла конфигурации, библиотеки, на которые эта конфигурация ссылается, должны быть доступны, т.е. они должны быть доступны в данный момент в виде исходных библиотек в средстве миграции.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: