Altium NEXUS Documentation

Работа между схемой и платой_AD

Щелкните ЛКМ в панели Navigator с зажатой клавишей Alt, чтобы выделить компонент одновременно на схеме и на плате

Одним из главных преимуществ Altium NEXUS является то, что вы можете легко переходить между различными элементами своего проекта. Например, один щелчок кнопки мыши в панели Projects открывает лист схемы, другой – печатную плату, третий – файл OutputJob со всеми выходными документами, которые необходимо сформировать.

Тем не менее, проект – это не только простой доступ к файлам. Вам необходимы ориентированные на проектирование средства, которые помогают решить все конструкторские задачи. Ключевым элементом эффективной работы является возможность беспрепятственно переходить между схемой и платой при выполнении различных задач проектирования.

Например, вы готовитесь к размещению компонентов и изучаете различные варианты компоновки, группируя связанные между собой компоненты на периферии платы. Или, возможно, вы проверяете связность, находите критические цепи и исследуете, как они были разведены.

Для решения подобных задач вам необходимо найти объекты в целевом документе на основе объектов, которые вы видите в исходных документах.

Перекрестный переход, перекрестное выделение и панель Navigator – вот некоторые способы, которые позволяют вам работать между документами схем и плат.

Перекрестный переход, перекрестное выделение и панель Navigator могут приближать вид, выделять объекты и затенять прочие объекты. Настройка этих действий осуществляется на странице System - Navigation диалогового окна Preferences.

Унифицированная среда проектирования

Фундаментальным элементом системы является унифицированная модель данных (Unified Data Model, UDM). При компиляции проекта создается единая связная модель данных, которая является центральной для процесса проектирования. Доступ к этой модели и ее изменение осуществляется через различные редакторы и службы системы. Вместо хранения отдельных наборов данных для каждого аспекта проектирования, модель UDM систематизирована для хранения всей информации для всех аспектов проекта, в том числе компонентов и связей между ними.

Как взаимодействовать с этой унифицированной моделью данных, например, для трассировки цепи в проекте? Это осуществляется через панель Navigator.

Зачем необходима компиляция, и что такое унифицированная модель данных?

Итак, что же такое динамическая компиляция и зачем необходимо компилировать проект?

При ручной компиляции проекта (Project » Validated PCB Project) система проверяет унифицированную модель данных (Unified Data Model, UDM) на логические, электрические и графические ошибки в соответствии с настройками компилятора.

Унифицированная модель данных

В основе системы лежит унифицированная модель данных (Unified Data Model, UDM). При автоматической динамической компиляции проекта происходит создание единой связанной модели, которая занимает центральное место в процессе проектирования. Данные этой модели затем можно открывать и изменять с помощью различных редакторов и служб системы. Вместо того, чтобы хранить данные каждого аспекта проектирования по отдельности, модель UDM структурирована для хранения всей информации о проекте, в том числе о компонентах и связи между ними.

Модель связности проекта инкрементально обновляется после каждого действия пользователя благодаря динамической компиляции. Не нужно компилировать проект вручную, поскольку это осуществляется автоматически. Для проекта платы, процесс автоматической компиляции выполняет три функции:

  1. формирование иерархии проекта.
  2. Создание связности цепей между всем листами проекта.
  3. Построение внутренней унифицированной модели данных (Unified Data Model, UDM) проекта.

Благодаря автоматической компиляции все внесенные проектные изменения сразу отражаются в панелях Navigator и Projects.

Скомпилированная модель проекта называется унифицированной моделью данных (Unified Data Model? UDM). Эта модель включает в себя подробное описание каждого компонента в проекте и его связность с другими компонентами.

В версиях системы до Altium NEXUS 20.0, для построения унифицированной модели данных было необходимо компилировать проект вручную. Сейчас модель данных проекта обновляется инкрементально после каждой операции благодаря динамической компиляции, что формирует так называемую динамическую модель данных (Dynamic Data Model, DDM). Нет ручной компиляции проекта, она осуществляется автоматически.

Перекрестный переход

Перекрестным переходом называется возможность щелкнуть (или щелкнуть дважды) ЛКМ по объекту в одном проектном интерфейсе и отобразить этот объект в другом проектном интерфейсе. В Altium NEXUS существует множество мест, где можно осуществить перекрестный переход.

Например, после запуска команды Tools » Cross Probe в редакторе плат вы можете щелкнуть по компоненту в плате и отобразить тот же самый компонент на схеме. Эта команда поддерживает перекрестный переход между компонентами, шинами, цепями и выводами/контактными площадками. По умолчанию вы остаетесь в исходном редакторе; используйте это поведение, когда видимы исходный и целевой документы. Зажмите Ctrl при щелчке ЛКМ, чтобы перейти в целевой документ.

Кроме того, после валидации проекта вы можете щелкнуть ПКМ по сообщению об ошибке в панели Messages и выбрать команду Cross Probe либо дважды щелкнуть ЛКМ по сообщению, чтобы перейти к месту ошибки в схеме.

Анимация, демонстрирующая перекрестный переход из схемы в плату
Вы можете осуществлять перекрестный переход между компонентами, выводами, цепями или шинами. Зажмите Ctrl для перехода в целевой редактор.

Существует ряд различных способов, с помощью которых вы можете осуществлять перекрестный переход в Altium NEXUS.

► Узнайте больше о Перекрестном переходе и выделении.


Перекрестное выделение

Перекрестное выделение схоже с перекрестным переходом. Используйте его для выделения компонента, который вы в данный момент можете видеть в другом проектном интерфейсе. Перекрестное выделение также предлагает выделение множества компонентов. Оно работает в обоих направлениях между схемой и платой, и это идеальное средство для создания набора выделенных объектов, которые готовы к какой-либо проектной операции. Например, вы можете видеть ряд компонентов на схеме и хотели бы найти их в рабочей области редактора плат для размещения их на плате.

После включения режима Cross Select Mode (меню Tools) при выделении компонента в одном редакторе он будет автоматически выделен в другом редакторе.

Анимация, демонстрирующая использование перекрестного выделения из схемы в плату
Используйте перекрестное выделение для быстрого выделения компонентов на плате непосредственно из схемы. Включите этот режим через меню Tools любого из редакторов.

► Узнайте больше о Перекрестном переходе и выделении.


Применение цвета к цепям

При создании проекта он быстро становится визуально перегруженным – схема занята связями, плата становится лабиринтом из линий соединения и разведенных цепей. Для внесения визуальной ясности, проектировщик может применить цвет к связям на схеме, а также к линиям соединения и трассировке на плате.

Функция выборочного переопределения цвета определенных цепей называется Net Color Override. Можно цвет применить к цепям на схеме и затем передать эти настройки цвета в плату, либо настройки цвета можно применить непосредственно в редакторе плат.

Изображение, показывающее схему и плату рядом друг с другом и применение цвета к цепям в обоих редакторах

► Узнайте больше о Применении цвета к цепям.


Синхронизация проекта

Самой распространенной задачей при работе между схемой и платой является поддержание соответствия схемы и платы, т.е. их синхронизация. Независимо от того, передаете ли вы данные из схемы в новую плату первый раз или вносите изменения в существующий проект на стороне схемы или платы, используется один и тот же процесс.

Иллюстрация, показывающее синхронизацию схемы и платы с помощью компаратораПроцесс синхронизации ищет и устраняет различия схемы и платы.

Синхронизация проекта осуществляется непосредственно между редакторами схем и плат, каких-либо промежуточных файлов списка цепей не используется. Система использует модуль сравнения (компаратор), чтобы сравнивать все аспекты проекта и формировать список запросов на инженерные изменения (Engineering Change Order, ECO). После применения этих запросов, две стороны проекта становятся синхронизированными.

► Узнайте больше о Синхронизации проекта.


Панель Navigator

Если проект большой и разбит на множество листов, может быть сложно отследить цепь и проверить связность проекта, просто взглянув на схему. Чтобы упростить этот процесс, используется панель Navigator. Панель отображает весь валидированный проект, поэтому она будет пустой, пока вы не запустите валидацию проекта (Project » Validate PCB Project). Панель Navigator можно открыть, нажав кнопку Кнопка Panels в нижней правой части приложения и выбрав Navigator.

Использование панели Navigator для поиска шины одновременно на схеме и на плате с помощью щелчка ЛКМ с зажатой клавишей Alt
Используйте панель Navigator для просмотра всего валидированного проекта. Зажмите клавишу Alt при щелчке ЛКМ в панели, чтобы найти этот же объект на плате.

► Узнайте больше о Панели Navigator.


Что дальше?

Подобно всем технологиям проектирования Altium NEXUS, редактор схем и редактор плат разработаны для быстрого изучения и простой работы в них. Широко используются контекстные меню, и везде доступна контекстно-зависимая справка (F1) и списки сочетаний клавиш для интерактивных команд (Shift+F1).

Если вы не знакомы с Altium NEXUS, вы можете начать с базового урока. Создайте простой проект из девяти компонентов, начав с пустого листа схемы и закончив платой, а также набором файлов, необходимых для ее изготовления.

Также могут оказаться полезными следующие страницы:

Синхронизация проекта

Панель Navigator

Перекрестный переход и выделение

Применение цвета к цепям

Эквивалентная замена выводов и секций

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: