Hướng dẫn Bắt đầu Nhanh Power Analyzer của Keysight

Sơ lược

Hướng dẫn bắt đầu nhanh này giới thiệu cách Power Analyzer by Keysight giúp bạn đánh giá mạng phân phối nguồn DC của thiết kế PCB ngay trong Altium Designer, để bạn không còn phải phỏng đoán mà có thể xác định liệu các đường dẫn đồng, mặt phẳng đồng, đường mạch và lỗ via có đáp ứng được nhu cầu cấp nguồn của thiết kế hay không. Hướng dẫn giải thích cách tiện ích mở rộng này tích hợp trực tiếp với dự án hiện tại, cách cài đặt và khởi chạy, những thông tin cần thiết lập trước khi chạy phân tích, cũng như cách bắt đầu xác định và mô phỏng các net nguồn. Nếu bạn muốn có điểm khởi đầu rõ ràng hơn để sử dụng Power Analyzer by Keysight trong quy trình làm việc hiện có, bài viết này sẽ trình bày các bước thiết yếu để bắt đầu. Hãy đọc tiếp để tự tin hơn khi sử dụng công cụ.

- Tìm hiểu chức năng của Power Analyzer by Keysight trong Altium Designer và cách công cụ này hỗ trợ phân tích tính toàn vẹn nguồn DC bằng dữ liệu thiết kế hiện có của dự án.
- Xem quy trình cơ bản để cài đặt tiện ích mở rộng, mở tài liệu phân tích và chuẩn bị các thiết lập bo mạch cũng như net để mô phỏng.
- Nắm rõ các yêu cầu thiết lập chính, bao gồm việc đồng bộ giữa sơ đồ nguyên lý và PCB, các tùy chọn cấu hình, yêu cầu về gói đăng ký và lựa chọn net nguồn.
Tìm hiểu sâu hơn với AI:

Với các thiết kế số hiện đại có mạch tốc độ cao, bo mạch bố trí linh kiện dày đặc và nhiều đường nguồn điện áp thấp, các yêu cầu đặt ra cho mạng phân phối nguồn DC đòi hỏi phải áp dụng phương pháp phân tích khi thiết kế mạng này. Việc phân tích DC của mạng phân phối nguồn, hay các kết quả phân tích tính toàn vẹn nguồn DC (PI-DC), nhằm bảo đảm có đủ đồng trên đường dẫn từ nguồn điện áp đến tải – nói cách khác, các lớp mặt phẳng, đường mạch và lỗ via trên bo mạch phải có kích thước (và đặc tính) phù hợp để đáp ứng yêu cầu tiêu thụ điện năng của các thiết bị trên bo mạch.

May mắn thay, có thể loại bỏ việc phỏng đoán khi đánh giá mạng phân phối nguồn của PCB bằng cách sử dụng công cụ mô phỏng tính toàn vẹn nguồn DC (PI-DC), giúp phân tích hiệu năng DC của thiết kế bo mạch dựa trên các thuộc tính điện và vật lý của nó. Altium Designer có một công cụ như vậy, đó là Power Analyzer by Keysight.

Được cung cấp dưới dạng tiện ích mở rộng Altium có thể tải xuống, Power Analyzer tích hợp trực tiếp với Altium Designer để cho phép mô phỏng và phân tích PI-DC cho dự án PCB hiện tại. Vì Power Analyzer hoạt động ngay trong Altium Designer nên không cần nhập/xuất dữ liệu thủ công, chuyển đổi dữ liệu hay chạy ứng dụng riêng – chỉ cần khởi chạy Power Analyzer từ trình chỉnh sửa sơ đồ nguyên lý hoặc PCB, thiết lập các thông số kiểm tra mong muốn rồi chạy mô phỏng. Kết quả chủ yếu được thể hiện thông qua mô hình 2D/3D của bố trí đồng trên bo mạch, cho phép nhanh chóng đánh giá kết quả và thực hiện các thử nghiệm thăm dò “điều gì sẽ xảy ra nếu” đối với thiết kế bố trí PCB.

Truy cập chức năng Power Analyzer by Keysight

Để truy cập chức năng Power Analyzer by Keysight trong Altium Designer, phải cài đặt tiện ích mở rộng phần mềm Power Analyzer by Keysight . Bạn có thể cài đặt hoặc gỡ bỏ tiện ích mở rộng này theo cách thủ công.

Để biết thêm thông tin về cách quản lý tiện ích mở rộng, hãy tham khảo trang Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Khi bạn nhấp để tải xuống và cài đặt tiện ích mở rộng,  End-User License Agreement sẽ mở ra (). Nhấp vào Accept đồng nghĩa với việc bạn chấp nhận các điều khoản và điều kiện của EULA; khi đó, quá trình cài đặt sẽ tiếp tục. Nhấp vào Close đồng nghĩa với việc bạn không chấp nhận các điều khoản và điều kiện của EULA, và quá trình cài đặt sẽ dừng lại.

Khi tiện ích mở rộng phần mềm Power Analyzer by Keysight được cài đặt, bạn có thể:

 
 
 
 
 
  • thêm tài liệu Phân tích nguồn mới hoặc mở tài liệu hiện có; 

  • Button, Manage Power Nets cấu hình Power Analyzer và các net nguồn; 

  • Button, Show Power Net in Tree kiểm tra cấu trúc cây của các net;

  • Button, Show the Power Net Analysis on the PCB kiểm tra mọi kết quả phân tích nguồn hiện có;

  • Button, View the Power Net Analysis results as a Report xem các báo cáo hiện có và tạo báo cáo mới từ các kết quả phân tích nguồn hiện có.

Tuy nhiên, để thực hiện một phân tích nguồn mới, bạn cần có gói đăng ký Power Analyzer by Keysight còn hiệu lực. Nếu không, khi bạn thử bắt đầu phân tích nguồn, hộp thoại Analyze Your Power Nets sẽ mở ra để bạn yêu cầu dùng thử miễn phí ().

Khởi chạy Power Analyzer

Để bắt đầu làm việc với Power Analyzer, hãy mở tài liệu PCB của dự án hoặc một trong các sơ đồ nguyên lý của dự án, rồi chọn Tools » Power Analyzer by Keysight từ các menu chính.

Tài liệu Power Analyzer Keysight (<ProjectName>.pdnaK) sẽ mở ra và được thêm vào vùng Source Documents của dự án (trong bảng Projects), như minh họa bên dưới.

Không thấy lệnh Power Analyzer by Keysight trong menu? Hãy kiểm tra xem tiện ích mở rộng đã được cài đặt và bạn đã có gói đăng ký cho tiện ích đó hay chưa (tìm hiểu thêm).

Có thể khởi chạy Power Analyzer từ menu của trình chỉnh sửa sơ đồ nguyên lý hoặc trình chỉnh sửa PCB. Tuy nhiên, vì Power Analyzer mô phỏng các cấu trúc PCB nên mọi thay đổi thiết kế trên sơ đồ nguyên lý phải được đồng bộ sang PCB thì tài liệu phân tích mới có thể phát hiện được (*.pdnaK). Nếu một thay đổi thiết kế chưa được phát hiện, hãy lưu, đóng rồi mở lại tài liệu phân tích.

Chuẩn bị phân tích

Bạn đã sẵn sàng phân tích, nhưng khi nhấp vào nút Analyze, một hộp thoại mở ra mời dùng thử? Hãy kiểm tra xem tiện ích mở rộng đã được cài đặt và bạn đã có gói đăng ký sử dụng tiện ích này hay chưa (tìm hiểu thêm).

Power Analyzer cần biết các đặc tính vật lý của bo mạch. Những đặc tính này bao gồm mật độ dòng điện tối đa cho các lớp bề mặt/lớp trong, đường kính via tối thiểu và tối đa, loại đồng, nhiệt độ làm việc và các thông số khác. Các đặc tính này được xác định trong vùng Configuration của tài liệu phân tích.

Các tùy chọn cấu hình

  • Các giá trị mật độ dòng điện tối đa và dòng điện qua via tối đa giống nhau cho mọi net vì chúng phụ thuộc vào hình học của đồng.

  • Các thiết lập Max Current Density for Surface / Internal Layers quy định giá trị cho phép đối với các lớp tương ứng của PCB.

  • Dòng điện tối đa qua via được quy định cho kích thước lỗ tối thiểu và tối đa được sử dụng trong dự án. Các giá trị đường kính lỗ được xác định trong các trường Min Via Diameter và Max Via Diameter, cùng với Max Current được phép đối với kích thước lỗ đó.

  • Phần mềm chia bố cục PCB thành các lưới trong quá trình mô phỏng. Theo mặc định, kích thước lưới động được sử dụng. Bằng cách bật hộp kiểm Simulation Mesh Size, bạn có thể xác định kích thước lưới cần thiết.

  • Thiết lập mặc định là loại trừ net Ground khỏi kết quả bản đồ nhiệt. Để đưa net Ground vào, hãy bỏ chọn hộp kiểm Skip Ground, sau đó chọn net GND trong danh sách thả xuống Network / Net ở đầu bảng Power Analysis by Keysight để xem kết quả bản đồ nhiệt. Lưu ý rằng bản đồ nhiệt hỗ trợ các cấu trúc polygon trên lớp tín hiệu, nhưng không thể mô phỏng hoạt động của lớp mặt phẳng nguồn.

  • Trường Copper Type quy định loại đồng được sử dụng, cùng với các thông số liên quan và các thông số nhiệt độ. 

  • Work Temperature được dùng để xác định điện trở suất của các dây dẫn, còn Temperature Compensation là một đặc tính của chính vật liệu liên quan đến khả năng dẫn nhiệt. Các vật liệu khác nhau có hệ số dẫn nhiệt khác nhau và do đó sẽ ảnh hưởng đến sự phát nóng của vật liệu tùy theo tải. Sự phát nóng này sẽ ảnh hưởng đến điện trở bên trong của vật liệu, từ đó ảnh hưởng đến độ sụt áp.

  • Via Plating Thickness hiển thị trong vùng Global PCB Parameters được xác định trong bảng Properties của Layer Stack Manager – tìm hiểu thêm.

Thay đổi các giá trị mặc định này nếu cần để phù hợp với thiết kế của bạn.

Ngoài mật độ dòng điện tối đa và dòng điện qua via tối đa, cần quy định giá trị sụt áp cho phép cho từng net nguồn đã xác định. Cấu hình DC Drop Limit cho từng net bằng cách chọn một tỷ lệ phần trăm định sẵn hoặc nhập giá trị Custom.

Power Analyzer sử dụng Auto-Define Settings khi cố gắng tự động xác định các net nguồn trong thiết kế của bạn. Để thực hiện việc này, công cụ cần biết cách nhận diện các phần tử mạch như bộ ổn áp, đầu nối và linh kiện mắc nối tiếp. Ngoài việc sử dụng các dấu hiệu như tiền tố ký hiệu linh kiện, bạn cũng có thể thêm tham số cho một số linh kiện để cải thiện quá trình phát hiện tự động. Để biết thêm thông tin, hãy tham khảo mục Yêu cầu nhận diện tự động.

Thêm net nguồn để mô phỏng

Để thêm net nguồn cho mô phỏng, nhấp vào nút  ở phía trên bên trái để mở hộp thoại Manage Nets. Chọn hộp kiểm cho Power Net Name cần thiết và cấu hình Reference Net tương ứng. Nếu một net không có đối tượng cổng nguồn trong thiết kế sơ đồ nguyên lý, net đó sẽ không xuất hiện trong danh sách Power Net Name. Nhấp vào Show Custom Nets để đưa tất cả các net trong thiết kế vào danh sách. Có thể bật nhiều net nguồn nếu cần. Quan hệ phân cấp giữa các net nguồn được tự động xác định sau khi net nguồn được cấu hình đầy đủ.

Mỗi net nguồn cần một nguồn cấp điện; các nguồn này sẽ được cấu hình tiếp theo.

Bạn cũng có thể nhấp vào nút  để phần mềm tạo các net nguồn cho bạn. Phần mềm sẽ cố gắng thực hiện việc này bằng cách tự động nhận diện cấu trúc liên kết của dự án, dựa trên các thiết lập hiện tại trong vùng Auto-Define Settings thuộc mục Configuration trong tài liệu phân tích (*.pdnaK).

Thêm nguồn cấp điện

Để thêm nguồn cấp điện, nhấp vào + (hoặc điều khiển Quản lý đi kèm) trong mục Sources của mạch nguồn mong muốn. Nếu mạch có nhiều nguồn cấp điện, nhấp vào Quản lý và chọn các linh kiện còn lại.

Để một linh kiện có thể được chọn làm nguồn, linh kiện đó phải kết nối với Power Net đã chọn, nhưng có thể kết nối với Reference Net đã chọn thông qua bất kỳ linh kiện nào được kết nối với Reference Net đó.

Thẻ linh kiện

Mỗi linh kiện được đưa vào dưới dạng Nguồn hoặc Tải được biểu diễn trong tài liệu Power Analyzer bằng một Component Card.

  • Di chuột lên Thẻ linh kiện để hiển thị các nút Edit và Delete.
  • Nhấp đúp vào Thẻ linh kiện để mở hộp thoại Properties cho linh kiện đó.
  • Nhấp vào giá trị ID phần tử thiết kế để định vị chéo đến linh kiện đó trên sơ đồ nguyên lý. Mức thu phóng khi định vị chéo được xác định trong mục Highlight Methods trên trang System - Navigation của hộp thoại Preferences.
  • Chỉnh sửa giá trị phân tích chính của linh kiện đó trực tiếp trong Thẻ (hoặc Chỉnh sửa linh kiện để truy cập tất cả các thuộc tính).

Mở rộng net

Các net nguồn trên bo mạch có thể đi qua các phần tử thụ động, chẳng hạn như cầu chì hoặc điện trở, với một net khác ở phía bên kia của linh kiện đó. Trong trường hợp này, nên extend the net bằng cách đưa linh kiện trung gian và net thứ hai của nó vào làm một phần của net chính. Chức năng Extend Nets được sử dụng cho mục đích này.

Để mở rộng một net, nhấp vào biểu tượng +Mở rộng net bên cạnh tên net để mở hộp thoại <PowerNet> Extensions Manager. Nhấp vào + để mở rộng net mục tiêu. Power Analyzer chỉ hiển thị các net có thể kết nối thông qua một linh kiện mở rộng duy nhất. Sau khi bạn Add net, một linh kiện liên quan sẽ tự động được thêm vào hộp thoại <PowerNet> Extensions Manager và có thể thay đổi nếu muốn.

Các net nguồn có thể được mở rộng thông qua một linh kiện mắc nối tiếp.Các net nguồn có thể được mở rộng thông qua một linh kiện mắc nối tiếp.

Sau đó, bạn có thể tiếp tục mở rộng net bằng cách nhấp vào biểu tượng + như minh họa trong hình bên dưới. Khi hoàn tất, nhấp vào Lưu trong hộp thoại <PowerNet> Extensions Manager.

Tiếp tục thêm các linh kiện mắc nối tiếp và các net.Tiếp tục thêm các linh kiện mắc nối tiếp và các net.

Lưu ý khi mở rộng net

  • Với mỗi linh kiện mắc nối tiếp, bạn có thể thiết lập độ sụt áp, điện trở và dòng điện tối đa cho phép; các thông số này sẽ được tính đến trong quá trình phân tích (xem hình).

  • Nếu bạn xác định sai net, bạn có thể xóa net đó bằng cách di chuột lên tên net và nhấp vào biểu tượng xóa xuất hiện.

  • Sau khi lưu net đã mở rộng, các linh kiện kết nối với các net mở rộng sẽ xuất hiện trong danh sách tải để bạn có thể thêm chúng.

  • Bên cạnh tên net nguồn, bạn có thể thấy số phần mở rộng đã được thêm. Di con trỏ lên con số đó để hiển thị tên các net mở rộng (như minh họa trong hình trên).

  • Khả năng hỗ trợ mô phỏng các linh kiện mắc song song trong net mở rộng được bổ sung trong tiện ích mở rộng PABK V1.0.6, còn khả năng hỗ trợ trên giao diện người dùng được bổ sung trong tiện ích mở rộng PABK V1.0.9. Để xác định các linh kiện mắc song song, chọn net trong hộp thoại bật lên Extensions Manager, sau đó bật tất cả các linh kiện mắc song song như minh họa trong hình bên dưới. Di chuột lên hình để xem hộp thoại sau khi hoàn tất việc mở rộng net.

    Chọn tất cả các linh kiện mắc song song trong net.Chọn tất cả các linh kiện mắc song song trong net.

Chỉ định tải

Để thêm một linh kiện tải, nhấp vào + (hoặc nút điều khiển Quản lý tương ứng) trong phần Loads rồi chọn linh kiện mong muốn. Một linh kiện sẽ được liệt kê trong hộp thoại khi được kết nối với net chính hoặc net mở rộng.

Sau khi thêm linh kiện, bạn có thể chỉ định mức tiêu thụ của linh kiện ngay trên Thẻ linh kiện hoặc nhấp vào nút  để mở hộp thoại <NetName>/<LoadName> Load Properties.

Lưu ý khi cấu hình tải

  • Xác định các thuộc tính của tải, bao gồm Load Type, Total Load Current, cùng với Min và Max Voltage.
  • Xác nhận rằng net cấp nguồn IN cũng như các tùy chọn Reference và Connected to reference through được cấu hình đúng.
  • Dòng điện tải được tự động chia đều cho tất cả các chân nguồn đã xác định; hãy điều chỉnh các giá trị này nếu cần.
  • Khi cấu hình tải thuộc loại IC (Current), bạn có thể xem tất cả các chân của linh kiện tải kết nối với nguồn thông qua các linh kiện mắc nối tiếp khác nhau và chọn các chân cần thiết.

Khi hộp thoại Manage Loads (hoặc Add Sources) đang mở, hộp thoại sẽ có cột Design Item Id. Nhấp vào một mục trong cột này để định vị chéo linh kiện tương ứng trên sơ đồ nguyên lý, giúp bạn dễ dàng xác minh rằng mình đang chọn đúng linh kiện.

Mức thu phóng khi định vị chéo được xác định trong phần Highlight Methods trên trang System - Navigation của hộp thoại Preferences.

Chỉ định VRM

Để xác định một linh kiện mô-đun ổn áp (VRM), trước tiên hãy thêm linh kiện đó làm tải. Sau đó mở hộp thoại Load Properties của linh kiện (nhấp vào nút  ) để cấu hình.

Sau khi một tải được cấu hình làm VRM, tải đó cũng sẽ xuất hiện dưới dạng nguồn cho net nguồn được chỉ định là net OUT của nó.Sau khi một tải được cấu hình làm VRM, tải đó cũng sẽ xuất hiện dưới dạng nguồn cho net nguồn được chỉ định là net OUT của nó.

Lưu ý khi cấu hình VRM

  • Chỉ định Load Type là VRM thuộc loại mong muốn.
  • Chỉ định điện áp đầu ra trong trường Vout, cùng với các thuộc tính khác của bộ ổn áp.
  • Cấu hình các net IN và OUT trong vùng Nets Management của hộp thoại.
  • Nếu VRM không kết nối trực tiếp với net tham chiếu hoặc sử dụng tham chiếu khác, hãy cấu hình các tùy chọn Reference và Connected to reference through theo yêu cầu.
  • Một mạng nguồn con sẽ tự động được tạo trong hệ thống phân cấp với VRM đó làm nguồn (như minh họa ở trên).
  • Nếu VRM có nhiều net đầu ra, hãy thêm tất cả các net cần thiết bằng liên kết +Thêm net đầu ra trong hộp thoại Load Properties, rồi chỉ định dòng điện đầu ra của chúng trong các trường tương ứng xuất hiện.

Net nguồn đã cấu hình

Mỗi net nguồn đã cấu hình được hiển thị dưới dạng một mục định nghĩa riêng có thể thu gọn trong tài liệu *.pdnaK. Net PWR_IN đã cấu hình được hiển thị bên dưới cùng với hai net nguồn con, 3V3 và 1V8, được thụt vào một chút để biểu thị trạng thái net con.

Tìm hiểu mục định nghĩa net nguồn

  • Mỗi net nguồn được hiển thị dưới dạng một Power Net Definition riêng có thể thu gọn.
  • Thanh tiêu đề của mục Định nghĩa net nguồn bao gồm:
    • Tên net nguồn 
    • Net tham chiếu 
    • Chỉ báo số lượng net bổ sung (), nếu net đã được mở rộng. Di chuột lên để hiển thị tên của các net con.
    • Nút  ; nhấp vào để hiển thị cấu trúc kết nối của các linh kiện trong net này trong ngữ cảnh toàn bộ hệ thống phân cấp net nguồn.
    • Nút  ; nhấp vào để loại net này cùng với tất cả các net con khỏi quá trình phân tích.
    • Nút  ; nhấp vào để phân tích net này cùng với mọi net con.
  • Mỗi linh kiện trong net được biểu diễn bằng một Thẻ linh kiện.
  • Sau khi net được phân tích, các kết quả Voltage Drop, Current Density và Max Via Current của net đó được hiển thị trong mục Định nghĩa net nguồn, như minh họa trong hình trên.
    • Mỗi đồng hồ hiển thị giá trị mô phỏng so với giới hạn đã chỉ định. Nếu giá trị nằm hoàn toàn trong giới hạn, vạch thang đo có màu xanh lá. Nếu giá trị gần giới hạn, vạch có màu vàng; nếu vượt quá giới hạn, vạch có màu đỏ. 
    • Nhấp vào nút  để chuyển sang trình biên tập PCB và hiển thị phần đồng thuộc net này trên PCB. Trong trình biên tập PCB, sử dụng bảng Power Analyzer by Keysight để điều khiển quá trình phân tích.
    • Nhấp vào nút  để tạo và mở báo cáo chi tiết về net nguồn đó. Trong báo cáo, sử dụng  để lưu một bản sao HTML.

Chế độ xem dạng cây của các net nguồn

Chuyển sang xem net nguồn đã cấu hình (và mọi net con được xác định thông qua VRM) theo dạng cây bằng cách nhấp vào nút  tương ứng. Toàn bộ cấu trúc sẽ được hiển thị, trong đó net nguồn cụ thể và các linh kiện liên quan được tô sáng tương ứng.

Chế độ xem dạng cây giúp bạn nhanh chóng đánh giá xem toàn bộ mạng nguồn đã được xác định đúng yêu cầu và sẵn sàng để phân tích hay chưa. Để quay lại cửa sổ chính, hãy nhấp vào liên kết Power Analyzer by Keysight ở góc trên bên trái của tài liệu .pdnaK.

Chạy phân tích

Sau khi hoàn tất cấu hình, bạn có thể chạy phân tích cho một net cụ thể bằng cách nhấp vào nút  tương ứng. Phần tóm tắt kết quả phân tích được trình bày trong phần định nghĩa net nguồn, như minh họa bên dưới. Để xem kết quả trên PCB, hãy nhấp vào nút  tương ứng.

Để phân tích tất cả các net đã cấu hình chỉ bằng một thao tác, hãy nhấp vào nút  (ở góc trên bên phải của tài liệu phân tích). Nếu bạn chọn phân tích net nguồn cấp cao nhất trong cấu trúc cây, tất cả các net con (được tạo thông qua các linh kiện VRM) cũng sẽ được phân tích. Nếu tất cả các net đã được phân tích, bạn có thể chọn net hiện được tô sáng bằng danh sách thả xuống Network/Net ở đầu bảng Power Analyzer by Keysight. 

Quản lý lớp

Bạn có thể chuyển đổi giữa các lớp của mô phỏng theo cách tương tự như khi làm việc với PCB — thông qua các thẻ lớp ở cuối cửa sổ trình chỉnh sửa PCB. Bạn cũng có thể tập trung vào lớp hiện tại bằng phím tắt Shift+S; sử dụng phím tắt này để chuyển lần lượt qua các tùy chọn hiển thị của chế độ một lớp.

Sử dụng các thẻ lớp PCB để nhanh chóng chuyển đổi cách hiển thị kết quả phân tích. Hình ở đây hiển thị kết quả cho lớp trên cùng. Di con trỏ lên hình ảnh để xem kết quả cho lớp dưới cùng.Sử dụng các thẻ lớp PCB để nhanh chóng chuyển đổi cách hiển thị kết quả phân tích. Hình ở đây hiển thị kết quả cho lớp trên cùng. Di con trỏ lên hình ảnh để xem kết quả cho lớp dưới cùng.

Bảng Power Analyzer by Keysight

Trong trình chỉnh sửa PCB, quá trình phân tích và kết quả được điều khiển thông qua bảng Power Analyzer by Keysight. Lưu ý rằng bảng này được thêm vào danh sách các bảng có sẵn (thông qua nút Panels) sau khi đã thực hiện phân tích nguồn và nhấp vào nút  .  

Mạng / Net

  • Network / Net - dùng để chọn mạng () hoặc net () mà bạn muốn hiển thị dưới dạng bản đồ nhiệt trong không gian làm việc đồ họa.
  • Only nets with violations - khi tùy chọn này được bật (mặc định), chỉ những net hiện có vi phạm mới xuất hiện trong danh sách thả xuống. Bỏ chọn tùy chọn này để liệt kê tất cả các net nguồn. 
  • Sử dụng các thao tác tiêu chuẩn của trình chỉnh sửa PCB để dịch chuyển và thu phóng trong không gian làm việc nhằm kiểm tra kết quả mô phỏng.

Bên dưới bộ chọn Network / Net, bảng có hai thẻ là General và Heatmap. Các tùy chọn trong những thẻ này áp dụng cho net hiện được chọn trong danh sách thả xuống Network / Net.

Chọn net cần hiển thị, sau đó cấu hình các tùy chọn chung hoặc bản đồ nhiệt cho net đó.Chọn net cần hiển thị, sau đó cấu hình các tùy chọn chung hoặc bản đồ nhiệt cho net đó.

Bản đồ nhiệt

Thẻ Heatmap trên bảng Power Analyzer by Keysight được dùng để kiểm soát dữ liệu hiển thị dưới dạng bản đồ nhiệt — mật độ dòng điện hoặc độ sụt áp — cũng như cách áp dụng màu sắc cho mật độ dòng điện hoặc độ sụt áp.

Sử dụng thẻ Heatmap  của bảng Power Analyzer by Keysight để thay đổi kết quả mô phỏng được hiển thị trên PCB. Ở đây, kết quả mật độ dòng điện đang được hiển thị. Di con trỏ lên hình ảnh để xem kết quả độ sụt áp.Sử dụng thẻ Heatmap của bảng Power Analyzer by Keysight để thay đổi kết quả mô phỏng được hiển thị trên PCB. Ở đây, kết quả mật độ dòng điện đang được hiển thị. Di con trỏ lên hình ảnh để xem kết quả độ sụt áp.

Các tùy chọn cho từng chế độ này được mô tả bên dưới.

Bản đồ nhiệt cho mật độ dòng điện
  • Toàn bộ net được tô màu để phản ánh mật độ dòng điện tại mọi vị trí dọc theo net; mật độ dòng điện càng cao thì màu càng nóng (càng đỏ). 
  • Show Heatmap - sử dụng điều khiển này để nhanh chóng tắt bản đồ nhiệt và khôi phục cách hiển thị tiêu chuẩn của PCB. 
  • Show Arrows of Current Direction - bật tùy chọn này để hiển thị các mũi tên nhỏ chỉ hướng dòng điện trên toàn bộ net.
  • Use Noise Suppression - Khi dòng điện tính toán tiến gần về 0, các mũi tên chỉ hướng dòng điện tạo cảm giác rằng có dòng điện chạy trong khu vực đó, trong khi về cơ bản là không có. Bật tùy chọn này để loại bỏ các giá trị dòng điện nhỏ có khả năng gây hiểu nhầm này.
  • Scope Controller - cách áp dụng màu sắc cho net để hiển thị cường độ, hay mức nhiệt, được điều khiển bởi Scope Controller. Giá trị Max mặc định là mật độ dòng điện tính toán lớn nhất trong net đó (xem hình ảnh), còn Min mặc định là 0 A/mm2. Thang này được hiển thị dưới dạng một thanh màu bên dưới PCB, thể hiện: các thiết lập Min và Max hiện tại, thang chia được xác định bởi kiểu thang đã chọn và đơn vị. Có thể điều chỉnh các giá trị Min và Max bằng cách nhấp và kéo thanh trượt, hoặc nhập giá trị mới vào trường Min hoặc Max. Các giá trị tính toán nhỏ hơn Min được hiển thị bằng màu xanh lam, còn các giá trị lớn hơn Max được hiển thị bằng màu đỏ. 
  • Use Logarithmic Scale - bật tùy chọn này để chuyển thang từ tuyến tính sang logarit. Thang logarit có tác dụng tập trung các giá trị cao hơn về phía đầu hot của thang màu. Ví dụ, bạn có thể bật thang logarit để nhanh chóng xác định các đoạn đường mạch mang dòng điện lớn hơn, sau đó chuyển sang thang tuyến tính để kiểm tra sự phân bố mật độ dòng điện trong đoạn đường mạch đó.

Bản đồ nhiệt mật độ dòng điện theo thang logarit cho thấy một khu vực cần chú ý; di con trỏ lên hình ảnh để xem khu vực đó được hiển thị theo thang tuyến tính.Bản đồ nhiệt mật độ dòng điện theo thang logarit cho thấy một khu vực cần chú ý; di con trỏ lên hình ảnh để xem khu vực đó được hiển thị theo thang tuyến tính.

Bản đồ nhiệt cho độ sụt áp
  • Toàn bộ net được tô màu để thể hiện độ sụt áp tại mọi vị trí dọc theo net; điện áp càng cao thì màu càng nóng (càng đỏ). Với cách biểu diễn này, màu càng lạnh thì điện áp càng thấp (và độ sụt áp càng lớn). 
  • Show Heatmap - sử dụng tùy chọn này để nhanh chóng xóa bản đồ nhiệt và khôi phục chế độ hiển thị tiêu chuẩn của PCB. 
  • Show Arrows of Current Direction - bật để hiển thị các mũi tên nhỏ chỉ hướng dòng điện trên toàn bộ net.
  • Use Noise Suppression - Khi dòng điện tính toán tiến gần đến không, các mũi tên chỉ hướng dòng điện tạo cảm giác rằng vẫn có dòng điện chạy trong khu vực đó, dù thực tế hầu như không có. Bật tùy chọn này để loại trừ các giá trị dòng điện nhỏ có thể gây hiểu nhầm này.
  • Scope Controller - cách áp dụng màu cho net để thể hiện cường độ, hay mức nhiệt, được điều khiển bằng Scope Controller. Giá trị Max mặc định thấp hơn một chút so với điện áp tối đa được chỉ định cho net đó, còn giá trị Min là Max - calculated voltage drop (xem hình ảnh). Thang đo này được hiển thị dưới dạng một thanh màu bên dưới PCB, thể hiện: độ sụt áp dưới dạng giá trị tuyệt đối hoặc phần trăm, các thiết lập Min và Max hiện tại, cùng đơn vị đo. Có thể điều chỉnh các giá trị Min và Max bằng cách nhấp và kéo các nút trượt, hoặc nhập giá trị mới vào các trường Min hoặc Max. Các giá trị tính toán nhỏ hơn Min được hiển thị bằng màu xanh lam, còn các giá trị lớn hơn Max được hiển thị bằng màu đỏ. 
  • Scale Type - thang đo độ sụt áp có thể được biểu thị bằng vôn (nhấp nút  ) hoặc dưới dạng phần trăm (nhấp nút  ).
  • Enable Visual Slider for Voltage Contour - khi bật, hiển thị các vị trí trên bản đồ nhiệt có điện áp bằng với các điểm đường đồng mức điện áp đã chỉ định, giúp bạn dễ dàng xác định những vị trí đó. Có thể điều chỉnh giá trị của các điểm đường đồng mức bằng cách kéo thanh trượt hoặc nhập giá trị vào các trường Voltage Contour Points bên dưới. Có thể thêm điểm mới và xóa điểm hiện có bằng cách nhấp vào biểu tượng tương ứng.

Có thể cấu hình các điểm đường đồng mức để nhanh chóng xác định những vị trí trên bo mạch có điện áp bằng giá trị đó.Có thể cấu hình các điểm đường đồng mức để nhanh chóng xác định những vị trí trên bo mạch có điện áp bằng giá trị đó.

Phát hiện vi phạm

Nếu mô phỏng phát hiện vi phạm: Voltage Drop, Current Density hoặc Max Via Current, các vi phạm đó sẽ được liệt kê trong phần Violations của bảng Power Analyzer by Keysight. Nhấp vào một vi phạm trong bảng để định vị chéo đến vị trí cụ thể trên PCB nơi lỗi đó xảy ra. Nếu không đọc được toàn bộ mô tả vi phạm, hãy di con trỏ lên phần Mô tả của vi phạm để hiển thị chú giải công cụ với đầy đủ thông tin chi tiết.

Các vi phạm được tự động liệt kê chi tiết trong phần Violations của bảng Power Analyzer by Keysight. Di con trỏ lên hình ảnh để xem vi phạm dòng điện qua via.Các vi phạm được tự động liệt kê chi tiết trong phần Violations của bảng Power Analyzer by Keysight. Di con trỏ lên hình ảnh để xem vi phạm dòng điện qua via.

Lưu ý rằng chế độ bản đồ nhiệt (Mật độ dòng điện hoặc Độ sụt áp) được tự động chọn dựa trên loại vi phạm mà bạn nhấp vào. 

Đầu dò

Phần Đầu dò của bảng Power Analyzer by Keysight được dùng để đặt các đầu dò đo lường trực tiếp trên PCB. Đầu dò có thể đo Mật độ dòng điện hoặc Độ sụt áp; loại phép đo được xác định theo chế độ bản đồ nhiệt hiện tại của bo mạch.

Đầu dò có thể là:

  1. Đầu dò đơn, dùng để đo giá trị tuyệt đối tại vị trí đặt đầu dò, hoặc
  2. Đầu dò chênh lệch, dùng để đo độ chênh lệch giữa hai vị trí đặt đầu dò. 

Cả hai loại đầu dò đều được đặt bằng cách nhấp vào nút  trong vùng Probes của bảng. Để đặt Đầu dò đơn, nhấp vào vị trí mong muốn rồi nhấp chuột phải (hoặc nhấn Esc). Để đặt Đầu dò chênh lệch, nhấp một lần để xác định vị trí đầu dò thứ nhất, sau đó nhấp lần thứ hai để xác định vị trí đầu dò thứ hai. Sau khi xác định đầu dò, kết quả đo sẽ được hiển thị trong bảng.

Khi đặt đầu dò, các tính năng bắt dính được áp dụng tương tự như khi đặt các đối tượng thiết kế khác trong trình biên tập PCB. Để biết thêm thông tin về hệ thống bắt dính con trỏ hợp nhất, hãy tham khảo trang Làm việc với hệ thống bắt dính con trỏ.

Nhấp nút  để tạo ảnh PCB tại vị trí đầu dò được nhấp gần nhất. Ảnh sẽ hiển thị trong vùng Image Captures của bảng, được đánh dấu bằng nhãn Probe. Di con trỏ lên ảnh chụp để hiển thị thông tin chi tiết của đầu dò (xem hình ảnh). 

Đầu dò có thể đo điện áp hoặc dòng điện dưới dạng giá trị tuyệt đối hoặc độ chênh lệch giữa hai vị trí. Di con trỏ lên hình ảnh để xem đầu dò dòng điện.Đầu dò có thể đo điện áp hoặc dòng điện dưới dạng giá trị tuyệt đối hoặc độ chênh lệch giữa hai vị trí. Di con trỏ lên hình ảnh để xem đầu dò dòng điện.

Nếu thiết kế có bất kỳ thay đổi nào, bạn phải xóa các đầu dò hiện có () và đặt các đầu dò mới.

Ảnh chụp

Chức năng chụp ảnh trong bảng Power Analyzer by Keysight có thể được dùng để chụp ảnh net đã chọn trong thiết kế, sau đó đưa ảnh vào báo cáo.

Để chụp một khu vực cụ thể của bo mạch, trước tiên hãy điều chỉnh khung nhìn bo mạch trong không gian thiết kế chính sao cho các thành phần bạn muốn chụp đều hiển thị. Khi đã sẵn sàng, nhấp nút   trong vùng Image Captures của bảng để chụp ảnh. Bạn có thể tiếp tục thay đổi khung nhìn bo mạch và Add thêm ảnh. Để xóa ảnh, di con trỏ lên ảnh để hiển thị nút  , sau đó nhấp một lần để xóa.

Ảnh chụp không được lưu cùng dự án. Để lưu ảnh, hãy tạo Báo cáo phân tích.

Báo cáo phân tích

Để tạo báo cáo phân tích đầy đủ, nhấp nút  ở đầu tài liệu phân tích. Báo cáo đầy đủ có một phần dành cho từng net nguồn trong mạng, như minh họa trong hình bên dưới. 

Trong báo cáo, nhấp vào một net nguồn để xem báo cáo chi tiết về net đó, bao gồm:

  • Các thiết lập cấu hình chung
  • Cấu trúc xếp lớp của bo mạch
  • Bản đồ nhiệt Mật độ dòng điện cho từng lớp tín hiệu
  • Bản đồ nhiệt Độ sụt áp cho từng lớp tín hiệu
  • Chế độ xem dạng cây của mạng nguồn, trong đó net đã chọn được tô sáng.
  • Chi tiết phân tích cho net đã chọn, bao gồm: Công suất tiêu thụ; chi tiết về biên dự phòng và kết quả Đạt/Không đạt; bản tóm tắt chi tiết về hiệu năng của tất cả các via trong net đó; tất cả ảnh chụp màn hình do người dùng tạo.

  • Nhấp nút  để lưu báo cáo ở định dạng HTML. Sử dụng hộp thoại Save Report Settings xuất hiện sau đó để cấu hình các mạng và dữ liệu cụ thể cần đưa vào báo cáo.
  • Báo cáo được lưu trong một thư mục con thuộc thư mục dự án, có tên là \PowerAnalyzerByKeysight_Output\HTMLReport\<ProjectName> [PDNA]_<CurrentDate>_<CurrentTime>.
  • Tất cả hình ảnh trong báo cáo được lưu trong thư mục con \Images.
  • Một số tệp nhật ký cũng được tạo trong quá trình phân tích và được lưu trong một thư mục con thuộc thư mục dự án, có tên là \PowerAnalyzerByKeysight_Output\<BoardName>\.

Yêu cầu đối với nhận diện tự động

Ngoài việc thêm thủ công các net nguồn, Power Analyzer by Keysight còn có khả năng tự động nhận diện và thêm các net nguồn, bao gồm cả nguồn cấp và tải, giúp giảm thời gian xác định cấu trúc hệ thống nguồn.

Cài đặt xác định tự động

Trước khi bắt đầu nhận diện tự động, bạn phải cấu hình các tham số của thuật toán cho phù hợp với dự án. Các tham số này được cấu hình trong mục Auto-Define Settings thuộc phần Configuration của cửa sổ tài liệu Power Analyzer by Keysight.

Các linh kiện không đáp ứng các tiêu chí xác định tự động này được xem là tải thông thường. Bạn cũng có thể thêm các tham số có tên vào từng linh kiện trên sơ đồ nguyên lý để xác định loại và đặc tính của linh kiện đó trong hệ thống nguồn. Các tham số này có thể được khai báo khi tạo linh kiện hoặc thêm vào sau trên sơ đồ nguyên lý.

Tham số cho linh kiện

Để được nhận diện chính xác, tất cả các linh kiện liên quan đến nguồn phải đáp ứng các tiêu chí sau:

  • Để tự động phát hiện linh kiện nguồn cấp, linh kiện phải có tham số tên là Component Type, với giá trị Source.

  • Nếu không tìm thấy tham số này, việc tìm kiếm sẽ dựa trên Default Connectors Designators, được xác định trong vùng Auto-Define Settings thuộc phần Configuration trong tài liệu bộ phân tích (*.pdnaK). Lưu ý rằng chỉ các đầu nối có kết nối nguồn mới được xác định, trừ khi chúng được tham chiếu như một phần của net mở rộng.
  • Các mô-đun điều chỉnh điện áp (VRM):
    • Bộ ổn áp tuyến tính phải có tham số tên là Component Type, với giá trị VRM.
    • Đối với bộ điều chỉnh VRM loại SMPS, tham số Component Type phải có giá trị SMPS.
    • Nếu VRM có chức năng cảm nhận điện áp (Sense), tham số Component Type phải có giá trị Sense.

  • Nếu tham số không được xác định, việc tìm kiếm sẽ dựa trên VRM Keywords được xác định trong vùng Auto-Define Settings thuộc phần Configuration trong tài liệu bộ phân tích. Theo mặc định, các từ khóa này là: PWR, REG, Regulator, Voltage, Switch.

  • Giá trị tiêu thụ của linh kiện (tải) phải được xác định bằng tham số tên là Current Consumption. Hãy chú ý ký hiệu phân cách thập phân được dùng trong giá trị; ký hiệu này có thể là . hoặc , tùy theo cài đặt hệ thống.

Nếu linh kiện có tham số Current Consumption, giá trị được chỉ định sẽ được chia đều cho tất cả các chân nối với cùng một mạch.

Đồng bộ hóa tham số

Tất cả các tham số phải được đồng bộ giữa PCB và sơ đồ nguyên lý. Bạn có thể kiểm tra bằng cách chọn một linh kiện trên PCB và xác nhận rằng các tham số phân tích nguồn có trong tab Parameters của bảng Properties.

Đối với thiết kế

  • Tất cả các net nguồn phải được xác định:
    • bằng một đối tượng Power Port,
    • có thuộc tính Power Net được cấu hình để net bao gồm Supply Net Parameter (như mô tả bên dưới),
    • hoặc được đặt tên sao cho tên của chúng được Name Mask nhận diện (được xác định trong vùng Auto-Define Settings thuộc phần Configuration trong tài liệu bộ phân tích).
  • Để lấy giá trị điện áp bằng Name Mask, tên net nguồn phải tuân theo định dạng *V* hoặc *.*V, trong đó * là một giá trị số, như minh họa trong hình bên dưới.

  • Một cách khác để xác định giá trị điện áp cho net nguồn là cấu hình thuộc tính Power Net, được xác định trong bảng Properties cho bất kỳ dây dẫn nào trong net. Để bật thuộc tính này, trước tiên hãy đặt một chỉ thị Parameter Set (Place » Directives » Parameter Set) lên net (di con trỏ lên hình bên dưới để hiển thị hình minh họa quy trình này). Kích thước, màu sắc và nhãn do người dùng xác định; chính sự hiện diện của chỉ thị sẽ kích hoạt thuộc tính Power Net của net đó. Sau khi thêm chỉ thị, hãy chọn một dây dẫn trong net đó, bật thuộc tính Power Net và cấu hình Voltage của net, như minh họa bên dưới. 

  • Các linh kiện mắc nối tiếp phải tuân theo các ký hiệu định danh đã xác định cho điện trở, cuộn cảm và linh kiện nối tiếp tùy chỉnh (như được xác định trong vùng Auto-Define Settings thuộc phần Configuration trong tài liệu bộ phân tích).

  • VRM phải được kết nối với ít nhất hai net nguồn.

Các lệnh của Power Analyzer

Các lệnh sau có sẵn trong các menu chính của trình biên tập Power Analyzer.

Lệnh

Tóm tắt và cách sử dụng

Tools » Define Automatically

Thử tự động nhận diện cấu trúc liên kết của dự án dựa trên các cài đặt hiện tại trong vùng Auto-Define Settings thuộc phần Configuration trong tài liệu bộ phân tích (*.pdnaK). Bạn cũng có thể truy cập lệnh này bằng cách nhấp vào nút Define Automatically ở góc trên bên trái của trình biên tập.

File » Load from File

Tải tài liệu Power Analyzer by Keysight đã lưu (*.pdnaK) vào trình biên tập Power Analyzer.

Edit » Manage Nets

Mở hộp thoại Manage Nets, nơi bạn chọn các net nguồn cần phân tích. Đánh dấu chọn một net sẽ thêm net đó vào tài liệu bộ phân tích (*.pdnaK). Bỏ chọn một net sẽ xóa net đó (cùng với tất cả các net nguồn con) khỏi tài liệu. Bạn cũng có thể truy cập lệnh này bằng cách nhấp vào nút Manage Nets ở góc trên bên trái của trình biên tập. Tìm hiểu thêm về Quản lý net.

File » Save

Lưu cấu hình Power Analyzer hiện tại vào tài liệu Power Analyzer by Keysight (*.pdnaK)

File » Save As

Lưu cấu hình Power Analyzer hiện tại vào tài liệu Power Analyzer by Keysight (*.pdnaK) với tên mới do người dùng xác định.

Tools » Measurement Units » mil

Cấu hình Power Analyzer để sử dụng đơn vị đo hệ Anh (mil).

Tools » Measurement Units » mm

Cấu hình Power Analyzer để sử dụng đơn vị đo hệ mét (mm).

Các hạn chế của Power Analyzer

Hiện tại, Power Analyzer by Keysight không hỗ trợ:

  1. Điện áp âm.
  2. Linh kiện nhúng (linh kiện được đặt trên lớp bên trong). Tìm hiểu thêm về Thiết kế PCB có linh kiện nhúng.

 

AI-LocalizedBản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.
Contents
Tính khả dụng của tính năng

Các tính năng bạn có thể sử dụng phụ thuộc vào giải pháp Altium mà bạn đang có – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, hoặc Altium Designer (đang trong thời hạn hiệu lực).

Nếu bạn không thấy một tính năng được nêu trong tài liệu có trong phần mềm thực tế của mình, liên hệ Bộ phận Kinh doanh của Altium để tìm hiểu thêm.

Tài liệu cũ

Tài liệu Altium Designer không còn được phân phiên bản. Nếu bạn cần truy cập tài liệu cho các phiên bản cũ hơn của Altium Designer, hãy truy cập mục Tài liệu cũ trên trang Trình cài đặt khác.

Contents