Xác định sơ đồ đi dây

Các kết nối dây riêng lẻ bên trong bộ dây được xác định trong tài liệu sơ đồ đi dây bộ dây (*.WirDoc). Hãy thêm tài liệu này vào dự án bộ dây từ bảng Projects bằng cách nhấp chuột phải vào mục dự án rồi chọn Add New to Project » Harness Wiring Diagram trong menu ngữ cảnh (hoặc dùng lệnh File » New » Harness Wiring Diagram từ các menu chính).

Thiết lập tài liệu sơ đồ đi dây bộ dây

Các tùy chọn của tài liệu sơ đồ đi dây bộ dây có thể được cấu hình trong bảng Properties khi không có đối tượng nào được chọn trong vùng thiết kế của tài liệu. Các thiết lập chính gồm:

  • Trong vùng General của thẻ General trên bảng – chọn đơn vị đo áp dụng cho tài liệu và các phần tử đồ họa của nó, đồng thời thiết lập các lưới để giúp việc đặt đối tượng dễ dàng hơn. Altium Designer cung cấp ba loại lưới: lưới hiển thị để điều hướng, lưới bắt điểm để đặt đối tượng và khoảng cách bắt điểm để hỗ trợ tạo kết nối.

  • Trong vùng Page Options của thẻ General trên bảng – cấu hình kích thước trang tài liệu và khung tiêu đề, hoặc chọn từ các mẫu sơ đồ đi dây bộ dây hiện có.

Các thẻ General và Parameters của bảng Properties khi không có đối tượng nào được chọn trong tài liệu sơ đồ đi dây bộ dây 
Các thẻ GeneralParameters của bảng Properties khi không có đối tượng nào được chọn trong tài liệu sơ đồ đi dây bộ dây

  • Việc thiết lập tài liệu sơ đồ đi dây bộ dây tương tự như thiết lập tài liệu sơ đồ nguyên lý (*.SchDoc) của một dự án thiết kế PCB. Tham khảo trang Thiết lập tài liệu sơ đồ nguyên lý để tìm hiểu thêm.

  • Dùng danh sách thả xuống Length Units để chọn đơn vị chiều dài cho tài liệu. Các giá trị Strip LengthPull Off Length của các khoang socket sẽ được hiển thị bằng đơn vị đã chọn. Các đơn vị được hỗ trợ là mm, cm, m, inft. Đơn vị chiều dài mặc định của các tài liệu sơ đồ đi dây mới tạo có thể được xác định trên trang Harness Design – General của hộp thoại Preferences.

  • Để tìm hiểu thêm về cách tạo mẫu tài liệu đi dây bộ dây, hãy tham khảo trang Tạo tài liệu mẫu bộ dây.

  • Các thuộc tính mặc định của các đối tượng sơ đồ đi dây bộ dây có thể được cấu hình trên trang Harness Design – Defaults page của hộp thoại Preferences. Các thuộc tính này sẽ được áp dụng khi đặt các đối tượng tiếp theo.

  • Khi tạo tài liệu sơ đồ đi dây bộ dây, bạn cũng có thể sử dụng các đối tượng văn bản và đối tượng vẽ. Cách làm việc với các đối tượng này trong tài liệu sơ đồ đi dây bộ dây tương tự như trong tài liệu sơ đồ nguyên lý (*.SchDoc) của dự án thiết kế PCB. Tham khảo Làm việc với đối tượng văn bản trên sơ đồ nguyên lý và Làm việc với đối tượng vẽ trên sơ đồ nguyên lý để tìm hiểu thêm về các đối tượng này.

    • Lưu ý rằng liên kết hoạt động tới các đối tượng của sơ đồ đi dây bộ dây (ví dụ: dây và linh kiện) và các đối tượng bản vẽ bố trí bộ dây (ví dụ: bó dây và điểm kết nối) cũng được hỗ trợ trong khung văn bản và ghi chú. Nhấp vào một liên kết trong khung văn bản hoặc ghi chú đã đặt để dò chéo đến đối tượng đó trong tài liệu liên kết.

  • Để kiểm tra sơ đồ đi dây bộ dây của bạn về các vi phạm logic, điện và trình bày bản vẽ, hệ thống hỗ trợ một số phép kiểm tra vi phạm. Tham khảo trang Xác thực thiết kế bộ dây để tìm hiểu thêm.

  • Tài liệu sơ đồ đi dây bộ dây có thể được lưu ở định dạng ASCII, điều này có thể hữu ích khi chia sẻ. Sử dụng lệnh File » Save As và chọn Harness Wiring ascii (*.WirDoc) từ danh sách thả xuống Save as type trong hộp thoại Save As được mở ra. Khi lưu sơ đồ đi dây ASCII bằng lệnh File » Save, hộp thoại File Format sẽ mở ra để thông báo rằng định dạng ASCII đang được sử dụng. Chọn Phiên bản ASCII trong hộp thoại  để tiếp tục sử dụng định dạng này.

Đồng bộ hóa dự án Multi-board và dự án Harness

 
 
 
 
 

Khi dự án bộ dây là một phần của dự án thiết kế multi-board, sơ đồ đi dây bộ dây có thể được đồng bộ từ dữ liệu tài liệu sơ đồ nguyên lý multi-board (*.MbsDoc). Để thực hiện việc này, hãy chọn lệnh Design » Import Changes From <Multi-board Project> từ các menu chính.

Để tìm hiểu thêm về cách thêm dự án thiết kế bộ dây vào một dự án multi-board, hãy tham khảo trang Harness Design.

Nếu tài liệu sơ đồ nguyên lý multi-board chứa nhiều hơn một định nghĩa kết nối bộ dây, hộp thoại Select Harness Definition sẽ mở ra. Hãy chỉ định định nghĩa liên quan đến dự án bộ dây hiện tại.

Hộp thoại Select Harness Definition
Hộp thoại Select Harness Definition

Hộp thoại Engineering Change Order sau đó sẽ mở ra, hiển thị các linh kiện đầu nối bộ dây và các net bộ dây đã được định nghĩa trong sơ đồ nguyên lý multi-board, đây sẽ là cơ sở cho sơ đồ đi dây bộ dây.

Sử dụng hộp thoại Engineering Change Order để nhập dữ liệu từ dự án multi-board. 
Sử dụng hộp thoại Engineering Change Order để nhập dữ liệu từ dự án multi-board. 

Sau khi thực thi các thay đổi (), dữ liệu từ tài liệu sơ đồ nguyên lý multi-board sẽ được nhập vào sơ đồ đi dây bộ dây. Các linh kiện đầu nối, mỗi linh kiện được biểu diễn bằng ký hiệu sơ đồ nguyên lý của nó, sẽ xuất hiện trong tài liệu sơ đồ đi dây bộ dây, ban đầu ở các vị trí bất kỳ.

Ví dụ về sơ đồ đi dây bộ dây ngay sau khi nhập.
Ví dụ về sơ đồ đi dây bộ dây ngay sau khi nhập.

Các đường net sẽ được hiển thị giữa các chân để biểu diễn các kết nối logic được định nghĩa trong sơ đồ nguyên lý multi-board. Lưu ý rằng ở giai đoạn này, chưa có dây vật lý nào trong thiết kế.

Lưu ý rằng dữ liệu kết nối được nhập từ dự án multi-board vào dự án bộ dây phụ thuộc vào tên chân của các linh kiện đầu nối, vì vậy hãy đảm bảo rằng các tên duy nhất và chính xác được gán cho các chân linh kiện trong thư viện nguồn trước khi nhập dữ liệu.

Làm việc với linh kiện

Ngoài việc đồng bộ hóa từ tài liệu sơ đồ nguyên lý multi-board, các linh kiện cũng có thể được đặt thủ công vào sơ đồ đi dây bộ dây. Điều này cho phép đặt linh kiện trong một dự án bộ dây độc lập (không phải là một phần của dự án multi-board), đồng thời cũng cho phép đặt thêm các linh kiện trong một sơ đồ đi dây bộ dây là một phần của dự án multi-board.

Sử dụng bảng Components để đặt các ký hiệu của những linh kiện cần thiết. Quy trình đặt linh kiện tương tự như trong trình biên tập Schematic – tham khảo trang Tìm kiếm & đặt linh kiện để tìm hiểu thêm. Lưu ý rằng sẽ không có các đường net cho các linh kiện được thêm thủ công, vì không có thiết kế logic cấp cao hơn để điều khiển chúng.

  • Các linh kiện được đặt từ các thư viện sẵn có và được biểu diễn bằng các mô hình ký hiệu sơ đồ nguyên lý của chúng trên sơ đồ đi dây bộ dây. Tham khảo Xây dựng & duy trì linh kiện và thư viện của bạn để tìm hiểu thêm về cách tạo linh kiện.

  • Các linh kiện nhiều phần cũng có thể được đặt trong sơ đồ đi dây bộ dây. Khi dữ liệu thiết kế được nhập vào bản vẽ bố trí bộ dây, các định danh sẽ được gán chính xác cho các linh kiện trong bản vẽ bố trí bộ dây. Nếu nhiều phần của cùng một linh kiện được đặt trên sơ đồ đi dây bộ dây, chỉ một phiên bản của linh kiện đó được đặt trên bản vẽ bố trí bộ dây ().

  • Các đầu nối harness có thể được sử dụng để tạo kết nối giữa nhiều dự án multi-board trong cấu hình lồng nhau.

  • Khi dán các linh kiện harness đã cắt/sao chép lên sơ đồ đi dây bộ dây, các định danh của linh kiện đã dán sẽ tuân theo tùy chọn Reset Parts Designators On Paste từ trang Schematic – Graphical Editing page của hộp thoại Preferences. Khi các linh kiện được dán, phần số trong định danh của chúng sẽ được đặt lại thành ? khi tùy chọn này được bật.

Để di chuyển một linh kiện đã đặt (hoặc một linh kiện đang được đặt từ bảng Components) đến vị trí mong muốn, hãy nhấp và giữ nút chuột trái trên linh kiện đó rồi di chuyển chuột. Trong khi kéo, sử dụng Spacebar để xoay linh kiện 90 độ và các phím XY để lật theo chiều ngang và chiều dọc tương ứng.

Sơ đồ đi dây bộ dây sau khi di chuyển các linh kiện
Sơ đồ đi dây bộ dây sau khi di chuyển các linh kiện

Các thuộc tính của một linh kiện đã đặt có thể được cấu hình trong bảng Properties khi linh kiện được chọn trong vùng thiết kế. Bảng Properties cho một linh kiện bao gồm các thẻ sau:

 
 
 
 
 
  • General – các thuộc tính chung của linh kiện, chẳng hạn như định danh và chú thích, vị trí, tham số, v.v.

  • Pins – danh sách các chân linh kiện.

  • Cavities – cho phép gán các khoang socket cho linh kiện (tìm hiểu thêm).

  • Associated Parts – cho phép gán các phần bổ sung, chẳng hạn như ống co nhiệt, cho linh kiện.

Các thẻ của bảng Properties khi một linh kiện được chọn
Các thẻ của bảng Properties khi một linh kiện được chọn

Gán khoang socket

 
 
 
 
 

Các khoang socket và loại của chúng có thể được gán cho một linh kiện harness. Chọn một linh kiện trong vùng thiết kế để thêm khoang và loại. Chọn một chân trên thẻ Properties của bảng Cavities , sau đó nhấp nút  . Chọn loại mong muốn từ danh sách thả xuống. Các loại khoang sau được hỗ trợ:

  • Crimp – dùng để tạo kết nối điện bằng cách ép chặt ống tiếp điểm quanh dây dẫn.

  • Seal – dùng để bảo vệ môi trường bằng cách bịt kín điểm vào của dây.

  • Plug – dùng để lấp đầy một khoang đầu nối hở (không sử dụng) nhằm duy trì tính toàn vẹn của lớp bịt kín môi trường.

  • Other – dùng để chỉ định các chi tiết hoặc vật liệu khác/bổ sung, ví dụ như thiếc hàn.

Đối với loại khoang Crimp hoặc các hàng chưa được thêm loại khoang, bạn có thể chỉ định các giá trị sau:

  • Strip Length – chiều dài mà tại đó lớp cách điện được cắt khỏi dây dẫn.

  • Pull Off Length – chiều dài mà tại đó phần cách điện đã cắt được kéo ra khỏi dây dẫn. Giá trị này có thể được dùng trong các trường hợp đầu dây không được tuốt hoàn toàn và phần cách điện đã tháo vẫn được giữ lại trên dây để ngăn hư hại sợi dẫn.

Các đơn vị dùng để hiển thị những giá trị này trong bảng Properties khi một linh kiện được chọn được chỉ định bằng danh sách thả xuống Length Units trên thẻ General của bảng Properties khi không có đối tượng nào được chọn trong tài liệu.

Trong hộp thoại Select Connector được mở ra, duyệt đến và chọn linh kiện mong muốn. Loại cụ thể và thông tin liên quan sẽ được thêm vào chân trên thẻ, như được minh họa trong các hình bên dưới, đối với việc thêm một crimp vào chân 1.

Lưu ý rằng các chân được trình bày trong bảng của thẻ Cavities theo tên của chúng (cột Pins) và việc gán khoang phụ thuộc vào tên chân, vì vậy hãy đảm bảo rằng các tên duy nhất và chính xác được gán cho các chân linh kiện.

Đối với crimp, seal hoặc plug, chỉ có thể thêm một khoang của một loại cụ thể vào một chân. Sau khi một khoang của một loại cụ thể đã được thêm, mục đó sẽ không còn khả dụng (bị làm mờ) trong danh sách thả xuống. Có thể thêm bất kỳ số lượng khoang loại Other nào vào một chân.

Các chân đã được gán crimp được ký hiệu bằng biểu tượng trong vùng thiết kế, như được minh họa trong hình bên dưới.

Vùng lưới của thẻ Cavities hỗ trợ chọn nhiều và các thao tác sao chép/dán/xóa cho các mục đã chọn.

  • Có thể chọn nhiều mục chân bằng các phím tắt Click, Hold&DragCtrl+ClickShift+Click và Ctrl+A.

  • Khi nhiều mục chân được chọn, nhấp   để thêm một khoang cho tất cả các chân đã chọn hoặc nhấp  hay nhấn Delete để xóa các khoang đã thêm khỏi các chân đã chọn. 

  • Để thay đổi khoang của một chân, hãy chọn mục của chân đó, sau đó nhấp  để mở hộp thoại Select Connector nhằm chọn khoang mới.

  • Chọn một hoặc nhiều mục chân và dùng các phím tắt Ctrl+X/Ctrl+C để cắt/sao chép các mục đã chọn, sau đó dùng phím tắt Ctrl+V để dán nội dung đã cắt/sao chép vào mục hiện đang được chọn.

Tạo kết nối trong sơ đồ đi dây bó dây

Các dây vật lý được đặt trong tài liệu sơ đồ đi dây bó dây bằng cách chọn lệnh Place » Harness Wire từ các menu chính (phím tắt: Shift+W).

Sau khi chọn lệnh, hãy nhấp vào một chân của đầu nối (một dấu cộng đỏ xuất hiện tại con trỏ khi nó ở trên điểm nóng của chân) để đặt điểm bắt đầu của dây bó dây. Di chuyển con trỏ và nhấp để neo một loạt điểm đỉnh xác định hình dạng của dây bó dây. Sau khi đặt điểm đỉnh cuối cùng tại điểm nóng của một chân khác, nhấp chuột phải để hoàn tất việc đặt.

Khi đặt dây bó dây, nhấn Shift+Spacebar để chuyển qua các chế độ đặt. Chế độ này xác định cách tạo các góc khi đặt dây và các góc mà dây có thể được đặt. Khi ở chế độ 90 Degree hoặc 45 Degree (các chế độ trực giao thực sự), nhấn Spacebar để chuyển giữa các chế độ phụ bắt đầu và kết thúc. Chế độ và chế độ phụ hiện tại được hiển thị trên Thanh trạng thái.

Khi đặt dây bó dây, các netline sẽ theo dõi/cập nhật “trực tiếp”, cho bạn thấy nơi cần đi dây theo thời gian thực, như minh họa trong video bên dưới. Khi một kết nối được hoàn tất, netline của nó sẽ biến mất khỏi tài liệu.

Minh họa tính năng dò tuyến trực tiếp

Khi đã được đặt và chọn, các đỉnh của một dây bó dây có thể được kéo để thay đổi góc giữa hai đoạn liền kề (Show example).

Chọn một dây bó dây trong không gian thiết kế để thay đổi nó trong bảng Properties. Từ bảng này, bạn có thể đổi tên dây bó dây đã chọn, thay đổi chiều rộng và màu sắc của nó, và thêm các tham số có thể được hiển thị hoặc ẩn trong không gian thiết kế.

Bảng Properties khi một dây bó dây được chọn
Bảng Properties khi một dây bó dây được chọn

  • Một dây bó dây đã đặt có thể được thay thế bằng một linh kiện đi dây bó dây chứa một dây đơn. Để thực hiện việc này, hãy chọn dây bó dây cần thay thế và nhấp vào nút ở bên phải trường Design Item ID trong bảng Properties. Trong hộp thoại Replace Component mở ra, duyệt đến và chọn linh kiện cần thiết. Dây đã đặt sẽ được cập nhật theo các thuộc tính và tham số của linh kiện được chọn trong khi vẫn giữ nguyên hình học của nó. Tham khảo phần Placing a Harness Wiring Component để tìm hiểu thêm.

  • Màu chính của một dây được xác định bởi tham số Color, tham số này mặc định được hiển thị trên dây bó dây đã đặt. Để chỉnh sửa màu, hãy nhập tên của màu đó (ví dụ: Red) hoặc mã thập lục phân của nó (bằng cách gõ ký tự # theo sau là số thập lục phân, ví dụ: #9900FF) làm giá trị tham số. Ngoài ra, hãy nhấp vào nút màu ở bên trái giá trị tham số và sử dụng bộ chọn màu được mở ra, nơi màu dây có thể được chỉ định bằng giá trị RGB hoặc HEX, bằng cách chọn tự do hoặc từ một loạt giá trị đặt sẵn.

  • Sơ đồ đi dây bó dây hỗ trợ các dây nhiều màu bằng cách chọn màu thứ cấp và màu cấp ba của dây. Trong bảng Properties, nhấp vào danh sách thả xuống   ở cuối vùng Parameters rồi chọn SecondaryTertiary để xác định các màu mong muốn; tham số cho màu đã chọn sẽ xuất hiện trong vùng Parameters . Bạn cũng có thể xác định màu viền cho dây bó dây bằng cùng danh sách thả xuống rồi chọn Border. Lưu ý rằng tham số Color điều khiển khả năng hiển thị của giá trị kết hợp của các tham số màu dây đã định nghĩa Color, Secondary ColorTertiary Color. Nhấp qua trình chiếu bên dưới để xem ví dụ.

    Javascript ID: Harness_WD_Pnl_Properties_Wire_Colors_AD25

    Một dây chỉ xác định màu chính

    Một dây có xác định màu thứ cấp

    Một dây có xác định màu cấp ba

    Một dây có xác định màu viền

    Một dây có xác định tất cả các tùy chọn màu

    Các dây nhiều màu được hỗ trợ bởi các bảng trong tài liệu bản vẽ chế tạo thiết kế bó dây (*.HarDwf) – tìm hiểu thêm.

  • Nếu một dây bó dây có giá trị No cho tham số Include Cut của nó, dây này sẽ không được hiển thị trong danh sách đi dây và bảng kết nối trong bản vẽ chế tạo.

  • Các tham số Color, Min. Bending Radius, ThicknessUnits của một dây bó dây được sử dụng khi đồng bộ một dự án thiết kế bó dây với công cụ MCAD bằng MCAD CoDesigner. Tham khảo trang Synchronizing a Harness Design Project để tìm hiểu thêm.

Thêm mối nối và điểm lấy nhánh

Trong các tình huống thiết kế mà một dây mới cần được nối với một dây đã đặt, trước tiên phải đặt một đối tượng splice (Place » Splice) hoặc tap (Place » Tap).

  • Splice – dây gốc được splice chia thành hai dây riêng biệt.

    Javascript ID: Harness_WD_PlacingSplice_AD25

    Một dây khác cần được nối với dây đã chọn (W4).

    Một splice được đặt trên dây. Lưu ý rằng splice chia dây gốc thành hai tại vị trí splice.

    Một dây khác đã được nối với splice.

    Khi hai dây được nối theo dạng chữ T, một splice sẽ tự động được đặt tại vị trí nút nối chữ T (Show example).

  • Tap – dây gốc vẫn liền mạch, không bị ngắt.

    Javascript ID: Harness_WD_PlacingTap_AD25

    Một dây khác cần được nối với dây đã chọn (W4).

    Một tap được đặt trên dây. Lưu ý rằng tap không chia dây gốc.

    Một dây khác đã được nối với tap.

Các thuộc tính của một splice hoặc tap đã đặt (vị trí và biểu diễn trực quan của nó) có thể được cấu hình trong bảng Properties khi đối tượng được chọn trong không gian thiết kế.

Bảng Properties khi một splice/tap được chọn
Bảng Properties khi một splice/tap được chọn

Vùng Associated Parts của bảng Properties cho phép gán các linh kiện cho splice/tap đã chọn, và linh kiện này sẽ được phản ánh trong BOM của dự án.

Thêm cáp

Để xác định một hoặc nhiều dây là được thêm vào một cáp, bạn có thể đặt một đối tượng cáp trên sơ đồ đi dây bó dây (Place » Harness Cable).

Đặt một cáp để xác định một hoặc nhiều dây là được thêm vào một cáp.
Đặt một cáp để xác định một hoặc nhiều dây là được thêm vào một cáp.

Khi một đối tượng cáp được chọn, các dây được cáp này bao phủ sẽ được tô sáng màu xanh lục neon trong không gian thiết kế ().

Các thuộc tính của một đối tượng cáp đã đặt (vị trí, biểu diễn trực quan và các tham số) có thể được cấu hình trong bảng Properties khi đối tượng được chọn trong không gian thiết kế.

 
 
 
 
 

Bảng Properties khi một cáp được chọn
Bảng Properties khi một cáp được chọn

Một cáp có tỷ lệ cố định 2:1 trong khi đặt hoặc chỉnh sửa đồ họa, với kích thước đặt cuối cùng được xác định bởi giá trị snap grid hiện tại của tài liệu.

  • Nếu một cáp được liên kết với các dây ở nhiều vị trí trên sơ đồ đi dây bó dây (tức là khi nhiều đối tượng cáp có cùng designator được đặt trên các dây khác nhau), việc chọn một đối tượng sẽ tô sáng tất cả các dây liên kết trong nhóm, và tất cả các dây này sẽ được liệt kê trong vùng Cable Objects của bảng Properties ().

  • Các tham số Color, Min. Bending Radius, ThicknessUnits của một cáp được sử dụng khi đồng bộ một dự án thiết kế bó dây với công cụ MCAD bằng MCAD CoDesigner. Tham khảo trang Synchronizing a Harness Design Project để tìm hiểu thêm.

Che chắn và xoắn dây

Một lớp che chắn (có hoặc không có kết nối, chẳng hạn như kết nối dây thoát) có thể được gắn vào một nhóm dây bằng cách đặt đối tượng shield (Place » Shield) hoặc shield with connection (Place » Shield with Connection).

Trong ví dụ minh họa bên dưới, các dây W1, W2 và W3 được che chắn bởi một shield không có kết nối (SH1), và các dây W4, W8 và W9 được che chắn bởi một shield có kết nối (SH2). Dây W10 được đặt để nối SH2 với một chân linh kiện.

Đặt một đối tượng shield hoặc shield with connection để biểu thị các dây được che chắn.
Đặt một đối tượng shield hoặc shield with connection để biểu thị các dây được che chắn.

Khi một đối tượng shield hoặc shield with connection được chọn, các dây được bao phủ sẽ được tô sáng màu xanh lục neon trong không gian thiết kế ().

Các thuộc tính của một đối tượng shield hoặc shield with connection đã đặt (vị trí và biểu diễn trực quan) có thể được cấu hình trong bảng Properties khi đối tượng được chọn trong không gian thiết kế. Vùng Shield Objects của bảng liệt kê các dây được đối tượng đã chọn bao phủ.

 
 
 
 
 

Bảng Properties khi một shield được chọn
Bảng Properties khi một shield được chọn

  • Một shield có tỷ lệ cố định 2:1 trong khi đặt hoặc chỉnh sửa đồ họa, với kích thước đặt cuối cùng được xác định bởi giá trị snap grid hiện tại của tài liệu. 

  • Nếu một shield được liên kết với các dây ở nhiều vị trí trên sơ đồ đi dây bó dây (tức là khi nhiều đối tượng shield có cùng designator được đặt trên các dây khác nhau), việc chọn một đối tượng sẽ tô sáng tất cả các dây liên kết trong nhóm, và tất cả các dây này sẽ được liệt kê trong vùng Shield Objects của bảng Properties ().

Các dây có thể được biểu thị là xoắn với nhau bằng cách đặt một twist (Place » Twist). Một twist có thể được đặt trên hai hoặc nhiều dây.

Trong ví dụ bên dưới, các dây W1 và W2 được biểu thị là xoắn với nhau bằng twist Tw1.

Đặt một đối tượng twist để biểu thị các dây được xoắn với nhau.
Đặt một đối tượng twist để biểu thị các dây được xoắn với nhau.

Khi một twist được chọn, các dây được bao phủ sẽ được tô sáng màu xanh lục neon trong không gian thiết kế ().

Các thuộc tính của một twist đã đặt (vị trí và biểu diễn trực quan của nó) có thể được cấu hình trong bảng Properties khi đối tượng được chọn trong không gian thiết kế. Vùng Twist Objects của bảng liệt kê các dây được twist đã chọn bao phủ.

 
 
 
 
 

Bảng Properties khi một twist được chọn
Bảng Properties khi một twist được chọn

  • Một twist có tỷ lệ cố định 1:1 trong khi đặt hoặc chỉnh sửa đồ họa, với kích thước đặt cuối cùng được xác định bởi giá trị snap grid hiện tại của tài liệu. 

  • Nếu một twist được liên kết với các dây ở nhiều vị trí trên sơ đồ đi dây bó dây (tức là khi nhiều đối tượng twist có cùng designator được đặt trên các dây khác nhau), việc chọn một đối tượng sẽ tô sáng tất cả các dây liên kết trong nhóm, và tất cả các dây này sẽ được liệt kê trong vùng Twist Objects của bảng Properties ().

  • Các tham số Twists per Unit Length và Thickness của một twist được sử dụng khi đồng bộ một dự án thiết kế bó dây với công cụ MCAD bằng MCAD CoDesigner. Tham khảo trang Synchronizing a Harness Design Project để tìm hiểu thêm.

Dây chưa kết nối

Các đầu dây chưa kết nối được biểu thị bằng một hình vuông đặc.

Một dây chưa kết nối được chỉ thị
Một dây chưa kết nối được chỉ thị

Không nên để đầu dây ở trạng thái chưa kết nối. Nếu thiết kế yêu cầu một đầu dây không được kết nối, cần đặt một đối tượng 'no connect' ở đầu dây đó (Place » No Connect).

Đặt một đối tượng 'no connect' ở đầu một dây cần được giữ không kết nối.
Đặt một đối tượng 'no connect' ở đầu một dây cần được giữ không kết nối.

Các thuộc tính của một đối tượng 'no connect' đã đặt (vị trí và biểu diễn trực quan của nó) có thể được cấu hình trong bảng Properties khi đối tượng được chọn trong không gian thiết kế.

Bảng Properties khi một đối tượng 'no connect' được chọn
Bảng Properties khi một đối tượng 'no connect' được chọn

Làm việc với nhiều sheet

Có thể định nghĩa một sơ đồ đi dây bó cáp hoàn chỉnh trên nhiều sheet (theo kiểu thiết kế “flat”, trong đó tất cả các sheet đều tồn tại trên cùng một cấp), mỗi sheet được biểu diễn bằng tài liệu *.WirDoc riêng. Kết nối được tạo trực tiếp từ bất kỳ sheet nào sang bất kỳ sheet nào khác bằng các đối tượng ngắt dây (Place » Wire Break) có cùng ký hiệu dây.

Sau khi chọn lệnh đặt wire break, hãy đặt đối tượng sao cho điểm hotspot điện của nó (đầu đang được giữ bởi con trỏ) chạm vào dây mà bạn muốn kết nối, sau đó nhấp chuột hoặc nhấn Enter để thực hiện việc đặt. Một wire break sau khi được đặt sẽ kế thừa các thuộc tính (ký hiệu và màu sắc) của dây mà nó được nối vào.

Chọn một wire break trong không gian thiết kế để thay đổi nó trong bảng Properties. Từ bảng này, bạn có thể xác định ký hiệu của dây mà nó được kết nối tới và kiểu của nó: hướng (Left hoặc Right) và màu sắc.

Đồng bộ hóa dây

Các dây bó cáp được kết nối bằng wire break vẫn được nhận diện là có kết nối ngay cả khi chúng có Design Item ID khác nhau. Ngoài ra, tất cả các đoạn dây có cùng ký hiệu được nối bằng cùng một wire break sẽ được so sánh (về part number, comment, màu sắc và tất cả các tham số). Nếu phát hiện bất kỳ khác biệt nào, vi phạm Mismatched parameters in connected wire segments sẽ được báo cáo. Cảnh báo cũng xuất hiện trong bảng Properties của dây và wire break, cho biết đã phát hiện xung đột giữa các tham số. Nhấp vào Synchronize trong cảnh báo để mở hộp thoại Conflict Wire Parameters, tại đó bạn có thể chọn bộ tham số sẽ được dùng cho đoạn dây.

Thuộc tính và tham số của dây trước khi đồng bộ hóa

Một cảnh báo xuất hiện trong bảng Properties cho biết có xung đột giữa các tham số. Sau khi nhấp vào Synchronize trong cảnh báo, hộp thoại Confirm Wire Parameters sẽ mở ra. Chọn tùy chọn mong muốn rồi nhấp OK để thực hiện đồng bộ hóa.

Vi phạm Mismatched parameters in connected wire segments trong hộp thoại Project Options

Sau khi đồng bộ hóa, các thuộc tính của các đoạn dây đã được đồng bộ. 

 
  • Lưu ý rằng khi thay đổi màu sắc và ký hiệu của một wire break, màu sắc và ký hiệu của dây mà wire break đó kết nối tới cũng sẽ thay đổi tương ứng; và ngược lại, khi thay đổi màu sắc và ký hiệu của một dây, màu sắc và ký hiệu của wire break nối với dây đó cũng sẽ thay đổi tương ứng.

  • Bạn cũng có thể thay đổi thuộc tính của wire break đang được đặt bằng cách nhấn Tab sau khi chọn lệnh đặt. Lưu ý rằng nếu một ký hiệu được xác định cho wire break trước khi đặt, thì dây mà nó kết nối tới sẽ kế thừa ký hiệu và màu sắc của wire break.

  • Nếu một màu viền được xác định cho dây mà wire break được kết nối tới, wire break này cũng sẽ được hiển thị với viền có màu đó. Đồng thời, ký hiệu của wire break sẽ được hiển thị bằng màu viền của dây được kết nối.

  • Wire break không có thuộc tính phông chữ độc lập; chúng sử dụng các thuộc tính Document Font của tài liệu sơ đồ đi dây bó cáp mà chúng được đặt trên đó.

  • Wire break cũng có thể được dùng để tạo kết nối ngay trong cùng một sheet sơ đồ đi dây bó cáp – ví dụ, thay vì đặt một dây từ một chân đầu nối sang chân đầu nối khác, bạn có thể đặt một dây bó cáp ngắn và một wire break trên từng chân này ().

Đặt một Harness Wiring Component

Khi được kết nối với Workspace của bạn, bạn có thể tạo các component với cấu trúc và thuộc tính được định nghĩa sẵn theo yêu cầu trong Workspace được kết nối, rồi tái sử dụng các component đó trong các thiết kế bó cáp của mình bằng cách đặt trực tiếp chúng vào các tài liệu sơ đồ đi dây bó cáp.

Tham khảo trang Tạo một Harness Wiring Component để tìm hiểu thêm.

Các component này (mỗi component được gán một mô hình đi dây bó cáp đã xác định) được truy cập từ bảng Components panel. Khi tài liệu sơ đồ đi dây bó cáp cần dùng là tài liệu đang hoạt động trong không gian thiết kế, hãy đặt một component bằng cách nhấp chuột phải vào mục của nó trong bảng và chọn lệnh Place <ComponentName> từ menu ngữ cảnh. Cách thức đặt component sẽ khác nhau tùy theo việc component đó bao gồm một đối tượng dây đơn hay một cấu trúc cáp (nhiều dây và/hoặc các đối tượng bổ sung: cáp, shield, v.v.).

  • Single wire – khi đặt một component bao gồm một đối tượng dây đơn, bạn sẽ vào chế độ đặt dây bó cáp. Dây đang được đặt sẽ kế thừa các thuộc tính đã được định nghĩa trong quá trình tạo component. Tham khảo phần Tạo kết nối trong sơ đồ đi dây bó cáp ở trên để tìm hiểu thêm về cách đặt dây bó cáp.

  • Cable structure – khi chọn lệnh đặt cho một component bao gồm cấu trúc cáp, cấu trúc cáp đó sẽ xuất hiện gắn với con trỏ đúng như đã được định nghĩa trong quá trình tạo component. Nhấp vào vị trí mong muốn trong tài liệu sơ đồ đi dây bó cáp để đặt component. Sau đó bạn có thể chỉnh sửa riêng từng đối tượng của component, ví dụ như gắn các dây cấu thành cáp vào các chân của đầu nối bó cáp.

Cập nhật sơ đồ đi dây từ thư viện

Các đối tượng sau có thể được cập nhật từ thư viện Workspace nguồn của chúng:

  • Harness component

  • Cavity của harness component

  • Các part liên kết với harness component

  • Dây

Khi một đối tượng được chọn, thông tin về component Workspace được liên kết có thể được tìm thấy trong bảng Properties (ví dụ: tab Associated Parts cho các part liên kết với harness component).

Nếu có phiên bản revision mới hơn của component Workspace, mục trạng thái revision sẽ phản ánh điều này bằng dòng chữ Out of date. Ở cấp độ từng đối tượng, liên kết có thể được cập nhật lên revision mới nhất của component Workspace bằng cách nhấp vào nút .

Ví dụ về việc chỉ báo revision của harness component đã lỗi thời
Ví dụ về việc chỉ báo revision của harness component đã lỗi thời

Tính năng Update from Libraries (Tools » Update from Libraries) cũng có thể được dùng để cập nhật các component đã lỗi thời được liên kết với các đối tượng liệt kê ở trên. Lưu ý rằng để một đối tượng được đưa vào quá trình cập nhật bằng tính năng Update from Libraries, component được gán cho đối tượng đó phải bao gồm một liên kết đến schematic symbol.

Đánh số/chú thích các đối tượng trong sơ đồ đi dây bó cáp

Sử dụng các lệnh trong menu Tools » Annotation để đánh số/chú thích các đối tượng sau trong tài liệu sơ đồ đi dây bó cáp:

  • Harness component

  • Dây

  • Mối nối và điểm rẽ nhánh

  • Cáp

  • Shield và shield có kết nối

  • Đoạn xoắn

  • Đối tượng “không kết nối”

Việc đánh số/chú thích các đối tượng trong tài liệu sơ đồ đi dây bó cáp tương tự như việc đánh số/chú thích component trong tài liệu schematic (*.SchDoc) của một dự án thiết kế PCB. Sử dụng các liên kết sau để tìm hiểu thêm về các lệnh annotation có sẵn cho một tài liệu sơ đồ đi dây bó cáp:

AI-LocalizedBản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.
Tính khả dụng của tính năng

Các tính năng bạn có thể sử dụng phụ thuộc vào giải pháp Altium mà bạn đang có – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, hoặc Altium Designer (đang trong thời hạn hiệu lực).

Nếu bạn không thấy một tính năng được nêu trong tài liệu có trong phần mềm thực tế của mình, liên hệ Bộ phận Kinh doanh của Altium để tìm hiểu thêm.

Tài liệu cũ

Tài liệu Altium Designer không còn được phân phiên bản. Nếu bạn cần truy cập tài liệu cho các phiên bản cũ hơn của Altium Designer, hãy truy cập mục Tài liệu cũ trên trang Trình cài đặt khác.

Nội dung