Đánh số linh kiện trong thiết kế
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Sơ lược
- Tìm hiểu mục đích của việc đánh số định danh thiết kế và lý do ký hiệu định danh linh kiện duy nhất đóng vai trò quan trọng trong sơ đồ nguyên lý, bố trí PCB và các tài liệu đầu ra như bảng kê vật tư (BOM).
- Hiểu sự khác biệt giữa đánh số định danh cấp sơ đồ nguyên lý, PCB và cấp bo mạch, bao gồm các loại thiết kế phù hợp nhất với từng phương pháp.
- Xem trước hộp thoại Annotate và các thiết lập chính để kiểm soát phạm vi đánh số định danh, thứ tự xử lý, tùy chọn đối chiếu và các thay đổi được đề xuất.
Đánh số linh kiện trong thiết kế là quy trình có hệ thống và phương pháp nhằm đảm bảo mỗi linh kiện trong thiết kế đều có thể được nhận diện riêng bằng một ký hiệu định danh duy nhất. Mặc dù Altium Designer có thể duy trì danh tính của các linh kiện bằng mã định danh duy nhất toàn cục (GUID), từ trước đến nay, hầu hết các nhà thiết kế vẫn sử dụng ký hiệu định danh của linh kiện làm phương thức chính để tham chiếu linh kiện giữa miền sơ đồ nguyên lý (logic) và miền PCB (vật lý), cũng như trong các đầu ra như bảng kê vật tư (BOM).
Có ba phương pháp đánh số linh kiện trong thiết kế. Việc lựa chọn công cụ đánh số phụ thuộc vào nhiều yếu tố, bao gồm loại thiết kế, sở thích cá nhân, chính sách và quy trình của công ty.
Schematic Level Annotation
Đánh số ở cấp sơ đồ nguyên lý sử dụng góc nhìn thuần logic của thiết kế để xác định ký hiệu định danh linh kiện. Phương pháp này hữu ích nhất cho các thiết kế đơn giản không sử dụng Device Sheets. Tuy nhiên, vì cho phép chỉ định thứ tự xử lý cũng như tùy chọn điền đầy các vỏ linh kiện hiện có đối với linh kiện nhiều phần, đây cũng là bước tiên quyết trước khi đánh số ở cấp bo mạch.
Tóm lại, hãy sử dụng phương pháp đánh số ở cấp sơ đồ nguyên lý để:
- Gom các phần của linh kiện nhiều phần vào cùng một vỏ linh kiện.
- Đánh số linh kiện dựa trên vị trí của chúng trong thiết kế sơ đồ nguyên lý.
- Đánh số linh kiện trong thiết kế đa kênh bằng quy tắc đặt tên mặc định được chỉ định trong tùy chọn dự án.
- Chuẩn bị thiết kế cho các bước đánh số tiếp theo.
PCB Annotation
Đánh số PCB sử dụng vị trí vật lý của linh kiện trên PCB để xác định ký hiệu định danh của chúng. Nhờ đó, thông tin vị trí được mã hóa hiệu quả vào ký hiệu định danh của linh kiện và có thể rất hữu ích khi gỡ lỗi PCB đã lắp ráp. Tóm lại, bạn nên sử dụng phương pháp đánh số PCB để đánh số linh kiện dựa trên vị trí của chúng trên bo mạch trong thiết kế PCB.
Board Level Annotation
Đánh số ở cấp bo mạch tạo ánh xạ giữa các ký hiệu định danh được sử dụng trong thiết kế sơ đồ nguyên lý (logic) và các ký hiệu tương ứng thực tế trên thiết kế PCB (vật lý). Mặc dù có thể sử dụng trong mọi thiết kế, phương pháp đánh số ở cấp bo mạch đặc biệt hữu ích cho thiết kế đa kênh hoặc thiết kế có sử dụng các trang thiết bị mà không thể chỉnh sửa ký hiệu định danh ngay trên chính trang đó. Bằng cách này, toàn bộ thiết kế có thể được đánh số lại mà không cần sửa đổi các trang thiết bị gốc. Đánh số ở cấp bo mạch giải quyết mọi xung đột đánh số có thể phát sinh do trùng ký hiệu định danh trong một dự án và lưu các thay đổi vào một *.Annotation tệp văn bản. Phương pháp này bao gồm các từ khóa bổ sung để tùy chỉnh quy tắc đặt tên và cho phép áp dụng chúng cho tất cả hoặc chỉ một nhóm phần linh kiện được chọn.
Tóm lại, hãy sử dụng phương pháp đánh số ở cấp bo mạch để:
- Đánh số các linh kiện đã được biên dịch trong các trang thiết bị.
- Đặt tên duy nhất cho mọi linh kiện trên nhiều kênh bằng các quy tắc đặt tên, bao gồm đánh số theo vị trí, đánh chỉ số toàn cục và các tùy chọn có thể cấu hình khác.
- Đặt tên linh kiện theo cách thủ công.
Đánh số linh kiện trên sơ đồ nguyên lý
Việc đánh số linh kiện trên sơ đồ nguyên lý được cấu hình bằng hộp thoại Annotate . Hộp thoại cung cấp các tùy chọn để gán ký hiệu định danh một cách có hệ thống cho tất cả hoặc các phần linh kiện được chọn trên những trang được chọn của dự án, đồng thời đảm bảo các ký hiệu định danh là duy nhất và được sắp xếp theo vị trí. Có thể cấu hình các tùy chọn đánh số để gom các phần của linh kiện nhiều phần vào cùng vỏ linh kiện, thiết lập tùy chọn chỉ số và hậu tố, đặt lại ký hiệu định danh trên sơ đồ nguyên lý, kể cả các ký hiệu bị trùng, và cập nhật ngược ký hiệu định danh từ PCB.
Hộp thoại Annotate được truy cập bằng cách chạy lệnh Đánh số sơ đồ nguyên lý (Tools » Annotation » Annotate Schematics).

Hộp thoại Annotate được mở từ lệnh Annotate Schematics.
Hộp thoại được chia thành hai vùng chính:
- Schematic Annotation Configuration - vùng này được sử dụng để cấu hình quy tắc đánh số cũng như phạm vi đánh số.
- Proposed Change List - vùng này liệt kê các thay đổi được đề xuất sẽ diễn ra sau khi được chấp nhận và thực thi bằng lệnh thay đổi kỹ thuật (ECO).
Các tùy chọn và điều khiển của hộp thoại Đánh số
Cấu hình đánh số linh kiện trên sơ đồ nguyên lý
Thứ tự xử lý
Sử dụng vùng này để chỉ định phương pháp đánh số theo vị trí mong muốn. Khi bạn chọn một phương pháp từ danh sách thả xuống, hình minh họa tương ứng sẽ tự động cập nhật để thể hiện cách các linh kiện sẽ được đánh số. Chọn trong các phương pháp đánh số theo vị trí sau:
- Up Then Across
- Down Then Across
- Across Then Up
- Across Then Down
Xử lý theo vị trí của
Sử dụng vùng này để chỉ định mốc tham chiếu vị trí linh kiện khi xử lý thứ tự đánh số. Chọn trong các tùy chọn sau:
- Designator - ký hiệu định danh của linh kiện được dùng làm mốc tham chiếu vị trí khi xác định thứ tự xử lý.
- Part - tâm của linh kiện được dùng làm mốc tham chiếu vị trí khi xác định thứ tự xử lý.
Thay thế các phần con
Sử dụng danh sách thả xuống để chọn có thay thế các phần con trong quá trình đánh số hay không.
Tùy chọn đối sánh
Khi sử dụng vỏ linh kiện nhiều phần, người thiết kế thường muốn gom được nhiều phần nhất vào số lượng linh kiện vật lý ít nhất, vì điều này giúp giảm thiểu tổng chi phí BOM của thiết kế. Các tùy chọn trong vùng này cho phép bạn xác định cách đối sánh và nhóm các phần linh kiện với nhau, cũng như các tiêu chí để xác định nhóm hợp lệ.
-
Complete Existing Packages - sử dụng tùy chọn này để quyết định có đưa các phần linh kiện chưa được đánh số vào các vỏ linh kiện hiện có hay không và đưa vào như thế nào. Sử dụng danh sách thả xuống để chọn trong các tùy chọn sau:
- None - không điền đầy các vỏ linh kiện hiện có và tất cả các phần linh kiện mới sẽ được đưa vào các vỏ linh kiện mới.
- Per Sheet - các vỏ linh kiện hiện có sẽ chỉ nhận thêm các phần linh kiện mới từ cùng một trang sơ đồ nguyên lý.
- Whole Project - các vỏ linh kiện hiện có sẽ nhận thêm các phần linh kiện mới từ bất kỳ trang sơ đồ nguyên lý nào trong dự án.
- Component Parameter - danh sách này bao gồm tất cả các tham số có trong các linh kiện của thiết kế hiện tại. Chọn hộp kiểm tương ứng với một tham số để sử dụng tham số đó khi đối sánh các phần linh kiện nhằm gom vào cùng vỏ. Nếu các linh kiện nhiều phần có cùng các tham số đã bật và cùng giá trị, chúng sẽ được gom vào cùng vỏ linh kiện (với điều kiện tùy chọn Complete Existing Packages không được đặt thành None). Những linh kiện còn lại không có các tham số đã bật cũng được gom vào cùng vỏ.
- Strictly - bật tùy chọn này cho một Component Parameter trong danh sách để chỉ định rằng tất cả linh kiện must có tham số đó mới được ghép vào một gói linh kiện. Các linh kiện không có tham số này sẽ được đánh số riêng lẻ và không được ghép gói.
Menu chuột phải
- Parameter » Enable Selected Parameters - dùng để đánh dấu ô 'Bao gồm' cho tất cả tham số hiện được chọn trong danh sách.
- Parameter » Enable All Parameters - dùng để đánh dấu ô 'Bao gồm' cho tất cả tham số trong danh sách.
- Parameter » Disable Selected Parameters - dùng để bỏ đánh dấu ô 'Bao gồm' cho tất cả tham số hiện được chọn trong danh sách.
- Parameter » Disable All Parameters - dùng để bỏ đánh dấu ô 'Bao gồm' cho tất cả tham số trong danh sách.
- Match Strictly » Enable Strict Matching On Selected Parameters - dùng để bật tùy chọn Strictly cho tất cả tham số hiện được chọn trong danh sách.
- Match Strictly » Enable Strict Matching On All Parameters - dùng để bật tùy chọn Strictly cho tất cả tham số trong danh sách.
- Match Strictly » Disable Strict Matching On Selected Parameters - dùng để tắt tùy chọn Strictly cho tất cả tham số hiện được chọn trong danh sách.
- Match Strictly » Disable Strict Matching On All Parameters - dùng để tắt tùy chọn Strictly cho tất cả tham số trong danh sách.
- Selection » Select All - dùng để chọn tất cả mục tham số trong danh sách.
- Selection » Deselect All - dùng để bỏ chọn tất cả mục tham số trong danh sách.
- Selection » Invert Selection - dùng để chọn tất cả tham số hiện chưa được chọn trong danh sách và bỏ chọn các tham số đang được chọn.
Các trang sơ đồ nguyên lý cần đánh số
Vùng này của hộp thoại liệt kê tất cả các trang sơ đồ nguyên lý nguồn trong dự án thiết kế. Các điều khiển trong vùng này dùng để xác định những trang sẽ được đưa vào quá trình đánh số và cách tính toán cụ thể các thay đổi khi đánh số. Với mỗi trang, các thông tin sau được hiển thị:
- Include/Exclude checkbox - đánh dấu ô này để đưa trang sơ đồ nguyên lý vào quá trình đánh số.
- Schematic Sheet - trường này hiển thị tên của trang sơ đồ nguyên lý.
-
Annotation Scope - dùng trường này để xác định phạm vi đánh số đối với các linh kiện trên trang. Sử dụng danh sách thả xuống để chọn một trong các phạm vi sau:
- All - tất cả các phần linh kiện trên trang sơ đồ nguyên lý sẽ được đánh số.
- Ignore Selected Parts - tất cả các phần linh kiện, ngoại trừ những phần hiện được chọn trong thiết kế, sẽ được đánh số.
- Only Selected Parts - chỉ những phần linh kiện hiện được chọn trong thiết kế mới được đánh số.
- Order - dùng trường này để chỉ định vị trí của trang này trong thứ tự đánh số tổng thể các trang. Nhập trực tiếp số thứ tự mong muốn vào trường hoặc sử dụng các mũi tên xuất hiện khi nhấp vào trường để điều chỉnh theo ý muốn.
- Designator Index Control - dùng các điều khiển trong cột này để bật việc sử dụng chỉ số bắt đầu (bằng cách đánh dấu ô tương ứng) và xác định giá trị cho chỉ số đó. Giá trị ký hiệu định danh sẽ bắt đầu từ giá trị chỉ số này.
- Add Suffix - dùng trường này để chỉ định hậu tố sẽ được thêm vào mỗi ký hiệu định danh được đánh số. Các hậu tố dạng chữ cái (A, B, C...), chữ số (1, 2, 3...) và ký tự không phải chữ hoặc số (_ * . %...) đều được hỗ trợ, kể cả tổ hợp của các dạng này.
Additional Controls
- All On - nhấp để đưa tất cả các trang sơ đồ nguyên lý vào quá trình đánh số.
- All Off - nhấp để loại tất cả các trang sơ đồ nguyên lý khỏi quá trình đánh số.
-
Right-Click Menu - các lệnh sau có sẵn trong menu ngữ cảnh khi nhấp chuột phải tại vùng này:
-
Order Alphabetically - dùng để sắp xếp danh sách sơ đồ nguyên lý theo thứ tự bảng chữ cái. Thao tác này sẽ ảnh hưởng đến mục Order tương ứng của mỗi trang.
-
Order By Project Order - dùng để sắp xếp danh sách sơ đồ nguyên lý theo thứ tự xuất hiện trong dự án (như hiển thị trên bảng Projects ). Thao tác này sẽ ảnh hưởng đến mục Order tương ứng của mỗi trang.
-
All On - dùng để đưa tất cả các trang sơ đồ nguyên lý vào quá trình đánh số.
-
All Off - dùng để loại tất cả các trang sơ đồ nguyên lý khỏi quá trình đánh số.
-
Danh sách thay đổi đề xuất
-
Main List - vùng này của hộp thoại liệt kê tất cả ký hiệu định danh của các phần linh kiện nằm trên những trang được chọn để đánh số. Với mỗi mục, thông tin chi tiết về các giá trị Current và Proposed Designator được hiển thị, cùng với Sub (phần) của linh kiện và Location of Partnguồn. Các biểu tượng ổ khóa được dùng để biểu thị các cột bị khóa nhằm ngăn thay đổi ký hiệu định danh và phần con.
Đánh dấu ô bên cạnh một ký hiệu định danh trong cột Current ('khóa ký hiệu định danh') sẽ khóa ký hiệu định danh cụ thể đó, ngăn mọi thay đổi. Tương tự, đánh dấu ô bên cạnh trường Sub của ký hiệu định danh ('khóa phần con') sẽ ngăn việc cập nhật phần con cụ thể đó của linh kiện nhiều phần chứa nó.
Các lệnh sau có sẵn trong menu chuột phải của vùng này:
- Designator » Lock Selected Designators - dùng để đánh dấu ô 'khóa ký hiệu định danh' cho tất cả ký hiệu định danh hiện được chọn trong danh sách.
- Designator » Lock All Designators - dùng để đánh dấu ô 'khóa ký hiệu định danh' cho tất cả ký hiệu định danh.
- Designator » Unlock Selected Designators - dùng để bỏ đánh dấu ô 'khóa ký hiệu định danh' cho tất cả ký hiệu định danh hiện được chọn trong danh sách.
- Designator » Unlock All Designators - dùng để bỏ đánh dấu ô 'khóa ký hiệu định danh' cho tất cả ký hiệu định danh.
- Part ID » Lock Selected Part ID - dùng để đánh dấu ô 'khóa phần con' cho tất cả ký hiệu định danh hiện được chọn trong danh sách.
- Part ID » Lock All Part ID - dùng để đánh dấu ô 'khóa phần con' cho tất cả ký hiệu định danh.
- Part ID » Unlock Selected Part ID - dùng để bỏ đánh dấu ô 'khóa phần con' cho tất cả ký hiệu định danh hiện được chọn trong danh sách.
- Part ID » Unlock All Part ID - dùng để bỏ đánh dấu ô 'khóa phần con' cho tất cả ký hiệu định danh.
- Selection » Select All - dùng để chọn tất cả mục ký hiệu định danh trong danh sách.
- Selection » Select All With '?' - dùng để chọn tất cả mục có ký hiệu định danh hiện tại chứa dấu ? (tức là đã được đặt lại).
- Selection » Deselect All - dùng để bỏ chọn tất cả mục ký hiệu định danh trong danh sách.
- Selection » Invert Selection - dùng để chọn tất cả ký hiệu định danh hiện chưa được chọn trong danh sách và bỏ chọn những ký hiệu đang được chọn.
- Annotation Summary - khu vực này cung cấp thông tin tóm tắt về việc đánh số, bao gồm số lượng trang liên quan và các tùy chọn đối sánh. Thông tin được cập nhật tự động khi có thay đổi trong các khu vực này.
- Update Changes List - nhấp để cập nhật danh sách thay đổi đề xuất chính bằng các thay đổi mới được tính toán dựa trên thiết lập đánh số linh kiện ở phía bên trái hộp thoại. Một hộp thoại thông tin sẽ hiển thị chi tiết số thay đổi so với trạng thái trước đó và số thay đổi so với trạng thái ban đầu.
- Reset All - nhấp để đặt lại tất cả ký hiệu định danh trong danh sách chính (không bị khóa) về tiền tố linh kiện mặc định, ví dụ: R?, C?, D?. Các thay đổi sẽ được đưa vào cột ký hiệu định danh Proposed . Danh sách thả xuống của nút cho phép đổi lệnh thành Reset Duplicates. Nếu hai hoặc nhiều linh kiện có cùng ký hiệu định danh, tất cả trừ một linh kiện sẽ được đặt lại về tiền tố mặc định. Một hộp thoại thông tin cũng sẽ hiển thị chi tiết số thay đổi so với trạng thái trước đó và số thay đổi so với trạng thái ban đầu.
- Back Annotate - nhấp để mở hộp thoại tìm và chọn tệp dùng để cập nhật ngược ký hiệu định danh.
- Accept Changes (Create ECO) - sau khi xem xét tất cả thay đổi đề xuất, nhấp vào nút này để mở hộp thoại Engineering Change Order, trong đó các thay đổi đề xuất được liệt kê dưới dạng sửa đổi thuộc nhóm Đánh số linh kiện. Sử dụng hộp thoại này để xác thực và thực thi ECO, hoàn tất quy trình đánh số linh kiện ở cấp sơ đồ nguyên lý.
Khóa linh kiện
Đối với các linh kiện nhiều phần không đồng nhất, hãy đảm bảo các biểu tượng khóa trong bảng Properties đều ở trạng thái đóng để ngăn thay đổi các phần con trong quá trình đánh số.
Tùy chọn nghiêm ngặt
Nếu hộp kiểm Strictly được bật cho một Component Parameter, tất cả linh kiện phải có tham số đó khớp nhau để được ghép vào cùng một vỏ linh kiện. Những linh kiện không có tham số này sẽ được đánh số riêng lẻ và không được ghép.
Ví dụ sau minh họa cách kết hợp các tùy chọn này để tạo ra một kết quả cụ thể:
Xét một thiết kế có tám cổng OR và tám điện trở (như trong hình bên dưới). Các cổng OR chứa một tham số có tên QuadOrGate, trong đó một nhóm bốn cổng OR có giá trị tham số là Package1 và nhóm bốn cổng OR còn lại có giá trị tham số là Package2. Các điện trở không có tham số này. Bật hộp kiểm cho QuadOrGate trong điều khiển Component Parameter sẽ đảm bảo tham số này được dùng để kiểm soát cách ghép các phần vào vỏ linh kiện; trong trường hợp này, hộp kiểm Strictly không được bật.
Sau khi chạy lệnh Tools » Annotation » Annotate Schematics, các phần có tham số QuadOrGate = Package1 sẽ được ghép vào cùng một linh kiện vật lý, còn các phần có tham số QuadOrGate = Package2 sẽ được ghép thành một nhóm riêng. Mọi linh kiện còn lại không có tham số QuadOrGate sẽ được ghép với nhau. Trong trường hợp này, các điện trở được ghép với nhau vì đặc điểm chung của chúng là không chứa tham số QuadOrGate.

Ví dụ về các linh kiện được ghép khi tùy chọn Strictly không được chọn.
Nếu đánh số cùng thiết kế đó nhưng chọn tùy chọn Strictly , chỉ những linh kiện có tham số QuadOrGate mới được ghép. Trong trường hợp này, các cổng OR sẽ được ghép còn các điện trở thì không. Do đó, mặc dù tùy chọn Strictly cho phép kiểm soát rất chi tiết quá trình ghép linh kiện, trong hầu hết trường hợp nên bỏ chọn tùy chọn này.

Ví dụ về các linh kiện được ghép khi tùy chọn Strictly được chọn.
Các trang sơ đồ nguyên lý cần đánh số
Bạn có thể kiểm soát chi tiết những trang sơ đồ nguyên lý và linh kiện nào sẽ chịu tác động của việc đánh số cũng như cách tính toán cụ thể các thay đổi đó.

Chỉ định phạm vi đánh số.
- Dấu chọn trong ô bên trái trang sơ đồ nguyên lý được liệt kê cho biết trang đó sẽ được xử lý khi thực hiện lệnh đánh số.
- Phạm vi đánh số được xác định bằng danh sách thả xuống Annotation Scope và có thể mở rộng để bao gồm toàn bộ trang sơ đồ nguyên lý hoặc giới hạn ở các linh kiện được chọn hoặc không được chọn. Khi sử dụng tùy chọn Ignore Selected Parts hoặc Only Selected Parts , các linh kiện phải được chọn trong thiết kế trước khi chạy lệnh đánh số.
- Cấu hình thứ tự đánh số các trang sơ đồ nguyên lý bằng trường Order. Nhập trực tiếp một giá trị vào trường hoặc sử dụng các mũi tên xuất hiện khi nhấp vào trường để đặt giá trị mong muốn.
- Nếu tùy chọn Designator Index Control được chọn, giá trị ký hiệu định danh sẽ bắt đầu từ giá trị Start Index. Start Index không có tác dụng nếu tùy chọn Designator Index Control không được chọn.
- Có thể thêm hậu tố vào cuối mỗi ký hiệu định danh bằng cách chỉ định một chuỗi/giá trị trong cột Suffix tương ứng. Tránh sử dụng hậu tố chỉ có một ký tự như 'A' hoặc '1' vì chúng dễ bị nhầm với các phần con và/hoặc các giá trị ký hiệu định danh khác.
Danh sách thay đổi đề xuất
Nhấp vào nút Update Changes List để cập nhật Proposed Change List, qua đó có thể xem xét tất cả thay đổi ký hiệu định danh trước khi áp dụng. Chỉ những ký hiệu định danh chưa được thiết lập trước đó (tức là R?, C?, v.v.) mới chịu tác động của các thay đổi. Vì vậy, nếu muốn cập nhật tất cả ký hiệu định danh trong thiết kế, trước tiên cần đặt lại chúng bằng cách nhấn nút Reset All.

Đặt lại ký hiệu định danh trước khi áp dụng thiết lập đánh số.
Proposed Change List liệt kê tất cả ký hiệu định danh của các phần nằm trong những trang được chọn để đánh số. Mỗi mục bao gồm thông tin chi tiết về các giá trị ký hiệu định danh Current và Proposed, cùng với Sub (phần) của linh kiện và Location of Partnguồn.
Chọn ô tương ứng với một Designator sẽ khóa ký hiệu định danh cụ thể đó, ngăn mọi thay đổi. Tương tự, chọn ô Sub sẽ ngăn cập nhật linh kiện nhiều phần cụ thể đó. Có thể dùng tùy chọn này thay cho việc thiết lập biểu tượng Lock trong bảng Properties .
Sau khi xem xét danh sách thay đổi đề xuất, nhấp vào nút Accept Changes (Create ECO) để mở hộp thoại Engineering Change Order. Khi ECO được thực thi, các thay đổi về đánh số sẽ được áp dụng cho thiết kế.
Các lệnh đánh số sơ đồ nguyên lý bổ sung
Menu Công cụ » Annotation chứa một số lệnh đánh số sơ đồ nguyên lý chuyên biệt. Mục đầu tiên trong nhóm, Annotate Schematic, đã được trình bày.

Các lệnh đánh số có sẵn
Đặt lại ký hiệu định danh trên sơ đồ nguyên lý
Nếu các phần nội dung lớn đã được cắt và dán từ nhiều nguồn khác nhau vào một thiết kế mới, có thể cần đặt lại tất cả ký hiệu định danh. Vì lệnh này sử dụng các thiết lập lấy từ hộp thoại Đánh số định danh , nên lệnh sẽ được áp dụng cho những mục đã được thiết lập trước đó trong hộp thoại này. Ví dụ, nếu trước đó tất cả Schematic Sheets To Annotate đều được chọn, thì lệnh Reset Schematic Designators sẽ áp dụng cho toàn bộ dự án bất kể các trang hiện có đang mở trong trình biên tập hay không. Nếu trước đó chỉ có một vài Schematic Sheets To Annotate được chọn, thì lệnh Reset Schematic Designators sẽ chỉ tác động đến các trang đó.
Sau khi khởi chạy lệnh, một hộp thoại xác nhận sẽ xuất hiện, tóm tắt số lượng ký hiệu định danh cần cập nhật và hỏi bạn có muốn tiếp tục thực hiện các thay đổi hay không. Sau khi nhấp vào Yes, tất cả ký hiệu định danh linh kiện trên mọi trang sơ đồ nguyên lý được bật chức năng đánh số định danh của dự án hiện hành sẽ được đặt lại và có dạng: R?, C?, D?, U?, v.v.
Mọi ký hiệu định danh ở trạng thái khóa đều không bị đặt lại hoặc thay đổi dưới bất kỳ hình thức nào.
Đặt lại các ký hiệu định danh trùng lặp trên sơ đồ nguyên lý
Khi nhân bản các phần của thiết kế, những linh kiện mới được sao chép vẫn giữ nguyên giá trị ký hiệu định danh của các linh kiện gốc. Lệnh Reset Duplicate Schematic Designators cung cấp một cách nhanh chóng để đặt lại các ký hiệu định danh trùng lặp thành '?'. Vì lệnh này sử dụng các thiết lập lấy từ hộp thoại Annotate , nên lệnh sẽ được áp dụng cho những mục đã được thiết lập trước đó trong hộp thoại này. Ví dụ, nếu trước đó tất cả Schematic Sheets To Annotate đều được chọn, thì lệnh Reset Duplicate Schematic Designators sẽ áp dụng cho toàn bộ dự án bất kể các trang hiện có đang mở trong trình biên tập hay không. Nếu trước đó chỉ có một vài Schematic Sheets to Annotate được chọn, thì lệnh Reset Schematic Designators sẽ chỉ tác động đến các trang đó.
Sau khi khởi chạy lệnh, một hộp thoại xác nhận sẽ xuất hiện, tóm tắt số lượng ký hiệu định danh cần cập nhật và hỏi bạn có muốn tiếp tục thực hiện các thay đổi hay không. Sau khi nhấp vào Yes, tất cả ký hiệu định danh linh kiện trùng lặp được tìm thấy trên mọi trang sơ đồ nguyên lý được bật chức năng đánh số định danh của dự án hiện hành sẽ được đặt lại và có dạng: R?, C?, D?, U?, v.v.
Mọi ký hiệu định danh ở trạng thái khóa đều không bị đặt lại hoặc thay đổi dưới bất kỳ hình thức nào.
Đánh số định danh sơ đồ nguyên lý ở chế độ nền
Lệnh Annotate Schematics Quietly được dùng để kiểm tra tất cả tài liệu sơ đồ nguyên lý nguồn của dự án hiện hành được bật chức năng đánh số định danh và gán một ký hiệu định danh duy nhất cho bất kỳ linh kiện nào hiện chưa có ký hiệu định danh. Quá trình đánh số định danh được thực hiện ở chế độ nền, cho phép áp dụng tất cả thiết lập trước đó của hộp thoại Annotate mà không cần mở lại hộp thoại. Điều này đặc biệt hữu ích khi thiết kế đang trong giai đoạn phát triển nhanh và người thiết kế muốn nhanh chóng đánh số định danh trước khi biên dịch thiết kế.
Buộc đánh số định danh lại cho tất cả sơ đồ nguyên lý
Lệnh này được dùng để kiểm tra tất cả tài liệu sơ đồ nguyên lý nguồn của dự án hiện hành được bật chức năng đánh số định danh và đánh số định danh lại cho tất cả linh kiện trong đó theo quy tắc đánh số định danh hiện được xác định trong hộp thoại Annotate.
Chạy lệnh Force Annotate All Schematics tương đương với việc chạy lệnh Reset Schematic Designators rồi ngay lập tức chạy lệnh Annotate Schematics Quietly. Do đó, lệnh Force Annotate All Schematics sử dụng các thiết lập đã được đặt trước đó trong hộp thoại Annotate để xác định những linh kiện và trang nào có thể được cập nhật.
Sau khi khởi chạy lệnh này, một yêu cầu xác nhận sẽ xuất hiện, nêu chi tiết số lượng ký hiệu định danh sẽ được cập nhật nếu bạn chấp nhận. Sau khi nhấp vào Yes, tất cả ký hiệu định danh linh kiện trên mọi trang sơ đồ nguyên lý được bật chức năng đánh số định danh của dự án hiện hành sẽ được đánh số lại khi cần thiết, để tuân theo quy tắc đánh số định danh theo vị trí hiện được xác định trong vùng Schematic Annotation Configuration của hộp thoại Annotate .
Chú thích ngược sơ đồ nguyên lý
Trước khi Design Compiler và Synchronizer của Altium Designer được giới thiệu, các thay đổi về ký hiệu định danh thường được truyền từ sơ đồ nguyên lý sang PCB thông qua tệp netlist (*.net). Các thay đổi về ký hiệu định danh cần truyền theo chiều ngược lại, từ PCB sang sơ đồ nguyên lý, được xử lý thông qua quy trình Chú thích ngược. Quy trình này sử dụng tệp Was-Is (*.WAS) hoặc tệp Lệnh thay đổi kỹ thuật (Engineering Change Order, *.ECO) để chỉ định các thay đổi cần áp dụng cho ký hiệu định danh trên sơ đồ nguyên lý.
Sau khi khởi chạy lệnh, hộp thoại Choose WAS-IS File for Back-Annotation from PCB sẽ xuất hiện. Duyệt đến và chọn tệp .was (hoặc .eco) cần dùng. Sau khi nhấp vào Open, một hộp thoại thông tin sẽ xuất hiện, liệt kê số lượng thay đổi đối với ký hiệu định danh so với trạng thái trước đó và so với trạng thái ban đầu. Tại thời điểm này, các thay đổi vẫn chưa thực sự được áp dụng. Nhấp vào OK để mở hộp thoại Annotate, nơi bạn có thể xem các thay đổi được đề xuất đối với ký hiệu định danh hiện tại trước khi quyết định tạo ECO để thực hiện chúng.
Đánh số các trang sơ đồ nguyên lý
Lệnh Number Schematic Sheets không thay đổi ký hiệu định danh linh kiện mà thay đổi ký hiệu định danh (số) của các trang sơ đồ nguyên lý. Vì vậy, về mặt khái niệm, lệnh này có liên quan đến khái niệm chung về đánh số định danh trong thiết kế.
Việc đánh số trang và tài liệu cho phép bạn kiểm soát ký hiệu định danh trang và lưu chúng dưới dạng tham số trong các tài liệu sơ đồ nguyên lý tương ứng. Sau đó, có thể sử dụng tính năng chuỗi đặc biệt của Altium Designer (=SheetNumber, =DocumentNumber, =SheetTotal) để hiển thị các giá trị này trên trang (ví dụ: ở chân trang) dưới dạng đối tượng văn bản.

Đánh số các trang sơ đồ nguyên lý.
Quy trình đánh số trang như sau:
Đánh số trang tự động (Tùy chọn dự án)
Bật để thực hiện đánh số trang tự động. Các giá trị sẽ được hiển thị trong bảng Projects. Bạn cũng có thể bật chức năng đánh số trang tự động bằng cách chọn tùy chọn Automatic Sheet Numbering trên tab Tùy chọn của hộp thoại Project Options.
Đánh số trang tự động
Nhấp vào nút thả xuống Auto Sheet Number để truy cập các tùy chọn đánh số trang.
Các tùy chọn Select Numbering Scheme gồm:
- Display Order - các trang được đánh số theo thứ tự hiển thị.
- Sheets Hierarchical Structure - Depth First - các trang được đánh số từ cấp cao nhất xuống từng nhánh. Cấp cao nhất được đánh số trước, sau đó toàn bộ nhánh đầu tiên bên dưới cấp cao nhất được đánh số, tiếp đến là nhánh thứ hai, v.v.
- Sheets Hierarchical Structure - Breadth First - các trang được đánh số theo cấp của chúng trong hệ thống phân cấp. Cấp cao nhất được đánh số trước, tiếp theo là tất cả các trang ở cấp thứ hai, v.v.
Các tùy chọn Select Numbering Method cho phép chọn các giá trị tuần tự Increasing hoặc Decreasing .
Đánh số tài liệu tự động
Nhấp vào danh sách thả xuống Auto Document Number để truy cập các tùy chọn đánh số tài liệu. Về cơ bản, chúng giống với các tùy chọn Auto Sheet Number nhưng có thêm các giá trị Prefix và Postfix .
Các tùy chọn Parameters như sau:
-
Prefix - chọn tiền tố để đặt trước số tài liệu. Hỗ trợ tiền tố dạng chữ cái (
A,B,C, v.v.), dạng số (1,2,3, v.v.) và dạng phi số (_,*,.,%, v.v.), bao gồm cả sự kết hợp giữa các dạng này. - Start - chọn giá trị số bắt đầu đánh số.
-
Postfix - chọn hậu tố để thêm vào sau số tài liệu. Hỗ trợ hậu tố dạng chữ cái (
A,B,C, v.v.), dạng số (1,2,3, v.v.) và dạng phi số (_,*,.,%, v.v.), bao gồm cả sự kết hợp giữa các dạng này. - Step - chọn giá trị tăng thêm cho mỗi số tài liệu. Ví dụ: nếu chỉ số Start được đặt thành 1 và giá trị Step được đặt thành 100, số tài liệu đầu tiên sẽ là 1, số tiếp theo sẽ là 101 (Giá trị bắt đầu + Bước tăng), tiếp theo là 201, v.v.
Cập nhật số lượng trang
Nhấp vào nút Update Sheet Count để đếm tổng số trang trong dự án hiện tại và điền kết quả vào cột SheetTotal. Số lượng trang là tổng số trang trong dự án, bất kể quy tắc đánh số được chọn trong hai mục điều khiển trước đó.
Di chuyển lên/xuống
Sử dụng các nút Move Up hoặc Move Down để di chuyển tài liệu sơ đồ nguyên lý đã chọn lên hoặc xuống trong danh sách. Thao tác này có ý nghĩa khi sử dụng quy tắc đánh số Display Order để chỉ định số trang hoặc số tài liệu.
Đánh số/đặt tên tùy chỉnh
Nếu tổ chức có hệ thống đánh số hoặc đặt tên riêng không thể tự động hóa bằng lệnh Auto Sheet Number hoặc Auto Document Number, bạn có thể nhập trực tiếp tên và số trang tùy chỉnh vào các trường SheetNumber hoặc DocumentNumber .
Đánh số trang sơ đồ nguyên lý và Device Sheets
Không thể cấu hình số trang hoặc số tài liệu cho Device Sheets khi chúng ở chế độ chỉ đọc (trạng thái mặc định). Các trang này sẽ được gạch chéo trong hộp thoại Đánh số trang cho dự án để cho biết không thể cập nhật chúng. Khi Device Sheets được đặt ở chế độ có thể chỉnh sửa, phần gạch chéo sẽ được loại bỏ và bạn có thể cấu hình số trang và số tài liệu như bình thường.
Kiểm soát cách hiển thị ký hiệu định danh trên PCB
Các chuỗi ký hiệu định danh mở rộng trong thiết kế đa kênh có thể khó bố trí trong Trình chỉnh sửa PCB. Bạn có thể chọn các tùy chọn đặt tên để tạo ra tên ngắn hoặc hiển thị ký hiệu định danh logic ban đầu của linh kiện. Ví dụ: C30_CIN1 sẽ hiển thị thành C30. Khi đó, cần thêm một số ký hiệu khác lên bo mạch để phân biệt các kênh, chẳng hạn như vẽ khung bao quanh từng kênh trên lớp in ký hiệu linh kiện.
Bạn có thể chọn hiển thị ký hiệu định danh logic hoặc vật lý trên PCB bằng danh sách thả xuống Designator Display trong vùng Other của bảng Properties ở chế độ Board . Nếu bạn chọn hiển thị ký hiệu định danh logic cho các linh kiện trong thiết kế đa kênh, các ký hiệu này sẽ xuất hiện trên PCB và trong mọi đầu ra được tạo, chẳng hạn như bản in và tệp Gerber. Tuy nhiên, các ký hiệu định danh vật lý duy nhất luôn được sử dụng khi tạo bảng kê vật tư.
Đồng bộ hóa thiết kế - Hoàn tất quá trình đánh số linh kiện
Đồng bộ hóa thiết kế trực tiếp là phương pháp ưu tiên để giữ cho ký hiệu định danh trên sơ đồ nguyên lý và PCB khớp nhau, trừ khi bạn không thể truy cập cả Trình chỉnh sửa sơ đồ nguyên lý lẫn Trình chỉnh sửa PCB. Tính năng Đồng bộ hóa thiết kế so sánh trực tiếp các linh kiện và kết nối của sơ đồ nguyên lý với PCB, từ đó tạo ra danh sách các khác biệt. Danh sách các thay đổi cần thiết để khắc phục những khác biệt này được tạo dưới dạng ECO (Lệnh thay đổi kỹ thuật). Tệp ECO mô tả các khác biệt giữa thiết kế hiện tại và thiết kế mong muốn, đồng thời có thể được thực thi để cập nhật thiết kế đích và đồng bộ hóa thiết kế.
Đồng bộ hóa thuận và đồng bộ hóa ngược
Các thuật ngữ Đồng bộ hóa thuận và Đồng bộ hóa ngược mô tả cụ thể hướng truyền các thay đổi về đánh số linh kiện và thiết kế trong quá trình đồng bộ hóa dữ liệu. Nếu hình dung một quy trình thiết kế bắt đầu từ sơ đồ nguyên lý và lấy sơ đồ nguyên lý làm cơ sở, thì Đồng bộ hóa thuận là quá trình cập nhật các thay đổi được thực hiện trong Trình chỉnh sửa sơ đồ nguyên lý sang PCB. Đồng bộ hóa ngược là quá trình cập nhật các thay đổi được thực hiện trên PCB trở lại Trình chỉnh sửa sơ đồ nguyên lý.
Đồng bộ hóa thuận
Một số lý do cần đồng bộ hóa dữ liệu từ sơ đồ nguyên lý sang PCB:
- Một linh kiện mới được thêm trong Trình chỉnh sửa sơ đồ nguyên lý và cần được đưa vào bố trí PCB.
- Bạn đã đánh số linh kiện cho thiết kế sơ đồ nguyên lý lần đầu tiên hoặc sau lần đồng bộ hóa thiết kế gần nhất.
- Trong thiết kế đa kênh, bạn đã thay đổi Project Options để sửa kiểu đặt tên vật lý (PCB).
- Bạn đã thực hiện đánh số linh kiện ở cấp bo mạch lần đầu tiên hoặc sau lần đồng bộ hóa thiết kế gần nhất.
Đồng bộ hóa thuận từ thiết kế sơ đồ nguyên lý sang thiết kế PCB
Chọn một trong các phương pháp sau để đồng bộ hóa thuận từ thiết kế sơ đồ nguyên lý sang thiết kế PCB:
- Chọn Update PCB Document trên menu Design trong Trình chỉnh sửa sơ đồ nguyên lý. Nếu có bất kỳ khác biệt nào giữa các tài liệu này và tài liệu PCB đích, hộp thoại Engineering Change Order sẽ mở ra với danh sách các sửa đổi cần thiết để đồng bộ hóa PCB với thiết kế sơ đồ nguyên lý. Nhấp vào Execute Changes để đồng bộ hóa thiết kế.
- Chọn Import Changes trên menu Design trong Trình chỉnh sửa PCB để nhập các thay đổi từ tài liệu sơ đồ nguyên lý vào tài liệu PCB.
Đồng bộ hóa ngược
Đồng bộ hóa ngược được thực hiện khi bạn đã đánh số linh kiện hoặc thay đổi thiết kế PCB và muốn cập nhật thiết kế sơ đồ nguyên lý.
Đồng bộ hóa ngược từ thiết kế PCB về thiết kế sơ đồ nguyên lý
Chọn một trong các phương pháp sau để đồng bộ hóa ngược từ thiết kế PCB về thiết kế sơ đồ nguyên lý:
-
trong Trình chỉnh sửa PCB, chọn Update Schematics trên menu Design . Theo mặc định, tùy chọn Push Component Designator Changes to Annotation File (if any) trong tab Tạo ECO của hộp thoại Project Options được chọn để các thay đổi được thực hiện trong Trình chỉnh sửa PCB chỉ được chuyển vào tệp đánh số linh kiện và cuối cùng được áp dụng vào các tài liệu đã biên dịch khi biên dịch. Bỏ chọn tùy chọn này để chỉ chuyển các thay đổi vào tài liệu sơ đồ nguyên lý nguồn (chế độ xem Editor ).
- Từ trình chỉnh sửa sơ đồ nguyên lý, chọn Tools » Annotation » Annotate Schematics rồi nhấp vào nút Back Annotate trong hộp thoại Đánh số linh kiện. Chọn tệp WAS-IS được tạo khi đánh số lại các ký hiệu định danh trong môi trường PCB.
- Từ trình chỉnh sửa sơ đồ nguyên lý, chọn Tools » Annotation » Board Level Annotate rồi nhấp vào nút Back Annotate trong hộp thoại Đánh số linh kiện ở cấp bo mạch. Chọn tệp WAS-IS được tạo khi đánh số lại các ký hiệu định danh trong môi trường PCB.
- Từ trình chỉnh sửa sơ đồ nguyên lý, chọn Tools » Annotation » Back Annotate Schematics. Chọn tệp WAS-IS được tạo khi đánh số lại các ký hiệu định danh trong môi trường PCB.
Các phương pháp đồng bộ hóa thiết kế truyền thống
Altium Designer hỗ trợ phương pháp Đồng bộ hóa thiết kế truyền thống thông qua tệp trung gian (netlist và WAS/IS). Có thể đồng bộ hóa xuôi dữ liệu đánh số linh kiện bằng tệp netlist và đồng bộ hóa ngược bằng tệp WAS/IS (liệt kê từng ký hiệu định danh trước đây WAS và hiện tại IS). Phương pháp được khuyến nghị để đồng bộ hóa thiết kế là Đồng bộ hóa thiết kế trực tiếp.
Liên kết linh kiện bằng mã định danh duy nhất
Nếu bạn đã đánh số lại linh kiện trong thiết kế, các ký hiệu định danh linh kiện trên sơ đồ nguyên lý hoặc các ký hiệu định danh linh kiện sau khi biên dịch sẽ không còn khớp với các ký hiệu định danh linh kiện trên PCB, vì vậy cần đồng bộ hóa để hoàn tất thiết kế. Thay vì dựa vào chính ký hiệu định danh làm trường khóa liên kết một ký hiệu trên sơ đồ nguyên lý với footprint PCB tương ứng, Altium Designer có thể duy trì việc đồng bộ hóa thiết kế thông qua hệ thống mã định danh duy nhất (UID). UID là giá trị do hệ thống tạo ra để xác định duy nhất linh kiện nguồn và đối chiếu từng linh kiện trên sơ đồ nguyên lý với linh kiện PCB tương ứng.
Khi một linh kiện được đặt lên trang sơ đồ nguyên lý, linh kiện đó sẽ tự động được gán một UID. Lần đầu tiên thông tin linh kiện được chuyển từ các tài liệu sơ đồ nguyên lý nguồn sang một PCB trống, thông tin UID của từng linh kiện trên sơ đồ nguyên lý sẽ được gán cho linh kiện PCB tương ứng.
Chức năng tái cấu trúc cho phép bạn chuyển đổi Trang thiết bị thành Trang sơ đồ nguyên lý và ngược lại, đồng thời giữ nguyên mã định danh duy nhất của trang và các linh kiện trên đó. Ngoài ra, bạn có thể tái cấu trúc (hoặc di chuyển) các mạch con sang các trang sơ đồ nguyên lý khác trong dự án hiện tại mà vẫn giữ nguyên mã định danh duy nhất của mạch con. Lệnh Refactor nằm trong menu Edit .
Tính năng đồng bộ hóa của Altium Designer, được khởi chạy bằng lệnh Design » Update, sử dụng các UID này để đối chiếu từng linh kiện trên sơ đồ nguyên lý với linh kiện PCB tương ứng. Sau đó, có thể áp dụng các cập nhật/thay đổi thiết kế bằng Lệnh thay đổi kỹ thuật (ECO). Một ECO liệt kê tất cả các sửa đổi cần thiết để áp dụng thay đổi cho một hoặc nhiều tài liệu thiết kế nhằm đáp ứng thao tác đồng bộ hóa được yêu cầu. ECO được sử dụng để áp dụng các cập nhật thiết kế trong nhiều tình huống, chẳng hạn như:
- Cập nhật thiết kế từ sơ đồ nguyên lý (SCH) sang PCB.
- Thực hiện cập nhật đánh số linh kiện cho các ký hiệu định danh linh kiện trên sơ đồ nguyên lý và các ký hiệu định danh linh kiện sau khi biên dịch.
- Áp dụng các cập nhật tham số bằng Parameter Manager (Tools » Parameter Manager).
- Cập nhật thông tin tham số bằng thông tin được lưu trong thư viện nguồn hoặc cơ sở dữ liệu của công ty. Bất cứ khi nào bạn so sánh sơ đồ nguyên lý và PCB (chẳng hạn khi chọn Design » Update), trước tiên Altium Designer sẽ đối chiếu các linh kiện có cùng UID. Khi phát hiện các linh kiện không có cùng UID, ứng dụng sẽ thông báo cho bạn và đề nghị thử đối chiếu theo ký hiệu định danh. Bạn sẽ tiếp tục nhận được thông báo này cho đến khi gán UID trùng khớp cho cả sơ đồ nguyên lý và PCB. Các mã định danh duy nhất và mối tương quan giữa chúng được quản lý trong hộp thoại Chỉnh sửa liên kết linh kiện (Project » Component Links).
Lưu ý rằng chỉ có thể mở hộp thoại này khi một tài liệu PCB đang hoạt động, vì các thay đổi UID luôn được áp dụng cho PCB thay vì sơ đồ nguyên lý. Bạn có thể sử dụng hộp thoại này ở bất kỳ giai đoạn nào trong quá trình thiết kế để xem liên kết giữa các linh kiện, xác minh rằng các linh kiện giữa các tài liệu được đối chiếu chính xác, cũng như gán các UID trùng khớp cho những linh kiện hiện chưa được đối chiếu.
