Thiết kế bó dây
Sơ lược
- Bạn sẽ hiểu những gì Altium Designer hỗ trợ trong thiết kế bộ dây điện, từ kết nối giữa các chân đến tài liệu sản xuất.
- Bạn sẽ thấy cách tổ chức một dự án bộ dây điện, bao gồm sơ đồ đấu dây, bản vẽ bố trí, dữ liệu BOM, tài liệu Draftsman và các tác vụ xuất đầu ra.
- Bạn sẽ biết cách sử dụng dự án bộ dây điện độc lập hoặc như một phần của dự án nhiều bo mạch, bao gồm các cách cơ bản để thêm và quản lý chúng.
Chức năng thiết kế bộ dây điện cho phép các kỹ sư thuộc nhiều chuyên môn khác nhau (tham gia vào quy trình thiết kế sản phẩm) làm việc trong Altium Designer. Chức năng này tích hợp khả năng hỗ trợ thiết kế bộ dây điện toàn diện vào cùng môi trường thiết kế PCB và hệ thống, loại bỏ sự phụ thuộc lớn vào phần mềm bên thứ ba như trước đây.
Chức năng thiết kế bộ dây điện cho phép bạn tạo một thiết kế bộ dây điện hoàn chỉnh, từ các kết nối riêng lẻ giữa các chân đến tài liệu sản xuất. Thiết kế bộ dây điện có thể được tạo dưới dạng một dự án độc lập hoặc là một phần của dự án đa bo mạch. Trong trường hợp thứ hai, các kết nối logic giữa các PCB trong dự án đa bo mạch sẽ xác định các kết nối bên trong bộ dây điện.
Cấu trúc của dự án thiết kế bộ dây điện
Bạn có thể tạo một dự án thiết kế bộ dây điện mới (*.PrjHar) theo cách tương tự như dự án thiết kế PCB hoặc đa bo mạch. Chọn lệnh File » New » Project từ các menu chính để mở hộp thoại Create Project. Chọn mục <Empty> hoặc một mẫu dự án có sẵn bên dưới mục Harness trong vùng Project Type của hộp thoại.
Một dự án thiết kế bộ dây điện hỗ trợ các tài liệu sau:
-
Sơ đồ đấu dây bộ dây điện (
*.WirDoc) – các dây dẫn và cáp riêng lẻ được đặt để tạo những kết nối vật lý cần thiết bên trong bộ dây điện. -
Bản vẽ bố trí bộ dây điện (
*.LdrDoc) – các dây dẫn và cáp được sắp xếp để thể hiện cấu trúc vật lý của bộ dây điện. -
ActiveBOM (
*.BomDoc) – chứa các đối tượng sau:-
Đầu nối và các bộ phận đi kèm
-
Các bộ phận đi kèm của mối nối dây
-
Các bộ phận đi kèm của điểm kết nối
-
Các hốc chân cắm
-
Nhãn bố trí
-
Vật liệu bọc bộ dây điện
-
Dây dẫn và cáp, cùng với giá trị chiều dài tương ứng
-
-
Tài liệu Draftsman (
*.HarDwf) – các hình biểu diễn chỉ đọc của sơ đồ đấu dây, bản vẽ bố trí và BOM được nhập vào, đồng thời mọi thông tin bổ sung cần thiết để sản xuất bộ dây điện cũng được thêm vào. -
Tệp Output Job (
*.OutJob) – bạn có thể cấu hình trước một tập hợp các đầu ra cần thiết cho thiết kế bộ dây điện bằng tệp Output Job. Mỗi đầu ra được cấu hình với các thiết lập và định dạng đầu ra riêng, ví dụ như xuất ra tệp hoặc máy in. Sau đó, bạn có thể tái sử dụng cùng một tệp Output Job đã cấu hình cho dự án thiết kế bộ dây điện giữa các thiết kế, giúp tiết kiệm thời gian và công sức chuẩn bị đầu ra cho mỗi thiết kế mới.Các đầu ra được hỗ trợ cho thiết kế bộ dây điện
Documentation Outputs
-
Bản in sơ đồ đấu dây bộ dây điện
-
Bản in bản vẽ bố trí bộ dây điện
-
Draftsman
Tìm hiểu thêm về Chuẩn bị dữ liệu in
Report Outputs
-
Danh mục vật tư
-
So sánh BOM
-
Dữ liệu sản xuất
-
Xuất nhận xét
Tìm hiểu thêm về Chuẩn bị báo cáo
Validation Outputs
-
Kiểm tra BOM
-
Trạng thái linh kiện
-
Tuân thủ cấu hình
Tìm hiểu thêm về Chuẩn bị báo cáo xác thực
PostProcess Outputs
-
Sao chép tệp
Tìm hiểu thêm về Chuẩn bị đầu ra hậu xử lý
-
Thêm dự án thiết kế bộ dây điện vào dự án đa bo mạch
Một dự án thiết kế bộ dây có thể (nhưng không bắt buộc) được đưa vào làm một phần của dự án đa bo mạch. Để thực hiện, hãy mở một dự án đa bo mạch có tài liệu sơ đồ nguyên lý chứa ít nhất một đối tượng kết nối bộ dây. Đảm bảo đã hoàn tất việc định nghĩa bộ dây: đã gán các linh kiện đầu nối bộ dây, chỉ định các kết nối đầu nối bộ dây ↔ chân PCB và các kết nối đầu nối bộ dây ↔ đầu nối bộ dây.
Thêm dự án bộ dây vào dự án đa bo mạch bằng cách nhấp chuột phải vào mục dự án đa bo mạch trong bảng Projects, chọn Add Existing to Project, sau đó duyệt đến và chọn tệp *.PrjHar cục bộ. Dự án bộ dây sẽ xuất hiện trong bảng Projects, bên trong cấu trúc dự án đa bo mạch.
Tạo thiết kế bộ dây – Hướng dẫn ví dụ
Các phần có thể thu gọn bên dưới cung cấp hướng dẫn từng bước để tạo từ đầu một thiết kế bộ dây đơn giản gồm ba linh kiện.
Tạo dự án thiết kế bộ dây
-
Chọn lệnh File » New » Project từ các menu chính.
-
Hộp thoại Create Project sẽ mở ra. Trong hộp thoại này:
-
Trong danh sách Locations, chọn mục tương ứng với Workspace của bạn (hoặc mục Local Projects nếu bạn không sử dụng Workspace).
-
Trong danh sách Project Type, chọn mục <Empty> thuộc loại Harness.
-
Nhập tên phù hợp vào trường Project Name, ví dụ:
Harness_Project. -
Thiết lập các tùy chọn khác ở phía bên phải hộp thoại theo yêu cầu (ví dụ: thư mục lưu trữ).
-
-
Nhấp vào nút
ở góc dưới bên phải hộp thoại để đóng hộp thoại và tạo dự án.
Một mục dành cho dự án mới, Harness_Project.PrjPCB, sẽ xuất hiện trong bảng Projects.
Định nghĩa sơ đồ đi dây
Main page: Định nghĩa sơ đồ đi dây
-
Nhấp chuột phải vào mục dự án trong bảng Projects, sau đó chọn lệnh Add New to Project » Harness Wiring Diagram từ menu ngữ cảnh. Một trang sơ đồ đi dây trống có tên
Harness Wiring Diagram1.WirDocsẽ mở ra trong không gian thiết kế và một mục dành cho tài liệu này sẽ xuất hiện, được liên kết với dự án trong bảng Projects, bên dưới mục Source Documents. -
Để lưu tài liệu sơ đồ đi dây mới trên máy cục bộ, chọn lệnh Save As từ menu chuột phải của mục tài liệu trong bảng Projects. Hộp thoại Save As sẽ mở ra, sẵn sàng lưu tài liệu tại cùng vị trí với tệp dự án. Nhập tên
Harness Wiring Diagramvào trường File name và nhấp vào nút Save. -
Do một tài liệu mới đã được thêm vào dự án nên tệp dự án đã thay đổi. Nhấp chuột phải vào mục dự án trong bảng Projects rồi chọn Save từ menu ngữ cảnh để lưu dự án trên máy cục bộ.
-
Đặt các linh kiện đầu nối lên sơ đồ đấu dây. Thông thường, bạn sẽ sử dụng các linh kiện từ thư viện riêng, được truy cập qua bảng Components. Trong ví dụ này, các mô hình đi kèm với linh kiện của nhà sản xuất sẽ được sử dụng trực tiếp.
-
Mở bảng Manufacturer Part Search. Để thực hiện, nhấp vào nút
ở góc dưới bên phải không gian thiết kế rồi chọn Manufacturer Part Search từ menu.
-
Trong trường Search ở đầu bảng, nhập
SLW-107-0-1-G-Srồi nhấnEnter. Kết quả tìm kiếm sẽ được hiển thị trong bảng. Ví dụ này cần một linh kiện có mô hình ký hiệu sơ đồ nguyên lý. Các linh kiện có mô hình được đánh dấu bằng biểu tượng
trong danh sách.
-
Chọn linh kiện tìm được, nhấp chuột phải vào linh kiện đó rồi chọn lệnh Place từ menu ngữ cảnh. Con trỏ sẽ tự động di chuyển vào trong phạm vi sơ đồ đấu dây và chuyển thành hình chữ thập, với ký hiệu đầu nối gắn theo con trỏ. Lúc này bạn đang ở chế độ đặt linh kiện. Khi bạn di chuyển con trỏ, đầu nối sẽ di chuyển theo.
Do not place the connector yet!
-
Khi đầu nối vẫn đang gắn theo con trỏ, nhấn phím
Tabđể mở bảng Properties. Là trường được sử dụng nhiều nhất, trường Designator sẽ tự động được tô sáng trong bảng, sẵn sàng để chỉnh sửa. -
Nhập
P1vào trường Designator và xác nhận rằng tùy chọn hiển thị của trường Comment được đặt thành hiển thị (có dạng
-
Giữ nguyên giá trị mặc định của tất cả các trường khác, sau đó nhấp vào nút tạm dừng trong không gian thiết kế để quay lại thao tác đặt linh kiện.
-
Sử dụng
Spacebarđể xoay linh kiện 90 độ và các phímXvàYđể lật linh kiện theo chiều ngang và chiều dọc tương ứng. -
Di chuyển con trỏ đang gắn ký hiệu đầu nối để đưa đầu nối đến phần trên bên phải của trang. Khi đã hài lòng với vị trí của linh kiện, nhấp để đặt linh kiện vào tài liệu.
-
Di chuyển con trỏ và bạn sẽ thấy một bản sao của đầu nối đã được đặt trong tài liệu, đồng thời bạn vẫn đang ở chế độ đặt linh kiện với ký hiệu đầu nối gắn theo con trỏ. Tính năng này cho phép bạn đặt nhiều bản sao của cùng một linh kiện.
-
Bạn đã sẵn sàng đặt đầu nối thứ hai. Đầu nối này giống đầu nối trước nên không cần chỉnh sửa các thuộc tính trước khi đặt. Altium Designer sẽ tự động tăng số trong ký hiệu định danh linh kiện khi bạn đặt nhiều bản sao của cùng một linh kiện. Trong trường hợp này, đầu nối tiếp theo sẽ tự động được gán ký hiệu P2.
-
Đặt đầu nối thứ hai và thứ ba theo hình bên dưới.
-
Sau khi đã đặt tất cả đầu nối, thoát chế độ đặt linh kiện bằng cách nhấp chuột phải hoặc nhấn phím
Esc. Con trỏ sẽ trở lại hình mũi tên thông thường.
-
-
Các chân linh kiện được kết nối bằng dây dẫn vật lý.
-
Chọn lệnh Place » Harness Wire từ các menu chính.
-
Nhấp vào điểm kết nối của chân P1-1 (một dấu chữ thập màu đỏ xuất hiện tại con trỏ khi con trỏ nằm trên điểm kết nối của chân) để đặt điểm đầu của dây, sau đó nhấp vào điểm kết nối của chân P2-1 để đặt điểm cuối của dây.
-
Tương tự, kết nối các chân khác của P1 và P2 (P1-2 ↔ P2-2, P1-3 ↔ P2-3, v.v.).
-
Sau khi đã đặt các dây, nhấp chuột phải để thoát lệnh.
-
-
Cần nối thêm dây vào các dây đã đặt. Trong những trường hợp như vậy, trước tiên cần đặt một mối nối hoặc điểm rẽ nhánh. Ví dụ này sẽ sử dụng các mối nối.
-
Chọn lệnh Place » Splice từ các menu chính.
-
Nhấn phím
Tabđể mở bảng Properties và chỉnh sửa các thuộc tính của mối nối. -
Nhập
SPL1vào trường Designator của bảng Properties. -
Nhấp vào nút tạm dừng trong không gian thiết kế để quay lại thao tác đặt mối nối.
-
Đặt năm mối nối trên các dây đã đặt trước đó, như trong hình bên dưới. Mỗi dây sẽ được mối nối chia thành hai đoạn.
-
Sau khi đã đặt các mối nối, nhấp chuột phải để thoát lệnh.
-
-
Đặt thêm các dây (Place » Harness Wire) giữa các mối nối đã đặt và các chân của P3, như trong hình bên dưới.
-
Đặt thêm các dây không kết nối vào chân P3-6 và P3-7 rồi đánh dấu chúng là không kết nối.
-
Chọn lệnh Place » Harness Wire từ các menu chính.
-
Nhấp vào điểm kết nối của chân P3-6 để đặt điểm đầu của dây, sau đó nhấp vào một điểm trong không gian thiết kế ở bên trái chân, cách xa các đối tượng khác, để đặt điểm cuối của dây, như minh họa bên dưới.
-
Nhấp chuột phải để hoàn tất việc đặt dây. Lưu ý rằng đầu dây không kết nối được biểu thị bằng một hình vuông đặc.
-
Nhấp vào điểm kết nối của chân P3-7 để đặt điểm đầu của dây, sau đó nhấp vào một điểm trong không gian thiết kế ở bên trái chân, cách xa các đối tượng khác, để đặt điểm cuối của dây, như minh họa bên dưới.
-
Nhấp chuột phải để hoàn tất việc đặt dây.
-
Vì không nên để đầu dây ở trạng thái không kết nối, cần đặt các đối tượng đánh dấu không kết nối tại các đầu dây không kết nối. Chọn lệnh Place » No Connect từ các menu chính.
-
Trong khi đặt, nhấn
Spacebarđể đặt vị trí tên của đối tượng không kết nối. -
Đặt một đối tượng không kết nối (
Nc1vàNc2) tại mỗi đầu dây chưa được kết nối.
-
-
Cấu hình cách hiển thị dây giữa chân P1-1 và mối nối SPL1. Nhấp đúp vào dây trong không gian thiết kế để mở bảng Properties.
-
Đặt Designator của dây thành
W1-A. -
Ẩn chú thích của dây bằng cách nhấp vào biểu tượng hiển thị ở bên phải trường Comment (biểu tượng phải có dạng
-
Đặt màu đỏ cho dây bằng cách nhấp vào ô màu trong cột Giá trị của tham số Color trong vùng Parameters rồi chọn màu trong cửa sổ bật lên.
-
-
Cấu hình cách hiển thị các dây khác đã đặt, như trong hình bên dưới.
-
Lưu tài liệu sơ đồ đấu dây vào máy bằng cách nhấp chuột phải vào mục tương ứng trong bảng Projects rồi chọn Save từ menu ngữ cảnh.
-
Đóng tài liệu sơ đồ đấu dây bằng cách nhấp chuột phải vào mục tương ứng trong bảng Projects rồi chọn Close từ menu ngữ cảnh.
Tạo bản vẽ bố trí
Main page: Tạo bản vẽ bố trí
-
Nhấp chuột phải vào mục dự án trong bảng Projects rồi chọn lệnh Add New to Project » Harness Layout Drawing từ menu ngữ cảnh.
Một trang bản vẽ bố trí trống có tên
Harness Layout Drawing1.LdrDocsẽ mở trong không gian thiết kế, và một mục cho tài liệu này sẽ xuất hiện, được liên kết với dự án trong bảng Projects bên dưới mục Source Documents. -
Để lưu tài liệu bản vẽ bố trí mới vào máy, chọn lệnh Save As từ menu chuột phải của mục tài liệu trong bảng Projects. Hộp thoại Save As sẽ mở, sẵn sàng lưu tài liệu vào cùng vị trí với tệp dự án. Nhập tên
Harness Layout Drawingvào trường File name rồi nhấp nút Save. -
Do một tài liệu mới đã được thêm vào dự án nên tệp dự án đã thay đổi. Nhấp chuột phải vào mục dự án trong bảng Projects rồi chọn Save từ menu ngữ cảnh để lưu dự án vào máy.
-
Chọn lệnh Design » Import Wiring Diagram từ các menu chính để nhập dữ liệu thiết kế từ sơ đồ đấu dây. Các đầu nối sẽ được chèn vào trang bản vẽ bố trí tại các vị trí tương đối được xác định trong sơ đồ đấu dây. Các điểm kết nối liên kết với đầu nối cũng sẽ được đặt cạnh từng đầu nối trên bản vẽ bố trí.
-
Đối với điểm kết nối liên kết với đầu nối P3, chỉ nên chọn các chân 1-5. Chọn điểm kết nối CP_P3 và bỏ chọn các chân 6 và 7 trong danh sách thả xuống Pins của mục P3 trong vùng Assigned Objects của bảng Properties.
-
Các kết nối vật lý được xác định dưới dạng bó dây. Mỗi bó dây phải bắt đầu và kết thúc tại một điểm kết nối. Trước tiên, đặt một bó dây bắt đầu tại CP_P1 và kết thúc tại CP_P2.
-
Chọn lệnh Place » Harness Bundle từ các menu chính.
-
Nhấp vào một điểm kết nối (dấu chữ thập màu đỏ xuất hiện tại con trỏ khi con trỏ nằm trên điểm kết nối của chân) để đặt điểm bắt đầu của bó dây, sau đó nhấp vào một điểm kết nối khác để đặt điểm kết thúc của bó dây.
-
Nhấp chuột phải để thoát lệnh và xác nhận việc đặt bó dây.
-
-
Chọn bó dây đã đặt trong không gian thiết kế để xem các thuộc tính của nó trong bảng Properties. Có thể xem các dây trong bó dây ở danh sách Bundle Objects. Lưu ý rằng bó dây bao gồm các dây W6 và W7 vì đây là hai dây duy nhất kết nối trực tiếp P1 và P2.
-
Để các dây giữa các chân 1-5 của P1 và P2 được đưa vào bó dây, các mối nối (đã được đặt trong sơ đồ đấu dây) phải được đưa vào bản vẽ bố trí. Đặt một điểm kết nối (CP1) lên bó dây bằng lệnh Place » Connection Point từ các menu chính. Thao tác này chia bó dây ban đầu thành hai bó dây riêng biệt.
-
Đặt một bó dây giữa các điểm kết nối CP1 và CP_P3.
-
Chọn CP1 và xác nhận rằng từng mối nối (SPL1, SPL2, SPL3, SPL4 và SPL5) đều được gán cho điểm này.
-
Giờ đây, mỗi bó dây sẽ tự động chứa đúng các dây cần thiết. Ví dụ: chọn bó dây giữa các điểm kết nối CP_P1 và CP1 để thấy rằng bó dây hiện chứa các dây W1-A, W2-A, W3-A, W4-A, W5-A, W6 và W7.
-
Khi bó dây giữa các điểm kết nối CP_P1 và CP1 được chọn trong không gian thiết kế, hãy cấu hình các thuộc tính của nó trong bảng Properties như sau:
-
Đặt Designator của bó dây thành
B1. -
Ẩn chú thích của bó dây bằng cách nhấp vào biểu tượng hiển thị ở bên phải trường Comment (biểu tượng phải có dạng
-
Đặt Length của bó dây thành
50mm.
-
-
Tương tự, cấu hình các thuộc tính của hai bó dây còn lại.
-
Đối với bó dây giữa các điểm kết nối CP1 và CP_P2, đặt Designator của bó dây thành
B2, tắt hiển thị Comment của bó dây và đặt Length của bó dây thành65mm. -
Đối với bó dây giữa các điểm kết nối CP1 và CP_P3, đặt Designator của bó dây thành
B3, tắt hiển thị Comment của bó dây và đặt Length của bó dây thành50mm.
Sau khi áp dụng các thay đổi, bản vẽ bố trí sẽ có dạng như bên dưới.
-
-
Có thể thay đổi ký hiệu của điểm kết nối để cải thiện hình thức hiển thị. Khi điểm kết nối CP1 được chọn, hãy thay đổi Style của nó thành Insulator trong vùng Properties của bảng Properties.
-
Các dây riêng lẻ có thể được biểu diễn trong bản vẽ bố trí dưới dạng các bó dây chỉ chứa một dây.
-
Đặt hai điểm kết nối (CP2 và CP3) cạnh đầu nối P3.
-
Chọn CP2 và nhấp vào nút
trong vùng Assigned Objects của bảng Properties.
-
Trong hộp thoại Add Assigned Objects vừa mở, tắt Show only unassigned objects, chọn mục tương ứng với đầu nối P3 rồi nhấp vào
.
-
Trong bảng Properties, chọn chân 6 của P3.
-
Chọn CP3 và nhấp vào nút
trong vùng Assigned Objects của bảng Properties.
-
Trong hộp thoại Add Assigned Objects vừa mở, tắt Show only unassigned objects, chọn mục tương ứng với đầu nối P3 rồi nhấp vào
.
-
Trong bảng Properties, chọn chân 7 của P3.
-
Đặt thêm hai điểm kết nối (CP4 và CP5).
-
Chọn CP4 và nhấp vào nút
trong vùng Assigned Objects của bảng Properties.
-
Trong hộp thoại Add Assigned Objects vừa mở, chọn mục tương ứng với đối tượng không kết nối Nc1 rồi nhấp vào
.
-
Chọn CP5 và nhấp vào nút
trong vùng Assigned Objects của bảng Properties.
-
Trong hộp thoại Add Assigned Objects vừa mở, chọn mục tương ứng với đối tượng không kết nối Nc2 rồi nhấp vào
.
-
Đặt một bó dây giữa CP2 và CP4 và một bó dây khác giữa CP3 và CP5. Bó dây thứ nhất sẽ tự động chứa dây W13 và bó dây thứ hai sẽ chứa dây W14.
-
Cấu hình thuộc tính của các bó dây đã đặt – đặt các giá trị Designator của chúng thành
B4vàB5, tắt hiển thị Comment của chúng và đặt Length của chúng thành30mm. -
Có thể thay đổi hình thức hiển thị của các bó dây và điểm kết nối để thể hiện sát hơn hình dạng thực tế của chúng.
-
-
Đặt các nhãn vật lý bằng lệnh Place » Layout Label từ các menu chính. Có thể cấu hình thuộc tính của nhãn bằng bảng Properties khi nhãn được chọn trong không gian thiết kế. Đặt nhãn lên các bó dây, đặt các giá trị Designator của chúng thành
L1,L2vàL3, đặt các giá trị Text của chúng thànhLabel A,Label BvàLabel C, đồng thời tắt hiển thị các giá trị Comment của chúng. -
Thay đổi cách biểu diễn đầu nối trên bản vẽ bố trí từ ký hiệu đồ họa sang mô hình vật lý.
-
Nhấp đúp vào đầu nối P1 trong không gian thiết kế để mở bảng Properties.
-
Trong vùng Model của bảng, đặt tùy chọn Type thành Physical Model và mở rộng vùng được thêm vào danh sách Views bên dưới.
-
Đặt Side của hình chiếu thành Front và Rotation thành 180 Degrees.
-
Trong không gian thiết kế, sử dụng
Click, Hold&Dragtrên hình chiếu linh kiện, ký hiệu định danh và chú thích để thay đổi vị trí của chúng theo yêu cầu.
-
-
Tương tự, cấu hình cách biểu diễn các đầu nối P2 và P3.
-
Lưu tài liệu bản vẽ bố trí vào máy tính bằng cách nhấp chuột phải vào mục tương ứng trong bảng Projects và chọn Save từ menu ngữ cảnh.
Kiểm tra tính hợp lệ của thiết kế bộ dây
Main page: Kiểm tra tính hợp lệ của thiết kế bộ dây
Trước khi tiếp tục, hãy kiểm tra tính hợp lệ của thiết kế bộ dây để đảm bảo các tài liệu sơ đồ đấu dây và bản vẽ bố trí không chứa vi phạm thiết kế.
-
Nhấp chuột phải vào mục dự án bộ dây trong bảng Projects và chọn lệnh Project Options từ menu ngữ cảnh. Hộp thoại Project Options sẽ mở ra.
-
Chọn tab Error Reporting của hộp thoại Project Options. Tab này liệt kê các phép kiểm tra hiện có. Các thiết lập Report Mode cho biết mức độ nghiêm trọng của các vi phạm tương ứng.
-
Đối với thiết kế ví dụ này, hãy tắt phép kiểm tra Unspecified connector cavities - no part choice for active pins (trong danh mục Violations Associated with Wiring Diagram). Để thực hiện, nhấp vào cột Report Mode của phép kiểm tra này và chọn No Report.
-
Nhấp vào OK trong hộp thoại Project Options để lưu thay đổi và đóng hộp thoại.
-
Nhấp chuột phải vào mục dự án trong bảng Projects, sau đó chọn lệnh Validate Harness Project <ProjectName> từ menu ngữ cảnh.
-
Mở bảng Messages bằng cách nhấp vào nút
ở góc dưới bên phải của không gian thiết kế và chọn Messages từ menu xuất hiện. Đảm bảo bảng chỉ chứa một thông báo: Compile successful, no errors found. -
Nếu có cảnh báo hoặc lỗi được liệt kê trong bảng Messages, hãy khắc phục các nguyên nhân gây vi phạm và kiểm tra lại để đảm bảo dự án không còn vi phạm chưa được xử lý. Nhấp đúp vào thông báo vi phạm trong bảng Messages để truy tìm chéo đến đối tượng gây vi phạm.
-
Nhấp chuột phải vào mục dự án trong bảng Projects, sau đó chọn Save từ menu ngữ cảnh để lưu các thay đổi đối với tùy chọn dự án.
-
Đóng tài liệu bản vẽ bố trí bằng cách nhấp chuột phải vào mục tương ứng trong bảng Projects và chọn Close từ menu ngữ cảnh.
Tạo bản vẽ chế tạo
Main page: Tạo bản vẽ chế tạo
-
Trước khi có thể đặt một hình chiếu vào bản vẽ chế tạo của dự án, cần thêm tài liệu ActiveBOM vào dự án. Nhấp chuột phải vào mục dự án trong bảng Projects, sau đó chọn lệnh Add New to Project » ActiveBOM từ menu ngữ cảnh.
-
Trong tài liệu ActiveBOM vừa mở, nhấp vào nút
ở phía trên để thiết lập số dòng.
-
Lưu tài liệu ActiveBOM trên máy bằng cách chọn lệnh Save As từ menu chuột phải của mục tài liệu trong bảng Projects. Hộp thoại Save As sẽ mở ra, sẵn sàng lưu tài liệu vào cùng vị trí với tệp dự án. Giữ nguyên tên và vị trí mặc định rồi nhấp Save.
-
Đóng tài liệu ActiveBOM bằng cách nhấp chuột phải vào mục tương ứng trong bảng Projects và chọn Close từ menu ngữ cảnh.
-
Nhấp chuột phải vào mục dự án trong bảng Projects và chọn lệnh Add New to Project » Draftsman Document từ menu ngữ cảnh.
-
Trong hộp thoại New Document vừa mở, chọn mẫu [Default] trong danh sách Templates và đảm bảo chọn đúng dự án và tài liệu bản vẽ bố trí (
Harness_Project.PrjHarvàHarness Layout Drawing.LdrDoc) trong các danh sách thả xuống Project và Document.
-
Nhấp OK trong hộp thoại. Một tài liệu Draftsman trống mới sẽ mở ra và mục tương ứng sẽ xuất hiện, được liên kết với dự án trong bảng Projects, bên dưới mục Source Documents.
-
Lưu tài liệu Draftsman trên máy bằng cách chọn lệnh Save As từ menu chuột phải của mục tài liệu trong bảng Projects. Hộp thoại Save As sẽ mở ra, sẵn sàng lưu tài liệu vào cùng vị trí với tệp dự án. Nhập
Harness Manufacturing Drawingvào trường File name rồi nhấp Save. -
Nhấp chuột phải vào mục dự án trong bảng Projects, sau đó chọn lệnh Save từ menu ngữ cảnh để lưu các thay đổi đối với cấu trúc dự án.
-
Nếu bảng Properties chưa hiển thị, nhấp vào nút
ở góc dưới bên phải của không gian thiết kế và chọn Properties từ menu vừa mở. Bảng này hiển thị các thuộc tính của đối tượng được chọn; nếu không có đối tượng nào được chọn, bảng sẽ hiển thị các thuộc tính của tài liệu Draftsman.
-
Trên tab Page Options của bảng, chọn A3 từ danh sách thả xuống Sheet_Size khi chế độ Standard đang được bật cho Formatting and Size.
-
Chọn lệnh Place » Wiring Diagram View từ các menu chính.
-
Con trỏ sẽ chuyển thành hình chữ thập và hình chiếu sẽ di chuyển theo con trỏ. Di chuyển con trỏ để định vị hình chiếu ở phía trên bên trái bản vẽ. Khi đã hài lòng với vị trí của hình chiếu, nhấp để đặt hình chiếu lên bản vẽ. Có thể thay đổi vị trí sau này nếu cần bằng cách sử dụng
Click, Hold&Dragtrên hình chiếu. -
Nhấp đúp vào hình chiếu sơ đồ đấu dây đã đặt để mở các thuộc tính của nó trong bảng Properties. Trong bảng:
-
Ẩn tiêu đề của hình chiếu bằng cách nhấp vào biểu tượng hiển thị ở bên phải trường Title trong vùng Title (biểu tượng phải hiển thị là
-
Tắt tùy chọn Show Border trong vùng Properties.
-
-
Chọn lệnh Place » Layout Drawing View từ các menu chính.
-
Di chuyển con trỏ để định vị hình chiếu ở phía trên bên phải bản vẽ rồi nhấp để đặt.
-
Nhấp đúp vào hình chiếu bản vẽ bố trí đã đặt để mở các thuộc tính của nó trong bảng Properties. Trong bảng:
-
Ẩn tiêu đề của hình chiếu bằng cách nhấp vào biểu tượng hiển thị ở bên phải trường Title trong vùng Title (biểu tượng phải hiển thị là
-
Tắt tùy chọn Show Border trong vùng Properties.
-
-
Chọn lệnh Place » Bill of Materials từ các menu chính và đặt bảng BOM vào một vùng trống trên trang bản vẽ.
-
Chọn lệnh Place » Wiring List từ các menu chính và đặt bảng danh sách dây vào một vùng trống trên trang bản vẽ. Nhấp đúp vào danh sách dây để mở các thuộc tính của nó trong bảng Properties và đảm bảo tùy chọn Length Units trong vùng Units của bảng được đặt thành Document: mm.
-
Có thể đặt các chú dẫn thể hiện số thứ tự hạng mục BOM vào bản vẽ chế tạo. Để thực hiện:
-
Chọn lệnh Place » Annotations » Callout từ các menu chính.
-
Di chuột lên một đầu nối trên hình chiếu bản vẽ bố trí để một cạnh hoặc một điểm của đầu nối này được tô sáng.
-
Nhấp để xác định vị trí đầu mũi tên chú dẫn.
-
Di chuyển con trỏ ra xa đầu nối và nhấp để đặt văn bản nguồn của chú dẫn (mặc định là số thứ tự hạng mục BOM).
-
Nhấp chuột phải để hoàn tất việc đặt chú dẫn. Bạn sẽ vẫn ở chế độ đặt chú dẫn.
-
Đặt chú dẫn cho hai đầu nối còn lại trên hình chiếu như minh họa bên dưới.
-
Nhấp chuột phải để thoát chế độ đặt chú dẫn.
-
-
Đặt bảng kết nối cho từng đầu nối:
-
Chọn lệnh Place » Connection Table từ các menu chính.
-
Đặt bảng cạnh một đầu nối trên hình chiếu bản vẽ bố trí.
-
Nhấp đúp vào bảng kết nối để mở các thuộc tính của nó trong bảng Properties.
-
Trong danh sách thả xuống Component trên tab General của bảng, chọn đầu nối nằm cạnh bảng vừa đặt và đảm bảo tùy chọn Length Units được đặt thành Document: mm.
-
Lặp lại các bước trên để đặt bảng kết nối cho hai đầu nối còn lại.
-
-
Đặt các kích thước trên hình chiếu bản vẽ bố trí theo hình bên dưới.
-
Để đặt kích thước tuyến tính, chọn Place » Linear Dimension từ các menu chính. Nhấp một lần để xác định điểm tham chiếu thứ nhất, nhấp lần nữa để xác định điểm tham chiếu thứ hai, rồi nhấp lần thứ ba để đặt văn bản kích thước và các đường gióng tương ứng. Đặt thêm một kích thước tuyến tính hoặc nhấp chuột phải để thoát chế độ đặt kích thước.
-
Để đặt kích thước góc, chọn lệnh Place » Angular Dimension từ các menu chính. Nhấp một lần để xác định đường tham chiếu thứ nhất, nhấp lần nữa để xác định đường tham chiếu thứ hai, rồi nhấp lần thứ ba để thiết lập vị trí văn bản kích thước và kiểu đường kích thước góc. Đặt thêm một kích thước góc hoặc nhấp chuột phải để thoát chế độ đặt kích thước.
-
Khi chọn một kích thước đã đặt trong không gian thiết kế, bạn có thể chỉnh sửa nhiều thuộc tính của kích thước đó trong bảng Properties, bao gồm phông chữ, cấu hình văn bản/mũi tên, giá trị (ghi đè thủ công) và dung sai.
-
-
Lưu tài liệu bản vẽ chế tạo vào máy bằng cách nhấp chuột phải vào mục tương ứng trong bảng Projects và chọn Save từ menu ngữ cảnh.
-
Nếu bạn đã tạo dự án thiết kế bộ dây trong một Workspace được kết nối, hãy nhấp chuột phải vào mục dự án trong bảng Projects, chọn lệnh Save to Server từ menu ngữ cảnh, rồi nhấp vào OK trong hộp thoại Save to Server vừa mở.
).

























































