Chuẩn bị báo cáo
Updated: October 13, 2026
Bạn có thể chuẩn bị và tạo nhiều báo cáo liên quan đến dự án hoặc một tài liệu cụ thể trong dự án cho thiết kế của mình, bao gồm:
-
Danh mục vật tư – tài liệu báo cáo này cung cấp danh sách tổng quan về tất cả các linh kiện cần thiết để chế tạo sản phẩm – bao gồm cả bo mạch trần, về cơ bản là 'linh kiện' nền tảng để lắp ráp tất cả các bộ phận khác lên đó. BOM đóng vai trò hướng dẫn về những vật tư cần mua để chế tạo sản phẩm đúng theo thiết kế. Báo cáo này cũng cho phép tính toán chi phí dựa trên số lượng bo mạch cần lắp ráp trong một đợt sản xuất được yêu cầu.
Dữ liệu được trình bày trong hộp thoại Report Manager – dùng để cấu hình báo cáo Danh mục vật tư – có thể lấy từ một trong hai nguồn. Nếu có tài liệu ActiveBOM (*.BomDoc) liên kết với dự án thiết kế, tài liệu này sẽ được dùng làm nguồn dữ liệu. Nếu không, dữ liệu sẽ được trích xuất từ các tài liệu sơ đồ nguyên lý nguồn của dự án.
-
So sánh BOM – báo cáo cung cấp thông tin về các linh kiện đã thay đổi (chẳng hạn như được thêm, xóa hoặc thay thế) trong quá trình phát hành dự án Workspace.
-
Manufacturing Data – một sổ làm việc Excel duy nhất chứa dữ liệu dành cho các nhà sản xuất bộ dây điện. Sổ làm việc được tạo bao gồm bốn trang tính riêng biệt:
-
Bill of Materials – hữu ích cho việc lập báo giá nhanh.
-
Wiring List – dùng cho máy gia công dây điện.
-
Labels – bản tổng hợp các nhãn vật lý cần in cho các bó dây, dùng với máy in Zebra hoặc các máy in khác.
-
Coverings – bản tổng hợp các lớp bọc cần bọc bên ngoài các bó dây.
Nên sử dụng tài liệu ActiveBOM của dự án thiết kế bộ dây điện làm nguồn cho đầu ra Dữ liệu sản xuất.
Để biết thêm thông tin về thiết kế bộ dây điện, hãy tham khảo trang Thiết kế bộ dây điện.
-
Báo cáo tham chiếu chéo linh kiện – tạo danh sách linh kiện dựa trên trang sơ đồ nguyên lý chứa chúng trong thiết kế.
Các báo cáo Danh mục vật tư và Tham chiếu chéo linh kiện có khả năng tùy chỉnh cao nhờ công cụ tạo báo cáo chuyên dụng và mạnh mẽ, với giao diện là hộp thoại Report Manager. Sau khi nội dung báo cáo cần thiết được xác định và sắp xếp theo yêu cầu, bạn có thể tạo báo cáo – bằng cách in hoặc xuất sang một trong các định dạng tệp: CSV (phân cách bằng dấu phẩy) (*.csv), Trang tính Microsoft Excel (*.xls;*.xlsx;*.xlt;*.xltx), Định dạng tài liệu di động (*.pdf), Văn bản phân cách bằng tab (*.txt), Trang web (*.htm;*.html), Bảng tính XML (*.xml). Tệp xuất có thể được lưu ở bất kỳ vị trí nào được chỉ định. Ngoài ra, sau khi được tạo, tệp có thể được mở trong ứng dụng phần mềm tương ứng và/hoặc thêm vào dự án. Sử dụng lệnh Report từ các menu của hộp thoại Report Manager để truy cập hộp thoại Report Preview, với báo cáo đã được tải sẵn. Sử dụng các điều khiển trong cửa sổ để điều chỉnh cách hiển thị báo cáo. Nhấp vào nút Print để mở hộp thoại Print , nơi bạn có thể xác định nội dung cần in và thiết bị in sẽ nhận lệnh in. Bản xem trước báo cáo cũng có thể được xuất sang nhiều định dạng tệp khác nhau.
-
Xuất nhận xét – tạo tệp PDF chứa các nhận xét được xuất từ tài liệu dự án.
-
Lịch sử dự án – tạo tệp PDF chứa lịch sử dự án được xuất. Cấu hình đầu ra bằng hộp thoại Project History Report Configuration, trong đó bạn có thể đặt Period để xuất báo cáo: toàn bộ lịch sử dự án hoặc từ/đến một bản phát hành dự án cụ thể (hoặc mới nhất).
-
Báo cáo phân cấp dự án – tạo danh sách các tài liệu nguồn được sử dụng trong dự án. Đầu ra này không có tùy chọn thiết lập; báo cáo ASCII được ghi vào thư mục đầu ra đã chỉ định.
-
Báo cáo các net một chân – tạo báo cáo liệt kê các net chỉ có một kết nối. Đầu ra này không có tùy chọn thiết lập; báo cáo ASCII được ghi vào thư mục đầu ra đã chỉ định. Một báo cáo liệt kê tất cả các tài liệu sơ đồ nguyên lý nguồn của thiết kế theo cấu trúc phân cấp của chúng trong dự án. Tệp được tạo trực tiếp và có định dạng <ActiveDocumentName>.REP.
Có thể thêm các đầu ra báo cáo vào tệp Output Job đang hoạt động từ menu của điều khiển [Add New Report Output] trong vùng Report Outputs của tệp hoặc từ các menu con Edit » Add Report Outputs trong các menu chính.
Mặc dù các tệp OutputJob giúp đơn giản hóa việc chuẩn bị đầu ra cho thiết kế và sau đó tạo chúng bằng quy trình phát hành dự án có tính toàn vẹn cao, bạn cũng có thể tạo trực tiếp các đầu ra báo cáo cho thiết kế đang hoạt động bằng lệnh trong menu Reports chính của trình chỉnh sửa sơ đồ nguyên lý hoặc menu con Reports » Project Reports của trình chỉnh sửa PCB.
-
Vì hộp thoại Report Manager có khả năng tùy chỉnh rất cao, bạn cũng có thể sử dụng hộp thoại này để tạo báo cáo ở bất kỳ định dạng nào cần thiết, chẳng hạn như tệp gắp và đặt linh kiện cần có dữ liệu được cấu trúc theo một cách cụ thể để phù hợp với một máy gắn linh kiện nhất định.
-
Tất cả các tệp đầu ra sẽ được ghi vào thư mục đầu ra được chỉ định trong trường Output Path, trên tab Options của hộp thoại Options for Project. Theo mặc định, đường dẫn đầu ra được đặt thành một thư mục con của thư mục chứa tệp dự án và có tên là Project Outputs for <ProjectName>. Bạn có thể thay đổi đường dẫn đầu ra theo yêu cầu. Trong bảng Projects, các tệp được tạo sẽ hiển thị trong các thư mục con Generated\Text Documents (.csv, .txt, .rep) hoặc Generated\Documents (.xls, .pdf, .htm, .xml). Lưu ý rằng nếu tạo báo cáo ở định dạng khác từ cùng một tài liệu đang hoạt động, tệp báo cáo đã tạo trước đó sẽ bị ghi đè (nếu có cùng tên tệp).
-
Nếu tùy chọn Use separate folder for each output type được bật (cũng trên tab Options ), đầu ra sẽ được ghi vào một thư mục con bổ sung, có tên là Reports (ví dụ: Project Outputs for <ProjectName>\Reports). Trong bảng Projects , đầu ra sẽ xuất hiện trong các thư mục con Generated (Reports)\Text Documents (.csv, .txt, .rep) hoặc Generated (Reports)\Documents (.xls, .pdf, .htm, .xml). Điều này cho phép bạn tạo nhiều báo cáo từ cùng một tài liệu đang hoạt động mà không có tệp nào bị ghi đè.

Bản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.