Tạo lắp ráp đa bo mạch vật lý

Altium Designer hỗ trợ tạo cụm lắp ráp nhiều bo mạch, được gọi là multi-board assembly. Sau khi cấu trúc logic của hệ thống được định nghĩa trong sơ đồ nguyên lý multi-board (*.MbsDoc), thiết kế multi-board vật lý sẽ được tạo bằng cách chuyển thiết kế hệ thống vào một tài liệu multi-board assembly trống (*.MbaDoc). Quá trình này sẽ nạp biểu diễn vật lý (PCB và các multi-board assembly khác) được tham chiếu bởi từng khối logic trong sơ đồ nguyên lý multi-board vào trình biên tập multi-board assembly. Trang này trình bày về quy trình đó.

Để tìm hiểu thêm về giai đoạn thiết kế logic của một multi-board assembly, hãy tham khảo trang Ghi nhận thiết kế hệ thống logic.

Các dự án multi-board và các dự án con liên quan của chúng có thể được lưu vào một Workspace đã kết nối, nơi chúng có thể tận dụng các khả năng kiểm soát phiên bản, chia sẻ và quản lý do Altium 365 Workspace hoặc Enterprise Server Workspace cung cấp.

Để biết thông tin về cách lưu trữ và chia sẻ dự án multi-board trong một Altium 365 Workspace, hãy tham khảo trang Dự án Workspace .

Để tạo một tài liệu multi-board assembly mới:

  1. Thêm một tài liệu multi-board assembly mới (*.MbaDoc) vào dự án multi-board bằng cách nhấp chuột phải vào mục dự án trong bảng Projects, sau đó chọn Add New to Project » Multi-board Assembly từ menu ngữ cảnh.

    Mỗi dự án thiết kế multi-board chỉ có thể bao gồm một tài liệu multi-board assembly.

  2. Lưu tài liệu multi-board assembly mới (nhấp chuột phải vào mục của tài liệu đó trong bảng Projects và chọn Save As từ menu ngữ cảnh).

  3. Chuyển biểu diễn logic của hệ thống từ sơ đồ nguyên lý multi-board sang tài liệu multi-board assembly – tìm hiểu thêm.

  4. Nếu có sẵn enclosure, hãy nạp nó vào cụm lắp ráp – tìm hiểu thêm.

  5. Định vị từng phần tử trong cụm lắp ráp – tham khảo trang Định vị & Định hướng các bo mạch của bạn để tìm hiểu thêm.

  6. Kết nối các phần tử trong cụm lắp ráp bằng mate – tham khảo trang Làm việc với Mate để tìm hiểu thêm.

Một ví dụ về multi-board assembly. Nhiều PCB được kết nối được đặt bên trong một enclosure.
Một ví dụ về multi-board assembly. Nhiều PCB được kết nối được đặt bên trong một enclosure.

Opening a Multi-board Assembly Created in Altium Designer 18

Các multi-board assembly được tạo trong Altium Designer 18 phải được nhập lại do các thay đổi định dạng tệp cần thiết để hỗ trợ công cụ 3D và bộ tính năng được cải tiến. Khi mở một tài liệu multi-board assembly có định dạng cũ, hộp thoại Legacy document import sẽ mở ra.

Chọn lệnh Design » Import trong trình biên tập multi-board assembly để tạo ECO sẽ nạp lại các module con.

Lưu ý rằng do các thay đổi định dạng tệp cần thiết để hỗ trợ bộ tính năng được cải tiến và công cụ 3D, một multi-board assembly được lưu bằng phiên bản Altium Designer mới hơn sẽ không thể mở trong Altium Designer 18.

Trình biên tập Multi-board Assembly sử dụng thư viện Open CASCADE để mô hình hóa hình học của multi-board assembly. Lưu ý rằng khi mở một tài liệu multi-board assembly cũ hơn (từ phiên bản phần mềm trước đó), các mate đã tạo sẽ bị xóa (bạn có thể chọn giữ nguyên vị trí tương đối của các phần trong cụm lắp ráp hoặc đặt chúng thành một hàng). Bạn có tùy chọn tạo một bản sao lưu của phiên bản cũ đó tại thời điểm mở.

Tính năng này đang ở giai đoạn Open Beta và khả dụng khi tùy chọn System.MBAEngine.UseOpenCascade được bật trong hộp thoại Advanced Settings dialog.

Chuyển thiết kế hệ thống sang tài liệu Multi-board Assembly

Thiết kế multi-board được chuyển từ sơ đồ nguyên lý multi-board sang tài liệu multi-board assembly bằng một trong các lệnh sau:

  • Design » Update Assembly - <MultiBoardAssemblyDocumentName>.MbaDoc từ các menu chính của trình biên tập sơ đồ nguyên lý multi-board.

  • Design » Import Changes From <MultiBoardProjectName>.PrjMbd từ các menu chính của trình biên tập multi-board assembly.

Khi bạn chạy một trong các lệnh này, phần mềm sẽ kiểm tra từng module trên sơ đồ nguyên lý multi-board, xác định PCB/assembly đã được chọn cho từng dự án con và trình bày danh sách các sửa đổi cần thiết để thêm từng bo mạch đó vào cụm lắp ráp trong hộp thoại Engineering Change Order.

Bo mạch từ mỗi dự án PCB được liệt kê như một sửa đổi ECO và được nạp vào trình biên tập Multi-board Assembly khi các ECO được thực thi.
Bo mạch từ mỗi dự án PCB được liệt kê như một sửa đổi ECO và được nạp vào trình biên tập Multi-board Assembly khi các ECO được thực thi.

Khi nhấp vào nút  , các bo mạch/cụm lắp ráp sẽ được nạp vào trình biên tập multi-board assembly. Mỗi bo mạch/cụm lắp ráp được đặt trong không gian thiết kế với cùng định hướng như trong dự án con. Quá trình này sẽ mất một khoảng thời gian vì toàn bộ tập dữ liệu của từng PCB phải được phân tích và nạp.

Các bo mạch trong multi-board assembly này đã được nạp vào không gian thiết kế của trình biên tập multi-board assembly, sẵn sàng để định vị.
Các bo mạch trong multi-board assembly này đã được nạp vào không gian thiết kế của trình biên tập multi-board assembly, sẵn sàng để định vị.

  • Sử dụng các tùy chọn trên trang Multi-board Assembly – General page của hộp thoại Preferences, bạn có thể cấu hình việc có nhập các đối tượng 3D tự do từ các PCB con hay không và liệu các đối tượng 3D có chiều cao nhỏ hơn giá trị chỉ định có không được nhập hay không.

  • Sử dụng lệnh View » Toggle Units từ các menu chính (hoặc phím tắt Q) để chuyển đổi đơn vị giữa hệ inch và hệ mét.

Thêm đối tượng bổ sung vào Multi-board Assembly

Bạn cũng có thể nạp các đối tượng bổ sung vào một multi-board assembly (ngoài các PCB được tham chiếu trong sơ đồ nguyên lý multi-board). Các đối tượng bổ sung có thể được nạp bằng menu Design hoặc bằng cách sử dụng các nút nằm ở phía trên của bảng Multi-board Assembly.

Mỗi thực thể, hay mục trong multi-board assembly, được gọi là một part.

Sử dụng lệnh hoặc nút phù hợp để:

  • Insert PCB Part () – chèn một PCB khác vào cụm lắp ráp này.

  • Insert MBA Part () – chèn một multi-board assembly khác vào cụm lắp ráp này.

  • Insert STEP Part () – chèn một mô hình cơ khí định dạng STEP vào cụm lắp ráp này.

  • Lưu ý rằng một part được chèn vào multi-board assembly như một thực thể đơn lẻ. Ví dụ, nếu bạn chèn mô hình STEP cho một vỏ máy, gồm nửa trên và nửa dưới, bạn sẽ không thể thao tác độc lập với từng nửa. Trong trường hợp này, bạn cần chèn từng nửa vào cụm lắp ráp riêng biệt.

  • Assembly hoặc PCB được chèn vào sẽ not được thêm vào dự án Multi-board Design (*.PrjMbd), và do đó sẽ không hiển thị như là đối tượng con của dự án đó trong bảng Projects.

Cập nhật hoặc chỉnh sửa một Assembly Part

Khóa/Mở khóa một Part

Để khóa/mở khóa một part, chọn part mong muốn, nhấp chuột phải, sau đó chọn lệnh Lock Selected Part/Unlock Selected Part trong menu ngữ cảnh để khóa/mở khóa part (hoặc các part đã mate) tại vị trí hiện tại của nó trong không gian thiết kế của trình biên tập assembly. Ngoài ra, nhấp chuột phải vào mục part trong bảng Multiboard Assembly, rồi chọn Locked.

  • Một part đã khóa không thể chỉnh sửa/di chuyển.

  • Các part đã khóa được đánh dấu bằng biểu tượng ổ khóa trong bảng Multiboard Assembly .

  • Một part riêng lẻ đã khóa sẽ không hiển thị object gizmo (để tìm hiểu thêm về object gizmo, tham khảo trang Định vị & Định hướng các bo mạch của bạn).

  • Một part đã khóa không thể được mate nếu nó được chọn làm nguồn (đối tượng di chuyển – để tìm hiểu thêm về việc mate các part, tham khảo trang Làm việc với Mate).

Cập nhật một Part

Nếu một part hoặc đối tượng 3D được thêm vào một assembly đã được cập nhật, bản cập nhật có thể được nạp vào multi-board assembly bằng một trong các thao tác sau:

  • Chọn lệnh Edit » Update All Parts từ các menu chính hoặc nhấp chuột phải ở bất kỳ đâu trong không gian thiết kế và chọn lệnh Update All Parts từ menu ngữ cảnh (phím tắt: Shift+Ctrl+U) để cập nhật tất cả part trong multi-board assembly đang hoạt động bằng thông tin layout mới nhất từ các tài liệu PCB con tương ứng của chúng.

  • Chọn part cần thiết rồi chọn lệnh Edit » Update Selected Part từ các menu chính hoặc nhấp chuột phải ở bất kỳ đâu trong không gian thiết kế và chọn lệnh Update Selected Part từ menu ngữ cảnh (phím tắt: Ctrl+U) để cập nhật các part đã chọn trong multi-board assembly đang hoạt động bằng thông tin layout mới nhất từ các tài liệu PCB con tương ứng của chúng.

  • Chọn đối tượng 3D cần thiết rồi chọn lệnh Edit » Update Selected 3D Body từ các menu chính hoặc nhấp chuột phải ở bất kỳ đâu trong không gian thiết kế và chọn lệnh Update Selected 3D Body từ menu ngữ cảnh để cập nhật các đối tượng 3D đã chọn trong multi-board assembly đang hoạt động bằng thông tin layout mới nhất từ các tài liệu PCB con tương ứng của chúng.

Chỉnh sửa một Part

Một phiên chỉnh sửa assembly hoặc PCB có thể được khởi chạy từ trong trình biên tập multi-board assembly. Chọn part cần thiết và chạy lệnh Edit » Edit Selected Part hoặc nhấp chuột phải ở bất kỳ đâu trong không gian thiết kế rồi chọn lệnh Edit Selected Part từ menu ngữ cảnh (phím tắt: Ctrl+E). Sau khi chạy lệnh, bạn sẽ vào chế độ chỉnh sửa part, với PCB đã chọn được phóng to và căn giữa (nếu có thể) để vừa trong cửa sổ thiết kế chính. Bo mạch sẽ vẫn hiển thị với đầy đủ màu sắc, trong khi tất cả các bo mạch khác sẽ bị làm mờ xám (chỉ đọc).

Thực hiện các thay đổi đối với vị trí linh kiện khi cần, bằng cách đặt thủ công và/hoặc dùng các tính năng căn chỉnh. Sau khi hoàn tất chỉnh sửa, sử dụng lệnh Finish Part Editing (Ctrl+E). Chế độ xem của không gian thiết kế sẽ trở về trạng thái hiển thị vừa tất cả các bo mạch trong cụm lắp ráp, và bo mạch đang được chỉnh sửa sẽ vẫn được chọn.

Nếu bạn muốn hủy chỉnh sửa mà không áp dụng bất kỳ thay đổi nào, hãy dùng lệnh Cancel Part Editing .

Điều hướng và quản lý Multi-board Assembly

Để điều hướng và quản lý multi-board assembly, bạn có thể sử dụng bảng Multiboard Assembly.

Bảng này hiển thị dạng cây có thể mở rộng của toàn bộ cấu trúc cụm lắp ráp, bao gồm:

  • Các bo mạch (PCB) và multi-board assembly được bao gồm cùng với các component, layer và net bên trong mỗi PCB

  • Các mô hình STEP đã được đưa vào

  • Các multi-board assembly khác đã được đưa vào

  • Các mate được tạo giữa các đối tượng trong cụm lắp ráp

Tô sáng các phần tử trong Multi-board Assembly

Bảng Multiboard Assembly cung cấp khả năng tô sáng, trong đó part được chọn trong cây sẽ được tô sáng trong không gian thiết kế. Việc tô sáng là hai chiều đối với các lựa chọn được thực hiện ở cấp trên cùng của cây cụm lắp ráp; ví dụ, trạng thái chọn của các mục trong bảng sẽ thay đổi để phản hồi với các đối tượng cấp cao nhất được chọn trong không gian thiết kế. Từ bảng này, việc chọn được hỗ trợ ở mọi cấp của cây khi hợp lý. Ví dụ, chọn một net riêng lẻ sẽ tô sáng net đó trên toàn bộ bo mạch, nhưng chọn một lớp điện môi riêng lẻ sẽ không tô sáng lớp đó. Có thể dùng các phím tắt chuẩn của Windows Shift+Click hoặc Ctrl+Click để chọn nhiều mục trong bảng.

Ba bo mạch được chọn trong không gian thiết kế cũng được tô sáng trong bảng.
Ba bo mạch được chọn trong không gian thiết kế cũng được tô sáng trong bảng.

Việc tô sáng từ bảng cung cấp một phương pháp rất hiệu quả để xác định vị trí của một part cụ thể hoặc kiểm tra đường đi của một nhóm net khi chúng đi bên dưới một bo mạch daughterboard.

Kiểm soát khả năng hiển thị và độ trong suốt của các part trong cụm lắp ráp

Ngoài việc tô sáng một hoặc nhiều part cụ thể, bảng này cũng có thể được dùng để kiểm soát khả năng hiển thị và độ trong suốt của các part hiện đang được chọn trong bảng. Nhấp chuột phải vào part đã chọn rồi chọn Visible hoặc Transparent từ menu ngữ cảnh. Các part trong suốt sẽ trở nên nhìn xuyên qua được. Các part có tùy chọn Visible bị tắt sẽ bị ẩn.

Javascript ID: MBA_Pnl_MultiboardAssembly_PartVisibility

Một mô hình STEP hiển thị đầy đủ trong cụm lắp ráp.

Cùng mô hình đó đã được làm trong suốt.

Cùng mô hình đó đã được ẩn hoàn toàn.

Bạn cũng có thể kiểm soát khả năng hiển thị của PCB, component trên PCB hoặc mô hình STEP trực tiếp trong không gian thiết kế.

  • Đối với toàn bộ một đối tượng, chẳng hạn như PCB hoặc mô hình STEP, hãy chọn đối tượng, sau đó nhấp chuột phải để hiển thị menu ngữ cảnh và chọn tùy chọn Visible để ẩn đối tượng. Dùng bảng Multi-board Assembly để khôi phục khả năng hiển thị.

  • Đối với một component PCB, hãy chọn PCB trong không gian thiết kế, nhấp chuột phải và chọn Edit Selected Part. Sau đó, nhấp chuột phải vào bất kỳ component nào trên bo mạch đó và chọn các lệnh Visible hoặc Transparent từ menu ngữ cảnh. Khi bạn hoàn tất cấu hình khả năng hiển thị của các component trên bo mạch đó, hãy nhấp chuột phải vào bo mạch đó một lần nữa và chọn Finish Editing Part hoặc Cancel Editing Part.

Đo khoảng cách

Lệnh Tools » Measure Distance từ các menu chính (phím tắt: Ctrl+M) được dùng để đo khoảng cách giữa các đối tượng 3D trong multi-board assembly. Sau khi chạy lệnh, bạn sẽ vào chế độ đo. Việc đo được thực hiện như sau:

  1. Chọn đối tượng 3D đầu tiên hoặc mặt cụ thể của đối tượng đó. Khi bạn di chuyển con trỏ qua một đối tượng 3D tiềm năng, màu của đối tượng đó sẽ thay đổi. Nếu bạn muốn chọn một mặt cụ thể của đối tượng, hãy giữ phím Ctrl khi di chuyển con trỏ – mặt hiện nằm dưới con trỏ sẽ được tô sáng. Khi con trỏ ở đúng vị trí, hãy nhấp để xác nhận việc chọn đối tượng/mặt.

  2. Chọn đối tượng 3D thứ hai hoặc mặt cụ thể của đối tượng đó.

  3. Công cụ sẽ hiển thị trực quan khoảng cách ngắn nhất giữa hai đối tượng (mặt) đã chọn.

  4. Tiếp tục đo khoảng cách giữa các đối tượng/mặt khác hoặc nhấn Esc để thoát chế độ đo.

  • Tất cả kết quả đo trong phiên đo hiện hoạt được hiển thị trong bảng Messages . Bạn có thể nhấp đúp vào một mục để cross-probe đến phép đo đó trong không gian thiết kế.

  • Sau khi kết thúc phiên đo, tất cả các phép đo trực quan sẽ được xóa, cùng với mọi mục đo trong bảng Messages .

  • Khi đưa con trỏ qua một đối tượng 3D (hoặc mặt của nó), màu sắc sẽ chuyển sang màu được chỉ định cho màu hệ thống Highlight Under Cursor , trong phần System Colors của bảng View Configuration.

Kiểm tra va chạm

Các va chạm được đánh dấu bất cứ khi nào hai đối tượng có các bề mặt chạm nhau hoặc giao nhau.

Để kiểm tra va chạm, chọn Tools » Check Collisions (phím tắt: Ctrl+K). Sau khi chạy lệnh, phần mềm sẽ kiểm tra va chạm giữa các thực thể khác nhau tham gia trong multi-board assembly. Trước tiên, mỗi bo mạch sẽ được kiểm tra va chạm với các phần enclosure/vỏ trên và dưới (các part STEP), sau đó là kiểm tra giữa các bo mạch với nhau (PCB).

Mọi va chạm sẽ được báo cáo qua bảng Messages , và các đối tượng vi phạm sẽ được tô sáng bằng màu hệ thống Violation . Sử dụng vùng Details của bảng Messages để điều tra component nào trên một bo mạch liên quan đến xung đột đang gây ra va chạm.

Nếu cần, các lỗi vi phạm va chạm được tô sáng trong không gian thiết kế sau khi chạy kiểm tra va chạm có thể được xóa bằng cách chọn lệnh Tools » Clear Violations .

  • Việc kiểm tra va chạm sẽ được thực hiện giữa tất cả các bo mạch và các phần enclosure/vỏ máy, bất kể khả năng hiển thị của bo mạch/part đó trong không gian thiết kế.

  • Các bề mặt đã mate không được xem là đang va chạm.

Hỗ trợ Rigid-Flex

Trình biên tập multi-board assembly hỗ trợ PCB rigid-flex. Rigid-flex là tên gọi của một mạch in kết hợp cả mạch mềm và mạch cứng. Trình biên tập multi-board assembly hiển thị PCB ở trạng thái gấp cuối cùng như đã được định nghĩa trong trình biên tập PCB.

Để biết thông tin về thiết kế PCB rigid-flex, hãy tham khảo trang Thiết kế PCB Rigid-Flex.

Xuất sang MCAD

Cụm lắp ráp có thể được xuất ở định dạng STEP 3D hoặc Parasolid. Để xuất toàn bộ cụm lắp ráp sang STEP 3D (*.step hoặc *.stp), chọn File » Export » STEP 3D từ các menu chính. Để xuất toàn bộ cụm lắp ráp sang định dạng Parasolid (*.x_t), chọn File » Export » Parasolid từ các menu chính.

Một ví dụ về tệp STEP của multi-board assembly được mở trong một công cụ MCAD.
Một ví dụ về tệp STEP của multi-board assembly được mở trong một công cụ MCAD.

Multi-board assembly cũng có thể được đồng bộ giữa Altium Designer và một công cụ MCAD được hỗ trợ bằng chức năng Altium MCAD CoDesigner.

Để tìm hiểu thêm, hãy tham khảo trang Đồng bộ hóa Multi-board Assembly.

Xuất sang PDF 3D

Một tài liệu multi-board assembly cũng có thể được xuất ra tệp PDF (*.pdf). Để thực hiện việc này, hãy chọn lệnh File » Export to PDF File từ các menu chính.

Để biết thêm thông tin, hãy tham khảo trang Chuẩn bị tệp PDF3D.

AI-LocalizedBản địa hóa bằng AI
Nếu bạn phát hiện vấn đề, hãy chọn văn bản/hình ảnh và nhấnCtrl + Enterđể gửi phản hồi cho chúng tôi.
Tính khả dụng của tính năng

Các tính năng bạn có thể sử dụng phụ thuộc vào giải pháp Altium mà bạn đang có – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, hoặc Altium Designer (đang trong thời hạn hiệu lực).

Nếu bạn không thấy một tính năng được nêu trong tài liệu có trong phần mềm thực tế của mình, liên hệ Bộ phận Kinh doanh của Altium để tìm hiểu thêm.

Tài liệu cũ

Tài liệu Altium Designer không còn được phân phiên bản. Nếu bạn cần truy cập tài liệu cho các phiên bản cũ hơn của Altium Designer, hãy truy cập mục Tài liệu cũ trên trang Trình cài đặt khác.

Nội dung