Altium Designer Documentation

Configuring PCB Printouts

Modified by Jason Howie on Apr 20, 2017

To create an output job file, select File » New » Output Job File. The new Output Job File will appear as a new file in the Output Job Editor window.


Output jobs are configured as an OutJob file, giving you full control over print-based output

Configuring 2D Print-based Output

When you're ready to print documentation from your Outjob, open the PCB Printout Properties dialog which enables designers to define and manage the printout(s) required for the specific print-based documentation you wish to generate.

The main area of the dialog is essentially divided into three columns:

  • Printouts & Layers - lists the currently defined printouts and their constituent layers.
  • Include Components - enables you to control which components are included in the associated printout.
The Include Components option is component-oriented (Surface-mount & Through-hole). Because of this, mechanical layers used in footprints must be paired, if those layers are used to produce printouts.
  • Printout Options - enables you to control additional options with respect to the associated printout.

Adding a New Printout

A new printout can be added to the current configuration by choosing the Insert Printout command from the PCB Printout Properties dialog's right-click menu.

The printout will be added beneath existing printouts and will be given a default name New PrintOut 1. By default, all options in the Include Components column will be enabled.

Double-Click on a printout to open the Printout Properties dialog, from which user to configure the properties of a printout/printout set .

Configuring a Printout

A newly added printout can be configured, or the configuration of an existing printout edited, by accessing the associated Printout Properties dialog. This dialog can be accessed either by double-clicking on the name field for the printout (in the Printouts & Layers column), or by right-clicking on the name field and choosing Properties from the pop-up menu that appears.

  • The Printout Name field allows you to change the name for the printout as required, giving a more meaningful name that will readily identify the nature and purpose of the printout. You can also change the name for a printout directly in the PCB Printout Properties dialog. Click once on the name field for the required printout to access in-place editing and enter a new name.
  • The Components region of the dialog allows you to control which components are included on the printout. For example, if the printout is concerned with layers on the top side of the board only, you might want to show only components placed on the Top layer and components that have pads on both Top and Bottom layers (e.g. PCB Edge Connectors).
  • The Options region of the dialog provides advanced print-related options, such as whether font substitution should be used where alternative fonts are used for the printout, in place of the three default fonts used in the PCB Editor (Default, Serif, Sans Serif). Specification of such fonts is performed in the PCB Print Preferences dialog (see Setting Print Preferences).
  • The Pad Display Options region of the dialog provides options that allow you to control the display of pads on the printout - whether or not pad numbers and associated nets are shown, and the font size used for the text.
  • The Layers region is the 'heart' of printout configuration, providing the necessary controls to add, edit and order the layers that are to make up the printout. Whether adding a new layer or editing an existing one, the Layer Properties dialog will appear, from where you can configure the layer as required.
Any additional new layer is added at the bottom of the layer list. This means that this layer will be drawn first in the printer's memory when the image is rendered. Each layer above is then rendered on top in turn. Use the Move Up and Move Down buttons to change its position in the render order.

Adding a New Layer

A new layer can be added to a printout in one of two ways:

  • While configuring the parent printout using the Printout Properties dialog. Use the Add button to add a new layer to the Layers list. The new layer will appear at the bottom of the list but controls are provided in this dialog for changing the ordering of layers
  • Directly from within the PCB Printout Properties dialog. Right-click within the area of the printout you wish to add a new layer to and choose Insert Layer from the pop-up menu that appears. The new layer will be added beneath any existing layers for that printout. You cannot change the layer ordering in the PCB Printout Properties dialog. This can only be achieved from within the Printout Properties dialog.

Configuring a Layer

A newly added layer can be configured, or the configuration of an existing layer edited, by accessing the associated Layer Properties dialog. This dialog appears directly when adding a new layer. To access the dialog for an existing layer, either:

  • Access the Printout Properties dialog for the parent printout, select the layer and press the Edit button.
  • Double-click directly on the layer's name in the Printouts Layers column of the PCB Printout Properties dialog.

If you are adding a new layer to a printout, first select the layer you would like to add from the Print Layer Type drop-down list. The list contains all currently defined layers for the source PCB document, allowing you to include any PCB layer on a printout. The central three regions of the dialog provide controls to determine how the primitives on that layer are displayed on the printout - either in Full, in Draft (outline) mode or Off (hidden). This gives you complete control over what appears on the printed page.

Consider, as an example, an assembly drawing, which includes the following layers:

  • Component overlay
  • Top layer (for surface mount pads)
  • Multilayer (for thruhole pads)

The top layer would be configured to display the component primitives, so the surface mount pads are visible, and hide the free primitives, so the routing is not visible. The multilayer would also be configured to display the component primitives, so the thruhole component pads are visible, and hide the free primitives so that the vias are not visible.

Setting Print Preferences

Clicking the Preferences button at the bottom left of the PCB Printout Properties dialog will open the PCB Print Preferences dialog. All options defined in this dialog apply to each print-based output that can be generated.

Colors and Grayscales

This region allows you to control the coloring that is used for each possible layer than can be printed. For each layer, you can define the color used when printing in grayscale or color. Click on the left-hand color swatch to access the range of grayscale shades.

Click on the right-hand color swatch to access the Choose Color dialog, from where you can choose from a range of predefined colors or create your own, custom color.

Press the Retrieve Layer Colors From PCB button if you wish to print using the same colors configured for the PCB design in the PCB Editor.

Using this feature will overwrite the right-hand color swatch for each layer. The grayscale color definitions will remain unchanged unless you manually change them. To print in color or gray scale, the corresponding option Color or Gray must be enabled in the associated page setup dialog for the print output. The color printing mode for the nominated printing device must also be set accordingly in its associated properties dialog.

Include on New Printouts

As well as adding mechanical layers individually to a printout, you can also automatically include them in all printouts when the print job(s) for the parent document type is sent to the nominated printing device. Use this region of the dialog to enable/disable each of the 16 possible mechanical layers for printing, as required.

Font Substitutions

Each of the three standard fonts used in the PCB Editor (Default, Serif and Sans Serif) can be substituted for a different Windows font when the printout is generated. Use the options in this region of the dialog to specify and enable substitution fonts.

Click on the  button next to the required font field, to access the standard Windows Font dialog, from where you can choose the substitution font required.

When you click OK , the name of the font will be inserted into the font field.

Font substitution, although enabled/disabled in the PCB Print Preferences dialog on a global scale, can be controlled at the individual printout level for each print-based output type, using the Enable Font Substitution option in the associated Printout Properties dialog.

Options

This region of the dialog provides a single option, Print Keepout Objects, which gives you full control over whether keepout-designated design objects are included on the printed document or not.

Right-click Menu

The following list of commands are available from the right-click menu, accessed from anywhere within the PCB Printout Properties dialog:

  • Create Final - use this command to quickly create a complete, predefined final artwork print-set for the source PCB document.
  • Create Composite - use this command to quickly create a predefined multi-layer composite print for the source PCB document.
  • Create Power-Plane Set - use this command to quickly create predefined power-plane drawings for the source PCB document.
  • Create Mask Set - use this command to quickly create predefined solder/paste mask drawings for the source PCB document.
  • Create Drill Drawings - use this command to quickly create a predefined set of drill drawings and guides for the source PCB document.
  • Create Assembly Drawings - use this command to quickly create predefined assembly drawings for the source PCB document.
  • Create Composite Drill Guide - use this command to quickly create a predefined composite drill drawing for the source PCB document.
  • Insert Printout - use this command to insert a new printout for the print-based output currently being configured.
  • Insert Printout Set - use this command to create a printout which includes all layers combined onto one layer. Additional layers and layer classes can then be added.
  • Insert Drill Printout Set - use this command to create a new drill printout. Layers and layer classes can then be inserted into the drill printout.
  • Insert Layer - use this command to insert a new layer into the focused printout. The layer will be added to the bottom of the current list of layers that exist for that printout.
  • Insert Layer Class - use this command to insert a new layer class into the focused printout.
  • Move Up - use this command to move items up within a column.
  • Move Down - use this command to move items down within a column.
  • Delete - use this command to remove the focused layer from its parent printout, or the focused printout from the print-set currently being configured. You will be prompted for confirmation of the deletion. You will be prevented from deleting all layers from a printout and all printouts from a print-set.
  • Properties - use this command to access either the Layer Properties dialog or Printout Properties dialog, depending on whether the focused entry is a layer or a printout respectively.
  • Preferences - use this command to access the PCB Print Preferences dialog, from where you can define global options that apply to all print-sets.

Configuring 3D Print-based Output

The PCB 3D Print Settings dialog enables you to select or create 3D printouts of your PCB for inclusion in the job output file. Remember, you can have multiple instances of any printout (use the Add New Documentation Output control in the job output file for this), which is particularly useful for 3D, as you can print out views of the board from differing perspectives if you wish.
The dialog is divided into four regions:

  • Render Resolution - has options for the quality of the "picture" of the 3D model to be printed. The available resolutions are not printer dependent.
  • View to Print - enables you to select from flat views of the board, that is, the camera perspective perpendicular to the board, or a custom view.
  • View Configuration - enables you to apply the current view configuration for surface colors, visibility and opacity, and board thickness.
  • Preview - shows you exactly what will be printed.

Creating Custom 3D Printouts

A custom view of your board can entail it being rotated to an angle, zoomed, have various settings for surface colors, visibility and opacity and board thickness. You can use these options to generate views that provide high levels of detail to highlight areas of your design or even create effects.

To create a custom 3D view of your board as a printout, do the following:

Go to the PCB Editor window and enter 3D mode [shortcut: 3 ]. Use the 3D view controls to achieve the desired perspective. Return to the job output file and double-click anywhere on the PCB 3D Prints row (or right-click on it and select Configure from the shortcut menu) to open the PCB 3D Print Settings dialog. Click the Custom option then press the Take Current Camera Position button. The Preview pane will update with the new perspective. Click OK to apply the custom setting to the current PCB 3D printout.

If you would like to apply custom surface colors and the like, do the following:

Go to the PCB Editor window and open the View Configurations dialog [shortcut L ]. From this dialog, set the view configuration options as you would like and apply it. Note, you do not have to save the view configuration to apply it to a PCB 3D printout. Return to the job output file, open the PCB 3D Print Settings dialog and press the Take Current View Configuration button. The Preview pane will update with the new view configuration settings. Once you apply the view configuration, it will apply to all of the View to Print options. Click OK to apply the view configuration to the current PCB 3D printout.

Save the Output Job Configuration file to keep any new 3D printouts.

Tips

Print-based output can be generated in one of two ways:

  • using an appropriately configured output generator defined in an Output Job file (*.OutJob). Output will be generated upon running the configured output generator
  • directly from within the active PCB document using the File » Print menu command. Output will be generated for the currently enabled default print set.
When generating output directly from the PCB Editor, using the File » Print menu command, this facility is configured separately to configurations defined in an Output Job Configuration file. In this case, use the Default Prints tab of the Options for Project dialog (Project » Project Options) to configure the default print configuration and page layout for each of the print-related outputs that can be generated.

Configuration options defined here are distinct and separate to those defined for the same output type in an Output Job file. In the case of the former, the settings are stored in the project file, whereas for the latter they are stored in the Output Job file.

Setup options accessed from the PCB Editor's File menu with respect to page and printer, are also separate to those defined when accessed from within an Output Job file. Again, the former will be stored with the project file, the latter with the Output Job file.

 

If you'd like to comment on the content on this page, use the Ctrl+Enter keyboard shortcut to send us your feedback. To include a section of the page in your comment (a typo, missing/wrong info, or incorrect imagery), highlight the text (max. 200 chars) and/or image first. Please restrict your feedback to documentation issues - for technical assistance refer to the Altium Forums.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text and/or image within the active document:
Request Free Trial

Complete this form to request a free 15 day trial of Altium Designer: