Altium Designer Documentation

ManageGridsAndGuides

Modified by Jason Howie on Apr 20, 2017

Parent page: PCB Commands

The following pre-packaged resources, derived from this base command, are available:


Applied Parameters: Action=ShowManager

Summary

This command is used to access the Grid Manager dialog, which provides a centralized location from which to define and manage all grids for the active PCB document. The dialog provides all controls necessary to facilitate creation of your own customized, local placement grids. Supporting Cartesian and Polar grid 'flavors', you can define any number of grids for use in a document, which can even be nested as required.

For detailed information on working with grids, see PCB Grids System.

Access

This command is accessed from the PCB Editor, and PCB Library Editor, by:

  • Choosing the Tools » Grid Manager command from the main menus.
  • Choosing the View » Grids » Grid Manager command from the main menus.
  • Right-clicking in the design workspace (in free space) and choosing the Snap Grid » Grid Manager command from the context menu.
  • Using the G keyboard shortcut, then choosing the Grid Manager entry on the subsequent pop-up menu - or using the G, M keyboard sequence.
The Grid Manager dialog can also be accessed by using the Grids command on the menu associated to the Snap button, at the bottom-right of the main design window. In addition, access can be made by clicking the Grids button at the bottom of the Board Options dialog.

Use

After launching the command, the Grid Manager dialog will appear. Use the dialog to define Cartesian or Polar-based local grids by which to place design objects – especially components – with greater precision:

  • Cartesian Grid - to create a new Cartesian-type grid use the Add Cartesian Grid command – available from the dialog's main menu or right-click menu – or press the R key. A new grid entry will appear in the list, initially with the default name New Cartesian Grid. A Cartesian grid is distinguished by the letter C, to the left of the grid name field. To edit the grid, simply double-click on its entry, or select its entry and use the Properties command accessible through the dialog's menus. The Cartesian Grid Editor dialog will appear presenting options with which to define the grid.
  • Polar Grid - to create a new Polar-type grid use the Add Polar Grid command – available from the dialog's main menu or right-click menu – or press the P key. A new grid entry will appear in the list, initially with the default name New Polar Grid. A Polar grid is distinguished by the letter P, to the left of the grid name field. To edit the grid, simply double-click on its entry, or select its entry and use the Properties command accessible through the dialog's menus. The Polar Grid Editor dialog will appear presenting options with which to define the grid.

Each grid-type is fully customizable using a dedicated editing dialog. Define where in the workspace the grid is to be located, the step size of the grid, the extent of the grid and two levels for visual display of the grid.

These localized grids can be nested, allowing you to essentially stack grids over each other and therefore build grid hierarchy. Where, in a particular region of the workspace, you have defined a number of local placement grids in a nested fashion, you can assign a priority level – ensuring the grid you need is the one actually used.

Tips

  1. A predefined, default snap grid is available – Global Board Snap Grid – which is the grid used in all areas of the board where a specific custom grid has not been defined. The snapping priority of this grid is lower than any of the custom grids you define. In other words, a custom grid will always be snapped to first, where defined.
  2. If required, you can create a cartesian or polar grid that is for component placement only. The grid is created and configured in exactly the same way as any other cartesian or polar grid, the only difference is that you enable check boxes (in the Grid Manager dialog) to configure it as component-only.
  3. The default display colors – assigned to Fine and Coarse display grids when the Reset to Default link is clicked in a grid editor, or the Reset All To System Grid Colors command is issued from the Grid Manager dialog – are defined in the System Colors region, on the Board Layers And Colors tab of the View Configurations dialog. Specifically, the default fine-level display grid color is specified using the Default Grid Color - Small option, and the default coarse-level display grid color is specified using the Default Grid Color - Large option.
  4. Each local placement grid you create and define is given a numbered priority. By default, each new grid is given the highest priority of 1, with all existing grids moved down in priority accordingly. The Global Board Snap Grid is an exception. As it is the default grid that is used in all areas of the board that are not 'covered' by defined custom grids, it is given the priority setting of Default. It has the lowest 'snapping priority' of all defined grids. In the workspace, priority is distinguished by drawing order. The highest priority grid (priority 1) will be drawn in front of all other grids, then the grid with priority level 2, and so on, down to the default Global Board Snap Grid, which is drawn behind all other custom grids.
  5. Rather than deleting the grid – you may well use it again later, in the same or different area of the board – you can simply 'hide' it from the workspace. This can be achieved by unchecking the grid's associated Enabled attribute in the Grid Manager dialog.
  6. Custom grids can be exported from a board and imported into another board, if required, through a PCB Grid file (*.PCBGrid). When you define a custom grid in the PCB Library Editor it only applies to the current component, to use it for other components Export it from the current component and Import it to any other components requiring the same grid.
  7. The cursor will only snap to a defined grid (including the default snap grid), provided the option Snap To Grids is enabled, in the Snap Options region of the Board Options dialog.


Applied Parameters: Tab = Grid Manager

Summary

This command is used to access the Grid Manager dialog, which provides a centralized location from which to define and manage all grids for the active PCB document. The dialog provides all controls necessary to facilitate creation of your own customized, local placement grids. Supporting Cartesian and Polar grid 'flavors', you can define any number of grids for use in a document, which can even be nested as required.

For detailed information on working with grids, see PCB Grids System.

Access

This command is accessed from the PCB Editor, and PCB Library Editor, by using the O keyboard shortcut, then choosing the Grid Manager entry on the subsequent pop-up menu - or using the O, G keyboard sequence.

The Grid Manager dialog can also be accessed by using the Grids command on the menu associated to the Snap button, at the bottom-right of the main design window. In addition, access can be made by clicking the Grids button at the bottom of the Board Options dialog.

Use

After launching the command, the Grid Manager dialog will appear. Use the dialog to define Cartesian or Polar-based local grids by which to place design objects – especially components – with greater precision:

  • Cartesian Grid - to create a new Cartesian-type grid use the Add Cartesian Grid command – available from the dialog's main menu or right-click menu – or press the R key. A new grid entry will appear in the list, initially with the default name New Cartesian Grid. A Cartesian grid is distinguished by the letter C, to the left of the grid name field. To edit the grid, simply double-click on its entry, or select its entry and use the Properties command accessible through the dialog's menus. The Cartesian Grid Editor dialog will appear presenting options with which to define the grid.
  • Polar Grid - to create a new Polar-type grid use the Add Polar Grid command – available from the dialog's main menu or right-click menu – or press the P key. A new grid entry will appear in the list, initially with the default name New Polar Grid. A Polar grid is distinguished by the letter P, to the left of the grid name field. To edit the grid, simply double-click on its entry, or select its entry and use the Properties command accessible through the dialog's menus. The Polar Grid Editor dialog will appear presenting options with which to define the grid.

Each grid-type is fully customizable using a dedicated editing dialog. Define where in the workspace the grid is to be located, the step size of the grid, the extent of the grid and two levels for visual display of the grid.

These localized grids can be nested, allowing you to essentially stack grids over each other and therefore build grid hierarchy. Where, in a particular region of the workspace, you have defined a number of local placement grids in a nested fashion, you can assign a priority level – ensuring the grid you need is the one actually used.

Tips

  1. A predefined, default snap grid is available – Global Board Snap Grid – which is the grid used in all areas of the board where a specific custom grid has not been defined. The snapping priority of this grid is lower than any of the custom grids you define. In other words, a custom grid will always be snapped to first, where defined.
  2. If required, you can create a cartesian or polar grid that is for component placement only. The grid is created and configured in exactly the same way as any other cartesian or polar grid, the only difference is that you enable check boxes (in the Grid Manager dialog) to configure it as component-only.
  3. The default display colors – assigned to Fine and Coarse display grids when the Reset to Default link is clicked in a grid editor, or the Reset All To System Grid Colors command is issued from the Grid Manager dialog – are defined in the System Colors region, on the Board Layers And Colors tab of the View Configurations dialog. Specifically, the default fine-level display grid color is specified using the Default Grid Color - Small option, and the default coarse-level display grid color is specified using the Default Grid Color - Large option.
  4. Each local placement grid you create and define is given a numbered priority. By default, each new grid is given the highest priority of 1, with all existing grids moved down in priority accordingly. The Global Board Snap Grid is an exception. As it is the default grid that is used in all areas of the board that are not 'covered' by defined custom grids, it is given the priority setting of Default. It has the lowest 'snapping priority' of all defined grids. In the workspace, priority is distinguished by drawing order. The highest priority grid (priority 1) will be drawn in front of all other grids, then the grid with priority level 2, and so on, down to the default Global Board Snap Grid, which is drawn behind all other custom grids.
  5. Rather than deleting the grid – you may well use it again later, in the same or different area of the board – you can simply 'hide' it from the workspace. This can be achieved by unchecking the grid's associated Enabled attribute in the Grid Manager dialog.
  6. Custom grids can be exported from a board and imported into another board, if required, through a PCB Grid file (*.PCBGrid). When you define a custom grid in the PCB Library Editor it only applies to the current component, to use it for other components Export it from the current component and Import it to any other components requiring the same grid.
  7. The cursor will only snap to a defined grid (including the default snap grid), provided the option Snap To Grids is enabled, in the Snap Options region of the Board Options dialog.


Applied Parameters: Action=ShowGuideManager

Summary

This command is used to access the Snap Guide Manager dialog, which provides a centralized location from which to define and manage all Snap Guides for the active PCB document. Snap guides are special objects that are manually placed specifically for the purpose of driving the cursor-snap on a certain axis or point – assisting in object/component placement. They can also serve as a visual indicator for general layout or alignment purposes.

Once a Snap Guide or manual Snap Point has been created, it can be defined only through the Snap Guide Manager dialog.
For detailed information on working with guides, see PCB Grids System.

Access

This command is accessed from the PCB Editor, and PCB Library Editor, by choosing the Tools » Guide Manager command from the main menus.

The Snap Guide Manager dialog can also be accessed by using the Guides command on the menu associated to the Snap button, at the bottom-right of the main design window. In addition, access can be made by clicking the Guides button at the bottom of the Board Options dialog.

Use

After launching the command, the Snap Guide Manager dialog will appear. Use this dialog to define and manage snap guides for the workspace. Two different types of guide are available:

  • Linear Snap Guides - facilitating cursor snap to a specific axis (horizontal, vertical, +45Degree, or -45Degree). During an interactive process such as placing or moving, the cursor will snap to a placed guide, at the point where that guide intersects the applicable snap grid. Using a guide, objects can quickly be aligned simply by dragging them until they 'snap' against the guideline.
  • Point Snap Guides - also referred to as a manual Snap Point, this is simply a hotspot that you manually mark within the confines of a defined grid. During an interactive process, such as placing or moving an object, that objects' hotspot will 'snap' to a point snap guide, when it passes into close proximity with it.

To add a new Snap Guide or Snap Point, simply click the Add button and choose the required guide type. An entry for the new guide/point will be added to the list.

Tips

  1. Snap Guides and manual Snap Points can be added directly to the workspace using the commands available from the Place » Work Guides sub-menu. This offers a far more visual means by which to specify the location of the guides and points. They will be added to the Snap Guide Manager dialog, where you can make fine-tuned adjustments as required.
  2. Rather than deleting the guide – you may well use it again later, in the same or different area of the board – you can simply 'hide' it from the workspace. This can be achieved by unchecking the guide's associated Enabled attribute in the Snap Guide Manager dialog.
  3. Snap guides can be exported from a board and imported into another board, if required, through a PCB Guide file (*.PCBGuide). When you define a snap guide in the PCB Library Editor it only applies to the current component, to use it for other components Export it from the current component and Import it to any other components requiring the same guide.
  4. Visually, point snap guides are particularly beneficial when the snap grid marker type is set to Dots.
  5. The cursor will only snap to a placed linear snap guide provided the option Snap To Linear Guides is enabled, in the Snap Options region of the Board Options dialog.
  6. The cursor will only snap to a placed point snap guide provided the option Snap To Point Guides is enabled, in the Snap Options region of the Board Options dialog.


Applied Parameters: Action=ShowGridPropertiesUnderCursor

Summary

This command is used to quickly access the dedicated grid editor dialog for the snap grid currently under the cursor.

Access

With the cursor over the grid of interest, this command is accessed from the PCB Editor, and PCB Library Editor, by:

  • Using the Ctrl+G keyboard shortcut.
  • Right-clicking and choosing the Snap Grid » Grid Properties command from the context menu.
  • Using the G keyboard shortcut, then choosing the Grid Properties entry on the subsequent pop-up menu.

Use

After launching the command, the applicable grid editing dialog will appear - either the Cartesian Grid Editor dialog, or the Polar Grid Editor dialog. Use the dialog to make changes to the definition of the grid, as required.

Tips

  1. Hover the cursor over the grid of interest - do not click in the workspace prior to launching the command.
  2. Where a number of grids overlap, the highest priority grid will be the one accessed for editing. In the workspace, priority is distinguished by drawing order. The highest priority grid (priority 1) will be drawn in front of all other grids, then the grid with priority level 2, and so on, down to the default Global Board Snap Grid, which is drawn behind all other custom grids.


Applied Parameters: Action=PlaceHorzLineGuide

Summary

This command is used to place a horizontal guideline at the desired Y-coordinate location in the workspace. Linear Snap Guides such as this facilitate cursor snap to a specific axis. During an interactive process such as placing or moving, the cursor will snap to a placed guide, at the point where that guide intersects the applicable snap grid. Using a guide, objects can quickly be aligned simply by dragging them until they 'snap' against the guideline.

For detailed information on working with guides, see PCB Grids System.

Access

This command is accessed from the PCB Editor, and PCB Library Editor, by choosing the Place » Work Guides » Place Horizontal Guide command from the main menus.

Use

After launching the command, the cursor will change to a cross-hair, and you will be prompted to choose a location for the horizontal guideline. Simply position the cursor and click, or press Enter - the guideline will appear, running horizontally through the chosen point.

Continue placing further horizontal guidelines, or right-click, or press Esc, to exit placement mode.

Tips

  1. The guide will be colored using a default yellow color (RGB = 250, 236, 133). Post-placement, this can be changed, along with position, and whether or not the guide is enabled, only through the Snap Guide Manager dialog.


Applied Parameters: Action=PlaceVertLineGuide

Summary

This command is used to place a vertical guideline at the desired X-coordinate location in the workspace. Linear Snap Guides such as this facilitate cursor snap to a specific axis. During an interactive process such as placing or moving, the cursor will snap to a placed guide, at the point where that guide intersects the applicable snap grid. Using a guide, objects can quickly be aligned simply by dragging them until they 'snap' against the guideline.

For detailed information on working with guides, see PCB Grids System.

Access

This command is accessed from the PCB Editor, and PCB Library Editor, by choosing the Place » Work Guides » Place Vertical Guide command from the main menus.

Use

After launching the command, the cursor will change to a cross-hair, and you will be prompted to choose a location for the vertical guideline. Simply position the cursor and click, or press Enter - the guideline will appear, running vertically through the chosen point.

Continue placing further vertical guidelines, or right-click, or press Esc, to exit placement mode.

Tips

  1. The guide will be colored using a default yellow color (RGB = 250, 236, 133). Post-placement, this can be changed, along with position, and whether or not the guide is enabled, only through the Snap Guide Manager dialog.


Applied Parameters: Action=PlacePlus45DegLineGuide

Summary

This command is used to place a 45 degree (y=x) guideline that passes through the desired X,Y coordinate location in the workspace. Linear Snap Guides such as this facilitate cursor snap to a specific axis. During an interactive process such as placing or moving, the cursor will snap to a placed guide, at the point where that guide intersects the applicable snap grid. Using a guide, objects can quickly be aligned simply by dragging them until they 'snap' against the guideline.

For detailed information on working with guides, see PCB Grids System.

Access

This command is accessed from the PCB Editor, and PCB Library Editor, by choosing the Place » Work Guides » Place +45 Degree Guide command from the main menus.

Use

After launching the command, the cursor will change to a cross-hair, and you will be prompted to choose a location for the +45 Degree guideline. Simply position the cursor and click, or press Enter - the guideline will appear, running at 45 Degrees through the chosen point.

Continue placing further +45 Degree guidelines, or right-click, or press Esc, to exit placement mode.

Tips

  1. The guide will be colored using a default yellow color (RGB = 250, 236, 133). Post-placement, this can be changed, along with position, and whether or not the guide is enabled, only through the Snap Guide Manager dialog.


Applied Parameters: Action=PlaceMinus45DegLineGuide

Summary

This command is used to place a -45 degree (y=-x) guideline that passes through the desired X,Y coordinate location in the workspace. Linear Snap Guides such as this facilitate cursor snap to a specific axis. During an interactive process such as placing or moving, the cursor will snap to a placed guide, at the point where that guide intersects the applicable snap grid. Using a guide, objects can quickly be aligned simply by dragging them until they 'snap' against the guideline.

For detailed information on working with guides, see PCB Grids System.

Access

This command is accessed from the PCB Editor, and PCB Library Editor, by choosing the Place » Work Guides » Place -45 Degree Guide command from the main menus.

Use

After launching the command, the cursor will change to a cross-hair, and you will be prompted to choose a location for the -45 Degree guideline. Simply position the cursor and click, or press Enter - the guideline will appear, running at -45 Degrees through the chosen point.

Continue placing further -45 Degree guidelines, or right-click, or press Esc, to exit placement mode.

Tips

  1. The guide will be colored using a default yellow color (RGB = 250, 236, 133). Post-placement, this can be changed, along with position, and whether or not the guide is enabled, only through the Snap Guide Manager dialog.


Applied Parameters: Action=PlaceManualHotSpot

Summary

This command is used to place a point Snap Guide – a manual snap point if you will. A point snap guide is simply a hotspot that you manually mark within the confines of a defined grid. During an interactive process, such as placing or moving an object, that objects' hotspot will 'snap' to a point snap guide, when it passes into close proximity with it.

For detailed information on working with guides, see PCB Grids System.

Access

This command is accessed from the PCB Editor, and PCB Library Editor, by choosing the Place » Work Guides » Place Point Guide command from the main menus.

Use

After launching the command, the cursor will change to a cross-hair, and you will be prompted to choose a location for the manual hotspot. Simply position the cursor and click, or press Enter - the point guide will appear, marked by a cross at the chosen point.

Continue placing further point guides, or right-click, or press Esc, to exit placement mode.

Tips

  1. The guide will be colored using a default yellow color (RGB = 250, 236, 133). Post-placement, this can be changed, along with position, and whether or not the guide is enabled, only through the Snap Guide Manager dialog.

 

If you'd like to comment on the content on this page, use the Ctrl+Enter keyboard shortcut to send us your feedback. To include a section of the page in your comment (a typo, missing/wrong info, or incorrect imagery), highlight the text (max. 200 chars) and/or image first. Please restrict your feedback to documentation issues - for technical assistance refer to the Altium Forums.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text and/or image within the active document:
Request Free Trial

Complete this form to request a free 15 day trial of Altium Designer: