Altium Designer Documentation

Gerber Setup

Modified by Phil Loughhead on Jun 17, 2017

The Gerber Setup dialog

Summary

This dialog provides tools to completely configure your Gerber file output options. Each Gerber file corresponds to one layer in the physical board – the component overlay, top signal layer, bottom signal layer, the solder masking layers, etc. It is advisable to consult with your board fabricator to confirm their requirements before supplying the output documentation required to fabricate your design. 

Access

The Gerber Setup dialog is accessed in the following ways:

  • Using an ODB output generator in an OutputJob Configuration file (*.OutJob). The output is generated when the configured output generator is run.
  • In an active PCB document, click File » Fabrication Outputs » Gerber Files. The output will be generated immediately upon clicking OK in the dialog.
The settings defined in the Gerber Setup dialog when generating output directly from the PCB are distinct and separate to those defined for the same output type in an OutputJob Configuration file. In the case of the former, the settings are stored in the project file, whereas for the latter, they are stored in the OutputJob Configuration file.

Options/Controls

General Tab 

The General tab of the Gerber Setup dialog

  • Units
    • Inches - enable this option to use imperial units where all work is done in mils (1/1000 inch).
    • Millimeters - enable this option to use metric units where all work is done in millimeters.
  • Format
    • 2:3 - provides a resolution of 1 mil  (1/1000 inch).
    • 2:4 - provides a resolution of 0.1 mil. 
    • 2:5 - provides a resolution of 0.01 mil. 

If you are using one of the higher resolutions, check that the PCB manufacturer supports that format. The 2:4 and 2:5 formats only need to be chosen if there are holes on a grid finer than 1 mil.

Layers Tab 

The Layers tab of the Gerber Setup dialog

Layers To Plot

This region is a list of all layers in the design. 

  • Plot - check the Plot box next to each specific layer(s) you wish to plot as part of the generated output.
  • Mirror - check the Mirror box to the right of each layer if you want a mirrored Gerber file to be created.​

Mechanical Layer(s) to Add to All Plots

Check the box next to each mechanical layer(s) you want added to all plots.

Plot Layers

Use the drop down to access a menu of commands that allow the Plot field for all layers in the Layers to Plot region to be enabled or disabled:

  • All On - select to check all boxes in the Plot column (Gerber data will be created for all checked layers).
  • All Off - select to clear all checked boxes in the Plot column (no Gerber data will be created). 
  • Used On - select to check all boxes in the Plot column of the listed layers that are used in the design.

Mirror Layers 

  • All On - select to check all boxes in the Mirror column (mirrored Gerber data will be created for all checked layers).
  • All Off -  select to clear all checked boxes in the Mirror column (no mirrored Gerber data will be created).
  • Used On - select to check all boxes in the Mirror column of the layers that are used in the design.

Right-click Menu

The Plot Layers and Mirror Layers commands can also be accessed by right-clicking the layer name in the list region. The following are additional commands included on the right-click menu:

  • Add Layer Class - click to open the Layer Class Name dialog and enter a name for the new layer.
  • Edit Layer Class - click to edit the name of a Layer Class.

Include unconnected mid-layer pads

Check this box to allow unconnected pads in the mid-layer on Gerber plots.

Drill Drawing Tab 

The Drill Drawing tab of the Gerber Setup dialog

Use this tab to specify that a drill drawing is required. Mirrored plots can also be specified.

Drill Drawing Plots  

  • Plot all used drill pairs - check this option to plot all used drill pairs in drill drawing plots.
  • Mirror plots - check this option to mirror layer pairs in drill drawing plots.
  • Configure Drill Symbols - click to open the Drill Symbols dialog in which you can configure the drill symbols.
  • Layer Pairs Region - this area shows all defined layer pairs in the design. Check the box in front of each desired layer pair to draw that layer pair in drill drawing plots. Check box is only accessible when Plot all used drill pairs is unchecked.

Drill Guide Plots 

  • Plot all used drill pairs - check this option to plot all used drill pairs in drill guide plots.
  • Mirror plots - check this option to mirror drill guide plots.
  • Layer Pairs Region - This area shows all defined layer pairs in the design. Check the box in front of each desired layer pair to draw that layer pair in drill guide plots. Check box is only accessible when Plot all used drill pairs is unchecked.

Apertures Tab

The Apertures tab of the Gerber Setup dialog

Use this tab to set up the required aperture information for the design.

  • Embedded apertures (RS274X) - when this option is enabled, the apertures are embedded in the Gerber files according to the RS274X standard and all information for each layer is contained in a single file. Enabling this option ensures that the current apertures list includes all the required apertures. If this option is disabled, the Options region of the tab becomes available.
  • Apertures List - lists all the current aperture data.
  • Options - use this region to select the following:
    • Maximum aperture size - input the maximum size of the apertures for the design.
    • Generate relief shapes - check this option to create relief style apertures.
    • Flash pad shapes- check this option to flash the pad shapes.
    • Flash all fills - check this option to flash all fills.
  • Additional Controls
    • New - click to open the DCode dialog. Enter DCode then click OK to open the Aperture dialog in which you can specify the properties of the new aperture. The DCode is a code assigned to that size aperture.  
    • Edit - click to edit the properties of the selected aperture.
    • Rename - click to open the DCode dialog. Enter the new DCode name of the selected aperture. 
    • Clear - click to clear all apertures from the Apertures List. A confirmation box appears before clearing.
    • Delete - click to delete the selected aperture.
    • Create List from PCB - click to create the Apertures List from the current PCB design.
    • Load - click to open the Load Aperture File dialog. Select the location of the aperture file to load.
    • Save - click to save the current apertures in the Apertures List. 

The above group of selections can also be accessed from the right-click context menu.

Tips on Apertures

Unless your PCB manufacturer does not support embedded apertures, it is highly recommended that you use the Embedded apertures (RS274X) option. Most modern photoplotters are raster plotters which can accept any size aperture. Generally, they also accept Gerber files with embedded apertures.

If your manufacturer does not use embedded apertures, a separate aperture file (*.apt) must be included with the Gerber files. If you use an existing aperture file rather than a generated one, the PCB Editor scans the primitives (tracks, pads, etc.) in the PCB document and matches these with aperture descriptions in the loaded *.apt file. If there is no exact match of aperture to primitive, the PCB Editor will automatically paint the primitive with a suitable smaller aperture. If there is no aperture suitable with which to paint, a *.MAT (match) file will be generated listing the missing apertures and Gerber file generation will be aborted.

Advanced Tab

The Advanced tab of the Gerber Setup dialog

Use this tab to specify options, such as film size, position on film, and plotter type, to be used during Gerber generation.

Film Size

  • X (horizontal) - enter a value for the film length.
  • Y (vertical) - enter a value for the film width.
  • Border size - enter a value for the border size of the film.

Aperture Matching Tolerances 

  • Plus - use this box to define the positive tolerance for aperture matching.
  • Minus - use this box to define the negative tolerance for aperture matching.

Batch Mode

  • Separate file per layer - select this option if you want each layer to generate a separate Gerber file.
  • Panelize layers - select this option if you want only one Gerber file to be generated in the format of panelization.

Leading/Trailing Zeroes 

  • Keep leading and trailing zeroes - if this option is enabled, all leading and trailing zeroes will appear in the generated Gerber file.
  • Suppress leading zeroes - if this option is enabled, no leading zeroes will appear in the generated Gerber file.
  • Suppress trailing zeroes - if this option is enabled, no trailing zeroes will appear in the generated Gerber file.

Position on Film 

Use the following options to choose the position on the film:

  • Reference to absolute origin 
  • Reference to relative origin 
  • Center on film

Plotter Type

  • Unsorted (raster) - select to use raster machine (default).
  • Sorted (vector) - select to use vector machine.

Other

  • G54 on aperture change - check this option to rotate the aperture wheel of the plotter after each aperture change.
  • Use software arcs - check this option to use software arcs.
  • Use polygons for octagonal pads - check this option to use polygons for any octagonal pads.
  • Optimize change location commands - when this option is enabled, X or Y location data is not included if it does not change from one object to the next.
  • Generate DRC Rules export file (.RUL) - check this option to generate a DRC Rules Export file (.RUL). This file report details the design rules for the source PCB document from which the Gerber data is being generated.  

The Gerber files should be created with the same format, or precision, as the NC Drill files. For example, if the Gerber files have been configured to use the 2:4 format, then the corresponding NC Drill files should use the same format. If Gerber files have been generated with the coordinate position on the film set to use either the absolute or relative origin, the NC Drill files should be generated using the same origin reference.

Tips

Generated Gerber Files

The following file extensions are used to identify each Gerber file. The filename for each Gerber file is the PCB filename when the Gerbers are generated via File » Fabrication Outputs » Gerber Files. For Gerbers generated through an OutputJob, the default is to use the PCB filename, however this can be overridden if required.

Gerber Extension

Description

G1, G2, etc.

Mid-layer 1, 2, etc.

GBL

Bottom Layer

GBO

Bottom Overlay

GBP

Bottom Paste Mask

GBS

Bottom Solder Mask

GD1, GD2, etc.

Drill Drawing

GG1, GG2, etc.

Drill Guide

GKO

Keep Out Layer

GM1, GM2, etc.

Mechanical Layer 1, 2, etc.

GP1, GP2, etc.

Internal Plane Layer 1, 2, etc.

GPB

Pad Master Bottom

GPT

Pad Master Top

GTL

Top Layer

GTO

Top Overlay

GTP

Top Paste Mask

GTS

Top Solder Mask

P01, P02, etc.

Gerber Panels

APR

Aperture File (generated when Embedded apertures (RS274X) on the Apertures tab is enabled)

APT

Aperture File (generated when Embedded apertures (RS274X) on the Apertures tab is not enabled)

Location of Generated Files

The output path for generated files depends on how the output was generated:

  • From an OutputJob file - the generated files are stored in a folder within the project folder, the naming and folder structure is defined in the Output Container that the Gerber File output is targeting.
  • Directly from the PCB - the output path is specified in the Project Options - Options dialog. By default, the output path is set to a sub-folder under the folder that contains the Project file and has the name Project Outputs for <ProjectName>. The output path can be changed as required. If the option to use a separate folder for each output type has been enabled in the Options tab, then the Gerber files will be written to a further sub-folder named Gerber Output.

Automatically Opening the Generated Output

When generating Gerber output, you can specify that the output be opened automatically in a new CAM document. The way in which this is accomplished depends on how you are generating the output:

  • From an OutputJob file - enable the Gerber Output auto-load option in the Output Job Options dialog (Tools » Output Job Options from the OutputJob Editor).
  • Directly from the PCB - ensure that the Open outputs after compile option is enabled on the Options tab of the Project Options dialog (Project » Project Options).
If you'd like to comment on the content on this page, use the Ctrl+Enter keyboard shortcut to send us your feedback. To include a section of the page in your comment (a typo, missing/wrong info, or incorrect imagery), highlight the text (max. 200 chars) and/or image first. Please restrict your feedback to documentation issues - for technical assistance refer to the Altium Forums.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text and/or image within the active document:
Request Free Trial

Complete this form to request a free 15 day trial of Altium Designer: