使用 CoDesigner 进行直接 ECAD-MCAD 设计

使用本 CoDesigner 文档需满足以下要求:

  • 受支持的 Altium 设计客户端:

    • 请注意,并非所有 Altium MCAD CoDesigner 安装版本都提供本页所述的全部功能。 有关更多信息,请参阅右侧的 Feature Availability 面板。

    • 要确定受支持的 Altium 设计客户端,请先确认您使用的 MCAD CoDesigner 插件版本,然后在 ECAD-MCAD 版本兼容性矩阵中查看受支持的版本

    • 使用 Autodesk Fusion CoDesigner 扩展 2.8 或更高版本时,支持 Altium CircuitMaker 2.1 或更高版本。请注意,CircuitMaker 仅支持 Autodesk Fusion®。了解更多。

  • 一个 Altium 工作区,受支持的工作区包括:

    • Altium 365 工作区

    • Altium Enterprise Server 工作区。Note:如果您使用的是本地部署的服务器,并且与许可相关的功能发生了变化,请在服务器浏览器界面的 Admin – Licenses 页面中删除并重新添加许可证,以刷新许可信息。

  • 受支持的 MCAD 设计软件,以及适用版本的 CoDesigner 插件。

如果您更喜欢通过观看视频学习,可以查看 MCAD 协同设计操作视频页面。

电子产品设计与开发领域的一项令人振奋的进展,是能够将电子电路直接印刷在基材上,例如作为产品组成部分的塑料成型件。Altium 正在开发相关技术,通过直接在三维结构上进行布局和布线,支持印刷电子和模塑互连器件(MID)的设计。现阶段,由于所需的设计方法不同,CoDesigner 尚不支持在 ECAD 与 MCAD 之间传输印刷电子设计。相关开发工作正在进行,后续更新将添加此支持。

什么是协同设计?

在电子与机械设计领域之间开展工作会带来独特的挑战。ECAD 和 MCAD 工具的设计目标不同,发展路径也各不相同,存储和管理数据的方式亦是如此。

然而,如今的设计要求必须解决这一难题——小巧而复杂的产品外壳内往往容纳着多块形状不规则的印制电路板。要成功设计这些产品,设计人员必须能够在 ECAD 和 MCAD 领域之间往返传递设计更改的同时开展协作。

在不同的设计软件之间传递复杂而详细的设计更改,远不只是将数据保存为另一种格式那么简单。电子和机械设计团队各自独立工作,必须能够在设计过程中的任意阶段传递更改。如何管理团队之间往返传递的更改,同时又不影响任何一方的日常设计工作?设计团队最不希望遇到的情况,就是一方必须停下工作,等待另一方接受其最新更改后,双方才能继续推进。

CoDesigner 解决了这一协同设计难题,它是一个用于在 ECAD 和 MCAD 设计领域之间传输印制电路板设计的接口。

工作原理

在 ECAD 和 MCAD 软件中添加 CoDesigner 插件后,CoDesigner 即可通过 Altium 工作区往返传递设计更改。工作区充当 ECAD 和 MCAD 领域之间的桥梁,如下图所示。

PCB design data can be transferred in both directions between ECAD and MCAD through an Altium Managed Content Server

通过工作区传递设计更改的优势在于,更新过程变为stateless。这意味着双方都可以继续独立工作,无需担心另一团队的设计进展。

例如,MCAD 设计人员定义好电路板形状后,可以将装配体Push到工作区。ECAD 设计人员会自动收到有待处理更改的通知。当他们单击 Pull 时,系统会将其电路板与工作区中的 MCAD 电路板定义进行比较,并生成一份更改列表,列出将其电路板与工作区版本同步所需的更改。随后,ECAD 设计人员可以启用所需的更改,并将其Apply到自己的电路板。接着,ECAD 设计人员可以在层叠中配置所需的各个铜层和其他制造层,定义板厚,再将更新后的电路板Push回传给 MCAD 设计人员,以便放置任何对位置有严格要求的机电元件。

什么是工作区?

Altium 工作区是一台用于托管和管理所有设计内容的专用服务器,可直接与您的设计软件连接。Altium 设计软件与工作区无缝协作,为在确保完整性和安全性的前提下管理设计数据提供了简洁高效的解决方案。

  • 根据您购买的 Altium 解决方案,Altium 工作区以 Altium Develop Workspace 或 Altium Agile Workspace 的名称提供。对于这两种工作区,本文档均使用通用术语 Altium Workspace 或类似表述。

  • 有关 Altium 365 平台安全性、可靠性、隐私和合规性的最新信息,请访问 Altium 365 信任中心。

  • 对于需要遵守 ITAR 和 EAR 等美国政府安全法规的组织,Altium 提供了位于美国的 Altium 365 GovCloud,它在 AWS GovCloud 区域运行,并提供额外的数据保护措施。 有关更多信息,请参阅 Altium 365 GovCloud 及其相关常见问题解答。

Altium 设计软件可以连接到以下工作区:

  • Altium 365 Workspace - 托管于 Altium 365 云基础设施平台上的工作区。该工作区支持设计、制造和供应领域之间的无缝连接,并提供在这些领域之间传递数据的机制。建议使用云端工作区,因为它提供了多种全球共享与协作功能,而这些功能只能通过基于云的 Altium 365 平台体验和使用。
  • Altium On-Prem Enterprise Server Workspace - 如果您的设计团队无法使用云端托管的工作区,Altium 也支持本地部署的 Enterprise Server,该服务器安装在您自己的场所内,并由您自己的 IT 部门管理。

进一步了解连接工作区进行设计

什么是个人空间?

每位在 Altium Live 注册的设计人员都可以使用自己的 Altium 365 个人空间。个人空间免费提供,并具备工作区中的部分协作功能。对于在 Altium CircuitMaker 和 Autodesk Fusion 之间开展工作的设计人员,个人空间也可用作 ECAD-MCAD 传输接口。

进一步了解 Altium 365 个人空间

进一步了解在 Altium CircuitMaker 和 Autodesk Fusion 之间开展协作

想知道 CoDesigner 是否支持您的 MCAD 软件?请查看安装和配置 Altium MCAD CoDesigner 页面,获取受支持的 MCAD 软件列表。

传输设计数据

工作区的作用

MCAD CoDesigner 通过 Altium Workspace 推送和拉取设计更改,在 ECAD 和 MCAD 之间传输设计。在 ECAD 中执行推送时,推送到 Altium Workspace 的并不是 PCB 文件,而是一个专用的 ECAD 到 MCAD 数据包。该数据包包括:电路板数据、层几何结构、Parasolid 格式的元器件 3D 模型(了解更多关于 MCAD 中如何命名 3D 模型的信息),以及铜几何结构(如果已启用)。

在 ECAD 或 MCAD 中执行推送时,CoDesigner 首先会在本地子文件夹 <DesignName>-EDM 中准备数据包。在 MCAD 端,EDM 文件夹还用于存储 MCAD 数据。随后,此数据包会传输到 Altium Workspace 中名为 Mechatronic 3D Models 的特殊文件夹。此文件夹仅供 MCAD CoDesigner 存储 ECAD 到 MCAD 的数据。如果您使用 MCAD CoDesigner,请勿删除或移动此文件夹,也不要限制电气和机械工程师对其的访问权限。

了解更多关于传输机电一体化 3D 模型的信息

ECAD-MCAD 对象转换

当电路板设计在 ECAD 和 MCAD 之间来回传输时,必须将一个设计环境中的对象转换为另一个设计环境中的等效对象。 对于某些对象,转换十分直接;例如,ECAD 安装孔会转换为 MCAD 孔,而 MCAD 电路板零件会转换为 ECAD 板形。

对于其他对象,转换过程则没有这么直接。例如,ECAD 元器件包含会成为制造后电路板一部分的封装元素,包括丝印和焊盘(其中包含铜、阻焊等特定层的细节以及孔);此外,还包含在 PCB 装配过程中安装到该封装上的元器件 3D 模型。在 MCAD 中,ECAD 元器件中所有与电路板相关的元素都会成为 MCAD 电路板零件的一部分,而 3D 模型则会成为 MCAD 元器件。 

这种对象转换最初可能会令人困惑;例如,在 MCAD 中移动元器件时,元器件焊盘及其孔会留在原处。将电路板推送回 ECAD,然后再次拉取到 MCAD 后,这些焊盘的位置才会更新,以匹配其元器件的新位置。

为帮助理解,下方的可折叠部分汇总了各个传输方向上的对象转换方式。

保存到服务器时自动执行 CoDesigner 推送

在 ECAD 中执行 Save 时,设计文件会保存在本地的项目工作文件夹中。执行 Save to Server 时,文件会先保存在本地,然后再保存到工作区中的项目文件夹。

这些操作与在 MCAD CoDesigner 中执行 Push 相互独立。MCAD 推送与保存到服务器是分开的操作,这可能会引起误解:电气工程师可能以为,在一天结束时执行了保存到服务器后,所有需要访问该设计数据的人员就都已获得最新数据,可以继续工作。

为了简化文件同步流程,在项目至少被拉取到 MCAD 一次后,每当在 ECAD 中对项目执行 Save to Server 时,工作区都会自动执行推送。

将项目保存到服务器时,会自动执行 MCAD 推送。将项目保存到服务器时,会自动执行 MCAD 推送。

  • 自动推送由工作区执行,此流程会在首次拉取到 MCAD 后启动。

  • 目前仅 Altium 365 工作区启用了自动推送。即将增加对本地部署的 Enterprise Server 工作区的支持。

  • 自动推送支持 PCB、线束和多板 ECAD 项目。MCAD CoDesigner 3.14 新增了对线束项目的支持。

MCAD 工程师执行拉取时,系统会提示上一次 MCAD 推送是自动执行的,如下方幻灯片所示。

在 ECAD 中将项目保存到工作区时,也会自动将其推送到 MCAD。

如果推送过程中出现警告或错误,则会显示一个标记。

单击可显示警告或错误的详细信息。

 

如果无法执行自动推送,系统会警告 MCAD 工程师,当前拉取的数据版本不是最新版本()。

以下情况下不会执行自动推送:

  • The ECAD project has only been saved to the working folder – 项目尚未保存到服务器。执行保存到服务器后,机械工程师首次从工作区拉取项目后,自动推送才会开始。

  • The ECAD project has failed CoDesigner's validation checks – 必须先解决这些问题,才能执行自动或手动 MCAD 推送。

  • There are multiple PCB files in the ECAD project, which have all been Saved to the Server – MCAD CoDesigner 无法确定应自动推送哪个 PCB,ECAD 工程师必须对正确的 PCB 执行手动 MCAD 推送,以解决此问题。

MCAD CoDesigner 记录其运行进度的位置

MCAD CoDesigner 会将 ECAD 和 MCAD 各方面操作的详细信息记录到日志文件中。日志文件位于:

C:\Users\<>\AppData\Local\Altium\Altium CoDesigner\

在此位置:

  • ECAD 事件记录在: AltiumDesignerExtension.log

  • MCAD 事件记录在: <McadName>Addin.log

协同设计界面

Altium 软件与 MCAD 软件通过各自软件中的面板(选项卡)相互交互。在 Altium 软件中,该面板称为 MCAD CoDesigner 面板;在 MCAD 软件中,称为 Altium CoDesigner 面板或选项卡。

MCAD CoDesigner / Altium CoDesigner 面板

在 ECAD 中,通过 MCAD CoDesigner 面板推送和拉取设计更改。 

在 MCAD 中,通过 Altium CoDesigner 面板推送和拉取设计更改。

 
  • 在 Altium 设计软件中,MCAD CoDesigner 面板用于双向推送和拉取设计更改,以及显示消息。

  • 在 MCAD 软件中,Altium CoDesigner 面板用于:

    • 创建新的协作项目

    • 打开现有协作项目

    • 配置协作选项

    • 双向推送和拉取设计更改

    • 显示消息

各 MCAD 工具启用面板(选项卡)的方法各不相同,您可以在安装和配置 Altium MCAD CoDesigner章节的相应页面中找到有关如何访问 Altium CoDesigner 面板的详细信息。

在 CoDesigner 面板中工作

虽然总体概念相同,但在 Altium CircuitMaker 与 Autodesk Fusion 之间协作时,操作方式存在一些差异。

进一步了解在 CircuitMaker 与 Autodesk Fusion 之间协作。

CoDesigner 面板在 ECAD 和 MCAD 中提供的功能基本相同。该面板始终显示 ECAD 中的最近一次更改和 MCAD 中的最近一次更改。

所有协同设计活动均通过 CoDesigner 面板执行。所有协同设计活动均通过 CoDesigner 面板执行。

ECAD 最新更改 / MCAD 最新更改

  • 这两个区域分别显示 ECAD 中的最近一次更改和 MCAD 中的最近一次更改。

  • 单击三角形图标可展开面板,显示最近一次更改的详细信息 。

  • 当另一设计端推送新的更改时, 横幅会自动出现,如下所示。
    面板将详细显示:

    • 执行推送的工程师的登录名

    • 推送时输入的可选注释

推送更改时,会出现“新更改”通知横幅。推送更改时,会出现“新更改”通知横幅。

  • 点击 Pull 按钮时,CoDesigner 会将当前打开的设计与上次从另一设计领域推送到工作区的版本进行比较。检测到的每项差异都会列在面板的 Changes 列表中,如下所示。在列表中选择一项更改时,系统会尽可能以紫色高亮显示该更改的影响。

点击列表中的一项更改,以高亮显示该更改的影响。点击列表中的一项更改,以高亮显示该更改的影响。

  • 对于不想应用的更改,请清除其对应的复选框。
  • 某些更改可能无法应用。在这种情况下,该更改及其复选框会显示为灰色。应用更改后,此差异仍将存在,应与推送该更改的工程师讨论。
  • 准备就绪后,点击 Apply 按钮,将所有已启用的更改应用到当前打开的设计。

支持更改历史记录和拒绝原因说明

系统会保留所有更改的完整历史记录。要查看历史记录,请点击“来自 ECAD/MCAD 的最新版本”下拉菜单右侧的 历史记录 链接,如下所示。

更改历史记录可让双方工程师轻松了解彼此对所做更改的回应。更改历史记录可让双方工程师轻松了解彼此对所做更改的回应。

每组更改都会详细列出:

  1. 执行此次推送()或 拉取()操作的人员,以及操作来自哪个设计领域( ECAD 或  MCAD)。

  2. 这些操作发生的日期和时间。

  3. 从另一设计领域推送更改时附带的可选摘要说明。

  4. 详细列出各项具体更改的列表,勾号表示接受的更改,叉号表示拒绝的更改。

  5. 详细说明拒绝某项更改原因的可选说明。 

  6. 在面板的 History 模式下,点击 按钮,返回 Latest Changes 模式。

  7. 点击 View Project in Browser 按钮,在工作区中查看项目。 

  8. 在浏览器中,点击左侧的 History 链接以查看项目历史记录,如下图所示。每个 CoDesigner 推送操作对应的历史事件卡片均以 MCAD Changes Suggested 为标题,并包含执行推送的人员姓名、日期和时间,以及附带的消息(如有)。使用这些信息可在 CoDesigner 面板与历史记录视图之间进行对照。 

    进一步了解项目历史记录:Altium 365 工作区或 Enterprise Server 工作区。

也可以在工作区中查看更改历史记录。也可以在工作区中查看更改历史记录。

为什么 CoDesigner 的历史事件卡片有所不同?

在 ECAD 中,CoDesigner 推送会将数据保存到工作区,但这些 CoDesigner 数据独立于源原理图和 PCB 项目文档。在 CoDesigner 推送期间,不会修改或保存源原理图和 PCB 项目文档,也不会提交项目。当 ECAD 工程师执行“保存到服务器”时,才会发生项目提交 only,这些提交会显示在深灰色的事件卡片上。

为了体现 MCAD CoDesigner 历史记录不会影响标准项目提交事件的历史记录,MCAD 更改会作为建议记录在紫色卡片上。该卡片不会直接连接到时间线,而是通过方向箭头指示该事件在整个项目历史记录中的位置。 请注意,目前仅支持 MCAD CoDesigner 推送事件。

为避免混淆并简化工作流程,执行“保存到服务器”时,还会自动执行一次 CoDesigner 推送,以确保 ECAD 和 MCAD 工程师都能访问最新的设计数据。进一步了解 CoDesigner 自动推送。

有关您安装的 MCAD CoDesigner 是否支持项目历史记录功能,请参阅右侧窗格中的 Note。

PCB 定义 - 板区域

在设计中,电路板上可能存在一些需要特别注意的区域,MCAD 工程师需要定义这些区域并将其传递给 ECAD 工程师。例如,电路板表面可能有一个必须保持无铜的区域,因为产品组装后,外壳的某个导电部件会与电路板表面接触。为此,MCAD 工程师可以使用 Altium CoDesigner 功能区上的按钮来定义 Keep Out Areas 和 Text Note Rooms。

如果已在 MCAD 中将这两类对象中的任意一种放置在电路板上,它们就会列在 CoDesigner 面板的 PCB Definitions 部分中的“板区域”列表中:

  • Keep Out Area - 在 MCAD 中定义的禁布区域会转换为 ECAD 中的 PCB 禁布区。PCB 禁布区是电路板上用于限制放置特定 ECAD 对象的区域。禁布区可以定义在电路板的任意一侧,也可以应用于所有 PCB 层。在 ECAD PCB 中需要禁止进入此区域的对象,可通过 Altium CoDesigner MCAD 面板中的 Keepout Restriction 属性进行选择;请根据需要进行配置。进一步了解在 MCAD 中放置禁布区域。

  • Text Note Room - 在 MCAD 中定义的文本注释 Room 会转换为 ECAD 中的 PCB Room。PCB Room 是一种设计规则,用于定义必须在其中放置特定元件或禁止放置特定元件的区域。此规则的常见用途是对 Room 所覆盖的板区域设置元件高度限制。通常,Room 规则会应用于单个元件或某一元件类。在 Altium CoDesigner MCAD 面板中点击一个文本注释 Room 定义以将其选中,然后输入供 ECAD 工程师参考的说明或信息;此文本将成为 ECAD PCB 编辑器中该 Room 的“注释”字段内容。进一步了解在 MCAD 中放置文本注释 Room。

板区域和文本注释 Room 是由 MCAD 工程师定义、随后推送给 ECAD 工程师的特殊区域。 

  • 默认情况下,在 ECAD 中创建或更改的禁布区和 Room 不会显示在 MCAD 中,从而减少机械工程师看到的冗余视觉信息。需要时,可以恢复它们在 MCAD 中的可见性。

  • 无法在 MCAD 中定义铜区域。如果 MCAD 工程师需要定义铜区域,请先在 MCAD 的相应层上放置禁布区域,然后在 ECAD 中使用 Tools » Convert » Convert Selected Keepouts to Primitives 命令,将禁布区域对象转换为铜区域对象。

PCB 定义 - 电路板外壳

CoDesigner 支持在 MCAD 中的设备装配体层级进行设计,并将外壳与电路板一起从 MCAD 传递到 ECAD。

CoDesigner 会识别出电路板和外壳已添加到设备装配体中。CoDesigner 会识别出电路板和外壳已添加到设备装配体中。

进一步了解如何在设备装配体中进行设计,以及如何将外壳从 MCAD 推送到 ECAD。

CoDesigner MCAD 设置菜单

CoDesigner 设置菜单用于在 MCAD 软件中配置 CoDesigner。

点击 Altium CoDesigner 面板右上角的向下箭头以打开菜单。

使用菜单选项可以:

  • 确认您当前登录的是哪个服务器/工作区。
  • 退出当前登录的服务器/工作区。
  • 打开 CoDesigner Settings 对话框,您可以在其中配置用于存储模型的集中位置,并启用真实铜箔支持。
  • 访问自定义服务器。单击 Use Custom Server 选项将退出当前工作区,并使 Altium CoDesigner 面板返回登录模式。

对于不显示版本号的旧版 CoDesigner,可打开 Windows 控制面板中的“程序和功能”来查看版本号。

CoDesigner MCAD 功能区

在 MCAD 软件中安装 CoDesigner 插件后,界面中会添加 Altium CoDesigner 功能区。单击 Altium CoDesigner 选项卡即可访问该功能区,轻松使用 ECAD-MCAD 协同设计过程中所需的常用 PCB 专用设计对象。使用这些按钮可确保采用正确的 MCAD 对象类型来创建兼容的 ECAD 对象。

使用 CoDesigner 功能区,以兼容 ECAD 的方式定义 PCB 上的对象。使用 CoDesigner 功能区,以兼容 ECAD 的方式定义 PCB 上的对象。

推荐的协作工作流程

ECAD-MCAD 协同设计是一个灵活的过程,没有必须遵循的固定方法。虽然电路板形状通常在 MCAD 中设计,但电路板厚度must在 ECAD 中定义,因为各种 PCB 层材料是在 ECAD 中选择和配置的。基于这一要求,建议采用以下设计流程。

在 ECAD 中启动协作流程

In ECAD:

  1. 创建项目。

  2. 添加 PCB。

  3. 定义层叠结构,以设置电路板厚度。

  4. 打开 MCAD CoDesigner 面板(单击设计空间右下角的 Panels 按钮并选择面板名称,或使用 View » Panels 子菜单),

  5. Push使用 MCAD CoDesigner 面板中的按钮推送电路板。除了将 ECAD-MCAD 交换数据推送到工作区之外,此操作还会将项目和电路板文件保存到工作区。保存的项目和电路板将成为 ECAD 设计人员的工作文件。


In MCAD:

  1. 打开 Altium CoDesigner 面板。打开面板的步骤取决于所使用的 MCAD 软件;有关更多详细信息,请参阅相应的在 MCAD 软件中安装 CoDesigner链接。

  2. Pull 在 Altium CoDesigner 面板中的电路板——这将根据工作区中的电路板定义创建 MCAD 电路板装配体。

  1. 将电路板插入设备装配体。
  2. 配置电路板外形,使其适配外壳。
  3. 定义安装孔。
  4. 放置对位置有严格要求的机电元件。
  5. 定义所需的禁布区或文本注释区域。
  6. 保存 MCAD 装配体。

    有关定义电路板外形、添加孔和放置元件的更多详细信息,请参阅给机械工程师的建议部分。

Pushing from MCAD back to ECAD:

  1. 使用 MCAD CoDesigner 面板中的按钮,将电路板 Push 到工作区——这会将电路板定义、孔及已放置元件的详细信息保存为 MCAD-ECAD 交换数据。

Pulling into ECAD:

  1. 打开电路板并执行 Pull,以从工作区加载更新后的电路板定义和元件详细信息。

In MCAD or ECAD:

  1. 重新打开装配体或 PCB 文件,继续进行设计。

在 MCAD 中启动协作流程

Starting the Board in MCAD:

  1. 可以在 MCAD 中启动 PCB 设计流程,但不建议这样做。在所有受支持的 MCAD 环境中,操作流程均相同。

推送并共享以邀请机械工程师(工作区托管于 Altium 365)

在 ECAD 的 MCAD CoDesigner 面板中单击 Push 时,MCAD CoDesigner 面板还提供了与其他工程师Share项目的选项。

CoDesigner 通过您的 Altium 工作区来回传递专用的 ECAD-to-MCAD 数据包,从而推送和拉取电路板设计。选中 Share 复选框后,将启动一个流程,为受邀工程师配置工作区访问权限和项目权限,使其能够访问项目,包括专用的 ECAD-MCAD 数据包。受邀工程师可通过其 MCAD 软件中 Altium CoDesigner 面板的推送/拉取功能访问项目;如果他们已有 Altium 账户,或在接受邀请的过程中选择创建 Altium 账户,也可以通过 Web 浏览器访问项目。

Share 复选框的选中状态取决于工作区中是否存在被分配了 Mechanical Engineers 角色的成员。如果没有,则该复选框默认为On。

项目可以与任何人共享,无论对方是否已是项目所属工作区的成员,甚至是否拥有 Altium 账户。下表根据执行共享时受邀者的权限状态,总结了其对项目的访问权限。

Existing Altium Account Status Existing Workspace Status Permissions Assigned During Share Notes
无有效的 Altium 账户 不是项目所属工作区的成员 获得项目的访客访问权限,并具有编辑权限

受邀者会收到一封电子邮件,其中包含创建 Altium 账户的链接。创建账户后,该访客还可以通过其个人空间中的与我共享部分,在浏览器中访问该项目。

请注意,受邀者将无法从其 MCAD 软件访问项目。将该用户添加为工作区成员并为其分配编辑权限,即可解决此问题。

有效的 Altium 账户 不是项目所属工作区的成员 成为项目所属工作区的成员并被分配 Mechanical Engineer 角色,项目以查看权限共享

新的工作区成员会被分配 Mechanical Engineer 角色。由于工作区现在已有被分配 ME 角色的成员,共享复选框将不再自动选中。

请注意,必须将项目权限提升为编辑,机械工程师才能从 MCAD 执行推送。

有效的 Altium 账户 已是项目所属工作区的成员 项目以编辑权限共享  

共享流程

如果选中了 Share 复选框,则在 MCAD CoDesigner 面板中单击 Send 按钮时,将打开 Share with a Mechanical Engineer 对话框。

输入您希望与之共享项目的人员的Email Address(以及可选的Note),然后单击对话框中的 Share 按钮。如果受邀者尚不是工作区成员,则会出现 Share with a Mechanical Engineer 通知对话框,提醒您受邀用户可能不属于您的组织。

在此对话框中单击 OK 后,或者如果对方已经是您的工作区成员,系统便会生成通知邮件并发送给受邀者。

请注意,电子邮件通知功能要求在工作区中启用 Enable Mail Notifications 选项()。

稍等片刻后,将出现操作成功对话框。

现在,项目已与该机械工程师共享。

执行推送和共享的注意事项

  • 您应在浏览器中登录工作区,并在项目的 Share 对话框()中确认已为受邀机械工程师分配Edit permissions。虽然机械工程师仅凭查看权限就能拉取电路板,但如果未以编辑权限向其共享 the project,他们将无法推送对电路板设计的更改。由于 ECAD-MCAD 协同设计通过不依赖特定工具的中间文件进行,而机械工程师对实际 PCB 设计文件仅具有只读访问权限,因此共享的风险较低。

  • 工作区的所有管理员都会收到一封通知邮件,告知某位受邀者(以其电子邮件地址标识)已获邀访问项目。

  • 如果受邀者没有 Altium 账户,他们会收到一封电子邮件,引导其前往一个中间表单来注册 Altium 账户。注册完成后,项目将以 Guest 身份及 Edit permissions 权限与其共享。请注意,没有 Altium 账户的受邀者在注册后,会被视为独立的个人组织,而不会被添加为您的工作区成员。

  • 如果执行推送和共享的 Altium Designer 工程师没有工作区管理员权限,则流程中会增加一个阶段。首先,所有工作区管理员都会收到共享请求通知。管理员批准邀请请求()后,系统将按上述方式处理邀请,最初发起邀请的人也会收到电子邮件通知。了解有关邀请其他用户加入您的 Altium 365 工作区的更多信息。

在 MCAD 和 ECAD 之间协作

CoDesigner 当前检测更改的精度为:线性尺寸 0.5 mils (0.0127 mm),角度尺寸 0.5 degrees。未来的 CoDesigner 更新将提高此精度。

在设计过程中的任何阶段,都可以使用 CoDesigner 面板在 MCAD 和 ECAD 工具之间传递更改。

通过 CoDesigner 面板在 MCAD 和 ECAD 工具之间推送和拉取更改。 Changes to the board and component detail are Pulled from MCAD in the MCAD CoDesigner panel 通过 CoDesigner 面板在 MCAD 和 ECAD 工具之间推送和拉取更改。

  1. 要传递设计更改,请单击相应面板中的 Push 按钮。
  2. 单击 Push 按钮后,源编辑器面板顶部会出现一个编辑窗口。输入有关设计更改的消息,然后单击 Send。
  3. 单击发送后:
    • 如果修改后的 PCB 文件工作副本当前尚未保存,系统会自动保存。
    • 更改将写入您的工作区。
    • 已发布的消息将显示在源编辑器 CoDesigner 面板的消息线程中。
    • 目标编辑器下次打开设计文件的工作副本时,其面板会显示一条消息,提示有待处理的更改。
  4. 在目标编辑器面板中单击 Pull,将显示一个列表,详细列出重新同步设计所需的各项更改。

使用更改列表

单击 Pull 按钮后,将列出为使工作文件与工作区中的快照同步而需要进行的每项更改,如下所示。

Incoming changes are detailed in the CoDesigner panel, these can be selectively enabled as required

  • 当前设计与存储在 Workspace 中的快照之间检测到的每一处差异,都会作为一项变更详细列在变更列表中。
  • 您不必接受每一项变更。如果忽略某项变更,下次沿同一方向执行更新时,该变更会再次出现在变更列表中。请注意,如果您选择忽略某项变更(例如移动安装孔),随后又推送了自己的设计变更,则被忽略的变更可能会被覆盖,因为在您的版本中,安装孔仍位于原来的位置。MCAD 设计人员可以通过不接受您对安装孔位置的移动,来避免丢失自己的变更。
  • 一项设计变更(例如更改元件位置)可能会在变更列表中对应多项变更。移动 PCB 元件时,MCAD 中会发生以下变更:元件的位置、元件在元件丝印层上形成的图形,以及元件在顶层和底层铜层上形成的图形。相关变更应全部一起应用。
  • 列表中可能包含无法在目标环境中应用的变更。在这种情况下,该变更仍会显示,但其复选框不可用,表示无法解决此差异。
  • 在变更列表中单击某项变更时,设计空间会尽可能高亮显示所选变更。
  • 单击 Apply 以应用已勾选的变更。

有关定义板外形、添加孔和放置元件的更多详细信息,请参阅机械工程师建议部分。

以下类型的 PCB 将not从 ECAD 传输到 MCAD:

  • Autodesk Inventor、Autodesk Fusion 和 Siemens NX 不支持刚挠结合板,电路板将作为单个刚性结构加载到 MCAD 中。SOLIDWORKS 和 PTC Creo 支持刚挠结合板,了解更多有关同步刚挠结合板的信息。

  • CoDesigner 仅在 PTC Creo 和 SOLIDWORKS 这两款 MCAD 软件中支持拉取和推送多板装配体。了解更多有关使用 Altium MCAD CoDesigner 同步多板装配体的信息。

MCAD 坐标网格

将电路板从 ECAD 推送到 MCAD 时,CoDesigner 使用 ECAD 绝对原点作为参考。CoDesigner 2.4 引入了一项功能:当 MCAD 原点与默认的 ECAD(绝对)原点不同时,在拉取到 ECAD 时创建新的 MCAD Coordinates 网格,其中包含一个 MCAD Origin 实体。这有助于电子工程师与机械工程师就不同电路板实体的位置进行沟通。

可以在 ECAD 中自定义 MCAD Coordinates 网格的显示方式,双击 Properties 面板中的条目即可打开网格编辑器对话框。了解更多有关 PCB 网格系统的信息。

在 MCAD 中定义的坐标网格也可以在 ECAD 中自定义。在 MCAD 中定义的坐标网格也可以在 ECAD 中自定义。

请注意,应在放置元件和其他对象之前更改 MCAD 中板框的位置,以免之后必须手动恢复这些对象的位置。

用于元件放置的 MCAD 平面

从 CoDesigner 2.2.0 开始,拉取电路板时会在 MCAD 中创建顶面和底面元件平面,以简化在 MCAD 中放置元件的过程。从 ECAD 推送的元件在 MCAD 中放置时会忽略阻焊层的厚度。

CoDesigner 如何处理铜层、阻焊层和丝印层

除了板外形和元件之外,CoDesigner 还会将顶面和底面的铜层、阻焊层和元件丝印层从 ECAD 传输到 MCAD。

以贴图形式呈现 ECAD 层

默认情况下,这些层会以单独的 SVG 图像形式从 ECAD 推送到 Workspace。将电路板装配体拉取到 MCAD 时,CoDesigner 会将 SVG 图像转换为 PNG 图像。随后,CoDesigner 会将顶面的一组 PNG 图像合并为一张顶面贴图,并将底面的一组图像合并为一张底面贴图。在拉取到 MCAD 的过程中,这两张贴图会分别应用到电路板的顶面和底面。

顶面和底面贴图分别应用于 MCAD 中电路板的两面。 顶面和底面贴图分别应用于 MCAD 中电路板的两面。

Autodesk Fusion — 以草图轮廓形式呈现 ECAD 层

将顶层/底层铜层和元件丝印层从 ECAD 传输到 Autodesk Fusion 时,采用的是另一种方法。在 Autodesk Fusion 中,这些层被导入为绘制在电路板对象上的草图轮廓。单击 Autodesk Fusion 的 Altium CoDesigner 功能区中的 Advanced Geometry( )按钮,可以切换这组层的显示状态。也可以使用 Autodesk Fusion 的可见性图标,有选择地隐藏或显示其中的任意层。

元件丝印层和表面铜层在 Autodesk Fusion 中以草图轮廓形式创建。元件丝印层和表面铜层在 Autodesk Fusion 中以草图轮廓形式创建。

顶层/底层阻焊层不会传输到 Autodesk Fusion,而是将 ECAD 顶层阻焊层的颜色应用于电路板对象。

MCAD 中的高级铜几何体

除了在 MCAD 中显示铜层、阻焊层和丝印层的贴图(图像)之外,CoDesigner 还可以将实际铜几何体(称为 Advanced Copper Geometry)和 3D 阻焊层传输到 MCAD。目前,PTC Creo、Autodesk Inventor、SOLIDWORKS 和 Siemens NX 支持此功能。从 CoDesigner 2.7 开始,元件丝印贴图会应用到阻焊层拉伸体的表面。

如有需要,可以将铜层传输到 MCAD。在上图中,除顶层铜层外,元件和其他层均已隐藏。如有需要,可以将铜层传输到 MCAD。在上图中,除顶层铜层外,元件和其他层均已隐藏。

要包含高级铜几何体,请在 Altium CoDesigner Settings 对话框中启用 Build 3D geometry for Copper and Solder Mask 选项(如有需要,同时启用 Build Vias 选项)。可通过 Altium CoDesigner 面板中的 CoDesigner 菜单()打开设置对话框。

启用“为铜和阻焊层构建 3D 几何体”选项,即可在 MCAD 装配体中包含这些层(Autodesk Inventor 对话框)。启用“为铜和阻焊层构建 3D 几何体”选项,即可在 MCAD 装配体中包含这些层(Autodesk Inventor 对话框)。

使用铜几何体和 3D 阻焊层的注意事项:

  • 铜层和阻焊层以 MCAD 子装配体的形式包含在内。
  • 层叠中存在的所有 PCB 铜层都会包含在内。请注意,铜层厚度不包含表面处理等镀层数据。此功能将在未来的更新中添加。
  • 启用 Build 3D geometry for Copper and Solder Mask 选项后,将包含通孔焊盘的孔壁铜。
  • 启用 Build 3D geometry for Copper and Solder Mask 选项后,也会包含过孔的表面图形。启用 Build Vias 选项可包含过孔的孔壁铜。
  • 启用 Build 3D geometry for Copper and Solder Mask 选项后,元件丝印贴图会应用到阻焊层拉伸体的表面。
  • 根据设计的复杂程度,包含铜几何体和过孔可能会significantly increase文件大小以及将设计拉取到 MCAD 所需的时间。
  • 铜层和阻焊层数据始终会从 ECAD 推送。如果您在 MCAD 中启用了 Build 3D geometry for Copper and Solder Mask 和 Build Vias 选项,则无需再次从 ECAD 推送,只需关闭电路板并从 Workspace 重新拉取即可。

Notes:

  • 请参阅右侧窗格中的 Note,了解您安装的 MCAD CoDesigner 是否支持高级铜几何体功能。如果不支持, 可以使用基于图像的贴花,如上文所述。
  • 铜形状只能在 ECAD 中编辑,在 MCAD 中所做的编辑不会推送到 ECAD。

精确呈现阻焊层

从更新版本 2.5 开始,启用 Build 3D Copper 选项后,CoDesigner 会在 MCAD 中将阻焊层构建为独立实体的精确模型,其中包含焊盘开窗。由于阻焊材料会填充铜层之间的蚀刻区域,因此 MCAD 中阻焊层的厚度为 ECAD 中定义的顶层铜厚与阻焊层厚度之和。

由于阻焊材料会填充走线、焊盘和过孔之间的蚀刻区域,因此其在 MCAD 中的总厚度为 ECAD 中定义的铜层厚度与阻焊层厚度之和。由于阻焊材料会填充走线、焊盘和过孔之间的蚀刻区域,因此其在 MCAD 中的总厚度为 ECAD 中定义的铜层厚度与阻焊层厚度之和。

如前所述,在 MCAD 中,元件放置在顶面和底面的元件平面上(这些平面在拉取电路板时于 MCAD 中创建)。由于这些平面位于顶层和底层铜层的外表面,因此从 ECAD 推送的元件在 MCAD 中放置时不会考虑阻焊层的厚度。这会导致元件与阻焊层发生碰撞。如果这些碰撞影响设计,可暂时减小 PCB 的厚度,使元件实际上位于阻焊层的外表面上。未来的更新将通过添加在 MCAD 中隐藏阻焊层的选项来解决此问题。

支持禁布区和 Room

Altium CoDesigner 功能区提供了一种便捷方式,可在 MCAD 中访问常用的 PCB 专用设计对象,包括禁布区和 Room。使用这些按钮可确保使用正确的 MCAD 对象类型来创建兼容的 ECAD 对象。

支持禁布区

PCB 禁布区是电路板上用于限制特定 ECAD 对象放置的区域。禁布区可以定义在电路板的任意一面,也可以应用于所有 PCB 层。通过禁布限制属性,可以选择禁止放置在该区域内的对象。

在 MCAD 中定义禁布区:

  • 单击 Altium CoDesigner 功能区上的 Keep Out Area 按钮。
  • 系统将提示您选择一个面、曲面或平面,请单击电路板上需要设置禁布区的一面。如果禁布区要应用于所有层,则可以在任意一面绘制。
  • 单击合适的 MCAD 草图工具(例如矩形)来定义禁布区。请注意,草图只能包含一个轮廓; 不支持内部轮廓。
  • 绘制禁布区所需的形状。
  • 退出 Sketch 模式。
  • 现在可以编辑该特征的属性。您可以将禁布区视为围绕禁布区域的围栏,将 Depth 修改为较小的值,例如 1mm。
  • 此禁布区将成为 ECAD 中特定层的禁布区,所在层对应于在 MCAD 中绘制它的层。要定义适用于所有层的禁布区,请在 MCAD 中将禁布区配置为双向拉伸,并将第二个方向的 Depth 设置为足够大的值,使其能够贯穿电路板。
  • 单击 MCAD 的接受按钮 ,完成特征定义过程。如有需要,可以在特征树中重命名该特征。
  • 在 Altium CoDesigner 面板中,选择 PCB Definition 选项卡,并根据需要配置禁布限制。现在可以将禁布区推送到 ECAD,它将在其中添加为禁布区域。根据在 MCAD 中的配置,它将成为顶层禁布区、底层禁布区或禁布层禁布区。如有需要,可以在 ECAD 中调整禁布区形状,然后将其推送回 MCAD。

支持 Room

PCB Room 是一种设计规则,用于定义特定元件必须放置或禁止放置的区域。此规则的一个常见用途是在 Room 覆盖的电路板区域内定义元件高度限制。通常,Room 规则会应用于单个元件或某个元件类。

在 MCAD 中定义 Room:

  • 单击 Altium CoDesigner 功能区上的 Text Note Room 按钮。

  • 系统将提示您选择一个面、曲面或平面,请单击电路板上需要设置 Room 的一面。

  • 单击合适的 MCAD 草图工具(例如矩形)来定义 Room。请注意,草图只能包含一个轮廓; 不支持内部轮廓。

  • 绘制 Room 所需的形状。

  • 退出 Sketch 模式。

  • 单击 MCAD 的接受按钮 ,完成特征定义过程。如有需要,可以在特征树中重命名该特征。

  • 在 Altium CoDesigner 面板中,选择 PCB Definition 选项卡,并为 Room 输入注释,向 ECAD 工程师说明其用途。现在可以将 Room 推送到 ECAD,它将在其中添加为 Placement Room 设计规则,所在层对应于在 MCAD 中绘制它的层。MCAD 与 ECAD 之间唯一可以传递的属性是注释,它将成为 Placement Room 设计规则的注释。

  • 现在可以根据需要在 ECAD 中配置 Placement Room 设计规则。

可以在 MCAD 中定义禁布区和 Room,并将其推送到 ECAD。可以在 MCAD 中定义禁布区和 Room,并将其推送到 ECAD。

传递电路板区域时的注意事项:

  • 支持填充和实心区域形式的 ECAD 禁布区域。
  • CoDesigner 会检测 ECAD 中禁布区和 Room 的锁定状态,确保在 MCAD 中执行拉取操作时不会移动这些对象。
  • 由于 ECAD 禁布区对象不包含唯一标识符或对象名称,因此将禁布区更改从 ECAD 传递到 MCAD 时,会先删除现有对象,再添加新对象(使用新的 MCAD 名称)。
  • 将更改从 ECAD 传递到 MCAD 时,对 ECAD Room 的更改也会标记为删除和添加,但会保留名称和注释。
  • 在 ECAD 中创建或更改的禁布区和 Room 默认不会显示在 MCAD 中,以减少机械工程师看到的冗余视觉信息。需要时,可以恢复它们在 MCAD 中的可见性。

Important Note about Versions: 如果 ECAD 扩展可能已更新,而 MCAD 插件尚未更新,则在将 MCAD 更改应用到 ECAD 时务必小心。如果您已在 ECAD 中为 PCB 定义禁布区和 Room,CoDesigner 将建议删除它们。解决方法很简单,只需在 ECAD 中拒绝这些更改,即可保留禁布区和 Room。

控制拉取到 MCAD 的元件数量

为提高处理含有大量元件的电路板时的性能,CoDesigner 支持在从 ECAD 拉取时排除低于用户自定义高度的元件。对于高度阈值,CoDesigner 使用 ECAD 中元件属性所定义的高度。请注意,这是 PCB 元件的 Height 属性,而不是添加到元件封装中的 3D 模型的高度()。

CoDesigner 检查的高度阈值在 Altium CoDesigner Settings 对话框中定义,如下图所示。可通过 MCAD 中的 Altium CoDesigner 面板访问该对话框:在面板菜单中选择 Settings 即可打开。下图显示了 Autodesk Fusion 的设置,各个受支持的 MCAD 中均提供相同的设置。

通过设置“忽略低于高度阈值的元件”,可在拉取到 MCAD 时排除小型元件。通过设置“忽略低于高度阈值的元件”,可在拉取到 MCAD 时排除小型元件。

在 ECAD 中配置元件高度

下面的视频演示了如何查找未定义 Height(默认为零)的 PCB 元件,以及如何快速更新多个元件的高度值。随后演示了如何在 MCAD 中设置 Ignore components setting smaller than,以及 MCAD CoDesigner 在从 ECAD 拉取时如何处理此设置。 

可在 ECAD 中快速检测并修正不正确的元件高度值。

MCAD 中的智能草图更改

假设 ECAD 工程师需要修改板框,而该板框在 MCAD 中已应用了尺寸标注和约束。以前,将电路板拉取回 MCAD 时,MCAD 草图中的尺寸标注和约束会丢失。现在,在拉取过程中,CoDesigner 仅重绘草图中在 ECAD 内发生更改的元素,从而使未更改元素相关的尺寸标注和约束保持原样。

请注意,在某些情况下,例如存在复杂机械约束时,此行为可能导致几何形状发生意外变化。在这种情况下,禁用这项新的智能草图支持功能并重新拉取,然后重建尺寸标注和约束(与早期版本的 CoDesigner 中所需的操作相同),可能更为高效。可通过禁用 MCAD 的 Altium CoDesigner Settings 对话框中的 Smart Sketch Change 选项来实现。

从 ECAD 拉取时,不受设计更改影响的智能尺寸标注将被保留。

在 MCAD 中管理 PCB 铣削刀具路径

电路板设计中常见的一项功能是沿板框外缘定义铣削路径。此路径通常包含多排小孔(称为“鼠咬孔”),孔周围保留的材料足以将电路板固定在制造时所用的拼板中。PCB 装配完成后,即可将电路板从周围的废料中掰下。

请注意电路板外缘周围的铣削路径,包括“鼠咬孔”。

铣削刀具路径在 ECAD 的机械层上定义,该层已配置为铣削刀具路径层。

 

虽然铣削刀具路径对于制造至关重要,但在 MCAD 设计过程中通常并不需要它,因为机械工程师需要专注于如何将电路板安装到产品外壳中。 MCAD CoDesigner 3.13 更新在 Altium CoDesigner Settings 对话框中引入了 Build Route Tool Path 选项,使机械工程师能够控制是否将铣削刀具路径拉取到 MCAD 中(请注意,该路径始终会从 ECAD 推送)。 

选择是否在拉取到 MCAD 时包含铣削刀具路径。选择是否在拉取到 MCAD 时包含铣削刀具路径。

协同设计具有变体的 PCB

Altium Designer 允许电子设计工程师为正在设计的产品创建变体。支持的变体包括:将元件标记为不装配;修改元件参数,包括丝印在电路板上的元件值;或将元件替换为替代元件(替代元件可能使用不同的封装,也可能使用相同的封装)。

在 Altium Designer 中,只有一个电路板设计。变体信息(例如替代元件的详细信息)存储在项目文件中,并在 Projects 面板中选中该变体时应用到电路板。电路板的 [No Variations] 版本保存为 PcbDoc。

可以使用 Altium Designer 创建电路板设计的变体,在 Projects 面板中选择变体,然后在 CoDesigner 面板中推送到 MCAD。可以使用 Altium Designer 创建电路板设计的变体,在 Projects 面板中选择变体,然后在 CoDesigner 面板中推送到 MCAD。

详细了解在 ECAD 中使用变体

给机械工程师的建议

本节详细介绍机械工程师在使用 CoDesigner 时应了解的功能和行为。

在 MCAD 中显示 ECAD 位号

Altium MCAD CoDesigner 在各个 MCAD 工具中采用不同的方式显示位号:

  • Autodesk Fusion – 显示 ECAD Properties 面板,以查看当前所选零件的属性()。
  • Autodesk Inventor – 默认情况下,位号显示在模型树中()。
  • PTC Creo – 在面板的 Model Tree 模式下,单击 Tree Columns 按钮,打开 Model Tree Columns 对话框。将 Not Displayed Type 设置为 ECAD Params,找到 ECAD_REF_DES 参数,然后单击 Add Column 按钮()。
  • SOLIDWORKS – 默认情况下,模型树中会显示参考标号()。
  • Siemens NX – 在装配导航器中,在显示列名称的位置 right-click,打开上下文菜单,然后选择 Columns » Component Name 以显示元件名称列()。

在机械工程师之间同步更改

  1. CoDesigner 通过 Altium 工作区(例如 Altium 365 工作区)将机械 PCB 装配体传输到 ECAD。通过工作区推送/拉取的更改具有方向性——从 MCAD 推送(并拉取到 ECAD)的 PCB 装配体,与从 ECAD 推送(并拉取到 MCAD)的 PCB 装配体在工作区中分别存储。这意味着,第二位机械工程师无法拉取另一位机械工程师刚刚推送到工作区的已修改电路板,而是会拉取上次推送的 ECAD 数据。请注意,MCAD 约束仅存在于创建这些约束的 MCAD 装配体中。将电路板从 MCAD 推送到 ECAD 时,会推送由约束确定的元件位置,但不会推送约束本身。因此,如果将电路板拉取到新的 MCAD 装配体中,其中将不包含之前的 MCAD 工程师创建的任何约束。

ECAD 和 MCAD 的更改在工作区中分别存储。ECAD 和 MCAD 的更改在工作区中分别存储。

要让其他机械工程师看到您的更改,请像保存其他装配体一样,将 PCB 装配体保存到双方均可访问的公共存储位置。此方法会保留所有 MCAD 约束。另一种方法是让 ECAD 设计人员将数据拉取到 ECAD 中,保存后,再将更新后的设计推送回 MCAD。但如上所述,使用此方法不会包含任何 MCAD 约束。

  1. 另一个要点是,不同机械工程师对同一 PCB 装配体所做的更改在推送时不会合并,任何机械工程师最后推送的更改都会覆盖其他机械工程师之前推送的更改。

Altium 工作区并非用于供多位 MCAD 工程师同步更改;这应通过合适的 MCAD 产品数据管理系统来完成。如果没有可用的 PDM 系统,而是使用 Altium 工作区,请记住,ECAD 工程师必须先拉取并接受 MCAD 工程师 1 的更改,然后将更新后的电路板推送回工作区,MCAD 工程师 2 才能拉取并看到这些更改(如下所述)。

同步过程图解

ECAD 和 MCAD 将各自的更改推送到工作区中的不同存储位置。这意味着,每位工程师只能拉取另一位工程师推送的更改。只有当另一位工程师在推送前已接受了自己所做的更改时,拉取的数据才会包含自己所做的这些更改。

例如,在 ECAD 中创建一块电路板,将其推送到工作区,再拉取到 MCAD:

在 ECAD 中进行设计更改

将更改推送到 MCAD 后(存储在工作区中)

即可将其拉取到 MCAD 中

 

如果 ECAD 工程师随后添加元件,AND MCAD 工程师添加孔,AND 如果双方各自推送自己的电路板,然后拉取对方的电路板,CoDesigner 将尝试删除 MCAD 工程师电路板上的孔,以及 ECAD 工程师电路板上的元件:

在 ECAD 和 MCAD 中同时进行更改

如果两位工程师都在拉取对方的更改之前推送自己的更改

对方的设计更改将会丢失

 

每位工程师都可以选择拒绝特定的拟议更改,例如,ECAD 工程师可以接受添加孔,但拒绝删除元件。不过,对于复杂的电路板和/或更改,这种工作方式可能难以管理。另外,对贴花的所有更改都会被 CoDesigner 视为单一更改,因此只能整体接受或拒绝,无法逐项处理。

更好的方法是由一位工程师先进行更改并推送电路板,然后另一位工程师先拉取电路板,再进行自己的更改,如下所示。

 

 

 

 

 

 

 

 

 

采用循环方式在 ECAD 和 MCAD 之间传递设计更改。

在 MCAD 中将圆角和倒角纳入板形

机械工程师通常会通过添加倒角和圆角来塑造电路板的边角。如果在 MCAD 中将其定义为 3D 实体,CoDesigner 将无法将其传输到 ECAD,因为 ECAD PCB 编辑器将板形定义为带厚度的 2D 对象。为解决此问题,当 CoDesigner 检测到此类 3D 实体时,会提供将其转换为 2D 实体并嵌入 电路板草图的选项。 

CoDesigner 可以将 MCAD 中应用于 Z 轴方向边缘的 3D 圆角和倒角转换为 2D,并推送到 ECAD。CoDesigner 可以将 MCAD 中应用于 Z 轴方向边缘的 3D 圆角和倒角转换为 2D,并推送到 ECAD。

  • 请注意,圆角和倒角的转换是单向过程。转换后,将无法再将其作为 3D 实体进行编辑。 
  • 3D 实体转换为 2D 实体的初步支持范围是 在 MCAD 中板形的垂直边缘(沿 Z 轴的边缘)上创建的 3D 圆角和倒角。
  • CoDesigner 3.9 之前的版本会向机械工程师发出警告,提示存在此类实体,但会忽略这些实体。

圆角和倒角支持情况:

  • 支持半径恒定的常规(圆形)圆角()。
  • 支持以距边缘相等距离 (对称距离-距离)定义的倒角()。
  • 不支持以角度-距离()或非对称距离-距离定义的倒角。
  • 不支持在非直线侧边以及其他圆角和倒角上定义的圆角和倒角。
  • 不支持在 刚柔结合设计上定义的圆角和倒角。

解决 ECAD 中的板轮廓问题

从 ECAD 推送电路板时,CoDesigner 会检查板轮廓,并在发现微小线段问题或自相交轮廓时向用户发出警告。将电路板拉取到 MCAD 时,CoDesigner 会尝试解决这些问题。如果无法解决,则必须在 ECAD 中解决。

自动移除微小线段

CoDesigner 2.4 引入了一项自动功能,用于检测并处理板外形中的微小线段。如果检测到此类问题,将显示一个对话框,提示您解决这些问题,如下所示。如果单击 Yes,检测到的问题将自动得到解决。如果单击 No 并关闭对话框,随后将显示一个错误对话框,详细列出各个问题的位置,您必须手动解决这些问题(如下所述)。

请注意,此功能使用了新的 API,因此仅适用于 Altium Designer 21.3.x 或更高版本。

请注意,自动功能无法解决在板外形或板切口中检测到的自相交问题。要解决这些问题,可以使用下文介绍的手动方法。

手动移除微小线段和自相交

未能自动解决的微小线段和自相交问题,以及在板切口中检测到的此类问题,都必须手动解决。

要在 ECAD 中修复这些问题:

  1. 将对话框中的错误信息复制到文本编辑器中,以便随时查阅问题所在位置的坐标。

  2. 将捕捉栅格(快捷键 Gtrl+G)设置为较小的值(例如 0.001 mil),以便对顶点位置进行微调。

  3. 切换到 View » Board Planning Mode。

  4. 放大问题所在的位置。也可以使用“跳转到位置”命令(Edit » Jump » New Location,或快捷键 J、L),然后在 Jump to Location 对话框中输入坐标。请注意,如果所用单位与当前电路板单位不同,可以在数值后附上单位(mm 或 mil)。如果问题由圆弧引起,问题位置可能是圆弧的圆心。在这种情况下,请目视检查板外形中是否存在短而平缓的圆弧。

  5. 运行 Design » Edit Board Shape 命令(快捷键 D、D)。板外形将在每条边的两端和中心显示顶点。检查是否存在彼此非常接近的多个顶点,以及非常平缓的圆弧。以下提示可帮助您解决问题:

    1. 单击并拖动边或顶点以修改形状。编辑时可使用三种形状修改模式:断开边、移动(滑动)边、弯曲边;在编辑过程中按 Shift+Space 可循环切换模式。当前模式会显示在状态栏上。
    2. 稍微移动短边末端的顶点,然后松开鼠标按钮。这通常就足以让软件处理并移除该短边。
    3. 在弯曲模式下拖动中心顶点,将圆弧拉平,即可把短而平缓的圆弧转换为直边(松开鼠标后,圆弧将被直边替代)。
    4. 当移动的边或圆弧的弦与现有边对齐时,会显示绿色对齐辅助线。
    5. 单击并按住某个顶点,然后按 Delete 可将其移除;要添加顶点,请按住 Ctrl 并单击边,然后将光标移到所需位置并松开。

     

  6. 再次推送电路板。

必须先解决板轮廓的自相交和微小线段问题,才能将电路板推送到 MCAD。

上方视频演示了如何在 Altium Designer 中解决板外形和板切口的问题。在其他 Altium 设计软件中,操作过程基本相同。

了解有关 顶点编辑模式的更多信息

了解有关 定义板形的更多信息

修复一个问题会使 ECAD 重新计算电路板或切口的整个轮廓,而重新计算可能会自动解决其他问题,因此建议每次修复后都执行一次推送。

将 PCB 的先前修订版本拉取到 MCAD

要将 ECAD 电路板拉取到空的 MCAD 装配体中,请单击 Altium CoDesigner 面板中的“拉取”按钮,打开“从公司工作区选择项目”对话框。该对话框默认提供最近推送的电路板。如果需要打开 PCB 设计的先前发布版本或修订版本,请单击对话框 ECAD Push to Open 部分中的 更改,打开 Select Push 对话框i。

该对话框列出了此前的所有推送,请选择所需的推送并单击 OK。 如果已为 ECAD 提交添加标签,可以启用 Select Push 对话框中的 Only show tagged commits 选项来快速筛选列表。

使用 Select Push 对话框,从 ECAD 中推送的所有修订版本中选择所需的先前修订版本。使用 Select Push 对话框,从 ECAD 中推送的所有修订版本中选择所需的先前修订版本。 

  • 工作区会执行自动推送,此过程将在首次拉取到 MCAD 后启动。了解有关自动推送的更多信息。

ECAD 端更改的可见性

请务必在 MCAD 软件中打开 PCB 装配体本身,而不是 PCB 装配体要装入的上级设备或装配体。如果打开的是 PCB 装配体,在 ECAD 端进行并推送的更改将详细列在 Altium CoDesigner 面板中。如果打开的是上级设备或装配体,面板中将不会详细列出这些更改。

从 ECAD 获取 PCB 装配体的更改

  1. 在 MCAD 中将 PCB 装配体作为单独的文件打开(作为根装配体)。
  2. 打开 Altium CoDesigner 面板。
  3. 单击 Pull。
  4. 查看表格中的更改,启用要应用的更改,然后单击 Apply 按钮。

在从 ECAD 传输到 MCAD 之前,3D 元器件模型会转换为 Parasolid 格式(了解有关 MCAD 中 3D 模型命名方式的更多信息)。在某些情况下,部分模型可能无法转换。此类模型在 MCAD 中会被其包围盒替代,CoDesigner 也会显示相关警告消息。

或者,您可以在 ECAD 中将此类模型替换为单实体 Parasolid 模型,因为此类模型会在 ECAD 和 MCAD 之间直接传输,无需转换。了解有关解决问题模型的更多信息。

首次在 MCAD 中打开 PCB 装配体时

  1. 将 PCB 装配体添加到设备装配体中。
  2. 应用适当的配合或约束,将其固定。

If a contour of the PCB does not correspond to the shape of your enclosure:

  1. 开始编辑电路板零件。
  2. 编辑电路板拉伸特征的草图,调整其形状以适配外壳。

更改 PCB 形状的一种方法是删除整个轮廓,然后通过偏移外壳的相应轮廓,从头创建电路板轮廓。

在 MCAD 中修改 PCB 设计

以下提示可帮助确保在将电路板推送到 ECAD 时,MCAD 中使用的设计形状和对象能够得到支持。

编辑电路板轮廓形状

  1. 开始编辑电路板零件。
  2. 编辑电路板拉伸特征的草图。

Notes:

  • 在 Creo 和 Inventor 的电路板轮廓草图中,或在 SolidWorks 的刚挠结合板轮廓草图中,不要包含任何内部轮廓。对于开槽和孔,请分别使用拉伸切除或孔特征。

  • 在 Inventor 的电路板轮廓草图中,不要创建多个轮廓,CoDesigner 对它们的解析可能产生不可预测的结果。

  • 在 Autodesk Fusion 中,如果使用“投影”命令投影现有外壳轮廓,以在 MCAD 中重新创建电路板形状,则必须禁用 Autodesk Fusion PROJECT 对话框中的 Projection Link 选项。启用“投影链接”选项后,每当参考轮廓的尺寸发生变化时,投影轮廓都会自动调整尺寸,目前 CoDesigner 不支持此功能。

更改 MCAD 电路板原点

  1. 如有必要,机械工程师可以在电路板定义的早期阶段更改裸板的 MCAD 原点。为此,机械工程师只需在电路板零件内移动或重新绘制电路板轮廓的整个 sketch。请注意,电路板零件在电路板装配体中被约束为“固定”,其原点与装配体原点重合(因此,“MCAD 原点”既指电路板零件原点,也指电路板装配体原点)。

强烈建议不要修改或破坏此约束,否则可能导致不可预测的变化。

Notes:

  • 如果已经放置了元件,则应在电路板装配体中相应地移动这些元件。
  • ECAD 中的“电气”电路板原点不会改变,因为它是单独处理的。

创建/编辑安装孔

  1. 开始编辑电路板零件。
  2. 在电路板零件的顶面或底面上创建/编辑 Hole 特征。

Notes:

  • 不支持特征阵列。
  • 如果孔的位置是相对于板边定义的,那么随后在 ECAD 中修改电路板轮廓并将其传回 MCAD 时,这些关联关系将被破坏。有关孔操作的更多信息,请参阅下文的使用约束和尺寸部分。

创建/编辑开槽

  1. 开始编辑电路板零件。
  2. 基于电路板零件的顶面或底面创建/编辑 Extruded Cut 特征。

Notes:

  • PTC Creo 或 Autodesk Inventor 不支持包含多个轮廓的草图,因此不应使用此类草图。*
  • 不支持特征阵列。
  • 如果拉伸切除的草图是相对于板边定义的,那么随后在 ECAD 中修改电路板轮廓并将其传回 MCAD 时,这些关联关系将被破坏。

编辑元件布局

  1. 开始编辑电路板装配体。
  2. 移动/旋转/翻转元件,或对元件应用配合/约束。

Notes:

  • 元件孔和丝印不会随 MCAD 中的元件移动而移动。要体现这些与元件相关的变化,请将电路板推送到 ECAD,在其中应用更改,然后将电路板从 ECAD 推送回 MCAD,以更新元件孔和丝印。
  • 如果在 ECAD 中修改电路板形状,引用板边的 MCAD 配合/约束可能会被破坏。

将 MCAD 中的固定或约束状态同步为 ECAD 中的锁定状态

如果元件在 MCAD 中被固定或受到约束,则它在 ECAD 中会被锁定(无论该约束是否允许其在 PCB 装配体内移动)。如果元件在 ECAD 中被锁定,则它在 MCAD 中会被固定,除非它在 MCAD 中已受到约束。锁定/固定状态的变化会在 MCAD 和 ECAD 之间同步。

将 ECAD 元件参数传输到 MCAD

ECAD PCB 元件参数会传输到 MCAD 中创建的相应模型。请注意,这不包括最初在 MCAD 中放置的元件。

在 MCAD 中使用约束和尺寸

应用于电路板轮廓的约束

  1. 机械工程师可以在电路板轮廓的某个元素与以下对象之间应用约束:另一个电路板轮廓元素、基准/参考特征、更高层级装配体中的零件,或元件。CoDesigner 不会修改这些约束。但是,如果在 ECAD 端更改电路板轮廓,MCAD 中的电路板零件草图将被重新绘制,所有边的 ID 都会改变。请注意,在 ECAD 中对电路板轮廓的任何部分进行任何更改,都会导致整个电路板在 MCAD 中重新绘制,并使所有板边 ID 发生变化。如果对这些边或其派生曲面应用了约束,这些约束将会失效。电路板在 MCAD 中将保持原位,如有必要,可以手动恢复这些约束。

考虑到重新定义约束所需的时间,建议only make changes to the board outline in MCAD。

Note: 请记住,CoDesigner 不能用于在机械工程师之间传输更改(请参阅在机械工程师之间同步更改)。

应用于元件的约束

  1. 机械工程师可以在元件与电路板、外壳或另一个元件之间应用约束。如果可以在本地找到该元件的模型(即未在其他文件夹中从头构建 PCB 装配体,或者已设置用于存储模型的公共文件夹),这些约束将保持有效。但是,如果在 ECAD 端移动了元件,MCAD 端的位置变化可能与该移动不一致,应进行手动检查(在这种情况下,CoDesigner 会通知您)。对于具有 ECAD 封装的元件,元件离板高度(Z 方向上相对于电路板表面的位置)始终由封装中 STEP 模型的位置定义。在向 MCAD 拉取时,CoDesigner 始终会尝试覆盖任何存在冲突的 MCAD 约束。

Note: 请谨慎选择应用配合/约束的位置。例如,如果未将 PCB 装配体固定在设备装配体中,就在 PCB 元件与外壳之间应用约束/配合,可能会导致设计发生不可预测的变化。

不会从 MCAD 传输到 ECAD 的更改

  • 裸板厚度——由 ECAD 中的层叠定义。

    Note:在 MCAD 中对板厚所做的更改将在 ECAD 中显示为不可应用的更改,以便 ECAD 设计人员了解所提出的更改。

  • 支持以恒定半径定义的 3D 圆角 和以距边缘相等距离(在 z 轴方向定义)定义的 3D 倒角 ,以及沿电路板 z 轴方向的孔和拉伸切除。对电路板零件应用的任何其他 3D 几何特征(例如角度-距离倒角)都会被忽略。详细了解如何使用圆角和倒角。
  • 对电路板零件应用的任何其他几何特征(例如 3D 倒角/圆角),但沿电路板 z 轴方向的孔和拉伸切除除外。
  • 在电路板装配体上下文中创建的任何其他几何特征(例如在装配体上下文中创建的孔),除非这些特征已传播到零件。
  • 元器件孔相对于元器件单独移动后的位置。
  • 元器件孔的尺寸。
  • 特征阵列。
  • 包含多个轮廓的切口草图(在 PTC Creo 和 Autodesk Inventor 中)。
  • 对拉伸铜所做的更改。
  • 对丝印所做的更改。
  • 元器件删除。由于元器件位置更改会传输到 ECAD,因此 MCAD 工程师可以通过将元器件移到电路板区域之外来表示删除 (了解不支持删除元器件的原因)。 

在设备装配体上下文中工作

CoDesigner 2.2.0 新增了在 MCAD 中的设备装配体层级进行工作,然后将外壳与电路板一起传输到 ECAD 的支持。下面的视频演示了将电路板装配体放入设备外壳并将外壳传输到 ECAD 的过程。

请参阅右侧窗格中的 Note,了解您安装的 MCAD CoDesigner 是否支持外壳交换功能。如果不支持,此视频演示了 另一种传输外壳的方法。

在设备装配体上下文中工作的概述。

使用外壳的提示:

  • 将电路板装配体放入外壳后,单击 Altium CoDesigner 面板中的 Recognize 按钮。CoDesigner 将检测电路板与外壳之间的关系,并在面板顶部详细列出添加到设备外壳中的所有电路板装配体的名称。

  • 检测到关系后,最后一步是将外壳添加到电路板。操作步骤如下:

    • 在模型树中选择外壳。
    • 显示 Altium CoDesigner 功能区。
    • 单击功能区上的 Enclosure 按钮。
    • 打开/显示 Altium CoDesigner 面板,您可以在 Altium CoDesigner 面板的 Board Enclosure 部分中确认外壳已与电路板关联。
  • 现在可以将外壳与电路板一起推送到 ECAD。

将包含更改的 PCB 装配体发送到 ECAD

  • 确保 PCB 装配体在 MCAD 中作为单独的文档(根装配体)打开。
  • 转到 Altium CoDesigner 面板。
  • 单击“推送”。

* 计划在未来的更新中改进此行为。

使用 MCAD 数据管理系统

请参阅右侧窗格中的 Note,了解您安装的 MCAD CoDesigner 是否支持 ECAD-MCAD 元器件链接功能。

将 PCB 从 ECAD 推送并拉取到 MCAD 时,CoDesigner 支持放置原生 MCAD 元器件。为此,CoDesigner 会请求 MCAD 软件从 MCAD 数据管理系统中获取元器件模型(按模型名称),然后将该元器件放置到 MCAD PCB 装配体上,以替代来自 ECAD 的模型。

目前,以下环境支持 ECAD 到 MCAD 的原生元器件链接:

  • 安装了 CoDesigner 插件 2.6.0 或更高版本,并连接到 PTC Windchill® 服务器的 PTC Creo Parametric。有关如何连接到 Windchill 的信息,请查阅 Creo 文档。详细了解如何配置 PTC Creo。
  • 安装了 CoDesigner 插件 2.6.0 或更高版本,并连接到 SOLIDWORKS® PDM Professional 的 SOLIDWORKS。有关如何连接到 SOLIDWORKS PDM 的信息,请查阅 SOLIDWORKS 文档。详细了解如何配置 SOLIDWORKS 以使用原生 MCAD 元器件。
  • 安装了 CoDesigner 插件 3.4.0 或更高版本,并连接到 Siemens Teamcenter PLM 的 Siemens® NX™。有关如何连接到 Teamcenter PLM 的信息,请查阅 Siemens NX 文档。详细了解如何配置 Siemens NX 以使用原生 MCAD 元器件。
  • ECAD 元器件与原生 MCAD 元器件之间的链接在您的 Altium 工作区中定义。详细了解如何将 ECAD 元器件链接到 MCAD 元器件。
  • Altium 工作区并非用于供多位 MCAD 工程师同步更改;应通过合适的 MCAD 产品数据管理系统来完成此操作。如果没有可用的 PDM 而使用 Altium 工作区,请注意,ECAD 工程师必须先拉取并接受 MCAD 工程师 1 的更改,然后将更新后的电路板推送回工作区,之后 MCAD 工程师 2 才能拉取并查看这些更改。

使用 SOLIDWORKS PDM

CoDesigner 已针对 SOLIDWORKS® PDM Professional 进行了开发和测试。

从 SOLIDWORKS PDM 放置原生 MCAD 元器件

将电路板设计从 ECAD 传输到 SOLIDWORKS MCAD 时,CoDesigner 支持使用 SOLIDWORKS PDM 系统中的等效原生 MCAD 元器件替换 ECAD 元器件。为此,您必须在以下位置配置设置:

  • MCAD - 配置 PDM 设置、CoDesigner 模型存储,并了解同步要求,具体说明见此处。
  • ECAD - 使用正确的语法在 ECAD 元器件中引用 MCAD 模型。必须在 ECAD 元器件中以参数形式定义 MCAD 元器件引用,参数值的格式为:
    <vault>:folder\folder\component.sldprt,其中 <vault> 是 SOLIDWORKS PDM 库的名称。
  • Workspace - 配置工作区选项,指定要使用原生 MCAD 元器件,并定义使用哪个 ECAD 元器件参数来引用等效的 MCAD 元器件。详细了解如何将 ECAD 元器件链接到 MCAD 元器件。

将更改拉取到现有 PCB 装配体之前

  • 将用于存储模型的公共文件夹元器件文件夹的本地副本与服务器同步(使用 SOLIDWORKS PDM 中的 Get latest version 命令)
  • 签出以下文件:
    • 电路板装配体
    • 电路板零件
    • 对于刚柔结合 2.0 装配体——所有电路板零件和子装配体
    • 如果构建了 3D 铜——与 3D 铜和阻焊层相关的装配体和零件
    • 贴花 PNG 文件(如果存储在 PDM 中)

Note: 通常,无需从 PDM 中签出元器件模型。

从 ECAD 向 MCAD 拉取更改时

  • 请留意 CoDesigner 可能要对元器件属性进行的任何更改——在 SOLIDWORKS 的 Altium CoDesigner 面板中,更改列表内的相应条目将以黄色高亮显示。

出现这些更改的一个常见原因是:在 MCAD 中创建元器件模型时,CoDesigner 会将 ECAD 元器件库中存储的元器件属性写入 MCAD 模型属性。然而,其中某些属性(例如 Description 和 Material)随后可能会被 MCAD 或 PDM 自动更改。因此,如果检测到属性值不同,CoDesigner 就会建议更改这些属性。

但是,如果您尝试应用这些更改,MCAD 会要求从 PDM 中签出每个受影响的模型,或将其另存为其他名称。为避免这种情况,请在 Altium CoDesigner 面板中取消勾选与修改元器件属性相关的更改。请注意,强烈建议您查明元器件属性存在差异的原因,并同步 MCAD 和 ECAD 两端的属性。

应用更改后

  • 将新创建的元器件、电路板装配体、子装配体和零件签入 PDM。

克隆 MCAD PCB

您是否希望克隆现有的 MCAD PCB 装配体,并将其复用于新的 PCB 项目,以保留机械尺寸和参考关系?只需编辑 MCAD 装配体克隆副本中的两个属性,即可实现这一点。

MCAD PCB 装配体通过 ManagedProjectGUID 和 ManagedProjectName 这两个属性与 ECAD 项目关联,您可以在 MCAD PCB 装配体的 Properties 对话框中查看和编辑这些属性。下图显示了 SOLIDWORKS 中的 Properties 对话框。

两个属性将 MCAD 装配体与 ECAD 项目关联起来。两个属性将 MCAD 装配体与 ECAD 项目关联起来。

  1. 要将现有的 MCAD PCB 装配体与新的 ECAD 项目关联,您需要更新 MCAD 装配体中的这些属性,使其与新的 ECAD 项目相匹配。
  • ManagedProjectName - ECAD PCB 项目文件名:<ManagedProjectName>.PrjPcb

  • ManagedProjectGUID - 要查找 GUID,可以从以下位置复制:

    1. 工作区的浏览器地址栏 – 打开存储该项目的 Altium 工作区,然后双击项目,在单独的浏览器选项卡中将其打开。浏览器地址栏中的 URL 包含 ManagedProjectGUID (); 或者,

    2. ECAD 项目文件 – 在文本编辑器中打开项目文件(其扩展名为 .PrjPcb)。ManagedProjectGUID 位于文件顶部的 [Design] 部分中 ()。复制 ManagedProjectGUID,但请do not modify or save在文本编辑器中对文件进行.PrjPcb。

  1. 在 MCAD 软件中,打开 MCAD PCB 装配体,编辑这两个属性的 Value,保存 MCAD 装配体并将其关闭。

  2. 重新打开克隆的 MCAD 装配体,并检查 Altium CoDesigner 面板的顶部;此时应显示您在步骤 1 中输入到克隆文件中的 ManagedProjectName 属性。如果显示正确,则说明克隆成功,现在可以从 MCAD 软件将电路板定义Pushed到工作区。

    编辑 ManagedProjectName 和 ManagedProjectGUID 属性后,CoDesigner 面板将显示更新后的项目名称。编辑 ManagedProjectName 和 ManagedProjectGUID 属性后,CoDesigner 面板将显示更新后的项目名称。

 

AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

Contents