Accessing, Defining & Managing Project Options

Altium Training

Altium Essentials: Schematic Electrical Rules Validation

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

At a Glance

Learn where to access the Project Options dialog in Altium Designer and how its settings control Workspace synchronization, design validation, and class generation. This article explains the controls for managing online availability, setting violation reporting levels, defining connectivity checks, and determining which classes transfer from schematics to the PCB. This page is also where you'll find information on configuring options for the Comparator, ECO generation, general options, multi-channel options, default prints, search paths (for file-based libraries), parameters, device sheets, managed Output Jobs and library-related options. Keep reading to configure your project settings with greater confidence.

- Find the Project Options dialog and understand the available Workspace synchronization and version control settings.
- Configure electrical and drafting violation reporting, including connectivity checks in the Connection Matrix.
- Understand class generation controls and the limitations that apply when using the Constraint Manager.
Go Deeper with AI:

The General, Error Reporting and Options tabs of the Project Options dialog
The General, Error Reporting and Options tabs of the Project Options dialog

Summary

An existing or newly created project is associated with a range of option settings that are specific to that project. These are stored in the project file (*.PrjPcb, for example) and will vary depending on the type of project. The option settings are configured in the Project Options dialog.

Access

The Project Options dialog is accessed in one of the following ways:

  • Right-click on the project entry in the Projects panel then click Project Options from the context menu.
  • Click the  icon in the Projects panel when the desired project is focused in the panel.
  • From any editor, select Project » Project Options from the main menus.

Dialog Tabs

If you find an issue, select the text/image and pressCtrl + Enterto send us your feedback.
Nav
Contents
Feature Availability

The features available to you depend on which Altium solution you have – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, or Altium Designer (on active term).

If you don’t see a documented feature in your actual software, contact Altium Sales to find out more.

Legacy Documentation

Altium Designer documentation is no longer versioned. If you need to access documentation for older versions of Altium Designer, visit the Legacy Documentation section of the Other Installers page.

Contents