Defining the Layer Stack

Now reading version 22. For the latest, read: Defining the Layer Stack for version 24
 

The PCB is designed and formed as a stack of layers. In the early days of printed circuit board (PCB) manufacturing, the board was simply an insulating core layer, clad with a thin layer of copper on one or both sides. Connections are formed in the copper layer(s) as conductive traces by etching away (removing) unwanted copper.

A single-sided PCB is shown on the left, typical of early PCB design. On the right is a rigid-flex PCB, where rigid sections are connected via flexible sections of PCB.        
A single-sided PCB is shown on the left, typical of early PCB design. On the right is a rigid-flex PCB, where rigid sections are connected via flexible sections of PCB.

Fast forward to today, where almost all PCB designs have multiple copper layers. Technological innovation and refinements in the processing technology have led to a number of revolutionary concepts in PCB fabrication, including the ability to design and manufacture flexible PCBs. By joining rigid sections of PCB together via flexible sections, complex, hybrid PCBs can be designed that can be folded to fit into unusually shaped enclosures.

In printed circuit board design, the layer stack defines how the layers are arranged in the vertical direction, or Z plane. Since it is fabricated as a single entity, any type of board, including a rigid-flex board, must be designed as a single entity. To do this, the designer must be able to define multiple PCB layer stacks and assign different layer stacks to different zones of the rigid-flex design.

Learn more about Rigid-Flex Design

The Layer Stack Manager

The definition of the PCB layer stack is a critical element of successful printed circuit board design. No longer just a series of simple copper connections that transfer electrical energy, the routing of many modern PCBs is designed as a series of circuit elements, or transmission lines.

Achieving a successful, high-speed PCB design is a process of balancing the material selection and layer stackup and assignment, against the routing dimensions and clearances required to achieve suitable single-sided and differential routing impedances. There are also numerous other design considerations that come into play when designing a modern, high-speed PCB, including layer-pairing, careful via design, possible back drilling requirements, rigid/flex requirements, copper balancing, layer stack symmetry, and material compliance.

The Layer Stack Manager brings together all of these layer-specific design requirements into a single editor.

To open the Layer Stack Manager select Design » Layer Stack Manager from the main menus. The Layer Stack Manager opens in a document editor in the same way as a schematic sheet, the PCB, and other document types do.

All aspects of layer stack management are performed in the Layer Stack Manager.
All aspects of layer stack management are performed in the Layer Stack Manager.

As a standard document editor, the Layer Stack Manager (LSM) can be left open while the board is being worked on, allowing you to switch back and forth between the board and the LSM. All of the standard view behaviors, such as splitting the screen or opening on a separate monitor are supported. Note that a Save action must be performed in the Layer Stack Manager before changes are reflected in the PCB.

The functionality is divided over a number of tabs displayed across the bottom of the Layer Stack Manager:

To change the measurement units in the active layer stack, choose Tools » Measurement Units then select the desired unit of measure (milinµ, or mm) or use the Ctrl+Q keyboard shortcut to cycle through the measurement units.

Editing the Layer Stack Properties

The Layer Stack Manager presents the layer properties in a spreadsheet-like grid. The properties can be edited directly in the grid or they can be edited in the Properties panel. The panel can be used in each of the Layer Stack Manager tabs, for example, giving access to the impedance profile and transmission line properties in the Impedance tab, or the µVia settings in the Via Types tab.

Some of the different modes of the Properties panel in the Layer Stack Manager.

Some of the different modes of the Properties panel in the Layer Stack Manager.

The Properties panel can be enabled/disabled via the  button at the bottom-right of the software.

When the Stackup tab of the Layer Stack document is active, the Properties panel allows you to edit the layer properties of the Layer Stack.

The Layer Stack Manager mode of the Properties panel: an overlay layer, an inner layer, a dielectric layer, and a plane layer.
The Layer Stack Manager mode of the Properties panel: an overlay layer, an inner layer, a dielectric layer, and a plane layer.

  • Name – the name of the layer.
  • Manufacturer – the layer manufacturer.
  • Material – the layer material. This can be pre-defined in the Altium Material Library dialog (Tools » Material Library) in the Constructions field, or user-defined in the Layer Stack. Click to open the Select Material dialog to choose the desired material for the currently selected layer in the layer stack.
  • Thickness – the thickness of the signal layer.
  • Dk – this is the Dielectric Constant (also referred to as εr in electromagnetics). This indicates the relative permittivity of an insulator material, which refers to its ability to store electrical energy in an electric field. For insulating purposes, a material with lower dielectric constant is better and in RF applications, a higher dielectric constant may be desirable. In addition, the lower the relative dielectric constant, the closer the performance of the material to that of air. This property is critical to matching the impedance requirements of certain transmission lines.
  • Df – this is the Dissipation Factor. This indicates the efficiency of insulating material by showing the rate of energy loss for a certain mode of oscillation, such as mechanical, electrical, or electromechanical oscillation. In other words, this is the property of a material that describes how much of the energy transmitted is absorbed by the material. The greater the loss tangent, the larger the energy absorption into the material. This property directly impacts the signal attenuation at high speeds.
  • Process – displays the copper plating process that is applied to the base copper that makes up the outer signal layers of the PCB (the Top Layer and Bottom Layer).
  • Weight – the weight of the copper per unit area, usually expressed in ounces/square foot (e.g., 0.5 oz/ft2).
  • Orientation – this defines which way the components point (orient) on that layer. For the top and bottom sides, this is set automatically in a new board. For other signal layers, it is used for:
    • Rigid-flex designs, where components mount on an inner signal layer that becomes a surface layer on a flex section, the software needs to know which way those components point. Use the drop-down to select the required orientation. Choices include: Not allowed, Top, and Bottom.
    • For a design that includes embedded components, the software needs to know which way a component points. Refer to the Designing a PCB with Embedded Components page for information regarding setting the component orientation in the layer stack. Use the drop-down to select the required orientation. Choices include: Not allowed, Top, and Bottom.
  • Copper Orientation – this defines the direction that the copper is laminated onto the core. Use the drop-down to select Above or Below, which determines the direction from which it is etched.
The Copper Orientation can also be chosen using the drop-down in the Copper Orientation column of the Layer Stack. To enable the column, right-click in the header, choose Select columns then enable the Copper Orientation entry in the Select columns dialog. Also, the Trace Inverted option in the Impedance Profile mode of the panel can be used to configure the copper orientation.

The orientation can be configured using the Copper Orientation drop-down in the Stackup mode of the Properties panel in the Copper Orientation column (if it is currently displayed), or by the Trace Inverted checkbox in the Impedance Profile mode of the Properties panel.

  • Pullback Distance – the distance from the plane edge to the board edge.
  • Frequency – this is the frequency at which the material is tested and the value that Dk / Df correspond to a certain frequency. Frequency is also taken from material references.
  • Description – enter a meaningful description.
  • Constructions – for dielectric layers, this displays the constructions of the layer. The numerical reference relates to the structure of the woven glass fabric used in the dielectric layer material; these are standard references used by PCB fabricators.
  • Resin – displays the resin percentage of the layer.
Notes on Constructions and Resin:
The choice of laminate construction can significantly impact both cost and performance. As should be expected, a single-ply construction will typically represent a cost savings compared to a multiple-ply construction. The magnitude of this savings will depend on the specific glass styles involved and a host of other parameters. Performance can also be affected and should be considered when specifying the constructions to be used. First, single-ply constructions are often lower in resin content. The other main benefit of single-ply constructions is dielectric thickness control, beyond resin content considerations. Tighter thickness tolerances can be achieved using a single-ply construction.
Constructions with relatively lower resin contents are often preferred since they result in less z-axis expansion and can therefore improve reliability in many applications. In addition, lower resin contents can also improve dimensional stability, resistance to warpage, and dielectric thickness control. On the other hand, constructions with higher resin contents result in lower dielectric constant values, which are sometimes preferred for electrical performance. In addition, a certain minimum resin content is required to ensure adequate resin-to-glass wet-out and to prevent voids from occurring within the laminate. The ability to wet out the glass filaments fully with resin is also important for CAP resistance.
  • Material Frequency – this is the frequency at which the material is tested and the value that Dk / Df correspond to a certain frequency. Frequency is also taken from material references.
  • GlassTransTemp – this is the Glass Transition Temperature (also known as TG) and is the temperature at which the resin changes from a glass-like state to an amorphous state changing its mechanical behavior, i.e. expansion rate.
  • Note – enter any pertinent notes for the layer.
  • Comment – enter any necessary comments for the layer.
  • Stack Symmetry – enable to add layers in matching pairs, centered around the mid-dielectric layer. When enabled, the layer stack is immediately checked for symmetry around the central dielectric layer. If any pair of layers that are equidistant from the central dielectric reference layer are not identical, the Stack is not symmetric dialog opens.
When Stack Symmetry is enabled:
– An edit action applied to a layer property is automatically applied to the symmetrical partner layer.
– Adding layers will automatically add matching symmetrical partner layers.
  • Library Compliance – when enabled, for each layer that has been selected from the Material Library, the current layer properties are checked against the values of that material definition in the library.
  • Substack – this information is for the currently selected substack (layers, dielectric, thicknesses, etc.,). As you switch from one substack to another, this information will update accordingly (for the currently selected substack).
The Substack region will only be available if the Rigid/Flex option is enabled in the Features drop-down.
  • Stack Name – enter the substack name. Naming the substack is useful when the X/Y stackup region is being assigned a layer substack.
  • Is Flex – enable if the substack is flex.
  • Layers – the number of conductive layers.
  • Dielectrics – the number of dielectrics.
  • Conductive Thickness – this is the sum of the thicknesses of all signal and plane layers (all copper or conductive layers).
  • Dielectric Thickness – the thickness of dielectric layer(s).
  • Total Thickness – the total thickness of the finished board.
  • Roughness – shows roughness of conductive layers.
  • Model Type – preferred model for calculating the impact of surface roughness (refer to the articles below for more information on the various models). Applies to all copper layers in the stack (should it be the substack?).
  • Surface Roughness – value of the surface roughness (available from your fabricator). Enter a value ​between 0 to 10µm, default is 0.1µm
  • Roughness Factor – characterizes the expected maximal increase in conductor losses due to the roughness effect. Enter a value between 1 to 100, default is 2.

To learn more about the options and controls available for the other Layer Stack tabs, use the links below:

Defining the Layer Stack

The layers you add in the Stackup tab of the Layer Stack Manager are the layers that will be fabricated during the manufacturing process.

Layer properties can be entered directly into the grid, or selected from the Material Library.Layer properties can be entered directly into the grid, or selected from the Material Library.

The properties of a layer can be edited directly in the grid or in the Properties panel.

  • Select File » Save to PCB (shortcut: Ctrl+S) to save the currently active Layer Stack to the PCB document.
  • Use the File » Load Stackup from File command to load an existing *.stackup template (or the File » Load Stackup from Server command, if you use a Workspace).
  • Use the File » Save As command to save the current stackup as a template (or the File » Save to Server command to save the template in your Workspace).
  • Pre-defined layer stacks are also available, in the Tools » Presets menu.

Configuring the Layer Properties and Materials

The properties of each layer can be edited directly in the LSM grid, or a pre-defined material can be selected from the Material Library by clicking the ellipsis button () in the Material cell for the selected layer. The Stackup Tab collapsible section earlier on this page summarizes the various techniques available for adding, removing, editing, and ordering the layers.

User-defined property columns can be added and the visibility of all columns configured in the Select columns dialog. To open the dialog, right-click on any column heading in the grid region then choose Select columns from the context menu.

Layer Types and their Properties

There is a large variety of materials used in the fabrication of a printed circuit board. The table in the collapsible section below gives a brief summary of the common materials used.

Materials Library and Library Compliance

Preferred layer stack materials can be pre-defined in the Material Library. In the Layer Stack Manager, select Tools » Material Library to open the Altium Material Library dialog, where existing materials can be reviewed, and new material definitions added.

The material for a specific layer is not selected in the Altium Material Library dialog. To use a specific material for a layer, click the ellipsis () for that layer in the Materials cell of the layer stack grid. This will open the Select Material dialog, which restricts the library to only show materials suitable for the layer that the ellipsis control was clicked.

If the Library Compliance checkbox is enabled in the Layer Stack Manager, then for each layer that has been selected from the Material Library, the current layer properties are checked against the values of that material definition in the library. Any property that is not compliant is marked with an error flag. Re-select the material () to update the values to the Material Library settings.

Layer Stack Symmetry

Dialog page: Stack is not symmetric

If you require the board layer stack to be symmetrical, enable the Stack Symmetry checkbox in the Board region of the Properties panel. When this is done, the layer stack is immediately checked for symmetry around the central dielectric layer. If any pair of layers that are equidistant from the central dielectric reference layer are not identical, the Stack is not symmetric dialog opens.

The upper section of the dialog details all detected conflicts in layer stack symmetry.

When Stack Symmetry is enabled:

  • An edit action applied to a layer property is automatically applied to the symmetrical partner-layer.
  • Adding layers will automatically add matching symmetrical partner-layers.
  • Use the Stack Symmetry option as a quick way of defining a symmetric board - define half of the layer stack, enable the Stack Symmetry option, then use one of the mirror whole stack options to replicate that set of layers.

Layerstack Visualization

An excellent way to verify the layer stack is to visualize it in 3D.

  • Select Tools » Layerstack Visualizer in the Layer Stack Manager to open the Layerstack Visualizer.
  • Use the controls to configure the presentation of the layer stack.
  • Right-click and drag to reorient the board in the visualizer.
  • Left-click on the image, then Ctrl+C to copy the image to the Windows clipboard.

Defining and Configuring the Rigid-Flex Substacks

Main article: Rigid-Flex Design

Rigid-Flex is under active development and now supports two modes of Rigid-Flex design. The original, or standard mode, referred to as Rigid-Flex, supports simple rigid-flex designs. If your design has more complex rigid-flex requirements, such as overlapping flex regions, then you need the Advanced Rigid-Flex mode (also known as Rigid-Flex 2.0). As well as overlapping flex regions, the Advanced mode also brings: visual definition of the substacks, easier definition of the rigid and flexible board regions, bends on nested cutouts, custom-shaped splits, and support for bookbinder-type structures. The required mode is selected in the Layer Stack Manager, as shown below.

The interface changes as you select either the standard or Advanced Rigid-Flex mode (hover the cursor over the image to show the difference).The interface changes as you select either the standard or Advanced Rigid-Flex mode (hover the cursor over the image to show the difference).

Learn more about Designing a Rigid-Flex PCB.

 

Each separate zone or region of a rigid-flex design can be made up of a different number of layers. To achieve that you need to be able to define multiple stacks, referred to as substacks.

Learn more about Designing a Rigid-Flex PCB

Exporting a Layer Stack

The current layer stack can be exported to a spreadsheet (*.csv) file by choosing the File » Export CSV command from the main menus. After launching the command, the Save As dialog opens in which you can select the desired location and name of the *.csv file.

Using the File » Export To Simbeor command, you can also export the layer stack to a Simbeor file (*.esx).

Other Layer-related Design Tasks

The layers in the layer stack form the space on which you build up the design. There are a number of design tasks that are related to the layers that are not performed in the Layer Stack Manager. These tasks are summarized below, with links to more information.

Defining the Board Shape

Main page: Board Shape object, Board Region object, Bending Line object

Where the layer stack defines the board in the Z-plane, the Board Shape defines the board in the X and Y planes. Also referred to as the board outline, the board shape is a closed polygonal shape that defines the overall extent of the board. The Board Shape can be made up of a single Board Region (for a traditional rigid PCB), or multiple board regions (for a rigid-flex PCB).

The Board Shape can be:

  • Defined manually - by redefining the existing shape, or placing one or more new board regions in Board Planning mode.
  • Defined from selected objects - typically done from an outline on a mechanical layer. Use this option if an outline has been imported from another design tool.
  • Defined from a 3D body - use this option if the blank board has been imported as a STEP model from an MCAD tool into a 3D Body Object (Place » 3D Body).
  • Pulled directly from an MCAD package - Altium is developing direct ECAD - MCAD design technology, called Altium CoDesigner. Learn more about ECAD-MCAD CoDesign.

Learn more about these approaches to defining the board shape.

Once the shape has been defined, bends in the flexible sections of a rigid-flex design are defined by placing Bending Lines.

Learn more about Rigid-Flex Design.

Assigning a Net to a Plane Layer

Panel page: Split Plane Editor
Related page: Internal Power & Split Planes

Assign a net to a plane layer, or a net to a split plane region, in the Split Plane Editor mode of the PCB panel.

The panel lists all plane layers. When a layer is selected in the Layers section, the section below will list all of the split plane zones on that layer (there will only be one if the plane is continuous with no splits defined). Double-click on a split plane zone to open the Split Plane dialog, where you can assign a net. You can also double-click on the layer in the workspace (when the plane layer is the active layer) to open the dialog.

Configuring the Layer Stack for Components Mounted on an Internal Signal Layer

Related article: Embedded Components

There are two situations where components can be mounted on an internal signal layer:

  1. when there are embedded components, or
  2. when there are components mounted on a flex region of a rigid-flex board, and that flex layer extends from a mid-layer in the rigid section of the board.

The software needs to know which way components are oriented for each layer they are mounted on so that it knows when the component primitives must be mirrored. For the Top and Bottom Layers, this is configured automatically; for other layers, the setting is configured by the designer. 

A component embedded on an internal signal layer (the component has been highlighted with blue outlines, the cavity with orange outlines).A component embedded on an internal signal layer (the component has been highlighted with blue outlines, the cavity with orange outlines).

  • Component orientation is configured for a layer in the Orientation column of the Stackup tab of the Layer Stack Manager.
  • If the Orientation column is not visible, enable it by right-clicking on an existing heading in the layers grid then selecting Select columns from the context menu.
  • The components on a layer can either point upwards (Top) or downwards (Bottom).

Documenting the Layer Stack

Object page: Layer Stack Table

Documentation is a key part of the design process and is particularly important for designs with a complex layer stack structure, such as a rigid-flex design. To support this, Altium Designer includes a Layer Stack Table, which is placed (Place » Layer Stack Table) and positioned alongside the board design in the workspace. The information in the layer stack table comes from the Layer Stack Manager.

Include a Layer Stack Table to document the design.
Include a Layer Stack Table to document the design.

  • To place a Layer Stack Table, select Place » Layer Stack Table.
  • The Layer Stack Table details the:
    • Layers used in the design
    • Material used for each layer
    • Thickness of each layer (and optionally the total board thickness).
    • The Dielectric Constant
    • The name of each stack and the layers used in that stack
  • Double-click anywhere on the placed table to open the Properties panel in Layer Stack Table mode.
  • The Layer Stack Table can also include an optional outline of the board showing how the various layer stacks are assigned to regions of the board. Use the Show Board Map option and slider bar to configure the map settings.
  • The Layer Stack Table is an intelligent design object, meaning it can be placed and updated as the design progresses. Double-click on the Layer Stack Table to edit it in the Properties panel.
  • An alternative approach to documenting the layer stack is to add a Draftsman document to the project and add a Layer Stack Table in it. Learn more about Draftsman.

Place the .Total_Thickness and the .Total_Thickness(<SubstackName>) special strings on a mechanical layer to include this information in your design documentation.

Including a Drill Table

Object page: Drill Table

Altium Designer includes an intelligent Drill Table that is placed like any other design object. The table can either display the drills required for all layer pairs (composite), or a specific layer pair. Place a drill table for each layer pair used in the design if you prefer separate drill information for each layer pair.

An alternative approach to documenting the layer stack is to add a Draftsman document to the project and add a Layer Stack Table in it. Learn more about Draftsman.

High Quality, Flexible Design Documentation

Main article: Draftsman

Altium Designer also provides a dedicated documentation editor - Draftsman. Draftsman has been built from the ground up as an environment for creating high-quality documentation that can include dimensions, notes, layers stack tables, and drill tables. Based on a dedicated file format and set of drawing tools, Draftsman provides an interactive approach to bringing together fabrication and assembly drawings with custom templates, annotations, dimensions, callouts, and notes.

Draftsman also supports more advanced drawing features including a Board Isometric View, a Board Detail View, and a Board Realistic View (3D view).

Place drawing views, objects and automated annotations on single or multi-page Draftsman documents. Place drawing views, objects and automated annotations on single or multi-page Draftsman documents.

Learn more about Draftsman

Note

The features available depend on your level of Altium Designer Software Subscription.

Content