Mechanical Data Import-Export Support in Altium NEXUS

Created: August 1, 2022 | Updated: August 1, 2022

Altium NEXUS includes capabilities to import design data from and export to popular formats such as STEP and Parasolid to exchange with MCAD tools.

Note that for supported MCAD packages, it is also possible to transfer the board and components directly between MCAD and ECAD using CoDesigner, Altium's ECAD-to-MCAD connectivity technology. Working through a connected Workspace, such as an Altium 365 Workspace, CoDesigner can push the board shape and placed components back and forth between your MCAD software and Altium NEXUS.

The features available in Altium CoDesigner depends on your Altium Subscription Plan. Learn more about the features included in each Subscription Plan.

Learn more about Direct ECAD-MCAD Design with Altium CoDesigner.

STEP Files Import-Export Support

Altium NEXUS offers advanced capabilities for interacting with mechanical design systems and software (MCAD) through the active exchange of physical design data. The range of systems and interfaces that bridge the ECAD-MCAD domains also rely on standardized data formats such as the industry ratified STEP protocol (Standard for Exchange of Product model data), which provides an information-rich, clear text encoded file format for 3D model design data.

The STEP file format itself (*.step or *.stp) is defined in the ISO 10303-21 (International Organization for Standardization) specification for CAD data exchange and is supported by the majority of MCAD tools and systems. At the fundamental file exchange level, Altium NEXUS offers both export and import capabilities for 3D STEP files.

This provides the basis for the free exchange of high-quality, standardized 3D modeling data between software domains, which simplifies ECAD-MCAD design collaboration and enhances both the quality and accuracy of 3D model data. Note that both the STEP AP214 and the legacy AP203 formats are supported by Altium NEXUS – exported files are ISO-10303-21 -compliant (AP214).

► See the the ISO 10303-21 specification web page.
► Read information on the STEP file format.

Export STEP files

An important function in the data exchange relationship between the ECAD and MCAD worlds is the ability to port the PCB or Multi-board assembly into mechanical design software for the purposes of physical clearance checking. This is particularly crucial where the design is intimately matched with a product enclosure that also exposes PCB peripherals such as controls, switches, connectors, and displays.

In this case, the inherent universality and accuracy of the STEP file format allows comprehensive PCB modeling data to be transferred from Altium NEXUS to MCAD software with a high degree of confidence in the dimensional relationships. The MCAD designer can then import and place the PCB assembly 3D STEP model into the mechanical design to check and/or modify accordingly.

The STEP file export capabilities are available through the STEP and MBASTEP exporters – show image.

Learn more about Browsing and Modifying the Core Feature Set.

Using the Exporter

An Altium NEXUS PCB document can be exported to the STEP file format. In an Outputjob file, click [Add New Export Output] and select an entry in the Export STEP menu. The export outputs can then be generated directly from the file or as part of the Project Release process.

Alternatively, select the File » Export » STEP 3D command from the main menus of Altium NEXUS's PCB editor. After launching the command, nominate a target file name and location.

The Export Options dialog accessed by double-clicking an added STEP export output or launching the File » Export » STEP 3D command provides a range of selections that include options to determine which board objects will be included in the generated file.

Exported STEP files displayed in an MCAD application, where the upper image file includes no pad holes or 3D bodies and the lower image file includes all objects.Exported STEP files displayed in an MCAD application, where the upper image file includes no pad holes or 3D bodies and the lower image file includes all objects.

Notes on Exported files

  • If the Export Selected options (3D Bodies and Pad Holes) have been enabled in the Export Options dialog but no objects are currently selected in the PCB editor, then the generated STEP files will not include any of those object types.
  • When the Export as Single Part option is selected, the generated STEP model will be saved as a single part, rather than an assembly of component models. This simplifies the exported STEP model but prevents individual components from being selected in the receiving MCAD application.
  • STEP files generated by the Export 3D feature position the model graphic relative to the origin point in the source PCB design. The software used to import that file may or may not respond to the included location instruction – if the imported model is not displayed, it may be off screen at the current zoom level.
  • If you do not have access to mechanical drawing/viewing software, the exported STEP file can be checked by importing it back into a placed 3D Body object in Altium NEXUS.

An Altium NEXUS Multi-board Assembly document can be exported to the STEP file format. Use the MBA Export STEP entry of the [Add New Export Output] menu in an Outputjob file or select the File » Export » STEP 3D command from the main menus of Altium NEXUS's Multi-board Assembly editor.

Save from the IPC Component Wizard

The automated IPC Compliant Footprint Wizard, which creates an IPC-compliant footprint in the PCB Library editor, provides the additional option of saving (and previewing) the generated footprint model as a 3D STEP file. The STEP based model can be embedded in the generated IPC-compliant footprint and also saved as a *.step file in a nominated location, where the latter option will allow the 3D model to be reused or distributed as needed.

The IPC Component Wizard is launched from the PCB footprint editor (Tools » IPC Compliant Footprint Wizard) and the STEP export option enabled in the wizard’s penultimate Footprint Destination page. The generated STEP file model will accurately match the component dimensions that have been entered in the wizard.

Along with the option to generate and embed a STEP model for the component, the wizard also allows this to be saved as a STEP 3D model file.Along with the option to generate and embed a STEP model for the component, the wizard also allows this to be saved as a STEP 3D model file.

Import STEP Files

Import into the PCB or PCB Footprint

STEP files can be imported and used in Altium NEXUS through two distinct approaches, both of which use the same mechanism. The approach used is essentially dependent on how a STEP file will be applied in a design:

  • A STEP file that represents mechanical elements of the final product design, such as an enclosure generated by an MCAD application, is generally imported into the PCB layout.
  • A STEP file that represents a 3D component body (downloaded from the internet or created locally) is generally imported into a PCB footprint.

Within both the PCB and PCB footprint domains in Altium NEXUS, STEP files are imported into a dedicated 3D Body object that is placed and aligned as required. Refer to the 3D Body Object Placement section to learn more.

Import into the Multi-board Assembly

A STEP model can be added to the active Multi-board assembly document using the Design » Insert STEP Part command from the main menus.

Parasolid Files Import-Export Support

Export Parasolid Files

An Altium NEXUS PCB document can be exported to the Parasolid file format. In an Outputjob file, click [Add New Export Output] and select an entry in the Export PARASOLID menu. The export outputs can then be generated directly from the file or as part of the Project Release process.

Alternatively, select the File » Export » PARASOLID command from the main menus of Altium NEXUS's PCB editor.

Import Parasolid Files

Within both the PCB and PCB footprint domains in Altium NEXUS, Parasolid files are imported into a dedicated 3D Body object that is placed and aligned as required. Refer to the 3D Body Object Placement section to learn more.

SolidWorks Part Files Import Support

Within both the PCB and PCB footprint domains in Altium NEXUS, SolidWorks Part files (*.sldprt) are imported into a dedicated 3D Body object that is placed and aligned as required. Refer to the  3D Body Object Placement section to learn more.

VRML Files Export Support

An Altium NEXUS PCB document can be exported to the VRML file format. In an Outputjob file, click [Add New Export Output] and select an entry in the Export VRML menu. The export outputs can then be generated directly from the file or as part of the Project Release process.

Alternatively, select the File » Export » VRML command from the main menus of Altium NEXUS's PCB editor.

IDF Files Import-Export Support

The IDF file import/export capabilities are available through the IDF importer/exporter – show image.

Learn more about Browsing and Modifying the Core Feature Set.

Export IDF Files

An Altium NEXUS PCB document can be exported to the IDF file format. In an Outputjob file, click [Add New Export Output] and select an entry in the Export IDF menu. The export outputs can then be generated directly from the file or as part of the Project Release process.

Alternatively, select the File » Export » IDF Board command from the main menus of Altium NEXUS's PCB editor.

Import IDF Files

To import an IDF file into the active PCB document, select the File » Import » IDF Board command from the main menus of Altium NEXUS's PCB editor.

IDX Files Import-Export Support

As more and more electronic products involve both electrical and mechanical components, and product release cycles get shorter, there's a real need for stronger collaboration between the ECAD and MCAD domains. But that collaboration isn't always smooth. The electrical designer and mechanical designer often send emails back and forth, or have to dabble in each other's respective design tools - something that leaves them treading a little water, and far removed from their established comfort zones. One solution is to use a method of collaboration that enables the two to graphically communicate ideas and proposals for change, without leaving their trusty working environments. Such a method is provided through an XML-based exchange file format - IDX (Incremental Design EXchange format).

With this intermediate exchange file (*.idx), an electrical designer can export only changes to the board design that are needed (and of value) by the mechanical designer. Conversely, the mechanical designer can float change proposals back to the electrical designer, who can then import those changes back into their design.

Support for this standard of collaboration between ECAD and MCAD domains is available in Altium NEXUS, courtesy of the MCAD IDX Exchange extension. This extension allows you to incrementally exchange data between Altium NEXUS and mechanical CAD applications (such as SOLIDWORKS), using the IDX exchange format. Functionality includes support for change requests, as well as the transfer of Cu geometry.

Initiating the Baseline File for Collaboration

Collaboration can be kicked off from either direction - either the electrical designer creating the initial IDX file, or the mechanical designer doing the honors. If the electrical designer does so, the file created is called the ECAD Baseline file (ECAD Baseline.idx), which is subsequently made available to the mechanical designer. If the mechanical designer does so, it is called the MCAD Baseline file (MCAD Baseline.idx), which is subsequently made available to the electrical designer.

Exporting from Altium NEXUS (ECAD Creation of Baseline)

From within Altium NEXUS, the main interface for collaboration is the MCAD IDX Exchange panel, which is accessed by clicking the  button at the bottom-right of Altium NEXUS when the PCB editor is active then selecting the MCAD IDX Exchange entry from the menu.

The panel can also be accessed using the MCAD IDX Exchange command from the main Tools menu.

To initiate collaboration, click the Export Baseline button. You will be presented with the Export Baseline dialog, which offers options, including the export of copper objects.

Exporting copper makes the IDX files much bigger and slower to process on the MCAD side. In addition, the IDX technology does not support change detection for copper objects.

Initiate collaboration from within Altium NEXUS by creating the ECAD BaselineInitiate collaboration from within Altium NEXUS by creating the ECAD Baseline

Importing to Altium NEXUS (MCAD Creation of Baseline)

If the baseline file has been created on the MCAD side, it can be imported into Altium NEXUS using the File » Import » MCAD IDX Baseline command. The Import MCAD Baseline dialog will open. Use this to browse to and specify the MCAD Baseline file (MCAD Baseline.idx), and the PCB document into which proposed changes are to be synchronized.

Accept collaboration from within Altium NEXUS by importing the MCAD Baseline.Accept collaboration from within Altium NEXUS by importing the MCAD Baseline.

Once the MCAD Baseline IDX file has been imported, collaboration proceeds through the MCAD IDX Exchange panel.

Collaboration Folder

When initiating collaboration from Altium NEXUS (creating the IDX Baseline file), a collaboration folder will be created under the original board design project. The folder is named using the PCB document name in the form <PCBDocumentName>.PcbDoc_EDMD. The folder will contain two files:

  • AD_EDMD_State.xml
  • ECAD Baseline.idx

Quickly access the generated folder from the MCAD IDX Exchange panel by clicking the Show In Explorer control (available only after initial export) or by clicking the  button then choosing the Open Collaboration Folder entry from the associated menu.

Creation of the folder and baseline file.
Creation of the folder and baseline file.

Synchronizing Changes

The MCAD IDX Exchange panel provides controls for keeping changes synchronized between the ECAD and MCAD domains. Changes are proposed through IDX Changes files:

  • If the mechanical designer has proposed changes and sent them across in a new IDX Changes file, the panel allows those changes to be received (imported) into the PCB design for consideration.
  • If changes have been made to the board, the panel can detect these changes (except copper changes) and list them, ready for export to an IDX Changes file that is subsequently made available to the mechanical designer.

Detecting and Exporting Board Changes

If you make a change to the PCB document, such as removing a component, that change can be detected by clicking the  button at the top of the MCAD IDX Exchange panel. The detectable changes will be listed in the Board Changes region of the panel, in terms of:

  • Object - for example, the component designator.
  • Change - for example, Removed for a component that has been removed from the design, or Added for one that has been added.
  • Status - this will be Proposed since the change is originating on the ECAD side.
  • Proposition Comment - a note to explain the change to the mechanical designer. Enter this as required.

Detecting changes to the board.Detecting changes to the board.

Once all changes have been made, detected, and proposition comments added, those changes can be exported using the  button. This will create an IDX Changes file (ECAD Changes n.idx).

With proposed changes to the board made, export to create an IDX Changes file to send those proposed changes to the mechanical designer.
With proposed changes to the board made, export to create an IDX Changes file to send those proposed changes to the mechanical designer.

It is now up to the mechanical designer to import and view the change proposals on their side. They will then either accept or reject each proposed change in turn, and send back their response in an IDX Response file (MCAD Response n.idx). Once this is received, import the response using the  button. To apply the changes in the response file, click the  button, which will generate an IDX Response file from the ECAD side back to the mechanical designer (ECAD Response n.idx).

This "handshaking" ensures that both parties are synchronized with the changes made.

To abandon the proposed changes, click the  button; the Board Changes list will be cleared.

Importing Changes

If the mechanical designer is proposing changes, those changes will be proposed in an IDX Changes file (MCAD Changes n.idx). Import the changes using the panel's  button. The changes will be listed in the Changes from Mechanical CAD region of the panel in terms of:

  • Object - for example, the component designator.
  • Change - for example, Moved for a component that has been moved within the design.
  • Status - this will be Proposed since the change is originating on the MCAD side.
  • Proposition Comment - a note to explain the change to the electrical designer.

Changes proposed by the mechanical designer, imported into the panel.Changes proposed by the mechanical designer, imported into the panel.

It is now up to you, as the electrical designer, to view and either accept or reject each proposed change in turn. To accept a proposed change, check its associated Accept check box. To reject, leave this unchecked. You also can enter a response in the respective Response Comment field.

Once all proposed changes have been accepted/rejected, click the  button. The accepted changes will be applied to the PCB document and an IDX Response file (ECAD Response n.idx) will be created, ready to send back to the mechanical designer.

Resetting Collaboration

To completely reset collaboration on the project, click the  button then choose the Reset Collaboration entry from the associated menu. All current entries in the panel will be cleared and all files in the collaboration folder will be deleted. This puts you back at square one, ready to export a baseline file, or import one, and start collaboration afresh.

Note that any applied changes to the design prior to a reset will remain.
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: