Design Object Selection

This documentation page references Altium NEXUS/NEXUS Client (part of the deployed NEXUS solution), which has been discontinued. All your PCB design, data management and collaboration needs can now be delivered by Altium Designer and a connected Altium 365 Workspace. Check out the FAQs page for more information.

 

Parent page: Getting Familiar with the Altium Design Environment

Object selection is one of the most important and frequently used operations when working with the main editors of the Altium NEXUS environment: schematic editor, PCB editor, Draftsman, etc. A design object must be selected before performing an operation on it, such as:

  • editing object location or size;
  • browsing and changing object properties;
  • performing a clipboard operation (cut/copy) or removal, etc.

Altium NEXUS provides a number of tools to select a required object or group of objects. Many of them are similar to those that can be found in other Windows applications.

When an object is selected, it is highlighted in the selection color (configure the schematic selection color on the Schematic – Graphical Editing page of the Preferences dialog, and the PCB selection color in the View Configuration panel). If the object can be graphically edited, colored editing handles are displayed when the object is selected.

Selected objects are visually distinguished in the editor's design space. Shown here is the component selected on a schematic sheet. Hover the cursor over the image to see a group of tracks selected in a PCB document.
Selected objects are visually distinguished in the editor's design space. Shown here is the component selected on a schematic sheet. Hover the cursor over the image to see a group of tracks selected in a PCB document.

Simple Selection

In the most basic case, you can select an object by hovering the cursor over it and clicking. Click a selected object again or click away from objects to deselect it.

Note that selection with clicking is not cumulative. The selected object deselects when you click on another object. To select multiple objects using clicking, hold the Shift key then click sequentially the objects to be selected or deselected. In other words, the Shift+Click shortcut changes the selection status of the object currently under the cursor without affecting the status of other objects.

This approach is ideal when the number of objects to be selected is small, or perhaps when there are different kinds of objects to be edited simultaneously.

Selection Rectangle

To select a number of objects located in a specific area of the design document, you can use a selection rectangle. Click and Hold away from objects in the corner of the imaginary rectangle enclosing the objects to be selected and Drag to the opposite corner of this rectangle. Note that the behavior of selection using the selection rectangle depends on the direction of dragging – from Left to Right or from Right to Left.

Select Within or Select Touching?

In Altium NEXUS, selection can either be objects that are: Within the selection rectangle or touching the selection rectangle. This is controlled by the direction you move the mouse as you draw the selection rectangle:

 Select Within - click and drag a blue rectangle from left to right to select all visible objects that are completely within the selection rectangle.
Select Touching - click and drag a green rectangle from right to left to select all visible objects that touch the selection rectangle.
This behavior of the selection rectangle works when the Use Left/Right Selection option is enabled in the System – General page of the Preferences dialog. When this option is disabled, only a blue rectangle is used independently of the mouse move direction, i.e. only objects that fall completely inside the selection rectangle are selected.

Partial Selection - Selecting a Child Object

Certain objects, including schematic components, sheet symbols, and harness connectors, are parent objects because they contain child text strings that can be edited independently. If a child object is selected but the parent is not, the parent's editing handles are displayed without color, indicating that a child of that object is currently selected, but not the entire object.

Certain editing actions, such as a Move command, will include the child object, while other editing actions, such as a Delete command, will not. To delete a parent object and its children, it must be selected (displaying colored editing handles). These differences are demonstrated in the animation below.

Note how the component selection handles change when a child object is selected or the entire component.
Note how the component selection handles change when a child object is selected or the entire component.

Selection Commands

To select/deselect objects you can use the commands of the Edit » Select and Edit » DeSelect sub-menus of the main menus. The selection commands include:

  • Lasso Select – select design objects within a user-defined, free-form 'lasso' area.
  • Outside Area – select design objects outside of a user-defined rectangular area.
  • Touching Line – select any design objects that are touched by a user-defined line.
  • All (shortcut: Ctrl+A) – select all objects on the current document.
The S key pops up the Select menu. The X key pops up the DeSelect menu.

Selection Memory

Eight selection memories are available in the schematic and PCB editors, which can be used to store and recall the selection state of up to eight sets of objects on the schematic or PCB. Select the objects you want to remember and then store them for quick recall later.

The following selection memory options are available:

  • Store in memory (Ctrl + number 1 to 8)
  • Add to memory (Shift + number 1 to 8)
  • Recall from memory (Alt + number 1 to 8)
  • Recall and Add from memory (Shift + Alt + number 1 to 8)
  • Apply memory as a design space filter (Shift + Ctrl + number 1 to 8).

You can also access the selection memories using the Edit » Selection Memory sub-menu.

Alternatively, use the Selection Memory dialog that is opened by pressing Ctrl+Q. Click on an STO button to store a selection or RCL to recall a selection. The filtering options at the bottom of the control panel will determine how the selection is displayed.

To prevent accidentally overwriting a selection memory, enable the Confirm Selection Memory Clear option in the Schematic – Graphical Editing page or PCB Editor – General page of the Preferences dialog. Selection Memory locations can be locked from being overwritten by checking the Lock checkbox associated with that selection memory.

Notes

Content