Verifying a Component

This documentation page references Altium NEXUS/NEXUS Client (part of the deployed NEXUS solution), which has been discontinued. All your PCB design, data management and collaboration needs can now be delivered by Altium Designer and a connected Altium 365 Workspace. Check out the FAQs page for more information.

Parent page: Creating a New Component

Before saving a Workspace Library component defined/edited in the Component Editor (in its Single Component Editing or Batch Component Editing mode) to the connected Workspace and making the component be available for use in designs, it is essential to make sure that this component meets the requirements in accordance with the configured settings. When you attempt to save a component back to the Workspace, the Component Editor runs a validation – a Component Rule Check. This feature can also be run at any time, manually, by choosing the Tools » Component Rule Check command, from the main menus. Be sure to have saved your component locally (File » Save) before you do.

The Component Rule Check command is also available from the editor's main File menu and from the component entry's right-click menu in the Projects panel.

Just as a board project has the validation process to detect any violations, the Component Editor has a Component Validator. Any violations that are found are listed in the Messages panel.

Detecting issues with a component prior to saving to the Workspace. Shown here is running the Component Rule Check command from the Component Editor in its Single Component Editing mode. Hover the cursor over the image to see running the command from the Component Editor in its Batch Component Editing mode.
Detecting issues with a component prior to saving to the Workspace. Shown here is running the Component Rule Check command from the Component Editor in its Single Component Editing mode. Hover the cursor over the image to see running the command from the Component Editor in its Batch Component Editing mode.

The Component Validator tests for an array of potential issues with the component and its defined models – both hardwired tests, as well as a range of violation types that can be user-defined at the global level.

The following hardwired validation checks all carry a report mode of :

User-definable checks are configured on the Data Management – Component Rule Checks page of the Preferences dialog.

User-definable violation checks that can be configured as part of global preferences, for use with the Component Validator.
User-definable violation checks that can be configured as part of global preferences, for use with the Component Validator.

Any of the hardwired tests that fail, or user-defined checks at a level of Fatal Error, will prevent saving of the component to the Workspace.

The default settings of the user-defined checks may not suit your components and, therefore, it is important to become familiar with the options and how to configure them to suit your designs. Information about each user-defined error check can be found below.

Violations Associated with Components

Violations Associated with Footprints

Violations Associated with Symbols