物理的なマルチボード アセンブリの作成

Modified by by Admin on May 10, 2019

Parent page: マルチボードの設計システム

ほとんどの基板は、単体で存在せず、他の基板と組み合わせます。そして、これらは、ケース、または筐体内に収めます。

設計プロセスのこの段階を進める手助けとして、マルチボード アセンブリを作成できます

マルチボード アセンブリは、最初にマルチボード プロジェクト (*.PrjMbd) を定義してから、マルチボード回路図 (*.MbsDoc ) でシステムの論理的な構造を定義して作成します。マルチボード回路図で各論理的なブロックは、PCB デザイン (*.PrjPcb) を参照します。

物理的なマルチボード デザインは、システムデザインを空のマルチボード アセンブリ ドキュメント (*.MbaDoc) へ移行して作成します。この記事で、そのプロセスについて説明します。

マルチボード アセンブリの論理的な設計については、論理的なシステムデザインの設計 を参照してください。

マルチボード アセンブリの作成

マルチボード アセンブリは、システムの物理的な表現です。新しいマルチボード アセンブリを作成するには、以下を行います:

  1. 新しいマルチボード アセンブリ ドキュメント (*.MBAdoc) をマルチボードプロジェクトへ追加して、保存します。
  2. マルチボード回路図からマルチボード アセンブリ ドキュメントへ、システムの論理的な表現を移行します。
  3. 筐体を利用できる場合、アセンブリへそれを読み込みます。
  4. アセンブリ内で各基板や必要な場合、筐体を位置決めします。

2 つのメモリカードと PCIe WiFi カードが接続されたメイン基板。

これらの各ステップの詳細を説明します。

 

マルチボード回路図の作成や確認の詳細については、マルチボード システムデザイン の記事を参照してください。

マルチボード アセンブリ ドキュメントをプロジェクトへ追加

新しいマルチボード アセンブリ ドキュメントをプロジェクトへ追加するには、以下のコマンドを使用できます:

  • File » New » Multi-board Assembly、または
  • Projects パネルでマルチボード プロジェクトを右クリックし、Add New to Project » Multi-board Assembly を選択します

アセンブリ ドキュメントをプロジェクトへ追加したら、右クリックし保存します(名称を設定して)。

マルチボード アセンブリは、システムレベル プロジェクトへ追加されました。

システムデザインをマルチボード アセンブリ ドキュメントへ移行

マルチボード デザインは、以下のコマンドを使用して、マルチボード回路図からマルチボード アセンブリ ドキュメントへ移行されます:

  • マルチボード回路図エディタで Design » Update Assembly
  • マルチボード アセンブリ エディタで Design » Import Changes

これらのコマンドを実行した時、マルチボード回路図の各モジュールがチェックされ、各子 PCB プロジェクトで選択された PCB を識別します。そして、それらの基板をアセンブリへ追加するために必要な変更リストが、Engineering Change Order ダイアログに表示されます。

各 PCB プロジェクトの基板は、ECOの変更としてリスト表示されます。そして、ECO が実行された時、マルチボード アセンブリ エディタへ読み込まれます。

Execute Changes ボタンをクリックした時、基板がマルチボード アセンブリ エディタへ読み込まれます。各基板は、PCB プロジェクトにある基板と同じ方向でワークスペースに配置されます。

アセンブリ エディタのワークスペースへ読み込まれたマルチボード アセンブリの 4 つの基板(位置決めできる状態)。

ワークスペースのビューを変更

基板をアセンブリ エディタへ最初に移行する時、同じ平面上に配置されます - 仮想的な面上に互いに隣り合ってレイアウトされます。数分以内で、どれかの基板を移動、回転できます! それから、ビューも回転できますが、どちらが動いているかわかりません!

3D デザイン空間での作業は、その空間でのビューを管理したり、その空間内でオブジェクトを操作する技術が必要です。これらは、空間のビューをコントロールしたり、その空間内で基板を位置決めする別々の技術です - ビューをコントロールするために使用する技術から始めましょう。

ビューの再方向決めを習得したら、基板を同じ方向、面に戻す方法を習得します。

 

アセンブリのビューは、キーボードとマウスを使用してコントロールできます。または、3D mouse (例えば、Space Navigator)を使用できます。

ワークスペースでビューの方向決め

 アセンブリエディタ ワークスペースの左下に、赤/緑/青の軸マーカーがあります。これは、Workspace Gizmo と呼ばれます。基板を選択すると、他の gizmo が表示されます。これは、Object Gizmo と呼ばれます。

Gizmo (色付きの矢印/面/アーク)を使用して、ワークスペースのビューや、ワークスペース内でオブジェクトの方向をコントロールできます。

ワークスペース Gizmo

ワークスペース Gizmo は、ビューの方向を変更するために使用します。

 

各ワークスペースの軸や、それに関する面は、以下の色で割り当てられます:

  • 青色の矢印 - Z 軸、X-Y 面を表示。上、または下のビューとして考えることができます。
  • 赤色の矢印 - X 軸、Y-Z 面を表示。前、または後ろのビューとして考えることができます。
  • 緑色の矢印 - Y 軸、X-Z 面を表示。左、または右のビューとして考えることができます。

ワークスペース Gizmo は、常に左下に表示されます。

色がついた Gizmo の上にカーソルを置くと、少し薄い表示になり、アクティブになります。その色をクリックすると、その軸の上から見たように表示されます。その色を 2 回クリックすると、反転し、その軸の反対側の上から見たように表示されます。以下のショートカットの表では、様々な動作の詳細を記載しています。

ワークスペースの軸へ整列するビューコントロールのショートカット

これらのショートカットは、ワークスペースの軸へビューを整列します:

ショートカット動作
Z キー、またはワークスペース Gizmo の 青色 をクリックZ 軸を基準に X-Y 平面でビューを表示します。反対方向から表示するには、青色をもう一度クリック、または Shift+Z ショートカットを使用します。
X キー、またはワークスペース Gizmo の 赤色 をクリックX 軸を基準に Y-Z 平面でビューを表示します。反対方向から表示するには、赤色をもう一度クリック、または Shift+X ショートカットを使用します。
Y キー、またはワークスペース Gizmo の 緑色 をクリックY 軸を基準に X-Z 平面でビューを表示します。反対方向から表示するには、緑色をもう一度クリック、または Shift+Y ショートカットを使用します。

ワークスペース Gizmo を使用して、ビューの方向を変更。

現在のビューへ整列するビューコントロールのショートカット

実行できるビューの移動のほとんどは、ワークスペースの軸から参照されず、現在のビューを参照します。現在のビューは、Current View Plane と呼ばれ、現在、表示されている面です。例えば、ズームする時、ワークスペースの内容は、ワークスペースの軸の現在の角度にかかわらず、ズームされます。

これらのショートカットは、Current View Plane に関連しています:

ショートカット動作
Ctrl+マウスホイールズームイン/アウト
右クリック_n_ドラッグパンハンドカーソルが表示され、current view plane でワークスペースのビューをスライドします。
Shift+右クリック_n_ドラッグ現在の X や Y ビュー平面軸に沿って、ワークスペースのビューを回転します。クリック、ドラッグする位置は、回転する中心になります。上/下にドラッグすると、current view plane の X 軸に沿って、ビューを回転します。左/右にドラッグすると、current view plane の Y 軸に沿って、ビューを回転します。
Shift+Ctrl+右クリック_n_ドラッグcurrent view plane の Z 軸に沿って、ワークスペースのビューを回転します。クリック、ドラッグする位置は、回転する中心になります。左にドラッグすると、current view plane の Z 軸に沿って、反時計回りにビューを回転します。右にドラッグすると、時計回りに回転します。
Ctrl+PgDn原点マーカーを含む全てのオブジェクトに合うように、ビューをズームします。

現在のビューは、マウスやキーボード ショートカットを使用して、変更できます。

アセンブリの基板を位置決め

ビューの回転については、ご理解頂けたと思います。アセンブリを構築するために必要なその他の技術は、基板の方向や位置決めです。

基板をクリックすると、セレクション色(デフォルトは、緑色)でハイライト表示されます。そして、カラーの矢印とアークが表示されます。これらのカラーの矢印とアークは、Object Gizmo と呼ばれます。基板をクリック、ドラッグして移動できます。

Object Gizmo は、オブジェクトを選択した時に表示されます。nn

アセンブリの各基板は、PCBエディタで設計した時と同じ方向でワークスペースへ読み込まれます。アセンブリエディタの基板の現在の方向にかかわらず、オブジェクトは、PCB エディタで作成された時と同じ X、Y、Z 軸が維持されます。

基板の再方向や再位置決め

 Object Gizmo が表示された時、以下の上でクリックしたまま移動します:

  • Object Gizmo の矢印 - そのオブジェクト軸に沿ってオブジェクトを移動します。
  • Object Gizmo のアーク - そのオブジェクト軸の周りでオブジェクトを回転します。回転中、オブジェクト軸がワークスペース軸と一致する時、オブジェクトが引き込まれます。
  • 選択したオブジェクト - Current View Plane へオブジェクトを移動します。Current View Plane は、現在、ビューをどのような方向にしているかによって定義されるため、この手法を使用して移動する場合、オブジェクトが 3 次元空間のどこにあるか予測するのが難しくなります。

 

選択したオブジェクトをドラッグする時、位置を予測できるようにするには、Current View Plane が、3 つのワークスペース平面の一つに整列されるように、最初に、ワークスペース Gizmo を使用して、ビューを再方向決めします。

オブジェクト Gizmo を使用して、基板を回転、または再位置決め。

平面、または軸へ強制的に移動

  • ワークスペース平面へオブジェクトを強制的に移動する(前の動画に示されている)には、以下を行います:
  1. ワークスペース Gizmo を使用して、ワークスペースを方向決めします(Workspace Gizmo の項目で記述した通り)。これにより、Current View Plane が方向決めされ、選択したワークスペース平面と同じになります。
  2. オブジェクトを選択してから、ワークスペースのどこかをクリックし、選択したオブジェクトをドラッグします。選択した基板を移動する時、現在のビューで定義した平面へ強制的に移動されることを思い出してください。   
  • オブジェクト軸へオブジェクトを強制的に移動する(前の動画に示されている)には、以下を行います:
  1. 移動するオブジェクトを選択します。そのオブジェクト Gizmo が表示されます。複数のオブジェクトを移動する場合、Shift+Click を使用して追加のオブジェクトを選択します。
  2. 適切なオブジェクト Gizmo の矢印をクリックしドラッグして、その軸に沿ってセレクションをスライドします。

ワークスペース軸へオブジェクトを整列

  • ワークスペース軸とオブジェクトを整列する(前の動画に示されている)には、以下を行います:
  1. オブジェクトを選択し、オブジェクト Gizmo を表示します。
  2. 適切なカラーのアークを使用して、オブジェクトを必要な方向に回転します。ワークスペース平面を交差する時、オブジェクトが引き込まれます。この動作は、オブジェクトを整列するガイドとして使用できます。

あるオブジェクトを他のオブジェクトと整列

Tools メニューには、ある基板を他の基板と整列するための以下のコマンドが含まれています。これらのコマンドは、2 回のクリックが必要になります(セレクション状態は無視されます)。最初のクリックは、基準面(または、軸)が指定され、2 回目にクリックするオブジェクト(軸)が、基準オブジェクトの平面(または、軸)と整列されます。

  • Align Plane-to-Plane - 2 番目のオブジェクトを最初のオブジェクトと同じ平面に合わせます。次のような平面を利用できます: 基板の表面(端を含む)、または STEP モデルの平面。
  • Align Axis-to-Axis - 2 番目の軸を最初の軸に沿って合わせます。次のような軸を利用できます: パッド、またはビアの中央、STEPモデルで定義した端、または軸。

 

これらのコマンドを実行して整列した後、そのコマンドが継続され、再度、整列できる状態です。これらのコマンドを終了するには、Esc を押す必要があります。

オブジェクトは、平面、または軸で整列できます。

アセンブリの断面ビューを定義

断面ビューは、通常、表示されないアセンブリ内の詳細を表示するために使用できるビューです。これは、アセンブリの断面をスライス、またはカットする面を定義して作成します。マルチボードアセンブリ エディタでは、3 つの軸(断面を 1、2、3 方向に定義できます)に沿って断面を定義できます。

断面の位置は、3 色のパネルで定義します。View Configuration パネル、または View メニューのコマンドを介してそれらの表示や方向を設定できます。各パネルの位置は、カラーの矢印をクリック、ドラッグして変更できます。あるいは、パネル上のどこかをクリックしたまま移動します。カーソル下のパネルを選択、移動できます。


断面ビューの例 - 画像上にカーソルを置くと、断面ビューが表示されます。

ケース等のオブジェクトをアセンブリへ追加

マルチボード回路図で参照した PCB だけでなく、追加のオブジェクトをマルチボードアセンブリへ読み込むこともできます。追加のオブジェクト(Part と呼びます)は、File メニューのコマンドを介して、または Multi-board Assembly パネルの上部にあるボタンを使用して含めることができます。

以下の適切なボタンをクリックします(または、File メニューのコマンドを使用します):

- 他のマルチボードアセンブリをこのアセンブリへ挿入します。

- 他の PCB をこのアセンブリへ挿入します。

- STEP フォーマットの機構モデルをこのアセンブリへ挿入します。

part は、一つの実体としてマルチボード アセンブリへ挿入されることに注意してください。例えば、上半分、下半分から成るケースの STEP モデルを挿入する場合、独立して半分ずつ操作することはできません。この場合、アセンブリを半分ずつ個別に挿入する必要があります。

アセンブリ Part の更新、または編集

  • アセンブリへ追加した part を更新した場合、更新はマルチボード アセンブリへ読み込まれます。part を選択してから Edit » Update Selected Parts コマンドを実行(または、右クリックメニューを使用)します。
  • アセンブリ、または PCB の編集は、マルチボード アセンブリ エディタ内で行えます。part を選択してから Edit » Edit Selected Part コマンドを実行(または、右クリックメニューを使用)します。

 

Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

Contact Us

Contact our corporate or local offices directly.

You are reporting an issue with the following selected text
and/or image within the active document:
ALTIUM DESIGNER FREE TRIAL
Altium Designer Free Trial
Let’s get started. First off, are you or your organization already using Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

In that case, why do you need an evaluation license?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You actually don’t need an evaluation license for that.

Click the button below to download the latest Altium Designer installer.

Download Altium Designer Installer

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Please fill out the form below to get a quote for a new seat of Altium Designer.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

If you are on Altium Subscription, you don’t need an evaluation license.

If you are not an active Altium Subscription member, please fill out the form below to get your free trial.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Why are you looking to evaluate Altium Designer?

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

You came to the right place! Please fill out the form below to get your free trial started.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Sounds exciting! Did you know we offer special discounted student licenses? For more information, click here.

In the meantime, feel free to request a free trial by filling out the form below.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.

That’s great! Making things is awesome. We have the perfect program for you.

Upverter is a free community-driven platform designed specifically to meet the needs of makers like you.

Click here to give it a try!

If would like to speak with a representative, please contact your local Altium office.
Copyright © 2019 Altium Limited

Got it. You can download a free Altium Designer Viewer license which is valid for a 6 months.

Please fill out the form below to request one.

By clicking “Get Your Free Trial”, you are agreeing to our Privacy Policy.
You may receive communications from Altium and can change your notification preferences at any time.