Creación del ensamblaje físico de múltiples placas

Altium Designer admite la creación de un ensamblaje multitarjeta, denominado multi-board assembly. Una vez que la estructura lógica del sistema se define en un esquema multitarjeta (*.MbsDoc), el diseño físico multitarjeta se crea transfiriendo el diseño del sistema a un documento vacío de ensamblaje multitarjeta (*.MbaDoc). Este proceso cargará en el editor de ensamblajes multitarjeta la representación física (PCB y otros ensamblajes multitarjeta) referenciada por cada bloque lógico del esquema multitarjeta. Esta página describe ese proceso.

Para obtener más información sobre la etapa de diseño lógico de un ensamblaje multitarjeta, consulte la página Capturing the Logical System Design.

Los proyectos multitarjeta y sus subproyectos asociados pueden guardarse en un Workspace conectado, donde pueden beneficiarse de las capacidades de control de versiones, uso compartido y gestión proporcionadas por un Altium 365 Workspace o Enterprise Server Workspace.

Para obtener información sobre cómo almacenar y compartir un proyecto multitarjeta en un Altium 365 Workspace, consulte la página Workspace Projects .

Para crear un nuevo documento de ensamblaje multitarjeta:

  1. Agregue un nuevo documento de ensamblaje multitarjeta (*.MbaDoc) al proyecto multitarjeta haciendo clic con el botón derecho en la entrada del proyecto en el panel Projects y seleccionando Add New to Project » Multi-board Assembly en el menú contextual.

    Cada proyecto de diseño multitarjeta solo puede incluir un documento de ensamblaje multitarjeta.

  2. Guarde el nuevo documento de ensamblaje multitarjeta (haga clic con el botón derecho en su entrada en el panel Projects y seleccione Save As en el menú contextual).

  3. Transfiera la representación lógica del sistema desde el esquema multitarjeta al documento de ensamblaje multitarjeta: más información.

  4. Si el recinto está disponible, cárguelo en el ensamblaje: más información.

  5. Coloque cada elemento dentro del ensamblaje; consulte la página Positioning & Orienting Your Boards para obtener más información.

  6. Conecte elementos dentro del ensamblaje mediante mates; consulte la página Working with Mates para obtener más información.

Ejemplo de un ensamblaje multitarjeta. Varias PCB conectadas se colocan dentro de un recinto.
Ejemplo de un ensamblaje multitarjeta. Varias PCB conectadas se colocan dentro de un recinto.

Opening a Multi-board Assembly Created in Altium Designer 18

Los ensamblajes multitarjeta creados en Altium Designer 18 deben importarse debido a cambios en el formato de archivo necesarios para admitir el motor 3D y el conjunto de funciones mejorado. Cuando se abre un documento de ensamblaje multitarjeta con el formato antiguo, se abrirá el cuadro de diálogo Legacy document import.

Seleccione el comando Design » Import en el editor de ensamblaje multitarjeta para generar ECO que volverán a cargar los módulos secundarios.

Tenga en cuenta que, debido a los cambios en el formato de archivo necesarios para admitir el conjunto de funciones mejorado y el motor 3D, un ensamblaje multitarjeta guardado en una versión posterior de Altium Designer no puede abrirse en Altium Designer 18.

El editor de ensamblaje multitarjeta usa la biblioteca Open CASCADE para el modelado geométrico de un ensamblaje multitarjeta. Tenga en cuenta que, al abrir un documento de ensamblaje multitarjeta antiguo (de una versión anterior del software), se eliminarán los mates creados (puede elegir entre mantener las posiciones relativas de las partes del ensamblaje o colocarlas en línea). Tiene la opción de crear una copia de seguridad de esa versión anterior en el momento de la apertura.

Esta función está en Open Beta y está disponible cuando la opción System.MBAEngine.UseOpenCascade está habilitada en el cuadro de diálogo Advanced Settings dialog.

Transferencia del diseño del sistema al documento de ensamblaje multitarjeta

El diseño multitarjeta se transfiere desde el esquema multitarjeta al documento de ensamblaje multitarjeta mediante cualquiera de los siguientes comandos:

  • Design » Update Assembly - <MultiBoardAssemblyDocumentName>.MbaDoc desde los menús principales del editor de esquemas multitarjeta.

  • Design » Import Changes From <MultiBoardProjectName>.PrjMbd desde los menús principales del editor de ensamblaje multitarjeta.

Cuando ejecuta uno de estos comandos, el software analiza cada módulo del esquema multitarjeta, identifica la PCB/el ensamblaje que se ha seleccionado para cada uno de los proyectos secundarios y presenta la lista de modificaciones necesarias para agregar cada una de esas tarjetas al ensamblaje en el cuadro de diálogo Engineering Change Order.

La tarjeta de cada proyecto PCB se enumera como una modificación ECO y se carga en el editor de ensamblaje multitarjeta cuando se ejecutan los ECO.
La tarjeta de cada proyecto PCB se enumera como una modificación ECO y se carga en el editor de ensamblaje multitarjeta cuando se ejecutan los ECO.

Cuando se hace clic en el botón  , las tarjetas/ensamblajes se cargan en el editor de ensamblaje multitarjeta. Cada tarjeta/ensamblaje se coloca en el espacio de diseño con la misma orientación que tiene en el proyecto secundario. Este proceso llevará algo de tiempo, ya que debe analizarse y cargarse el conjunto completo de datos de cada PCB.

Las tarjetas de este ensamblaje multitarjeta se cargaron en el espacio de diseño del editor de ensamblaje multitarjeta, listas para ser posicionadas.
Las tarjetas de este ensamblaje multitarjeta se cargaron en el espacio de diseño del editor de ensamblaje multitarjeta, listas para ser posicionadas.

  • Mediante las opciones de la página Multi-board Assembly – General page del cuadro de diálogo Preferences, puede configurar si deben importarse los cuerpos 3D libres de las PCB secundarias y si no deben importarse los cuerpos 3D cuya altura sea inferior al valor especificado.

  • Use el comando View » Toggle Units de los menús principales (o el atajo Q) para alternar las unidades entre imperiales y métricas.

Adición de objetos adicionales al ensamblaje multitarjeta

También puede cargar objetos adicionales en un ensamblaje multitarjeta (además de las PCB referenciadas en el esquema multitarjeta). Los objetos adicionales pueden cargarse mediante el menú Design o usando los botones ubicados en la parte superior del panel Multi-board Assembly.

Cada entidad, o elemento, de un ensamblaje multitarjeta se denomina part.

Use el comando o botón apropiado para:

  • Insert PCB Part () – insertar otra PCB en este ensamblaje.

  • Insert MBA Part () – insertar otro ensamblaje multitarjeta en este ensamblaje.

  • Insert STEP Part () – insertar un modelo mecánico en formato STEP en este ensamblaje.

  • Tenga en cuenta que una pieza se inserta en el ensamblaje multitarjeta como una sola entidad. Por ejemplo, si inserta el modelo STEP de una carcasa, que consta de una mitad superior y una mitad inferior, no podrá manipular esas mitades de forma independiente. En esta situación, debe insertar cada mitad en el ensamblaje por separado.

  • El ensamblaje o PCB insertado se agrega not al proyecto Multi-board Design (*.PrjMbd) y, por lo tanto, no aparece como elemento secundario de ese proyecto en el panel Projects.

Actualización o edición de una parte del ensamblaje

Bloqueo/desbloqueo de una parte

Para bloquear/desbloquear una parte, seleccione la parte deseada, haga clic con el botón derecho y luego elija el comando Lock Selected Part/Unlock Selected Part en el menú contextual para bloquear/desbloquear la parte (o las partes emparejadas) en su ubicación actual en el espacio de diseño del editor de ensamblaje. Como alternativa, haga clic con el botón derecho en una entrada de parte en el panel Multiboard Assembly y luego elija Locked.

  • Una parte bloqueada no puede editarse ni moverse.

  • Las partes que están bloqueadas se marcan con un icono de candado en el panel Multiboard Assembly .

  • Una parte individual bloqueada no muestra un gizmo de objeto (para obtener más información sobre el gizmo de objeto, consulte la página Positioning & Orienting Your Boards). Una parte bloqueada no puede emparejarse si se selecciona como origen (el objeto que se mueve; para obtener más información sobre el emparejamiento de partes, consulte la página Working with Mates).

Actualización de una parte

Si se ha actualizado una parte o cuerpo 3D agregado a un ensamblaje, la actualización puede cargarse en el ensamblaje multitarjeta mediante una de las siguientes acciones:

  • Elija el comando Edit » Update All Parts en los menús principales o haga clic con el botón derecho en cualquier lugar del espacio de diseño y elija el comando Update All Parts en el menú contextual (atajo: Shift+Ctrl+U) para actualizar todas las partes del ensamblaje multitarjeta activo con la información de diseño más reciente de sus documentos PCB secundarios correspondientes.

  • Seleccione la(s) parte(s) requerida(s) y elija el comando Edit » Update Selected Part en los menús principales o haga clic con el botón derecho en cualquier lugar del espacio de diseño y elija el comando Update Selected Part en el menú contextual (atajo: Ctrl+U) para actualizar las partes seleccionadas en el ensamblaje multitarjeta activo con la información de diseño más reciente de sus documentos PCB secundarios correspondientes.

  • Seleccione el cuerpo 3D requerido y elija el comando Edit » Update Selected 3D Body en los menús principales o haga clic con el botón derecho en cualquier lugar del espacio de diseño y elija el comando Update Selected 3D Body en el menú contextual para actualizar los cuerpos 3D seleccionados en el ensamblaje multitarjeta activo con la información de diseño más reciente de sus documentos PCB secundarios correspondientes.

Edición de una parte

Se puede iniciar una sesión de edición de ensamblaje o PCB desde el editor de ensamblaje multitarjeta. Seleccione la parte requerida y ejecute el comando Edit » Edit Selected Part o haga clic con el botón derecho en cualquier lugar del espacio de diseño y elija el comando Edit Selected Part en el menú contextual (atajo: Ctrl+E). Después de ejecutar el comando, entrará en el modo de edición de partes, con la PCB seleccionada ampliada y centrada (cuando sea posible) para ajustarse a la ventana principal de diseño. La tarjeta permanecerá mostrada con su coloración completa, mientras que todas las demás tarjetas aparecerán en gris (solo lectura).

Realice los cambios necesarios en la colocación de componentes, usando colocación manual y/o funciones de alineación. Una vez que haya terminado de editar, use el comando Finish Part Editing (Ctrl+E). La vista del espacio de diseño volverá a ajustarse para mostrar todas las tarjetas del ensamblaje, y la tarjeta que se estaba editando permanecerá seleccionada.

Si desea cancelar la edición sin aplicar ninguno de los cambios, use el comando Cancel Part Editing .

Navegación y gestión del ensamblaje multitarjeta

Para navegar y gestionar un ensamblaje multitarjeta, puede usar el panel Multiboard Assembly.

El panel presenta una vista de árbol expandible de la estructura completa del ensamblaje, que incluye:

  • Las tarjetas (PCB) y ensamblajes multitarjeta incluidos, así como los componentes, capas y redes dentro de cada PCB

  • Modelos STEP que se han incluido

  • Otros ensamblajes multitarjeta que se han incluido

  • Mates formados entre objetos del ensamblaje

Resaltado de elementos en el ensamblaje multitarjeta

El panel Multiboard Assembly ofrece capacidades de resaltado, donde la parte seleccionada en el árbol se resalta en el espacio de diseño. El resaltado es bidireccional para las selecciones realizadas en la parte superior del árbol del ensamblaje; por ejemplo, el estado de selección de las entradas del panel cambiará en respuesta a los objetos de nivel superior seleccionados en el espacio de diseño. Desde el panel, la selección se admite en todos los niveles del árbol donde tenga sentido. Por ejemplo, al seleccionar una red individual, esa red se resaltará en toda la tarjeta, pero al seleccionar una capa dieléctrica individual, esa capa no se resaltará. Los atajos estándar de Windows Shift+Click o Ctrl+Click pueden usarse para realizar selecciones múltiples en el panel.

Tres tarjetas seleccionadas en el espacio de diseño también se resaltan en el panel.
Tres tarjetas seleccionadas en el espacio de diseño también se resaltan en el panel.

El resaltado desde el panel proporciona un excelente método para localizar una parte específica o examinar la trayectoria de un conjunto de redes a medida que pasan por debajo de una tarjeta hija.

Control de la visibilidad y transparencia de las partes del ensamblaje

Además de resaltar una parte o partes específicas, el panel también puede usarse para controlar la visibilidad y la transparencia de las partes actualmente seleccionadas en el panel. Haga clic con el botón derecho en la(s) parte(s) seleccionada(s) y luego elija Visible o Transparent en el menú contextual. Las partes transparentes se volverán translúcidas. Las partes que tengan deshabilitada la opción Visible quedarán ocultas.

Javascript ID: MBA_Pnl_MultiboardAssembly_PartVisibility

Un modelo STEP es completamente visible en el ensamblaje.

El mismo modelo se hizo transparente.

El mismo modelo se ocultó por completo.

También puede controlar la visibilidad de una PCB, un componente de PCB o un modelo STEP directamente en el espacio de diseño.

  • Para un objeto completo, como una PCB o un modelo STEP, seleccione el objeto, luego haga clic con el botón derecho para mostrar el menú contextual y elija la opción Visible para ocultar el objeto. Use el panel Multi-board Assembly para restaurar la visibilidad.

  • Para un componente de PCB, seleccione la PCB en el espacio de diseño, haga clic con el botón derecho y elija Edit Selected Part. Luego, haga clic con el botón derecho en cualquier componente de esa tarjeta y elija los comandos Visible o Transparent en el menú contextual. Cuando haya terminado de configurar la visibilidad de los componentes de esa tarjeta, vuelva a hacer clic con el botón derecho sobre ella y elija Finish Editing Part o Cancel Editing Part.

Medición de distancia

El comando Tools » Measure Distance de los menús principales (atajo: Ctrl+M) se utiliza para medir distancias entre cuerpos 3D en el ensamblaje multitarjeta. Después de ejecutar el comando, entrará en el modo de medición. La medición se realiza de la siguiente manera:

  1. Elija el primer objeto 3D, o una cara específica de ese objeto. A medida que mueve el cursor sobre un posible objeto 3D, el color de ese objeto cambiará. Si desea seleccionar una cara específica del objeto, mantenga presionada la tecla Ctrl  mientras mueve el cursor; la cara que se encuentra actualmente bajo el cursor se resaltará. Con el cursor en posición, haga clic para confirmar la selección del objeto/cara.

  2. Elija el segundo objeto 3D, o una cara específica de ese objeto.

  3. La herramienta presenta visualmente la distancia más corta entre los dos objetos (caras) elegidos.

  4. Continúe midiendo la distancia entre otros objetos/caras o presione Esc para salir del modo de medición.

  • Todos los resultados de medición durante la sesión de medición activa se presentan en el panel Messages . Puede hacer doble clic en una entrada para hacer cross-probe a esa medición dentro del espacio de diseño.

  • Una vez que finalice la sesión de medición, se borrarán todas las mediciones visuales, junto con todas las entradas de medición en el panel Messages .

  • Al pasar el cursor sobre un cuerpo 3D (o una de sus caras), el color cambiará al especificado para el color del sistema Highlight Under Cursor , en la sección System Colors del panel View Configuration.

Prueba de colisiones

Las colisiones se señalan siempre que dos objetos tengan superficies que se toquen o se intersequen.

Para comprobar si hay colisiones, seleccione Tools » Check Collisions (atajo: Ctrl+K). Después de ejecutar el comando, el software verifica si hay colisiones entre las distintas entidades involucradas en el ensamblaje multitarjeta. Primero, se comprueba si cada tarjeta colisiona con las partes superior e inferior del recinto/carcasa (partes STEP), seguido de la comprobación entre las propias tarjetas (PCB).

Cualquier colisión se informará a través del panel Messages , y los objetos problemáticos se resaltarán usando el color del sistema Violation . Use la región Details del panel Messages para investigar qué componente de una tarjeta involucrada en un conflicto está causando la colisión.

Si es necesario, las violaciones por colisión resaltadas en el espacio de diseño después de haber ejecutado la comprobación de colisiones pueden eliminarse seleccionando el comando Tools » Clear Violations .

  • La comprobación de colisiones se realizará entre todas las tarjetas y las partes del recinto/carcasa, independientemente de la visibilidad de la tarjeta/parte en el espacio de diseño.

  • No se considera que las superficies emparejadas estén colisionando.

Compatibilidad con rigid-flex

El editor de ensamblaje multitarjeta admite PCB rigid-flex. Rigid-flex es el nombre que se da a un circuito impreso que combina circuitos flexibles y circuitos rígidos. El editor de ensamblaje multitarjeta muestra la PCB en el estado final plegado tal como se define en el editor de PCB.

Para obtener información sobre el diseño de PCB rigid-flex, consulte la página Designing a Rigid-Flex PCB.

Exportación a MCAD

El ensamblaje puede exportarse en formato STEP 3D o Parasolid. Para exportar todo el ensamblaje en STEP 3D (*.step o *.stp), seleccione File » Export » STEP 3D  en los menús principales. Para exportar todo el ensamblaje en formato Parasolid (*.x_t), seleccione File » Export » Parasolid en los menús principales.

Ejemplo del archivo STEP del ensamblaje multitarjeta abierto en una herramienta MCAD.
Ejemplo del archivo STEP del ensamblaje multitarjeta abierto en una herramienta MCAD.

Un ensamblaje multitarjeta también puede sincronizarse entre Altium Designer y una herramienta MCAD compatible usando la funcionalidad Altium MCAD CoDesigner.

Para obtener más información, consulte la página Synchronizing a Multi-board Assembly.

Exportación a PDF 3D

Un documento de ensamblaje multitarjeta también puede exportarse a un archivo PDF (*.pdf). Para hacerlo, elija el comando File » Export to PDF File en los menús principales.

Para obtener más información, consulte la página Preparing a PDF3D File.

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contenido