Diseño de un PCB rígido-flexible
De un vistazo
- Comprende la diferencia entre los modos rígido-flexibles Estándar y Avanzado, y cuándo se necesita cada uno.
- Aprende los pasos principales para crear una PCB rígido-flexible, incluidos los subapilados, las regiones de la placa y las líneas de flexión.
- Descubre cómo Altium Designer integra las consideraciones de diseño eléctrico y mecánico en un flujo de trabajo rígido-flexible.
¿Qué es un circuito rígido-flexible?
Como su nombre indica, un circuito impreso flexible es un patrón de conductores impreso sobre una película aislante flexible. Rígido-flexible es el nombre que recibe un circuito impreso que combina uno o varios circuitos flexibles con uno o varios circuitos rígidos, como se muestra en la imagen.
La tecnología de circuitos flexibles se desarrolló inicialmente para el programa espacial con el fin de ahorrar espacio y peso. Actualmente es muy utilizada, ya que no solo ahorra espacio y peso —lo que la hace ideal para dispositivos portátiles como teléfonos móviles y tabletas—, sino que también puede reducir la complejidad de la integración física, mejorar la fiabilidad del producto y reducir los costes.
Los circuitos flexibles se suelen dividir en dos clases según su uso: circuitos flexibles static y circuitos flexibles dynamic. Los circuitos flexibles estáticos (también denominados use A) son aquellos que se flexionan mínimamente durante el montaje y el funcionamiento. Los circuitos flexibles dinámicos (también denominados use B) son aquellos diseñados para flexionarse con frecuencia, como los de un cabezal de unidad de disco, un cabezal de impresora o los que forman parte de la bisagra de la pantalla de un portátil. Esta distinción es importante, ya que afecta tanto a la selección de materiales como al método de fabricación. Existen diversas configuraciones de apilado de capas que pueden fabricarse como circuitos rígido-flexibles, cada una con sus propias ventajas eléctricas, físicas y de coste.
Diseño mecánico de circuitos rígido-flexibles
Diseñar un circuito flexible o rígido-flexible es, en gran medida, un proceso electromecánico. El diseño de cualquier PCB es un proceso tridimensional, pero en un diseño flexible o rígido-flexible los requisitos tridimensionales son mucho más importantes. ¿Por qué? Porque la placa rígido-flexible puede fijarse a varias superficies del interior de la carcasa del producto, y el proceso de fijación y plegado suele realizarse durante el montaje del producto. Para obtener un diseño electromecánico funcional, se requiere una colaboración estrecha y constante entre los equipos de ingeniería mecánica y eléctrica. El enfoque tradicional para confirmar que la placa plegada cabe en su carcasa ha sido crear una maqueta mecánica, conocida como modelo recortable de papel. Por su propia naturaleza, resulta difícil lograr la precisión y el realismo necesarios con este enfoque.
Una placa con dos regiones rígidas conectadas por una región flexible en el editor de PCB ECAD y en MCAD.
Altium ayuda a resolver este desafío con CoDesigner, una sofisticada tecnología de interfaz entre el diseño mecánico y el electrónico. CoDesigner permite a los ingenieros intercambiar cambios en la forma de la placa y en los componentes entre los entornos de diseño ECAD y MCAD, directamente desde el software de diseño ECAD y MCAD.
-
Descripción general de la tecnología MCAD CoDesigner de Altium
-
Referencia técnica: obtenga más información sobre el codiseño ECAD-MCAD
-
Obtenga más información sobre cómo transferir un diseño rígido-flexible a MCAD
Diseño de una PCB rígido-flexible
Una placa de circuito impreso se diseña como una serie de capas apiladas unas sobre otras. En una placa de circuito impreso rígida tradicional, la forma de la placa la define en el plano X-Y, y el apilado de capas la define en el plano Z. La forma de la placa en X-Y se define en la ventana principal de edición de PCB, y las capas se configuran en el Administrador de apilado de capas. En una PCB rígido-flexible, la placa de circuito impreso terminada tiene más de una zona o región, y cada una de esas regiones puede utilizar un conjunto de capas diferente.
Para diseñar una placa rígido-flexible, debe:
-
Activar el modo Rigid-Flex necesario (Administrador de apilado de capas, comando Tools » Features » Rigid-Flex o Tools » Features » Rigid-Flex (Advanced))
-
Definir el subapilado necesario para cada región de la placa y configurar cómo se alinean entre sí esos subapilados en el plano Z.
-
Definir la forma de cada región rígida y flexible en el plano X-Y y asignar el subapilado correcto a cada región.
Activación del diseño rígido-flexible
Para admitir las estructuras complejas presentes en una placa de circuito impreso rígido-flexible moderna, el editor del plano Z —el Administrador de apilado de capas— ofrece distintos modos de visualización para editar la estructura de la placa. Seleccione el comando Design » Layer Stack Manager para abrir el Administrador de apilado de capas, donde podrá activar el modo rígido-flexible necesario y crear y alinear los subapilados que requiere su diseño rígido-flexible.
Al abrirse, el Administrador de apilado de capas mostrará el apilado de capas actual de la placa. En una PCB nueva, será una placa sencilla de dos capas. Para activar las funciones necesarias para diseñar una placa rígido-flexible, abra el submenú Tools » Features o haga clic en el botón Features (
) para seleccionar el modo estándar Rigid-Flex (también denominado RF1) o el modo Rigid-Flex (Advanced) (también denominado RF2).
Seleccione el comando para activar el modo rígido-flexible necesario.
Elección del modo rígido-flexible estándar o avanzado
El software de diseño de PCB de Altium ofrece dos modos de diseño rígido-flexible. El modo original, o estándar, denominado Rigid-Flex (o rigid-flex 1), admite diseños rígido-flexibles que incluyen una o varias definiciones de apilado rígido y flexible. Para utilizar el modo rígido-flexible estándar, debe ser posible definir la placa completa como una única forma plana vista desde arriba, sin regiones superpuestas. Este es el enfoque utilizado en el modo rigid-flex 1: se define una única forma global de la placa y, a continuación, se colocan líneas de división para dividir esa forma en las distintas regiones rígidas y flexibles. Una vez hecho esto, se puede asignar un apilado de capas a cada región.
Obtenga más información sobre el diseño de una placa rígido-flexible en modo estándar.
Si tu diseño tiene requisitos rígido-flexibles más complejos, como regiones flexibles superpuestas, necesitas el modo rígido-flexible avanzado (también conocido como rígido-flexible 2.0). Además de las regiones flexibles superpuestas, el modo avanzado también ofrece: definición visual de los subapilados en el plano Z, definición independiente de cada región rígida y flexible de la placa, pliegues en recortes anidados, divisiones con formas personalizadas, la posibilidad de definir estructuras de tipo encuadernación, la posibilidad de incluir una capa de cobertura en una región flexible y compatibilidad con diseños exclusivamente flexibles.
Más información sobre el diseño de una placa rígido-flexible en modo avanzado.
Cambiar del modo estándar al modo avanzado
El cambio del modo estándar al modo avanzado se realiza en Layer Stack Manager, como se muestra en la imagen anterior. Al seleccionar la opción Rigid-Flex (Advanced) en el menú Tools » Features, el software convierte automáticamente la forma única de la placa en varios objetos de región de placa y asigna los apilados de capas según sea necesario. El siguiente vídeo muestra el proceso.
Descripción general del cambio del modo rígido-flexible estándar al modo avanzado.
Trabajar con regiones de placa
Una región de placa es el término utilizado para describir cada área de la placa definida por el usuario que necesita tener asignado un apilado de capas específico, un requisito habitual en una PCB rígido-flexible. En la siguiente imagen, la forma de la placa se ha dividido en tres regiones de placa distintas: la región circular superior, la franja central estrecha y la región circular inferior.

Una placa rígido-flexible vista en el modo de planificación de placa. Observa que la forma de la placa se ha dividido en tres regiones de placa distintas, cada una de las cuales muestra su nombre y el apilado de capas que tiene asignado.
Cuando se crea una placa nueva, esta tiene una única región de placa de forma predeterminada. Si el diseño de la placa requiere varias regiones, puedes:
- dividir una única región de placa en varias regiones (modo rígido-flexible estándar o modo rígido-flexible avanzado), o bien
- colocar varias regiones de placa para construir la forma completa (modo rígido-flexible avanzado).
Las regiones de placa se definen y editan en el modo de planificación de placa (menú View).
Trabajar con líneas de plegado
Las líneas de plegado se definen y editan en el modo de planificación de placa (menú View).
Propiedades de una línea de plegado
Las líneas de plegado tienen las siguientes propiedades interrelacionadas:
- Bend Angle (a): el ángulo que debe doblarse la superficie de la región flexible.
-
Radius (
r): la distancia desde la superficie de plegado hasta el centro de curvatura. -
Width (
w): la anchura de la superficie que se doblará para los valores de Radius y Bend Angle especificados.
La relación entre Bend Angle, Radius y width puede expresarse como:
-
w = a/360 * 2*Pi*r -
o, en palabras,
width = Fraction of the circumference being bent * Circumference
Explorar las regiones de apilado de capas y las líneas de plegado
En el modo del panel PCB Layer Stack Regions, sus tres áreas principales cambian para reflejar lo siguiente (de arriba abajo):
- Los nombres de los Layer Stacks disponibles.
- Los Stackup Regions definidos en la placa o los asignados a un apilado de capas seleccionado.
- La lista de Bending Lines de la región de apilado seleccionada.
Mientras utilizas el modo Layer Stack Regions del panel PCB, cambia a la vista del modo de planificación de placa mediante el menú View » Board Planning Mode o utiliza el método abreviado 1.

Una placa puede dividirse en regiones distintas (regiones de apilado) a las que se asignan configuraciones específicas de apilado de capas (apilados de capas). Las áreas de plegado (líneas de plegado) se definen en las regiones flexibles de la placa.
Cuando se selecciona el nombre de un apilado de capas concreto en el área Layer Stacks del panel PCB, se aplica un filtro cuyo ámbito es ese apilado de capas. Por tanto, las regiones de placa asignadas a ese apilado aparecerán en el área Stackup Regions del panel. A su vez, las líneas de plegado definidas en una región de apilado seleccionada aparecerán en el área de lista Bending Lines.
Al hacer doble clic en una región de apilado de la lista (o en la propia región de placa en el espacio de diseño), se abre el cuadro de diálogo Región de placa (modo rígido-flexible estándar) o el modo Región de placa del panel Propiedades (modo rígido-flexible avanzado). Utiliza este cuadro de diálogo o panel para cambiar el nombre de una región, asignarla a un apilado de capas o bloquear sus propiedades 3D.
Al hacer doble clic en una línea de plegado de la lista del área Bending Line del panel, se abre el cuadro de diálogo Línea de plegado, en el que se pueden editar en detalle las propiedades de la línea.
Visualizar y plegar un diseño rígido-flexible en 3D
El editor de PCB incluye un potente motor de renderizado 3D que permite mostrar una representación tridimensional muy realista de la placa de circuito cargada. Este motor también admite circuitos rígido-flexibles y, cuando se utiliza junto con el control deslizante Fold State del panel PCB , permite al diseñador examinar su diseño rígido-flexible en estado plano (sin aplicar los ajustes de las líneas de plegado), completamente plegado (con todos los ajustes de las líneas de plegado aplicados) y en cualquier estado intermedio.
Para cambiar al modo de visualización 3D, pulsa la tecla de método abreviado 3 (pulsa 2 para volver a 2D o 1 para volver al modo de planificación de placa). La placa se mostrará en 3D. Si las huellas de los componentes incluyen objetos de cuerpo 3D que definen el componente montado, estos también se mostrarán. En la siguiente imagen, puedes ver que la placa incluye una batería y un clip de sujeción para la batería.
Para aplicar todas las líneas de plegado, desplace el control deslizante Fold State del panel PCB cuando esté configurado en el modo Layer Stack Regions, como se resalta en la imagen siguiente. Tenga en cuenta que los pliegues se aplican en el orden definido por su número de secuencia. Las líneas de plegado pueden compartir el mismo número de secuencia; esto simplemente significa que esos pliegues se realizarán al mismo tiempo al utilizar el control deslizante Fold State. La placa también se puede plegar/desplegar ejecutando el comando View » 3D View Control » Fold/Unfold (o pulsando el atajo de teclado 5).

Utilice el control deslizante Fold State (o el atajo de teclado 5) para aplicar todas las líneas de plegado en el orden definido por su valor de secuencia (índice de plegado).
Compatibilidad de 3D Movie Maker con diseños rígido-flexibles
El plegado de un diseño rígido-flexible también se puede capturar en un vídeo 3D. Es muy sencillo y no requiere utilizar fotogramas clave durante la secuencia de plegado.
Consulte la página Preparación de un vídeo 3D de una PCB para obtener una descripción detallada de cómo crear un vídeo 3D. Como guía básica:
- Cambie el editor de PCB al modo 3D.
- Abra el panel PCB 3D Movie Editor y cree un vídeo nuevo haciendo clic en el botón New . Haga clic en el vídeo recién creado en la sección Movie Title y asígnele un nombre adecuado.
- Cree un Key Frame inicial que muestre la placa desplegada.
- Desplace el control deslizante Fold State para mostrar el diseño rígido-flexible plegado y, a continuación, coloque la placa plegada en la posición deseada.
- Ahora cree un segundo Key Frame para esta vista y establezca el tiempo. Considere cuánto desea que dure el plegado del diseño rígido-flexible (el ajuste Duration); normalmente serían unos pocos segundos.
-
Para comprobar que el vídeo captura correctamente el proceso de plegado, haga clic en el botón de reproducción (situado en los controles del reproductor, en la parte inferior del panel).
- Para generar un archivo de vídeo, añada una salida de documentación PCB 3D Video en un archivo Output Job. Recuerde configurar las opciones de formato del vídeo en el cuadro de diálogo Configuración de vídeo.
- Haga clic en el enlace Generate Content del archivo Output Job para crear el archivo de vídeo.
El vídeo siguiente se creó mediante este proceso. Contiene los dos fotogramas clave descritos anteriormente y un fotograma clave adicional al final para mantener la posición final durante un segundo.
Un vídeo 3D sencillo creado a partir de tres fotogramas clave; el comportamiento del plegado se define mediante los valores de secuencia de las líneas de plegado.
► Más información sobre Preparación de un vídeo 3D de una PCB
Consideraciones de diseño
A continuación se resumen los aspectos clave que deben tenerse en cuenta al diseñar una PCB rígido-flexible:
- Trazado de conductores: es importante elegir el estilo de las esquinas de las pistas que atraviesan una región flexible; evite las esquinas pronunciadas y utilice curvas para minimizar las tensiones mecánicas.
- Forma y área de los pads: utilice refuerzos en forma de lágrima con orejas de conejo (salientes de anclaje) en los circuitos flexibles de una sola cara. El objetivo es que la capa de recubrimiento cubra parte del pad.
- Orificios pasantes: procure evitar los orificios pasantes en la zona de plegado, especialmente en aplicaciones dinámicas.
- Capa de recubrimiento: evite los concentradores de tensiones (que dejan expuesta la pista entrante); reduzca la abertura de la capa de recubrimiento a 250 µm.
- Planos: utilice un patrón de malla cruzada, si es posible.
- Longitudes escalonadas: para evitar el pandeo de las capas al flexionarlas (efecto de encuadernación), escalone las longitudes de las capas aproximadamente 1,5 veces el espesor de la capa.
- Bucle de servicio: haga la región flexible ligeramente más larga para facilitar el montaje/desmontaje y admitir variaciones dimensionales del producto (esta longitud adicional se denomina bucle de servicio).
- Aprovechamiento del cobre: considere cómo se panelizará el circuito flexible; puede ser conveniente ajustar el diseño para garantizar el mejor aprovechamiento del material.
- Panelización: oriente las regiones flexibles de acuerdo con la dirección de la fibra del material (realice el plegado siguiendo la fibra).
- Resistencia al desgarro: esquinas curvas; orificio taladrado en la esquina; orificio en la ranura; deje metal en las esquinas.
- Trazado de pistas: disponga las pistas de forma alternada en las placas de dos capas para evitar el efecto de viga en I y ensanche las pistas en la zona de plegado (esto es especialmente importante para los pliegues permanentes).
- Relación de plegado estático: establece la relación entre el radio de curvatura y el espesor del circuito. Idealmente, los circuitos multicapa deben tener una relación de plegado de al menos 15:1. Para los circuitos de doble cara, la relación mínima debe ser de al menos 10:1. Para los circuitos de una sola capa, la relación mínima debe ser de al menos 5:1. Para una aplicación dinámica, procure utilizar una relación de plegado de 20:1 a 40:1.
- El cobre laminado y recocido es más dúctil; el cobre depositado electrolíticamente no es la mejor opción para las regiones flexibles.
Requisitos de documentación y planos
Los requisitos de documentación que suelen recomendarse incluyen:
- La PCB flexible deberá fabricarse conforme a la norma IPC-6013, clase (indique aquí su requisito).
- La PCB flexible deberá construirse para cumplir una clasificación mínima de inflamabilidad V-0 (si se requiere).
- La PCB flexible deberá cumplir la directiva RoHS (si se requiere).
- El material rígido deberá ser GFN conforme a IPC-4101/24 (si se utiliza material epoxi).
- El material rígido deberá ser GIN conforme a IPC-4101/40 (si se utiliza material de poliimida).
- El material flexible revestido de cobre deberá cumplir la norma IPC 4204/11 (material dieléctrico flexible revestido de cobre sin adhesivo).
- El material de la capa de recubrimiento deberá cumplir la norma IPC 4203/1.
- El espesor máximo de la placa no deberá superar (indique aquí su requisito) y se aplicará después de todos los procesos de laminación y metalización. Se medirá sobre las superficies metalizadas acabadas.
- El espesor del adhesivo acrílico en la parte rígida del panel no deberá superar el 10 % del espesor total de la estructura. Consulte los comentarios anteriores al respecto.
- Se podrá utilizar material de embolsado para facilitar la fabricación, pero deberá retirarse de la parte flexible de la placa antes del envío.
- El espesor de la sección flexible deberá ser (indique aquí su requisito). No añada esta nota si este espesor no es crítico.
- El espesor mínimo de cobre en las paredes de los orificios pasantes metalizados debe ser de (indique aquí su requisito; se recomienda un promedio de 0,001”) con un anillo anular mínimo de (indique aquí su requisito; se recomienda 0,002).
- Aplicar una máscara de soldadura LPI verde (si es necesario) sobre el cobre desnudo en ambas caras solo en las secciones rígidas de la placa. Todo el metal expuesto tendrá (especifique aquí el acabado superficial requerido).
- Aplicar serigrafía en ambas caras de la placa (si es necesario) con tinta epoxi no conductora de color blanco o amarillo (los más habituales).
- Requisitos de marcado e identificación.
- Requisitos de pruebas eléctricas.
- Requisitos de embalaje y envío.
- Requisitos de impedancia.
Detalles adicionales del plano
- Una tabla de taladros que detalle el tamaño final de los orificios, las tolerancias correspondientes y si están metalizados o no.
- Un plano acotado que incluya las referencias de medición, las dimensiones críticas, las interfaces entre las secciones rígidas y flexibles, y los indicadores de ubicación y dirección de los dobleces.
- Detalles de panelización, si es necesario.
- Detalles de construcción y de las capas, con indicación del material utilizado en cada capa, los espesores y los pesos del cobre.
Referencias
Guía técnica de ingeniería de circuitos flexibles y rígido-flexibles - Epec Engineering Technologies
Tecnología de circuitos flexibles - Joe Fjelstad
Guía de diseño de circuitos flexibles - Minco Products Inc
Recursos de Minco Products sobre circuitos flexibles
- Fundamentos del diseño de circuitos flexibles - Robert Repas
- Mantener la flexibilidad - Mark Finstad, ingeniero de aplicaciones