Diseño con múltiples PCB
De un vistazo
- Comprende la estructura de un proyecto multiplaca y la función de sus documentos de esquema y ensamblaje.
- Descubre cómo el entorno multiplaca permite comprobar la conectividad eléctrica y colocar las placas dentro de una carcasa.
- Explora las opciones para consolidar los datos de los componentes en una BOM a nivel de sistema y preparar la documentación y los archivos de salida.
Muchos productos incluyen varias placas de circuito impreso interconectadas. Integrar estas placas dentro de la carcasa y garantizar que se conecten correctamente entre sí es una fase compleja del proceso de desarrollo del producto. ¿Se han asignado correctamente las redes en cada conector? ¿Están los conectores orientados correctamente? ¿Encajan entre sí las placas enchufables? ¿Caben todas las placas conectadas dentro de la carcasa? Un error en esta etapa tan avanzada del ciclo de desarrollo del producto resulta costoso, tanto por el coste del rediseño como por el retraso en la comercialización.
Para gestionar estos aspectos se necesita un entorno de diseño que admita el diseño a nivel de sistema. Lo ideal es disponer de un espacio de diseño donde se pueda definir el sistema funcional o lógico, así como conectar las distintas placas y verificar que se conecten correctamente, tanto lógica como físicamente.
Altium Designer incorpora el diseño a nivel de sistema al proceso de desarrollo de productos electrónicos mediante la funcionalidad de diseño multiplaca.
Estructura de un proyecto de diseño multiplaca
Los diseños de productos electrónicos avanzados suelen estar compuestos por varios diseños de PCB interconectados para crear un sistema completo y funcional. Desde un diseño con una placa principal y un módulo LCD en el panel frontal hasta un complejo sistema de placa posterior activa con tarjetas enchufables, todos se implementan como un sistema de varios diseños de placas.
Esto requiere un sistema de diseño de alto nivel que permita conectar eléctrica y físicamente varios diseños de PCB «secundarios», manteniendo la integridad de la conectividad de sus pines y redes. Altium Designer permite el diseño integrado a nivel de sistema mediante un entorno Multi-board Design específico que abarca tanto los aspectos lógicos (esquemático) como los físicos (PCB) del diseño del sistema.
En Altium Designer, un diseño multiplaca a nivel de sistema se aloja en un tipo de proyecto multiplaca específico (*.PrjMbd), junto con el documento de diseño lógico basado en esquemáticos (*.MbsDoc) y los documentos físicos basados en PCB (*.MbaDoc) que lo componen. Estos tipos de documentos incorporan diseños de proyectos de PCB existentes al entorno de diseño multiplaca, donde se interconectan, editan y verifican como un sistema completo.
Se puede crear un nuevo proyecto de diseño multiplaca del mismo modo que un proyecto de diseño de PCB o de arneses. Seleccione el comando File » New » Project en los menús principales para abrir el cuadro de diálogo Create Project. Seleccione la entrada <Empty> o una plantilla de proyecto disponible en la lista Multiboard.
Un proyecto de diseño multiplaca admite los siguientes documentos:
-
Esquemático multiplaca (
*.MbsDoc): se colocan bloques gráficos (módulos) que representan los proyectos de PCB secundarios y se conectan entre sí para crear el diseño lógico del sistema. -
Ensamblaje multiplaca (
*.MbaDoc): este documento es la contraparte física del diseño lógico del sistema definido en el documento de esquemático multiplaca y se rellena con datos de PCB importados del proyecto multiplaca. Las PCB a las que hacen referencia los módulos del esquemático multiplaca se cargan en el documento de ensamblaje multiplaca, donde puede colocar cada placa (junto con una carcasa, si es necesario). -
ActiveBOM (
*.BomDoc): contiene una lista de materiales (BOM) con los componentes utilizados en los proyectos de PCB secundarios.Lista de materiales a nivel de sistema
Un elemento fundamental de los datos de producción de un proyecto es un registro válido de los componentes necesarios para el diseño y sus datos asociados, recogidos en una lista de materiales (BOM). Altium Designer proporciona la función avanzada ActiveBOM, que también ofrece información en tiempo real sobre piezas fabricadas y proveedores, especificaciones de componentes, estado del ciclo de vida, disponibilidad y mucho más. Toda esta información se recopila y gestiona mediante el documento ActiveBOM del proyecto. En un diseño multiplaca, se pueden crear documentos ActiveBOM dentro del propio proyecto multiplaca para disponer de una definición de la BOM de todo el proyecto a partir de una única fuente, sin necesidad de recopilar manualmente esos datos de las BOM de cada subproyecto.
La BOM a nivel de sistema obtiene los parámetros de los componentes del documento de ensamblaje multiplaca, que a su vez obtiene la información de los componentes de los subproyectos multiplaca, según lo definido en el esquemático multiplaca. Por lo tanto, depende de que los subproyectos estén actualizados y de que sus esquemáticos y PCB estén sincronizados, al igual que los documentos de esquemático y ensamblaje multiplaca (Design » Update Assembly - <MultiBoardAssemblyDocumentName>.MbaDoc o Design » Import Changes from <MultiBoardProjectName>.PrjMbd, respectivamente).
Una BOM multiplaca de nivel superior también incluye detalles del proyecto de origen de cada elemento de la lista en forma de información en las columnas de módulo: ModuleAssembly, ModuleDesignator, ModuleSource y ModuleTitle (su visibilidad se puede gestionar desde la pestaña Columns del panel Properties).
Como referencia conjunta de la información de las piezas de todo el diseño del producto —en la práctica, un conjunto conectado de módulos de proyectos de PCB—, una BOM a nivel de sistema incluirá datos de componentes y de la cadena de suministro de todos los subproyectos, además de información consolidada, como el precio total de piezas específicas y el coste de todas las piezas del diseño multiplaca completo.
-
Documento de Draftsman (
*.MbDwf) – se importan y se anotan las vistas del ensamblaje multiplaca, y se añade cualquier información adicional necesaria para fabricar el diseño. -
Archivo de trabajo de salida (
*.OutJob) – mediante un archivo de trabajo de salida, se puede preconfigurar un conjunto de salidas necesarias para fabricar el diseño multiplaca como un sistema completo. Cada salida se configura con sus propios ajustes y su propio formato de salida; por ejemplo, la salida a un archivo o a una impresora. El mismo archivo de trabajo de salida configurado para un proyecto de diseño multiplaca puede reutilizarse en otros diseños, lo que ahorra tiempo y esfuerzo al preparar las salidas de cada nuevo diseño.Salidas compatibles con un diseño multiplaca
Documentation Outputs
-
PDF 3D de MBA
Obtenga más información sobre Preparación de un archivo PDF3D.
Report Outputs
-
Lista de materiales
-
Comparación de BOM
-
Exportar comentarios
Obtenga más información sobre Preparación de informes.
Validation Outputs
-
Comprobaciones de BOM
-
Estados de los componentes
-
Conformidad de la configuración
Obtenga más información sobre Preparación de informes de validación.
Export Outputs
-
Exportación de MBA a PARASOLID
-
Exportación de MBA a STEP
Obtenga más información sobre Compatibilidad con la importación y exportación de datos mecánicos.
PostProcess Outputs
-
Copiar archivos
Obtenga más información sobre Preparación de salidas de posprocesamiento.
-
Captura del diseño lógico del sistema
Para empezar a capturar el esquema de su diseño multiplaca, añada un nuevo documento de esquema multiplaca al proyecto multiplaca. Para ello, haga clic con el botón derecho en la entrada del proyecto en el panel Projects y seleccione el comando Add New to Project » Multi-board Schematic en el menú contextual. El documento de esquema multiplaca predeterminado aparecerá en el espacio de diseño.

El documento de esquema multiplaca recién creado será el documento activo en el espacio de diseño.
Las opciones de un documento de esquema multiplaca se configuran en el panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño. Las opciones principales se configuran en la pestaña General del panel:
- Unidades (la región General) – seleccione las unidades de medida preferidas (mm o mils) para el documento.
- Ajustes de rejilla y ajuste a objetos (la región General) – establezca los valores necesarios para facilitar la navegación y la colocación de objetos.
- Opciones de página (la región Page Options) – configure Formatting and Size, así como Margins and Zones para el documento. Puede seleccionar un Template disponible, elegir un tamaño de hoja Standard o definir un tamaño Custom.

Configure las opciones del documento de esquema multiplaca en el panel Properties.
Obtenga más información sobre Configuración del documento de esquema multiplaca.
Para representar el diseño de un proyecto de PCB secundario en el esquema multiplaca, coloque un módulo mediante el comando Place » Module de los menús principales. En el panel Properties del módulo seleccionado, defina sus valores de Designator y Title, así como el proyecto de PCB de origen al que está vinculado el módulo. Utilice el botón
asociado al campo Source para especificar un proyecto local o de un espacio de trabajo, y el menú desplegable Assembly/Board para seleccionar la PCB deseada dentro de ese proyecto.

Configure el origen y otras propiedades de un módulo en el panel Properties.
Más información sobre Módulos.
Importe los datos de diseño de los proyectos referenciados por los módulos colocados mediante el comando Design » Import From Child Projects de los menús principales. Se abrirá el cuadro de diálogo Engineering Change Order con la lista de cambios (orden de cambio de ingeniería – ECO) necesarios para sincronizar los datos de conectividad de los esquemas multiplaca con los proyectos secundarios.
-
De forma predeterminada, todas las modificaciones están habilitadas para incluirse al ejecutar la ECO. Puede habilitar o deshabilitar las entradas de modificación según sea necesario.
-
Haga clic en el botón
para validar las modificaciones habilitadas para incluirse en la ECO. Los resultados de la validación aparecerán en la columna Check de la sección Status del cuadro de diálogo.
-
Cuando esté satisfecho con los cambios que se van a realizar, haga clic en el botón
para ejecutar la ECO y aplicar los cambios válidos que contiene. Los resultados de la ejecución aparecerán en la columna Done de la sección Status del cuadro de diálogo.
Al ejecutar la ECO, se crea una entrada de módulo para cada conector en el módulo correspondiente. Un componente de un proyecto de PCB secundario se considera un conector para un diseño multiplaca si tiene un parámetro denominado System, con Connector como valor del parámetro.
Más información sobre Actualizaciones del diseño del sistema.
Para representar la conectividad entre los proyectos secundarios, sus módulos se conectan entre sí en el esquema multiplaca mediante conexiones de distintos tipos. Seleccione el comando Direct Connection, Cable o Harness del menú principal Place y, a continuación, arrastre la línea de conexión entre los puntos de conexión de las entradas de módulo.

Coloque conexiones mediante los comandos del menú principal Place.

Se han conectado dos módulos colocando dos conexiones directas entre sus entradas de módulo.
Seleccione una línea de conexión para mostrar y editar las opciones pertinentes de la conexión en el panel Properties.
Más información sobre Tipos de conexión.
Para validar el diseño multiplaca, elija el comando Design » Run ERC de los menús principales. El diseño se comprobará según los ajustes configurados en la pestaña Error Reporting del cuadro de diálogo Project Options, al que se accede haciendo clic con el botón derecho en la entrada del proyecto en el panel Projects y seleccionando Project Options. Las infracciones detectadas se mostrarán en el panel Messages.
Más información sobre Captura del diseño lógico del sistema.
Creación del ensamblaje físico multiplaca
Una vez definida la estructura lógica del sistema en un esquema multiplaca, se crea el diseño físico multiplaca colocando las placas en un ensamblaje multiplaca.
Para añadir un nuevo documento de ensamblaje multiplaca a su diseño multiplaca, haga clic con el botón derecho en la entrada del proyecto en el panel Projects y seleccione el comando Add New to Project » Multi-board Assembly del menú contextual. El documento de ensamblaje multiplaca predeterminado aparecerá en el espacio de diseño.

El documento de ensamblaje multiplaca recién creado será el documento activo en el espacio de diseño.
Para cargar en el ensamblaje multiplaca la PCB referenciada por cada módulo del esquema multiplaca, utilice el comando Design » Update Assembly - <MultiBoardAssemblyDocumentName>.MbaDoc de los menús principales del editor de esquemas multiplaca (o el comando Design » Import Changes from <MultiBoardProjectName>.PrjMbd del editor de ensamblajes multiplaca). Se abrirá el cuadro de diálogo Engineering Change Order con la lista de cambios necesarios para añadir las PCB al ensamblaje. Haga clic en el botón
para validar las modificaciones habilitadas para incluirse en la ECO y, a continuación, haga clic en el botón
para ejecutar la ECO y aplicar los cambios válidos que contiene.
Al hacer clic en el botón
, las PCB se cargan en el editor de ensamblajes multiplaca y se puede cerrar el cuadro de diálogo Engineering Change Order.

Un ensamblaje multiplaca después de actualizarlo desde el esquema multiplaca.
Utilice los siguientes atajos para navegar por el ensamblaje multiplaca:
-
Ctrl+Mouse Wheel– acercar y alejar -
Right-Click, Hold&Drag– desplazar la vista -
Shift + Right-Click, Hold&Drag– girar
También puede utilizar el manipulador de la esquina inferior izquierda del espacio de diseño para orientar la vista a lo largo de los ejes principales haciendo clic en sus flechas y planos.
Para colocar y orientar una PCB en el ensamblaje, selecciónela y utilice las flechas y los arcos del manipulador de objeto que aparece para mover y girar la PCB en las direcciones correspondientes.
Para manipular dos PCB como un solo objeto, puede crear una relación de posición en un punto seleccionado de una superficie de cada una. Para establecer una relación de posición entre dos PCB:
- Seleccione el comando Tools » Mating de los menús principales.
- Sitúe el cursor sobre una superficie plana o cilíndrica de la PCB de destino y seleccione un punto de ella para definir el primer punto de la relación de posición.
- Sitúe el cursor sobre una superficie plana o cilíndrica de la PCB de origen y seleccione un punto de ella para definir el segundo punto de la relación de posición. La PCB de origen se moverá de modo que el punto de origen y el de destino coincidan, con sus planos de superficie y ejes perpendiculares alineados.
- Utilice el panel Properties o los atajos indicados en él para ajustar la configuración de la relación de posición.
Se pueden cargar modelos STEP en un ensamblaje multiplaca para completarlo con una envolvente, una carcasa u otras piezas mecánicas, por ejemplo. Utilice el comando Design » Insert STEP Part de los menús principales para añadir un modelo STEP.
Para comprobar si hay colisiones en un ensamblaje multiplaca (situaciones en las que dos objetos tienen superficies que se tocan o se intersecan), seleccione Tools » Check Collisions comando de los menús principales. Cualquier colisión se notificará en el panel Messages y se resaltará en el espacio de diseño. Tenga en cuenta que las superficies acopladas no se consideran en colisión.
Más información sobre Creación del ensamblaje físico de múltiples placas.
Creación de un plano de fabricación
Una vez completado el ensamblaje de múltiples placas, se puede crear un plano de fabricación y añadirle anotaciones. Los planos de fabricación de diseños de múltiples placas se crean en el editor Draftsman.
Para añadir un nuevo documento de ensamblaje de múltiples placas a su diseño de múltiples placas, haga clic con el botón derecho en la entrada del proyecto en el panel Projects y seleccione el comando Add New to Project » Draftsman Document del menú contextual. Se abrirá el cuadro de diálogo New Document, donde podrá seleccionar una plantilla de documento predefinida o la opción [Default], que crea un documento A4 en blanco. Tras hacer clic en OK, aparecerá un nuevo documento de Draftsman en el espacio de diseño.

El documento de Draftsman recién creado será el documento activo en el espacio de diseño.
En un plano de fabricación de un proyecto de diseño de múltiples placas, están disponibles las siguientes vistas:
-
Vista de múltiples placas – una composición gráfica automática de los contornos de las PCB y los modelos 3D que constituyen el ensamblaje de múltiples placas.
-
Vista de sección – un dibujo de perfil o de sección obtenido a partir de un punto de «corte» especificado en una vista de múltiples placas colocada.
-
Vista de detalle de placa – una vista flotante y ampliada de un área definida de una vista de múltiples placas.
-
Vista realista de placa – una representación 3D escalable del ensamblaje de múltiples placas actual.
Para colocar una vista de dibujo, seleccione un comando del tipo de vista deseado en el menú Place del editor Draftsman: Multiboard View o un comando del menú Additional View.

Coloque las vistas de dibujo mediante los comandos del menú principal Place.
- Tras seleccionar el comando Multiboard View o Board Realistic View, entrará en el modo de colocación, indicado por una cruz y la vista bajo el cursor. Haga clic en el espacio de diseño para colocar la vista.
- Tras seleccionar el comando Section View o un comando Board Detail View, defina la posición de la línea de corte o el área de la vista de detalle, respectivamente, en una vista de múltiples placas colocada.
Una vez colocada una vista de dibujo, sus propiedades se pueden configurar en el panel Properties al seleccionar la vista en el espacio de diseño.

Una hoja de un documento de Draftsman con varias vistas colocadas: dos vistas de múltiples placas, una vista de sección, una vista de detalle de placa y una vista realista de placa.
Para añadir detalles importantes a los planos, Draftsman proporciona herramientas adicionales de anotación, acotación y tablas:
-
Para indicar las longitudes, los tamaños y los ángulos de los contornos de los objetos o la distancia entre objetos, se pueden colocar cotas en las vistas de placa. Utilice el grupo de comandos de colocación de cotas del menú principal Place para seleccionar el tipo de cota deseado.
-
Para añadir información importante a sus planos, se proporcionan herramientas de anotación adicionales, como llamadas, indicadores de acabado superficial y listas automáticas de notas. Utilice los comandos del menú Place » Annotation de los menús principales para seleccionar la herramienta de anotación deseada.
-
Para añadir los datos de la lista de materiales (BOM) al plano de fabricación, se puede colocar una tabla de lista de materiales (Place » Bill Of Materials). La tabla extraerá y reflejará los datos de un documento de ActiveBOM añadido al proyecto de diseño de múltiples placas. También está disponible una tabla genérica que se puede rellenar con datos personalizados (Place » Table).
-
Para colocar elementos básicos de dibujo de forma libre en un documento de dibujo, también se proporciona una serie de herramientas de elementos gráficos. Utilice el grupo de comandos de colocación de objetos gráficos del menú principal Place para seleccionar el tipo de objeto deseado.
Más información sobre Creación de un plano de fabricación.
).


).
