Preparando Seu Projeto para Fabricação
Num relance
- Aprenda a adicionar e configurar saídas em um OutJob, incluindo a escolha de fontes de dados que permitam a reutilização em diferentes projetos.
- Entenda como associar saídas a contêineres ou tarefas de impressão e controlar onde os arquivos gerados são salvos.
- Siga o fluxo de trabalho de liberação do projeto, incluindo opções de liberação, validação quando configurada, geração de dados e revisão.
A fase final do ciclo de projeto é gerar os arquivos de saída necessários para fabricar o produto. Para isso, é necessário gerar diversos arquivos de saída em vários formatos. Como projetista, você pode configurar e gerar as saídas individualmente nos editores de esquemático e de PCB ou, como alternativa, adicionar todas as saídas necessárias a um OutputJob e gerá-las como parte do processo de liberação do projeto.

O objetivo final é fabricar o produto – por exemplo, fabricar e montar uma PCB.
Preparação de dados de fabricação com Output Jobs
Você pode configurar e gerar as saídas individualmente, diretamente pelos menus File e Reports dos editores correspondentes. Nesse caso, as saídas são geradas diretamente ao clicar em OK na caixa de diálogo de configurações correspondente e gravadas no local especificado no campo Output Path da guia Options da caixa de diálogo Project Options.
No entanto, os arquivos Output Job simplificam a preparação das saídas dos seus projetos e sua posterior geração por meio do processo de liberação de projetos de alta integridade. Um Output Job, ou simplesmente “OutJob”, é essencialmente um conjunto pré-configurado de saídas que armazena as configurações dessas saídas e define onde os arquivos gerados serão gravados.
Para adicionar um novo OutJob ao seu projeto, clique com o botão direito do mouse na entrada do projeto no painel Projects e selecione o comando Add New to Project » Output Job File no menu de contexto. Um OutJob padrão será aberto na área de trabalho do projeto.

Um OutJob recém-criado será o documento ativo na área de trabalho do projeto.
Diversos tipos de saída para diferentes finalidades podem ser adicionados e configurados usando o lado esquerdo do OutJob. As saídas são agrupadas em categorias funcionais, como saídas de montagem, saídas de fabricação e saídas de relatórios.
Adicione uma nova saída do tipo necessário clicando no texto Add New <Type> Output correspondente na parte inferior de uma categoria e escolhendo o tipo de saída desejado no menu pop-up. A entrada de cada tipo de saída oferece um submenu no qual você pode especificar a fonte de dados, ou seja, quais documentos de origem serão usados quando a saída for gerada. É possível adicionar qualquer quantidade de saídas.
Para determinados tipos de saída, há opções disponíveis para configurar uma saída adicionada clicando com o botão direito do mouse sobre ela na lista e selecionando o comando Configure no menu de contexto. A caixa de diálogo de configuração correspondente será aberta para definir as opções da saída. Por exemplo, a caixa de diálogo Gerber X2 Setup será aberta para uma saída Gerber X2 Setup.

Configure uma saída conforme necessário na caixa de diálogo de configuração correspondente.
Para definir onde e em qual formato uma saída será gerada, são usados contêineres de saída e trabalhos de impressão. As saídas podem ser gravadas, quando aplicável, em três tipos de contêineres de saída – PDF, vídeo ou estrutura de pastas (um formato específico de arquivo de saída, como um arquivo Gerber). Algumas saídas também podem ser enviadas diretamente a um dispositivo de impressão como cópia impressa, adicionando e configurando um trabalho de impressão.
Um novo OutJob contém um contêiner de saída de cada tipo e um trabalho de impressão para a impressora padrão. Suas entradas são exibidas no lado direito do OutJob. Se necessário, um novo contêiner de saída ou trabalho de impressão pode ser adicionado clicando no controle Add New Output Container e selecionando o tipo de contêiner desejado ou clicando no controle Add New Print Job e selecionando a impressora desejada, respectivamente.

Adicione novos contêineres de saída e/ou trabalhos de impressão conforme necessário.
Para especificar quais saídas serão geradas usando cada contêiner de saída ou trabalho de impressão, selecione um contêiner ou trabalho e marque a opção Enabled para cada saída desejada na lista de saídas. Uma vez habilitada, uma linha verde conectará a saída ao contêiner de saída ou trabalho de impressão selecionado. As saídas podem ser associadas a contêineres de saída ou trabalhos de impressão individuais ou compartilhados.

Associe as saídas adicionadas aos contêineres de saída e trabalhos de impressão correspondentes usando as opções Enabled.
Para configurar um contêiner de saída ou trabalho de impressão, selecione sua entrada e clique no controle Change. A caixa de diálogo correspondente será aberta – por exemplo, ao selecionar um contêiner de saída de estrutura de pastas, será aberta a caixa de diálogo Folder Structure settings, na qual você poderá configurar o local de saída dos arquivos a serem gerados e outras opções relacionadas à geração de arquivos.

Defina as configurações de um contêiner de saída ou trabalho de impressão na caixa de diálogo correspondente.
As saídas configuradas em um OutJob podem ser geradas diretamente no próprio OutJob ou, para um projeto de PCB, como parte do processo de liberação do projeto de alta integridade. Para gerar as saídas associadas a um contêiner de saída ou trabalho de impressão diretamente no OutJob, selecione o contêiner ou trabalho e clique no controle Generate content ou Print, respectivamente.

Você pode gerar ou imprimir saídas diretamente no OutJob.
Liberação do projeto da placa
Com o processo de liberação do projeto da placa, você pode gerar simultaneamente todos os dados de fabricação configurados nos arquivos OutJob do seu projeto de PCB. Esse processo oferece várias vantagens em relação à geração de saídas individualmente ou diretamente nos OutJobs, incluindo a capacidade de validar o projeto como parte integrante do processo de liberação e de evitar intervenções manuais durante esse processo. Além disso, ao liberar o projeto para o Workspace conectado, há uma integração estreita com o controle de versão do Workspace.
Para iniciar a liberação de um projeto, clique com o botão direito do mouse na entrada correspondente no painel Projects e selecione o comando Project Releaser no menu de contexto. A visualização Release será aberta em uma guia separada.

Acesse a visualização Release – a interface de usuário do Project Releaser.
O processo de liberação é um fluxo dividido em etapas, com as entradas no lado esquerdo da visualização Release indicando em qual etapa você está.
Na etapa inicial do processo de liberação, você pode clicar no botão Options no canto inferior esquerdo da visualização para acessar a caixa de diálogo Project Release Options e configurar as opções do processo de liberação conforme necessário. As opções incluem a seleção do destino da liberação (Workspace, pasta ou arquivo zip) e a atribuição de OutJobs.

Configure as opções de liberação na caixa de diálogo Project Release Options.
Dependendo do destino de liberação selecionado, as etapas do processo de liberação variam um pouco. Uma liberação para um Workspace conectado é mostrada abaixo como exemplo.
|
Na etapa Configure Server Release, você pode especificar os tipos de dados que deseja gerar: dados de origem (um instantâneo do projeto de origem, sempre incluído na liberação), dados de fabricação e dados de montagem. A quantidade de conjuntos de dados de montagem corresponderá ao projeto base (sem variações) e a todas as variantes de projeto detectadas. Quando estiver pronto, clique no botão Prepare no canto inferior direito da visualização para prosseguir. Se algum problema for encontrado, serão oferecidas soluções para resolvê-lo. A etapa Validate Project é executada automaticamente quando um ou mais relatórios de validação, como um relatório de verificação de regras de projeto, são detectados nos arquivos OutJob atribuídos, e as saídas de validação associadas são executadas. A liberação falhará se alguma verificação de validação não for concluída com sucesso. A etapa Generate Data é executada automaticamente quando a etapa anterior é concluída sem problemas. Nessa etapa, todas as outras saídas definidas nos arquivos OutJob atribuídos são executadas para gerar os dados a serem liberados. Com todas as verificações de validação aprovadas e os dados de saída gerados, a etapa Review Data permite revisar os dados gerados. Prossiga com a liberação clicando no botão Release no canto inferior direito da visualização e confirmando a liberação na caixa de diálogo exibida. Após a confirmação da liberação na etapa anterior, a etapa Upload Data é iniciada automaticamente. Ela apresenta o progresso do upload dos dados. A etapa final Execution Report do processo fornece um resumo da liberação. Com o projeto liberado, você pode fechar a visualização Release clicando no botão Close no canto inferior direito da visualização. |






