Inspecionando os dados de fabricação com o Editor CAM
Num relance
- Aprenda a selecionar, executar, repetir e cancelar comandos no editor CAM.
- Entenda como os modos CAM e NC exibem de forma diferente as imagens de fabricação, os pontos de furação e os percursos de fresagem.
- Descubra como gerenciar a visibilidade das camadas, selecionar a camada atual e acessar os comandos de camada pelo painel CAMtastic.
O Editor CAMtastic (CAM) do Altium Designer oferece uma variedade de ferramentas, sendo as mais básicas destinadas à visualização e edição de dados CAM. Após a importação dos arquivos de imagem e de furação, o Editor CAM pode receber instruções que determinam os tipos de camada e o empilhamento, permitindo extrair uma netlist e compará-la com uma netlist IPC gerada pelo software original de projeto de PCB. Essas netlists abrangem não apenas componentes de furo passante, mas também vias cegas e enterradas. O Editor CAM também oferece ferramentas de verificação de regras de projeto, painelização e roteamento NC (além de fresagem).
Fundamentos das ações CAM
O ambiente do Editor CAM utiliza alguns métodos para executar ações e procedimentos que são ligeiramente diferentes daqueles aos quais você pode estar acostumado.
Ação antes da seleção
A maneira como as ações são executadas no Editor CAM pode parecer invertida para novos usuários acostumados a selecionar objetos before informar ao programa o que fazer com eles. Assim como outras ferramentas CAM, o Editor CAM inverte esse processo: primeiro, você escolhe a ação; em seguida, seleciona os objetos sobre os quais deseja atuar e, por fim, dá um comando de execução.
Se essa não é a maneira como você está acostumado a trabalhar, algumas dicas podem ajudar até você se adaptar. Primeiro, observe o cursor. Quando ele aparece como uma mira sobre a área de trabalho do projeto, isso significa que não está no modo de seleção (nesse modo, o cursor aparece como uma caixa quadrada de seleção). O fato de todos os botões de seleção estarem desabilitados pode lembrar você de que ainda não escolheu uma ação; pelo menos não uma que exija seleções gerais. A barra de status, localizada na parte inferior da janela principal de edição, é particularmente útil durante processos de várias etapas, quando você está se perguntando por que nada está acontecendo; ela informa o que o Editor CAM está aguardando que você faça.
Execução com o botão direito
Primeiro, você escolhe um comando e, em seguida, seleciona um conjunto de objetos. Depois disso, o Editor CAM aguarda um comando de execução. Isso permite que você monte cuidadosamente sua seleção em várias camadas e grupos de objetos. A maneira básica de enviar o comando de execução é clicar com o botão direito. As instruções na Status Bar indicarão quando o botão direito pode ser usado dessa forma. Você também pode usar o atalho de teclado Shift+F9 para executar a função atual depois que todos os objetos necessários para a função tiverem sido selecionados.
Você pode perceber que, após executar uma função, o cursor não retorna ao estado inativo. Em vez disso, a caixa de seleção permanece, e a barra de status solicita que você comece a selecionar novamente. Isso acontece quando a opção Auto Repeat Functions está habilitada na página CAM Editor - General da caixa de diálogo Preferences.
Às vezes, o botão direito do mouse pode ser usado para cancelar processos em andamento. Isso funciona quando você ainda não concluiu uma etapa obrigatória, como selecionar objetos. A tecla Esc, porém, é uma opção mais segura para cancelamentos em geral.
Modos de edição
O Editor CAM oferece dois modos de edição: CAM e NC (roteamento). Os modos são habilitados pelos respectivos comandos CAM Editor e NC Editor, disponíveis ao selecionar View » CAM Editor ou View » NC Editor no menu principal. Como alternativa, você pode definir o modo de edição diretamente na lista suspensa disponível no painel CAMtastic . Essencialmente, esses modos diferem na maneira como os dados são exibidos. O modo CAM Editor mostra as imagens exatamente como serão desenhadas ou expostas no filme fotográfico que será usado na fabricação da PCB. O modo NC Editor adiciona marcadores aos furos e aos percursos de roteamento.
Um percurso de roteamento exibido no modo NC Editor.
O CAM Editor estará sempre em um desses dois modos de edição. No modo CAM Editor, as ferramentas de roteamento ficam desabilitadas nos menus. Da mesma forma, quando o modo NC Editor está ativo, as ferramentas normais de edição CAM ficam desabilitadas. Quando o modo CAM Editor está ativo, o painel CAMtastic oferece acesso rápido aos DCodes definidos na lista de aberturas por meio de uma lista suspensa. Quando o modo NC Editor está ativo, essa lista suspensa mostra, em vez disso, o conjunto de ferramentas para furação, roteamento e fresagem. Acima de tudo, a área de projeto corresponde ao modo de edição atual. O modo NC Editor indica os pontos de furação e os percursos de roteamento com marcadores especiais: cada ponto de furação é marcado com um X, enquanto os percursos de roteamento contêm pontos de mergulho e retração e, quando necessário, também marcadores de direção. Esses marcadores de instrução ficam invisíveis ao trabalhar no modo CAM Editor.
O painel CAMtastic
O painel, disponível sempre que um documento CAM está ativo, contém as principais informações desse documento, incluindo as camadas, o Dcode ou a ferramenta atual, as configurações de grade/unidade e a localização absoluta do cursor na área de projeto. Você também pode alternar o foco entre as regiões Info, DRC, Nets e Steps do painel para acessar outras informações específicas do projeto.
A região Layers mostra todas as camadas criadas/importadas e seu status de visibilidade. A camada atual terá um X branco sobre sua amostra de cor associada e também será indicada na parte superior da região. Você pode clicar duas vezes no nome de outra camada para torná-la a camada atual.
Quando houver camadas, clicar com o botão direito em qualquer lugar dessa região oferece acesso rápido aos comandos de camada, incluindo as opções de bloquear, renomear ou adicionar camadas. Se você criou um novo documento e deseja começar a adicionar camadas, use o comando Edit » Layers » Add para adicionar a primeira camada.
Você pode destacar qualquer camada nessa lista e usar as teclas Up Arrow e Down Arrow do teclado para percorrer os dados CAM no modo de camada única. A tecla Right Arrow tornará todas as camadas visíveis, enquanto a tecla Left Arrow isolará a camada destacada. É possível selecionar várias camadas usando os recursos padrão Shift+Click e Ctrl+Click, permitindo mostrar, ocultar ou excluir várias camadas de uma só vez. Você pode usar as teclas +/- e * do teclado numérico para percorrer todas as camadas visíveis ou apenas as camadas de sinal/plano, respectivamente.
As camadas podem ser excluídas do painel, mas essa ação é irreversível. O comando Undo no menu Edit não restaurará as camadas excluídas.
Você pode alternar entre o painel CAMtastic e o documento CAM ativo usando o atalho de teclado Shift+F5. A tecla F4 alternará o estado de visibilidade de todos os painéis flutuantes.
Conteúdo e uso do painel CAMtastic
Recursos do painel
A lista suspensa na parte superior do painel permite alternar rapidamente entre os modos Editor CAM e Editor NC. A seção logo abaixo desse campo lista todas as camadas disponíveis no documento CAM atual (*.cam). As camadas são listadas na mesma ordem em que aparecem na caixa de diálogo Layers Table, disponível ao selecionar Tables » Layers no menu principal.
Para cada camada na lista, são apresentados o nome e o número, além de uma opção para controlar a visibilidade da camada (ativada ou desativada). Também há uma caixa de cor, que mostra a cor atualmente atribuída à camada. Clicar na cor abre a caixa de diálogo Change Layer Color , que oferece uma variedade de cores para escolher.
Na parte superior da lista de camadas, é exibido o nome da camada atual. A camada atual é aquela que será usada para posicionar novos objetos, como linhas, polilinhas e pontos de furação. A camada atual também é identificada por uma cruz branca na caixa de cor da respectiva entrada. Para tornar qualquer camada a camada atual, clique duas vezes em sua entrada na lista.
Clicar com o botão direito do mouse em uma única entrada de camada na lista abre um menu com os seguintes comandos relacionados às camadas:
- Type - use este comando para exibir o tipo atribuído à camada na caixa de diálogo Layers Table.
- ON - use para alternar a visibilidade da camada. Quando a camada estiver ativada (ou seja, visível no espaço de projeto), um símbolo de marca de seleção aparecerá à esquerda do comando e a opção de visibilidade correspondente à camada será habilitada.
- Current - use para tornar a camada selecionada a camada atual. Um símbolo de marca de seleção aparecerá à esquerda do comando, o nome da camada aparecerá no campo Current Layer (na parte superior da lista de camadas) e uma cruz branca aparecerá na caixa de cor associada à camada.
- Lock / Lock Selected - use para bloquear as camadas selecionadas, impedindo que qualquer desenho seja feito nelas. Quando habilitado, um símbolo de marca de seleção aparecerá à esquerda do comando.
- RESCan / RESCan Selected - use para comparar as datas dos dados da camada selecionada (Gerber/ODB ++ Feature) existentes no documento CAM ativo com as dos últimos dados gerados a partir do mesmo documento PCB de origem. Se os últimos dados gerados forem mais recentes que os existentes, o comando Reload será habilitado.
- Reload / Reload Selected - use para gerar novamente os dados da camada selecionada cujas alterações foram detectadas pelo processo Rescan . Todas as alterações na camada serão incorporadas ao documento CAM ativo para sincronizá-lo novamente com o documento PCB de origem.
- All On - use para tornar todas as camadas visíveis (ativadas) no espaço de projeto.
- All Off - use para tornar todas as camadas invisíveis (desativadas) no espaço de projeto.
- Isolate - use para tornar todas as camadas invisíveis (desativadas) no espaço de projeto, com exceção da camada escolhida (ativada).
- Scroll Up - use para percorrer para cima cada camada da lista, começando pela camada atualmente selecionada. À medida que cada camada é selecionada, ela se torna a camada atual e todas as demais ficam invisíveis no espaço de projeto.
- Scroll Down - use para percorrer para baixo cada camada da lista, começando pela camada atualmente selecionada. À medida que cada camada é selecionada, ela se torna a camada atual e todas as demais ficam invisíveis no espaço de projeto.
- Compare - use para abrir a caixa de diálogo Compare Layers, na qual você pode comparar duas camadas, alterar a tolerância das camadas e modificar a resolução da camada de mapeamento.
- Compress Layers - use para combinar em uma única camada as camadas que têm o mesmo tipo especificado na tabela de camadas. Isso se aplica apenas a camadas das quais deve haver somente uma por projeto (por exemplo, superior, inferior, máscara, serigrafia, furação superior, furação inferior).
- Rename - use para renomear a camada atualmente selecionada. Após executar o comando, a caixa de diálogo Enter Value será exibida. Digite um novo nome para a camada (somente em letras minúsculas) e clique em OK — o novo nome substituirá o antigo.
-
Add Layer - use para criar uma nova camada e adicioná-la à lista. Após executar o comando, a caixa de diálogo Enter Value será exibida. Insira um nome para a nova camada (somente em letras minúsculas) e clique em OK — a camada será adicionada ao final da lista.
Se várias camadas estiverem selecionadas na lista, a entrada Tipo no menu exibirá Seleção múltipla e os seguintes comandos ficarão indisponíveis: Ativar, Atual, Bloquear, Rolar para cima, Rolar para baixo e Adicionar camada. - Turn On / Turn On Selected - use para tornar todas as camadas selecionadas visíveis (ativadas) no espaço de projeto. Este comando só ficará disponível se pelo menos uma das camadas selecionadas estiver desativada.
- Turn Off / Turn Off Selected - use para tornar todas as camadas selecionadas invisíveis (desativadas) no espaço de projeto. Este comando só ficará disponível se pelo menos uma das camadas selecionadas estiver ativada.
- Lock / Lock Selected - use para bloquear as camadas selecionadas, impedindo que qualquer desenho seja feito nelas. Quando a camada estiver bloqueada, uma marca de seleção à direita do comando indicará esse estado. Para desbloquear, clique novamente nas camadas bloqueadas.
- Delete / Delete Selected - use para excluir as camadas selecionadas do documento CAM.
Guia Informações
A guia Info
A guia Info exibe informações após a execução de qualquer um dos comandos de consulta (Objeto, Grupo, Rede, Anel anular mínimo), disponíveis no menu Analysis .
Guia DRC
A aba DRC
A aba DRC lista as violações existentes após a execução de uma Verificação de Regras de Projeto (DRC) no documento atual. Quando há violações, é exibida uma pasta de nível superior para a verificação de projeto específica e, abaixo dela, subpastas para cada objeto com violação. Clicar em uma subpasta selecionará, ampliará e centralizará os objetos com violação na janela do editor de projeto.
Se o erro de DRC puder ser corrigido com o recurso de correção automática, você poderá clicar com o botão direito na subpasta do erro e selecionar Corrigir erro de DRC no menu de contexto.
Aba Nets
A aba Nets
A aba Nets exibe as redes incluídas no projeto após a extração da netlist por meio do comando Tools » Netlist » Extract. Para cada entrada, também é listado o comprimento total da rede. Clicar em uma entrada de rede selecionará, ampliará e centralizará todos os objetos associados a essa rede na janela do editor de projeto.
Aba Steps
A aba Steps
A aba Steps exibe os Steps ODB atualmente definidos para o documento. O nome do Step atual é exibido na parte superior da aba. Clicar duas vezes em uma entrada de Step o tornará o Step atual.
Clique com o botão direito em uma entrada de Step na aba para acessar um menu de contexto com os seguintes comandos:
- Current - use para tornar o Step escolhido o Step atual. Um símbolo de marca de seleção aparecerá à esquerda da entrada do comando.
- Delete - use para excluir o Step escolhido do documento de projeto. Não é possível excluir o Step atual nem um Step que tenha sido inserido em outro Step.
- Rename - use para renomear o Step escolhido. Após executar o comando, a caixa de diálogo Enter Value será exibida. Insira o novo nome do Step (somente em letras minúsculas) e clique em OK — o novo nome do Step substituirá todas as ocorrências do nome atual.
-
Add Insert - use para inserir um Step dentro de outro. A caixa de diálogo Add Insert to ODB Step será exibida. Use essa caixa de diálogo para selecionar o Step a ser inserido (na lista de Steps disponíveis) e definir a localização, o tamanho da matriz e as informações de orientação. Clicar em OK adicionará a inserção como um sub-Step do Step pai indicado na aba, usando o formato: n: NomeDoStep (Linhas, Colunas), em que [n] é o próximo número disponível atribuído ao Step inserido, começando em 1.
Na janela do editor de projeto, o Step inserido aparecerá como um conjunto de retângulos brancos vazios, cuja quantidade é determinada pelo tamanho da matriz escolhido na caixa de diálogo Add Insert to ODB Step. Também são exibidas cruzes brancas, uma por Step na matriz, com a cruz inferior esquerda localizada nas coordenadas do ponto de base escolhido, também definidas na caixa de diálogo. Essas cruzes definem onde o conteúdo de objetos do Step inserido será localizado caso você opte por explodir a matriz de Steps. O comando para explodir a matriz de Steps pode ser encontrado clicando com o botão direito na entrada do sub-Step na aba. O menu de contexto exibido também contém comandos para modificar e excluir a matriz de Steps inserida. - Add Step - use para criar um novo Step. A caixa de diálogo Enter Value será exibida. Insira um nome para o novo Step (somente em letras minúsculas) e clique em OK — o Step será adicionado ao final da lista e se tornará o Step atual.
-
Move Objects - use para mover objetos de um Step para outro. Este comando só estará disponível se o Step de origem da movimentação for o Step atual.
Após executar o comando, o cursor mudará para um pequeno quadrado e você será solicitado a selecionar os objetos a serem movidos. Posicione o cursor sobre objetos individuais e clique para selecioná-los ou use uma das várias ferramentas de seleção disponíveis.
Após concluir a seleção, clique com o botão direito para abrir a caixa de diálogo New Step for Objects. Selecione o Step para o qual deseja mover os objetos e clique em OK — os objetos serão removidos do Step atual e adicionados ao Step de destino. - Copy Objects - use para copiar objetos de um Step para outro. Este comando só estará disponível se o Step de origem da cópia for o Step atual. Este comando é semelhante ao comando Mover objetos, com a única diferença de que os objetos selecionados não são removidos do Step de origem, apenas copiados.
- Add Venting - use para adicionar um padrão de ventilação ao redor das PCBs panelizadas em um painel. Este comando só estará disponível se as PCBs tiverem sido panelizadas usando o comando Tools » Panelize PCB ou pelo carregamento de dados ODB++ que contenham um painel.
- Remove Venting - use para remover qualquer padrão de ventilação de uma PCB panelizada. Isso seria usado, por exemplo, se os contornos da PCB tivessem sido modificados após a adição da ventilação.
- Refresh Inserts - use para atualizar as inserções disponíveis de modo a refletir as alterações.
A região inferior do painel contém os seguintes campos:
- 1 - Dependendo de você estar usando o modo Editor CAM ou Editor NC, este controle permite selecionar o código D ou a ferramenta de furação atual, respectivamente.
- 2 - Este controle permite selecionar o modo atual de atração a objetos.
- 3 - Este controle permite alterar as unidades atuais do espaço de projeto. Selecione entre milímetros ou polegadas.
- 4 - Este campo do painel exibe as coordenadas X-Y da posição do cursor no espaço de projeto principal. Ele utiliza as unidades selecionadas no controle 3.
Informações adicionais sobre Steps
- Cada Step ODB definido no projeto contém a mesma lista de camadas. A diferença entre os Steps está nos objetos que eles contêm nessas camadas.
- É necessário definir dois ou mais Steps para o documento atual antes que um Step possa ser inserido em outro.
- Ao contrário de uma matriz normal de Step & Repeat, quando um Step é inserido em outro, a matriz resultante é composta inteiramente por elementos representados por contornos. O elemento inferior esquerdo não exibe os objetos do Step por completo. Se você clicar na entrada de nível superior do Step inserido (não na entrada abaixo do Step pai definido), os objetos contidos no Step inserido serão exibidos no local marcado pela cruz branca inferior esquerda. O Step pai e todos os outros elementos da matriz do Step inserido não serão exibidos.
-
A aba Steps é atualizada automaticamente sempre que você clica em OK na caixa de diálogo Steps Table, aberta ao selecionar Tables » Steps no menu principal.
O código D, o modo de atração a objetos e as unidades do espaço de projeto podem ser alterados durante o posicionamento de elementos de desenho (por exemplo, linhas, polilinhas, retângulos etc.). Por exemplo, você pode posicionar uma linha com segmentos desenhados usando diferentes códigos D, todos na mesma sessão de posicionamento. Você pode desenhar uma polilinha, alterar o código D durante seu posicionamento e, ao concluir o posicionamento, o código D atual será aplicado à polilinha inteira.
Notas
- Por padrão, as cores de desenho (Draw) e flash (Flash) atribuídas a uma camada são idênticas. Alterar a cor atribuída à camada no painel atualizará ambas as cores, Draw e Flash, na caixa de diálogo Layers Table. Se quiser alterar as cores Draw ou Flash individualmente, será necessário editar suas respectivas entradas na caixa de diálogo. Ao editar as cores por meio da caixa de diálogo, apenas a atribuição da cor Draw será refletida no painel.
- Selecione uma entrada na lista de camadas e pressione a tecla Left Arrow para desativar todas as camadas, exceto a selecionada. Selecione uma entrada na lista de camadas e pressione a tecla Right Arrow para ativar todas as camadas.
- Os comandos baseados em Rescan e Reload só ficarão disponíveis se a opção Reset auto-load options after generation estiver habilitada antes da geração inicial dos arquivos de saída Gerber/ODB++. Essa opção pode ser encontrada na caixa de diálogo Output Job Options, acessada pelo menu Tools quando o arquivo Output Job associado (*.OutJob) estiver ativo. Habilitar essa opção impede que os dados de saída sejam carregados em um novo documento CAM quando os dados forem gerados posteriormente a partir do documento PCB de origem.
- Após a extração da netlist das informações Gerber contidas no documento atual, as redes aparecem listadas na aba Nets do painel com nomes padrão. Esses nomes seguem o formato $Netn (em que n é o próximo número inteiro atribuído com base na ordem de extração). Se você tiver importado uma netlist no formato IPC-D-356, gerada a partir do documento PCB, poderá renomear as redes com os nomes mais significativos atribuídos no projeto original da PCB. Para isso, escolha Tools » Netlist » Rename Nets nos menus principais.
- Várias redes podem ser selecionadas na aba Nets — todas elas serão então selecionadas na janela do editor de projeto.
- Ao investigar erros de DRC, selecionar uma entrada na aba DRC ativará apenas as camadas nas quais estão os objetos que apresentam violações. Todas as outras camadas serão desativadas. Ao investigar redes, as camadas relevantes devem ser ativadas previamente; caso contrário, talvez você não veja nada.
