Acessando, Definindo e Gerenciando Opções do Projeto
Altium Essentials: Schematic Electrical Rules Validation
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

As abas General, Error Reporting e Options da caixa de diálogo Project Options
Resumo
Um projeto existente ou recém-criado está associado a um conjunto de configurações de opções específicas desse projeto. Elas são armazenadas no arquivo do projeto (*.PrjPcb, por exemplo) e variam dependendo do tipo de projeto. As configurações de opções são definidas na caixa de diálogo Project Options.
Acesso
A caixa de diálogo Project Options pode ser acessada de uma das seguintes maneiras:
- Clique com o botão direito na entrada do projeto no painel Projects e clique em Project Options no menu de contexto.
-
Clique no ícone
no painel Projects quando o projeto desejado estiver em foco no painel.
- Em qualquer editor, selecione Project » Project Options nos menus principais.
Abas da caixa de diálogo
Geral

A aba General da caixa de diálogo Project Options
A aba General da caixa de diálogo Project Options permite controlar a disponibilidade on-line e a sincronização de um projeto do Workspace.
Opções/Controles
Quando acessada para um projeto enquanto você está desconectado do respectivo Workspace, a única opção disponível é o botão Turn Off Synchronization.
Quando acessada para um projeto que não pertence a um Workspace, a aba General da caixa de diálogo Project Options exibirá apenas o botão Make Project Available Online. Clique no botão para abrir a caixa de diálogo Disponibilizar on-line, que adicionará seu projeto ao Workspace após a conclusão das etapas necessárias. Após a conclusão, todas as opções da aba da caixa de diálogo estarão disponíveis.
Geral
- Description - use este campo para fornecer uma descrição opcional do projeto, que será refletida no campo de descrição ao navegar pelo projeto na interface do Workspace no navegador.
Disponibilidade on-line e sincronização
-
Version Control - marcar esta caixa refletirá o modo atual de disponibilidade on-line. Habilite esta opção para armazenar este projeto sob controle de versão (VCS) no repositório de projetos Git Versioned Storage do Workspace ou desabilite-a para usar a sincronização simples. Habilitar o controle de versão formal permite que vários usuários trabalhem no projeto, o que significa que ele será compartilhado com todos os outros colaboradores conectados ao seu Workspace.
-
Migrate to Altium 365 Versioned Storage - habilite esta opção para migrar um projeto que usa um sistema VCS externo para o VCS nativo do Workspace do Altium 365. O projeto convertido, que manterá o histórico anterior de commits do VCS, poderá então se beneficiar dos recursos habilitados pelo VCS nativo do Workspace, como a linha do tempo do histórico baseada em eventos. Esta opção está disponível apenas para um projeto espelhado.
-
Server Folder - a pasta do Workspace na qual o projeto está localizado.
-
Enable Conflict Prevention Notifications - habilite esta opção para gerenciar o acesso de edição de arquivos, recebendo um alerta quando um membro da equipe estiver editando o mesmo documento de um projeto do Workspace, para evitar a possibilidade de conflitos de dados.
-
Turn Off Synchronization - clique neste botão para desativar a sincronização, garantindo que a cópia local do projeto não esteja mais vinculada àquela que está no Workspace. O projeto localizado no Workspace permanecerá inalterado.
Requisitos
-
Link Requirements – se o bloco do Portal de Requisitos não estiver vinculado ao projeto, clique neste botão para abrir a caixa de diálogo Link Requirements, na qual você poderá selecionar o bloco a ser vinculado ao projeto.
-
Linked Requirements – se o bloco do Portal de Requisitos estiver vinculado ao projeto, esta entrada mostrará o bloco vinculado Clique no link para alterar o mapeamento atual entre projeto e bloco. Clique no botão Unlink para remover o vínculo.
Consulte a página Requisitos em um projeto para saber mais.
Relatório de erros

A aba Error Reporting da caixa de diálogo Project Options (para um projeto de PCB)
A aba Error Reporting da caixa de diálogo Project Options permite definir os níveis de relatório para cada uma das possíveis violações elétricas e de desenho que podem existir nos documentos esquemáticos de origem ao validar o projeto. Quando o projeto é validado, essas configurações de violação são usadas em conjunto com as configurações da aba Matriz de conexões para verificar se há violações de conectividade nos documentos de origem.
Opções/Controles
Lista de violações
Esta lista apresenta todas as possíveis violações elétricas e de desenho que podem existir nos documentos de origem do projeto. As violações são agrupadas nas seguintes categorias:
PCB Design:
Multi-board Design:
Harness Design:
Cada tipo específico de violação é apresentado com os seguintes campos:
- Violation Type Description - uma breve descrição do tipo de violação.
-
Report Mode - use este campo para especificar o nível de gravidade associado à violação da verificação. Use a lista suspensa para escolher entre os seguintes níveis de relatório:
-
Menu do botão direito
Os seguintes comandos estão disponíveis no menu do botão direito:
- All Off - defina Report Mode para todos os tipos de violação como No Report.
- All Warning - defina Report Mode para todos os tipos de violação como Warning.
- All Error - defina Report Mode para todos os tipos de violação como Error.
- All Fatal - defina Report Mode para todos os tipos de violação como Fatal Error.
- Selected Off - defina Report Mode para todos os tipos de violação selecionados como No Report.
- Selected To Warning - defina Report Mode para todos os tipos de violação selecionados como Warning.
- Selected To Error - defina o Report Mode de todos os tipos de violação selecionados como Error.
- Selected To Fatal - defina o Report Mode de todos os tipos de violação selecionados como Fatal Error.
- Default - restaure as configurações padrão do Report Mode de todos os tipos de violação.
- Report Suppressed Violations in Messages Panel - habilite esta opção para exibir as violações no painel Messages, mesmo que tenham sido suprimidas por meio desta aba.
Opção adicional
- Set To Installation Defaults - clique para restaurar as opções da aba aos padrões de instalação.
Matriz de conexões

A aba Connection Matrix da caixa de diálogo Project Options
A aba Connection Matrix da caixa de diálogo Project Options apresenta uma matriz que fornece um mecanismo para estabelecer regras de conectividade entre pinos de componentes e identificadores de rede, como portas e entradas de folha. Ela define as condições lógicas ou elétricas que devem ser relatadas como avisos ou erros. Por exemplo, um pino de saída conectado a outro pino de saída normalmente seria considerado uma condição de erro, mas dois pinos passivos conectados não. Quando o projeto for validado, essas configurações de violação serão usadas (em conjunto com as configurações definidas na aba Relatório de erros) para verificar a existência de violações nos documentos de origem.
Opções/Controles
Matriz de conexões
A matriz apresenta todas as verificações possíveis de conexões elétricas entre combinações de pinos, portas e entradas de folha, além de verificar entidades não conectadas. A matriz é lida por linhas e colunas, e a cor do elemento na interseção entre a linha e a coluna especifica como o compilador responderá ao verificar essa condição específica.
Para alterar o modo de relatório de uma verificação de violação na matriz, clique no quadrado colorido na interseção da linha e da coluna de duas entidades. A cada clique, o modo avançará para o próximo nível de relatório. Os seguintes níveis são compatíveis:
- No Report
- Warning
- Error
- Fatal Error
Menu do botão direito
Os seguintes comandos estão disponíveis no menu de contexto acessado com o botão direito do mouse:
- All Off - defina todas as entradas da matriz como No Report.
- All Warning - defina todas as entradas da matriz como Warning.
- All Error - defina todas as entradas da matriz como Error.
- All Fatal - defina todas as entradas da matriz como Fatal Error.
- Default - restaure todas as entradas aos seus valores padrão.
Opção adicional
- Set To Installation Defaults - clique para restaurar as opções da aba aos padrões de instalação.
Geração de classes

A aba Class Generation da caixa de diálogo Project Options
A aba Class Generation da caixa de diálogo Project Options permite configurar e controlar a geração de classes. Classes são coleções lógicas de um determinado tipo de objeto de projeto. Por exemplo, um grupo de componentes relacionados pode ser reunido em sua própria classe de componentes, que pode então ser usada como base para criar uma regra específica. Esta aba fornece controles para determinar quais classes são geradas automaticamente e quais classes definidas pelo usuário são geradas quando os documentos esquemáticos de origem são sincronizados com o documento de projeto da PCB.
Opções/Controles
Classes geradas automaticamente
-
Generate Net Classes for Buses - marque esta opção para gerar automaticamente uma classe de redes para cada barramento do projeto. Os membros de uma classe serão as redes individuais que compõem o barramento (a partir do qual essa classe foi gerada).
-
Generate Net Classes for Components - marque esta opção para gerar automaticamente uma classe de redes para cada componente do projeto. Os membros de uma classe serão as redes associadas às quais os pinos do componente (a partir do qual essa classe foi gerada) estão conectados.
-
Generate Separate Net Classes for Bus Sections - marque esta opção para gerar automaticamente uma classe de redes separada para cada seção de barramento. Uma seção de barramento é criada ao especificar um barramento que, na verdade, é uma seção de um barramento maior, por exemplo,
D[15..8], do barramentoD[15..0]. -
Generate Net Classes for Named Signal Harnesses - habilite esta opção para gerar automaticamente uma classe de redes para cada chicote de sinais nomeado no projeto. Os membros de uma classe serão as redes associadas aos sinais reunidos pelo chicote de sinais nomeado (a partir do qual a classe foi gerada).
-
Sheet-Level Class Generation Grid - esta região permite controlar a geração automática de classes de componentes e/ou de redes no nível de cada folha esquemática. Todas as folhas esquemáticas de origem do projeto são listadas com as seguintes informações para cada uma:
- Sheet Name - o nome do documento esquemático.
- Full Path - o caminho absoluto para a pasta em que o documento está localizado.
-
Component Classes - marque esta opção para gerar uma classe de componentes para a folha.
- Generate Rooms - marque esta opção para gerar uma room para a classe de componentes.
-
Net Classes Scope - use este campo para determinar se uma classe de nets será gerada para a folha e, em caso afirmativo, o escopo da geração. A lista suspensa do campo oferece as seguintes opções:
- None - não gerar uma classe de nets para esta folha.
- Local Nets Only - gerar uma classe de nets para esta folha, mas contendo apenas nets membros locais à folha.
- All Nets - gerar uma classe de nets para esta folha que contenha todas as nets membros associadas à folha (as locais e as que se conectam a outros locais).
-
Structure Classes Generate Structure - marque esta opção para gerar uma classe de estrutura para a folha.
Uma classe de estrutura é um tipo especial de classe que pode conter, como membros, qualquer tipo de classe (classe de nets, classe de componentes etc.). Ao gerar automaticamente uma classe de estrutura a partir de cada folha esquemática do projeto que contenha componentes e/ou nets, durante a transferência do projeto para a PCB, a estrutura do projeto pode ser representada fielmente na PCB. As classes de estrutura não apenas permitem reproduzir a estrutura dos documentos esquemáticos no ambiente da PCB, para navegação avançada, mas também podem ser usadas em consultas lógicas, por exemplo, ao definir o escopo de regras de projeto ou ao aplicar filtros.
Classes definidas pelo usuário
- Generate Component Classes - marque esta opção para gerar classes de componentes definidas pelo usuário quando o projeto for transferido para a PCB. As classes de componentes são definidas manualmente no esquemático adicionando um parâmetro ClassName aos componentes desejados e definindo seu valor como o nome de classe desejado.
- Generate Rooms for Component Class - marque esta opção para gerar rooms com base nas classes de componentes definidas pelo usuário. Esses componentes precisam ter um parâmetro de componente cujo nome seja 'ClassName'.
- Generate Net Classes - marque esta opção para gerar classes de nets definidas pelo usuário quando o projeto for transferido para a PCB. As classes de nets são definidas manualmente no esquemático por meio da diretiva Net Class. Para tornar uma net membro de uma classe de nets, anexe uma diretiva Net Class ao fio ou barramento relevante (ou a uma blanket) e defina o valor de seu parâmetro ClassName como o nome de classe desejado.
► Saiba como criar uma classe de nets definida pelo usuário
► Saiba como criar uma classe de componentes definida pelo usuário
Opção adicional
- Set To Installation Defaults - clique para restaurar as opções da aba aos padrões da instalação.
Notas
-
Para gerar classes (automáticas e/ou definidas pelo usuário) ao transferir o projeto para a PCB, certifique-se de que as respectivas configurações do comparador estejam definidas como Find Differences na aba Comparador da caixa de diálogo Project Options, conforme a seguir:
- Classes de nets - defina o tipo de comparação Extra Net Classes (na categoria Differences Associated with Nets) como Find Differences.
- Classes de componentes - defina o tipo de comparação Extra Component Classes (na categoria Differences Associated with Components) como Find Differences.
-
Além disso, na aba Geração de ECO da caixa de diálogo Project Options , certifique-se de que as respectivas configurações de ECO estejam definidas como Generate Change Orders.
- Classes de nets - defina o tipo de modificação Add Net Classes (na categoria Modifications Associated with Nets) como Generate Change Orders.
- Classes de componentes - defina o tipo de modificação Add Component Classes (na categoria Modifications Associated with Components) como Generate Change Orders.
Comparador

A aba Comparator da caixa de diálogo Project Options
A aba Comparator da caixa de diálogo Project Options permite definir quais tipos de diferenças devem ser encontrados e quais devem ser ignorados ao comparar documentos. Para cada comparação possível, você pode escolher entre encontrar ou ignorar diferenças usando a lista suspensa correspondente na coluna Mode. Você pode configurar a busca por diferenças em componentes, nets, parâmetros e objetos físicos, conforme necessário.
Opções/Controles
Esta caixa de diálogo é dividida em duas regiões principais:
- A região superior, intitulada Comparison Type Description/Mode, lista a descrição e o modo de comparação de cada tipo de comparação disponível.
- A região inferior, intitulada Object Matching Criteria, é usada para definir os critérios de correspondência para Net, Net Class, Component Class, Differential Pair e Structure Class.
Descrição/Modo do tipo de comparação
- Comparison Type Description - esta região lista as descrições de cada tipo de comparação disponível no projeto. Use a barra de rolagem na extremidade direita para navegar até Differences Associated with Components, Differences Associated with Nets, Differences Associated with Parameters, Differences Associated with Physical e Differences Associated with Structure Classes para visualizar/alterar os modos de comparação em cada área.
-
Mode - clique em uma entrada para alterar o modo de comparação usando a lista suspensa:
-
Find Differences- selecione esta opção para encontrar diferenças nesse tipo de comparação. -
Ignore Differences- selecione esta opção para ignorar quaisquer diferenças nesse tipo de comparação (nenhuma comparação será realizada para esse tipo de comparação).
-
Critérios de correspondência de objetos
- Object Type - lista de tipos de objetos, como Net, Net Class, Component Class, Differential Pair e Structure Class.
- Min Match % - insira o valor percentual mínimo de correspondência desejado ou clique no lado direito da coluna e, em seguida, use as teclas de seta para cima e para baixo para aumentar ou diminuir o valor.
- Min Matched Members - insira o número mínimo desejado de membros correspondentes ou clique no lado direito da coluna e, em seguida, use as teclas de seta para cima e para baixo para aumentar ou diminuir o valor.
- Use Name Matching - clique na entrada ou use a lista suspensa para selecionar After member matching ou Never.
- Show Manual Matching Dialog - clique na entrada ou use a lista suspensa para selecionar For unmatched objects ou Never.
Opções adicionais
- Ignore Rules Defined in PCB Only - marque esta opção para ignorar as regras definidas apenas na PCB dentro do projeto. Por exemplo, ao executar uma ordem de alteração de engenharia, as alterações podem ser aplicadas do esquemático à PCB e, se esta opção estiver habilitada, as regras existentes apenas na PCB serão ignoradas. Se não houver regras correspondentes nas folhas de esquemático do mesmo projeto, o comparador não tentará adicionar novas regras.
- Set To Installation Defaults - clique para restaurar as opções da aba aos padrões de instalação.
Geração de ECO

A aba ECO Generation da caixa de diálogo Project Options
A aba ECO Generation da caixa de diálogo Project Options permite configurar quais tipos de modificação podem ser incluídos ao gerar uma ordem de alteração de engenharia (ECO) com base nas diferenças encontradas pelo Comparador.
Opções/Controles
Lista de tipos de modificação
Esta lista apresenta todas as modificações possíveis que podem ser feitas por meio de uma ordem de alteração de engenharia ao sincronizar os documentos esquemáticos de origem com o documento de projeto da PCB. As entradas da lista incluem categorias de tipos de modificação associados a Components, Nets, Parameters, Structure Classes, etc.
Cada tipo específico de modificação inclui os seguintes campos:
- Modification Type Description – uma breve descrição do tipo de modificação (a ação a ser executada pelo Sincronizador).
-
Mode – use este campo para controlar se o tipo de modificação será incluído ou não em qualquer ECO gerada. Use a lista suspensa para escolher entre as seguintes opções:
- Generate Change Orders - incluir o tipo de modificação em uma ECO gerada.
- Ignore Differences - excluir o tipo de modificação de uma ECO gerada.
Menu do botão direito
O seguinte comando está disponível no menu de contexto acessado com o botão direito:
- Report – use este comando para gerar um relatório dos modos de modificação configurados atualmente. A caixa de diálogo Report Preview será exibida com o relatório já carregado. Use essa caixa de diálogo para inspecionar o relatório usando os diversos controles de página/zoom antes de exportá-lo para um arquivo ou imprimi-lo.
Opções adicionais
- Push Component Designator Changes to Annotation File (if any) – marque para incluir as alterações dos designadores de componentes no arquivo de anotação.
- Set To Installation Defaults – clique para restaurar as opções da aba aos padrões de instalação.
Opções

A aba Options da caixa de diálogo Project Options
A aba Options da caixa de diálogo Project Options permite especificar o caminho de saída e as opções relacionadas às saídas geradas para o projeto. Você também pode especificar diversas opções de geração de netlist e o escopo dos identificadores de rede.
Opções/Controles
-
Output Path – o caminho de saída padrão para a geração de arquivos de saída do projeto atual (
*.PrjPcb). - ECO Log Path – o caminho de saída padrão para os arquivos de log de ECO.
-
Schematic Template Location – use este campo para especificar um diretório de onde obter os arquivos de modelo de esquemático (
*.SchDot,*.SchDoc) para o projeto.
Opções de saída
- Open outputs after compile – habilite para abrir os arquivos gerados após a compilação do projeto. Para um projeto de pacote de biblioteca integrada, habilite a opção para instalar a biblioteca integrada após compilar o projeto de pacote.
-
Timestamp folder – habilite para criar uma pasta com data e hora para a saída gerada, como um relatório de BOM (Reports » Bill of Materials). O nome da pasta segue o formato
<FolderName> Date Time, em que<FolderName>é especificado no campo Output Path eDateeTimeseguem o mesmo formato das configurações do seu sistema. - Archive project document – habilite para arquivar o documento do projeto. Por exemplo, ao gerar saídas de fabricação de um projeto de PCB (File » Fabrication Outputs e File » Assembly Outputs), a pasta de saída de destino incluirá uma cópia do documento de PCB relacionado.
- Use separate folder for each output type – habilite para criar pastas separadas para cada tipo de saída gerado para o projeto. Essa estrutura de pastas também será representada no painel Projects.
Opções de netlist
- Allow Ports to Name Nets – habilite para nomear uma rede usando a propriedade Name de uma porta conectada por fio, em vez de usar um nome de rede padrão gerado pelo sistema.
- Allow Sheet Entries to Name Nets – habilite para nomear uma rede usando o nome da entrada de folha, em vez de usar um nome de rede padrão gerado pelo sistema.
- Allow Single Pin Nets – habilite para permitir a existência de redes que contenham apenas um único pino.
-
Append Sheet Numbers to Local Net – habilite para acrescentar o valor do parâmetro Sheet Number de um documento esquemático (um parâmetro no nível do documento) às redes locais dessa folha. Uma rede local é uma rede que não sai da folha. Para uma rede que sai da folha (e, portanto, não é local), esta opção não se aplica.
- Higher Level Names Take Priority – habilite para que os rótulos de rede usados nas folhas superiores da hierarquia deem nome às redes nas folhas inferiores.
-
Power Port Names Take Priority – o software permite tornar local uma rede de alimentação global conectando uma porta de alimentação a uma porta normal por meio de um fio. Isso faz com que todos os pinos dessa folha conectados àquela porta de alimentação pertençam a uma rede separada. Habilitar esta opção força a nomeação da rede usando o nome da rede atribuído à porta de alimentação.
Escopo dos identificadores de rede
Os projetos com várias folhas são definidos no nível elétrico (ou de conectividade) por identificadores de rede. Os identificadores de rede (rótulos de rede, portas, entradas de folha, portas de alimentação e pinos ocultos) criam conexões lógicas entre pontos da mesma rede. Isso pode ocorrer dentro de uma folha ou entre várias folhas. As conexões físicas existem quando um objeto está ligado diretamente a outro objeto elétrico por um fio. As conexões lógicas são criadas quando dois identificadores de rede do mesmo tipo (por exemplo, dois rótulos de rede) têm a mesma propriedade Net .
Quando o modelo de conectividade do projeto é criado, você deve definir como deseja que os identificadores de rede se conectem entre si — isso é conhecido como configurar o Net Identifier Scope. Há basicamente duas maneiras de conectar folhas em um projeto com várias folhas: horizontalmente, diretamente de uma folha para outra, e assim por diante; ou verticalmente, de uma subfolha para o símbolo de folha que a representa na folha superior. Na conectividade horizontal, as conexões são feitas de porta a porta (também é possível conectar rótulo de rede a rótulo de rede). Na conectividade vertical, as conexões são feitas de entrada de folha a porta.
Use a lista suspensa para escolher entre os seguintes escopos:
-
Automatic (Based on project contents) – este modo seleciona automaticamente qual modo de identificador de rede usar com base nos seguintes critérios: se houver entradas de folha na folha de nível superior, será usado Hierarchical; se não houver entradas de folha, mas houver portas, será usado Flat; se não houver entradas de folha nem portas, será usado Global.
- Flat (Only ports global) – as portas se conectam globalmente entre todas as folhas do projeto. Com esta opção, os rótulos de rede são locais a cada folha, ou seja, não se conectam entre folhas. Todas as portas com o mesmo nome serão conectadas em todas as folhas. Esta opção pode ser usada em projetos com várias folhas sem hierarquia. Não é recomendada para projetos grandes, pois pode ser difícil rastrear uma rede pelas folhas.
- Hierarchical (Sheet entry <-> port connections, power ports global) – conecta verticalmente uma porta à entrada de folha correspondente. Esta opção estabelece conexões entre folhas somente por meio das entradas dos símbolos de folha e das portas correspondentes nas subfolhas. Ela usa portas nas folhas para levar redes ou barramentos até as entradas dos símbolos de folha correspondentes na folha superior. Portas sem uma entrada de folha correspondente não serão conectadas, mesmo que exista uma porta com o mesmo nome em outra folha. Os rótulos de rede são locais a cada folha, ou seja, não se conectam entre folhas. No entanto, as portas de alimentação são globais — todas as portas de alimentação com o mesmo nome são conectadas em todo o projeto. Esta opção pode ser usada para criar projetos com qualquer profundidade ou hierarquia e permite rastrear uma rede por todo o projeto no esquemático impresso.
- Strict Hierarchical (Sheet entry <-> port connections, power ports local) – este modo de conectividade se comporta da mesma forma que o modo Hierarchical , com a diferença de que as portas de alimentação permanecem locais a cada folha, ou seja, não se conectam a portas de alimentação com o mesmo nome em outras folhas.
- Global (Netlabels and ports global) – as portas e os rótulos de rede se conectam entre todas as folhas do projeto. Com esta opção, todas as redes com o mesmo rótulo de rede serão conectadas entre si em todas as folhas. Além disso, todas as portas com o mesmo nome serão conectadas em todas as folhas. Se uma rede conectada a uma porta também tiver um rótulo de rede, seu nome será o do rótulo de rede. Esta opção também pode ser usada em projetos com várias folhas sem hierarquia; no entanto, é difícil rastrear as conexões de uma folha para outra, pois nem sempre é fácil localizar visualmente os nomes das redes no esquemático.
Permitir a troca de pinos usando estes métodos
No editor de PCB, as trocas de pinos, pares diferenciais e partes são realizadas trocando as redes nos pads dos componentes e no cobre correspondente. Quando as alterações são incorporadas aos esquemáticos, há duas maneiras de tratar uma troca de pinos:
-
Adding / Removing Net-Labels – habilite para permitir a troca de pinos em um símbolo de componente. A troca no esquemático por meio da troca de rótulos de rede só pode ser realizada se a conectividade for estabelecida pelos rótulos de rede, ou seja, se os pinos não estiverem conectados diretamente entre si por fios.
-
Changing Schematic Pins – habilite para permitir a troca de rótulos de rede nos fios ligados aos pinos de um componente. A troca de pinos será a única opção disponível quando as redes estiverem fisicamente conectadas a um componente por fios. Esse método pode ser usado em componentes simples (como um arranjo de resistores) ou quando não houver alternativa devido à estrutura do projeto esquemático.
Geral
- Automatic Sheet Numbering – habilite esta opção para numerar automaticamente as folhas de esquemático deste projeto. Isso permite controlar a designação das folhas e armazená-las como parâmetros nos respectivos documentos de esquemático.
-
Automatic Cross References – habilite esta opção para adicionar automaticamente informações de referência cruzada de portas, conectores entre folhas e entradas de folha a todos os documentos de esquemático de origem do projeto ativo. Esse recurso ajuda a rastrear a conectividade das redes em um projeto não hierárquico.
- New Indexing of Sheet Symbols – habilite para usar qualquer dígito ou número como o primeiro ou o último índice de um símbolo de folha repetido, incluindo 0. Números negativos não são permitidos. O último índice deve ser sempre maior que o primeiro.
Referências cruzadas
-
Sheet Style – escolha um dos seguintes estilos de folha para as referências cruzadas de portas em uma folha de esquemático ou em folhas de esquemático de um projeto.
-
None– nenhum estilo de folha é adicionado à string de referência cruzada de todas as portas. -
Name– os nomes das folhas às quais as portas estão vinculadas são adicionados às strings de referência cruzada. -
Number– os números das folhas às quais as portas estão vinculadas são adicionados às strings de referência cruzada.
-
-
Location Style – escolha um dos seguintes estilos de localização para as referências cruzadas de portas em uma folha de esquemático ou em folhas de esquemático de um projeto.
-
None– nenhum estilo de localização é adicionado à string de referência cruzada de todas as portas. -
Zone– a numeração das zonas de referência (as zonas ficam nas bordas das folhas) é adicionada às strings de referência cruzada de todas as portas associadas aos objetos pai, como a localização dos símbolos de folha. -
Location X,Y– as localizações das portas são exibidas entre colchetes nas strings de referência cruzada de todas as portas associadas aos objetos pai, como a localização dos símbolos de folha.
-
- Follow Cross References settings in Preferences – quando esta opção está habilitada, os valores das opções Sheet Style e Location Style são herdados das opções na região Port Cross References da página Esquemático – Geral da caixa de diálogo Preferences.
-
Display Cross References for:
-
Ports – use a lista suspensa para selecionar o modo de exibição das referências cruzadas das portas.
-
Disabled– nenhuma referência cruzada é adicionada às portas. -
Only Related Sheet Entry– exibe a referência cruzada à entrada de folha associada na folha de esquemático pai. -
Only Related Ports– exibe referências cruzadas às portas associadas. -
Sheet Entry & Ports– exibe referências cruzadas tanto à entrada de folha quanto às portas.
-
- Off-sheet Connectors – habilite esta opção para exibir referências cruzadas para objetos de conector fora da folha.
- Sheet Entries – habilite esta opção para exibir referências cruzadas para objetos de entrada de folha.
-
Ports – use a lista suspensa para selecionar o modo de exibição das referências cruzadas das portas.
Pares diferenciais
-
Custom Diff Pair Suffix Grid – lista os sufixos padrão de pares diferenciais (
_P/_N) e todos os sufixos personalizados de pares diferenciais definidos, em termos de:- Positive Suffix – o sufixo da rede positiva de um par diferencial.
- Negative Suffix – o sufixo da rede negativa de um par diferencial.
- Add – clique para adicionar um novo par de sufixos à lista.
- Remove – clique para excluir da lista os pares de sufixos selecionados.
Criação de xNets
- Sources/Destinations – defina uma lista de prefixos separados por vírgulas para os designadores dos componentes que podem ser usados como componentes de origem ou destino em xNets.
- Discretes – defina uma lista de prefixos separados por vírgulas para os designadores dos componentes que podem ser usados como componentes em série em xNets.
Multicanal

A aba Multi-Channel da caixa de diálogo Project Options
A aba Multi-Channel da caixa de diálogo Project Options permite definir o esquema de nomenclatura das rooms e o formato dos designadores de componentes para uso em projetos multicanal. O projeto multicanal permite referenciar a mesma subfolha várias vezes no projeto. Isso pode ser feito posicionando vários símbolos de folha que referenciam a mesma subfolha ou incluindo a palavra-chave Repeat no designador de um símbolo de folha para instanciá-lo várias vezes.
O Altium Designer oferece recursos de projeto verdadeiramente multicanal, o que significa que você pode referenciar folhas individuais repetidamente em um projeto. Quaisquer alterações necessárias podem ser aplicadas em um único lugar, e a recompilação do projeto propaga essas alterações para cada instância. O Altium Designer não apenas oferece suporte a múltiplos canais, como também permite que eles sejam aninhados.
O mapeamento de um único componente lógico no esquemático para as múltiplas instâncias físicas na PCB é controlado pelo esquema de designadores multicanal definido nesta aba.
Opções/Controles
Nomenclatura das rooms
-
Room Naming Style - use este campo para especificar o estilo a ser usado para nomear as rooms. Ao selecionar um estilo na lista, a imagem abaixo é atualizada para refletir a convenção de nomenclatura que aparecerá no projeto. Quando o projeto é compilado, uma room é criada para cada folha do projeto, incluindo cada banco e cada canal de nível inferior. Há cinco estilos disponíveis — dois planos e três hierárquicos (os que incluem o caminho):
- Flat Numeric With Names
- Flat Alpha With Names
- Numeric Name Path
- Alpha Name Path
- Mixed Name Path
-
Level Separator for Paths - use este campo para especificar o caractere/símbolo necessário para separar as informações do caminho ao usar os estilos de nomenclatura hierárquicos (os estilos que incluem o caminho). Por padrão, será usado o caractere de sublinhado (_).
- Preview - conforme você faz alterações em Room Naming Style e/ou Designator Format, a imagem nesta região é atualizada dinamicamente para refletir a convenção de nomenclatura que aparecerá no projeto. A imagem apresenta um exemplo de projeto com canais aninhados de 2 x 2. As regiões hachuradas maiores representam os dois canais de nível superior (ou bancos), e as regiões sombreadas internas representam os canais de nível inferior (com dois componentes de exemplo mostrados em cada um).
Nomenclatura dos componentes
-
Designator Format - use este campo para especificar o formato usado ao atribuir designadores aos componentes do projeto. Os oito formatos predefinidos a seguir estão disponíveis na lista suspensa do campo: cinco planos e três que podem ser usados em um contexto hierárquico (contendo a nomenclatura dos canais):
- $Component_$RoomName
- $RoomName_$Component
- $Component$ChannelAlpha
- $Component_$ChannelPrefix$ChannelAlpha
- $Component_$ChannelIndex
- $Component_$ChannelPrefix$ChannelIndex
- $ComponentPrefix_$ChannelIndex_$ComponentIndex
- $ComponentPrefix_$RoomName_$ComponentIndex
Definindo seu próprio formato de designador
Você também pode definir seu próprio formato de designador de componente digitando diretamente no campo Designator Format. As seguintes palavras-chave podem ser usadas na construção da string de formato:
- $RoomName - este é o nome do canal associado, conforme determinado pelo estilo escolhido no campo Room Naming Style .
- $Component- este é o designador lógico do componente.
- $ComponentPrefix - este é o prefixo do designador lógico do componente (por exemplo, U para U1).
- $ComponentIndex - este é o índice do designador lógico do componente (por exemplo, 1 para U1).
- $ChannelPrefix - este é o designador lógico do símbolo de folha.
- $ChannelIndex - este é o índice do canal.
- $ChannelAlpha - este é o índice do canal expresso como um caractere.
Notas
- A indexação alfabética de um canal só é realmente útil se o projeto contiver menos de 26 canais no total ou se você estiver usando um formato de designador de natureza hierárquica.
- Em um projeto multicanal, são exibidas abas na parte inferior da folha do esquemático na janela de projeto, uma para cada canal (ou banco). Os nomes das abas são os nomes dos símbolos de folha acrescidos do número do canal, por exemplo, BANKA. Essas são as visualizações compiladas (visualizações físicas) do projeto, enquanto o projeto lógico permanece como antes na aba Editor.
Impressões padrão

A aba Default Prints da caixa de diálogo Project Options
A aba Default Prints da caixa de diálogo Project Options permite configurar as saídas de impressão padrão para vários editores do Altium Designer. Esses padrões definidos são usados ao executar os seguintes comandos de impressão nos menus principais dos editores:
- File » Print
- File » Print Preview » Print
A aba Default Prints da caixa de diálogo Project Options também pode ser acessada a partir do editor de esquemáticos e do editor de PCB, selecionando o comando File » Default Prints nos menus principais.
Opções/Controles
A área principal da aba apresenta uma lista de todas as saídas de impressão compatíveis que podem ser geradas a partir dos editores de esquemáticos e de PCB. Os tipos de saída são agrupados nas seguintes categorias:
-
Assembly Outputs -
Documentation Outputs -
Fabrication Outputs -
Other Outputs -
Report Outputs -
Validation Outputs
Para cada entrada, são exibidas as seguintes informações:
- Output Description – o que é gerado ao usar este tipo de saída de impressão.
- Supports – o editor que oferece suporte a este tipo de saída de impressão.
-
Default Print – indica se este tipo de saída de impressão deve ser usado como o tipo de impressão padrão (habilitado) ou não (desabilitado).
Opções adicionais
-
Configure – clique neste botão para acessar uma caixa de diálogo associada, na qual é possível configurar a saída de impressão selecionada no momento. As caixas de diálogo envolvidas incluem:
- Caixa de diálogo Impressão – para configurar desenhos de montagem, desenho composto, impressões de PCB, impressões de PCBLIB, impressões de esquemáticos, desenho de furação composto, desenho/guias de furação, impressões da arte-final, impressões de planos de alimentação e impressões de máscaras de solda/pasta.
- Caixa de diálogo Configurações de impressão 3D da PCB – para configurar impressões 3D da PCB.
- Caixa de diálogo Vídeo 3D da PCB – para configurar saídas de vídeo 3D da PCB.
- Caixa de diálogo PDF3D – para configurar saídas PDF3D e PDF3D MBA.
- Caixa de diálogo Propriedades avançadas de impressão de texto – para configurar impressões de relatórios e impressões de texto. Defina opções para a saída impressa (por exemplo, cabeçalho e numeração de páginas/linhas). Você também pode especificar o uso de uma determinada fonte.
- Wave Print Properties Form caixa de diálogo – para configurar impressões do SimView.
- Caixa de diálogo Configuração do relatório de empilhamento de camadas – para configurar saídas de relatório do empilhamento da placa.
- Caixa de diálogo Gerenciador de relatórios – para configurar relatórios de lista de materiais e comparação de BOM.
- Caixa de diálogo Configuração de exportação de comentários – para configurar um relatório de exportação de comentários.
- Caixa de diálogo Configuração de diferenças – para configurar um relatório de diferenças.
- Caixa de diálogo Configuração da verificação de regras elétricas – para configurar um relatório de validação da verificação de regras elétricas.
- Page Setup – clique para acessar uma caixa de diálogo de configuração de página para a saída de impressão selecionada no momento. Nessa caixa de diálogo, você pode configurar a impressão com a impressora escolhida em termos de papel, escala e configurações de cor. Você também pode acessar a caixa de diálogo de configuração correspondente e a caixa de diálogo de configuração da impressora, visualizar a impressão e, por fim, imprimir a saída na impressora selecionada.
Caminhos de pesquisa

A aba Search Paths da caixa de diálogo Project Options
A aba Search Paths da caixa de diálogo Project Options permite especificar os caminhos de pesquisa dos arquivos de bibliotecas e modelos do projeto.
Opções/Controles
Lista ordenada de caminhos de pesquisa
Esta grade mostra a lista ordenada de caminhos de pesquisa de arquivos de bibliotecas e modelos (por exemplo, bibliotecas de footprints de PCB, modelos de simulação e de integridade de sinal). Para cada caminho, você pode especificar o filtro e as configurações de recursividade.
- Path - localização do caminho de pesquisa.
- Filter - o filtro da pesquisa. Por padrão, o filtro pesquisa todos os arquivos.
- Recursive - marque para pesquisar em todos os subdiretórios do diretório do caminho de pesquisa. Clique duas vezes em um caminho de pesquisa para editá-lo.
- Add - use para abrir a caixa de diálogo Edit Search Path para adicionar um novo caminho de pesquisa.
Os seguintes tipos de arquivo são compatíveis: bibliotecas de footprints (*.PcbLib), arquivos de modelos de simulação (*.mdl), arquivos de subcircuitos de simulação (*.ckt) e arquivos de modelos IBIS (*.ibs).
- Delete - use para remover um caminho de pesquisa selecionado.
- Properties - use para acessar a caixa de diálogo Edit Search Path para editar as propriedades do caminho de pesquisa selecionado.
- Move Up - use para mover o caminho de pesquisa selecionado uma linha para cima.
- Move Down - use para mover o caminho de pesquisa selecionado uma linha para baixo.
Arquivos encontrados em todos os caminhos de pesquisa
Esta grade mostra os arquivos de bibliotecas e modelos encontrados a partir da lista Ordered List of Search Paths. Use o botão Refresh List para visualizar uma lista atualizada.
Parâmetros

A aba Parameters da caixa de diálogo Project Options
A aba Parameters da caixa de diálogo Project Options permite gerenciar os parâmetros definidos para o projeto, geralmente chamados de project-level parameters. Os parâmetros definidos no nível do projeto estão disponíveis para uso em todas as folhas de esquemático e documentos de PCB do projeto por meio de strings especiais: =<ProjectParameterName> em um esquemático (por exemplo, =Project) e .<ProjectParameterName> em uma PCB (por exemplo, .Project). Os parâmetros podem ser usados para fornecer informações adicionais sobre o projeto. Os parâmetros no nível do projeto, por exemplo, podem ser usados globalmente como fonte de dados paramétricos de strings especiais a serem adicionadas às folhas de esquemático e/ou ao documento de PCB — este último não oferece suporte a parâmetros locais.
Os parâmetros de projeto do lado do Workspace são salvos no Workspace junto com o projeto e só podem ser editados na interface do Workspace no navegador (saiba mais sobre Editing a Project no Altium 356 Workspace ou no On-Prem Enterprise Workspace). Por outro lado, os parâmetros de projeto do lado do design são salvos no arquivo do projeto (*.PrjPcb) e podem ser editados no Altium Designer. Os parâmetros de projeto do lado do Workspace aparecem na aba Parameter da caixa de diálogo Project Options com um ícone azul , enquanto os parâmetros de projeto do lado do design aparecem com um ícone laranja
Opções/Controles
-
Parameters Grid – a região principal lista todos os parâmetros atualmente definidos para o projeto, em termos de:
- Name – o nome do parâmetro.
- Value – o valor do parâmetro.
-
Add – clique para abrir a caixa de diálogo Parameter Properties, na qual você pode adicionar um parâmetro. Use os campos Name e Value para atribuir ao parâmetro um nome significativo que reflita sua finalidade e seu valor, respectivamente. Ambos os campos permitem um máximo de 255 caracteres.
- Remove – clique para excluir os parâmetros selecionados da lista de parâmetros. Esta opção não está disponível para parâmetros de projeto do lado do Workspace, pois eles só podem ser removidos ou editados no Workspace.
- Edit – clique para abrir a caixa de diálogo Parameter Properties, na qual você pode modificar o conteúdo do parâmetro atualmente selecionado. Esta opção não está disponível para parâmetros de projeto do lado do Workspace, pois eles só podem ser removidos ou editados no Workspace.
- Refresh – clique para reverter as últimas alterações feitas no parâmetro de projeto do lado do design. Para parâmetros de projeto do lado do Workspace, clique para garantir que você tenha a versão mais recente do parâmetro. As alterações feitas nos parâmetros de projeto do lado do Workspace dentro do Workspace não serão refletidas nesta caixa de diálogo até que esta opção seja usada.
Menu de contexto
Os seguintes comandos estão disponíveis no menu de contexto:
-
Edit – use para modificar o parâmetro atualmente selecionado na caixa de diálogo Parameter Properties. Este comando não está disponível para parâmetros de projeto do lado do Workspace, pois eles só podem ser removidos ou editados no Workspace.
-
Add – use para adicionar um novo parâmetro do lado do design à lista na caixa de diálogo Parameter Properties.
-
Remove – use para excluir os parâmetros selecionados da lista. Este comando não está disponível para parâmetros de projeto do Workspace, pois eles só podem ser removidos ou editados no Workspace.
-
Copy – use para copiar os parâmetros selecionados para a área de transferência do Windows.
-
Paste – use para colar os parâmetros da área de transferência do Windows na lista de parâmetros. Este comando não está disponível para parâmetros de projeto do Workspace, pois eles só podem ser removidos ou editados no Workspace.
Folhas de dispositivo

A aba Device Sheets da caixa de diálogo Project Options
A aba Device Sheets da caixa de diálogo Project Options permite especificar as pastas nas quais as folhas de dispositivo podem ser encontradas e sua ordem.
Opções/Controles
- Main region - lista os Device Sheet Folders caminhos do projeto atual. Marque Include Sub-folders para incluir as subpastas das pastas principais listadas.
- Move Up - use para mover a pasta de folhas de dispositivo selecionada um nível acima por vez.
- Move Down - use para mover a pasta de folhas de dispositivo selecionada um nível abaixo por vez.
- Add - use para abrir uma caixa de diálogo para procurar uma nova pasta a ser adicionada.
- Remove - use para remover a pasta de folhas de dispositivo selecionada.
OutputJobs gerenciados

A aba Managed OutputJobs da caixa de diálogo Project Options
A aba Managed OutputJobs da caixa de diálogo Project Options permite configurar uma lista de modelos de tarefas de saída disponíveis no Workspace conectado para uso com o projeto.
Opções/Controles
- Outputjob List - lista todos os OutputJobs do Workspace em termos de Item Revision, Revision State, Description e Name.
- Add - clique para abrir a caixa de diálogo Select configuration item (Output Jobs) e selecionar os OutputJobs desejados.
- Remove - clique para remover as tarefas de saída selecionadas.
Opções de biblioteca

A aba Library Options da caixa de diálogo Project Options
A aba Library Options da caixa de diálogo Project Options permite selecionar o formato de um projeto de biblioteca integrada.
Opções/Controles
-
Integrated Library Format
- Original - selecione para usar o formato original de biblioteca integrada. Esse formato é usado para compatibilidade com o software Protel DXP (DXP 2002), anterior ao lançamento do Altium Designer.
-
Altium Designer- selecione para usar o Altium Designer como formato de biblioteca integrada (usado em todas as versões do software desde o Altium Designer 2004 original).
).
