Altium Designer Documentation

Управляемые проекты

Последнее изменение: Pavel Demidov; 12.08.2020

Главная страница: Altium Concord Pro

Программное обеспечение Altium для проектирования в сочетании с Altium Concord Pro обеспечивает поддержку управляемых проектов (Managed Projects). Управляемые проекты ориентированы на этап разработки жизненного цикла проекта, что упрощает создание и текущий рабочий процесс для проектов в системе контроля версий. Централизованное хранение под управлением Concord Pro также позволяет этой функциональной возможности быть основой других служб для совместной работы.

Ключевые преимущества использования управляемых проектов:

  • Упрощенное хранение. Нет необходимости принимать решения о месте хранения. Поддерживаются резервное копирование и прочие базовые службы.
  • Основа других служб для совместной работы.
  • Контроль версий.
  • Специальная система комментирования.
  • Уведомления и состояния. Состояние документа, в том числе локальные изменения, видимы всей проектной группе.
  • Одновременная работа над проектом платы без необходимости в сложной настройке.

Технически, управляемый проект является сочетанием мета-информации, которая хранится на сервере, вместе с тесной интеграцией с локальной службой Version Control Altium Concord Pro. Типовой рабочий процесс:

  1. Пользователь создает новый управляемый проект: через диалоговое окно Create Project в Altium Designer, из веб-интерфейса Concord Pro или путем преобразования существующего проекта в доступный для Concord Pro (из Altium Designer). В процессе создания проекта, пользователь определяет имя проекта, его описание и проектный репозиторий.
  2. В веб-интерфейсе Concord Pro или непосредственно в Altium Designer определяется доступ к проекту.
  3. Все сотрудники выбирают проект на открытие (из Altium Designer или из веб-интерфейса Concord Pro), после чего он автоматически извлекается.
Преимуществом управляемых проектов является то, что они по умолчанию находятся под управлением контроля версий, и совместную работу над ними можно осуществлять, не беспокоясь об общих дисках, серверах, соглашениях и т.д.
Перед созданием нового управляемого проекта или преобразованием существующего неуправляемого проекта в доступный для Concord Pro убедитесь, что существует проектный репозиторий для сохранения в него этого и всех будущих проектов. Управление проектными репозиториями, как правило, осуществляется в Altium Concord Pro, с помощью его локальной службы Version Control. Новая установка Altium Concord Pro предоставляет один проектный репозиторий Git (Versioned Storage) для хранения всех управляемых проектов. Если вы обновили Altium Concord Pro с Altium NEXUS Server 1.0 (или Altium Vault 3.0), то будет также доступно использование репозиториев SVN, соответственно, вы сможете продолжить использовать рабочий процесс, применяемый ранее. В этом случае вы можете продолжить создавать репозитории с помощью локальной службы Version Control (только SVN) или подключаться ко внешним репозиториям (SVN или Git).

Создание нового управляемого проекта

Существует три способа создания управляемого проекта:

  • Создание нового проекта в Altium Designer.
  • Создание нового проекта в веб-интерфейсе Altium Concord Pro.
  • Преобразование существующего проекта в доступный для Concord Pro в Altium Designer.

Эти способы рассмотрены более подробно в разделах ниже.

Через Altium Designer

Новый управляемый проект может быть создан в Altium Designer с помощью диалогового окна Create Project (File » New » Project):

Настройки в диалоговом окне Create Project для создания нового управляемого проекта из Altium Designer.

  1. В списке Locations выберите запись сервера Concord Pro (здесь будет отображено имя, указанное на странице Admin - General веб-интерфейса Concord Pro). Чтобы эта опция была доступа в списке, должен быть осуществлен вход в Concord Pro.
  2. В списке Project Type выберите тип проекта, который вы хотите создать, и один из применимых шаблонов, если необходимо. Если в установке Concord Pro существуют созданные и выпущенные шаблоны проектов, они будут отображены в списке доступных для выбора шаблонов.
  3. Введите имя проекта (Project Name) и, опционально, описание проекта (Description).

    Имя проекта должно начинаться с A-Z, a-z или 0-9, и оно может содержать эти символы. Допустимы подчеркивания, дефисы и пробелы, но пробелы могут быть только в середине имени (пробелы в начале и в конце будут игнорироваться). Вы не можете использовать следующие слова: AUX, COM1-COM9, LPT1-LPT9, CON, NUL и PRN. Кроме того, имя не может содержать следующие символы: \ . / ? % * : | " < >.
  4. Используйте поле Folder для определения папки в структуре Concord Pro, которая будет создана для проекта. Путь по умолчанию для новых проектов Concord Pro указывается на странице Admin - Settings - Projects веб-интерфейса Concord Pro (по умолчанию это папка Projects\<ИмяПроекта>). Нажмите кнопку  для просмотра и выбора другой папки на сервере, если необходимо.
  5. Используйте поле Local Storage для определения расположения хранения проекта на жестком диске перед его фиксацией в центральном проектном репозитории. Расположение по умолчанию определяется на странице System - Default Locations диалогового окна Preferences. Нажмите кнопку  для просмотра и выбора другой папки, если необходимо. Это "рабочая" папка для проекта и локальный репозиторий Git, в который он фиксируется. Во время фиксации, проект передается в централизованный проектный репозиторий в Altium Concord Pro (Versioned Storage), который является удаленным репозиторием Git.
  6. Используйте область списка Parameters для добавления или удаления пар имен и значений пользовательских параметров, которые связаны с проектом и которые будут храниться на сервере. Используйте кнопку  для добавления в список новой пары имени и значения параметра. Эти параметры управляемого проекта сохраняются на сервере Concord Pro с новым проектом, и их можно изменить на сервере. Напротив, параметры проекта хранятся в файле проекта (*.PrjPcb), и их можно изменить в Altium Designer. Параметры обоих типов могут использоваться в качестве специальных строк в Altium Designer – откройте панель Properties, когда размещенный объект Text String выделен в рабочей области. Параметры, определенные для проекта, также можно просмотреть на вкладках Parameters и Server Parameters диалогового окна Project Options (Project » Project Options).
Если вы обновились до Altium Concord Pro из предыдущей серверной технологии и у вас все еще возможность использовать внутренние (SVN) и/или внешние (SVN/Git) проектные репозитории, будет представлено поле Repository, в котором содержится список всех проектных репозиториев, управляемых через локальную службу Version Control в Concord Pro и опубликованных вам для использования. Выберите репозиторий, в котором необходимо хранить новый проект и его файлы.

После того, как проект определен необходимым образом, нажмите кнопку . Структура нового проекта будет создана в указанных локальных и серверных папках. Проект будет открыт в панели Projects, в которой будет показано, что проект и входящие в него документы запланированы на добавление (Scheduled for addition), что обозначено иконками синего перекрестия ().

Проект появится в панели Projects в записи для целевого сервера, где отражено имя этого сервера.

Щелкните ПКМ по проекту в панели Projects и выберите команду Commit Project или Version Control » Commit Whole Project. Будет открыто диалоговое окно Commit to Version Control. Выберите файлы, которые вы хотите зафиксировать в проектном репозитории Versioned Storage Concord Pro, и нажмите кнопку . После добавления проекта, в панели Projects будет отражено, что файлы в удаленном проектном репозитории (в Altium Concord Pro) и в локальном репозитории (рабочая копия) полностью синхронизированы, что обозначено соответствующими иконками .

Если вы обновились до Altium Concord Pro из предыдущей серверной технологии и у вас все еще возможность использовать внутренние (SVN) и/или внешние (SVN/Git) проектные репозитории, вы можете нажать соответствующую кнопку в диалоговом окне, чтобы зафиксировать (или зафиксировать и передать) проект в выбранный внутренний репозиторий SVN или внешний проектный репозиторий SVN/Git.

Зафиксируйте и передайте новый проект в проектный репозиторий Versioned Storage Altium Concord Pro.

При фиксации проекта, Altium Designer обнаружит наличие всех несохраненных файлов и предложит сохранить их.

Кроме того, запись проекта появится на странице Projects веб-интерфейса Concord Pro.

Новый проект проект, отображаемый на странице Projects веб-интерфейса Altium Concord Pro.

Проект будет изначально опубликован с правами на чтение/запись проектировщику, который создал его (его владельцу), и всем администраторам сервера Concord Pro. Кроме того, он будет доступен всем (Anyone) только для чтения, что означает, что все пользователи сервера Concord Pro смогут просматривать этот проект. Для получения более подробной информации по настройке прав доступа перейдите в раздел Публикация управляемого проекта.

Фиксация без передачи

Для тех, кто не знаком с репозиториями Git или кто просто хочет передавать локальные изменения проектов в Altium Concord Pro, использование кнопки  в диалоговом окне Commit to Version Control является самым ясным и простым способом.

Тем не менее, у вас есть возможность выполнить фиксацию (Commit) в локальном репозитории Git перед тем, как передать изменения в удаленный репозиторий Git (Versioned Storage) в Altium Concord Pro. Для этого выберите команду Commit, как указано выше, и в диалоговом окне Commit to Version Control выберите опцию Commit из выпадающего меню кнопки . Изменения будут сохранены в локальном репозитории Git для этого проекта, и состоянием файлов, которое будет отражено в панели Projects, станет Ahead of server ().

Пример фиксации нового проекта в локальном репозитории Git.

Эти локально сохраненные изменения можно отправить в удаленный репозиторий Git в Concord Pro позже путем выполнения команды Push. Это можно осуществить различными способами:

  • Щелкните ПКМ по записи проекта в панели Projects и выберите команду Commit Project из контекстного меню либо выберите команду File » Commit Project из главного меню. В диалоговом окне Commit to Version Control нажмите кнопку . Это просто выполнит передачу этих файлов "перед сервером" и выполнит фиксацию и передачу файлов, для которых это еще не выполнено.

  • Щелкните ПКМ по записи проекта в панели Projects (или по определенному файлу) и выберите команду Version Control » Push(n) из контекстного меню. Здесь n отражает количество локальных фиксаций, которые были выполнены (перед сервером).

После передачи, в панели Projects будет отражено, что файлы в удаленном репозитории (в Concord Pro) и в локальном репозитории (рабочей копии) полностью синхронизированы ().

Через веб-интерфейс Concord Pro

Управляемый проект может быть создан непосредственно через страницу Projects веб-интерфейса Altium Concord Pro. На этой странице приведен список всех проектов, которые доступны в Concord Pro и которые опубликованы вошедшему в данный момент пользователю. Для создания нового проекта нажмите кнопку  над списком проектов, чтобы открыть окно Add Project.

Создание нового управляемого проекта через веб-интерфейс Altium Concord Pro.

Окно Add Project будет изначально открыто в упрощенном виде. Выберите шаблон проекта, если шаблон доступен – в области Templates будет приведен список всех управляемых шаблонов проектов, которые существуют в Concord Pro. При выборе шаблона будет также определен тип проекта. Затем введите имя (Name) и, опционально, описание (Description) проекта.

Имя проекта должно начинаться с A-Z, a-z или 0-9, и оно может содержать эти символы. Допустимы подчеркивания, дефисы и пробелы, но пробелы могут быть только в середине имени (пробелы в начале и в конце будут игнорироваться). Вы не можете использовать следующие слова: AUX, COM1-COM9, LPT1-LPT9, CON, NUL и PRN. Кроме того, имя не может содержать следующие символы: \ . / ? % * : | " < >.

Чтобы получить доступ к дополнительным элементам управления, нажмите Show additional fields. Будут представлены следующие поля:

  • Vault Folder (Папка хранилища) – используйте это поле, чтобы указать, где в структуре папок Concord Pro будет создана папка проекта. По умолчанию это папка Projects\<ИмяПроекта>. Путь по умолчанию к папке для новых проектов указан на странице Admin - Settings - Projects веб-интерфейса Concord Pro.
  • Project Type (Тип проекта) – используйте это поле, чтобы указать тип проекта из списка всех типов проектов, поддерживаемых Altium Designer. Если вы выбрали управляемый шаблон проекта, это поле не будет отображаться.
  • Repository (Репозиторий) – в этом поле отображен Versioned Storage – проектный репозиторий Git, доступный в рамках установки Concord Pro. В нем будут храниться все новые проекты (и их файлы).
Если вы обновились до Altium Concord Pro из предыдущей серверной технологии и у вас все еще возможность использовать внутренние (SVN) и/или внешние (SVN/Git) проектные репозитории, будет доступно поле Repository. В нем будут перечислены все проектные репозитории, управляемые через локальную службу Version Control сервера Concord Pro и доступные вам для использования. Выберите репозиторий, в котором необходимо хранить новый проект и его файлы. Если выбран репозиторий SVN, будет представлено поле Repository Folder. Используйте это поле, чтобы указать имя папки в репозитории, в которой будут находиться проект и связанные с ним файлы. По умолчанию папке будет задано имя проекта.

После определения нового проекта необходимым образом нажмите , чтобы создать структуру нового проекта. Вы вернетесь в общий список проектов, где сможете увидеть запись нового проекта.

Новый проект, отображаемый на странице Projects веб-интерфейса Altium Concord Pro.

Проект будет изначально опубликован с правами на чтение/запись проектировщику, который создал его (его владельцу), и всем администраторам сервера Concord Pro. Кроме того, он будет доступен всем (Anyone) только для чтения, что означает, что все пользователи сервера Concord Pro смогут просматривать этот проект. Для получения более подробной информации по настройке прав доступа перейдите в раздел Публикация управляемого проекта.

Преобразование существующего неуправляемого проекта

Вы можете создать управляемый проект путем преобразования существующего неуправляемого проекта и его портирования в Altium Concord Pro. Для этого откройте существующий неуправляемый проект в Altium Designer как обычно, щелкните по нему ПКМ в панели Projects и выберите команду Make Project Available on Server из контекстного меню, чтобы открыть диалоговое окно Make Available On Server.

Если проект находится под управлением контроля версий в локальном репозитории, он не может быть преобразован и портирован в Concord Pro напрямую. Будет отображено сообщением об этом, с возможностью преобразования проекта в обычный, игнорируя ревизии SVN и лог изменений, и последующим портированием этого проекта в Concord Pro в качестве управляемого проекта.

Преобразование существующего обычного проекта в управляемый проект, доступный на сервере Altium Concord Pro.

Используйте диалоговое окно Make Available On Server, чтобы изменить имя проекта (Project Name) и добавить описание (Description). По умолчанию будет использоваться имя изначального проекта.

Щелкните ЛКМ по ссылке Advanced в нижней части, чтобы отобразить поле Folder. Это поле используется для указания того, где в структуре папок Concord Pro будет создана папка проекта. Путь по умолчанию для новых проектов Concord Pro указан на странице Admin - Settings - Projects веб-интерфеса Concord Pro (по умолчанию это будет Projects\<ИмяПроекта>). Нажмите кнопку  для просмотра и выбора другой серверной папки, если это необходимо.

Когда свойства управляемого проекта определены необходимым образом в диалоговом окне Make Available On Server, нажмите OK. Проект и его файлы будут зафиксированы и переданы в целевой проектный репозиторий Versioned Storage Concord Pro, и в панели Projects будет отражено, что удаленный проектный репозиторий и локальный репозиторий (рабочая копия) полностью синхронизированы, что обозначено соответствующими иконками .

Новый портированный управляемый проект станет доступен на странице Projects веб-интерфейса Concord Pro.

Проебразованный и портированный проект добавлен в список управляемых проектов.

Проект будет изначально опубликован с правами на чтение/запись проектировщику, который сделал его доступным на сервере Concord Pro (владельцу проекта), и всем администраторам сервера Concord Pro. Кроме того, он будет доступен всем (Anyone), только для чтения, что означает, что все пользователи сервера Concord Pro смогут просматривать этот проект. Для получения более подробной информации по настройке прав доступа перейдите в раздел Публикация управляемого проекта.

Просмотр управляемых проектов

Список проектов на странице Projects веб-интерфейса Altium Concord Pro включает в себя все проекты, которые опубликованы вам, и здесь предлагается ряд элементов управления для доступа к управлению проектами. Используйте кнопку , чтобы переключить страницу в режим предварительного просмотра проектов (графических плиток), и кнопку , чтобы переключить страницу в режим подробного списка.

Страница Projects веб-интерфейса Concord Pro – центр управления проектами. Здесь показан режим подробного списка страницы. Наведите курсор мыши на изображение, чтобы увидеть режим предварительного просмотра проектов.

Список управляемых проектов автоматически отсортирован по дате последнего изменения, где вверху (в режиме подробного списка) или вверху слева (в режиме предварительного просмотра проектов) отображается проект, который был изменен последним. В любом из этих режимов, вы можете нажать кнопку  для быстрого переключения сортировки проектов в алфавитном порядке их имен.

Запись каждого проекта в режиме подробного списка включает с себя следующую информацию:

  • Name (Имя) – имя проекта.
  • Author (Автор) – пользователь, который создал проект.
  • Kind (Тип) – тип проекта. Как правило, это проект платы (PcbProject) или многомодульного устройства (SystemDesign).
  • Last Modified (Последнее изменение) – пользователь, который последним изменил проект. Будет отображена запись System, если проект был изменен фоновым автоматизированным процессом Concord Pro, как правило это добавление извлеченной информации (такой как предварительный просмотр или статистика платы).
  • Date (Дата) – дата последнего изменения проекта.
Список проектов может быть отсортирован по имени (Name), автору (Author) или дате (Date) с помощью заголовка соответствующего столбца. Щелкните ЛКМ по заголовку столбца один раз, чтобы отсортировать по возрастанию, и щелкните еще раз, чтобы отсортировать по убыванию. Стрелки справа от имени столбца обозначат текущее направление сортировки.

В режиме предварительного просмотра проекта, плитка управляемого проекта включает в себя имя проекта и дату последнего изменения. Плитка также автоматически заполняется 3D-видом платы проекта, если она доступна.

Пример плитки выбранного управляемого проекта, когда страница Projects находится в режиме предварительного просмотра проектов.

В обоих режимах отображения проектов (подробный список и предварительный просмотр) доступны следующие элементы управления (описаны в соответствующих разделах ниже). Они работают для выбранного в данный момент в списке проекта:

 Share (Опубликовать) – открыть окно Manage Permissions с элементами управления, необходимыми для настройки прав доступа к проекту другим пользователям.

 Open (Открыть) – открыть страницу Projects Management проекта. Эта страница будет открыта в отдельной вкладке браузера.

 Edit (Изменить) – открыть окно Edit Project, где вы можете изменить имя (Name), описание (Description) и серверные параметры (Parameters) проекта. Все прочие поля не доступны для редактирования, они лишь предоставляют информацию.

 More (Больше) – доступ к дополнительным опциям:

  • Clone (Клонировать) – выберите эту команду, чтобы открыть окно Clone Project, в котором находятся элементы управления для создания идентичной копии проекта.
  • Watch (Отслеживать) – выберите эту команду для отслеживания проекта. Вы будете получать соответствующие уведомления, касающиеся проекта (например, при его обновлении, выпуске, изменении прав доступа), на главных страницах Home и Stream веб-интерфейса. Создатель проекта автоматически отслеживает проект.
  • UnWatch (Прекратить отслеживание) – выберите эту команду, чтобы остановить отслеживание проекта и получение уведомлений о событиях, связанных с проектом.
  • Delete (Удалить) – выберите эту команду, чтобы удалить проект из репозитория Concord Pro и сделать его неуправляемым. Это не затронет локальную рабочую копию.
В режиме предварительного просмотра проектов, команды Edit, Share, Clone и Delete также доступны непосредственно из плитки проекта – нажмите , чтобы открыть соответствующее меню. Кроме того, вы можете дважды щелкнуть ЛКМ по плитке проекта в режиме предварительного просмотра проектов, чтобы открыть страницу управления этим проектом.

Также доступна возможность поиска (Search), которая позволяет отфильтровать список проектов по ряду свойств, таким как имя, автор, описание и т.д. Введите любую часть поисковой строки в поле в верхней части веб-интерфейса. В списке будут отображены только те проекты, атрибуты которых включают в себя поисковую строку.

Пример использования поиска, где проект найден по его описанию.

Чтобы очистить фильтр, щелкните ЛКМ по записи страницы Projects в дереве навигации слева либо очистите поле поиска и нажмите клавишу Enter.

Область свойств

Область в правой части страницы Projects Concord Pro отображает подробную информацию о свойствах выбранного в данный момент проекта.

Откройте более подробную информацию о выделенном в данный момент проекте в области Properties.

Свойства, которые доступны в области Properties, извлечены или сформированы сервером Concord Pro из выделенного в данный момент проекта. Данные различных типов сгруппированы под разворачиваемыми заголовками (изображения приведены в качестве примеров):

  • General Info (Общая информация) – общая информация и текущие данные проекта.

  • Description (Описание) – текстовое описание, добавленное при создании проекта. Его можно изменить с помощью опции Edit проекта.

  • Releases (Выпуски) – выпуски проекта, представленные с точки зрения собранных пакетов (в том числе данные для сборки, данные для изготовления связанной/родительской платы и исходные файлы, из которых эти данные были сформированы). Множество выпусков отображается последовательно, где вверху отображает самый новый выпуск.

  • Additional Info (Дополнительная информация) – обширный набор данных, извлеченных или вычисленных из самого проекта.

  • Preview (Предварительный просмотр) – сформированные изображения-миниатюры платы проекта в 2D- и 3D-видах, а также схемы верхнего уровня иерархии проекта.

Публикация управляемого проекта

Если проект является управляемым, вы можете определить, у каких пользователей есть доступ к этому проекту. Это осуществляется путем публикации проекта, т.е. настройкой прав доступа к нему. Помните, что управляемый проект, созданный или преобразованный, по умолчанию опубликован для следующих лиц:

  • Владельцу проекта, который, как правило, является проектировщиком, который создал (преобразовал) проект: полные (на чтение/запись) права доступа.
  • Участникам роли Administrators: полные (на чтение/запись) права доступа.
  • Всем, что обозначено наличием записи Anyone: права только на чтение.

Настройка прав доступа может быть выполнена через веб-интерфейс Concord Pro, а также непосредственно в Altium Designer.

Через веб-интерфейс сервера

Для настройки доступа к проекту из веб-интерфейса Concord Pro выберите запись проекта на странице Projects и нажмите кнопку Share ().

Это также можно сделать в режиме отображения предварительного просмотра страницы Projects – выберите плитку нужного проекта, затем нажмите  и выберите команду Share из контекстного меню.

Будет открыто диалоговое окно Manage Permissions, в котором находятся все элементы управления, необходимые для публикации проекта другим пользователям.

Когда проект централизованно управляется сервером Concord Pro, его публикация другим пользователям осуществляется путем настройки прав доступа к этому проекту.

Что следует иметь в виду:

  • С точки зрения прав доступа, у пользователя или роли (группы) есть права на чтение/запись, когда включена опция Can Write. Если эта опция отключена, у пользователя/роли есть только права на чтение.
  • Чтобы удалить существующего пользователя/роль из доступа к проекту, нажмите по соответствующему элементу управления Remove ().
  • По умолчанию все пользователи сервера Concord Pro могут видеть проект. Если вы хотите предоставить доступ только определенным пользователям и/или ролям, запись Anyone необходимо удалить.
  • Если вы удалили запись Anyone, ее можно добавить обратно с помощью элемента управления Add Anyone. Имейте в виду, что при этом по умолчанию всем пользователям Concord Pro будут предоставлены права на чтение/запись проекта.

Чтобы опубликовать проект другому пользователю Concord Pro:

  1. Нажмите Add User в окне Manage Permissions.

  2. В открывшемся окне Add Users начните вводить полное имя, имя пользователя или email пользователя Altium Concord Pro в поле Select Users to be added, чтобы отобразить список соответствующих пользователей. Выберите нужного пользователя из списка. Можно выбрать множество пользователей. Чтобы удалить пользователя, нажмите перекрестие справа от его имени.

  3. Задайте права доступа для пользователей с помощью поля Permission. Используйте выпадающее меню для выбора между доступом на чтение (Read) или на чтение/запись (Read/Write).

  4. Когда настройки выполнены, нажмите кнопку  , чтобы сохранить добавление пользователей и вернуться в окно Manage Permissions.

  5. Нажмите кнопку  в окне Manage Permissions.
Чтобы изменить права доступа существующего пользователя, используйте опцию Can Write в окне Manage Permissions, для переключения между доступом на чтение/запись (включена) или только на чтение (отключена).

У вас также есть возможность публиковать проект роли (группе пользователей), заданной на сервере Concord Pro. Чтобы опубликовать проект роли:

  1. Нажмите Add Group в окне Manage Permissions.

  2. В открывшемся окне Add Groups начните вводить имя роли в поле Select Groups to be added, чтобы отобразить список соответствующих ролей. Выберите нужную роль из списка. Можно выбрать множество ролей. Чтобы удалить роль, нажмите перекрестие справа от ее имени.

  3. Задайте права доступа для ролей с помощью поля Permission. Используйте выпадающее меню для выбора между доступом на чтение (Read) или на чтение/запись (Read/Write).

  4. Когда настройки выполнены, нажмите кнопку , чтобы сохранить добавление ролей и вернуться в окно Manage Permissions.

  5. Нажмите кнопку  в окне Manage Permissions.
Чтобы изменить права доступа существующей роли (группе), используйте опцию Can Write в окне Manage Permissions, для переключения между доступом на чтение/запись (включена) или только на чтение (отключена).

Через Altium Designer

Доступ к проекту может быть настроен непосредственно в Altium Designer через диалоговое окно Share, которое открывается по нажатию кнопки  в верхней правой части окна приложения. Либо используйте команду Share, которая может быть вызывана для активного проекта или для проекта в фокусе:

  • Активный проект – когда какой-либо документ проекта открыт в качестве активного документа, выберите команду Project » Share из главного меню.
  • Проект в фокусе – доступ осуществляется из панели Projects щелчком ПКМ по записи требуемого проекта и выбором команды Share из контекстного меню.
При использовании кнопки  для вызова диалогового окна убедитесь, что запись проекта, который вы хотите опубликовать, выбрана в панели Projects.

Вызов диалогового окна Share – центра управления публикацией проекта из Altium Designer.

Поддерживаются следующие уровни публикации из Altium Designer:

  • Публикация текущего проекта – динамический проект, находящийся в процессе разработки, который может быть опубликован:

    • Другим членам команды вашего Workspace – для редактирования и/или просмотра. Для публикации на этом уровне необходима как регистрация на AltiumLive, так и активная подписка на лицензии Altium Designer. Также необходимо подключение к своему Altium 365 Workspace. Приглашенный член команды может просматривать проект через Altium Designer либо через интерфейс платформы Altium 365. Редактирование осуществляется только через Altium Designer.
    • Людям вне команды вашего Workspace – только для просмотра и комментирования, по email-приглашению. Для публикации на этом уровне необходима как регистрация на AltiumLive, так и активная подписка на лицензии Altium Designer. Также необходимо подключение к своему Altium 365 Workspace. Это позволяет приглашенным заинтересованным лицам просматривать динамический, находящийся в процессе разработки проект из любого веб-браузера, из любой точки мира, без получения доступа ко всем вашим проектным данным на сервере. Когда соответствующие участники вашей команды Workspace вносят изменения в проект, люди извне смогут увидеть эти изменения. Эта функциональность доступна через платформу, но за пределами Altium 365 Workspace, поэтому всё, что необходимо для получения доступа – это регистрация на AltiumLive.
  • Публикация слепка проекта – статичный слепок проекта в определенный момент времени. Может быть опубликован:

    • По ссылке – доступ кого угодно через веб-браузер. Для публикации на этом уровне не нужна ни регистрация на AltiumLive, ни активная подписка на лицензии Altium Designer. Получатели общей ссылки используют Altium 365 Viewer для просмотра проекта (но не его комментирования). Для просмотра не нужна регистрация на AltiumLive, ссылка доступна в течение 48 часов.
    • Определенным людям – доступ определенных людей по email-приглашению. Для публикации на этом уровне необходима регистрация на AltiumLive, но не активная подписка на лицензии Altium Designer. Получатели открывают слепок проекта в интерфейсе платформы Altium 365 через email-приглашение. Для просмотра нужна регистрация на AltiumLive, но слепок доступен постоянно. Также доступно комментирование проекта.
Для получения более подробной информации о выгрузке слепков проектов через интерфейс платформы Altium 365 Platform и его публикации другим перейдите на страницу Публикация слепков проектов. Для получения более подробной информации о публикации динамических проектов людям вне команды при просмотре проекта в веб-браузере перейдите на страницу Публикация динамических проектов за пределы Workspace.

Доступ к странице подробного управления проектом

Главная страница: Управление определенным проектом

Altium Concord Pro предлагает расширенный, ориентированный на производство вид проекта, который открывается путем выбора нужного проекта и нажатия кнопки  над списком проектов либо двойным щелчком непосредственно по записи нужного проекта в списке. Страница Projects Management для этого проекта будет открыта в новой вкладке браузера, с вариантами вида Design, Manufacturing и BOM:

  • Design (Проект) – просматривайте исходные документы проекта, осуществляйте навигацию по ним, просматривайте свойства проекта и размещайте комментарии. Этот вид использует интерфейс Web Review. Это вид самой новой версии исходных проектных данных, а не определенного выпуска этого проекта, поэтому его следует рассматривать как вид проекта, находящегося в процессе разработки.
  • Manufacturing (Производство) – просматривайте выпуски проекта. Доступ осуществляется путем открытия выпуска, который будет представлен на отдельной вкладке с помощью Manufacturing Portal. Из этого портала вы можете просмотреть выпущенные данные для изготовления (сборки) печатного узла и изготовления печатной платы, просмотреть BOM и загрузить данные в пакете Build Package для производства.
  • BOM (Состав изделия) – просматривайте информацию о составе изделия исходного проекта.

Доступ к странице Projects Management проекта. Здесь показаны виды Design, Manufacturing и BOM интерфейса. Вид Manufacturing предоставляет доступ к Manufacturing Portal, из которого можно загрузить пакет Build Package м

Страницу Projects Management также можно открыть из Altium Designer. Для активного управляемого проекта используйте команду Project » Show in Web Browser из главного меню. Либо щелкните ПКМ по записи проекта в панели Projects и выберите команду Show in Web Browser из контекстного меню. При просмотре проекта через панель Explorer Altium Designer, которая по умолчанию отображается в виде Project View, а не Classic View, откройте страницу Projects Management нажатием кнопки .

Открытие управляемого проекта в Altium Designer

Для работы над управляемым проектом вы извлекаете его как локальную рабочую копию. Это выполняется непосредственно из Altium Designer с помощью команды File » Open Project. Будет открыто диалоговое окно Open Project, в котором вы можете выбрать, какой управляемый проект необходимо открыть из Altium Concord Pro (когда вы вошли в Concord Pro, сервер появится в области Locations диалогового окна, с именем, заданным этому серверу). В списке будут приведены только те управляемые проекты, которые были опубликованы вам (для доступа к которым у вас есть права), и из всех управляемых проектных репозиториев, которые опубликованы вам.

После того, как проект открыт, он появится под записью сервера Concord Pro в панели Projects.

В Altium Designer выберите, какой доступный вам управляемый проект необходимо открыть.

Вы можете открыть проект в папку извлечения по умолчанию либо использовать выпадающее меню  для указания пользовательского пути. Путь к папке извлечения по умолчанию определен в поле Document Path на странице System - Default Locations диалогового окна Preferences.
При просмотре проекта через панель Explorer Altium Designer, которая по умолчанию отображается в виде Project View, а не Classic View, нажмите кнопку  в правой верхней части панели, чтобы открыть проект в Altium Designer (добавить его в панель Projects).

Редактирование управляемого проекта

Для изменения свойств проекта в Altium Concord Pro выберите его запись на странице Projects и нажмите кнопку . В открывшемся окне Edit Project вы можете изменить имя (Name), описание (Description) и серверные параметры (Parameter) проекта. Пары имен и значений параметров можно добавлять (), изменять и удалять ().

Это также доступно в режиме предварительного просмотра страницы Projects – выберите плитку нужного проекта, затем нажмите  и выберите команду Edit из контекстного меню.

Вы можете изменить имя (Name), описание (Description) и серверные параметры (Parameters) управляемого проекта на любом этапе.

Параметры управляемого проекта сохраняются на сервере Concord Pro с проектом, и их можно изменить на сервере. Напротив, параметры проекта хранятся в файле проекта (*.PrjPcb), и их можно изменить в Altium Designer. Параметры обоих типов могут использоваться в Altium Designer в качестве специальных строк – откройте панель Properties, когда размещенный объект Text String выделен в рабочей области. Параметры, заданные для проекта, также можно просмотреть на вкладках Parameters и Server Parameters диалогового окна Project Options (Project » Project Options).

Нажмите Show additional fields, чтобы отобразить прочие поля проекта, которые лишь предоставляют информацию и не доступны для редактирования.

Дополнительные поля, доступные только для чтения, которые отображают информацию о том, где проект находится в структуре папок Concord Pro, его тип и в каком проектном репозитории он хранится.

Нажмите кнопку , чтобы подтвердить изменения.

При просмотре проекта через панель Explorer Altium Designer, которая по умолчанию отображается в виде Project View, а не Classic View, проект можно изменить, нажав кнопку  и выбрав команду Edit из соответствующего меню.

Клонирование управляемого проекта

Чтобы клонировать существующий управляемый проект, выберите его запись на странице Projects, нажмите кнопку  и выберите команду Clone из соответствующего меню. Будет открыто окно Clone Project.

Это также доступно в режиме предварительного просмотра страницы Projects – выберите плитку нужного проекта, затем нажмите  и выберите команду Clone из контекстного меню.

Вы можете клонировать управляемый проект для создания его идентичной копии, а также его рабочих файлов.

Используйте это окно для определения имени, описания и пути хранения клонированного проекта. По умолчанию будет использоваться имя оригинального проекта с суффиксом ' - Copy'.

Клонированный проект будет создан в том же проектом репозитории, что и оригинальный проект – вы не можете изменить это в рамках процесса клонирования.

После настройки полей необходимым образом нажмите кнопку  – оригинальный проект и входящие в него файлы и данные будут клонированы, и этот проект будет добавлен в список страницы Projects.

Клонирование управляемого проекта в Altium Designer

Чтобы клонировать управляемый проект в Altium Designer, щелкните ПКМ по записи этого проекта в панели Projects и выберите команду Clone из контекстного меню. Используйте диалоговое окно Clone Project, чтобы определить имя проекта (Project Name), описание (Description, не заполняется автоматически) и пути к папке Concord Pro (Folder) и к рабочей копии (Local Storage).

Клонирование управляемого проекта в Altium Designer.

При просмотре проекта через панель Explorer Altium Designer, которая по умолчанию отображается в виде Project View, а не Classic View, проект можно клонировать, нажав кнопку  в верхней правой части панели.

Удаление управляемого проекта

Чтобы удалить существующий управляемый проект с сервера Altium Concord Pro, выберите его запись на странице Projects, нажмите кнопку  и выберите команду Delete из соответствующего меню. Нажмите кнопку  в открывшемся диалоговом окне Confirmation, чтобы подтвердить удаление.

Это также доступно в режиме предварительного просмотра страницы Projects – выберите плитку нужного проекта, затем нажмите  и выберите команду Delete из контекстного меню.

Удаление управляемого проекта из Altium Concord Pro.

При просмотре проекта через панель Explorer Altium Designer, которая по умолчанию отображается в виде Project View, а не Classic View, проект можно удалить, нажав кнопку  и выбрав команду Remove из соответствующего меню.
Это действие сделает проект неуправляемым. Проект будет удален только с сервера Concord Pro – локальная рабочая копия не будет затронута.

Обратите внимание, что когда вы удалили проект, его папка и объект (Project Item) останутся в структуре папок Concord Pro, что можно увидеть на странице Explorer веб-интерфейса. Если вы хотите снова использовать имя этого проекта, необходимо удалить объект проекта и его папку (через контекстное меню), именно в таком порядке.

Если вы хотите выполнить это действие, убедитесь, что сначала удален проект, как описано выше, перед удалением объектов на странице Explorer.

Чтобы использовать имя проекта повторно, сначала необходимо удалить объект проекта, а затем его папку.

Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Concord Pro

Заполните форму ниже, чтобы получить бесплатную пробную версию Altium Concord Pro