Altium Designer Documentation

Altium Concord Pro - Управляемые проекты

Created: 30.07.2019 | Updated: 31.07.2019

Главная страница: Altium Concord Pro

Программное обеспечение Altium для проектирования в сочетании с Altium Concord Pro обеспечивает поддержку управляемых проектов (Managed Projects). Для управляемых проектов определяется этап жизненного цикла, что упрощает создание и текущий рабочий процесс для проектов в системе контроля версий. Централизованное хранение под управлением Concord Pro также позволяет этой функциональной возможности быть основой других служб для совместной работы.

Ключевые преимущества использования управляемых проектов:

  • Упрощенное хранение. Нет необходимости принимать решения о месте хранения. Поддерживаются резервное копирование и прочие базовые службы.
  • Основа других служб для совместной работы.
  • Контроль версий.
  • Специальная система комментирования.
  • Уведомления и состояния. Состояние документа, в том числе локальные изменения, видимы всей проектной группе.
  • Одновременная работа над проектом платы без необходимости в сложной настройке.

Технически, управляемый проект является сочетанием мета-информации, которая хранится на сервере, вместе с тесной интеграцией с локальной службой Version Control Altium Concord Pro. Типовой рабочий процесс:

  1. Пользователь создает новый управляемый проект (через диалоговое окно Create Project в ПО Altium для проектирования, таком как Altium Designer, из веб-интерфейса Concord Pro или путем преобразования существующего проекта в ПО для проектирования). В процессе создания проекта, пользователь определяет имя проекта, его описание и проектный репозиторий.
  2. В веб-интерфейсе Concord Pro или непосредственно в ПО Altium для проектирования определяется доступ к проекту.
  3. Все сотрудники выбирают проект на открытие (из ПО для проектирования или из веб-интерфейса Concord Pro), после чего он автоматически извлекается.
Преимуществом управляемых проектов является то, что они по умолчанию находятся под управлением контроля версий, и совместную работу над ними можно осуществлять, не беспокоясь об общих дисках, серверах, соглашениях и т.д.
Перед созданием нового управляемого проекта или преобразованием существующего неуправляемого проекта убедитесь, что существует проектный репозиторий для сохранения в него этого и всех будущих проектов. Управление проектными репозиториями, как правило, осуществляется в Altium Concord Pro, с помощью его локальной службы Version Control. Новая установка Altium Concord Pro предоставляет один проектный репозиторий Git (Versioned Storage) для хранения всех управляемых проектов. Если вы обновили Altium Concord Pro с Altium NEXUS Server 1.0 (или Altium Vault 3.0), то будет также доступно использование репозиториев SVN, соответственно, вы сможете продолжить использовать рабочий процесс, применяемый ранее. В этом случае вы можете продолжить создавать репозитории с помощью локальной службы Version Control (только SVN) или подключаться ко внешним репозиториям (SVN или Git).

Создание нового управляемого проекта

Существует три способа создания управляемого проекта:

  • Создание нового проекта в Altium Designer.
  • Создание нового проекта в веб-интерфейсе Altium Concord Pro.
  • Преобразование существующего неуправляемого проекта в Altium Designer.

Эти способы рассмотрены более подробно в разделах ниже.

Через Altium Designer

Новый управляемый проект может быть создан в Altium Designer с помощью диалогового окна Create Project (File » New » Project):

  1. Выберите запись сервера Concord Pro из списка LOCATIONS (здесь будет отображено имя, указанное на странице Admin - General веб-интерфейса Concord Pro) – чтобы эта опция была доступа, должен быть осуществлен вход в Concord Pro.
  2. Введите имя проекта (Project Name) и, опционально, описание проекта (Description).
    Имя проекта должно начинаться с A-Z, a-z или 0-9, и оно может содержать эти символы. Допустимы подчеркивания, дефисы и пробелы, но пробелы могут быть только в середине имени (пробелы в начале и в конце будут игнорироваться). Вы не можете использовать следующие слова: AUX, COM1-COM9, LPT1-LPT9, CON, NUL и PRN. Кроме того, имя не может содержать следующие символы: \ . / ? % * : | " < >.
  3. В поле Repository будет приведен список всех проектных репозиториев, управляемых локальной службой Version Control в Concord Pro, которые были опубликованы для вас. Выберите репозиторий, в котором необходимо хранить новый проект и его файлы.
  4. Используйте поле Folder для определения папки в структуре Concord Pro, которая будет создана для проекта. Путь по умолчанию для новых проектов Concord Pro указывается на странице Admin - Settings - Projects веб-интерфейса Concord Pro.
  5. Используйте поле Local Storage для определения расположения хранения проекта на жестком диске перед его фиксацией в центральном проектном репозитории. Расположение по умолчанию определяется на странице System - Default Locations диалогового окна Preferences.
  6. Используйте кнопку для добавления параметров (пар их имен и значений) в списке Parameters. Эти параметры управляемого проекта сохраняются на сервере Concord Pro с новым проектом, и их можно изменить на сервере. Напротив, параметры проекта хранятся в файле проекта (*.PrjPcb), и их можно изменить в Altium Designer. Параметры обоих типов могут использоваться в качестве специальных строк в Altium Designer.

Настройка создания нового управляемого проекта в Altium Concord Pro с помощью диалогового окна Create Project. Обратите внимание, что в поле Repository вам будут доступны для выбора только те проектные репозитории, которые были опубликованы для вас.Настройка создания нового управляемого проекта в Altium Concord Pro с помощью диалогового окна Create Project. Обратите внимание, что в поле Repository вам будут доступны для выбора только те проектные репозитории, которые были опубликованы для вас.

После нажатия новый проект будет создан локально, в соответствии с заданным путем Local Storage. Проект будет открыт в панели Projects, в которой будет показано, что проект запланирован на добавление (Scheduled for addition), что обозначено иконкой синего перекрестия ().

Проект появится в панели Projects в записи для целевого сервера, где отражено имя этого сервера – в данном случае, Altium Concord Pro.

Щелкните ПКМ по проекту в панели Projects и выберите команду Commit Project или Version Control » Commit Whole Project. Будет открыто диалоговое окно Commit to Version Control. Выберите файлы, которые вы хотите зафиксировать в проектном репозитории, и нажмите Commit and Push (или Commit для целевого репозитория SVN). После добавления проекта, в панели Projects будет отражено, что файлы в репозитории и локальная рабочая копия полностью синхронизированы.

Фиксация нового управляемого проекта в целевом проектном репозитории.Фиксация нового управляемого проекта в целевом проектном репозитории.

Кроме того, запись проекта появится на странице Projects веб-интерфейса Concord Pro.

Новый управляемый проект, отображаемый на странице Projects.Новый управляемый проект, отображаемый на странице Projects.

Проект будет изначально опубликован с правами на чтение/запись проектировщику, который создал его, и всем администраторам сервера Concord Pro. Кроме того, он будет доступен всем только для чтения, что означает, что все пользователи сервера Concord Pro смогут просматривать этот проект. Для получения более подробной информации по настройке прав доступа перейдите в раздел Публикация управляемого проекта.

Через веб-интерфейс Concord Pro

Управляемый проект может быть создан непосредственно через веб-интерфейс Altium Concord Pro:

  1. Войдите в интерфейс и откройте страницу Projects. Все созданные ранее проекты будут приведены в списке на этой странице.
  2. Нажмите кнопку в верхней правой части страницы. Будет открыто окно Add Project.
  3. Окно будет изначально открыто в упрощенном виде. Введите имя проекта, описание (если необходимо) и выберите шаблон управляемого проекта, если он существует на сервере.
    Имя проекта должно начинаться с A-Z, a-z или 0-9, и оно может содержать эти символы. Допустимы подчеркивания, дефисы и пробелы, но пробелы могут быть только в середине имени (пробелы в начале и в конце будут игнорироваться). Вы не можете использовать следующие слова: AUX, COM1-COM9, LPT1-LPT9, CON, NUL и PRN. Кроме того, имя не может содержать следующие символы: \ . / ? % * : | " < >.
  4. Чтобы получить доступ к дополнительным элементам управления, перейдите в расширенный вид окна, нажав Show additional fields. Будут представлены следующие поля:
    1. Server (Vault) Folder (Папка сервера (хранилища)) – используйте это поле, чтобы указать, где в структуре папок Concord Pro будет создана папка проекта. По умолчанию это папка Projects\<ИмяПроекта>. Путь по умолчанию к папке для новых проектов указан на странице Admin - Settings - Projects веб-интерфейса Concord Pro.
    2. Project Type (Тип проекта) – используйте это поле, чтобы указать тип проекта из списка всех типов проектов, поддерживаемых Altium Concord Pro. Если вы выбрали шаблон управляемого проекта, это поле не будет отображаться.
    3. Repository (Репозиторий) – в этом поле приведен список всех проектных репозиториев, управляемых локальной службой Version Control сервера и доступных вам для использования. Выберите репозиторий, в котором необходимо хранить новый проект и его файлы. По умолчанию будет выбран репозиторий Versioned Storage (на основе Git).
    4. Repository Folder (Папка репозитория) – используйте это поле для указания имени папки в репозитории, в котором будут размещены проект и связанные с ним файлы. По умолчанию папке будет задано имя проекта. Если выбран репозиторий Versioned Storage (на основе Git), это поле не будет отображаться.

Определение нового управляемого проекта непосредственно через веб-интерфейс сервера.Определение нового управляемого проекта непосредственно через веб-интерфейс сервера.

После определения нового проекта необходимым образом нажмите – новый проект будет создан. Изначально будет открыта страница подробной информации о проекте (подробнее об этом ниже). Нажмите Projects в дереве навигации, чтобы вернуться к общему списку управляемых проектов, где теперь будет отображаться новый проект.

Новый управляемый проект был создан через веб-интерфейс. Нажмите Projects в дереве навигации, чтобы вернуться из подробной информации о проекте к общему списку проектов.Новый управляемый проект был создан через веб-интерфейс. Нажмите Projects в дереве навигации, чтобы вернуться из подробной информации о проекте к общему списку проектов.

Проект будет изначально опубликован с правами на чтение/запись проектировщику, который создал его, и всем администраторам сервера Concord Pro. Кроме того, он будет доступен всем только для чтения, что означает, что все пользователи сервера Concord Pro могут просматривать этот проект. Для получения более подробной информации по настройке прав доступа перейдите в раздел Публикация управляемого проекта.

Преобразование существующего неуправляемого проекта

Вы можете создать управляемый проект путем преобразования существующего неуправляемого проекта. Для этого откройте существующий неуправляемый проект в Altium Designer как обычно, щелкните по нему ПКМ в панели Projects и выберите команду Convert to Managed Project из контекстного меню.

Если проект находится под управлением контроля версий в локальном репозитории, он не может быть преобразован напрямую. Будет отображено сообщением об этом, с возможностью преобразования проекта в обычный, игнорируя ревизии SVN и лог изменений, и последующим преобразованием этого обычного проекта в управляемый.

 

Команда Convert to Managed Project откроет диалоговое окно Convert to Managed Project, в котором вы определяете имя проекта и его описание. По умолчанию будет использоваться имя изначального (исходного) проекта.

Прочие настройки доступны при открытии параметров Advanced:

  • Целевой проектный репозиторий, управляемый через сервер Altium Concord Pro, в который вы вошли. Выберите из доступных вам проектных репозиториев, которые определены с помощью службы Version Control сервера (на странице VCS (Admin - VCS) веб-интерфейса). По умолчанию будет выбран репозиторий Versioned Storage (на основе Git). Обратите внимание, что при преобразовании проекта типа VCS, если этот проект уже существует в проектом репозитории SVN, предоставленном сервером, то будет использоваться тот же самый репозиторий – вы не сможете выбрать другой репозиторий.
  • Будут показаны путь и директория репозитория, причем директория не доступна для редактирования, если выбран репозиторий Versioned Storage (на основе Git). По умолчанию в репозитории будет создана папка с тем же именем, что и у проекта.
  • Будет также показан путь к локальной рабочей копии VCS проекта (Working Copy Path), как определено исходным расположением проекта.
  • Запись Server Folder отображает целевой путь нового проекта в структуре папок сервера. По умолчанию это будет Projects\<ИмяПроекта>, но его можно изменить. Настройка Server Folder также определит расположение, в которое данные проекта будут выпущены при использовании средства Project Releaser в Altium Designer.

Преобразование существующего проекта в управляемый.Преобразование существующего проекта в управляемый.

Когда свойства управляемого проекта определены необходимым образом в диалоговом окне Convert to Managed Project, нажмите OK. Проект и его файлы будут зафиксированы в целевом проектном репозитории, и в панели Projects будет отражено, что файлы в репозитории и локальная рабочая копия полностью синхронизированы.

Новый преобразованный управляемый проект станет доступен на странице Projects веб-интерфейса Concord Pro.

Преобразованный проект добавлен в список управляемых проектов.Преобразованный проект добавлен в список управляемых проектов.

Проект будет изначально опубликован с правами на чтение/запись проектировщику, который преобразовал его, и всем администраторам сервера Concord Pro. Кроме того, он будет доступен всем только для чтения, что означает, что все пользователи сервера Concord Pro могут просматривать этот проект. Для получения более подробной информации по настройке прав доступа перейдите в раздел Публикация управляемого проекта.

Просмотр управляемых проектов

Как упоминалось выше, управляемые проекты доступны для просмотра на странице Projects веб-интерфейса Concord Pro.

Страница Projects веб-интерфейса Concord Pro – центр управления проектами.Страница Projects веб-интерфейса Concord Pro – центр управления проектами.

Для каждого проекта в списке отображается следующая информация:

  • Name (Имя) – имя проекта, вместе с его описанием (если оно задано).
  • Author (Автор) – пользователь, который создал проект.
  • Last modified (Последнее изменение) – дата последнего изменения проекта.
Список управляемых проектов автоматически отсортирован по дате Last modified, где вверху списка отображается проект, который был изменен последним. Список может быть отсортирован по любому из этих столбцов данных – щелкните мышью по заголовку столбца один раз, чтобы отсортировать по возрастанию, и щелкните еще раз, чтобы отсортировать по убыванию.

Для каждого проекта доступны следующие элементы управления (описаны в соответствующих разделах ниже):

Open (Открыть) – открыть проект на странице подробной информации о нем.

Edit (Изменить) – изменить имя (Name) и/или описание (Description) проекта.

Share (Опубликовать) – открыть элементы управления для настройки прав доступа к проекту.

Remove (Удалить) – удалить проект с сервера.

Страница подробной информации о проекте

Щелкните мышью по элементу управления Open (), связанному с проектом, или щелкните мышью по имени проекта, чтобы открыть страницу подробной информации об этом проекте.

Доступ к странице подробной информации о проекте.Доступ к странице подробной информации о проекте.

Эту страницу проекта можно также открыть из Altium Designer через панель Explorer. Это вид по умолчанию, доступный после выпуска проекта на сервер Concord Pro. Если вы просматриваете связанные с проектом объекты на виде Classic View панели, вы можете переключиться на подробный вид, нажав кнопку в правой верхней части панели и выбрав Project View из контекстного меню.

На странице подробной информации о проекте доступны следующие вкладки:

  • Parameters (Параметры) – список параметров (в виде пар имен и значений), связанных с управляемым проектом и сгруппированных под заголовками трех типов параметров:
    • Project file (Файл проекта) – параметры, которые хранятся в файле проекта (*.PrjPCB), которые могут быть добавлены/изменены через панель Project Options в Altium Designer.
    • Managed project (Управляемый проект) – параметры, которые хранятся с управляемым проектом на сервере и которые могут быть добавлены в диалоговом окне Create Project в Altium Designer либо могут быть добавлены/изменены при редактировании проекта в веб-интерфейсе сервера.
    • Analytics (Аналитика) – параметрические данные, которые автоматически извлечены сервером Concord Pro из управляемого проекта.

    Проектные и серверные параметры доступны для использования в Altium Designer в качестве специальных строк – откройте панель Properties, когда размещенный объект Text String выделен в рабочей области. Параметры, заданные для проекта, также можно просмотреть на вкладках Parameters и Server Parameters диалогового окна Project Options (Project » Project Options).
  • Preview (Предварительный просмотр) – интерактивный графический предварительный просмотр исходных данных проекта. Изменяйте масштаб, панорамируйте и дважды щелкайте мышью по элементам в главном окне предварительного просмотра для навигации по проекту.

  • Part List (Список компонентов) – простой список всех управляемых компонентов в проекте, автоматически извлеченный из исходных данных проекта сервером Concord Pro. Здесь приведены идентификаторы объектов (Item ID) и состояния ревизии каждого серверного компонента, используемого в проекте.

  • Working files (Рабочие файлы) – исходные файлы проекта, которые можно загрузить в едином архиве Zip.

  • Releases (Выпуски) – представляет все выпуски проекта, где самый новый выпуск отображается вверху списка. Каждая запись слева отображает метку даты/времени выпуска, а также пакеты, которые включены в этот выпуск. Используйте поле Search, чтобы быстро найти определенный выпуск (очень полезно, если проект был выпущен множество раз).

    Если вы щелкнете мышью по какой-либо записи с общей информацией о выпуске слева, на вкладках справа будет отображена информация, относящаяся к этому выпуску:

    Графическое представление того, как сформированные данные связаны между собой в рамках родительского проекта для выбранного выпуска. Щелкните мышью по ссылке, чтобы открыть соответствующую ревизию объекта на странице Explorer веб-интерфейса сервера Concord Pro. Также отображена дата и время выпуска, кем проект был выпущен и ревизия VCS.

    Список параметрических данных выбранного проекта, в том числе параметры, сформированные системой, и все заданные проектные и серверные параметры.

    Интерактивный графический просмотр выпущенных исходных данных проекта, где все проектные файлы доступны для выбора в дереве Navigator.

    Простой список всех управляемых компонентов в выпущенном проекте, с их идентификаторами объектов (Item ID) и состояниями ревизии каждого компонента, который содержится на сервере Concord Pro.

    Обратите внимание, что этот список отображает все компоненты в выпущенном проекте, независимо от вариантов сборки, созданных в этом выпуске. Иными словами, список не отфильтрован по вариантам. Этот список не является заменой BOM – для этих целей используйте ActiveBOM привычным образом.

    Выбранный в данный момент выпуск можно загрузить, нажав справа от вкладки. Будет открыто окно, с помощью которого вы можете указать, какие данные необходимо включить в загрузку (например, пакеты исходных данных, данных для изготовления и данных для сборки).

    Настройка пакетов, необходимых для включения в загрузку выбранного выпуска управляемого проекта.

    После настройки загрузки необходимым образом с помощью флажков нажмите кнопку . Архив будет загружен в папку загрузок по умолчанию браузера (с именем в формате: SRC-<ИмяПРоекта>-<РевизияВыпуска>(<ВключенныеПакеты>).zip, например SRC-Bluetooth_Sentinel-A.2(fab,src,pcba).zip. Он содержит отдельные архивы пакетов, выбранных для загрузки.

  • Stream (Поток) – данные последовательных событий с информацией о недавней активности проекта.

Функции проекта

Для представленного проекта доступен ряд дополнительных элементов управления:

  • VCS Location (Расположение VCS) – URL к проекту в его родительском проектном репозитории. Для проекта, который хранится в проектом репозитории SVN, щелкните мышью по этой ссылке, чтобы открыть проектный репозиторий, в котором находится проект, во внешнем клиенте SVN.
  • – щелкните мышью по этой кнопке, чтобы открыть проект в Altium Designer (путем открытия файла X2.exe). Если ПО для проектирования уже запущено, проект будет открыт в этой инстанции.
  • Меню – выберите это меню, чтобы отобразить дополнительные функции для выпущенного проекта, в том числе:
    • Edit (Изменить) – выберите, чтобы открыть окно Edit Project. Отсюда вы можете изменить имя (Name), описание (Description) и серверные параметры (Parameters) проекта. Все прочие поля не доступны для редактирования, они лишь предоставляют информацию.
    • Share (Опубликовать) – выберите, чтобы открыть окно Manage Permissions, в котором находятся все элементы управления, необходимые для публикации проекта другим пользователям. Для получения более подробной информации перейдите в раздел Публикация управляемого проекта.
    • Clone (Клонировать) – выберите, чтобы открыть окно Clone Project, в котором находятся элементы управления для создания идентичной копии проекта. Для получения более подробной информации перейдите в раздел Клонирование управляемого проекта.
    • Watch (Отслеживать) – выберите для отслеживания проекта. Вы будете получать соответствующие уведомления, касающиеся проекта (например, при его обновлении, выпуске, изменении прав доступа), на вкладке Stream, а также на главных страницах Home и Stream веб-интерфейса. Создатель проекта автоматически отслеживает проект. Выберите эту опцию еще раз, чтобы отключить отслеживание проекта и получение уведомлений.
    • Remove (Удалить) – выберите, чтобы удалить проект из репозитория и сделать его неуправляемым. Если вы извлекли проект локально, у вас все еще останется эта локальная рабочая копия.

Обновление проектных данных

Когда проект изменяется извне, например, после редактирования в ПО Altium для проектирования и фиксации этих изменений в Concord Pro, сервер автоматически повторно обработает проектные данные для обновления подробной информации, такой как параметры и извлеченный список компонентов.

После того, как изменение проекта было зафиксировано на сервере, на странице подробной информации о проекте может быть отображен процесс обновления данных. По его завершении будет отображено сообщение с запросом на обновление вида для отображения новых данных – нажмите ссылку refresh или клавишу F5, чтобы обновить страницу.

Публикация управляемого проекта

Если проект является управляемым, вы можете определить, у каких пользователей есть доступ к этому проекту. Это осуществляется путем публикации проекта, т.е. настройкой прав доступа к нему. Помните, что управляемый проект, созданный или преобразованный, по умолчанию опубликован для следующих лиц:

  • Проектировщику, который создал (преобразовал) проект: полные (на чтение/запись) права доступа.
  • Участникам роли Administrators: полные (на чтение/запись) права доступа.
  • Всем, что обозначено наличием записи Public: права только на чтение.

Настройка прав доступа может быть выполнена через веб-интерфейс Concord Pro, а также непосредственно в Altium Designer.

Через веб-интерфейс сервера

Для настройки доступа к проекту из веб-интерфейса Concord Pro щелкните мышью по соответствующему элементу управления Share () на странице Projects.

Это также можно сделать нажатием кнопки на странице подробной информации о проекте.

Будет открыто диалоговое окно Manage Permissions, в котором находятся все элементы управления, необходимые для публикации проекта другим пользователям.

Когда проект централизованно управляется сервером Concord Pro, его публикация другим пользователям осуществляется путем настройки прав доступа к этому проекту.Когда проект централизованно управляется сервером Concord Pro, его публикация другим пользователям осуществляется путем настройки прав доступа к этому проекту.

Что следует иметь в виду:

  • С точки зрения прав доступа, у пользователя/роли есть права на чтение/запись, когда включен параметр Can Write. Если этот параметр отключен, у пользователя/роли есть только права на чтение.
  • Чтобы удалить существующего пользователя/роль из доступа к проекту, щелкните мышью по соответствующему элементу управления Remove ().
  • По умолчанию все пользователи сервера Concord Pro могут видеть проект. Если вы хотите предоставить доступ только определенным пользователям и/или ролям, запись Public необходимо удалить.
  • Если вы удалили запись Public, ее можно добавить обратно с помощью элемента управления Add Public. Имейте в виду, что при этом по умолчанию всем пользователям Concord Pro будут предоставлены права на чтение/запись проекта.

Чтобы опубликовать проект другому пользователю Concord Pro:

  1. Щелкните мышью по элементу управления Add User в окне Manage Permissions.

  2. В открывшемся окне Add Users начните вводить полное имя, имя пользователя или email пользователя Altium Concord Pro в поле Select Users to be added, чтобы отобразить список соответствующих пользователей. Выберите нужного пользователя из списка. Можно выбрать множество пользователей. Чтобы удалить пользователя, нажмите перекрестие справа от его имени.

  3. Задайте права доступа для пользователей с помощью поля Permission. Используйте выпадающее меню для выбора между доступом на чтение (Read) или на чтение/запись (Read/Write).

  4. Когда настройки выполнены, нажмите кнопку , чтобы сохранить добавление пользователей и вернуться в окно Manage Permissions.

  5. Нажмите кнопку в окне Manage Permissions.
Чтобы изменить права доступа существующего пользователя, используйте параметр Can Write в окне Manage Permissions, для переключения между доступом на чтение/запись (включено) или только на чтение (выключено).

У вас также есть возможность публиковать проект группе, заданной на сервере Concord Pro. Чтобы опубликовать проект группе:

  1. Щелкните мышью по элементу управления Add Group в окне Manage Permissions.

  2. В открывшемся окне Add Groups начните вводить имя группы в поле Select Groups to be added, чтобы отобразить список соответствующих групп. Выберите нужную группу из списка. Можно выбрать множество групп. Чтобы удалить группу, нажмите перекрестие справа от ее имени.

  3. Задайте права доступа для групп с помощью поля Permission. Используйте выпадающее меню для выбора между доступом на чтение (Read) или на чтение/запись (Read/Write).

  4. Когда настройки выполнены, нажмите кнопку , чтобы сохранить добавление ролей и вернуться в окно Manage Permissions.

  5. Нажмите кнопку в окне Manage Permissions.
Чтобы изменить права доступа существующей роли, используйте параметр Can Write в окне Manage Permissions, для переключения между доступом на чтение/запись (включено) или только на чтение (выключено).

Через Altium Designer

Доступ к проекту может быть настроен непосредственно в Altium Designer с помощью команды Project Permissions. Доступ к этой команде может быть осуществлен для активного проекта или для проекта в фокусе:

  • Активный проект – когда какой-либо документ проекта открыт в качестве активного документа, выберите команду Project » Project Permissions из главного меню.
  • Проект в фокусе – доступ осуществляется из панели Projects щелчком ПКМ по записи требуемого проекта и выбором команды Project Permissions из контекстного меню.

Будет открыто диалоговое окно Permissions For - <ИмяПроекта>, в котором вы можете настроить публикацию необходимым образом. Используйте меню Add диалогового окна, чтобы выбрать тип публикации, который вы хотите применить (для пользователя, роли и т.д.), и затем выберите необходимую запись в открывшемся диалоговом окне Search for User/Role.

Настройка доступа к управляемому проекту непосредственно из Altium Designer.Настройка доступа к управляемому проекту непосредственно из Altium Designer.

Открытие управляемого проекта

Для работы над управляемым проектом вы извлекаете его как локальную рабочую копию. Это можно выполнить двумя путями:

  • Непосредственно из Altium Designer – используйте команду File » Open Project. Будет открыто диалоговое окно Open Project, в котором вы можете выбрать, какой управляемый проект необходимо открыть из Altium Concord Pro. В списке будут приведены только те управляемые проекты, которые были опубликованы вам (для доступа к которым у вас есть права), и из всех управляемых проектных репозиториев, которые опубликованы вам.

    В Altium Designer выберите, какой доступный вам управляемый проект необходимо открыть.В Altium Designer выберите, какой доступный вам управляемый проект необходимо открыть.

    Вы можете открыть проект в папку извлечения по умолчанию или использовать выпадающее меню  для указания пользовательского пути. Путь к папке извлечения по умолчанию определен в поле Document Path на странице System - Default Locations диалогового окна Preferences.
  • На странице Projects веб-интерфейса Concord Pro – щелкните мышью по элементу управления Open (Доступ к элементу управления для открытия управляемого проекта со страницы подробной информации о проекте веб-интерфейса Concord Pro.), связанному с проектом. На странице подробной информации о проекте нажмите кнопку Доступ к элементу управления для открытия управляемого проекта со страницы подробной информации о проекте веб-интерфейса Concord Pro..
    Команда веб-интерфейса на открытие проекта, активированная кнопкой , откроет ПО Altium для проектирования путем доступа к его исполняемому файлу – x2.exe. Выбранный проект будет открыт в запущенной инстанции, либо будет запущен последний использованный интерфейс.

    Доступ к элементу управления для открытия управляемого проекта со страницы подробной информации о проекте веб-интерфейса Concord Pro.Доступ к элементу управления для открытия управляемого проекта со страницы подробной информации о проекте веб-интерфейса Concord Pro.

Редактирование управляемого проекта

Для изменения свойств управляемого проекта на более поздней стадии, щелкните мышью по соответствующему элементу управления Edit ().

Это также можно сделать, выбрав опцию Edit из меню на странице подробной информации о проекте.

Будет открыто окно Edit Project. Отсюда вы можете изменить имя (Name), описание (Description) и серверные параметры (Parameters) проекта. Все прочие поля не доступны для редактирования, они лишь предоставляют информацию.

Вы можете изменить имя (Name), описание (Description) и серверные параметры (Parameters) управляемого проекта на любом этапе.Вы можете изменить имя (Name), описание (Description) и серверные параметры (Parameters) управляемого проекта на любом этапе.

Клонирование управляемого проекта

Чтобы клонировать существующий управляемый проект, перейдите на страницу подробной информации о нем и выберите опцию Clone из меню . Будет открыто окно Clone Project.

Вы можете клонировать управляемый проект для создания его идентичной копии, а также его рабочих файлов.Вы можете клонировать управляемый проект для создания его идентичной копии, а также его рабочих файлов.

Используйте это окно для определения имени, описания и пути хранения клонированного проекта. По умолчанию будет использоваться имя оригинального проекта с суффиксом ' - Copy'.

Клонированный проект будет создан в том же проектом репозитории, что и оригинальный проект – вы не можете изменить это в рамках процесса клонирования.

После настройки полей необходимым образом нажмите кнопку – оригинальный проект будет клонирован, и этот клон будет открыт на вкладке Parameters страницы подробной информации о проекте.

Удаление управляемого проекта

Чтобы удалить управляемый проект, щелкните мышью по соответствующему элементу управления Remove () на странице списка проектов Projects.

Другой способ – на странице подробной информации о проекте выберите опцию Remove из меню .
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: