Altium NEXUS Documentation

Определение областей проводящего материала и управление ими_AD

Содержание

Полное содержание

Зачастую на печатных платах необходимы большие участки проводящего материала. Это может быть сетчатая область земли в аналоговом проекте, большая сплошная область для доставки высоких токов питания или сплошная область земли для экранирования от электромагнитных помех. В Altium NEXUS области проводящего материала могут быть определены с помощью трех различных проектных объектов: Fill (заполнения), Solid Region (сплошные регионы) и Polygon Pour (заливки полигоном). Преимуществом полигонов является автоматическая заливка вокруг проводящих объектов, которые принадлежат другим цепям, в соответствии с применимыми правилами проектирования Electrical Clearance и Polygon Connect Style.

Заливки полигоном и проводящие регионы

Заполнения и сплошные регионы

Пример выделенного сплошного региона.
Пример выделенного сплошного региона.

Заполнение (Place » Fill) – это прямоугольный проектный объект, который может быть размещен на любом слое, в том числе проводящем (сигнальном). Форма заполнений может быть только прямоугольной, и они не обходят другие объекты, такие как контактные площадки, переходные отверстия, трассы, регионы, другие заполнения и текст. Если заполнение размещено на сигнальном слое, его можно подключить к цепи.

Регион (Place » Solid Region) – это проектный объект, используемый для определения полигональных областей. Сплошной регион, или Solid Region (который обычно называют просто регионом, или Region), может быть размещен на любом слое, в том числе сигнальном (проводящем). Подобно заполнению, регион не обходит другие объекты, такие как контактные площадки, переходные отверстия, трассы, заполнения, другие регионы и текст. Если регион размещен на сигнальном слое, его можно подключить к цепи.

У региона есть ряд специальных свойств, которые позволяют его использовать для следующих целей:

  • Вырезы в полигоне – регион становится, по сути, отрицательным (пустым) объектом, вокруг которого происходит заливка полигоном.
  • Вырезы в плате – регион также становится отрицательным (пустым) объектом для определения выреза или отверстия нестандартной формы в плате.
  • Контактные площадки нестандартной формы – регион определяет проводящую область контактной площадки нестандартной формы, что дает возможность автоматически определить более широкие/узкие вскрытия и участки соответствующей формы на слоях паяльной маски и паяльной пасты.

Заливки полигоном

Сплошной и сетчатый полигоны, демонстрирующие различные зазоры и стили подключения.    Сплошной и сетчатый полигоны, демонстрирующие различные зазоры и стили подключения.
Сплошной и сетчатый полигоны, демонстрирующие различные зазоры и стили подключения.

Заливки полигоном (или просто полигоны) используются для создания проводящих областей на плате.

Заливка полигоном (Place » Polygon Pour), размещенная на сигнальном слое, создает полигональную (многоугольную) область меди, которая может быть сплошной или сетчатой. При заливке полигоны автоматически учитывают зазоры вокруг электрических объектов, принадлежащих другим цепям, подключаются к объектам той же цепи и заполняют области нестандартной формы. Зазоры и свойства подключений управляются применимыми правилами проектирования Electrical Clearance и Polygon Connection Style.

Размещение заливки полигоном

Выберите команду Place » Polygon Pour из главного меню для размещения полигона на текущем слое в редакторе плат. После запуска команды курсор изменит свой вид на перекрестие и вы перейдете в режим размещения заливки полигоном. Нажмите клавишу Tab, чтобы приостановить размещение и открыть панель Properties в режиме Polygon Pour, где можно выбрать опции заполнения и подключения к цепи.

Режим Polygon Pour панели Properties.Режим Polygon Pour панели Properties.

Для получения информации об объектах Polygon Pour перейдите на эту страницу.

Когда вы размещаете полигон, вы определяете контур объекта полигона. Когда ввод контура завершен, полигон автоматически заполняется в соответствии с режимом заполнения Fill Mode и прочими опциями, выбранными в панели Properties.

Режимы заполнения полигона

Поддерживается три режима заполнения: Solid, Hatched и None.

Solid – когда выбран этот режим, полигон внутренне формируется из сплошных регионов, с отдельным регионом для каждого непрерывного участка меди в завершенном полигоне. Этот тип полигона выводится в Gerber с помощью определений регионов Gerber. Обратите внимание, что в определениях регионов Gerber не поддерживаются круглые вырезы, поэтому дуги (отверстия) для круглых вырезов фактически аппроксимируются хордами. Их точность определяется настройкой Arc Approx. в панели Properties . Полигоны этого типа обычно заливаются быстрее, и в результате получаются файлы плат и Gerber меньшего размера.

Hatched – когда выбран этот режим, полигон формируется из трасс и дуг. При изменении настроек Track Width и Grid Size для трасс/дуг завершенный полигон может выглядеть как сетчатый или сплошной. Полигоны этого типа обычно заливаются медленнее, и в результате получаются файлы плат и Gerber большего размера. Обратите внимание, что контур сетчатого полигона создается из трасс и дуг, центральной линией которых является заданная пользователем граница полигона.

None – это, по сути, тот же режим, что и Hatched. Этот режим может быть полезен, если вы анализируете структуру и конструкцию различных полигонов и хотите понять взаимодействие перекрывающихся полигонов. Этот режим также полезен при внесении проектных изменений, когда полигоны мешают процессу. Другим подходом к использованию контуров при внесении проектных изменений является отключение (Shelve) полигонов – они остаются в файле платы, но скрываются.

Процесс размещения

В редакторе плат Altium NEXUS процесс размещения одинаков для всех полигональных (многоугольных) объектов, таких как сплошной регион, форма платы или полигон. Их границы замкнуты, поэтому независимо от того, на каком этапе размещения вы находитесь, система покажет линию от курсора до начального положения объекта. Эта линия станет последним ребром объекта, когда вы нажмете клавишу Esc (или щелкнете ПКМ) для выхода из режима размещения. Размещение является процессом определения положения углов с помощью различных доступных режимов.

Режимы углов

При размещении полигона доступно пять различных режимов углов: 45º, 45º с дугой, 90º, 90º с дугой и произвольный угол, как показано ниже.

При размещении полигона доступны различные режимы углов. Нажимайте Shift+Пробел для переключения между режимами.    При размещении полигона доступны различные режимы углов. Нажимайте Shift+Пробел для переключения между режимами.

Советы по размещению полигона:

  • Нажимайте Shift+Пробел для перебора режимов углов.
  • Нажмите Пробел для переключения направления угла (доступно для всех режимов, кроме Any Angle).
  • Нажмите Backspace, чтобы удалить угол, размещенный последним.
  • Нажмите Esc или щелкните ПКМ, чтобы выйти из режима размещения, и система завершит полигон.
  • Для режимов углов с дугами размер дуги можно изменить с помощью клавиш "," и ".". Зажмите Shift, чтобы ускорить процесс изменения размера.

Понятие упреждения

При конструировании платы существует множество ситуаций, когда необходима возможность предсказать, как должен пойти сегмент трассы или ребро объекта, без фиксации этого объекта. Для этого Altium NEXUS включает в себя функцию упреждения под названием Look-Ahead. Когда она включена, сегмент трассы/ребро объекта, присоединенное в данный момент к курсору, не размещается при щелчке ЛКМ, а размещается только предыдущий сегмент. Иными словами, последний сегмент позволяет вам предсказать, где будет размещен будущий сегмент.

Нажмите клавишу 1 при размещении объекта для включения и отключения режима упреждения. Обратите внимание, как меняется отображение для каждого режима. При размещении трассы, сегмент, который будет размещен при следующем щелчке ЛКМ, отображен как заштрихованный, а упреждающий сегмент отображен только контуром. При размещении полигонального объекта, ребра, которые будут размещены при следующем щелчке ЛКМ, показаны сплошными белыми линиями, а упреждающее ребро показано пунктирной белой линией.

На изображениях ниже показано, как меняется отображение сегмента трассы при включении и отключении режима упреждения.

Размещение трасс с включенным (первое изображение) и отключенным (второе изображение) режимом упреждения. При следующем щелчке ЛКМ будут размещены заштрихованные сегменты трасс. Размещение трасс с включенным (первое изображение) и отключенным (второе изображение) режимом упреждения. При следующем щелчке ЛКМ будут размещены заштрихованные сегменты трасс.

Упреждение работает и при размещении заливки полигоном. Нажмите клавишу 1 в процессе размещения для его включения и отключения. На изображениях ниже показано размещение первого угла заливки полигоном.

Упреждение включено. При следующем щелчке ЛКМ ребром полигона станет сплошная линия, но не пунктирная линия. Обратите внимание на сплошную возвратную линию – она показывает, как будет замкнут полигон, если вы завершите размещение полигона. Упреждение включено. При следующем щелчке ЛКМ ребром полигона станет сплошная линия, но не пунктирная линия. Обратите внимание на сплошную возвратную линию – она показывает, как будет замкнут полигон, если вы завершите размещение полигона.

Упреждение отключено. При следующем щелчке ЛКМ обе сплошные белые линии станут ребрами полигона. Обратите внимание на сплошную возвратную линию – она показывает, как будет замкнут полигон, если вы завершите размещение полигона. Упреждение отключено. При следующем щелчке ЛКМ обе сплошные белые линии станут ребрами полигона. Обратите внимание на сплошную возвратную линию – она показывает, как будет замкнут полигон, если вы завершите размещение полигона.

Нажмите клавишу 1 для включения и отключения упреждения. Обратите внимание, что эта клавиша работает только при размещении объекта.

Нажмите Shift+F1 при размещении для отображения полного списка сочетаний клавиш команды.

Подключение полигона к цепи

Полигон может быть подключен к цепи. Выберите нужную цепь в выпадающем списке Connect to Net в панели Properties. Заливка полигоном будет подключена ко всем контактным площадкам этой цепи, обнаруженным внутри контура полигона. Подключение полигона к контактным площадкам определяется применимым правилом проектирования Polygon Connect Style. Зазор между полигоном и объектами, принадлежащим другим цепям, определяется применимым правилом проектирования Electrical Clearance.

То, как полигон будет работать с объектами той же цепи, такими как трассы, определяется опцией, выбранной в выпадающем списке Pour Over:

  • Pour Over All Same Net Objects – выберите эту опцию, если вы хотите, чтобы полигон автоматически подключался ко всем объектам той же цепи.
  • Pour Over Same Net Polygons Only – выберите эту опцию (выбрана по умолчанию), если вы хотите, чтобы полигон автоматически подключался только к полигонам той же цепи внутри своих границ.
  • Don't Pour Over Same Net Objects – выберите эту опцию, если вы не хотите, чтобы полигон подключался к любых другим объектам, отличным от контактных площадок, той же (или какой-либо другой) цепи.

Удаление неподключенной меди

После заливки полигона могут образоваться участки (островки) полигона, которые полностью изолированы от подключенной цепи из-за наличия других трасс, контактных площадок и т.д. Чтобы система обнаруживала и удаляла эти изолированные островки меди, включите опцию Remove Dead Copper.

Если полигон размещен на слое, отличном от сигнального, он не будет залит вокруг существующих объектов, поскольку эти объекты не назначены какой-либо цепи и, соответственно, не принадлежат чему-либо.

Управлением стилем подключения полигона

Главная страница: Правило проектирования Polygon Connect Style

То, как полигон будет подключаться к контактным площадкам той же цепи, управляется применимым правилом проектирования Plane » Polygon Connect Style (Design » Rules).

То, как полигон будет подключаться к контактным площадкам той же цепи, определяется правилом проектирования Polygon Connect Style.То, как полигон будет подключаться к контактным площадкам той же цепи, определяется правилом проектирования Polygon Connect Style.

Доступны три опции:

  • Relief Connect – будет создано подключение радиальными лучами. Задайте количество проводников (Number), угол поворота этих проводников (Angle, 90º или 45º), ширину проводников (Conductor Width) и ширину воздушного зазора (Air Gap Width, зазор между краем контактной площадки и краем полигона, окружающего эту контактную площадку).
  • Direct Connect – полигон будет залит поверх контактной площадки, что создаст сплошную медь вокруг вывода.
  • No Connect – контактные площадки цепи будут изолированы от полигона.

Настройка Air Gap Width управляет зазором между краем контактной площадки и окружающим полигоном, но в более ранних версиях Altium NEXUS за это отвечали правила проектирования Electrical Clearance. При открытии платы, созданной в более ранней версии Altium NEXUS, будет отображено предупреждение. В этом случае, важно проверить и задать настройки Air Gap Width в правилах проектирования Polygon Connect Style.

Управление зазором полигона

Подобно другим объекта, размещенным на сигнальном (проводящем) слое, зазор между полигоном и объектами, вокруг которых он залит, управляется применимым правилом проектирования Electrical Clearance.

Зазор от полигона до объектов других цепей управляется правилом проектирования Electrical Clearance.Зазор от полигона до объектов других цепей управляется правилом проектирования Electrical Clearance.

Часто между полигоном и объектами других цепей задают больший зазор. Для этого можно определить правило проектирования Electrical Clearance для полигонов. Пример приведен на изображении выше. Помните, что у правила Polygon Clearance должен быть более высокий приоритет (Priority), чем у общего правила для зазоров, чтобы оно применялось.

При определении правила Electrical Clearance для полигонов необходимо использовать ключевое слово запроса InPolygon (или InPoly), а не IsPolygon (или IsPoly), поскольку правила для зазоров работают с примитивами (регионы, трассы и дуги), из которых состоит полигон, т.е. которые находятся в полигоне, не с полигоном как объектом в целом. Корректным правилом для зазоров будет между объектами в полигоне (InPolygon) и всеми остальными (All) объектами.

 

Перезаливка полигона

Существует ряд способов перезаливки полигона.

Для перезаливки полигона:

  • Дважды щелкните ЛКМ где-либо на полигоне, чтобы открыть панели Properties. Измените настройки нужным образом.
  • Щелкните ПКМ по полигону и выберите команду Repour из меню Polygon Actions.
  • В диалоговом окне Polygon Pour Manager (Tools » Polygon Pours » Polygon Manager) выберите нужный полигон и нажмите кнопку Repour.
  • Используйте нужную команду Repour в меню Tools » Polygon Pours.

Подтвердите изменения в диалоговом окне Confirm.

Для изменения полигона текущим (активным) слоем должен быть слой, на котором находится полигон.

Вырезы в полигонах

Вырез в полигоне (Polygon Pour Cutout) является, по сути, отрицательной областью проводящего материала, с помощью которой можно определить пустой участок или отверстие в полигоне. Чтобы определить вырез в полигоне, выберите команду Place » Polygon Pour Cutout из главного меню, затем с помощью щелчков ЛКМ определите форму выреза. После определения выреза полигон нужно перезалить, после чего он будет залит вокруг заданного выреза. Помните, что вырез фактически является сплошным регионом, и его размер можно изменить, щелкнув ЛКМ один раз, чтобы выделить его, и перетащив с зажатой ЛКМ ребро или вершину. После изменения размера выреза полигон нужно перезалить.

Был размещен вырез (первое изображение), затем полигон был перезалит (второе изображение). Был размещен вырез (первое изображение), затем полигон был перезалит (второе изображение).Был размещен вырез (первое изображение), затем полигон был перезалит (второе изображение).

Создание заливки полигоном из набора трасс

Помимо определения проводящих участков на плате, полигоны и сплошные регионы также используются для определения других проектных объектов полигональной формы, таких как специальный символ или логотип компании. Если нужный контур был определен в другой системе проектирования, например в AutoCAD, его можно экспортировать как файл DXF и импортировать в Altium NEXUS. Этот контур затем можно преобразовать в полигон или сплошной регион.

Для преобразования набора трасс в полигон выделите сегменты трасс и выберите команду Tools » Convert » Create Polygon from Selected Primitives из главного меню.

Обратите внимание на следующее:

  • Полигон будет создан на текущем (активном) слое, а не слое, на котором располагаются выделенные трассы. Это значит, что вы можете определить контур на механическом слое и создать полигон на сигнальном слое.
  • Выделенные трассы не исчезнут после создания полигона и останутся выделенными.
  • Если полигон создан на том же слое, что и выделенные трассы, он будет залит внутри трасс в соответствии с применимым правилом проектирования Electrical Clearance.
  • Полигон будет создан с режимом заливки (Fill Mode) None. Дважды щелкните ЛКМ по нему, чтобы перезалить его с нужным режимом.
Чтобы Altium NEXUS мог выполнить преобразование трасс в полигон, контур должен быть корректно определен. Это значит, что контур должен быть замкнут, с корректным соединением концов трасс (начало/конец в одной точке X, Y).

Перемещение заливки полигоном

Перетащите с зажатой ЛКМ заливку полигоном для ее перемещения. Зажмите клавишу Shift для выделения множества заливок полигоном, которые нужно переместить.

Изменение формы заливки полигоном

Изменение размера полигона с углами 90º с дугами.Изменение размера полигона с углами 90º с дугами.

Вы можете изменить форму существующей заливки полигоном.

Для изменения формы полигона:

  • Щелкните ЛКМ по полигону, чтобы выделить его и подсветить все вершины полигона и изменить курсор на перекрестие.

    • Перетащите с зажатой ЛКМ залитую ручку управления, чтобы переместить соответствующий угол.
    • Перетащите с зажатой ЛКМ ребро, чтобы переместить ребро полностью.
    • Перетащите с зажатой ЛКМ незалитую ручку управления, чтобы переместить всю сторону (для трассы и дуги).
    • Ctrl+ЛКМ по незалитой ручке управления, чтобы разбить это ребро на два. Зажать Ctrl необходимо только в начале перемещения. Для перебора режимов (дуга, скос, произвольный угол) используйте сочетание клавиш Shift+Пробел.
  • Если режим размещения под произвольным углом создает ненужные вершины, зажмите ЛКМ на вершине и перетащите ребро, чтобы уменьшить количество вершин на этом ребре до одной. Чтобы удалить вершину, зажмите ЛКМ на ней, как если бы вы собирались переместить ее, и нажмите клавишу Delete.
  • По завершении внесения изменений щелкните ПКМ и выберите команду Polygon Actions » Repour Selected, чтобы перезалить полигон.

Разделение заливки полигоном

Для разделения одной заливки полигоном на две или несколько отдельных заливок полигоном используется команда Place » Slice Polygon Pour. После выбора команды вы перейдете в режим разделения (аналогичен режиму размещения трассы). Используйте ЛКМ для определения набора вершин, которые определят линию разделения. При определении разделения используйте Shift+Пробел для перебора режимов углов; нажмите Tab для изменения ширины; нажмите Пробел для переключения между начальным и конечным режимами углов; используйте клавишу Backspace для удаления последней размещенной вершины. Разместите конец линии разделения за пределами полигона. По завершении определения линии разделения щелкните ПКМ или нажмите клавишу Esc.

Будет открыто диалоговое окно с подтверждением, сколько будет создано новых полигонов. Нажмите Yes, чтобы подтвердить, что вы хотите перестроить полигоны.

Отключение заливки полигоном

В процессе конструирования могут произойти изменения: могут быть добавлены или изменены компоненты, может быть изменена трассировка и т.д. Чтобы упростить управление существующими полигонами в этом процессе, их можно отключить (Shelve, т.е. дословно "сложить на полку"). Это временно скроет их из редактора, но при этом они останутся в базе данных платы.

  • Чтобы отключить все заливки полигоном в текущей плате, выберите команду Tools » Polygon Pours » Shelve n Polygon(s) главного меню (здесь n обозначает количество заливок полигоном, которые были обнаружены в плате).
  • Чтобы восстановить все отключенные заливки полигоном, выберите команду Tools » Polygon Pours » Restore n Shelved Polygon(s) главного меню (здесь n обозначает количество отключенных в данный момент заливок полигоном).
  • Вы также можете отключать полигоны выборочно с помощью команд контекстного меню Polygon Actions или диалогового окна Polygon Pour Manager.

Использование заливок полигоном на непроводящих слоях

Заливки полигоном также могут использоваться на непроводящих слоях. Если заливка полигоном была размещена на слое, отличном от сигнального, она не будет залита вокруг существующих объектов, поскольку они не назначены какой-либо цепи.

Диалоговое окно Polygon Pour Manager

Главная страница: Диалоговое окно Polygon Pour Manager

Диалоговое окно Polygon Pour Manager обеспечивает обзор всех полигонов, которые на текущий момент существуют в проектной области платы. Диалоговое окно также позволяет именовать/переименовывать полигоны, определять порядок полигонов, осуществлять перезаливку или отключение выбранных полигонов и добавлять правила или задавать их область действия на основе выбранных полигонов.

Диалоговое окно Polygon Pour Manager дает полный контроль над полигонами в конструкции. Диалоговое окно Polygon Pour Manager дает полный контроль над полигонами в конструкции.

Примечания касательно диалогового окна Polygon Pour Manager:

  • Запуск диалогового окна Polygon Pour Manager осуществляется с помощью команды Tools » Polygon Pours » Polygon Manager.
  • Полигон автоматически именуется при размещении. Вы можете переименовать полигон в соответствии с собственными требованиями к проекту. Обратите внимание, что название полигона (Name) можно использовать для определения области действия правил, которые должны работать для этого полигона.
  • Раздел Pour Order позволяет изменять порядок заливки с помощью кнопок Move Up, Move Down и Auto Generate. Вы также можете изменять порядок с помощью перетаскивания с зажатой ЛКМ, что может быть намного быстрее, если конструкция содержит много полигонов.
  • Порядок заливки может быть важен, если есть полигон, который находится полностью в границах другого полигона. Как правило, заливка должна происходить от наименьшего полигона к наибольшему.
  • Кнопка Auto Generate определит порядок полигонов от наименьшего по площадки к наибольшему для каждого слоя.
  • Если нажать кнопку Repour, вы сможете выбрать перезаливку измененных полигонов, выбранных полигонов, полигонов с нарушениями, всех полигонов или принудительную перезаливку всех полигонов (Force Repour All Polygons). Процесс обновления можно отслеживать в строке состояния.

Отчет о полигонах

Для получения более подробной информации о заливках полигоном в плате используйте раздел Board Information панели Properties (доступен, когда в проектной области нет выделенных объектов) или список свойств заливки полигоном и его дочерних объектов. Количество полигонов, найденных в плате, отображается в группе Primitives & Others в разделе Board Information. Помните, что это общее количество отображает не только заливки полигоном, но и внутренние экраны и разделения экранов. Для получения более подробного списка свойств полигонов используйте панель PCB List.

Использование панели List для просмотра и редактирования свойств полигонов

Главная страница: Панель PCB List

Панель PCB List предоставляет альтернативный подход к представлению всех объектов, которые существуют в проектной области. Чтобы открыть панель PCB List, нажмите кнопку Panels внизу справа от проектной области и выберите PCB List из меню. Панель PCB List представляет данные в табличном виде. По умолчанию она отображает все объекты из проектной области. Используйте элементы управления в верхней части панели для настройки фильтра списка. На изображении ниже показано, что панель PCB List настроена на редактирование (Edit) всех объектов (all objects), с отображением в списке только полигонов (Polygons). В панели PCB List могут быть изменены свойства одного или множества полигонов.

Панель PCB List можно использовать для просмотра и редактирования заливок полигоном.Панель PCB List можно использовать для просмотра и редактирования заливок полигоном.

Использование внутренних экранов питания и разделений

Экраны питания

Экраны питания – это специальные сплошные внутренние проводящие слои, которые обычно используют для обеспечения электрически стабильной земли или опорного питания в плате.

Редактор плат поддерживает до 16 внутренних экранов питания. Вы можете назначить цепь каждому из этих слоев или назначить экрану питания несколько цепей, разделив его на две или больше изолированных областей. Подключения контактных площадок и переходных отверстий управляются правилами проектирования Plane. Создание экранов питания осуществляется в негативе, т.е. объекты, размещенные на экранном слое питания, станут пустыми участками, а остальная область будет сплошной медью.

Печатные платы изготавливаются с четным числом проводящих слоев, поэтому вам может понадобиться добавить еще один сигнальный или экранный слой, чтобы обеспечить четное число слоев.

Создание внутренних экранов

Добавление в плату внутренних экранов питания осуществляется в Layer Stack Manager (Design » Layer Stack Manager). Чтобы добавить новый внутренний экран, выделите существующий слой, под которым вы хотите создать внутренний слой, и выберите Insert layer below » Plane. В стек слоев будет добавлен новый внутренний экран. Используйте режим Layer Stack Manager панели Properties, чтобы определить свойства выбранного внутреннего экранного слоя.

Отображение экранов

Для отображения внутреннего экрана в проектной области, в том числе экранов питания, необходимо сначала включить отображение экранного слоя на вкладке Layer & Colors панели View Configuration.

При необходимости используйте команду Tools » Split Planes » Rebuild Split Planes on Current Layer или Rebuild Split Planes on All Layers, чтобы пересчитать и перестроить экраны. Также может оказаться полезным отображение отверстий контактных площадок и слоя Multi-layer. Используйте сочетание клавиш Shift+S для переключения между различными режимами одного слоя (Single Layer Mode), которые помогут найти интересующие объекты.

В режиме 3D (клавиша 3) вы можете увидеть физическое представление всех объектов внутренних экранов. 3D-среда позволяет подробно изучить внутренние слои. Если щелкнуть ЛКМ по внутреннему экрану, будет подсвечена вся область внутри трасс отступа. Вы также можете выделять внутренние экраны и их содержимое для просмотра с помощью режима Split Plane Editor, доступного их выпадающего меню в верхней части панели PCB.

3D-представление термобарьеров на разделении экрана.
3D-представление термобарьеров на разделении экрана.

Отступы и экраны питания

Когда экран питания добавлен, по контуру платы автоматически добавляется набор трасс для создания отступа экрана от края платы. Эти трассы нельзя изменить в проектной области, поскольку их ширина определяется в Layer Stack Manager. Если значение отступа для внутренних экранов было изменено, эти трассы будут перестроены автоматически.

Создание пустых областей

Чтобы создать участки пустых областей в экране, т.е. регионы, свободные от проводящего материала, вы можете разместить линии, дуги и заполнения с помощью команд Place для создания этих областей.

Подключение контактных площадок и переходных отверстий к экрану питания

Подключения к контактным площадкам и переходным отверстиям отображаются на экране питания в соответствии с правилами проектирования Plane, заданными в диалоговом окне PCB Rules and Constraints Editor (Design » Rules). Вы можете создать дополнительные правила для контактных площадок и переходных отверстий, к которым есть особые требования по их подключению.

Термобарьеры и прямые подключения

Сквозные контактные площадки и переходные отверстия могут быть подключены к экрану питания путем прямого подключения или термобарьера. Подключения термобарьером используются для тепловой изоляции подключенного вывода от сплошного проводящего экрана при пайке платы. Правила проектирования в редакторе плат позволяют определить форму термобарьера для контактных площадок, которые подключаются к экрану питания.

Правило проектирования Power Plane Connect Style определяет стиль подключения вывода компонента к экрану питания. Доступны три опции подключения:

  • Relief Connect (Подключение термобарьером)
  • Direct Connect (Прямое подключение)
  • No Connect (Нет подключения)

Также доступна особая поддержка подключения SMD-выводов питания к экранным слоям питания. Контактные площадки SMD в цепи, которая подключена к экрану питания, автоматически помечаются как подключенные к соответствующему экрану. Автотрассировщик завершает физическое подключение для этих контактных площадок путем размещения фэнаута, который является короткой трассой и переходным отверстием, подключенным к экранному слою с помощью термобарьера или напрямую.

Подключение термобарьером к контактной площадке на экране питания. Цветные участки обозначают области отсутствия меди.
Подключение термобарьером к контактной площадке на экране питания. Цветные участки обозначают области отсутствия меди.

Когда экранному слою назначена цепь, у каждой контактной площадки в цепи соответствующего экранного слоя питания отображается небольшое перекрестие. Оно отображается как '+' для подключения термобарьером и как 'x' для прямого подключения. Поскольку контактные площадки, подключенные напрямую, имеют сплошную медь на выводе, они показаны в цвете экрана вплоть до отверстия контактной площадки.

Контактные площадки, которые не подключаются к экрану питания

Контактные площадки, не подключенные к экрану, изолированы от него областью отсутствия меди. Эта область указана в правиле проектирования Power Plane Clearance в качестве радиального расширения вокруг отверстия контактной площадки.

Правила проектирования имеют иерархию, поэтому вы можете добавить новые правила, чтобы переопределить другие. Убедитесь, что вы задали нужные приоритеты в диалоговом окне PCB Rules and Constraints Editor, т.е. порядок, в котором применяется множество правил проектирования одного типа.

Подключение переходных отверстий к экранам питания

Подобно контактным площадкам, переходные отверстия автоматически подключаются ко внутренним экранным слоям питания с той же цепью. Переходное отверстие будет подключено в соответствии с применимым правилом проектирования Power Plane Connect Style. Если вы не хотите, чтобы переходные отверстия подключались к экранам питания, добавьте правило Power Plane Connect Style со стилем подключения No Connect и областью действия IsVia.

Учет особенностей производства

Согласуйте с производителем подходящие размеры термобарьеров. Также проверьте, что неподключенные контактные площадки или переходные отверстия не окружают полностью подключенную контактную площадку, поскольку это может непреднамеренно привести к изоляции контактной площадки. Не удаляйте слишком много меди и соблюдается баланс между максимальным количеством меди и доступными технологическими возможностями.

Отключение контактных площадок и переходных отверстий от экрана

В правилах проектирования Power Plane Connect Style вы можете задавать дополнительные ограничения для подключения контактных площадок и переходных отверстий к экранам питания. Область действия для контактных площадок может быть задана по обозначению или физическим свойствам, таким как размер контактной площадки. Поскольку у переходных отверстий не обозначений, область действия для них должна быть задана исходя из их физических свойств, таких как диаметр переходного отверстия.

Область действия для определенных контактных площадок и переходных отверстий, которые не должны подключаться к экранам питания

Чтобы не подключать к экранам питания, например, контактные площадки, обозначения которых начинаются с U7, вы можете использовать запрос (ObjectKind = 'Pad') And (Name Like 'U7-*') для определения области действия правила проектирования Power Plane Connect Style и задать стиль подключения No Connect. Запрос (ObjectKind = 'Pad') And (HoleSize = 25) определит область действия для контактных площадок с размером отверстия 25 милов.

При работе с переходными отверстиями, которые вы не нужно подключать к экранам питания, вы можете изменить их так, чтобы они содержали определенное свойство, которое будет уникальным образом отличать их от остальных переходных отверстий, например, другой диаметр, и определить область действия нового правила проектирования Power Plane Connect Style со стилем подключения No Connect, чтобы она соответствовала только этим переходным отверстиям. Для переходных отверстий, например, диаметром 24 мила может использоваться запрос (ObjectKind = 'Via') And (ViaDiameter = '24'). Для переходных отверстий цепи VCC может использоваться запрос InNet('VCC') And IsVia.

Либо если вы не можете выбрать переходные отверстия этими способами, вы можете преобразовать их в свободные контактные площадки и использовать их названия для определения области действия. Для этого выделите переходные отверстия, которые вы не хотите подключать, преобразуйте их в свободные контактные площадки (Tools » Convert » Convert Selected Vias to Free Pads) и задайте им всем одинаковое обозначение, например NoPlaneConnect. Затем добавьте новое правило проектирования Power Plane Connect Style и укажите область действия (ObjectKind = 'Pad') And (Name = 'Free‑NoPlaneConnect') в этом правиле. Также выберите No Connect для Connect Style. Все свободные контактные площадки с названием NoPlaneConnect будут отключены от всех экранных слоев питания.

Удаление внутренних экранов питания

Чтобы удалить внутренний экран, щелкните ПКМ по слою в Layer Stack Manager и выберите Delete layer из контекстного меню. Будет открыто диалоговое окно с предупреждением, что вместе со слоем будут удалены все примитивы на нем. Нажмите Yes для подтверждения.

Разделения экранных слоев

Разделение экранного слоя – это замкнутая область на внутреннем экране, которая делит экран на отдельные электрически изолированные области. Каждая область определяет путем размещения границ вокруг всех всех выводов цепи, после чего областям назначают разные цепи, что создает два или больше разделения слоя на одном внутреннем экранном слое питания.

Экранные слои могут быть разделены на любое количество отдельных регионов. Процесс разделения похож на разрезание экрана на области, где ширина размещаемой линии определяет расстояние между ними. Экраны питания формируются в негативе, поэтому линии границ станут участками отсутствия меди и, соответственно, создадут разделение между этой цепью и соседними цепями на экране.

Разделение внутреннего экрана.
Разделение внутреннего экрана.

Обычно внутреннему экрану сначала назначают цепь с наибольшим количеством контактных площадок, затем определяются области (разделения) для других цепей, к которым вы хотите подключить этот экран. Все контактные площадки, которые не могут быть охвачены областью разделения экрана, будут отображаться с линией соединения, обозначая, что они должны быть подключены на сигнальном слое.

Разделение экранов питания полностью поддерживаются проверкой правил проектирования (DRC). Однако они не распознаются при анализе целостности питания, поскольку здесь считается, что экран питания является непрерывным проводящим слоем. Извлечение списка цепей в редакторе CAM не поддерживает режим разделения экранов Altium NEXUS, поскольку невозможно определить полилинию для описания каждой области.

Использование в конструкции множества разделений экранов

Поддерживаются разделения внутри разделения (вложенные разделения, или островки), поэтому нет необходимости оборачивать внешнее разделение вокруг внутреннего. Если вы хотите дальше разделить экран, вы можете продолжить добавлять объекты на экранный слой питания внутри существующего разделения экрана для создания дополнительных электрически изолированных областей.

Советы по управлению представлением при разделении экрана

При определении области разделения в экране питания может быть сложно увидеть все контактные площадки, которые должна охватывать область разделения. Чтобы улучшить видимость контактных площадок цепи, которые вы хотите подключить к разделения экрана, воспользуйтесь следующими способами перед началом работы:

  • Пересчитайте и перестройте внутренние внутренние экраны, выбрав Tools » Split Planes » Rebuild Split Planes on Current Layer / Rebuild Split Planes on All Layers из главного меню.
  • Используйте 3D-режим (клавиша 3), чтобы увидеть физическое представление экранов, в том числе области отсутствия меди и термобарьеры. Чтобы упростить перемещение по плате в 3D, задайте масштаб толщины платы, чтобы увеличить вертикальное расстояние между слоями. Элемент управления Board thickness (Scale) находится в разделе 3D Settings на вкладке View Options панели View Configuration.

  • Отобразите только необходимый минимум слоев (например, слой Keep Out, слой Multi-layer, нужные механические слои) и используемый экран питания. Отключите остальные слои в панели View Configuration.
  • Скройте все линии соединения (View » Connections » Hide All). В некоторых случаях, может быть полезно отобразить отдельную цепь, для которой вы хотите создать разделение экрана (View » Connections » Show Net).
  • Задайте разные цвета для цепей на разделении экрана, выбрав Nets в панели PCB и дважды щелкнув ЛКМ по названию цепи, чтобы открыть диалоговое окно Edit Net.
  • Чтобы отобразить все контактные площадки, связанные с цепью, щелкните ЛКМ по цепи на внутреннем экране в панели PCB, чтобы маскировать остальные контактные площадки.
  • Назначьте внутреннему экрану питания цепь с наибольшим количеством контактных площадок и используйте в панели PCB List запросы, такие как InNet('A') или InNet('B'), чтобы показать цепи, например, одни с термобарьерами, другие без них, и отличить контактные площадки, включенные в новое разделение экрана.
  • Чтобы отобразить объекты и примитивы только на внутренних слоях, используйте запрос OnPlane в панели PCB Filter.

Определение разделений экранов

Для определения разделения экрана в Altium NEXUS вы можете размещать линии, дуги, трассы и заполнения на экранных слоях. Когда область экрана будет изолирована от остальной его части, будет создано разделение экрана. Затем новому разделению слоев присваивается цепь. Самый простой способ определения разделений экранов – это использовать команду Place » Line и задать границу разделения экрана на экране питания.

Создание разделения экрана с помощью команды Place » Line.Создание разделения экрана с помощью команды Place » Line.

В фотошаблонах будет создана линия отсутствия меди, которая, в свою очередь, разделит экранный слой. Ширина линии станет шириной этого разделения. Если вы щелкните ПКМ, чтобы выйти из режима разделения линии, экран будет проанализирован и будет создана независимая область разделения. Чтобы изменить расстояние между разделением экрана и внутренним экраном питания при размещении линии, нажмите клавишу Tab, чтобы открыть диалоговое окно Line Constraints и изменить значение Line Width.

Чтобы разделить экран питания на два разделения экрана, вы можете разместить линии через плату от одной трассы отступа до другой. При соединении линий с трассами отступа они образуют изолированную область и, соответственно, создадут полигональный объект, который определит разделение экрана. Убедитесь, что линии соединяются – курсор изменит свой вид на большую окружность под перекрестием при соединении линий.

Если вы не знаете, какую минимальную область отсутствия меди следует задать, проконсультируйтесь с производителем.

Чтобы определить разделение экрана нестандартной формы, вы можете создать замкнутую область из линий, дуг и заполнений. Вы также можете использовать существующие линии, дуги, заполнения и трассы на внутреннем слое, чтобы задать часть границы. При их соединении таким образом, что будет сформирована замкнутая область, будет создано разделение экрана.

Использование дуг, заполнений и трасс

Если при определении разделения экрана вы используете дуги, рекомендуется размещать короткие сегменты трасс между сегментами дуг. Обратите внимание, что использование заполнения (Place » Fill) не создаст разделение экрана, только пустую область. Вы можете использовать заполнения для создания внешних ребер разделения экрана путем их размещения, например, вместо линий.

Если вы размещаете вместо линий трассы с помощью команды Place » Interactive Routing, убедитесь, что трассам не назначена цепь (No Net) и что разделению трассы назначена нужная цепь.

Назначение цепи разделению экрана

Чтобы убедиться, что область разделения определена корректно, щелкните ЛКМ по ней. Если эта область замкнута, только она будет подсвечена.

Подсвеченное разделение экрана.
Подсвеченное разделение экрана.

Когда область подсвечена, дважды щелкните ЛКМ, чтобы открыть диалоговое окно Split Plane и назначить цепь – для этого выберите название цепи для разделения экрана из выпадающего списка в диалоговом окне.

Разделение экрана отображается в более темном полупрозрачном оттенке цвета цепи. Измените цвет цепи, выбрав Nets в панели PCB и дважды щелкнув ЛКМ по названию цепи, чтобы открыть диалоговое окно Edit Net.

 

Размещение трасс на экранах питания

Поскольку экранные слои питания формируются в негативе, трасса, размещенная на экранном слое питания, создает участок отсутствия меди и, соответственно, отсутствие подключения. Поэтому вы не можете использовать отдельную трассу на экранном слое для трассировки цепи. Если вы хотите провести цепь на экранном слое питания, необходимо создать тонкий островок меди, размер которого будет соответствовать ширине трассы, которую вы хотите использовать. Путем создания границы из линий вокруг области, которая будет выступать к качестве трассы (Place » Line), вы сформируете разделение экрана, которому можно будет назначить цепь.

Либо, если на одном экранном слое необходимо провести множество цепей, может быть эффективнее использовать сигнальный слой для трассировки соединений и использовать заливку полигоном для создания экрана питания.

Изучение и редактирование разделений экранов

Вы можете изучать и редактировать разделения экранов в панели PCB, выбрав Split Plane Editor из выпадающего меню в верхней части панели. Щелкните ЛКМ по цепи/слою, чтобы отобразить разделения экранов и их цепи на экране питания.

Щелкните ЛКМ по разделению слоя в разделе Split Plane(s) и Net(s), чтобы отобразить контактные площадки и переходные отверстия на этом экране питания. Дважды щелкните ЛКМ по названию разделения, чтобы открыть диалоговое окно Split Plane, в котором вы можете изменить цепь, связанную с этим разделением экрана, или щелкнуть ПКМ в проектной области, чтобы выбрать опцию из контекстного меню.

В режиме 3D (клавиша 3) вы можете увидеть физическое представление всех объектов внутренних экранов. 3D-среда позволяет легко перемещаться сквозь плату, что упрощает изучение экранов. Пересчет и перестроение внутренних экранов после редактирования осуществляется с помощью команд Tools » Split Planes » Rebuild Split Planes on Current Layer и Rebuild Split Planes on All Layers.

Удаление разделения экрана

Поскольку разделение формируется, когда область экрана изолирована, разделение будет удалено при удалении какого-либо объекта, который образует границу разделения. Соответственно, чтобы удалить разделение экрана, удалите примитив его границы, например, линии или другие примитивы, которые образуют контур разделения экрана. Помните, что трассы отступа могут быть удалены только при удалении внутреннего экрана из стека слоев.

Проверка правил проектирования для разделений экранов

Для разделений экранов вы можете провести пакетную проверку следующих правил проектирования:

  • Broken planes (Экраны с разрывами)
  • Dead copper regions (Участки неподключенной меди)
  • Starved thermal connections (Ограниченное подключение термобарьером)

Соответствующие опции доступны в разделе DRC Report Options в диалоговом окне Design Ruler Checker, которое вызывается с помощью команды Tools » Design Rule Check главного меню. Включите нужные опции, чтобы выполнять соответствующие проверки и получать отчеты по ним в процессе пакетной DRC.

Нарушения этих правил будут отображены в созданном отчете. Щелкните ЛКМ в отчете, чтобы отобразить соответствующую ошибку в редакторе плат.

Экраны с разрывами

Разрывы в экранах происходят, если область экрана, у которого есть подключение, становится электрически изолированной от остальной части экрана. Это может случиться, например, при размещении соединителя на разделении экрана, но без его подключения к этому разделению. Пустоты вокруг выводов соединяются, что полностью разрезает экран, фактически разделяя его на две части.

Экран с разрывом показывает ошибку DRC (ярко-зеленым цветом).
Экран с разрывом показывает ошибку DRC (ярко-зеленым цветом).

Неподключенная медь

Неподключенными считаются участки меди, у которых нет подключения к цепи и которые также становятся электрически изолированными от начального экрана. Это может случиться, например, при размещении соединителя (не подключенного к экрану) с близко расположенными друг у другу выводами, пустоты вокруг которых соединяются таким образом, что участки меди становятся изолированным от остальной части экрана.

Участок неподключенной меди показывает ошибку DRC (ярко-зеленым цветом).
Участок неподключенной меди показывает ошибку DRC (ярко-зеленым цветом).

Ограниченное подключение термобарьером

Термобарьеры представляют собой подключение к экрану с вырезами вокруг для уменьшения теплопередачи к экрану. Такие подключения могут стать "ограниченными" при уменьшении пустотами площади поверхность лучей, подключаемых к экрану. Это правило также проверяет площадь поверхности термобарьера (не только лучей) с учетом областей пустот, перекрывающих термобарьер.

Ограниченное подключение термобарьером показывает ошибку DRC (ярко-зеленым цветом).
Ограниченное подключение термобарьером показывает ошибку DRC (ярко-зеленым цветом).

Перейдите на страницу Определение ограничений конструкции – Правила проектирования для получения более подробной информации.

Примечания по разделениям экранов

  • Проверки DRC для разделений экранов выполняются только в пакетном режиме.
  • Чтобы удалить маркеры нарушений, необходимо снова запустить пакетную DRC или выбрать команду Tools » Reset Error Markers главного меню.
  • Пересчет и перестроение внутренних экранов после редактирования выполняется с помощью команд Tools » Split Planes » Rebuild Split Planes on Current Layer / Rebuild Split Planes on All Layers главного меню.
  • Для проверки наличия разрывов в экранах и неподключенной меди необходимо, чтобы для правила Un-Routed Net (категория Electrical) была включена опция Batch.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: