Tạo một mô hình mô phỏng
Sơ lược
- Cách tạo hoặc tìm nguồn mô hình mô phỏng, bao gồm tải tệp từ nhà sản xuất, sao chép mô hình dạng văn bản và tự viết tệp mạch con.
- Cách tạo, lưu, liên kết và chỉnh sửa mô hình mô phỏng trong Workspace bằng Altium Designer và Workspace được kết nối.
- Những thông tin cần thiết để định nghĩa chính xác một mô hình mô phỏng, bao gồm tên mô hình, các tệp được tham chiếu và các tham số ở cấp mô hình.
Để mô phỏng một thiết kế mạch bằng Trình mô phỏng mạch tín hiệu hỗn hợp của Altium Designer, tất cả linh kiện trong mạch phải sẵn sàng cho mô phỏng – nghĩa là mỗi linh kiện đều phải được liên kết với một mô hình mô phỏng.
Loại mô hình và cách lấy mô hình phụ thuộc chủ yếu vào linh kiện và, ở một mức độ nhất định, vào sở thích cá nhân của người thiết kế. Nhiều nhà sản xuất thiết bị cung cấp các mô hình mô phỏng tương ứng với thiết bị do họ sản xuất. Thông thường, bạn chỉ cần tải xuống tệp mô hình cần thiết và liên kết tệp đó với linh kiện trên sơ đồ nguyên lý. Tìm hiểu thêm về Thêm mô hình mô phỏng vào thiết kế.
Một số mô hình có thể cần được viết từ đầu – ví dụ: sử dụng cú pháp mạch con phân cấp để tạo tệp mô hình mạch con cần thiết (*.ckt).
Tạo mô hình mô phỏng mới
Một số mô hình được nhà sản xuất và nhà cung cấp cung cấp dưới dạng tệp văn bản có thể tải xuống. Đôi khi, nội dung chi tiết của mô hình được hiển thị dưới dạng văn bản trên trang trình duyệt thay vì tệp tải xuống; trong trường hợp này, bạn có thể tạo tệp mô hình mới trong Altium Designer rồi sao chép/dán nội dung từ trang trình duyệt vào tệp mô hình mới. Sử dụng lệnh tương ứng trong menu con File » New » Mixed Simulation, như minh họa bên dưới.

Các lệnh để tạo tệp mô hình mới, trống.
Sau đó, bạn có thể sao chép/dán thông tin từ tệp mô hình vào trình biên tập mô hình.

Ví dụ về nội dung văn bản của một mô hình mô phỏng.
Tạo mô hình mô phỏng trong Workspace
Altium Designer, khi kết hợp với một Workspace được kết nối, cho phép tạo và quản lý các mô hình mô phỏng trong Workspace. Sau khi được tạo, một mô hình mô phỏng trong Workspace có thể được dùng để tạo một hoặc nhiều linh kiện trong Workspace.
Mặc dù các mô hình mô phỏng trong Workspace được tạo tự động khi bạn thêm tệp mô hình mô phỏng vào một linh kiện đang được định nghĩa trong Component Editor ở chế độ chỉnh sửa từng linh kiện rồi lưu linh kiện đó vào Workspace, bạn cũng có thể tạo mô hình mô phỏng trực tiếp trong Workspace như mô tả bên dưới.
-
Mở bảng Components và bật hiển thị mô hình bằng cách nhấp vào nút
ở đầu bảng rồi chọn Models.
-
Đi đến danh mục Simulations và chọn Create Component từ menu của nút
.

Đi đến các mô hình mô phỏng trong bảng Components và chọn lệnh tạo mô hình mới -
Trong hộp thoại Create New Item mở ra, nhập thông tin cần thiết, bảo đảm tùy chọn Open for editing after creation đã được bật rồi nhấp vào OK. Mô hình mô phỏng trong Workspace sẽ được tạo và trình biên tập SimModel tạm thời sẽ mở, hiển thị tài liệu
.SimModellàm tài liệu hiện hành trong không gian thiết kế. Tài liệu này sẽ được đặt tên theo Item-Revision, với định dạng:<Item><Revision>.SimModel(ví dụ:SIM-001-0001-1.SimModel).
Ví dụ về chỉnh sửa bản sửa đổi đầu tiên của mô hình mô phỏng trong Workspace – trình biên tập SimModel tạm thời cung cấp tài liệu để bạn định nghĩa mô hình mô phỏng. - Sử dụng tài liệu này để định nghĩa mô hình mô phỏng trong Workspace theo yêu cầu. Để biết thêm thông tin về cách thực hiện, xem Định nghĩa mô hình mô phỏng.
- Lưu mô hình vào Workspace bằng nút điều khiển Save to Server ở bên phải mục mô hình mô phỏng trong bảng Projects. Hộp thoại Edit Revision sẽ xuất hiện, cho phép bạn thay đổi Tên, Mô tả và thêm ghi chú phát hành theo yêu cầu. Tài liệu và trình biên tập sẽ đóng sau khi lưu.
-
Tài liệu chứa định nghĩa mô hình mô phỏng nguồn,
*.SimModel, sẽ được lưu trong bản sửa đổi của mô hình mô phỏng trong Workspace. Mô hình mô phỏng sẽ được hiển thị trong bảng Components, thuộc danh mục Simulations.
Mô hình mô phỏng trong Workspace đã lưu trong bảng ComponentsDữ liệu được lưu trong Workspace bao gồm định nghĩa mô hình trong tệp
.SimModel, cũng như mọi tệp.mdlhoặc.cktđược tham chiếu. Trong bảng Explorer, chuyển sang thẻ chế độ xem Preview, rồi nhấp vào một tệp được tham chiếu để xem trước nội dung của tệp đó. Các tham số cấp mô hình cũng sẽ được hiển thị, nếu có.
Duyệt mô hình mô phỏng trong Workspace đã lưu trong bảng Explorer. Chuyển sang thẻ chế độ xem Preview để xem dữ liệu đã lưu.
Sau đó, mô hình mô phỏng trong Workspace đã lưu có thể được liên kết với một linh kiện trong Workspace khi định nghĩa linh kiện trong Component Editor ở chế độ Chỉnh sửa từng linh kiện hoặc Chỉnh sửa linh kiện hàng loạt.
Định nghĩa mô hình mô phỏng
Thông tin cần thiết để định nghĩa mô hình trong tệp SimModel như sau:
-
Model Name – sử dụng trường này để chỉ định tên của mô hình. Khi được lưu trở lại Workspace, nội dung này sẽ được dùng làm Name của bản sửa đổi mục mô hình mô phỏng.
Khi tham chiếu đến tệp MDL, tên phải trùng với tên xuất hiện trong dòng
.MODELcủa phần định nghĩa mô hình. Hãy xem một mô hình điốt có định nghĩa như sau:.MODEL 1N4002 D(IS=2.55E-9 RS=0.042 N=1.75 TT=5.76E-6 CJO=1.85E-11 + VJ=0.75 M=0.333 BV=100 IBV=1E-5 )Tên mô hình ở đây là
1N4002. Đây là tên phải được nhập vào trường Model Name.Khi tham chiếu đến tệp CKT, tên phải trùng với tên xuất hiện trong dòng
.SUBCKTcủa phần định nghĩa mô hình. Hãy xem một mô hình cầu chì có định nghĩa như sau:.SUBCKT FUSE 1 2 PARAMS: CURRENT=1 RESISTANCE=1m SW1 1 2 3 0 SMOD OFF BNLV 3 0 V=(abs(v(1,2)))
.MODEL SMOD SW (VT=\{(CURRENT*RESISTANCE)\} RON=1g ROFF=\{RESISTANCE\})
.ENDS FUSETên mô hình ở đây là
FUSE. Đây là tên phải được nhập vào trường Model Name. -
Model File – đối với mô hình được định nghĩa bằng tệp
.mdlhoặc.ckt, hãy sử dụng nút Browse để chọn tệp cần thiết từ một thư viện có sẵn. - Description – nhập mô tả về mô hình, chẳng hạn như mục đích sử dụng. Khi được lưu trở lại Workspace, nội dung này sẽ được dùng làm Description của bản sửa đổi mô hình mô phỏng.
- Parameters – các tham số cấp mô hình của mô hình (xem Tham số cấp mô hình).
-
Model Preview – hiển thị nội dung chỉ đọc của tệp
.mdlhoặc.cktđược tham chiếu.
Tham số cấp mô hình
Khi phù hợp, các tham số cấp mô hình có thể được định nghĩa trực tiếp trong tệp SimModel, vì chúng vốn là một phần trong định nghĩa của mô hình. Vùng Parameters của tài liệu sẽ tự động được điền các tham số áp dụng cho mô hình đã chọn. Có thể chỉnh sửa giá trị tham số ngay tại chỗ - nhấp vào trường Parameter Value tương ứng với một tham số trong danh sách rồi nhập trực tiếp giá trị cần thiết.

Định nghĩa các tham số của mô hình như một phần trong định nghĩa mô hình – bằng cách chỉnh sửa trực tiếp tại chỗ.
Chỉnh sửa mô hình mô phỏng Workspace
Bất cứ lúc nào, bạn cũng có thể quay lại bất kỳ mô hình mô phỏng Workspace nào và chỉnh sửa trực tiếp. Chọn danh mục Simulations trong bảng Components (phải bật tùy chọn Models trong menu
của bảng để truy cập danh mục này), nhấp chuột phải vào mục của một mô hình mô phỏng rồi chọn lệnh Edit từ menu ngữ cảnh. Trình biên tập tạm thời sẽ lại mở ra, đồng thời mở tệp chứa định nghĩa mô hình mô phỏng nguồn trong mô hình mô phỏng Workspace để chỉnh sửa. Thực hiện các thay đổi cần thiết, sau đó lưu tài liệu vào bản sửa đổi tiếp theo của mô hình mô phỏng Workspace.
Tạo tệp SimModel
Có thể tạo các tệp SimModel từ tài liệu thư viện nguyên lý hoặc tài liệu thư viện cơ sở dữ liệu đang hoạt động bằng lệnh Tools » Generate SimModel Files.
Sau khi chạy lệnh, hộp thoại Generate SimModel Files sẽ xuất hiện. Mỗi tệp SimModel (cùng phần định nghĩa mô hình mô phỏng bên trong) được tạo dựa trên liên kết mô hình mô phỏng của một linh kiện nguyên lý trong thư viện nguyên lý đang hoạt động (hoặc thông tin mô phỏng của một bản ghi linh kiện trong thư viện cơ sở dữ liệu đang hoạt động). Sử dụng các tùy chọn trong hộp thoại để cấu hình việc tạo một hoặc nhiều tệp SimModel theo nhu cầu. Theo mặc định, một thư mục con có tên Sim Models sẽ được tạo. Hãy đổi tên này cho phù hợp hơn nếu cần. Nếu thư mục được chỉ định đã tồn tại, thư mục đó sẽ được sử dụng; nếu chưa, thư mục sẽ được tạo.

Hộp thoại Generate SimModel Files
Sau khi thiết lập các tùy chọn theo yêu cầu, nhấp vào OK. Quá trình tạo sẽ bắt đầu và khi hoàn tất, một hộp thoại xác nhận sẽ xuất hiện, cho biết số lượng tệp SimModel đã được tạo. Mọi tệp .mdl, .ckt hoặc .scb được tham chiếu cũng sẽ được lưu cùng với các tệp SimModel.
Nếu di chuyển từ thư viện tích hợp, bạn có thể lấy các thư viện nguyên lý nguồn (SchLib) bằng cách mở IntLib trong Altium Designer rồi chọn trích xuất các thư viện nguồn. Khi tạo tệp SimModel từ thư viện cơ sở dữ liệu, chỉ các linh kiện trong những bảng hiện đang được bật mới được xem xét.
Cách đặt tên tệp SimModel phụ thuộc vào loại thư viện nguồn:
- Schematic Library - mỗi tệp SimModel được đặt theo tên của mô hình mô phỏng. Khi nhiều linh kiện nguyên lý có cùng một cách triển khai mô hình mô phỏng (mô hình mô phỏng có cùng tên), chỉ một tệp SimModel duy nhất được tạo với tên đó.
- Database Library - mỗi tệp SimModel được đặt theo tên của mô hình mô phỏng, như được chỉ định trong trường Sim Model Name của bản ghi linh kiện. Khi nhiều bản ghi linh kiện (trong các bảng được bật) có cùng một cách triển khai mô hình mô phỏng (cùng nội dung trong trường Sim Model Name ), chỉ một tệp SimModel duy nhất được tạo với tên đó.
Trình hướng dẫn mô hình SPICE
Một số mô hình linh kiện tương tự được tích hợp sẵn trong SPICE cho phép sử dụng tệp mô hình đi kèm (*.mdl) để định nghĩa các đặc tính hành vi nâng cao thông qua các tham số (ví dụ: điện trở bán dẫn, điốt, BJT). Việc tạo tệp mô hình này bằng tay rồi liên kết thủ công với linh kiện cần thiết trên sơ đồ nguyên lý có thể khá tốn công sức. SPICE Model Wizard giúp đơn giản hóa tác vụ này. Với trình hướng dẫn, các đặc tính của linh kiện có thể được định nghĩa dựa trên dữ liệu do người dùng thu thập. Các tham số – được nhập trực tiếp hoặc trích xuất từ dữ liệu cung cấp – sẽ tự động được ghi vào tệp mô hình, sau đó tệp này được liên kết với linh kiện được chỉ định trên sơ đồ nguyên lý.
SPICE Model Wizard cung cấp giải pháp bán tự động, thuận tiện để tạo và liên kết mô hình mô phỏng SPICE cho nhiều loại linh kiện tương tự – những linh kiện được tích hợp sẵn trong SPICE và cần có tệp mô hình liên kết (*.mdl). Các đặc tính hành vi của mô hình được định nghĩa dựa trên thông tin bạn cung cấp cho trình hướng dẫn. Mức độ chi tiết của thông tin này phụ thuộc vào loại linh kiện mà bạn muốn tạo mô hình – từ việc nhập đơn giản các tham số mô hình đến nhập dữ liệu linh kiện lấy từ bảng dữ liệu của nhà sản xuất hoặc từ các phép đo trên chính linh kiện thực tế.
Các phần sau trình bày cách sử dụng trình hướng dẫn – từ truy cập đến kiểm tra xác nhận.
Truy cập trình hướng dẫn
Để truy cập trình hướng dẫn từ trình biên tập ký hiệu sơ đồ nguyên lý, chọn lệnh Tools » XSpice Model Wizard từ các menu chính.

Trang đầu tiên của SPICE Model Wizard
Trên hai trang tiếp theo của trình hướng dẫn, bạn có thể chọn:
- Loại linh kiện cụ thể mà bạn muốn tạo mô hình từ danh sách các loại linh kiện được hỗ trợ.
- Thêm mô hình SPICE được tạo sau đó vào một linh kiện hiện có trong tài liệu thư viện hay vào một linh kiện mới do trình hướng dẫn tạo và thêm vào tài liệu đó.
Các loại linh kiện được hỗ trợ
Trình hướng dẫn có thể được dùng để tạo mô hình SPICE cho các loại linh kiện tương tự sau:
- Điốt
- Tụ điện bán dẫn
- Điện trở bán dẫn
- Công tắc điều khiển bằng dòng điện
- Công tắc điều khiển bằng điện áp
- Transistor lưỡng cực tiếp giáp
- Đường truyền có tổn hao
- Đường truyền RC phân bố đều
Đặt tên mô hình
Một trong những bước quan trọng nhất khi thực hiện theo các trang của trình hướng dẫn là đặt tên cho mô hình bạn đang tạo. Trên thực tế, bạn sẽ không thể chuyển sang bước định nghĩa tham số của trình hướng dẫn cho đến khi nhập tên.
Sau khi tạo, tên này sẽ xuất hiện trong trường Model Name của hộp thoại Sim Model. Bản thân tệp mô hình cũng được tạo với tên này (<ModelName>.mdl). Khi sử dụng trình hướng dẫn để thêm mô hình vào một linh kiện thư viện mới, tên được chỉ định cho mô hình cũng sẽ được dùng để đặt tên cho linh kiện.
Khi đặt tên mô hình, bạn cũng có thể nhập một mô tả ngắn cho mô hình đó. Mô tả này có thể là chức năng của mô hình (ví dụ: Semiconductor Resistor), hoặc thông tin cụ thể hơn về một giá trị hay cấu hình (ví dụ: NPN BJT).
Các đặc tính cần mô hình hóa
Sau khi đặt tên cho mô hình, bạn sẽ chuyển sang một hoặc nhiều trang liên quan đến các đặc tính cần mô hình hóa. Các loại mô hình được trình hướng dẫn hỗ trợ có thể được chia thành hai nhóm sau:
- Các mô hình yêu cầu nhập trực tiếp giá trị cho các tham số mô hình khác nhau. Để biết thêm thông tin, xem phần Mô hình linh kiện được tạo bằng cách nhập trực tiếp tham số.
- Các mô hình yêu cầu nhập dữ liệu để trích xuất các tham số định nghĩa những đặc tính linh kiện đã chọn. Dữ liệu được nhập lấy từ kết quả đo trực tiếp trên linh kiện thực tế hoặc từ bảng dữ liệu của nhà sản xuất. Để biết thêm thông tin, xem phần Mô hình linh kiện được tạo bằng cách trích xuất tham số từ dữ liệu.
Tạo mô hình
Sau khi định nghĩa dữ liệu/tham số cần thiết, trình hướng dẫn sẽ hiển thị mô hình được tạo. Đây là nội dung sẽ được lưu vào tệp MDL.

Xem trước nội dung tệp mô hình được tạo.
Bạn có thể chỉnh sửa mô hình ngay trên trang này để kiểm soát tối đa việc định nghĩa mô hình.
Khi đã hài lòng với định nghĩa mô hình, nhấp vào Next để chuyển đến trang cuối của trình hướng dẫn. Nhấp vào Finish sẽ cho phép bạn lưu mô hình. Sử dụng hộp thoại Save SPICE Model File để xác định vị trí lưu tệp MDL được tạo. Theo mặc định, tệp sẽ được lưu vào cùng thư mục với tài liệu thư viện sơ đồ nguyên lý. Bạn cũng có thể đổi tên tệp ở bước này nếu muốn.
Nếu bạn đã yêu cầu gắn mô hình vào một linh kiện mới, linh kiện đó sẽ được tạo và thêm vào tài liệu thư viện.
Mô hình linh kiện được tạo bằng cách nhập trực tiếp tham số
Đối với các mô hình linh kiện sau đây, trình hướng dẫn không trích xuất thông tin tham số từ dữ liệu đã nhập. Thay vào đó, các mô hình được tạo dựa trên việc nhập trực tiếp giá trị cho các tham số tương ứng. Khi nhập giá trị tham số, có một vài điểm cần lưu ý:
- Nếu không chỉ định giá trị cho một tham số, tham số đó sẽ không có trong tệp mô hình được tạo. Trong trường hợp này, giá trị mặc định được lưu nội bộ trong SPICE sẽ được sử dụng. Nói cách khác, nếu giá trị của một tham số được chỉ định trong tệp mô hình thì giá trị trong tệp mô hình sẽ ghi đè giá trị mặc định của tham số đó.
- Nếu giá trị mặc định của một tham số trong trình hướng dẫn là '-' và bạn không nhập cụ thể giá trị cho tham số đó, giá trị mặc định bằng không (trong nội bộ SPICE) sẽ được sử dụng để tính toán.
Tụ điện bán dẫn
Các tham số sau có thể được định nghĩa cho mô hình linh kiện này bằng trình hướng dẫn. Khi bạn nhập giá trị, tham số tương ứng sẽ được ghi vào tệp MDL được tạo.
CJ |
Điện dung đáy tiếp giáp (đơn vị F/m²). |
|
CJSW |
Điện dung thành bên tiếp giáp (đơn vị F/m). |
|
DEFW |
Chiều rộng mặc định của linh kiện (đơn vị mét). (Mặc định = 1e-6). |
|
NARROW |
Độ thu hẹp do ăn mòn ngang (đơn vị mét). (Mặc định = 0). |
Điện trở bán dẫn
Có thể sử dụng trình hướng dẫn để xác định các tham số sau cho mô hình linh kiện này. Khi nhập một giá trị, tham số tương ứng sẽ được ghi vào tệp MDL được tạo.
TC1 |
Hệ số nhiệt độ bậc nhất (đơn vị Ohm/˚C). (Mặc định = 0) |
|
TC2 |
Hệ số nhiệt độ bậc hai (đơn vị Ohm/˚C2). (Mặc định = 0) |
|
RSH |
Điện trở tấm (đơn vị Ohm). |
|
DEFW |
Chiều rộng mặc định (đơn vị mét). (Mặc định = 1e-6). |
|
NARROW |
Độ thu hẹp do ăn mòn bên (đơn vị mét). (Mặc định = 0). |
|
TNOM |
Nhiệt độ đo tham số (đơn vị ˚C). Nếu không chỉ định giá trị, giá trị mặc định được gán cho TNOM trên thẻ Advanced của hộp thoại Advanced Analyses Settings sẽ được sử dụng (Mặc định = 27). |
Công tắc điều khiển bằng dòng điện
Có thể sử dụng trình hướng dẫn để xác định các tham số sau cho mô hình linh kiện này. Khi nhập một giá trị, tham số tương ứng sẽ được ghi vào tệp MDL được tạo.
IT |
Dòng điện ngưỡng (đơn vị Ampe). (Mặc định = 0). |
|
IH |
Dòng điện trễ (đơn vị Ampe). (Mặc định = 0). |
|
RON |
Điện trở khi đóng (đơn vị Ohm). (Mặc định = 1). |
|
ROFF |
Điện trở khi ngắt (đơn vị Ohm). Theo mặc định, giá trị này được đặt bằng 1/GMIN. GMIN là một tham số SPICE nâng cao, được chỉ định trên thẻ Advanced của hộp thoại Advanced Analyses Settings. Tham số này thiết lập điện dẫn tối thiểu (điện trở tối đa) của bất kỳ linh kiện nào trong mạch. Giá trị mặc định là 1e-12 mho, do đó giá trị mặc định của ROFF là 1000G Ohm. |
Công tắc điều khiển bằng điện áp
Có thể sử dụng trình hướng dẫn để xác định các tham số sau cho mô hình linh kiện này. Khi nhập một giá trị, tham số tương ứng sẽ được ghi vào tệp MDL được tạo.
VT |
Điện áp ngưỡng (đơn vị Vôn). (Mặc định = 0). |
|
VH |
Điện áp trễ (đơn vị Vôn). (Mặc định = 0). |
|
RON |
Điện trở khi đóng (đơn vị Ohm). (Mặc định = 1). |
|
ROFF |
Điện trở khi ngắt (đơn vị Ohm). Theo mặc định, giá trị này được đặt bằng 1/GMIN. GMIN là một tham số SPICE nâng cao, được chỉ định trên thẻ Advanced của hộp thoại Advanced Analyses Settings. Tham số này thiết lập điện dẫn tối thiểu (điện trở tối đa) của bất kỳ linh kiện nào trong mạch. Giá trị mặc định là 1e-12 mho, do đó giá trị mặc định của ROFF là 1000G Ohm. |
Đường truyền có tổn hao
Có thể sử dụng trình hướng dẫn để xác định các tham số sau cho mô hình linh kiện này. Khi nhập một giá trị (hoặc bật một cờ), tham số tương ứng sẽ được ghi vào tệp MDL được tạo.
R |
Điện trở trên một đơn vị chiều dài (đơn vị Ohm/đơn vị chiều dài). (Mặc định = 0). |
|
L |
Độ tự cảm trên một đơn vị chiều dài (đơn vị Henry/đơn vị chiều dài). (Mặc định = 0). |
|
G |
Điện dẫn trên một đơn vị chiều dài (đơn vị mho/đơn vị chiều dài). (Mặc định = 0). |
|
C |
Điện dung trên một đơn vị chiều dài (đơn vị Farad/đơn vị chiều dài). (Mặc định = 0). |
|
LEN |
Chiều dài đường truyền. |
|
REL |
Điều khiển điểm ngắt (đơn vị tùy ý). (Mặc định = 1). |
|
ABS |
Điều khiển điểm ngắt (đơn vị tùy ý). (Mặc định = 1). |
|
NOSTEPLIMIT |
Cờ mà khi được bật sẽ loại bỏ ràng buộc buộc bước thời gian phải nhỏ hơn độ trễ của đường truyền. (Mặc định = không bật). |
|
NOCONTROL |
Cờ mà khi được bật sẽ ngăn việc giới hạn bước thời gian dựa trên các tiêu chí sai số tích chập. (Mặc định = không bật). |
|
LININTERP |
Cờ mà khi được bật sẽ sử dụng phép nội suy tuyến tính thay cho phép nội suy bậc hai mặc định để tính toán các tín hiệu trễ. (Mặc định = không bật). |
|
MIXEDINTERP |
Cờ mà khi được bật sẽ sử dụng một tiêu chí đánh giá để xác định liệu có thể áp dụng nội suy bậc hai hay không; nếu không, sẽ sử dụng nội suy tuyến tính. (Mặc định = không bật). |
|
COMPACTREL |
Đại lượng cụ thể dùng để điều khiển việc rút gọn các giá trị lịch sử dùng cho phép tích chập. Theo mặc định, đại lượng này sử dụng giá trị được chỉ định cho tham số dung sai sai số mô phỏng tương đối (RELTOL), được xác định trên thẻ Advanced của hộp thoại Advanced Analyses Settings. |
|
COMPACTABS |
Đại lượng cụ thể dùng để điều khiển việc rút gọn các giá trị lịch sử dùng cho phép tích chập. Theo mặc định, đại lượng này sử dụng giá trị được chỉ định cho tham số dung sai sai số dòng điện tuyệt đối (ABSTOL), được xác định trên thẻ Advanced của hộp thoại Advanced Analyses Settings. |
|
TRUNCNR |
Cờ mà khi được bật sẽ cho phép sử dụng phương pháp lặp Newton-Raphson để xác định bước thời gian phù hợp trong các thủ tục điều khiển bước thời gian. (Mặc định = không bật, khi đó phương pháp thử và sai được sử dụng – mỗi lần giảm một nửa bước thời gian trước đó). |
|
TRUNCDONTCUT |
Cờ mà khi được bật sẽ vô hiệu hóa việc giảm bước thời gian mặc định nhằm hạn chế sai số trong quá trình tính toán thực tế các đại lượng liên quan đến đáp ứng xung. (Mặc định = không bật). |
Đường truyền RC phân bố đồng đều
Có thể sử dụng trình hướng dẫn để xác định các tham số sau cho mô hình linh kiện này. Khi nhập một giá trị, tham số tương ứng sẽ được ghi vào tệp MDL được tạo.
K |
Hằng số truyền sóng. (Mặc định = 2). |
|
FMAX |
Tần số tối đa cần xét (đơn vị Hertz). (Mặc định = 1.0G). |
|
RPERL |
Điện trở trên một đơn vị chiều dài (đơn vị Ohm/mét). (Mặc định = 1000). |
|
CPERL |
Điện dung trên một đơn vị chiều dài (đơn vị Farad/mét). (Mặc định = 1.0e-15). |
|
ISPERL |
Dòng điện bão hòa trên một đơn vị chiều dài (đơn vị Ampe/mét). (Mặc định = 0). |
|
RSPERL |
Điện trở điốt trên một đơn vị chiều dài (đơn vị Ohm/mét). (Mặc định = 0). |
Các mô hình linh kiện được tạo bằng cách trích xuất tham số từ dữ liệu
Đối với điốt và BJT, trình hướng dẫn trích xuất thông tin tham số từ dữ liệu bạn nhập. Các tham số cụ thể được trích xuất để đưa vào tệp mô hình sẽ phụ thuộc vào những đặc tính của điốt hoặc BJT mà bạn đã chọn để lập mô hình.
Phương thức nhập dữ liệu thay đổi tùy theo từng đặc tính. Trong một số trường hợp, bạn cần nhập trực tiếp các giá trị dữ liệu; trong những trường hợp khác, bạn cần nhập dữ liệu đồ thị. Trong mọi trường hợp, dữ liệu đều được lấy từ phép đo trực tiếp trên linh kiện, bảng dữ liệu của nhà sản xuất hoặc kết hợp cả hai nguồn.
Khi được yêu cầu nhập dữ liệu đồ thị, hãy nhập một chuỗi điểm dữ liệu lấy từ đồ thị nguồn vào bảng do trình hướng dẫn cung cấp. Nếu dữ liệu được lưu ở định dạng các giá trị phân tách bằng dấu phẩy (*.csv), bạn có thể nhập dữ liệu bằng nút Import Data có sẵn. Trình hướng dẫn sẽ sử dụng dữ liệu bạn nhập để trích xuất các tham số mô hình cần thiết. Kết quả trích xuất được trình bày ở một trang tiếp theo của trình hướng dẫn, bao gồm các giá trị tham số đã trích xuất và đồ thị so sánh giữa dữ liệu đã nhập với các giá trị được tính toán từ những tham số đó. Hình bên dưới minh họa một ví dụ về cách hiển thị kết quả tham số như vậy.

Nhập dữ liệu nguồn để trình hướng dẫn có thể trích xuất các tham số mô hình cần thiết.
Bạn có thể chỉnh sửa các giá trị tham số đã trích xuất để tinh chỉnh thêm độ chính xác của mô hình điốt. Đồ thị so sánh sẽ được cập nhật để phản ánh các thay đổi.
Điốt
Các phần sau trình bày chi tiết từng đặc tính mà bạn có thể chọn để lập mô hình cho điốt. Mỗi phần giải thích các tham số được trích xuất và dữ liệu nguồn mà trình hướng dẫn cần để thực hiện việc trích xuất.
Dòng điện phân cực thuận
Các tham số sau được dùng để mô tả đặc tuyến dòng điện–điện áp DC của điốt trong vùng phân cực thuận:
IS |
Dòng điện bão hòa (đơn vị ampe). |
|
N |
Hệ số phát xạ. |
|
RS |
Điện trở thuần (đơn vị ôm). |
Để trích xuất các tham số này, cần có đồ thị dòng điện thuận của điốt (IF) theo điện áp thuận của điốt (VF). Đồ thị này có thể lấy từ bảng dữ liệu của nhà sản xuất hoặc từ các phép đo trên linh kiện thực tế.
Hình bên dưới minh họa một ví dụ về đồ thị như vậy, lấy từ bảng dữ liệu, cùng một mạch thử nghiệm mẫu có thể dùng để đo trực tiếp nhằm thu thập dữ liệu nguồn cần thiết.

Ví dụ về đồ thị và mạch đo đặc tuyến I-V của điốt trong vùng phân cực thuận.
Dữ liệu được nhập vào trình hướng dẫn dưới dạng một chuỗi điểm dữ liệu lấy từ đồ thị nguồn.
Điện dung tiếp giáp khi phân cực ngược
Các tham số sau được dùng để mô tả điện dung của điốt khi hoạt động trong vùng phân cực ngược:
CJO |
Điện dung tiếp giáp khi không phân cực (đơn vị fara). |
|
M |
Hệ số phân bố tạp chất. |
|
VJ |
Điện thế tiếp giáp (đơn vị vôn). |
Để trích xuất các tham số này, cần có đồ thị điện dung khi phân cực ngược (Cd) theo điện áp ngược của điốt (VR). Đồ thị này có thể lấy từ bảng dữ liệu của nhà sản xuất hoặc từ các phép đo trên linh kiện thực tế.
Hình minh họa một ví dụ về đồ thị như vậy, lấy từ bảng dữ liệu, cùng một mạch thử nghiệm mẫu có thể dùng để đo trực tiếp nhằm thu thập dữ liệu nguồn cần thiết. Có thể sử dụng mạch này khi không có máy đo điện dung.

Ví dụ về đồ thị và mạch đo điện dung của điốt trong vùng phân cực ngược.
Dữ liệu được nhập vào trình hướng dẫn dưới dạng một chuỗi điểm dữ liệu lấy từ đồ thị nguồn.
Mạch ví dụ trong hình trên dựa trên phương trình:
I = C * (dv/dt)
Giải phương trình này theo C, ta được:
C = I/(dv/dt)
Mạch tạo ra điện áp tăng tuyến tính từ nguồn V1. Bằng cách tính độ dốc của điện áp này, có thể xác định thành phần dv/dt trong phương trình. Lấy dòng điện điốt đo được chia cho độ dốc của điện áp tăng tuyến tính sẽ thu được đường cong điện dung của điốt.
Dòng điện phân cực ngược
Các tham số sau được dùng để mô tả dòng điện phân cực ngược của linh kiện sau khi đánh thủng:
BV |
Điện áp đánh thủng ngược (đơn vị vôn). |
|
IBV |
Dòng điện tại điện áp đánh thủng (đơn vị ampe). |
Để trích xuất các tham số này, trình hướng dẫn yêu cầu nhập hai giá trị sau:
-
Giá trị điện áp đánh thủng ngược.
-
Giá trị dòng điện qua điốt tại điểm đánh thủng ngược.
Các giá trị này có thể lấy từ bảng dữ liệu của nhà sản xuất hoặc từ các phép đo trên linh kiện thực tế. Bảng dữ liệu thường trình bày các đặc tính điện (DC) của điốt dưới dạng bảng, vì vậy bạn chỉ cần tìm các giá trị này và nhập chính xác như được công bố.
Nếu dữ liệu nguồn ở dạng đồ thị — thường gặp khi đo trực tiếp trên linh kiện thực tế — bạn cần đọc hai giá trị này tại điểm điốt bắt đầu đánh thủng. Hình bên dưới minh họa một ví dụ về đồ thị như vậy.

Xác định các giá trị dòng điện và điện áp tại điểm đánh thủng ngược từ đồ thị.
Mặc dù các giá trị có thể được hiển thị là số âm trên đồ thị, khi nhập vào các trường tương ứng trong trình hướng dẫn, bạn chỉ được nhập giá trị dương.
Đặc tính phục hồi ngược
Tham số sau được dùng để lập mô hình thời gian phục hồi ngược của điốt khi chuyển từ phân cực thuận sang phân cực ngược:
TT |
Thời gian quá cảnh (đơn vị giây). |
Để trích xuất tham số này, trình hướng dẫn yêu cầu nhập thời gian phục hồi ngược của điốt (Trr) tại điều kiện dòng điện thuận bằng dòng điện ngược (tức là IR/IF=1). Dữ liệu này thường có trong bảng dữ liệu của nhà sản xuất dành cho điốt chuyển mạch, dưới dạng số liệu đơn giản.
Hình bên dưới minh họa cách thông tin này được trình bày trong bảng dữ liệu của nhà sản xuất. Giá trị cần quan tâm trong hình — cũng là giá trị cần nhập vào trình hướng dẫn — là 4ns.

Xác định thời gian phục hồi ngược của điốt.
Transistor tiếp giáp lưỡng cực (BJT)
Khi tạo mô hình transistor tiếp giáp lưỡng cực (BJT), Trình hướng dẫn tạo mô hình SPICE yêu cầu bạn chọn nguồn dữ liệu để trích xuất thông tin tham số:
- Dữ liệu đo – chọn tùy chọn này nếu dữ liệu nguồn của bạn được lấy từ các phép đo trên linh kiện thực tế và bạn muốn xây dựng một mô hình chính xác mô tả mọi khía cạnh của đặc tính DC.
- Bảng dữ liệu của nhà sản xuất – chọn tùy chọn này nếu dữ liệu nguồn của bạn được lấy từ bảng dữ liệu. Bảng dữ liệu thường không cung cấp đủ thông tin cần thiết để mô hình hóa mọi khía cạnh của linh kiện BJT. Tuy nhiên, chúng thường có đủ thông tin để tạo mô hình linh kiện chỉ dùng trong vùng tích cực thuận.
Sự khác biệt giữa hai tùy chọn này chủ yếu ảnh hưởng đến cách trích xuất các tham số mô hình hóa đặc tuyến dòng điện–điện áp DC của BJT. Đối với điện dung tiếp giáp phân cực ngược và thời gian quá cảnh, cách trích xuất tham số của hai tùy chọn là giống nhau.
Các phần sau trình bày chi tiết từng đặc tính mà bạn có thể chọn để mô hình hóa cho linh kiện BJT, tương ứng với loại dữ liệu nguồn (dữ liệu đo hoặc bảng dữ liệu). Các tham số được trích xuất trong từng trường hợp và dữ liệu nguồn mà Trình hướng dẫn yêu cầu để thực hiện việc trích xuất cũng được trình bày.
Các đặc tính được mô hình hóa bằng dữ liệu đo
Có thể mô hình hóa các đặc tính sau bằng dữ liệu thu được từ các phép đo trực tiếp trên linh kiện thực tế.
-
Forward-Bias Parameters
Các tham số sau được dùng để mô tả đặc tuyến dòng điện–điện áp DC của BJT trong vùng phân cực thuận:
IS
Dòng bão hòa vận chuyển (đơn vị A).
BF
Hệ số beta thuận cực đại lý tưởng.
NF
Hệ số phát xạ dòng thuận.
RB
Điện trở cực gốc khi không phân cực (đơn vị Ohm).
RC
Điện trở cực góp (đơn vị Ohm).
RE
Điện trở cực phát (đơn vị Ohm).
IKF
Dòng tại điểm bắt đầu suy giảm beta thuận ở dòng lớn (đơn vị A).
ISE
Dòng bão hòa rò B-E (đơn vị A).
NE
Hệ số phát xạ dòng rò B-E.
VAF
Điện áp Early thuận (đơn vị V).
Các phần sau trình bày chi tiết dữ liệu đo cần thiết; khi nhập dữ liệu này, Trình hướng dẫn sẽ có thể trích xuất các tham số trên.
-
Base-Emitter Voltage versus Base Current
Dữ liệu này được dùng để trích xuất ban đầu tham số RC. Hình bên dưới minh họa đồ thị điện áp cực gốc–cực phát (VBE) theo dòng cực gốc (IB), cùng một mạch thử nghiệm có thể dùng để đo và thu thập dữ liệu. Mạch cấp cưỡng bức một dòng điện vào cực gốc, đồng thời đo điện áp hở mạch giữa cực gốc và cực phát.

Ví dụ về đồ thị và mạch đo VBE theo IB.Dữ liệu được nhập vào Trình hướng dẫn dưới dạng một chuỗi các điểm dữ liệu lấy từ đồ thị nguồn.
-
Collector-Emitter Voltage versus Base Current
Dữ liệu này được dùng để trích xuất ban đầu tham số RE. Hình bên dưới minh họa đồ thị điện áp cực góp–cực phát (VCE) theo dòng cực gốc (IB), cùng một mạch thử nghiệm có thể dùng để đo và thu thập dữ liệu. Mạch cấp cưỡng bức một dòng điện vào cực gốc, đồng thời đo điện áp hở mạch giữa cực góp và cực phát.

Ví dụ về đồ thị và mạch đo VCE theo IB.Dữ liệu được nhập vào Trình hướng dẫn dưới dạng một chuỗi các điểm dữ liệu lấy từ đồ thị nguồn.
-
Forward Gummel Plot
Dữ liệu này chủ yếu được dùng để trích xuất các tham số IS, BF, NF, RB, IKF, ISE và NE. Dữ liệu cũng được dùng để tối ưu hóa các tham số RC, RE và VAF. Hình bên dưới minh họa đồ thị Gummel, cùng một mạch thử nghiệm có thể dùng để đo và thu thập dữ liệu. Đồ thị Gummel thể hiện:
-
Dòng cực gốc theo điện áp cực gốc–cực phát (IB theo VBE).
-
Dòng cực góp theo điện áp cực gốc–cực phát (IC theo VBE).
Điện áp cực gốc–cực góp (VBC) được giữ ở mức 0 V.

Ví dụ về đồ thị Gummel thuận và mạch thử nghiệm.Dữ liệu được nhập vào Trình hướng dẫn dưới dạng một chuỗi các điểm dữ liệu lấy từ đồ thị Gummel nguồn. Phải nhập các giá trị IB và IC thô – Trình hướng dẫn sẽ áp dụng hàm LN cho dữ liệu đường cong.
-
-
Collector Current versus Base-Emitter Voltage
Dữ liệu này được dùng để trích xuất ban đầu tham số VAF. Hình bên dưới minh họa đồ thị dòng cực góp (IC) theo điện áp cực gốc–cực phát (VBE), cùng một mạch thử nghiệm có thể dùng để đo và thu thập dữ liệu. Mạch được dùng để tạo hai đường cong IC theo VBE, ứng với hai giá trị điện áp cực gốc–cực góp (VBC) khác nhau. Các đường cong nên được đo ở mức dòng thấp nhất có thể và với VBC gần 0 V nhất trong điều kiện thực tế cho phép.

Ví dụ về các đồ thị và mạch đo VBE theo IC.Dữ liệu được nhập vào Trình hướng dẫn dưới dạng một chuỗi các điểm dữ liệu trong hai bảng – mỗi bảng dành cho một đường cong dữ liệu nguồn. Trong mỗi trường hợp, cũng phải nhập giá trị VBC được sử dụng.
-
-
Reverse-Bias Parameters
Các tham số sau được dùng để mô tả đặc tuyến dòng điện–điện áp DC của BJT trong vùng phân cực ngược:
IS
Dòng bão hòa vận chuyển (đơn vị A).
BR
Hệ số beta ngược cực đại lý tưởng.
NR
Hệ số phát xạ dòng ngược.
RB
Điện trở cực gốc khi không phân cực (đơn vị Ohm).
RC
Điện trở cực góp (đơn vị Ohm).
RE
Điện trở cực phát (đơn vị Ohm).
IKR
Dòng tại điểm bắt đầu suy giảm beta ngược ở dòng lớn (đơn vị A).
ISC
Dòng bão hòa rò B-C (đơn vị A).
NC
Hệ số phát xạ dòng rò B-C.
VAR
Điện áp Early ngược (đơn vị V).
Các phần sau trình bày chi tiết dữ liệu đo cần thiết; khi nhập dữ liệu này, Trình hướng dẫn sẽ có thể trích xuất các tham số trên.
-
Reverse Gummel Plot
Dữ liệu này chủ yếu được dùng để trích xuất các tham số IS, BR, NR, RB, IKR, ISC và NC. Dữ liệu cũng được dùng để tối ưu hóa các tham số RC, RE và VAR. Hình bên dưới minh họa một đồ thị Gummel và một mạch thử nghiệm mẫu, có thể thực hiện các phép đo trên mạch này để thu thập dữ liệu. Đồ thị Gummel biểu diễn:
-
Dòng điện cực gốc theo điện áp cực gốc-cực góp (IB theo VBC).
-
Dòng điện cực phát theo điện áp cực gốc-cực góp (IE theo VBC).
Điện áp cực gốc-cực phát (VBE) được giữ ở mức 0 vôn.

Ví dụ về đồ thị Gummel ngược và mạch thử nghiệm.Dữ liệu được nhập vào trình hướng dẫn dưới dạng một chuỗi điểm dữ liệu lấy từ đồ thị Gummel gốc. Phải nhập các giá trị IB và IE thô — trình hướng dẫn sẽ áp dụng hàm LN cho dữ liệu đường cong.
-
-
Emitter Current versus Base-Collector Voltage
Dữ liệu này được dùng để trích xuất ban đầu tham số VAR. Hình bên dưới minh họa một đồ thị dòng điện cực phát (IE) theo điện áp cực gốc-cực góp (VBC) và một mạch thử nghiệm mẫu, có thể thực hiện các phép đo trên mạch này để thu thập dữ liệu. Mạch được dùng để tạo hai đường cong IE theo VBC ứng với hai giá trị điện áp cực gốc-cực phát (VBE) khác nhau. Nên đo các đường cong ở mức dòng điện thấp nhất có thể và với VBE gần 0 vôn nhất trong điều kiện thực tế.

Ví dụ về đồ thị và mạch cho IE theo VBC.Dữ liệu được nhập vào trình hướng dẫn dưới dạng một chuỗi điểm dữ liệu trong hai bảng — mỗi bảng tương ứng với một đường cong dữ liệu nguồn. Giá trị VBE được sử dụng cũng phải được nhập cho từng trường hợp.
-
Các đặc tính được mô hình hóa bằng dữ liệu từ bảng thông số kỹ thuật của nhà sản xuất
Có thể mô hình hóa các đặc tính sau bằng dữ liệu lấy từ bảng thông số kỹ thuật của nhà sản xuất.
-
Forward-Bias Parameters
Các tham số sau được dùng để mô tả đặc tính dòng điện-điện áp DC của BJT trong vùng phân cực thuận:
IS
Dòng điện bão hòa vận chuyển (đơn vị ampe).
BF
Hệ số beta thuận cực đại lý tưởng.
NF
Hệ số phát xạ dòng điện thuận.
RE
Điện trở cực phát (đơn vị ôm).
IKF
Dòng điện tại điểm bắt đầu suy giảm beta thuận ở dòng điện cao (đơn vị ampe).
ISE
Dòng điện bão hòa rò B-E (đơn vị ampe).
NE
Hệ số phát xạ dòng rò B-E.
Các phần sau trình bày chi tiết dữ liệu cần nhập để trình hướng dẫn có thể trích xuất các tham số này.
-
Base-Emitter Voltage versus Collector Current
Dữ liệu này được dùng để trích xuất các tham số IS, NF, RE và IKF. Hình bên dưới minh họa một đồ thị điện áp cực gốc-cực phát (VBE) theo dòng điện cực góp (IC), lấy từ bảng thông số kỹ thuật.
Dữ liệu được nhập vào trình hướng dẫn dưới dạng một chuỗi điểm dữ liệu lấy từ đồ thị gốc. Phải nhập các giá trị IC thô — trình hướng dẫn sẽ áp dụng hàm LN cho dữ liệu đường cong.
Cũng cần nhập giá trị tỷ số beta cưỡng bức của đường cong (β = IC/IB). Trong đồ thị ví dụ ở hình trên, giá trị này được hiển thị ở góc trên bên trái của đồ thị, do đó cần nhập giá trị 10.
-
DC Current Gain versus Collector Current
Dữ liệu này được dùng để trích xuất các tham số BF, NE, ISE và IKF. Hình bên dưới minh họa một đồ thị hệ số khuếch đại dòng điện DC (hFE) theo dòng điện cực góp (IC), lấy từ bảng thông số kỹ thuật.
Dữ liệu được nhập vào trình hướng dẫn dưới dạng một chuỗi điểm dữ liệu lấy từ đồ thị gốc. Để đảm bảo độ chính xác, nên nhập các giá trị hệ số khuếch đại dòng điện DC ứng với các mức dòng điện cực góp thấp, trung bình và cao.
-
-
Forward Early Voltage
Tham số sau được dùng để mô hình hóa hiệu ứng điều biến độ rộng vùng cực gốc trong mô hình transistor Gummel-Poon:
VAF
Điện áp Early thuận (đơn vị vôn).
Để trích xuất tham số này, bạn cần nhập một điểm từ đường cong dẫn nạp đầu ra (hOE) theo dòng điện cực góp (IC). Hình bên dưới minh họa một đường cong như vậy.
Đọc một giá trị bất kỳ trên đường cong. Trong ví dụ ở hình trên, ta có thể đọc được IC = 1mA và hOE = 30μmhos.
Thông thường, dữ liệu được trình bày dưới dạng bảng, như ví dụ trong hình bên dưới.

Ví dụ về dữ liệu dẫn nạp đầu ra dạng bảng.Các giá trị cần quan tâm trong hình — và cũng là các giá trị cần nhập vào trình hướng dẫn — là 1mA cho dòng điện cực góp và 30μmhos cho dẫn nạp đầu ra (thường sử dụng giá trị cực đại).
Các đặc tính được mô hình hóa bằng dữ liệu đo hoặc dữ liệu của nhà sản xuất
Có thể mô hình hóa các đặc tính sau bằng dữ liệu lấy từ bảng thông số kỹ thuật của nhà sản xuất hoặc từ các phép đo trực tiếp trên linh kiện thực tế.
-
Base-Emitter Capacitance
Các tham số sau được dùng để mô tả điện dung tiếp giáp phân cực ngược của tiếp giáp cực gốc-cực phát:
CJE
Điện dung vùng nghèo B-E khi không phân cực (đơn vị fara).
MJE
Hệ số số mũ của tiếp giáp B-E.
VJE
Điện thế tiếp xúc nội tại B-E (đơn vị vôn).
Để trích xuất các tham số này, cần có đồ thị điện dung tiếp giáp B-E phân cực ngược (Cj) theo điện áp (VBE). Nếu không có máy đo điện dung, có thể sử dụng mạch thử nghiệm mẫu trong hình bên dưới để thu thập dữ liệu. Hình này cũng minh họa các đồ thị mẫu thu được từ mạch như vậy — lần lượt biểu diễn VBE và Cj theo thời gian. Từ các đồ thị này, có thể dễ dàng đọc được các giá trị VBE và Cj tại những thời điểm tương ứng.

Ví dụ về mạch và đồ thị điện dung tiếp giáp B-E phân cực ngược.Dữ liệu được nhập vào trình hướng dẫn dưới dạng một chuỗi điểm dữ liệu lấy từ các đồ thị gốc.
Mạch ví dụ trong hình trên dựa trên phương trình:
I = C * (dv/dt)Giải phương trình này theo C, ta được:
C = I/(dv/dt)Mạch tạo ra một điện áp tăng tuyến tính từ nguồn V1. Bằng cách tính độ dốc của điện áp này, có thể xác định thành phần
dv/dttrong phương trình. Lấy dòng điện điốt đo được chia cho độ dốc của điện áp tăng tuyến tính sẽ thu được đường cong điện dung của điốt. Hai đồ thị trong hình trên liên hệ với mạch như sau:-
Đồ thị trên – VBE là V1.
-
Đồ thị dưới – Cj là q1[ie]/(dV1/dt).
-
-
Base-Collector Capacitance
Các tham số sau được dùng để mô tả điện dung tiếp giáp khi phân cực ngược của tiếp giáp cực gốc–cực góp:
CJC
Điện dung vùng nghèo B-C khi không phân cực (đơn vị farad).
MJC
Hệ số mũ của tiếp giáp B-C.
VJC
Điện thế tiếp xúc của tiếp giáp B-C (đơn vị vôn).
Để trích xuất các tham số này, cần có đồ thị điện dung tiếp giáp B-C khi phân cực ngược (Cj) theo điện áp (VBC). Nếu không có máy đo điện dung, có thể dùng mạch thử nghiệm minh họa trong hình dưới để thu thập dữ liệu. Hình cũng cho thấy các đồ thị ví dụ thu được từ mạch này – lần lượt biểu diễn VBC và Cj theo thời gian. Từ các đồ thị này, có thể dễ dàng đọc các giá trị VBC và Cj tại những thời điểm tương ứng.

Mạch và đồ thị ví dụ về điện dung tiếp giáp B-C khi phân cực ngược.Dữ liệu được nhập vào trình hướng dẫn dưới dạng một chuỗi điểm dữ liệu lấy từ đồ thị nguồn.
Mạch ví dụ trong hình trên dựa trên phương trình:
I = C * (dv/dt)Giải phương trình này theo C, ta được:
C = I/(dv/dt)Mạch tạo ra một điện áp tăng tuyến tính từ nguồn V1. Bằng cách tính độ dốc của điện áp này, có thể xác định thành phần
dv/dttrong phương trình. Lấy dòng điện điốt đo được chia cho độ dốc của điện áp tăng tuyến tính sẽ thu được đường cong điện dung của điốt. Hai đồ thị trong hình trên liên hệ với mạch như sau:-
Đồ thị trên – VBC là V1.
-
Đồ thị dưới – Cj là q1[ic]/(dV1/dt).
-
-
Collector-Substrate Capacitance
Các tham số sau được dùng để mô tả điện dung tiếp giáp khi phân cực ngược của tiếp giáp cực góp–đế:
CJS
Điện dung cực góp–đế khi không phân cực (đơn vị farad).
MJS
Hệ số mũ của tiếp giáp đế.
VJS
Điện thế tiếp xúc của tiếp giáp đế (đơn vị vôn).
Để trích xuất các tham số này, cần có đồ thị điện dung tiếp giáp C-S khi phân cực ngược (Cj) theo điện áp (VCS). Nếu không có máy đo điện dung, có thể dùng mạch thử nghiệm minh họa trong hình dưới để thu thập dữ liệu. Hình cũng cho thấy các đồ thị ví dụ thu được từ mạch này – lần lượt biểu diễn VCS và Cj theo thời gian. Từ các đồ thị này, có thể dễ dàng đọc các giá trị VCS và Cj tại những thời điểm tương ứng.

Mạch và đồ thị ví dụ về điện dung tiếp giáp C-S khi phân cực ngược.Dữ liệu được nhập vào trình hướng dẫn dưới dạng một chuỗi điểm dữ liệu lấy từ đồ thị nguồn.
Mạch ví dụ trong hình trên dựa trên phương trình:
I = C * (dv/dt)Giải phương trình này theo C, ta được:
C = I/(dv/dt)Mạch tạo ra một điện áp tăng tuyến tính từ nguồn V1. Bằng cách tính độ dốc của điện áp này, có thể xác định thành phần
dv/dttrong phương trình. Lấy dòng điện điốt đo được chia cho độ dốc của điện áp tăng tuyến tính sẽ thu được đường cong điện dung của điốt. Hai đồ thị trong hình trên 24 liên hệ với mạch như sau:-
Đồ thị trên – VCS là V1.
-
Đồ thị dưới – Cj là q1[is]/(dV1/dt).
-
-
Transit Times
Các tham số sau được dùng để mô tả thời gian chuyển tiếp của BJT:
TF
Thời gian chuyển tiếp thuận lý tưởng (đơn vị giây).
TR
Thời gian chuyển tiếp ngược lý tưởng (đơn vị giây).
Để trích xuất các tham số này, trình hướng dẫn yêu cầu nhập tần số độ lợi bằng một (fT) của transistor. Đây là tần số mà tại đó độ lợi dòng điện của transistor bằng một. Dữ liệu này thường có trong bảng dữ liệu của nhà sản xuất dưới dạng các giá trị số đơn giản.
Hình dưới minh họa cách thông tin này được trình bày trong bảng dữ liệu của nhà sản xuất. Giá trị cần quan tâm trong hình – giá trị cần nhập vào trình hướng dẫn – là 100MHz.

Ví dụ về mục Tích độ lợi dòng điện–băng thông trong bảng.
Các tham số không được trình hướng dẫn trích xuất
Các tham số sau khó trích xuất từ dữ liệu đo và thường không có trong bảng dữ liệu của nhà sản xuất. Trình hướng dẫn không trích xuất các tham số này và cũng không thêm chúng vào tệp mô hình BJT được tạo ra. Mặc dù không có trong tệp MDL, SPICE vẫn sử dụng các tham số này khi mô phỏng linh kiện BJT – với các giá trị mặc định vốn có của chúng. Các giá trị mặc định này được liệt kê dưới đây để tiện tham khảo.
IRB |
Dòng điện tại đó điện trở cực gốc giảm đến điểm giữa giá trị ban đầu và giá trị tối thiểu (đơn vị ampe). (Mặc định = vô hạn). |
|
RBM |
Điện trở cực gốc tối thiểu ở dòng điện lớn (đơn vị ôm). (Mặc định = RB). |
|
XTF |
Hệ số biểu thị sự phụ thuộc của TF vào phân cực. (Mặc định = 0). |
|
VTF |
Điện áp mô tả sự phụ thuộc của TF vào VBC (đơn vị vôn). (Mặc định = vô hạn). |
|
ITF |
Tham số dòng điện lớn mô tả ảnh hưởng đến TF (đơn vị ampe). (Mặc định = 0). |
|
PTF |
Pha dư tại tần số freq=1.0/(TF*2PI)Hz (đơn vị độ). (Mặc định = 0). |
|
XCJC |
Tỷ phần điện dung vùng nghèo B-C nối với nút cực gốc bên trong. (Mặc định = 1). |
|
XTB |
Số mũ nhiệt độ của beta thuận và ngược. (Mặc định = 0). |
|
EG |
Độ rộng vùng cấm dùng để mô tả ảnh hưởng của nhiệt độ đến IS (đơn vị eV). (Mặc định = 1.11). |
|
XTI |
Số mũ nhiệt độ mô tả ảnh hưởng đến IS. (Mặc định = 3). |
|
KF |
Hệ số nhiễu nhấp nháy. (Mặc định = 0). |
|
AF |
Số mũ nhiễu nhấp nháy. (Mặc định = 1). |
|
FC |
Hệ số trong công thức tính điện dung vùng nghèo khi phân cực thuận. (Mặc định = 0.5). |
|
TNOM |
Nhiệt độ đo tham số (tính bằng ˚C). (Giá trị mặc định của tham số này bằng giá trị được nhập cho tham số TNOM trên trang SPICE Options của hộp thoại Analysis Setup. Giá trị này mặc định là 27˚C). |
Tất nhiên, bạn có thể thêm thủ công bất kỳ tham số nào trong số này vào tệp MDL và chỉ định các giá trị muốn sử dụng theo yêu cầu.
