Nhập các thư viện hiện có vào Workspace được kết nối của bạn
Sơ lược
- Tìm hiểu cách truy cập Library Importer và lựa chọn giữa chế độ Đơn giản và Nâng cao.
- Nắm rõ những thư viện và dữ liệu linh kiện có thể nhập, cùng các giới hạn chính.
- Khám phá bản xem trước khi nhập, cách phân loại linh kiện, thiết lập tham số và báo cáo để xem xét và tinh chỉnh quá trình nhập.
Altium Designer, kết hợp với Workspace được kết nối của bạn, cung cấp quy trình tinh gọn với mức độ tự động hóa cao để nhanh chóng nhập các thư viện hiện có vào Workspace đó. Giao diện của quy trình này – Library Importer – mang đến giải pháp chỉ bằng một lần nhấp, tự động phân tích các thư viện đã chọn và nhập chúng vào Workspace mà bạn đang kết nối.
Hỗ trợ mọi loại thư viện thuộc các phương thức quản lý linh kiện trước đây (SchLib, PcbLib, IntLib, DbLib, SVNDbLib), Library Importer là giải pháp chuyên dụng giúp nhanh chóng xây dựng thư viện linh kiện trên Workspace của công ty, để bạn có thể tận dụng nhiều lợi ích: tính toàn vẹn cao, lưu trữ và quản lý tập trung, dễ dàng tái sử dụng thiết kế, cùng thông tin chuỗi cung ứng theo thời gian thực.
Library Importer cung cấp chế độ giao diện Simple tối giản, trong đó các thư viện linh kiện dựa trên cơ sở dữ liệu và tệp đã chọn được nhập thành các linh kiện trên Workspace chỉ trong một bước. Trong quá trình đó, công cụ nhập tự động xử lý việc phân loại, thư mục nguồn đích, lựa chọn tham số cần đưa vào và kiểu giá trị, cũng như chuyển toàn bộ dữ liệu liên quan. Giao diện cũng có chế độ Advanced, cung cấp bản xem trước đầy đủ về nội dung thư viện dự kiến nhập, đồng thời cho phép truy cập dữ liệu và các thiết lập liên quan. Mặc dù theo mặc định, quá trình nhập chỉ cần một lần nhấp, công cụ nhập cũng cung cấp các tùy chọn cấu hình nâng cao thông qua bảng Properties để kiểm soát chính xác hơn cách thực hiện quá trình nhập.
Những gì được nhập?
Toàn bộ thông tin có trong thư viện nguồn ban đầu đều được nhập vào các linh kiện trên Workspace, bao gồm tất cả các mô hình miền được tham chiếu (ký hiệu sơ đồ nguyên lý, footprint PCB, mô hình mô phỏng), thông tin tham số, các lựa chọn mã linh kiện đã gán, tệp datasheet, v.v. Các mẫu linh kiện cũng được tạo khi cần, sau đó có thể được tinh chỉnh và dùng cho những lần nhập thư viện tiếp theo.
Nếu các linh kiện ban đầu của bạn được định nghĩa nhiều footprint PCB, Library Importer sẽ chuyển cả các mô hình đó sang và giữ nguyên footprint mặc định hiện tại. Nếu bạn chỉ làm việc với thư viện PCB – tức là chỉ quan tâm đến bố trí PCB – thì Library Importer hỗ trợ nhập riêng các thư viện đó, hoặc có thể chuyển sang chế độ chỉ nhập mô hình, trong đó các loại mô hình được chỉ định sẽ được nhập từ thư viện tích hợp hoặc thư viện cơ sở dữ liệu. Các thư viện chứa nhiều loại linh kiện (thư viện nguyên khối) cũng được tự động phát hiện và xử lý.
Mặc dù quá trình nhập thư viện phải xử lý các nguồn thư viện dựa trên cơ sở dữ liệu và tệp có thể sử dụng nhiều tiêu chuẩn định dạng khác nhau, các quy trình phân tích tự động vẫn phát hiện được loại linh kiện trong thư viện nguồn (điện trở, tụ điện, v.v.), cũng như tên tham số và kiểu giá trị của chúng (Vôn, Ôm, v.v.). Hệ thống thực hiện và xử lý nhiều bước kiểm tra, chẳng hạn như bảo đảm không có ID trùng lặp cho các linh kiện được tạo trong thư viện Workspace, hoặc bảo đảm không tạo ra các mô hình hay mẫu linh kiện trùng lặp, đồng thời tái sử dụng các đối tượng đó cho (liên kết với) các linh kiện khi cần. Nếu phát sinh vấn đề, hệ thống sẽ đánh dấu và đề xuất cách giải quyết, nhằm đưa quá trình nhập trở lại bình thường nhanh chóng và suôn sẻ nhất có thể.
Các loại thư viện có thể nhập gồm:
-
Thư viện sơ đồ nguyên lý (
*.SchLib). -
Thư viện footprint PCB (
*.PcbLib). -
Thư viện tích hợp (
*.IntLib) -
Thư viện cơ sở dữ liệu (
*.DbLib). -
Thư viện cơ sở dữ liệu SVN (
*.SVNDbLib).
Truy cập Library Importer
Library Importer khả dụng khi bạn kết nối với một Workspace. Để truy cập công cụ nhập ở chế độ Simple :
-
Trong bảng Components, chọn tùy chọn Import Library từ menu
. Nếu một thư viện dựa trên cơ sở dữ liệu hoặc tệp đang được chọn trong cột Categories của bảng (hoặc trong menu thả xuống ở trên cùng khi bảng ở chế độ thu gọn), Library Importer sẽ mở cho thư viện này. Khi một loại linh kiện thư viện Workspace được chọn, hộp thoại Open tiêu chuẩn của Windows sẽ mở ra để bạn duyệt tìm và chọn tệp thư viện cần nhập.
-
Nhấp chuột phải vào một tệp thư viện trong bảng Projects và chọn Import Library từ menu ngữ cảnh.
-
Chọn Tools » Import Library trong trình biên tập ký hiệu sơ đồ nguyên lý hoặc footprint PCB khi một tệp thư viện cục bộ đang mở.
-
Chọn File » Import Library hoặc Tools » Import Library trong trình biên tập thư viện cơ sở dữ liệu.
-
Trong hộp thoại Libraries Preferences, chọn một mục thư viện trên thẻ Installed rồi nhấp vào Import.
-
Kéo và thả một tệp thư viện từ thư mục Windows vào bảng Explorer.
Chế độ Đơn giản cung cấp các tùy chọn để nhập ngay thư viện đã chọn hoặc mở Library Importer ở chế độ giao diện đồ họa đầy đủ

Library Importer khi được truy cập ở chế độ nhập Simple chỉ bằng một lần nhấp.
Để truy cập trực tiếp Library Importer ở chế độ giao diện Advanced, chọn File » Library Importer từ menu chính.

Library Importer khi được truy cập ở chế độ giao diện Advanced đầy đủ cũng hỗ trợ quy trình nhập chỉ bằng một lần nhấp.
Chế độ Đơn giản
Chế độ Đơn giản của Library Importer chọn sẵn mọi thiết lập của quá trình nhập dựa trên kết quả phân tích thư viện nguồn và Workspace được kết nối. Sau đó, hộp thoại Library Importer hiển thị bản tóm tắt cấu trúc nhập, bao gồm tổng số lượng của từng loại mục. Việc nhập thư viện được thực hiện chỉ trong một bước bằng lệnh
.
Chế độ giao diện Đơn giản này phù hợp với hầu hết các định dạng thư viện nguồn phổ biến, vốn thường chứa các loại linh kiện thông dụng (điện trở, tụ điện, mạch tích hợp, v.v.) và các giá trị tham số đã chuẩn hóa. Trong quá trình phân tích ban đầu, hệ thống suy ra loại linh kiện trong thư viện dựa trên ký hiệu định danh hoặc từ khóa tham số (LD?, LED, v.v.), sau đó tìm mẫu linh kiện tương ứng trong Workspace đích (LED). Mẫu này được áp dụng khi nhập các linh kiện đó, qua đó xác định các thiết lập nhập như thư mục đích (Components/LED), ánh xạ tham số, đơn vị giá trị tham số, v.v. – các mẫu phù hợp sẽ có sẵn trong Workspace nếu tùy chọn bao gồm dữ liệu mẫu được chọn trong quá trình kích hoạt Workspace Altium 365 hoặc cài đặt Altium On-Prem Enterprise Server.
Kết quả nhập thư viện, dưới dạng các linh kiện mới được tạo trong Workspace, có thể được xem trong cả bảng Explorer và Components. Các linh kiện được nhập bao gồm toàn bộ mô hình, các tham số được diễn giải theo Mẫu linh kiện đã áp dụng, các lựa chọn linh kiện được lấy từ dữ liệu nguồn Liên kết nhà cung cấp, cùng mọi liên kết hoặc tệp tham chiếu.
Các điểm đáng chú ý về quá trình nhập thư viện:
-
Thư viện hỗn hợp (thư viện chứa nhiều loại linh kiện) được tự động chia thành các nhóm con, trong đó mỗi nhóm đại diện cho một loại linh kiện có trong thư viện đó. Các nhóm được xử lý như những thư viện riêng biệt.
-
Thư viện nguồn có loại linh kiện không thể nhận dạng (không được phát hiện) sẽ được nhập mà không qua diễn giải, dưới dạng các linh kiện chưa được gán loại trong thư mục
Components/Uncategorizedcủa Workspace. Trước khi chạy quá trình nhập , bạn có thể giải quyết vấn đề này bằng cách áp dụng Ánh xạ ký hiệu định danh hoặc Nhóm theo tham số trong chế độ Advanced (giao diện đầy đủ). Ngoài ra, bạn có thể tiếp tục nhập rồi sửa đổi các thiết lập và thư mục của linh kiện sau đó thông qua bảng Explorer. - Quá trình nhập thư viện bao gồm bước Kiểm tra tính hợp lệ tự động cho linh kiện. Các linh kiện gây ra lỗi kiểm tra tính hợp lệ sẽ bị bỏ qua.
- Nếu phát hiện các mô hình trùng lặp trong thư viện nguồn cần nhập, chỉ một trong số các mô hình này được nhập và liên kết với các linh kiện được tạo ra trong Workspace đích. Một thông báo tương ứng sẽ xuất hiện ở đầu hộp thoại Library Importer.
-
Bạn có thể xem mọi lỗi phát sinh trong quá trình này tại Importing Report, được truy cập bằng nút
sau khi quá trình nhập hoàn tất.
Chế độ nâng cao
Giao diện đồ họa đầy đủ của Library Importer được hiển thị khi ở chế độ Advanced, cho phép kiểm soát chi tiết việc quản lý thư viện, loại linh kiện và tham số linh kiện. Khi kết hợp với bảng Properties, việc nhập thư viện linh kiện vào Workspace có thể được cấu hình theo nhu cầu cụ thể của bạn. Lưu ý rằng các thiết lập của công cụ nhập có thể được lưu và khôi phục bằng cách xuất/nhập tệp cấu hình.
Chế độ nâng cao được bật khi mở Library Importer bằng lệnh File » Library Importer hoặc khi chọn nút
trong chế độ Đơn giản. Các thư viện được thêm vào phần SOURCE LIBRARIES của công cụ nhập (nếu chưa có sẵn) bằng cách kéo và thả tệp thư viện vào khu vực này, nhấp chuột phải vào <All Libraries> rồi chọn Add Library từ menu ngữ cảnh, hoặc chọn nút
.
Phần Import Preview liệt kê các nhóm loại linh kiện được nhận diện từ thư viện nguồn – dưới dạng Types hoặc Folder Structure được đề xuất và bao gồm chế độ xem dạng lưới theo tham số của các linh kiện đó (Components). Có thể chỉnh sửa trực tiếp các giá trị tham số trong lưới mà không cần mở và chỉnh sửa thư viện nguồn. Khu vực Details bên dưới chứa thông tin bổ sung lấy từ linh kiện hiện được chọn – Lựa chọn linh kiện, Mô hình và Bảng dữ liệu.
Bất kể các tùy chọn và dữ liệu chi tiết được hiển thị trong giao diện, chế độ xem Nâng cao của công cụ nhập vẫn có thể được sử dụng tương tự như chế độ xem Đơn giản – chỉ cần nhấp vào nút
để bắt đầu quá trình nhập mà không cần can thiệp thêm. Cũng như trong quy trình ở chế độ xem Đơn giản, công cụ nhập đã phân tích thư viện, suy ra loại linh kiện mà thư viện chứa và áp dụng Mẫu linh kiện phù hợp. Mẫu này sẽ xác định thư mục đích trong Workspace, các Quy tắc đặt tên và Định nghĩa vòng đời được áp dụng, cũng như cách ánh xạ/diễn giải tham số.
Thư viện hỗn hợp
Các thư viện nguồn chứa nhiều loại linh kiện được các quy trình phân tích của công cụ nhập phát hiện và chia thành các nhóm thư viện con, để có thể xử lý như các thư viện riêng cho từng loại linh kiện. Việc phát hiện loại linh kiện dựa trên ký hiệu định danh của linh kiện nguồn (R?, C?, v.v.) cũng như các từ khóa (Resistor, Res, v.v.) có trong những tham số chính khác của linh kiện (Mô tả, ID, v.v.).
Trong ví dụ bên dưới, thư viện nguồn (ProjectABC.IntLib) đã được tự động “chia tách” theo các loại linh kiện được phát hiện (Tụ điện, Điện trở, v.v.). Bạn có thể chọn các loại này trong cột Folder Structure (hoặc cột Types) để xem trước các mục linh kiện thuộc từng loại trong lưới Components.
Lưu ý rằng có thể thay đổi cách hiển thị danh sách Components theo một số cách:
-
Nhấp vào tiêu đề cột để sắp xếp lại danh sách theo cột tham số đó, rồi nhấp lần nữa để đảo ngược thứ tự.
-
Từ menu ngữ cảnh khi nhấp chuột phải vào tiêu đề:
-
Chọn Clear Sorting để đưa thứ tự danh sách về thiết lập mặc định (theo cột Name với thứ tự tăng dần).
-
Chọn Best Fit để điều chỉnh độ rộng của một cột cụ thể cho vừa với nội dung.
-
Chọn Select Best Fit All Columns để điều chỉnh độ rộng của tất cả các cột hiện có cho vừa với nội dung của chúng.
-
Chọn Select Columns để truy cập hộp thoại Select Columns, nơi bạn có thể bật, tắt các cột tham số và sắp xếp lại vị trí của chúng trong danh sách.
-
-
Nhấp vào biểu tượng Bộ lọc trong tiêu đề cột để giới hạn danh sách theo một giá trị hiện có trong cột tham số, các giá trị trống/không trống hoặc một thiết lập bộ lọc Custom. Bộ lọc đang áp dụng được hiển thị ở cuối danh sách, nơi bạn có thể bật/tắt bộ lọc (bằng ô kiểm tương ứng), sửa đổi trong Filter Editor hoặc xóa bộ lọc. Chọn All thông qua biểu tượng bộ lọc ở tiêu đề cũng sẽ xóa bộ lọc đang áp dụng.
Linh kiện chưa được phân loại
Nếu một mục nhóm con của thư viện có tên là Uncategorized (và được liệt kê là Uncategorized trong Types hoặc Folder Structure và đi kèm với
biểu tượng), điều này cho biết công cụ nhập không thể phát hiện và gán loại cho nhóm linh kiện đó – Loại linh kiện thực tế được đặt thành None. Trong trường hợp này, các linh kiện không được nhận diện (IC logic đảo) sử dụng tiền tố ký hiệu định danh không được nhận dạng (U?) và các tham số của chúng không chứa những từ khóa có thể nhận diện như IC, logic, v.v.
Có thể xử lý vấn đề này bằng cách ánh xạ thủ công các ký hiệu định danh dùng cho những linh kiện đó tới loại linh kiện mong muốn trong hộp thoại Library Splitting, được truy cập qua nút
– nút này khả dụng khi thư viện nguồn (ProjectABC.IntLib) được chọn. Hộp thoại Library Splitting, với các giá trị mặc định, cung cấp các tùy chọn điều khiển để thiết lập cách nhóm thư viện tùy chỉnh cho các linh kiện chưa phân loại, dựa trên ánh xạ ký hiệu định danh theo loại linh kiện và việc tách nhóm theo tham số.
Khi đã chọn tùy chọn Map Designators của hộp thoại, hãy chọn loại linh kiện phù hợp với các linh kiện chưa phân loại từ danh sách thả xuống Component Type (bao gồm tất cả các loại linh kiện hiện có). Xác nhận ánh xạ loại–ký hiệu định danh đã hoàn tất (loại linh kiện Logic với các ký hiệu định danh U?) bằng nút
.
Khi loại linh kiện đã được xác định bằng ánh xạ vừa áp dụng, công cụ nhập sẽ sử dụng Mẫu linh kiện tương ứng (Logic) để cấu hình việc nhập thư viện theo các thiết lập của mẫu (thư mục, cách đặt tên, v.v.).
Lưu ý rằng nhờ tính linh hoạt của các thiết lập trong Công cụ nhập thư viện, bạn có thể nhập một loại thư viện linh kiện mới (chưa phân loại) cùng toàn bộ cơ sở hạ tầng cần thiết cho những lần nhập loại thư viện đó trong tương lai. Bằng cách chọn cấu hình nhập phù hợp – Loại linh kiện mới, Mẫu linh kiện, thư mục đích, ánh xạ tham số và các loại đơn vị Giá trị tham số – yêu cầu duy nhất cho lần nhập tiếp theo của loại thư viện đó là chọn Loại linh kiện đã xác định trước. Loại linh kiện được chọn sau đó sẽ quyết định tất cả các khía cạnh còn lại của quá trình nhập.
Loại khỏi quá trình nhập
Bạn cũng có thể loại trừ các loại linh kiện cụ thể khỏi quá trình nhập. Để loại trừ một loại linh kiện, trong danh sách Types, hãy nhấp chuột phải vào loại linh kiện muốn loại trừ rồi chọn Exclude from Importer từ menu ngữ cảnh – chuyển danh sách trong cột từ Folder Structure sang Types nếu muốn
Loại linh kiện bị loại trừ sẽ hiển thị mờ trong danh sách Types. Để xem các linh kiện bị loại trừ trong bảng, hãy nhấp vào Show Excluded Component (n), trong đó n biểu thị số linh kiện bị loại trừ.
Đưa lại vào quá trình nhập
Nếu bạn đã loại trừ một loại linh kiện khỏi quá trình nhập bằng lệnh Exclude from Importer được mô tả ở trên nhưng sau đó lại cần đưa loại linh kiện đó vào, hãy nhấp chuột phải vào loại linh kiện hiển thị mờ trong danh sách Types (hoặc Folder Structure) rồi chọn Include to Importer từ menu ngữ cảnh. Loại linh kiện sẽ xuất hiện trở lại trong danh sách Types, cho biết nó không còn bị loại trừ.
Lỗi và cảnh báo kiểm tra tính hợp lệ
Các linh kiện sẽ không được nhập chính xác vào Workspace, hoặc hoàn toàn không được nhập, được đánh dấu bằng các thẻ cảnh báo hoặc lỗi trong giao diện nâng cao khi chạy Công cụ nhập thư viện hoặc thực hiện kiểm tra tính hợp lệ của quá trình nhập Việc kiểm tra tính hợp lệ cũng kiểm tra đường dẫn thư mục Workspace trống, các tham số hệ thống xung đột và các mô hình trùng lặp. Lỗi nghiêm trọng sẽ chặn quá trình nhập.
Khi bạn thử thực hiện quá trình nhập, bảng Messages sẽ hiển thị các vấn đề vi phạm đã phát hiện, và một hộp thoại sẽ cho phép chọn hủy bỏ hoặc tiếp tục với cấu hình nhập hiện tại. Trong trường hợp tiếp tục, các linh kiện không hợp lệ sẽ không được nhập hoặc quá trình nhập sẽ thất bại.
Khi quá trình nhập bị hủy hoặc khi chạy kiểm tra tính hợp lệ thủ công, mọi linh kiện không vượt qua các bước kiểm tra nhập sẽ được gắn biểu tượng lỗi/cảnh báo kèm thông tin bổ sung trong vùng Details bên dưới. Các biểu tượng trong cột xem trước Status cho biết những mục linh kiện cụ thể vi phạm các quy tắc kiểm tra nhập.
Các phép kiểm tra tính hợp lệ được tích hợp sẵn được liệt kê bên dưới.
Mô tả linh kiện quá dài
Report mode:
Tóm tắt
Vi phạm này xảy ra khi mô tả của linh kiện cần nhập có hơn 256 ký tự.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
<ComponentName> description more then 256 characters.
trong đó:
-
ComponentNamelà tên của linh kiện vi phạm.
Khuyến nghị khắc phục
Chỉnh sửa mô tả linh kiện trong thư viện nguồn để không vượt quá giới hạn độ dài.
Lỗi mẫu linh kiện
Report mode:
Tóm tắt
Vi phạm này xảy ra khi có lỗi trong mẫu linh kiện được áp dụng cho các linh kiện cần nhập.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Component template has errors: <Descripion>
trong đó:
-
Descripionlà mô tả lỗi của mẫu linh kiện.
Khuyến nghị khắc phục
Dựa trên mô tả lỗi, tìm và sửa lỗi trong thư viện nguồn hoặc cấu hình nhập thư viện.
HRID linh kiện trùng lặp
Report mode:
Tóm tắt
Vi phạm này xảy ra khi ID mục của các linh kiện cần nhập trùng nhau.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
<ComponentName1> component HRID is duplicated with <ComponentName2> component HRID.
trong đó:
-
ComponentName1vàComponentName2là tên của các linh kiện vi phạm.
Khuyến nghị khắc phục
Trong vùng Parameter Mapping của bảng Properties, hãy đảm bảo tham số ID được ánh xạ tới một tham số trong thư viện nguồn có giá trị duy nhất cho từng linh kiện vi phạm. Bạn cũng có thể đặt ánh xạ cho tham số này thành <Auto> – trong trường hợp này, ID mục linh kiện sẽ được đặt tự động dựa trên Naming Scheme được chỉ định trong vùng Component của bảng (ở tab Advanced).
Ngoài ra, hãy đảm bảo tham số được chọn cho ID mục có giá trị duy nhất cho từng linh kiện gây ra vi phạm trong thư viện nguồn.
Hình học mô hình trùng lặp
Report mode:
Tóm tắt
Vi phạm này xảy ra khi các linh kiện cần nhập có mô hình ký hiệu với hình học giống nhau trong các thư viện nguồn.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
<SymbolModelName1> model has the same geometry as <SymbolModelName2> in your source library. Imported components will be linked to <SymbolModelName2>
trong đó:
-
SymbolModelName1vàSymbolModelName2là tên của các mô hình ký hiệu gây ra vi phạm.
HRID của linh kiện bị trống
Report mode:
Tóm tắt
Vi phạm này xảy ra khi ID mục của một linh kiện cần nhập bị trống.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
<ComponentName> component HRID is empty.
trong đó:
-
ComponentNamelà tên của linh kiện gây ra vi phạm.
Đề xuất cách khắc phục
Trong vùng Parameter Mapping của bảng Properties, hãy đảm bảo tham số ID được ánh xạ tới một tham số trong thư viện nguồn có giá trị cho linh kiện gây ra vi phạm. Bạn cũng có thể đặt ánh xạ cho tham số này thành <Auto> – trong trường hợp này, ID mục của linh kiện sẽ được đặt tự động dựa trên Naming Scheme được chỉ định trong vùng Component của bảng (trong thẻ Advanced).
Ngoài ra, hãy đảm bảo tham số được chọn có giá trị trong thư viện nguồn.
Cài đặt thực thể có Định nghĩa vòng đời bị trống
Report mode:
Tóm tắt
Vi phạm này xảy ra khi thư viện nguồn chứa nội dung thuộc loại chưa được gán định nghĩa vòng đời.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
<ContentType> entity settings in library <LibraryName>.<LibraryType> have empty Lifecycle Definition.
trong đó:
-
ContentTypelà loại nội dung (ví dụ: linh kiện hoặc ký hiệu) chưa được gán định nghĩa vòng đời. -
LibraryNamelà tên của thư viện nguồn chứa nội dung thuộc loại chưa được gán định nghĩa vòng đời. -
LibraryTypelà tên của nhóm thư viện con chứa nội dung thuộc loại chưa được gán định nghĩa vòng đời.
Đề xuất cách khắc phục
Hãy đảm bảo đã chọn một định nghĩa vòng đời trong danh sách thả xuống Lifecycle Definition cho loại nội dung gây ra vi phạm trong bảng Properties (trong thẻ Advanced). Nếu có các mục khả dụng trong danh sách thả xuống, hãy đảm bảo loại nội dung gây ra vi phạm được gán định nghĩa vòng đời. Tham khảo trang Thiết lập định nghĩa vòng đời cho Workspace để tìm hiểu thêm.
Cài đặt thực thể có Quy tắc đặt tên bản sửa đổi bị trống
Report mode:
Tóm tắt
Vi phạm này xảy ra khi thư viện nguồn chứa nội dung thuộc loại chưa được gán quy tắc đặt tên bản sửa đổi.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
<ContentType> entity settings in library <LibraryName>.<LibraryType> have empty Revision Naming Scheme.
trong đó:
-
ContentTypelà loại nội dung (ví dụ: linh kiện hoặc ký hiệu) chưa được gán quy tắc đặt tên bản sửa đổi. -
LibraryNamelà tên của thư viện nguồn chứa nội dung thuộc loại chưa được gán quy tắc đặt tên bản sửa đổi. -
LibraryTypelà tên của nhóm thư viện con chứa nội dung thuộc loại chưa được gán quy tắc đặt tên bản sửa đổi.
Đề xuất cách khắc phục
Hãy đảm bảo đã chọn một định nghĩa vòng đời trong danh sách thả xuống Quy tắc đặt tên bản sửa đổi cho loại nội dung gây ra vi phạm trong bảng Properties (trong thẻ Advanced). Nếu có các mục khả dụng trong danh sách thả xuống, hãy đảm bảo loại nội dung gây ra vi phạm được gán quy tắc đặt tên bản sửa đổi. Tham khảo trang Thiết lập quy tắc đặt tên bản sửa đổi cho Workspace để tìm hiểu thêm.
Thư mục không tồn tại
Report mode:
Tóm tắt
Vi phạm này xảy ra khi thư mục đích để nhập nội dung không tồn tại trong Workspace đang kết nối.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Folder '<FolderPath>' does not exist
trong đó:
-
FolderPathlà đường dẫn đến thư mục đích không tồn tại trong Workspace đang kết nối.
Đề xuất cách khắc phục
Trong bảng Properties, hãy chỉ định thư mục đích bằng cách nhấp vào nút
ở bên phải trường Folder cho nội dung sẽ được lưu vào Workspace. Trong hộp thoại Choose Folder mở ra, hãy duyệt đến và chọn một thư mục hiện có hoặc tạo ngay một thư mục mới.
Không tìm thấy footprint trong các thư viện khả dụng
Report mode:
Tóm tắt
Vi phạm này xảy ra khi một linh kiện có footprint được liên kết nhưng không thể tìm thấy footprint đó trong các thư viện khả dụng.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Footprint <FootprintName> is not found in available libraries. Any referenced footprints can only be found if the relevant PcbLib(s) are either installed, or are added to the Library Importer directly.
trong đó:
-
FootprintNamelà tên của footprint bị thiếu.
Đề xuất cách khắc phục
Thêm các thư viện chứa footprint được liên kết vào Library Importer. Bạn có thể thực hiện việc này bằng cách nhấp vào điều khiển Choose a Library trong vùng Details khi một linh kiện có vi phạm này được chọn trong vùng Components.
Ngoài ra, hãy đảm bảo các thư viện chứa footprint được liên kết với những linh kiện cần nhập đã được cài đặt (tham khảo trang Tìm kiếm linh kiện trong thư viện cơ sở dữ liệu & thư viện dựa trên tệp để tìm hiểu thêm về các thư viện đã cài đặt) hoặc chỉnh sửa liên kết đến footprint trong thư viện nguồn.
Tham khảo phần Nhập thư viện sơ đồ nguyên lý để tìm hiểu thêm.
Ánh xạ tham số không hợp lệ
Report mode:
Tóm tắt
Vi phạm này xảy ra khi có lỗi trong cấu hình ánh xạ tham số.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Parameter mapping in library <LibraryName>.<LibraryType> has error: <Descripion>
trong đó:
-
LibraryNamelà tên thư viện nguồn có chứa linh kiện được ánh xạ tham số không chính xác. -
LibraryTypelà tên nhóm thư viện con có chứa linh kiện được ánh xạ tham số không chính xác. -
Descripionlà mô tả về vi phạm ánh xạ tham số.
Đề xuất khắc phục
Trong vùng Parameter Mapping của bảng Properties, tìm các tham số có biểu tượng
và cập nhật ánh xạ cho phù hợp. Ngoài ra, có thể xóa các mục ánh xạ bị lỗi.
Mục có HRID đã được phát hành
Report mode:
Tóm tắt
Vi phạm này xảy ra khi ID mục của linh kiện cần nhập trùng với ID của một mục đã có trong Workspace đích.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Item with HRID <ItemID> already released.
trong đó:
-
ItemIDlà ID được sử dụng cho một mục trong Workspace.
Đề xuất khắc phục
Trong vùng Parameter Mapping của bảng Properties, hãy đảm bảo rằng tham số ID được ánh xạ tới một tham số trong thư viện nguồn có giá trị duy nhất. Bạn cũng có thể đặt ánh xạ cho tham số này thành <Auto> – trong trường hợp này, ID mục của linh kiện sẽ được đặt tự động dựa trên Naming Scheme được chỉ định trong vùng Component của bảng (trong thẻ Advanced). Khi đó, hãy đảm bảo rằng Naming Scheme được thiết lập để tạo ra các ID mục duy nhất.
Ngoài ra, hãy đảm bảo rằng tham số được chọn làm ID mục có giá trị duy nhất trong thư viện nguồn.
Không tìm thấy định nghĩa vòng đời để nhập bảng dữ liệu
Report mode:
Tóm tắt
Vi phạm này xảy ra khi thư viện nguồn có các linh kiện được liên kết với bảng dữ liệu và loại nội dung Datasheet chưa được gán cho một định nghĩa vòng đời.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Lifecycle Definition to import <LibraryName>.<LibraryType> library datasheets is not found.
trong đó:
-
LibraryNamelà tên thư viện nguồn có các linh kiện kèm bảng dữ liệu. -
LibraryTypelà tên nhóm thư viện con có các linh kiện kèm bảng dữ liệu.
Đề xuất khắc phục
Hãy đảm bảo rằng loại nội dung Datasheet được gán cho một định nghĩa vòng đời. Tham khảo trang Thiết lập định nghĩa vòng đời cho Workspace để tìm hiểu thêm.
Ngoài ra, có thể tắt tính năng nhập tệp bảng dữ liệu bằng cách thay đổi tùy chọn Migrate trong vùng Datasheet của bảng Properties (trong thẻ Advanced).
Mô tả mô hình quá dài
Report mode:
Tóm tắt
Vi phạm này xảy ra khi mô tả mô hình của linh kiện dài hơn 256 ký tự.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Description of Model '<ModelName>' of component '<ComponentName>' more then 256 characters.
trong đó:
-
ModelNamelà tên mô hình vi phạm. -
ComponentNamelà tên linh kiện chứa mô hình vi phạm.
Đề xuất khắc phục
Chỉnh sửa mô tả mô hình trong thư viện nguồn để không vượt quá giới hạn độ dài.
Giá trị tham số bắt buộc bị bỏ trống
Report mode:
Tóm tắt
Vi phạm này xảy ra khi mẫu linh kiện được liên kết có một tham số được đánh dấu là bắt buộc nhưng tham số này không có giá trị trong thư viện nguồn.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
<ParameterName> required parameter value in component <ComponentName> is empty.
trong đó:
-
ParameterNamelà tên tham số vi phạm. -
ComponentNamelà tên linh kiện chứa tham số vi phạm.
Đề xuất khắc phục
Thêm giá trị cho tham số vi phạm trong thư viện nguồn hoặc trực tiếp trong vùng lưới của Library Importer. Ngoài ra, có thể chỉnh sửa ánh xạ tham số trong vùng Parameter Mapping của bảng Properties (trong thẻ General ) để tham số bắt buộc được ánh xạ tới một tham số có giá trị trong thư viện nguồn.
Không tìm thấy quy tắc đặt tên bản sửa đổi để nhập bảng dữ liệu
Report mode:
Tóm tắt
Vi phạm này xảy ra khi thư viện nguồn có các linh kiện được liên kết với bảng dữ liệu và loại nội dung Datasheet chưa được gán cho một quy tắc đặt tên bản sửa đổi.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Revision Naming Scheme to import <LibraryName>.<LibraryType> library datasheets is not found.
trong đó:
-
LibraryNamelà tên thư viện nguồn có các linh kiện kèm bảng dữ liệu. -
LibraryTypelà tên nhóm thư viện con có các linh kiện kèm bảng dữ liệu.
Đề xuất khắc phục
Hãy đảm bảo rằng loại nội dung Datasheet được gán cho một quy tắc đặt tên bản sửa đổi. Tham khảo trang Thiết lập quy tắc đặt tên bản sửa đổi cho Workspace để tìm hiểu thêm.
Ngoài ra, có thể tắt tính năng nhập tệp bảng dữ liệu bằng cách thay đổi tùy chọn Migrate trong vùng Datasheet của bảng Properties (trong thẻ Advanced).
Không tìm thấy tệp mô hình mô phỏng
Report mode:
Tóm tắt
Vi phạm này xảy ra khi linh kiện có một mô hình mô phỏng được liên kết nhưng không thể tìm thấy mô hình đó tại đường dẫn đã chỉ định.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Simulation model file <Path> is not found.
trong đó:
-
Pathlà đường dẫn đã chỉ định tới mô hình mô phỏng.
Đề xuất khắc phục
Hãy đảm bảo rằng mô hình mô phỏng nằm tại đường dẫn đã chỉ định. Ngoài ra, có thể cập nhật đường dẫn tới mô hình trong thư viện nguồn.
Tên ký hiệu không được để trống
Report mode:
Tóm tắt
Vi phạm này xảy ra khi linh kiện không có ký hiệu được liên kết.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Symbol name cannot be empty.
Đề xuất khắc phục
Hãy đảm bảo rằng liên kết tới ký hiệu được xác định chính xác cho linh kiện trong thư viện nguồn.
Bạn không có quyền truy cập để sửa đổi thư mục
Report mode:
Tóm tắt
Vi phạm này xảy ra khi bạn không có quyền ghi vào thư mục đích trong Workspace được kết nối.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
You do not have access right to modify folder <FolderPath>.
trong đó:
-
FolderPathlà đường dẫn đến thư mục đích trong Workspace được kết nối mà bạn không có quyền chỉnh sửa.
Khuyến nghị khắc phục
Yêu cầu quản trị viên Workspace cấp cho bạn quyền ghi vào thư mục (tham khảo trang Kiểm soát quyền truy cập nội dung Workspace để tìm hiểu thêm).
Ngoài ra, hãy sử dụng bảng Properties để chọn một thư mục khác mà bạn có quyền ghi. Nhấp vào nút
ở bên phải trường Folder của nội dung sẽ được lưu vào Workspace, rồi trong hộp thoại Choose Folder mở ra, duyệt đến và chọn một thư mục hiện có hoặc tạo ngay một thư mục mới.
Các phép kiểm tra do người dùng xác định được cấu hình trong vùng Import Checks của bảng Properties. Sử dụng menu thả xuống Report Mode để chọn mức báo cáo khác cho loại vi phạm tương ứng. Các phép kiểm tra này được liệt kê dưới đây.
Linh kiện bị trùng lặp theo tham số
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một linh kiện trong các thư viện nguồn cần nhập có giá trị tham số được đặt là duy nhất, nhưng một linh kiện trong Workspace đích cũng có cùng giá trị cho tham số này. Tham khảo phần Phát hiện trùng lặp để tìm hiểu thêm.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Component <ComponentName> is duplicated with components by parameter <ParameterName> (<ParameterValue>):
- Server components: <WorkspaceComponentList>
trong đó:
-
ComponentNamelà tên của linh kiện vi phạm. -
ParameterNamelà tên của tham số được đặt là duy nhất. -
ParameterValuelà giá trị của tham số được đặt là duy nhất. -
WorkspaceComponentListlà danh sách ID Item-Revision của các linh kiện trong Workspace đích có giá trị trùng lặp ở tham số được đặt là duy nhất.
Khuyến nghị khắc phục
Kiểm tra các tham số linh kiện trong thư viện nguồn cần nhập và đảm bảo đã chọn đúng tham số làm tham số duy nhất trong danh sách thả xuống Unique Field trên thẻ Advanced của bảng Properties.
Nếu linh kiện cần nhập giống với linh kiện đã có trong Workspace đích, bạn có thể loại linh kiện đó khỏi quá trình di chuyển – tìm hiểu thêm.
Linh kiện bị trùng lặp theo lựa chọn linh kiện
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi Workspace đích chứa một linh kiện có cùng lựa chọn linh kiện với một linh kiện trong các thư viện nguồn cần nhập. Tham khảo phần Phát hiện trùng lặp để tìm hiểu thêm.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Component <ComponentName> is duplicated with components by Part Choices:
- Server components: <WorkspaceComponentList> (<Manufacturer> <PartNumber>)
trong đó:
-
ComponentNamelà tên của linh kiện vi phạm. -
WorkspaceComponentListlà danh sách ID Item-Revision của các linh kiện trong Workspace đích có cùng lựa chọn linh kiện với linh kiện trong thư viện nguồn cần nhập. -
Manufacturerlà tham số nhà sản xuất của lựa chọn linh kiện bị trùng lặp. -
PartNumberlà tham số mã linh kiện của lựa chọn linh kiện bị trùng lặp.
Khuyến nghị khắc phục
Kiểm tra các tham số linh kiện trong thư viện nguồn cần nhập và đảm bảo các ánh xạ tham số lựa chọn linh kiện (được liệt kê trong vùng Part Choices Mapping trên thẻ General của bảng Properties) là chính xác.
Nếu linh kiện cần nhập giống với linh kiện đã có trong Workspace đích, bạn có thể loại linh kiện đó khỏi quá trình di chuyển – tìm hiểu thêm.
Mẫu linh kiện bị trùng lặp
Chức năng xác thực của Library Importer hiện chưa thực hiện phép kiểm tra này.
Chưa xác định loại linh kiện
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi có một linh kiện chưa được phân loại, tức là linh kiện chưa được gán loại linh kiện.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
<ComponentName> component type is undefined.
trong đó:
-
ComponentNamelà tên của linh kiện vi phạm.
Khuyến nghị khắc phục
Gán loại linh kiện cho linh kiện chưa được phân loại. Tham khảo phần Linh kiện chưa được phân loại để tìm hiểu thêm.
Không tìm thấy bảng dữ liệu
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi không tìm thấy bảng dữ liệu theo liên kết được xác định trong một linh kiện thuộc thư viện nguồn.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Datasheet <Path> is not found.
trong đó:
-
Pathlà đường dẫn đến bảng dữ liệu được xác định trong linh kiện thuộc thư viện nguồn.
Khuyến nghị khắc phục
Tìm và khôi phục tệp bảng dữ liệu bị thiếu về vị trí dự kiến. Ngoài ra, bạn có thể tắt tính năng nhập tệp bảng dữ liệu bằng cách thay đổi tùy chọn Migrate trong vùng Datasheet của bảng Properties (trên thẻ Advanced).
Không hỗ trợ nhập ánh xạ chân
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một linh kiện trong thư viện nguồn có ánh xạ chân tùy chỉnh.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Import for <ComponentName> component pin mapping is not supported.
trong đó:
-
ComponentNamelà tên của linh kiện vi phạm.
Khuyến nghị khắc phục
Sau khi nhập, bạn có thể kiểm tra ánh xạ chân và cấu hình theo yêu cầu khi chỉnh sửa linh kiện trong trình biên tập linh kiện ở chế độ chỉnh sửa từng linh kiện – tìm hiểu thêm.
Giá trị tham số không hợp lệ
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi giá trị tham số của linh kiện không thể được diễn giải thành một giá trị hợp lệ theo loại đơn vị đã chỉ định.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
<ParameterName> parameter value <ParameterValue> in component <ComponentName> cannot be converted to unit of type <UnitType>.
trong đó:
-
ParameterNamelà tên của tham số linh kiện vi phạm. -
ParameterValuelà giá trị của tham số linh kiện vi phạm. -
ComponentNamelà tên của linh kiện có tham số vi phạm. -
UnitTypelà đơn vị đo hiện được đặt cho tham số vi phạm.
Khuyến nghị khắc phục
Chỉnh sửa giá trị tham số gây lỗi trong vùng lưới của Library Importer sang định dạng hợp lệ. Hoặc thay đổi đơn vị tham số được ánh xạ Type, được xác định bởi mẫu linh kiện đang áp dụng, thành không diễn giải Text từ vùng Parameter Mapping của bảng Properties (trong thẻ General) khi thư viện nguồn được chọn.
Ánh xạ lựa chọn linh kiện không hợp lệ
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi có lỗi trong cấu hình ánh xạ lựa chọn linh kiện.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
Part Choice mapping in library <LibraryName>.<LibraryType> has error: <Descripion>
trong đó:
-
LibraryNamelà tên thư viện nguồn chứa linh kiện có ánh xạ lựa chọn linh kiện không chính xác. -
LibraryTypelà tên nhóm thư viện con chứa linh kiện có ánh xạ lựa chọn linh kiện không chính xác. -
Descripionlà mô tả về vi phạm ánh xạ lựa chọn linh kiện.
Khuyến nghị khắc phục
Trong vùng Part Choices Mapping của bảng Properties, tìm các tham số có biểu tượng
và cập nhật ánh xạ cho phù hợp. Hoặc xóa các mục ánh xạ có lỗi.
Tên tham số trùng với tham số hệ thống
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một linh kiện trong thư viện nguồn có tham số trùng tên với một tham số hệ thống. Các tham số này như sau:
-
AncestorItemRevisionGUID -
Cat -
ComponentType -
ContentType -
ContentTypeGUID -
CreatedAt -
CreatedBy -
CreatedByGUID -
DynamicData -
Folder -
FolderGuid -
Hrid -
Id -
ItemDescription -
ItemGUID -
ItemHRID -
LatestRevision -
LifeCycle -
LifecycleStateGUID -
ModifiedBy -
ReleaseDate -
ReleaseDateNum -
ReleaseNote -
RevisionId -
RevisionNamingSchemeGUID -
SourceGUID -
SourceVaultGUID -
Text -
Updated -
UpdatedByGUID
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
'<ParameterName>' is system parameter
trong đó
-
ParameterNamelà tên tham số linh kiện gây lỗi.
Khuyến nghị khắc phục
Xóa mục ánh xạ của tham số gây lỗi khỏi vùng Parameter Mapping của bảng Properties (trong thẻ General). Hoặc xóa hay đổi tên tham số gây lỗi trong linh kiện thuộc thư viện nguồn.
Các tham số mô phỏng bị bỏ qua
Default report mode:
Tóm tắt
Vi phạm này xảy ra khi một linh kiện trong thư viện nguồn có mô hình mô phỏng được liên kết.
Thông báo
Một thông báo được hiển thị trong bảng Messages theo định dạng sau:
<ComponentName> component simulation parameters are skipped (<SimulationParameterList>).
trong đó:
-
ComponentNamelà tên linh kiện gây lỗi trong thư viện nguồn. -
SimulationParameterListlà danh sách các tham số mô phỏng, phân tách bằng dấu phẩy, sẽ bị bỏ qua trong quá trình nhập.
Khuyến nghị khắc phục
Sau khi nhập, bạn có thể cấu hình liên kết đến mô hình mô phỏng theo yêu cầu khi chỉnh sửa linh kiện trong trình biên tập linh kiện ở chế độ Chỉnh sửa một linh kiện – tìm hiểu thêm.
Khắc phục lỗi và cảnh báo
Các lỗi tham số, chẳng hạn như trong ví dụ ở đây khi giá trị Forward Voltage của linh kiện không thể được diễn giải thành điện áp hợp lệ, có thể được khắc phục bằng cách:
-
Chỉnh sửa giá trị tham số gây lỗi – tìm và chỉnh sửa ô tương ứng sang định dạng hợp lệ.
-
Thay đổi đơn vị tham số được ánh xạ Type, được xác định bởi Mẫu linh kiện đang áp dụng, từ
Voltagethành không diễn giảiText– chọn Thư viện nguồn trong giao diện trình nhập, rồi thay đổiForward VoltageType trong danh sách của bảng Thuộc tính Parameter Mapping (trong thẻ General). -
Loại linh kiện khỏi quá trình nhập – nhấp chuột phải vào mục tương ứng và chọn tùy chọn Exclude from Importer .
Lỗi thiếu tệp, chẳng hạn như không tìm thấy tệp bảng dữ liệu trong ví dụ ở đây, có thể được khắc phục bằng cách:
- Cách rõ ràng nhất là tìm và khôi phục tệp bị thiếu về vị trí dự kiến.
- Tắt tính năng nhập tệp bảng dữ liệu – thay đổi tùy chọn Migrate trong phần bảng Thuộc tính Datasheet (trong thẻ Advanced).
- Loại linh kiện khỏi quá trình nhập thư viện – như mô tả ở trên.
Sử dụng trường Search (phía trên bên phải) nếu bạn muốn tìm các mục linh kiện cụ thể. Tính năng tìm kiếm lọc danh sách các mục theo giá trị tham số khớp với loại linh kiện hiện được chọn – chọn All trong Types (Folder Structure) để tìm kiếm áp dụng cho tất cả linh kiện trong các thư viện nguồn hiện có.
Nhập thư viện nguyên lý
Nếu bạn gặp lỗi 'không tìm thấy mô hình' (chẳng hạn như Footprint <footprint name> not found in available libraries) khi nhập thư viện nguyên lý, điều đó có nghĩa là Library Importer không thể tìm thấy các mô hình được liên kết với các linh kiện trong SCHLIB.
Ở Chế độ đơn giản, các lỗi này sẽ được hiển thị trong Importing Report dựa trên HTML, có thể truy cập từ nút
xuất hiện sau khi quá trình nhập đã chạy. Ở Chế độ nâng cao, các lỗi được biểu thị bằng biểu tượng Trạng thái trong giao diện chính và dưới dạng các mục trong bảng Messages – điều này xảy ra khi thực hiện kiểm tra xác thực hoặc khi nhập thư viện
Các footprint bị thiếu được phát hiện chính xác trong quá trình Xác thực. Quá trình này cũng cung cấp tùy chọn Choose a Library trong báo cáo lỗi (trong danh sách thả xuống Details). Nếu phát hiện nhiều linh kiện bị thiếu footprint, hộp thoại Apply PcbLib Selection sẽ cung cấp các tùy chọn sử dụng PcbLib được chỉ định cho trường hợp này hoặc cho tất cả linh kiện bị thiếu footprint.
Một cách khác để khắc phục (hoặc tránh) vấn đề này là đảm bảo rằng các tệp thư viện mô hình cần thiết có sẵn trong Altium Designer. Các thư viện được cài đặt qua trang Quản lý dữ liệu – Thư viện dựa trên tệp của hộp thoại Preferences.
Hoặc nếu không muốn cài đặt nhiều thư viện mô hình, bạn cần đặt chúng trong đường dẫn thư viện mặc định của phần mềm (hoặc chỉnh sửa đường dẫn) và kiểm tra xem thư viện nguồn của mô hình đã được chỉ định cho các linh kiện trong Thư viện nguyên lý hay chưa:
- Đưa thư viện mô hình vào vị trí đường dẫn tìm kiếm mặc định của phần mềm. Thêm thư viện mô hình, chẳng hạn như thư viện PCB tương ứng, vào vị trí được chỉ định bởi đường dẫn thư viện mặc định của hệ thống. Để kiểm tra vị trí này, xem mục Library Path trên trang Hệ thống – Vị trí mặc định của hộp thoại Preferences. Nếu một tệp thư viện đã được thêm/sao chép vào vị trí đường dẫn đó, bạn có thể cần khởi động lại Altium Designer để ghi nhận thay đổi.
-
Chỉ định tên thư viện mô hình đích cho các linh kiện trong Thư viện nguyên lý. Để Library Importer nhận biết thư viện mô hình được liên kết với một linh kiện trong thư viện nguyên lý, hãy chỉ định tên thư viện đó trong hộp thoại Mô hình PCB của thư viện.
Phát hiện trùng lặp
Library Importer cũng có các cơ chế để tránh tạo linh kiện trùng lặp trong Workspace đích. Việc này được thực hiện trong quá trình kiểm tra tính hợp lệ bằng cách so sánh các tham số định danh linh kiện và các lựa chọn linh kiện (Part Choices) của thư viện nguồn với các thông tin tương ứng của linh kiện trong Workspace đích và trong các thư viện nguồn sẽ được nhập. Với thiết lập mặc định của trình nhập, bước kiểm tra tính hợp lệ sẽ hiển thị thông báo Warning khi phát hiện mục Name hoặc Part Choices giống nhau ở các linh kiện (cho thấy có khả năng trùng lặp linh kiện). Thông báo cảnh báo/lỗi được hiển thị bao gồm loại vi phạm trùng lặp (tham số hoặc Part Choice), tên linh kiện thư viện vi phạm và linh kiện (theo ID) bị trùng với linh kiện đó.

Hai trường hợp có khả năng trùng lặp được phát hiện trong quá trình kiểm tra tính hợp lệ, trong đó Name (hình trên) hoặc Part Choice (hình dưới) của linh kiện đã tồn tại trong các linh kiện trên Workspace.
Cặp tên–giá trị tham số dùng để phát hiện vi phạm trùng lặp được chỉ định trong vùng Duplicates Detection của bảng Properties, trên thẻ Advanced. Sử dụng menu thả xuống Unique Field (mặc định là Name) để chọn trong số các tham số có sẵn trong thư viện nguồn. Lựa chọn này đặc biệt hữu ích cho các cấu hình thư viện của công ty sử dụng trường định danh riêng có liên kết với hệ thống doanh nghiệp tổng thể.

Vi phạm trùng lặp được phát hiện khi giá trị của một tham số được chỉ định (ERP-REF) giống nhau ở một linh kiện trong thư viện cục bộ và một linh kiện trên Workspace.
Bạn có thể đặt loại cờ trạng thái khác cho các vi phạm trùng lặp bằng cách chọn một Report Mode khác trong vùng Import Checks, trên thẻ General của bảng Properties.
Việc phát hiện trùng lặp cũng được thực hiện đối với các mô hình ký hiệu của linh kiện. Nếu các linh kiện sẽ được nhập có các mô hình ký hiệu có cùng hình dạng trong các thư viện nguồn, chỉ một trong các mô hình này sẽ được nhập.
Thư viện dùng một mô hình duy nhất
Tính năng tự động phát hiện trùng lặp cũng được dùng để xử lý các thư viện nguồn sử dụng chung một mô hình ký hiệu cho tất cả linh kiện. Các thư viện như vậy thường chỉ bao gồm một loại linh kiện với các kiểu và giá trị khác nhau, chẳng hạn như các điện trở có cùng kiểu vỏ, trong đó ký hiệu của mỗi linh kiện là một hình đồ họa mô hình tiêu chuẩn.
Library Importer phát hiện trường hợp dùng chung một mô hình duy nhất này, sau đó cấu hình quá trình nhập để chuyển một mô hình ký hiệu áp dụng cho tất cả linh kiện được nhập – thay vì một ký hiệu tương ứng có tên riêng cho từng linh kiện. Ký hiệu được nhập sẽ lấy tên của một trong các ký hiệu sẽ được nhập, và tất cả tham số linh kiện vẫn giữ nguyên.
Bạn có thể chỉnh sửa ký hiệu thư viện đã nhập (có tên chung và trường Mô tả để trống) cho phù hợp với nhu cầu. Trong bảng Components, sử dụng tùy chọn Edit trong menu chuột phải để thực hiện thao tác này. Trong quá trình thực hiện, chọn tùy chọn Update items related to <symbol ID> trong hộp thoại Create Revisions for Item để bảo đảm các linh kiện đã nhập sử dụng bản sửa đổi mới của ký hiệu.
Chỉ nhập mô hình
Library Importer có thể được chuyển sang chế độ nhập đặc biệt Models Only để phát hiện và xử lý các mô hình linh kiện có sẵn trong thư viện nguồn.
Trong chế độ Chỉ mô hình, quá trình phân tích của trình nhập sẽ phát hiện tất cả các mô hình ký hiệu, footprint và mô phỏng có sẵn trong thư viện nguồn (IntLib, SchLib, PcbLib, v.v.), sau đó nhập các mô hình đó vào Workspace bằng cách sử dụng vị trí, quy tắc đặt tên và định nghĩa vòng đời mặc định của hệ thống.
Khi Library Importer được chuyển sang chế độ Nâng cao hoặc được mở ở chế độ Nâng cao (File » Library Importer), bạn có thể xem đầy đủ thông tin chi tiết về quá trình nhập mô hình dự kiến. Vùng Import Preview hiển thị Folder Structure sẽ được sử dụng trong Workspace đích; bạn có thể thay đổi thiết lập mặc định này trong trường Folder cho từng loại mô hình trong bảng Properties. Bạn có thể chọn các quy tắc đặt tên và định nghĩa vòng đời áp dụng cho từng mô hình từ các loại có sẵn trong hệ thống (xem bảng Properties bên dưới).
Nếu muốn, bạn có thể giới hạn việc nhập mô hình linh kiện vào Workspace theo loại bằng cách tắt (hoặc bật) các loại mô hình cụ thể trong bảng Properties thông qua các nút
tương ứng.
Sau khi cấu hình Library Importer, chọn nút
để hoàn tất việc nhập các mô hình linh kiện được liệt kê. Bạn có thể xem lại kết quả trong tệp nhật ký nhập được cung cấp qua hộp thoại tiến trình Library Importer , hoặc bằng cách xem các mô hình đã nhập trong bảng Components.
Chỉ nhập linh kiện
Tương tự chế độ nhập Models Only được mô tả ở trên, Library Importer có thể được chuyển sang chế độ nhập đặc biệt Components Only, cho phép bạn nhập các linh kiện có sẵn trong thư viện nguồn mà không nhập các mô hình được liên kết với chúng.
Trong chế độ Chỉ linh kiện, quá trình phân tích của trình nhập sẽ phát hiện tất cả linh kiện, tham số và Part Choices trong thư viện nguồn, sau đó nhập các linh kiện này vào Workspace bằng cách sử dụng vị trí, quy tắc đặt tên và định nghĩa vòng đời mặc định của hệ thống.
Khi Library Importer được chuyển sang chế độ Nâng cao hoặc được mở ở chế độ Nâng cao (File » Library Importer), bạn có thể xem đầy đủ thông tin chi tiết về quá trình nhập linh kiện dự kiến. Bạn có thể chọn thư mục áp dụng, quy tắc đặt tên và định nghĩa Vòng đời từ các loại có sẵn trong hệ thống (xem bảng Properties bên dưới).
Sau khi cấu hình Library Importer, chọn nút
để hoàn tất việc nhập các linh kiện trong danh sách. Chỉ các mục linh kiện được tạo trong Workspace, không kèm mô hình liên kết nào. Bạn có thể xem kết quả trong tệp nhật ký nhập được cung cấp qua hộp thoại tiến trình Library Importer , hoặc xem các linh kiện đã nhập trong bảng Components.
Bảng Properties
Các thiết lập trong bảng Properties liên kết với Library Importer cung cấp khả năng kiểm soát nâng cao đối với cấu hình nhập cho thư viện đã chọn (hoặc nhóm thư viện con). Bạn có thể truy cập bảng này từ chế độ Nâng cao của Library Importer bằng cách chọn tùy chọn Properties trong menu của nút
(ở góc dưới bên phải của không gian thiết kế), nhấp vào nút
ở góc trên bên phải của chế độ xem Library Importer, hoặc nhấp vào nút
bên cạnh <All Libraries> hay một mục danh mục cụ thể trong danh sách Source Libraries.
Các thiết lập tùy chọn của bảng được xác định bởi thiết lập mặc định của hệ thống hoặc các thiết lập được chỉ định trong Mẫu linh kiện đang áp dụng. Mẫu này lại được xác định theo loại linh kiện được phát hiện trong thư viện – LED trong ví dụ minh họa ở đây. Người dùng cũng có thể chỉnh sửa các thiết lập để điều chỉnh quy trình nhập theo yêu cầu và khôi phục chúng bằng liên kết Reset to Default (ở góc trên bên phải).
Các phần trong tab General của bảng bao gồm:
-
General:
-
Component Type – loại linh kiện mà trình nhập phát hiện cho thư viện đã chọn và mẫu tương ứng được áp dụng (xem Component Template bên dưới). Ghi đè thiết lập này bằng cách chỉnh sửa trường để tạo một loại linh kiện mới, hoặc chọn một loại khác bằng các tùy chọn trong menu thả xuống (hoặc qua nút – đây là một cách khác để xử lý vấn đề linh kiện chưa được phân loại. Chọn tùy chọn
[LibraryName]để đặt tên loại theo tên thư viện đã chọn. -
Component Template – Mẫu linh kiện trong Workspace sẽ được áp dụng cho các linh kiện được nhập, cùng với thiết lập Loại linh kiện tương ứng. Ghi đè thiết lập này bằng cách chọn một mẫu khác từ các tùy chọn trong menu thả xuống (hoặc qua nút Đặt tùy chọn này thành
[Create new]để tự động tạo mẫu từ các tham số của thư viện nguồn và các thiết lập hiện tại của Library Importer, hoặc chọn [No Template] để không áp dụng hay tạo mẫu.
-
Component Type – loại linh kiện mà trình nhập phát hiện cho thư viện đã chọn và mẫu tương ứng được áp dụng (xem Component Template bên dưới). Ghi đè thiết lập này bằng cách chỉnh sửa trường để tạo một loại linh kiện mới, hoặc chọn một loại khác bằng các tùy chọn trong menu thả xuống (hoặc qua nút – đây là một cách khác để xử lý vấn đề linh kiện chưa được phân loại. Chọn tùy chọn
-
Parameter Mapping – ánh xạ giữa các tham số của thư viện và các tham số trong mẫu linh kiện đang áp dụng (hoặc các thiết lập mặc định khi không có mẫu), cùng với Kiểu giá trị của từng tham số (Văn bản hoặc kiểu có hỗ trợ đơn vị). Sử dụng các tùy chọn trong menu thả xuống của cột Source Library Parameter để thay đổi ánh xạ, và các tùy chọn menu của cột Type để ghi đè thiết lập hiện có do mẫu hoặc giá trị mặc định xác định. Chọn tùy chọn
<Skip>để không đưa một tham số vào. Bất kỳ tham số nào chưa được tự động ghép với tham số của thư viện nguồn (được hệ thống đặt thành<Skip>) đều có thể được ánh xạ thủ công tới một tham số Mẫu phù hợp – ví dụ, có thể chọn tham số nguồnROHSđể ghép với tham sốRoHS Compliantđược xác định trong mẫu của Workspace. Có thể chỉnh sửa tên tham số, cũng như thêm, chỉnh sửa và xóa các bộ tham số. Các tham số cơ bản của linh kiện (ID,Name,Description) có thể được ánh xạ lại, nhưng ngoài thao tác đó thì chỉ có thể đọc. -
Part Choice Mapping – danh sách các tham số mã linh kiện nhà sản xuất hoặc liên kết nhà cung cấp mà trình nhập nhận diện được, sẽ được dùng để tạo các mục Lựa chọn linh kiện cho các linh kiện được nhập. Sử dụng các tùy chọn trong menu thả xuống để xác định lại ánh xạ, hoặc thêm và xóa các bộ ánh xạ. Lưu ý rằng theo mặc định, các tham số mã linh kiện nhà sản xuất và liên kết nhà cung cấp không được đưa vào (bị bỏ qua) trong quá trình nhập. Khi một linh kiện trong thư viện có nhiều liên kết nhà cung cấp, thông tin tham chiếu nhà cung cấp chính (
Supplier 1/Supplier Part Number 1) sẽ được dùng cho các mục trong trường Lựa chọn linh kiện. -
Import Checks – xem hoặc thiết lập cách trình nhập phản hồi bằng lỗi/cảnh báo khi vi phạm các quy tắc xác thực nhập. Sử dụng menu thả xuống Report Mode để thay đổi phản hồi và biểu tượng cho một mục Violation Type. Lưu ý rằng nếu chọn chế độ báo cáo
Fatal Error, quá trình nhập sẽ bị chặn khi phát hiện vi phạm này.
Tab Advanced của bảng cung cấp các thiết lập cho tất cả các mục đối tượng dữ liệu của trình nhập, theo giá trị mặc định của hệ thống hoặc Mẫu linh kiện đang áp dụng. Các mục này bao gồm Mô hình linh kiện, tệp bảng dữ liệu và mọi Mẫu linh kiện được tạo. Ngoại trừ tùy chọn Datasheet (công tắc bật/tắt), các thiết lập cho từng đối tượng nhập bao gồm:
- Folder – thư mục đích trong Workspace dành cho đối tượng được nhập, có thể được chỉnh sửa thủ công (chẳng hạn để tạo thư mục đích mới) hoặc được chọn qua nút duyệt
- Naming Scheme – quy định đặt tên cho đối tượng trong Workspace theo Mẫu linh kiện, hoặc nếu không có mẫu đang hoạt động thì theo quy tắc được đặt cho thư mục đích (hoặc được nhập thủ công). Sử dụng menu thả xuống để chọn trong số các Quy tắc đặt tên có sẵn. Lưu ý rằng việc thay đổi đường dẫn thư mục đích (Folder) có thể đi kèm với thay đổi Quy tắc đặt tên đang áp dụng, tùy theo thiết lập của chính thư mục hoặc của Mẫu linh kiện được áp dụng/liên kết.
- Revision Naming Scheme – cách đặt tên cho các bản sửa đổi trong Workspace của đối tượng, theo mẫu đang áp dụng hoặc được chọn từ các tùy chọn trong menu thả xuống của mục đó. Chỉ những quy tắc được hệ thống bật mới có thể được chọn.
- Lifecycle Definition – Hệ thống vòng đời được sử dụng cho đối tượng, được thiết lập bởi mẫu đang áp dụng hoặc được chọn từ các tùy chọn trong menu thả xuống của mục đó. Chỉ những định nghĩa được hệ thống bật mới có thể được chọn.
Xuất và nhập cấu hình
Library Importer có khả năng xuất một tệp văn bản chi tiết ghi lại cấu hình hiện tại, bao gồm tất cả các thiết lập nhập có thể cấu hình như đường dẫn đích, ánh xạ tham số, quy tắc đặt tên, định nghĩa vòng đời, loại linh kiện đích, v.v.
Tệp cấu hình của Library Importer được lưu bằng lệnh File » Export » Importer Config dưới dạng tệp *.lmcfg và có thể được khôi phục bất cứ lúc nào thông qua tùy chọn menu File » Import » Importer Config .
Khả năng khôi phục cấu hình đặc biệt hữu ích khi cơ sở dữ liệu nguồn hoặc thư viện dựa trên tệp đã được cập nhật và cần nhập những thay đổi đó vào Workspace. Nếu cấu hình đã được xuất khi thư viện được nhập lần đầu, cấu hình được khôi phục (nhập lại) sẽ tái lập chính xác các thiết lập cấu hình đã sử dụng, bảo đảm phương thức truyền dữ liệu nhất quán cho thư viện đó (hoặc các thư viện đó).

























