Tạo Bản Vẽ Bố Trí
Sơ lược
- Tìm hiểu cách tạo và cấu hình tài liệu bản vẽ bố trí bộ dây, bao gồm đơn vị đo, lưới, tùy chọn trang và mẫu.
- Xem cách nhập dữ liệu từ sơ đồ đấu dây vào bản vẽ bố trí và cách nhập lại các cập nhật từ sơ đồ đấu dây về sau.
- Hiểu cách biểu diễn và cấu hình các linh kiện trong bản vẽ bố trí, bao gồm chế độ xem ký hiệu, chế độ xem mô hình vật lý và các thiết lập thuộc tính liên quan.
Sau khi thiết kế bộ dây được thể hiện dưới dạng sơ đồ đấu dây, có thể tạo biểu diễn vật lý của thiết kế dưới dạng bản vẽ bố trí bộ dây (*.LdrDoc). Thêm tài liệu này vào dự án bộ dây từ bảng Projects bằng cách nhấp chuột phải vào mục dự án rồi chọn Add New to Project » Harness Wiring Diagram từ menu ngữ cảnh (hoặc sử dụng lệnh File » New » Harness Layout Drawing từ các menu chính).
Thiết lập tài liệu bản vẽ bố trí bộ dây
Có thể cấu hình các tùy chọn của tài liệu bản vẽ bố trí trong bảng Properties khi không có đối tượng nào được chọn trong không gian thiết kế của tài liệu. Các thiết lập chính bao gồm:
-
Trong vùng General của tab General trên bảng – chọn đơn vị đo áp dụng cho tài liệu và các phần tử đồ họa, đồng thời thiết lập lưới để việc bố trí dễ dàng hơn. Altium Designer cung cấp ba loại lưới: lưới hiển thị để điều hướng, lưới bắt dính để bố trí và khoảng cách bắt dính để hỗ trợ tạo kết nối.
-
Trong vùng Page Options của tab General trên bảng – cấu hình kích thước trang bản vẽ và khung tên hoặc chọn từ các mẫu bản vẽ bố trí bộ dây có sẵn.

Các tab General và Parameters của bảng Properties khi không có đối tượng nào được chọn trong tài liệu bản vẽ bố trí bộ dây
Nhập dữ liệu từ sơ đồ đấu dây
Chọn lệnh Design » Import Wiring Diagram từ các menu chính để nhập dữ liệu thiết kế từ sơ đồ đấu dây. Linh kiện sẽ được đặt trên trang bản vẽ bố trí tại các vị trí tương đối được xác định trong sơ đồ đấu dây. Các điểm kết nối gắn với linh kiện cũng sẽ được đặt cạnh từng linh kiện trên bản vẽ bố trí.

Tài liệu bản vẽ bố trí bộ dây với dữ liệu được nhập từ sơ đồ đấu dây
Làm việc với linh kiện
Ban đầu, mỗi linh kiện được biểu diễn trên bản vẽ bố trí bằng ký hiệu của nó. Có thể cấu hình các thuộc tính của linh kiện đã đặt trong bảng Properties khi linh kiện được chọn trong không gian thiết kế. Bảng Properties dành cho linh kiện bao gồm các tab sau:
-
General – các thuộc tính chung của linh kiện, chẳng hạn như ký hiệu định danh và chú thích, vị trí, cách biểu diễn mô hình, các tham số, v.v.
-
Pins – danh sách các chân của linh kiện.
-
Cavities – chế độ xem chỉ đọc của các hốc cắm được gán cho linh kiện. Chỉ có thể thay đổi việc gán hốc cắm trong sơ đồ đấu dây – tìm hiểu thêm.
-
Associated Parts – cho phép gán các bộ phận bổ sung, chẳng hạn như ống co nhiệt, cho linh kiện.
Cấu hình cách biểu diễn linh kiện
Sử dụng tùy chọn Graphical Symbol / Physical Model trong vùng Model của bảng Properties (trong thẻ General) khi một linh kiện được chọn, bạn có thể chuyển đổi giữa cách biểu diễn bằng ký hiệu (ký hiệu của linh kiện) và hình chiếu mô hình 3D (footprint của linh kiện). Sử dụng các thiết lập khác trong vùng này của bảng để cấu hình cách biểu diễn.
|
Linh kiện được biểu diễn bằng ký hiệu sơ đồ nguyên lý Cùng linh kiện đó được biểu diễn bằng hình chiếu mô hình 3D |
Khi sử dụng cách biểu diễn Physical Model, hãy sử dụng các tùy chọn Style để hiển thị mô hình dưới dạng Solid (không có đường nét) hoặc dưới dạng Wireframe. Sử dụng các tùy chọn trong danh sách thả xuống Side để chọn hướng nhìn mong muốn của mô hình (có các tùy chọn chiếu vuông góc và chiếu đẳng trục). Các hình ảnh bên dưới minh họa một số thiết lập cùng kết quả tương ứng trong không gian thiết kế.
Có thể xoay trực tiếp hình biểu diễn mô hình vật lý trong không gian thiết kế bằng cách dùng chuột kéo tay nắm xoay ở góc dưới bên phải của hình biểu diễn; trường Rotation sẽ tự động cập nhật (góc xoay thay đổi theo từng bước 1 độ). Bạn cũng có thể giữ phím Alt để giới hạn góc xoay theo từng bước 45 độ. Để tiện theo dõi, khi xoay hình biểu diễn bằng chuột, góc hiện tại được hiển thị trong Status Bar.
Xác định cách bố trí vật lý trên bản vẽ bố trí bộ dây
Tất cả các kết nối vật lý trong bộ dây đều được định nghĩa dưới dạng bó dây (ngay cả khi một bó chỉ chứa một dây). Mỗi bó dây phải bắt đầu và kết thúc tại một điểm kết nối. Khi nhập dữ liệu thiết kế bộ dây lần đầu (như mô tả ở trên), một điểm kết nối sẽ tự động được đặt bên cạnh mỗi linh kiện và được liên kết với linh kiện đó cùng tất cả các chân của nó. Nếu cấu trúc vật lý của thiết kế yêu cầu, bạn có thể đặt thêm các điểm kết nối mới và cấu hình những đối tượng được gán cho một điểm kết nối.
Làm việc với các điểm kết nối
Để đặt một điểm kết nối mới, sử dụng lệnh Place » Connection Point từ các menu chính. Các điểm kết nối được hiển thị trong không gian thiết kế như bên dưới.
Các thuộc tính của một điểm kết nối đã đặt (vị trí, hình thức hiển thị, v.v.) có thể được cấu hình trong bảng Properties khi điểm kết nối được chọn trong không gian thiết kế.

Bảng Properties khi một điểm kết nối được chọn
Gán đối tượng cho điểm kết nối
Các đối tượng được gán cho một điểm kết nối có thể được cấu hình theo nhu cầu và ý đồ thiết kế của bạn. Có thể gán một hoặc nhiều đối tượng (linh kiện, mối nối/điểm rẽ nhánh, đối tượng 'không kết nối' và lớp bọc chống nhiễu có kết nối) cho một điểm kết nối bằng hộp thoại Add Assigned Objects, được mở bằng cách nhấp vào nút
trong vùng Assigned Objects của bảng Properties .
Khi một linh kiện được gán cho một điểm kết nối, một đường gạch chấm sẽ hiển thị trong không gian thiết kế giữa linh kiện và điểm kết nối, như minh họa bên dưới. Trong Properties, bạn có thể chọn những chân linh kiện được gán. Nhấp vào ô trong cột Pins của bảng ở vùng Assigned Objects để mở danh sách thả xuống và chọn các chân linh kiện cần thiết.
Làm việc với các bó dây
Để đặt một bó dây mới, sử dụng lệnh Place » Harness Bundle từ các menu chính (phím tắt: Shift+B).
Sau khi chọn lệnh, nhấp vào một điểm kết nối (dấu chữ thập màu đỏ xuất hiện tại con trỏ khi con trỏ nằm trên điểm bắt dính của điểm kết nối) để đặt điểm bắt đầu của bó dây. Di chuyển con trỏ và nhấp để cố định một chuỗi các đỉnh xác định hình dạng của bó dây. Sau khi đặt đỉnh cuối cùng tại điểm bắt dính của một điểm kết nối khác, nhấp chuột phải để hoàn tất việc đặt.
Theo mặc định, bó dây được đặt bằng chế độ đặt Any Angle. Khi đặt bó dây, nhấn Shift+Spacebar để lần lượt chuyển qua các chế độ đặt. Chế độ này xác định cách tạo góc khi đặt bó dây và các góc mà bó dây có thể được đặt. Khi ở chế độ 90 Degree hoặc 45 Degree (các chế độ trực giao thực sự), nhấn Spacebar để chuyển đổi giữa chế độ phụ bắt đầu và kết thúc. Chế độ và chế độ phụ hiện tại được hiển thị trên Thanh trạng thái.

Ví dụ về một bó dây được đặt giữa các điểm kết nối CP1 và CP_P2.
Sau khi được đặt và chọn, bạn có thể kéo các đỉnh của bó dây để thay đổi góc giữa hai đoạn liền kề.
Có thể cấu hình các thuộc tính của bó dây đã đặt (vị trí, cách hiển thị, v.v.) trong bảng Properties khi bó dây được chọn trong không gian thiết kế.

Bảng Properties khi một bó dây được chọn
Mỗi bó dây sẽ tự động chứa các đối tượng (dây dẫn và/hoặc cáp) theo thông tin kết nối được xác định trong sơ đồ đấu dây. Các đối tượng này được liệt kê trong vùng Bundle Objects của bảng Properties khi bó dây được chọn. Nhấp vào một đối tượng trong danh sách này để tô sáng tất cả các bó dây mà đối tượng đã chọn đi qua.
Sử dụng trường Length trong vùng Properties của bảng để xác định chiều dài của bó dây đã chọn. Chiều dài của các dây dẫn và cáp đi qua các bó dây được tính dựa trên giá trị Length của các bó dây đó. Giá trị chiều dài dây dẫn/cáp được tính toán sẽ hiển thị trong cột Length Value của bảng dữ liệu trong vùng Bundle Objects của bảng.
Thêm hình chiếu đoạn dây
Hình chiếu đoạn dây hiển thị các dây dẫn nằm bên trong đoạn, tức là các dây đơn, các cặp dây xoắn và các dây thuộc cáp. Nhờ đó, bạn có thể thấy chính xác cách các dây dẫn được bố trí cùng nhau về mặt vật lý bên trong đoạn bó dây. Mỗi dây dẫn được gắn nhãn và hiển thị bằng màu đã xác định cho dây đó, đồng thời có độ dày dựa trên giá trị tham số Thickness của dây (được xác định trên sơ đồ đấu dây (*.WirDoc)). Bạn có thể đặt hình chiếu của một đoạn bó dây đã đặt vào bản vẽ bố trí (*.LdrDoc) bằng lệnh Add Segment View trong vùng Model của bảng Properties . Sau đó, vùng Segment View sẽ hiển thị danh sách thả xuống để bạn chọn mức Zoom cho hình chiếu vừa thêm. Không gian thiết kế sẽ phóng to vào hình chiếu như minh họa trong phần trình chiếu ví dụ bên dưới. Để xóa hình chiếu đoạn dây, hãy sử dụng lệnh Delete trong vùng Segment View. Nhấp để chọn hình chiếu và di chuyển đến vị trí mong muốn trong không gian thiết kế.
Thêm điểm ngắt
Có thể đặt điểm ngắt trên bó dây để cho biết bó dây không được vẽ theo tỷ lệ (NTS). Bó dây sẽ hiển thị ký hiệu ngắt ở giữa đoạn dài nhất như trong hình đầu tiên bên dưới, và phần thuộc tính sẽ hiển thị Drawn Length. Để đặt điểm ngắt, hãy bật tùy chọn Add Break Symbol trong vùng Properties của thuộc tính bó dây. Lớp bọc bao quanh bó dây có điểm ngắt cũng sẽ hiển thị chỗ ngắt tại cùng vị trí. Nếu lớp bọc kết thúc tại điểm ngắt của bó dây, lớp bọc sẽ được vẽ dài hơn một chút, như trong hình thứ hai.
Các bó dây chứa dây dẫn từ cáp được tách nhánh
Tất cả các bó dây chứa dây dẫn từ một cáp bộ dây được tách nhánh sẽ được tô sáng trên bản vẽ bố trí khi cáp được chọn trong vùng Bundle Objects của bảng Properties. Chiều dài của cáp được tách nhánh được xác định theo chiều dài của dây dẫn dài nhất.
|
Cáp C1 được tách nhánh đến các đầu nối khác nhau. Khi nhấp vào mục cáp trong vùng Bundle Objects của bảng Properties cho bó dây đã chọn, tất cả các bó dây chứa dây dẫn từ C1 sẽ được tô sáng. Chiều dài của cáp được xác định theo chiều dài của dây dẫn dài nhất (trong trường hợp này, các dây dẫn đi qua bó B1 và B3 là dài nhất). |
Các đối tượng không kết nối bên trong cáp
Nếu sơ đồ đấu dây có các đối tượng 'không kết nối' bên trong cáp, bạn không cần thêm các đối tượng này vào các điểm kết nối trên bản vẽ bố trí. Bó dây sẽ nhận diện chính xác các đối tượng của cáp. Xem ví dụ trong các hình bên dưới.
|
Một cáp trong tài liệu sơ đồ đấu dây chứa các dây dẫn không được kết nối (W4 và W5). Các đối tượng 'không kết nối' không được gán cho các điểm kết nối trên bản vẽ bố trí. Tuy nhiên, bó dây vẫn nhận diện chính xác tất cả các đối tượng của cáp (bao gồm dây dẫn W4 và W5). |
Dây nối tắt
Dây nối tắt có thể được hiển thị trong bản vẽ bố trí. Khi sơ đồ đấu dây của dự án bộ dây có một dây nối các khoang chân của cùng một đầu nối bộ dây, dây này được hiển thị trong bảng Properties dưới dạng một đối tượng thuộc bó dây tương ứng với đầu nối bộ dây trên bản vẽ bố trí của dự án khi bó dây được chọn trong không gian thiết kế.
Gán lại các đối tượng trong bó dây
Bạn có thể gán lại các đối tượng trong bó dây trên bản vẽ bố trí, trong trường hợp một dây có thể đi theo nhiều đường giữa đầu nối nguồn và đầu nối đích. Theo mặc định, dây đó sẽ tự động được gán cho đường đi qua bó dây ngắn nhất, nhưng bạn có thể thay đổi cách gán này. Điều khiển Assign Objects to Bundle xuất hiện ở cuối phần Bundle Objects của bảng Properties (khi bó dây được chọn trong không gian thiết kế), và chỉ xuất hiện khi có đường đi thay thế. Hộp thoại Assign Objects to Bundle mở ra, cho phép bạn chọn các đối tượng (dây/cáp) để chuyển giữa các bó dây phù hợp và hợp lệ.
Bọc các bó dây
Có thể đặt một đối tượng lớp bọc bộ dây (Place » Harness Covering) lên một bó dây. Chiều dài lớp bọc có thể được điều chỉnh trực tiếp bằng thao tác đồ họa trong không gian thiết kế trong hoặc sau khi đặt.
Sau khi chọn lệnh đặt lớp bọc bộ dây, một chấm màu cam sẽ xuất hiện trong không gian thiết kế khi con trỏ nằm trên một bó dây, cho biết có thể đặt lớp bọc bộ dây tại đó (chấm màu xám cho biết không thể đặt lớp bọc bộ dây tại vị trí cụ thể đó). Nhấp vào vị trí bạn muốn lớp bọc bắt đầu, sau đó di chuyển con trỏ dọc theo bó dây đến điểm bạn muốn lớp bọc kết thúc, rồi nhấp lại. Các lớp bọc bộ dây có thể chồng lên nhau, như minh họa trong video bên dưới. Bạn cũng có thể đặt/kéo dài lớp bọc bộ dây qua một điểm nối (điểm kết nối trong bản vẽ bố trí nơi hai hoặc nhiều bó dây gặp nhau). Nhờ đó, không cần sử dụng các lớp bọc bộ dây riêng biệt giữa các điểm nối trong một đoạn có nhiều đầu nối.
Điểm bắt đầu của lớp bọc được xác định là điểm ngoài cùng bên trái, trên cùng của đường đi, và đường đi chỉ bao gồm các bó dây mà lớp bọc nằm trên.
Có thể cấu hình các thuộc tính của lớp bọc bộ dây đã đặt trong bảng Properties khi lớp bọc bộ dây được chọn trong không gian thiết kế.

Bảng Properties khi một lớp bọc bộ dây được chọn
Bạn có thể xác định kích thước của đối tượng lớp bọc bộ dây tương ứng với kích thước của bó dây mà nó bọc (Line Width của bó dây) bằng danh sách thả xuống Size trong bảng Properties. Cuộn qua các hình ảnh bên dưới để xem ví dụ về các lớp bọc bộ dây có kích thước khác nhau với nhiều kích thước bó dây khác nhau.
Thêm nhãn bố trí
Có thể đặt các nhãn vật lý vào bản vẽ bố trí (Place » Layout Label).
Có thể cấu hình các thuộc tính của nhãn bố trí đã đặt (ký hiệu định danh, văn bản, hình thức hiển thị, v.v.) trong bảng Properties khi nhãn bố trí được chọn trong không gian thiết kế.

Bảng Properties khi một nhãn bố trí được chọn
Khi xác định văn bản của nhãn trong trường Text, hãy sử dụng Ctrl+Enter hoặc Shift+Enter để thêm một dòng văn bản mới. Bật Show only first line để chỉ hiển thị dòng đầu tiên của trường Text trong không gian thiết kế. Bạn cũng có thể căn chỉnh văn bản nhãn bố trí theo nhu cầu bằng các điều khiển Alignment.
Thêm nhãn bố trí vào bó dây
Nhãn bố trí tự động tuân theo hướng của bó dây mà chúng được gắn vào. Nhãn bố trí sẽ “bám” vào bó dây để đi theo hướng và đường đi của bó dây. Trong hoặc sau khi đặt nhãn bố trí, nhấn Spacebar để xoay nhãn mỗi lần 90 độ hoặc cập nhật giá trị Rotation trong bảng Properties .
Nếu bạn không muốn nhãn đi theo hướng của bó dây (tức là không “bám” vào bó dây), hãy nhấn phím Alt trong khi đặt để đặt nhãn tại vị trí mong muốn, như minh họa trong video bên dưới.
Khi di chuyển bó dây có nhãn đang “bám” vào nó, vị trí nhãn bố trí sẽ được tính toán lại và di chuyển theo bó dây.
Cập nhật đối tượng bản vẽ bố trí từ thư viện
Các đối tượng sau có thể được cập nhật từ thư viện Workspace nguồn:
-
Linh kiện bộ dây điện
-
Các bộ phận liên quan đến linh kiện bộ dây điện
-
Các bộ phận liên quan đến điểm kết nối
-
Lớp bọc bộ dây điện
-
Nhãn bố trí
Khi một đối tượng được chọn, bạn có thể tìm thông tin về linh kiện Workspace được liên kết trong bảng Properties (ví dụ: thẻ Associated Parts cho các bộ phận liên quan của một linh kiện bộ dây điện hoặc vùng General cho nhãn bố trí).
Nếu có phiên bản sửa đổi mới hơn của linh kiện Workspace, mục trạng thái phiên bản sửa đổi sẽ phản ánh điều này bằng văn bản Out of date. Ở cấp độ từng đối tượng, có thể cập nhật liên kết đến phiên bản sửa đổi mới nhất của linh kiện Workspace bằng cách nhấp vào nút
.
Ví dụ về chỉ báo phiên bản sửa đổi đã lỗi thời của linh kiện bộ dây điện
Tính năng Update from Libraries (Tools » Update from Libraries) cũng có thể được dùng để cập nhật các linh kiện đã lỗi thời được liên kết với những đối tượng liệt kê ở trên. Lưu ý rằng để một đối tượng được đưa vào quá trình cập nhật bằng tính năng Update from Libraries, linh kiện được gán cho đối tượng đó phải có liên kết đến một ký hiệu sơ đồ nguyên lý.
Đánh số định danh cho các đối tượng trong bản vẽ bố trí bộ dây điện
Sử dụng các lệnh trong menu Tools » Annotation để đánh số định danh cho các đối tượng sau trong tài liệu bản vẽ bố trí bộ dây điện:
-
Linh kiện bộ dây điện
-
Điểm kết nối
-
Bó dây điện
-
Lớp bọc bộ dây điện
-
Nhãn bố trí
Việc đánh số định danh cho các đối tượng trong tài liệu bản vẽ bố trí bộ dây điện tương tự như đánh số định danh cho các linh kiện trong tài liệu sơ đồ nguyên lý (*.SchDoc) của dự án thiết kế PCB. Sử dụng các liên kết sau để tìm hiểu thêm về các lệnh đánh số định danh có sẵn cho tài liệu bản vẽ bố trí bộ dây điện:
-
Đặt lại các ký hiệu định danh trùng lặp trong bản vẽ bố trí bộ dây điện
-
Đánh số định danh cho bản vẽ bố trí bộ dây điện ở chế độ im lặng
Truy vấn chéo giữa sơ đồ đấu dây và bản vẽ bố trí
Hỗ trợ truy vấn chéo giữa sơ đồ đấu dây và bản vẽ bố trí của dự án bộ dây điện. Có thể truy cập lệnh Cross Probe từ menu chính Tools và menu chuột phải trong không gian thiết kế.
Có thể thực hiện truy vấn chéo:
-
Giữa các linh kiện trong sơ đồ đấu dây và bản vẽ bố trí.
-
Từ một dây trong sơ đồ đấu dây đến các bó dây mà dây này đi qua trong bản vẽ bố trí.
-
Từ một bó dây trong bản vẽ bố trí đến các dây đi qua bó dây này trong sơ đồ đấu dây.
|
Định vị chéo từ một linh kiện trong sơ đồ đấu dây đến linh kiện tương ứng trong bản vẽ bố trí. Định vị chéo từ một linh kiện trong bản vẽ bố trí đến linh kiện tương ứng trong sơ đồ đấu dây. Định vị chéo từ một dây dẫn trong sơ đồ đấu dây đến các bó dây tương ứng trong bản vẽ bố trí. Định vị chéo từ một bó dây trong bản vẽ bố trí đến các dây dẫn tương ứng trong sơ đồ đấu dây. |
).






).
).
).
).
).
).




).










)
).
).



